Server Environments

The following sections describe the supported environments (such as operating systems, application servers, and RDBMS) for hosting the CA Identity Manager server components.
cim143
The following sections describe the supported environments (such as operating systems, application servers, and RDBMS) for hosting the CA Identity Manager server components. 
This version of the CA Identity Manager Server requires that you install the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files for your selected JDK. Download and install the corresponding files for your version of Java.
 
Supported Server Operating Systems
 
Operating System
 
 
Release
 
 
Version/ Level
 
Microsoft Windows Server
2012, 2012 R2, 2016, 2019
  • 64-bit
  • Support for Standard Edition and Essentials Edition
  • Latest SP assumed
  • Supported on all the application servers that the product supports
Red Hat Enterprise Linux
6.x, 7.x, 8.x
  • 64-bit
  • Supported on all the application servers that the product supports
 
Note:
 
When a third-party product reaches the end of its primary or mainstream support, we will no longer provide support for that third-party product. Third-party products under extended vendor support are not supported by us.
 
Supported Virtualization Platforms
CA Identity Manager supports all virtualization technologies as defined in the CA Virtualization Policy.
For more details, see CA Support Statement for Virtualization 
Supported 64-bit Application Servers
 
Application Server
 
 
Release
 
 
JDK/JRE
 
 
Comments
 
JBoss/WildFly
JBoss 6.4 EAP or later 6.x releases
WildFly 8.2 or later 8.x releases
  • Oracle Java 8 (1.8.x)
  • AdoptOpenJDK 1.8.0_212 and later 1.8.x versions
  • Important! 
     
    Identity Suite has shifted the primary support from Oracle JDK to AdoptOpenJDK, a popular free version of Java that derives its source from OpenJDK. Existing customers with valid licenses from Oracle may continue to run our products using Oracle JDK. However, in such cases, the customer is responsible for obtaining support from Oracle to address any future Java security and vulnerability issues that may arise.
  • CA Identity Manager installer does not work with AdoptOpenJDK. Post installation of CA Identity Manager, you must change the Java if you wish to use AdoptOpenJDK.
  • Unicast and Multicast are supported with JBoss
  • July 2015 Critical Patch Update or later is required for Oracle JDK/JRE 1.8.x
  • Unicast with Replication configuration is not supported for WildFly 8.2.x cluster due to a known bug with HornetQ in WildFly 8.2.x. For more information, search for the Knowledge Base article with the number HQ222116 at http://issues.jboss.org.
  • Domain mode is not supported
  • For cluster support, one computer per node is supported. Use default ports.Multi Node deployments require a true cluster (silo approach is not supported).
Oracle WebLogic
12c R2 (12.2.1.x)
Oracle Java 8 (1.8.x)
  • The minor version of JDK 1.8.x must be 131 or higher.
IBM WebSphere
8.5.5.11 and later
IBM Java 8 (1.8.x)
  • Fix pack 8.5.5.9-WS-WAS-IFPI73197
  • WebSphere 8.5.x supports only JSF/MyFaces 1.2
    (JSF/MyFaces 2 is not currently supported)
Starting from release 1.8.0_181, Java has enabled endpoint identification on LDAPS (secure LDAP over TLS) connections. This will result in the LDAP connection failure when the LDAP endpoint does not have a certificate matching the name of the endpoint. To avoid LDAP connection failure, apply the workaround mentioned at Java Upgrade LDAP Issue
Supported Repositories
Supported Identity Manager User Store (Formerly called Corporate Directory)
 
The following list describes the platforms certified for maintaining user information as well as other organizational information (such as groups). Please note that other LDAP v3 servers and RDBMS are supported for this repository as long as they are verified as part of a CA Partner program. Also note that any LDAP server must be compliant to the X.521 object definition standards (see http://www.itu.int/ITU-T/recommendations/rec.aspx?rec=X.521).
 
Directory 
 
 
User Store
 
 
Provisioning Store
 
 
Runtime Store
 
# CA Directory r12.x, 14.0
Yes
Yes
No
 
# CA Identity Manager 14.3 supports only CA Directory 64-bit.
 
 
Supported Runtime Databases
 
The following list describes the platforms certified and supported for the CA Identity Manager runtime database. A runtime database is a required repository for storing environment configuration information, workflow configuration and status, task history information, reporting snapshot data and (if configured) audit records.
Database 
/ Directory
 
 
User Store
 
 
Runtime Store
 
Oracle Directory Server Enterprise Edition 11.x, Oracle Unified Directory 11g r2
Yes
No
Microsoft Active Directory 2012 R2 (including Lightweight Directory Services), 2016
Yes
No
IBM Directory Server 6.x
Yes
No
Novell eDirectory 8.8.x
Yes
No
Oracle OID 11g r1
Yes
No
Red Hat Directory Server 9.x, 10.x
Yes
No
Open LDAP 2.4
Yes
No
Oracle Database
  • 11g r2
  • 12c R1 (RAC + Container DB multi tenancy)
  • 12c R2 (RAC + Container DB multi tenancy)
  • 18c (RAC + Container DB multi tenancy)
Yes
Yes
* Microsoft SQL Server 2012, 2014, 2016, 2017
Yes
Yes
 
Note: 
CA Identity Manager 14.3 does not support a combined user store and provisioning directory for new as well as upgraded environments. 
 
* Includes support for all service packs / releases on this version
 
Additional CA Interoperability Matrix 
The following matrix lists CA Identity Manager additional interoperability with other products. Please note that additional products are supported as target endpoints as well as repositories and are listed in the appropriate tables in this document.
 
CA Product
 
 
Release / Product
 
 
Comments / Supported Versions
 
CA Single Sign-On
r12.5, r12.51, r12.52x, r12.6.01, r12.7, and 12.8
  • Please refer to the CA Single Sign-On support matrix for supported policy server stores.
  • The latest Service Pack and Cumulative Release is assumed.
  • It is not recommended to place CA Single Sign-On and CA Identity Manager on the same system
CA Identity Governance
r12.6 (and later), r14.x
  • The latest Service Pack and Cumulative Release are assumed.
CA Normalized Integration Management for Service Management
3.2
  • ServiceAide - NorthStar
  • SAP Solution Manager ITSM - 7.3 SP3
  • CA Service Desk Manager - 14.1,
     
    17.1
  • ServiceNow - Jakarta, Kingston
  • BMC Remedy - 8.1, 9.1
  • HP ServiceManager - 9.32, 9.41
  • Salesforce Service Cloud - Winter 2019
The .x in the release numbers denote the actively supported releases.