Platform Support and Requirements

The following table summarizes the platforms that  components support.
catpa04304
The following table summarizes the platforms that 
CA Process Automation
 components support.
The listed operating system and software support can change over time. See support.ca.com for the latest information about 
CA Process Automation
 version support.
Verify that your operating system has the latest Windows service packs or Linux updates installed.
 
System Requirements
 
CA Process Automation
Component
 
Supported Operating Systems
 
Supported Operating System Versions
 
Supported Java Versions
 
Other Requirements
 
Orchestrators
Windows
Microsoft Windows Server 2012 x64
Microsoft Windows Server 2012 R2 x64 
Microsoft Windows Server 2016 x64
Microsoft Windows Server 2019 x64
Oracle Java Development Kit (JDK) 1.8.162 and above.
Linux
Red Hat Enterprise Linux 6.9
Red Hat Enterprise Linux 7.4
Oracle Linux 6.9
Oracle Linux 7.4
Centos Linux 6.9
Centos Linux 7.4
Agents
Windows
Windows Server 2008 R2
Windows Server 2012
Windows Server 2012 R2
Windows Server 2016
Windows Server 2019
Oracle Java Development Kit (JDK) 1.7.71 or above.
Oracle Java Development Kit (JDK) 1.8.x.
For proxy touchpoints and host groups, each remote host must run an SSHv2 server.
Verify that an agent installed on a UNIX or Linux computer includes ksh under the /bin/ksh directory. If the ksh file is not installed, install it under /bin/ksh. If the ksh file is installed in a different directory on the agent computer, create a symbolic link (/bin/ksh) to reference the installed ksh file.
Linux
Red Hat Enterprise Linux 6.9
Red Hat Enterprise Linux 7.4
Oracle Linux 6.9
Oracle Linux 7.4
Centos Linux 6.9
Centos Linux 7.4
Solaris SPARC
Solaris 10 (64 bit)
Solaris 11 (64 bit)
Solaris 11.3 (64 bit)
HP Integrity
HP-UX 11i v2
HP-UX 11i v3
HP JAVA 7 (1.7.0.13) Runtime Environment (JRE) and above
HP JAVA 8 (1.8.0.1) Runtime Environment (JRE) and above
HP 9000 PA-RISC
HP-UX 11i v2
HP-UX 11i v3
IBM AIX
AIX 6
AIX 7.1
AIX 7.2
IBM JAVA 7 (1.7.0) Runtime Environment (JRE)
IBM JAVA 8 (1.8.0) Runtime Environment (JRE)
Solution Suite
Windows
Microsoft Windows Server 2012 R2 
Microsoft Windows Server 2016 
Oracle Java Runtime Environment (JRE) 1.8.x
 
System Requirements for Databases
 
CA Process Automation
 Component
 
Supported Operating Systems
 
Supported Operating System Versions
 
Other Requirements
 
Databases
See the vendor documentation for supported operating systems.
One of the following relations databases:
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2016
  • Microsoft SQL Server 2017
  • Microsoft SQL Server Cluster
  • Microsoft SQL Server Cluster AOAG 2016
  • Oracle Database 11g Release 2
  • Oracle Database 12c Release 1 (RAC or Standalone)
  • Oracle Database 12c Release 2 (RAC or Standalone)
  • MySQL5.7 latest update
  • MySQL8.0.15
To connect to the pluggable database of Oracle Database 12c Release 1 (RAC or a standalone server) or Oracle Database 12c Release 2 (RAC or Standalone), it is mandatory to provide the database connection string details. For more information, see the 
Connect to Oracle 12c (RAC or a Standalone Server)
 section in Prepare an Oracle Database.
See Database Prerequisites for detailed requirements.
For Oracle, CA Technologies recommend 11.2.0.2 or later.
 
System Requirements for Directory Server
 
CA Process Automation
Component
 
Supported Operating Systems
 
Supported Operating System Versions
 
Directory Server
See 
CA Embedded Entitlements Manager
(CA EEM) documentation.
 
CA Embedded Entitlements Manager
 CA EEM r12.51 CR04, CA EEM r12.51 CR05, CA EEM r12.6, CA EEM r12.6 CR01