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Introducing Inventory for
Network Devices

This chapter includes the following topics:

■ About Inventory for Network Devices

■ About licensing Inventory for Network Devices

■ Components of Inventory for Network Devices

■ Where to get more information

About Inventory for Network Devices

Note: Current documentation applies to the most recent version of the product.

Inventory for Network Devices gathers inventory data from discovered devices in your network.
This inventory is gathered from the devices that are not managed through the Symantec
Management Agent. Because a management agent is not required, this inventory is considered
an agentless inventory.

Agentless inventory gathers inventory on the devices that are already discovered and exist
as resources in the Symantec Management Platform's Configuration Management Database
(CMDB).

Agentless inventory tasks run on discovered devices and report the data to Notification Server.
The discovery data is stored in the CMDB. You can configure the automated tasks that are
scheduled to run at regular intervals to keep your inventory data current.

You can gather inventory on the following types of devices:

■ Cluster
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■ Computer

■ Computer: Virtual machine

■ Infrastructure device

■ IP phone

■ KVM device

■ Network-attached storage

■ Network backup device

■ Network printer

■ Out-of-band management device

■ Out-of-band management device: Chassis management controller

■ Physical rack

■ Physical enclosure

■ Physical bay

See “Gathering agentless inventory” on page 12.

Inventory for Network Devices gathers inventory only on SNMP-enabled network devices. You
can determine the type of inventory that is gathered through SNMP data mapping tables. The
tables identify the data fields that you want to collect and apply the settings to selected device
types.

See “About SNMP data mapping” on page 18.

Starting from 8.1 RU2, Inventory for Network Devices supports SNMPv3. With the SNMPv3
support, you can gather agentless inventory on SNMPv3-enabled Cisco switches and the
devices connected to them (for example, VMs, Desktops, etc.). Note that SNMPv3 support is
limited to Cisco switches only.

Before you gather inventory on network devices, you must collect the data about the
SNMP-enabled devices on your network. Use the Network Discovery task to discover your
network devices. Make sure that the connection profile of the Network Discovery task has
the SNMP turned on.

For more information, see topics about Network Discovery in the IT Management Suite
Administration Guide.

About licensing Inventory for Network Devices
Each Symantec product includes a trial license that is installed by default. You can register
and obtain an extended trial license through the Symantec website at the following URL:
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http://www.symantec.com/business/products/activating/

You can also purchase a full product license.

Use the Symantec Installation Manager to install licenses.

For more information about applying licenses to a solution, see the IT Management Suite
Administration Guide.

See “About Inventory for Network Devices” on page 6.

Components of Inventory for Network Devices
Inventory for Network Devices runs on the Symantec Management Platform and uses the
components of the platform.

See “About Inventory for Network Devices” on page 6.

Inventory for Network Devices includes the following components:

Table 1-1 Components of Inventory for Network Devices

DescriptionComponent

You create and schedule tasks to collect inventory
on discovered devices.

See “Gathering agentless inventory” on page 12.

Inventory for Network Devices tasks (also known
as agentless inventory tasks)

You can use the wizard to easily create agentless
inventory tasks.

See “Creating agentless inventory tasks using the
wizard” on page 13.

Agentless inventory wizard

This portal page provides links to the commonly
used tasks and a summary of inventory data.

Agentless Inventory Home page

These tables define the type of inventory data that
is gathered.

See “About SNMP data mapping” on page 18.

SNMP data mapping tables

Where to get more information
Use the following documentation resources to learn about and use this product.
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Table 1-2 Documentation resources

LocationDescriptionDocument

IT Management Suite (ITMS) 8.5 Documentation■ Information about new
features and
important issues.

■ Information about how
to use this product,
including detailed
technical information
and instructions for
performing common
tasks.

■ Release Notes
■ User Guides

The Documentation Library, which is available in the
Symantec Management Console on the Help menu.

Context-sensitive help is available for most screens in the
Symantec Management Console.

You can open context-sensitive help in the following ways:

■ Click the page and then press the F1 key.
■ Use the Context command, which is available in the

Symantec Management Console on the Help menu.

Information about how to
use this product,
including detailed
technical information and
instructions for
performing common
tasks.

Help is available at the
solution level and at the
suite level.

This information is
available in HTML help
format.

Help

In addition to the product documentation, you can use the following resources to learn about
Symantec products.

Table 1-3 Symantec product information resources

LocationDescriptionResource

Knowledge BaseArticles, incidents, and
issues about Symantec
products.

SymWISE Support
Knowledgebase

Unified Help SystemAll available IT
Management Suite and
solution guides are
accessible from this
Symantec Unified Help
System that is launched
on cloud.

Cloud Unified Help System
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Table 1-3 Symantec product information resources (continued)

LocationDescriptionResource

The links to various groups on Connect are as follows:

■ Deployment and Imaging
■ Discovery and Inventory
■ ITMS Administrator
■ Mac Management
■ Monitor Solution and Server Health
■ Patch Management
■ Reporting
■ ServiceDesk and Workflow
■ Software Management
■ Server Management
■ Workspace Virtualization and Streaming

An online resource that
contains forums, articles,
blogs, downloads,
events, videos, groups,
and ideas for users of
Symantec products.

Symantec Connect
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Gathering agentless
inventory

This chapter includes the following topics:

■ About gathering agentless inventory

■ Gathering agentless inventory

■ Creating agentless inventory tasks using the wizard

■ Manually creating, scheduling, modifying, and stopping agentless inventory tasks

■ Viewing agentless inventory results

About gathering agentless inventory
Inventory for Network Devices lets you gather agentless inventory data from the discovered
SNMP network devices such as computers, network printers, network-attached storage devices,
and network backup devices. To gather inventory, agentless tasks run on discovered devices
and report the data to Notification Server. The data is stored in the Configuration Management
Database (CMDB). You can configure the automated tasks that are scheduled to run at regular
intervals to keep your inventory data current.

See “About Inventory for Network Devices” on page 6.

See “Gathering agentless inventory” on page 12.

When you configure agentless inventory tasks, you specify the following:

■ Which devices to inventory

■ When to run the task

You can configure multiple tasks to meet your needs.
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You can create and configure agentless inventory tasks in the following ways:

The wizard guides you through the creation and configuration of agentless
inventory tasks. You can later edit the advanced settings and schedules
of a task on the task page.

See “Creating agentless inventory tasks using the wizard” on page 13.

Creating a task with
Agentless Inventory wizard.

You can manually create tasks from the Agentless Inventory Tasks
Web Part. This option lets you configure more advanced settings and
schedules.

See “Manually creating, scheduling, modifying, and stopping agentless
inventory tasks” on page 15.

Creating a task manually

You can only gather inventory from the SNMP-enabled devices on your network that are
already discovered. Run the Network Discovery task to discover your network devices and
create resources for them in the CMDB. Make sure that the connection profile of the Network
Discovery task has the SNMP turned on.

For more information, see topics about Network Discovery in the IT Management Suite
Administration Guide.

Agentless inventory tasks use connection profiles to manage the protocols that are used to
communicate with network devices. Connection profiles are components of the Symantec
Management Platform. When a device is discovered, a resource for that device is created in
the CMDB. The resource keeps a record of the protocols that were used to communicate with
the device. When you use agentless inventory tasks, you do not specify a connection profile
or protocols. Agentless inventory tasks automatically use the same protocols that were enabled
when the device was discovered.

For more information, see the topics about resource discovery and using connection profiles
in the IT Management Suite Administration Guide.

Gathering agentless inventory
You can gather agentless inventory data from discovered SNMP-enabled network devices
and enter that data in the Configuration Management Database (CMDB).

See “About gathering agentless inventory” on page 11.

The process for gathering agentless inventory from network devices is as follows:
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Table 2-1 Process for gathering inventory of network devices

DescriptionActionStep

You can only gather inventory of the devices that are
already discovered.

For more information, see topics about Network
Discovery in the IT Management Suite Administration
Guide.

Discover network devices.Step 1

SNMP data mapping tables identify the data fields
that you want to gather and apply the settings to the
selected device types.

See “Using SNMP data mapping tables” on page 19.

Use SNMP data mapping tables to
define how to map SNMP devices
to the data that you want to gather.

Step 2

You create and schedule tasks to collect inventory.
You can create the tasks either with inventory wizard
or manually.

See “Creating agentless inventory tasks using the
wizard” on page 13.

See “Manually creating, scheduling, modifying, and
stopping agentless inventory tasks” on page 15.

Create agentless inventory tasks.Step 3

You can view the gathered inventory data in the
Resource Manager or on the Agentless Inventory
page.

See “Viewing agentless inventory results”
on page 16.

View agentless inventory data.Step 4

Creating agentless inventory tasks using the wizard
The wizard guides you through the process of creating agentless inventory tasks and configuring
basic settings. You can later configure the advanced settings and schedule the tasks on the
task page.

This task is a step in the process of gathering agentless inventory from network devices.

See “Gathering agentless inventory” on page 12.

Before you perform theis step, ensure that you have mapped the SNMP devices to the data
that you want to gather.

See “Using SNMP data mapping tables” on page 19.
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To create agentless inventory tasks for network devices using the inventory wizard

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 In the Agentless Inventory Quick Start Web Part, click Run inventory wizard.

3 In the Agentless inventory task creation wizard, on the Choose devices to inventory
page, do the following, and then click Next:

■ Select Choose devices, and then, in the drop-down list, click the group of target
devices that you want to gather inventory from.
For more information, see topics about using filters and organizational views in the IT
Management Suite Administration Guide.

■ Under Include Device Types, check the types of devices that you want to gather
inventory from.

■ (Optional) To gather inventory from an individual device, in the wizard, select Individual
device, and then, in the drop-down list, click the device from which you want to gather
inventory.
This list includes all SNMP-enabled devices that have been previously discovered and
have resources in the Configuration Management Database (CMDB).

4 On the Inventory network task name page, type a name for the task, and then click
Next.

5 On the Schedule task page, configure the task schedule, and then click Finish.

See “To schedule agentless inventory tasks” on page 16.

6 (Optional) To view the created task, do one of the following:

■ In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory, and then view the task in theAgentless Inventory
Tasks Web Part.
Note that to view the newly created task, you may need to click the Refresh symbol.

■ In the Symantec Management Console, on the Manage menu, click Jobs and Tasks,
and then, in the left pane, under Jobs / Tasks, expand System Jobs and Tasks >
Discovery and Inventory.

The next step is to view the agentless inventory data.

See “Viewing agentless inventory results” on page 16.
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Manually creating, scheduling, modifying, and
stopping agentless inventory tasks

You can manually create, modify, and stop agentless inventory tasks on the Agentless
Inventory Home page.

See “About gathering agentless inventory” on page 11.

This task is a step in the process for gathering agentless inventory.

See “Gathering agentless inventory” on page 12.

Before you perform these steps, ensure that you have mapped the SNMP devices to the data
that you want to gather.

See “Using SNMP data mapping tables” on page 19.

To manually create agentless inventory tasks

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 In the Agentless Inventory Tasks Web Part, on the Available Tasks tab, on the toolbar,
click New.

3 In the New Agentless Inventory Task dialog box, give the task a descriptive name, and
then do the following:

■ Select Group of Devices, and then, in the drop-down list, click the group of devices
that you want to gather inventory from.
For more information, see the topics about using filters and organizational views in
the IT Management Suite Administration Guide.

■ UnderGroup of Devices, check the types of devices that you want to gather inventory
from.

■ (Optional) To gather inventory from an individual device, select Individual device,
and then, in the drop-down list, click the device that you want to gather inventory from
This list includes all SNMP-enabled devices that have been previously discovered and
have resources in the Configuration Management Database (CMDB).

■ (Optional) Click Advanced, specify the maximum number of threads per inventory
task, and then click OK.
During the inventory process, a separate thread is used for each device. The maximum
number of threads is based on the amount of traffic that you want this task to generate
and on the capacity of your Notification Server computer.

4 Click OK.
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To schedule agentless inventory tasks

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 In the Agentless Inventory Tasks Web Part, on the Available Tasks tab, click the task
that you want to schedule, and then click Schedule.

3 In the New Schedule dialog box, configure the task schedule according to your needs,
and then click Schedule.

To configure or stop agentless inventory tasks

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 In the Agentless Inventory Tasks Web Part, on the Available Tasks tab, click the task
that you want to schedule, and then do one of the following:

■ To configure the task run schedule, on the toolbar, click Schedule.
In theNew Schedule dialog box, configure the task according to your needs, and then
click Schedule.

■ To configure the task settings, on the toolbar, click the Edit symbol.
In the New Agentless Inventory Task dialog box, configure the task according to
your needs, and then click OK.

■ To stop the task, click the Tasks Run tab, click the task that you want to stop, and
then, on the toolbar, click Stop.

The next step is to view the agentless inventory data.

See “Viewing agentless inventory results” on page 16.

Viewing agentless inventory results
The data collected by the inventory tasks is stored in the CMDB.

You can view the collected data and the additional details about the devices in the Resource
Manager or on the Agentless Inventory Home page

For more information, see the topics about Resource Manager in the IT Management Suite
Administration Guide.

The Agentless Inventory Home page presents a data summary of inventoried network
devices. On this page you can also see the status of agentless inventory tasks.

This task is a step in the process for gathering agentless inventory.

See “Gathering agentless inventory” on page 12.
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To view agentless inventory data in the Resource Manager

1 In the Symantec Management Console, on the Manage menu, click Resource.

2 In the Select Resource dialog box, click the resource that you want to view, and then
click OK.

3 On the Resource Manager page, on the toolbar, click View > Inventory, and then, in
the navigation pane, under Data Classes, navigate to Network Device Data to view the
inventory data.

To view agentless inventory data on the Agentless Inventory Home page

1 In the Symantec Management Console, on theHomemenu, clickDicovery and Inventory
> Agentless Inventory.

2 On the Agentless Inventory Home page, view the Devices Inventoried By Type (Last
30 Days) and Agentless Inventory Tasks Web Parts.
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Mapping network device
data

This chapter includes the following topics:

■ About SNMP data mapping

■ Using SNMP data mapping tables

About SNMP data mapping
SNMP data mapping tables let you define how to map SNMP devices to the data that you
want to gather. Inventory for Network Devices provides predefined SNMP data mapping tables
for common SNMP devices. The predefined tables are read-only and cannot be edited.

You can also create your own custom SNMP data mapping tables.

See “Using SNMP data mapping tables” on page 19.

When you create a new SNMP data mapping table, you specify Management Information Base
(MIB) data objects, also known as MIB files or MIBs. MIBs are the data objects that are defined
in the database. An SNMP manager uses them to control hardware and software resources.
MIBs let you expand the data fields that can be collected when inventory runs. Inventory for
Network Devices provides many MIBs of the leading hardware manufacturers. You can also
import additional MIBs using the MIB Import task. The MIB files that you import with the MIB
Import task can have the .MIB, .MY, or any other file extension for MIB files.

For more information, see the topic about importing MIB files using the MIB import task in the
IT Management Suite Administration Guide.

When you map SNMP data mapping tables to a device, you choose a device from a list of
classified SNMP devices. This list includes the SNMP devices that are configured on the SNMP
Device Classifications page of Network Discovery.
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Using SNMP data mapping tables
SNMP data mapping tables let you define how to map SNMP devices to the data that you
want to gather. Inventory for Network Devices provides predefined SNMP data mapping tables
for common SNMP devices. The predefined tables are read-only and cannot be edited.

See “About SNMP data mapping” on page 18.

If you manage network devices in a large infrastructure, you can export configured SNMP data
mapping tables and send them to other locations within your organization. This method is an
easy way to ensure that all Notification Servers that use Inventory for Network Devices gather
the same inventory.

See “To export an SNMP data mapping table” on page 20.

You can also test table definitions to ensure that you have defined the field values for a table
definition correctly. When you test the table, you test it on a single device that you specify.

See “To test an SNMP data mapping table on a single device” on page 20.

To view an SNMP data mapping table

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 On the Agentless Inventory Home page, in the Agentless Inventory Quick Start Web
Part, click Data mapping tables.

3 On the SNMP Data Mapping Tables page, in the left pane, click the table that you want
to view.

4 In the right pane, on the Table details tab, view table details.

On the Device mappings tab, view the SNMP devices to which the table is mapped.

To create a new SNMP data mapping table

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 On the Agentless Inventory Home page, in the Agentless Inventory Quick Start Web
Part, click Data mapping tables.

3 On the SNMP Data Mapping Tables page, on the toolbar, click New.

4 In the New Table dialog box, type a new table name, and then click OK.

5 In the right pane, under Table Columns, on the toolbar, click New.

6 In the Edit Row Values dialog box, do the following:

■ Type the name and length of the row.
The length of some types is predefined.
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■ (Optional) Check Key to enable the row to be a primary key in the data table.

■ Click Select OID to select an Object ID.
The Object ID is mapped to the source of the protocol information. For example, it can
map to the Object ID for an SNMP query.
In the Object ID Selection Tool dialog box, in the mib drop-down list, choose an
Object ID according to your needs, and then click Save changes.

7 Click OK.

8 Click Save changes.

9 Click the Device Mappings tab, and check the devices that you want to apply this table
to.

10 Click Test on device.

In the Test Table Mappings on Device dialog box, in the Host address box, type the
host address or host name of the device that you want to test, and then click Test.

The data appears if a valid response is received from the device.

Click Close.

11 Click Save changes.

To test an SNMP data mapping table on a single device

1 Either in a new table or in the details of an existing table, click Test on Device.

2 Enter the host address or host name of the device you want to test.

3 Click Test.

The data appears if a valid response is received from the device.

To export an SNMP data mapping table

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 On the Agentless Inventory Home page, in the Agentless Inventory Quick Start Web
Part, click Data mapping tables.

3 On the SNMP Data Mapping Tables page, in the left pane, click the table that you want
to export, in the upper left corner, click the Tools icon, and then click Export.

4 In the dialog box that open, choose the directory where you want to export the file, and
then click Save.

By default, the file name is the same as the table name.
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To import an SNMP data mapping table

1 In the Symantec Management Console, on the Home menu, click Discovery and
Inventory > Agentless Inventory.

2 On the Agentless Inventory Home page, in the Agentless Inventory Quick Start Web
Part, click Data mapping tables.

3 On the SNMP Data Mapping Tables page, in the left pane, click Import.

4 Browse to the file that you want to import, and then click OK.
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