
Symantec™ Patch
Management Solution for
Windows® 8.5 powered by
Altiris™ technology User
Guide



Symantec™ Patch Management Solution for
Windows® 8.5 powered by Altiris™ technology User
Guide

Documentation version: 8.5

Legal Notice
Copyright © 2019 Symantec Corporation. All rights reserved.

Symantec, the Symantec Logo, the Checkmark Logo and Altiris are trademarks or registered trademarks
of Symantec Corporation or its affiliates in the U.S. and other countries. Other names may be trademarks
of their respective owners.

This Symantec product may contain third party software for which Symantec is required to provide attribution
to the third party (“Third Party Programs”). Some of the Third Party Programs are available under open
source or free software licenses. The License Agreement accompanying the Software does not alter any
rights or obligations you may have under those open source or free software licenses. Please see the
Third Party Legal Notice Appendix to this Documentation or TPIP ReadMe File accompanying this Symantec
product for more information on the Third Party Programs.

The product described in this document is distributed under licenses restricting its use, copying, distribution,
and decompilation/reverse engineering. No part of this document may be reproduced in any form by any
means without prior written authorization of Symantec Corporation and its licensors, if any.

THE DOCUMENTATION IS PROVIDED "AS IS" AND ALL EXPRESS OR IMPLIED CONDITIONS,
REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE
DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH DISCLAIMERS ARE HELD TO BE LEGALLY
INVALID. SYMANTEC CORPORATION SHALL NOT BE LIABLE FOR INCIDENTAL OR CONSEQUENTIAL
DAMAGES IN CONNECTION WITH THE FURNISHING, PERFORMANCE, OR USE OF THIS
DOCUMENTATION. THE INFORMATION CONTAINED IN THIS DOCUMENTATION IS SUBJECT TO
CHANGE WITHOUT NOTICE.

The Licensed Software and Documentation are deemed to be commercial computer software as defined
in FAR 12.212 and subject to restricted rights as defined in FAR Section 52.227-19 "Commercial Computer
Software - Restricted Rights" and DFARS 227.7202, et seq. "Commercial Computer Software and
Commercial Computer Software Documentation," as applicable, and any successor regulations, whether
delivered by Symantec as on premises or hosted services. Any use, modification, reproduction release,
performance, display or disclosure of the Licensed Software and Documentation by the U.S. Government
shall be solely in accordance with the terms of this Agreement.



Symantec Corporation
350 Ellis Street
Mountain View, CA 94043

https://www.symantec.com

https://www.symantec.com


Symantec Support
All support services will be delivered in accordance with your support agreement and the
then-current Enterprise Technical Support policy.

Contacting Technical Support
Customers with a current support agreement may access Technical Support information at
the following URL:

www.symantec.com/business/support/

Before contacting Technical Support, make sure you have satisfied the system requirements
that are listed in your product documentation. Also, you should be at the computer on which
the problem occurred, in case it is necessary to replicate the problem.

When you contact Technical Support, please have the following information available:

■ Product release level

■ Hardware information

■ Available memory, disk space, and NIC information

■ Operating system

■ Version and patch level

■ Network topology

■ Router, gateway, and IP address information

■ Problem description:

■ Error messages and log files

■ Troubleshooting that was performed before contacting Symantec

■ Recent software configuration changes and network changes

Licensing and registration
If your Symantec product requires registration or a license key, access our technical support
Web page at the following URL:

www.symantec.com/business/support/

http://www.symantec.com/business/support/
http://www.symantec.com/business/support/


Symantec Support .............................................................................................. 4

Chapter 1 Introducing Patch Management Solution for
Windows ........................................................................... 7

About Patch Management Solution for Windows ................................... 7
How Patch Management Solution for Windows works ............................ 8
Where to get more information .......................................................... 9

Chapter 2 Implementing Patch Management Solution for
Windows .......................................................................... 12

Preparing your environment for Patch Management ............................ 12
Installing the software update plug-in ......................................... 14
Configuring Windows software updates distribution ....................... 15
Downloading the Windows software updates catalog ..................... 15

Deploying software updates ............................................................ 16
Running compliance and vulnerability reports .............................. 17
About downloading and distributing software updates .................... 18
Downloading and distributing software updates ............................ 20
Viewing software update delivery results ..................................... 23

Assessing software updates with a task ............................................ 23
Installing software updates with a task .............................................. 25

Chapter 3 Performing Advanced Configuration .............................. 32

Upgrading the software update plug-in .............................................. 32
Uninstalling the software update plug-in ............................................ 33
Configuring software updates download location ................................. 33
Creating and assigning custom severity levels .................................... 34
Configuring software updates installation settings ............................... 35
Configuring Windows System Assessment Scan policy ........................ 35
Relocating or checking the integrity of software update packages ........... 37
Staging software bulletins .............................................................. 38

Contents



Chapter 4 Replicating Patch Management Solution for
Windows data in hierarchy ......................................... 40

About replicating Patch Management Solution for Windows data in
hierarchy .............................................................................. 40

Replicating patch management language alerts .................................. 41
Replicating the software updates catalog ........................................... 42
Replicating a software update policy ................................................. 43

Appendix A Technical reference ............................................................ 44

About hierarchy and data replication direction .................................... 44
About Patch Management Solution security roles ................................ 45

Index .................................................................................................................... 47

Patch Management Solution Glossary ......................................................... 49

6Contents



Introducing Patch
Management Solution for
Windows

This chapter includes the following topics:

■ About Patch Management Solution for Windows

■ How Patch Management Solution for Windows works

■ Where to get more information

About Patch Management Solution for Windows

Note: Current documentation applies to the most recent version of the product.

Patch Management Solution for Windows lets you inventory managed computers to determine
the software updates (patches) that they require. The solution then lets you download the
required software updates from the software vendor and provides you with the tools to install
the software updates. Patch Management provides all security updates, critical updates and
hotfixes but does not provide all optional updates.

Patch Management Solution for Windows supports hierarchy and maintenance windows.
Hierarchy lets you configure features and settings for a parent Notification Server computer,
then pass the settings down to child Notification Server computers.

Patch Management Solution for Windows uses targeted deployments. Updates are not deployed
to a computer unless that computer specifically needs that software update. If a managed
computer meets the prerequisites of a software update, it falls into a targeted filter. The
prerequisites are matched against the data that is sent to Notification Server by the software
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update plug-in: for example, the Internet Explorer and operating system versions. Software
updates are then installed according to the software vendor specifications. For example, if the
update requires a restart, then the computer is restarted after the update is installed. Service
Packs are installed before other software updates.

When a software update has been superseded and rendered obsolete by another update or
updates, the later update is installed.

See “About downloading and distributing software updates” on page 18.

The software vendor assigns severity levels to software updates, but you can also create a
custom severity level.

See “Creating and assigning custom severity levels” on page 34.

For more information about the vendors that Patch Management Solution for Windows supports,
see the following knowledge base article:

https://www.symantec.com/docs/HOWTO79563

You can also use Patch Management Workflow Web Service that is installed with Patch
Management Solution. The service contains API that accesses the functionality of Notification
Server and lets you perform various patch management actions.

■ The PatchWorkflowSvc Web Service page presents the list of available methods along
with method call examples. You can invoke the methods on this page.
You can access the page at
http://localhost/Altiris/patchmanagementcore/patchworkflowsvc.asmx

■ Starting from 8.5 RU3, the HTML Help page is introduced. The page includes list of available
methods, detailed descriptions of methods and their parameters, and usage examples for
some methods.
You can access the page at
http://localhost/Altiris/patchmanagementcore/patchworkflowsvc.html

Warning: You must ensure that each software update works correctly in your environment
before deploying it. Symantec recommends that you first distribute any required software
update in a test environment before deploying it to your production environment.

HowPatchManagement Solution forWindowsworks
Patch Management Solution for Windows uses inventory information to decide which software
update packages to distribute. From software bulletins, you create the software update policies
that send the associated packages to managed computers and install the appropriate software
update programs.
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After you install Patch Management Solution for Windows, you download complete software
bulletin information (patch management metadata) from the Symantec website. Information
includes the severity of each software bulletin, details on its software updates, and where they
can be downloaded from the vendors. This information also includes rules for creating filters
and rules on how to verify that a software update is installed. Then you deploy the software
update plug-in to managed computers, which gathers inventory. Inventory includes software
vendor, software release, and service pack information. From this inventory, Patch Management
Solution for Windows creates specific filters to target only the computers requiring individual
software updates.

See “Preparing your environment for Patch Management” on page 12.

You use theDistribute Software Updateswizard to automate the downloading and distribution
of software updates. Instead of creating a policy for each individual software update, you use
this wizard to create a single policy for the relevant software bulletins. You can add multiple
software bulletins to a policy. If you want to, you can modify any default settings and
command-line options in a software update policy.

When you download a software bulletin, each associated software update executable is
downloaded from the vendor to the Notification Server computer. From the information in
software bulletin executables, Patch Management Solution for Windows creates a software
update package for each software update. From the downloaded software bulletins, you then
create software update policies to distribute software update packages to the appropriate
computer filters. When a managed computer receives a software update policy, it verifies that
the update is needed, then downloads the software update package from the Notification
Server computer or a package server. The managed computer then installs the update. At an
interval, the software update policy is re-evaluated and software updates are reinstalled if
needed. For example, if an operation removes a software update, it is reinstalled. Or if a vendor
revises a software update, it is reinstalled.

After the software update plug-in distributes software updates, it sends results of patch
deployment to the Notification Server computer. This information can be viewed in reports.

See “Deploying software updates” on page 16.

Where to get more information
Use the following documentation resources to learn about and use this product.
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Table 1-1 Documentation resources

LocationDescriptionDocument

IT Management Suite (ITMS) 8.5 Documentation■ Information about new
features and
important issues.

■ Information about how
to use this product,
including detailed
technical information
and instructions for
performing common
tasks.

■ Release Notes
■ User Guides

The Documentation Library, which is available in the
Symantec Management Console on the Help menu.

Context-sensitive help is available for most screens in the
Symantec Management Console.

You can open context-sensitive help in the following ways:

■ Click the page and then press the F1 key.
■ Use the Context command, which is available in the

Symantec Management Console on the Help menu.

Information about how to
use this product,
including detailed
technical information and
instructions for
performing common
tasks.

Help is available at the
solution level and at the
suite level.

This information is
available in HTML help
format.

Help

In addition to the product documentation, you can use the following resources to learn about
Symantec products.

Table 1-2 Symantec product information resources

LocationDescriptionResource

Knowledge BaseArticles, incidents, and
issues about Symantec
products.

SymWISE Support
Knowledgebase

Unified Help SystemAll available IT
Management Suite and
solution guides are
accessible from this
Symantec Unified Help
System that is launched
on cloud.

Cloud Unified Help System

10Introducing Patch Management Solution for Windows
Where to get more information

https://www.symantec.com/docs/DOC11076
https://support.symantec.com
https://help.symantec.com/home/ITMS8.5?locale=EN_US


Table 1-2 Symantec product information resources (continued)

LocationDescriptionResource

The links to various groups on Connect are as follows:

■ Deployment and Imaging
■ Discovery and Inventory
■ ITMS Administrator
■ Mac Management
■ Monitor Solution and Server Health
■ Patch Management
■ Reporting
■ ServiceDesk and Workflow
■ Software Management
■ Server Management
■ Workspace Virtualization and Streaming

An online resource that
contains forums, articles,
blogs, downloads,
events, videos, groups,
and ideas for users of
Symantec products.

Symantec Connect
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Implementing Patch
Management Solution for
Windows

This chapter includes the following topics:

■ Preparing your environment for Patch Management

■ Deploying software updates

■ Assessing software updates with a task

■ Installing software updates with a task

Preparing your environment for Patch Management
Patch Management Solution for Windows requires some components to be configured or
enabled before others can function correctly. When you complete each task for the first time,
you can also configure it for future automation. Automation is a key feature of Patch
Management Solution for Windows as it reduces system administration workload and enhances
overall security.

See “About Patch Management Solution for Windows” on page 7.

After you configure Patch Management Solution to work in your environment, you can distribute
software updates.

See “Deploying software updates” on page 16.
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Table 2-1 Process for preparing your environment for Patch Management

DescriptionActionStep

Use Symantec Installation Manager to install the solution.Install or upgrade the
solution.

Step 1

Install or upgrade the Symantec Management Agent on every computer
to which you want to send patches.

For more information, see the topics about installing or upgrading the
Symantec Management Agent in the IT Management Suite
Administration Guide.

See “Where to get more information” on page 9.

Install or upgrade the
Symantec Management
Agent.

Step 2

Install the plug-in that manages all of the Patch Management Solution
for Windows functionality on a client computer.

See “Installing the software update plug-in” on page 14.

See “Upgrading the software update plug-in” on page 32.

Install or upgrade the
software update plug-in.

Step 3

(Optional)

Configure software update package distribution and program settings.

See “Configuring Windows software updates distribution” on page 15.

Configure Windows software
updates distribution

Step 4

On client computers, enable and configure theWindowsUpdate service
to make available the installation of software updates. You can configure
the Windows Update service to start manually or automatically.

Symantec recommends that you configure theWindowsUpdate service
to start manually. When you enable the Manual startup type setting,
the service starts and remains started until a computer restart.

Warning: When you enable the Automatic startup type setting, client
computers may be restarted after the software update cycle is
completed.

For more information, see the following knowledge base article:

http://www.symantec.com/docs/TECH41678

Enable theWindowsUpdate
service.

Step 5

(Optional)

Configure the software update files storage location settings.

See “Configuring software updates download location” on page 33.

Configure the software
update files location settings.

Step 6
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Table 2-1 Process for preparing your environment for Patch Management (continued)

DescriptionActionStep

(Optional)

Configure the time when you want to perform software update
installation and computer restarts.

See “Configuring software updates installation settings” on page 35.

Configure the software
updates installation settings.

Step 7

(Optional) Configure when to run the system assessment scan that
inventories managed computers for the software updates that they
require.

The system assessment scan policy is enabled by default and runs
automatically on all computers with Software Update plug-in installed.

See “Configuring Windows System Assessment Scan policy”
on page 35.

Configure the system
assessment scan interval.

Step 8

Download the Windows software updates metadata and configure the
metadata update schedule.

See “Downloading the Windows software updates catalog” on page 15.

Download the Windows
software updates metadata.

Step 9

Installing the software update plug-in
The software update plug-in manages all of the Patch Management Solution for Windows
functionality on a client computer. When the system assessment scan tool reports to Notification
Server that a certain software update is required for a managed computer, the update is then
sent to the software update plug-in. The software update plug-in ensures that the update is
applicable and not already installed, and then installs it.

After you install the software update plug-in on a managed computer, the Software Updates
tab appears in the Symantec Management Agent user interface. This tab displays the status
of software updates for that computer. If the tab is not visible, in the Symantec Management
Agent, click View > Software Updates. To open the Symantec Management Agent user
interface, click the Symantec Management Agent icon in the system tray of the managed
computer.

See “Installing the software update plug-in” on page 14.

Note: If you have a large number of computers where you want to install the software update
plug-in, consider deploying it during off-peak hours to minimize network traffic. Deploying the
software update plug-in can take some time, depending on the number of managed computers
and the Symantec Management Agent settings.

See “Preparing your environment for Patch Management” on page 12.
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To install the software update plug-in

1 In the Symantec Management Console, on the Actions menu, click Agents/Plug-ins >
Rollout Agents/Plug-ins.

2 In the left pane, expand Software > Patch Management > Software Update Plug-in
Install.

3 (Optional) In the right pane, make any necessary changes.

For help, press F1 or, on the Help menu, click Context.

4 In the upper right corner of the page, click the colored circle, and then click On.

5 Click Save changes.

The next step is to configure software update package distribution and program settings.

See “Configuring Windows software updates distribution” on page 15.

Configuring Windows software updates distribution
You can set up how you want Windows software updates distributed. You can configure
package distribution and program settings.

To configure Windows remediation settings

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, expand Software > Patch Management > Windows Settings, and then
click Windows Patch Remediation Settings.

3 In the right pane, make any wanted changes, or leave the default values.

4 Click Save changes.

Downloading the Windows software updates catalog
You must download the Windows software updates catalog (patch management metadata, or
patch management import files) before you can download software updates or create software
update policies. The process of populating the information repository from the patch
management metadata files can be started after you complete the installation of the solution.

The Import Patch Data background task downloads the software update catalog files and
imports software management resources from the files into the Configuration Management
Database (CMDB). These resources are necessary for populating the Patch Remediation
Center and deploying patches to managed computers.

This task downloads the information about the updates that are available for download. It does
not download the actual software update files.

See “Preparing your environment for Patch Management” on page 12.
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You can run this task once or schedule the task. This procedure ensures that you have the
latest, most accurate data, and your software update tasks are kept up-to-date. Symantec
recommends that you configure this task to run daily.

Before you perform this step, ensure that you have installed or upgraded the software update
plug-in.

See “Installing the software update plug-in” on page 14.

See “Upgrading the software update plug-in” on page 32.

To download the Windows software updates catalog immediately

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand Jobs and Tasks > System Jobs and Tasks > Software > Patch
Management > Import Patch Data for Windows.

3 In the right pane, under Vendors and Software, click Update.

4 When the available products list import is complete, under Vendors and Software, check
the software for which you want to download the patch management metadata.

5 (Optional) Make any other necessary changes.

For help, click the page, and then press F1, or on the Help menu, click Context.

6 Click Save changes.

7 Under Task Status, click New Schedule.

8 In the New Schedule dialog box, click Now, and then click Schedule.

To configure a schedule for downloading the software updates catalog

1 On the Import Patch Data for Windows page, under Task Status, click New Schedule.

2 In theNew Schedule dialog box, click Schedule, and then configure a schedule on which
to run this task.

Symantec recommends that you configure this task to run daily.

3 Click Schedule.

Deploying software updates
After you configure Patch Management Solution to work in your environment, you can gather
information about the needs and priorities for patching in your environment. Use this information
to set up software update policies, and then evaluate the results with software update delivery
reports.

See “Preparing your environment for Patch Management” on page 12.
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Table 2-2 Process for deploying software updates

DescriptionActionStep

Check your environment for vulnerabilities and evaluate which software
updates you need to distribute.

See “Running compliance and vulnerability reports” on page 17.

Run compliance and
vulnerability reports

Step 1

View which software bulletins you need to install, then download updates
and create software update policies.

See “Downloading and distributing software updates” on page 20.

See “Staging software bulletins” on page 38.

Review and distribute
available software updates.

Step 2

Evaluate the results by running the Software Update Delivery
Summary report and revisiting compliance reports.

See “Viewing software update delivery results” on page 23.

Evaluate the results.Step 3

For an example on how to manage the updates with Patch Management Solution, please see
the following videos:

http://www.youtube.com/watch?v=LfjiZ8peXhs

http://www.youtube.com/watch?v=iY25PztN7Kc

Running compliance and vulnerability reports
You can view and manage your patch management data through reports. Reports give you
the information that is specific to Patch Management Solution. For example, you can use
compliance reports to determine how many urgent software updates your managed computers
require.

Reports let you view information in various ways. You can see your information in tables or
graphically in charts. You can also drill down on specific items in a report to obtain additional
information.

You can download or distribute software updates directly from reports by right-clicking the
update name in the report.
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Table 2-3 Patch Management Solution reports

DescriptionReport type

Compliance reports let you quickly determine which software updates your
managed computers require. Compliance reports are used to determine if the
computers are up-to-date with the latest software updates. These reports are
also used to check if a particular software bulletin or update is installed on your
managed computers. This capability is useful if a specific security issue affects
your network environment, and a certain update addresses the problem.

Compliance reports

The diagnostics reports display vulnerability summary and software update
plug-in installation information.

Diagnostics reports

The remediation status reports summarize and detail software update
associations and activities.

Remediation status
reports

The software bulletins reports summarize and detail software bulletins activity
and status.

Software bulletins
reports

To view Patch Management reports

1 In the Symantec Management Console, on the Reports menu, click All Reports.

2 In the left pane, expand Software > Patch Management.

3 Click the report that you want to view.

For example, click Compliance > Windows Compliance by Bulletin.

4 If you want to view more information about an update, right-click any update, and then
click Resource Manager.

Each type of compliance report opens a different Resource Manager, depending on the
type of results. For example, the Windows Compliance by Computer report opens a
computer-type Resource Manager. When you open a Resource Manager for a software
update, you can click Summaries > Software Bulletin Details, and, under Additional
Information, you can find a hyperlink to the Microsoft TechNet article on the bulletin.

The next step is to review and distribute available software updates.

See “Downloading and distributing software updates” on page 20.

See “Staging software bulletins” on page 38.

About downloading and distributing software updates
You can stage software bulletins and download software update packages on the Patch
Remediation Center page, where all available software updates are listed. You can also do
this at Home > Patch Management or from any Patch Management Solution report.
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When you stage a software bulletin, all associated updates are downloaded to the Notification
Server computer.

When the number in the Updates column equals the number in the Available Packages
column, all updates for the software bulletin have been downloaded.

You can choose to download the software update packages and distribute them at a later time.
You also have an option to download and then, once the download has finished, distribute the
software update to managed computers.

Sometimes not all software updates need to be downloaded for a software bulletin. For example,
a software bulletin for Windows 10 may contain the updates that you do not want to deploy.
In such a case, you can create a software update policy that downloads and distributes only
selected updates for a particular software bulletin. To partially distribute updates, you check
only the required updates on the second page of the Distribute Software Updates wizard.

For Windows updates, you can also select the update(s) that you need in the Windows
Compliance by Update report, and then right-click the Distribute Packages Partially
drop-down menu option.

Some UNIX, Linux, or Mac advertisements can contain similar updates. As a result, you can
get a fully staged software update policy even if you stage only one advertisement. For example,
if you stage only the advertisement for x64 system that already includes x86 updates, you can
get a fully staged policy.

Later you can edit a partially staged software update policy and stage previously non-staged
updates.

Note:The right-click commandDownload Packages in patch reports does not support staging
updates partially and downloads all software updates for a software bulletin.

The right-click command Recreate packages is not available for partially staged bulletins.

Note: If you chose to revise the existing partially staged software update policies, by default,
the new software updates are always added to the policies in the disabled state and not
distributed to target computers.

Note: When distributing updates, you should consider possible effects on your network
environment. Symantec recommends that you distribute new updates to a test environment
first.

See “Staging software bulletins” on page 38.

See “Downloading and distributing software updates” on page 20.
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You can configure Windows software updates distribution to automatically clean up folders
with expired packages in default and custom locations. If you check the optionDelete packages
after on the Windows Patch Remediation Settings page, the software update plug-in gets
notifications from Symantec Management Agent about the deletion of an expired Patch or
Software package, identifies the package location, and deletes the contents of the corresponding
folder.

See “Configuring Windows software updates distribution” on page 15.

You can manually clean up the software bulletins and package files that are not needed as
follows:

■ You can disable one or many software bulletins by selecting the
bulletins in patch reports, right-clicking the Disable drop-down menu
option, and then clicking Disable software bulletins.

■ If the selected bulletins are part of one or more software update
policies on your current Notification Server or on any other Notification
Server(s) in the hierarchy, you can also remove the disabled bulletins
from the policies by checking the Remove the selected bulletins
from policies option in the Disable software bulletins dialog box.

Note: If you want to disable software bulletins and remove them from the
software update policies, you must do it at the same time. You cannot
remove from software update policies the bulletin that is already disabled.

Disable software bulletins and
remove them from software
update policies.

You can automatically delete the unused package files as follows:

■ Configure the package service settings to automatically delete the
package files that have not been used for a specified time by checking
the Delete package files if they are unused for option on the
Package Service Settings page.

■ Run the Check Software Update Package Integrity task with the
enabled optionDelete the downloaded packages that are no longer
in use
See “Relocating or checking the integrity of software update packages”
on page 37.

Delete unused package files.

Downloading and distributing software updates
You can stage software bulletins and download software update packages on the Patch
Remediation Center page, where all available software updates are listed. You can also do
this at Home > Patch Management or from any Patch Management Solution report.

When you stage a software bulletin, all associated updates are downloaded to the Notification
Server computer. You can choose to download the software update packages and distribute
them to the client computers at a later time. You can also distribute the software updates once
the download is complete.
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See “Staging software bulletins” on page 38.

To deliver and install the software updates to the appropriate computers, you can use the
following delivery methods:

Table 2-4 Software update delivery methods

DescriptionMethod

You can create the following types of software update policies:

■ A policy that distributes all updates for a particular software bulletin.
■ A policy that distributes only selected updates for a particular software bulletin.

Later you can edit the partially staged policy and select and stage previously
non-staged updates.

See “About downloading and distributing software updates” on page 18.

Note: When distributing updates, you should consider the effects it can possibly have
on your network environment. Symantec recommends that you distribute new updates
to a test environment first.

The Distribute Software Updates wizard lets you create software update policies. If
the associated software updates are not yet downloaded, Patch Management Solution
creates a download task. When download is completed, the software update policy is
distributed to the target computers.

See “To distribute software updates” on page 22.

If you want to install a Service Pack, Symantec recommends that you create a software
update policy for this service pack only, without any other bulletins included in it. Also,
in the wizard, check the Allow immediate restart if required box.

You can access the software update policies that you create at Manage > Policies >
Software > Patch Management > Software Update Policies. On a policy page, you
can view the details of the policy and change its settings if necessary.

You can also access the list of the software update policies at Home > Patch
Management, in the left pane, under Windows, by clicking Windows Policies. In the
central pane, you can click the policy that you need, and then view or edit its settings
on the policy page that opens in the right pane.

Software update policies.
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Table 2-4 Software update delivery methods (continued)

DescriptionMethod

You can create the following software update tasks and sequence them in a single job
with other tasks:

■ Windows Software Update Assessment task
See “Assessing software updates with a task” on page 23.

■ Windows Software Update Installation task
See “Installing software updates with a task” on page 25.

You may want to use the software update tasks instead of software update policies for
the following reasons:

■ You need to perform management operations before and after the installation of
software updates as part of a sequence of events.

■ You need to assess and install some particular updates once and as soon as
possible on the limited number of target computers that you specify. The tasks
come to target client computers faster than a software update policy.

Software update tasks.

You can view the software update delivery results in reports.

See “Viewing software update delivery results” on page 23.

Before you perform this step, ensure that you have run the compliance and vulnerability reports.

See “Running compliance and vulnerability reports” on page 17.

See “Preparing your environment for Patch Management” on page 12.

To distribute software updates

1 In the Symantec Management Console, on the Actions menu, click Software > Patch
Remediation Center.

2 On the Patch Remediation Center page, in the right pane, in the Show drop-down menu,
click Windows Compliance by Bulletin or any other report that suits your needs, and
then click the Refresh symbol to see which updates the target computers require.

3 Right-click the bulletin with the software updates that you want to distribute to client
computers, and then click Distribute Packages.

If you want to distribute many bulletins at once, select multiple items while holding down
the Shift or Ctrl key, right-click one of them, and then click Distribute Packages.

4 In the Distribute Software Updates wizard, click Step 1, ensure that the settings are
configured as needed, and then click Next.

5 On the second page of the wizard, check the updates that you want to distribute.

You can check all updates or only some updates for a particular software bulletin.
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6 Turn on the policy.

At the upper right of the second wizard page, click the colored circle, and then click On.

You can also turn on the policy later.

7 Click Distribute software updates.

8 In the status dialog box, click Close.

Viewing software update delivery results
The Software Update Delivery Summary report summarizes the results of all scheduled
Microsoft software update policies. It shows you which computers the software update tasks
target, and if the updates have been successfully installed. The report also shows you if any
software update tasks failed, or if they have not yet been completed.

Patch Management Solution for Windows also provides other reports that you can view.

See “Preparing your environment for Patch Management” on page 12.

To view the software update delivery summary report

1 In the Symantec Management Console, on the Reports menu, click All Reports.

2 In the left pane, expand Software > Patch Management > Remediation Status, and
then click Windows Software Update Delivery Summary.

Assessing software updates with a task
(Windows only)

In addition to detection of applicable and installed software updates with Windows System
Assessment Scan policy, Patch Management Solution lets you use a Windows Software
Update Assessment task for update assessment.

This feature is available starting from IT Management Suite version 8.5 RU3.

See “Configuring Windows System Assessment Scan policy” on page 35.

The task assesses applicability of the selected single or multiple software updates, or all
updates in the selected bulletin. The task detects if the updates are already installed on client
computers.

You can create and run aWindows Software Update Assessment task for a software update
before you install the update with a Windows Software Update Installation task. You can
create a separateWindows Software Update Assessment task, and then manually sequence
the task in a single client job with a Windows Software Update Installation task. You can
also create one or both software update tasks together with a client job that contains the tasks
from patch management reports.
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If you sequence the assessment and installation tasks in a single client job with other pre- and
post-installation tasks, and the assessment task detects that the selected for installation update
is not applicable or already installed, you can choose to skip the installation of the update and
running the pre- and post-installation tasks on the client computers that have the updates
already installed or not applicable.

See “Installing software updates with a task” on page 25.

Note that the hierarchy and replication functionality is not supported for Windows Software
Update Assessment tasks and jobs that contain Windows Software Update Assessment
tasks.

For more information on how to create a sample client job with a Windows Software Update
Assessment task, see the following knowledge base article:

https://www.symantec.com/docs/DOC11578

Upon Windows Software Update Assessment task completion, you can view the status of
software updates assessment on the Notification Server computer, in the Symantec
Management Console, on the task page.

See “To view the status of software updates assessment” on page 25.

To assess software updates with a task

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, right-click the folder where you want to create the task, and then click
New > Task.

3 In the Create New Task dialog box, in the left pane, expand Software > Patch
Management, and then click Windows Software Update Assessment.

4 In the right pane, configure the following task option:

Lets you select software updates that you want to assess.

The task must have at least one update selected.

Software Updates
Assessment

5 (Optional) To specify the timeout period for the task and other task options, clickAdvanced,
configure the options according to your needs, and then click OK.

Note: The task timeout period should not be less than the time that is required for update
assessment.
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6 Click OK.

7 Schedule the task to run.

Note: The task start abides by maintenance window settings that you define while
scheduling the task and that are defined in Task Management. However, if the task is
already running, the task completes the update assessment even if the assessment
exceeds the specified maintenance window.

To view the status of software updates assessment

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, navigate to the folder that contains the Windows Software Update
Assessment task that you require and click the task.

For example, expand System Jobs and Tasks > Software > Patch Management >
Windows Software Update Assessment.

3 In the right pane, view the status of assessment tasks.

To view task status details and task instance details along with statuses of included
updates, under Task Status, double-click a task, and then double-click the computer
name that you require.

Installing software updates with a task
(Windows only)

In addition to installing software updates with software update policies, Patch Management
Solution lets you use a Windows Software Update Installation task for update installation.

This feature is available starting from IT Management Suite version 8.5 RU2.

See “Downloading and distributing software updates” on page 20.

Before installing software updates with a Windows Software Update Installation task, you
can create and run a Windows Software Update Assessment task. The assessment task
assesses applicability of the selected software updates and detects if the updates are already
installed on client computers. If you plan to sequence the installation task in a single client job
with other pre- and post-installation tasks, and the assessment task detects that the selected
for installation update is not applicable or already installed, the update will not be installed and
the pre- and post-installation tasks will not run.

See “Assessing software updates with a task” on page 23.
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Table 2-5 Process for installing software updates with a task

DescriptionActionStep

The reasons to install software updates with an Windows Software
Update Installation task are as follows:

■ If you need to perform management operations immediately before
and after the installation of single or multiple software updates as
part of a sequence of events, you can create a Windows Software
Update Installation task for the required update(s). Then you can
sequence the task in a single client job with other pre- and
post-installation tasks according to your needs. For creating pre-
and post-installation tasks, you can use system, user-created, and
sample tasks and jobs.
Note that the hierarchy and replication functionality is not supported
for Windows Software Update Installation tasks and jobs that
contain Windows Software Update Installation tasks.
For more information on how to create a sample client job with a
Windows Software Update Installation task, see the following
knowledge base article:
https://www.symantec.com/docs/DOC11414

■ You can install software updates with aWindows Software Update
Installation task if you need to install some particular updates once
and as soon as possible on the limited number of target computers
that you specify. The task comes to target client computers faster
than a software update policy.

In addition to the general task creation way, you can also create a
WindowsSoftware Update Installation task from patch management
reports, Patch Remediation Center reports, or Resource Manager
reports for a selected resource.

See “To install software updates with a task” on page 28.

See “To create software update tasks from patch management reports”
on page 30.

You create and run an
Windows Software Update
Installation task for required
software updates.

Step 1

Windows Software Update Installation task execution triggers the
system task Distribute Software Updates to run immediately on the
Notification Server computer.

The system task downloads from vendors to the Notification Server
computer and prepares for distribution (stages) the software updates
that are included into theWindows Software Update Installation task.

The system task Distribute
SoftwareUpdates stages the
software updates.

Step 2
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Table 2-5 Process for installing software updates with a task (continued)

DescriptionActionStep

Target client computers can receive the Windows Software Update
Installation task only after the system task completes download of the
required updates. Large update size can delay the actual start of update
deployment on target client computers.

Note: To speed up the Windows Software Update Installation task
delivery to target client computers, you can stage the required updates
before you create the task.

See “Staging software bulletins” on page 38.

The Windows Software Update Installation task abides by Task
Management maintenance windows. For example, if maintenance
windows are specified and the task is not configured to override
maintenance windows, target client computers receive the task as soon
as the first available maintenance window opens.

Target client computers
receive the Windows
Software Update
Installation task.

Step 3

After a target client computer receives theWindows Software Update
Installation task, the task waits until the software update plug-in has
time to process the task separately from other software update
cycles/policies and patch management tasks. For this reason Symantec
recommends that you limit the number of software update policies and
patch management tasks that run on a target client computer at the
same time.

The software update plug-in
processes the Windows
Software Update
Installation task.

Step 4

As soon as the Windows Software Update Installation task gets
processed and receives required software update packages, the task
triggers a software update cycle to install its applicable software updates
on the target computer.

If a target computer has other updates (incl. superseded updates) that
are already delivered for immediate installation by software update
policies, such updates are also installed if they are detected as
applicable for installation during the software update cycle.

If the Windows Software Update Installation task contains multiple
updates that supersede each other, only superseding updates are
installed.

Note: The Windows Software Update Installation task settings
override all Default Software Update Plug-in Policy options, except
for the notification options.

Software update cycle starts.Step 5
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Table 2-5 Process for installing software updates with a task (continued)

DescriptionActionStep

During the software update cycle, users of target computers can view
the installation status of each software update on the Software Updates
tab.

Note that after the Windows Software Update Installation task
completes, and update of the Symantec Management Agent
configuration occurs, the Software Updates tab no longer provides the
corresponding software update data.

Depending on the notification options that you define for the Default
Software Update Plug-in Policy, users can also get a message that
notifies them about the start of the software update cycle and see the
progress of software update installations in a separate dialog box.

Users view installation-related
information.

Step 6

Upon Windows Software Update Installation task completion, you
can view the status of software updates installation on the Notification
Server computer in the Symantec Management Console, on the task
page.

See “To view the status of software updates installation” on page 31.

You can also view software update delivery results in Patch
Management Solution reports.

See “Viewing software update delivery results” on page 23.

You view software update
delivery results.

Step 7

On the Notification Server computer, the automatic system task Clean
up Install Software Updates task data runs daily and also as soon
as the Windows Software Update Installation task completes with
success or failure. The system task cleans up unused data of completed
Windows Software Update Installation task instances. Note that other
scheduled or running tasks for the same software update stay intact.

Automatic data cleanup does not apply to the status of software updates
installation on the Windows Software Update Installation task page
and software update delivery results in reports.

Automatic cleanup of unused
Windows Software Update
Installation task data occurs.

Step 8

To install software updates with a task

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, right-click the folder where you want to create the task, and then click
New > Task.

3 In the Create New Task dialog box, in the left pane, expand Software > Patch
Management, and then click Windows Software Update Installation.

4 In the right pane, configure the following task options:
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Lets you select software updates that you want to install.

The task must have at least one update selected.

Note: Symantec recommends that you limit the number of updates
in aWindowsSoftware Update Installation task. The more updates
a single task contains, the longer timeout period the task requires.

Software Updates
Installation

Lets you configure restart options for the task while the task runs
and after the task completes installation of software updates.

■ Suppress restart during task execution
No restart of a target computer occurs even if the task contains
one or many software updates that require computer restart. The
task completes with success.
If you enable this option and some of the task updates requires
restart, you need to ensure that the computer gets restarted at
some time. You need to analyse the task return codes, and then
sequence a power control task after this task as part of one job.
Otherwise the update installation stays unfinished and Patch
Management Solution reports show the update as not installed.
For more information about Windows Software Update
Installation task return codes, see the following knowledge base
article:
https://www.symantec.com/docs/DOC11414

Note: Symantec recommends that you do not use this option
for a single Windows Software Update Installation that is not
included into a client job.

■ Restart if required at the end of task execution
If the task contains one or many software updates that require
computer restart, a target computer is restarted once upon task
completion.
If a single job contains multiple tasks with software updates that
require computer restart, a target computer is restarted every
time when such task completes.

Restart after updates
installation

5 (Optional) To specify the timeout period for the task and other task options, clickAdvanced,
configure the options according to your needs, and then click OK.

Note: The task timeout period should not be less than the time that is required for update
installation.
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6 Click OK.

7 Schedule the task to run.

Note: The task start abides by maintenance window settings that you define while
scheduling the task and that are defined in Task Management. However, if the task is
already running, the task completes the update installation even if the installation exceeds
the specified maintenance window.

To create software update tasks from patch management reports

1 In the Symantec Management Console, on the Home menu, click Patch Management.

2 On the Patch Management home page, in the left pane, expand Windows, and then
under Compliance and Remediation, click one of the following reports:

■ Compliance by Update

■ Compliance by Bulletin

3 In the right pane, select the required update or the bulletin that contains the required
update.

You can select multiple items while holding down the Shift or Ctrl key.

4 Right-click the selected updates or bulletins, and then click one of the following actions:

■ Create Software Update tasks only for selected updates

■ Create Software Update tasks for all updates in bulletins

5 In the dialog box, give a descriptive base name for the task(s) and job, specify the target
folder, and under Create, select at least one software update task.

Note: Disable the option Client job that contains the selected task(s) if you want to
create separate software update tasks, and then manually include the tasks into an existing
client job.

6 Click OK.

7 In the dialog box, click the created task(s) or job, and then on the task or job page, configure
and schedule the task(s) or job to run.

See 4 on page 28.
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To view the status of software updates installation

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, navigate to the folder that contains the Windows Software Update
Installation task that you require and click the task.

For example, expand System Jobs and Tasks > Software > Patch Management >
Windows Software Update Installation.

3 In the right pane, view the status of installation tasks.

To view task status details and task instance details along with statuses of included
updates, under Task Status, double-click a task, and then double-click the computer
name that you require.
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Performing Advanced
Configuration

This chapter includes the following topics:

■ Upgrading the software update plug-in

■ Uninstalling the software update plug-in

■ Configuring software updates download location

■ Creating and assigning custom severity levels

■ Configuring software updates installation settings

■ Configuring Windows System Assessment Scan policy

■ Relocating or checking the integrity of software update packages

■ Staging software bulletins

Upgrading the software update plug-in
If you upgraded Patch Management Solution from a previous version, you must also upgrade
the Symantec Management Agent and the software update plug-ins that are installed on the
target computers.

For more information about upgrading the Symantec Management Agent, see IT Management
Suite Administration Guide.

See “Preparing your environment for Patch Management” on page 12.
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To upgrade the software update plug-in

1 In the Symantec Management Console, on the Actions menu, click Agents/Plug-ins >
Rollout Agents/Plug-ins.

2 In the left pane, click Software > Patch Management > Software Update Plug-in
Upgrade.

3 (Optional) In the right pane, make any wanted changes.

For help, press F1 or click Help > Context.

4 Turn on the policy.

5 Click Save changes.

The next step is to configure the Patch Management Solution core settings.

See “Configuring software updates download location” on page 33.

Uninstalling the software update plug-in
You can uninstall the software update plug-in if there is an extended period of time when you
do not want to use the patch management features on a managed computer and you want to
eliminate any overhead that is caused by the plug-in.

Ensure that the Software Update Plug-in Install policy is turned off before uninstalling the
software update plug-in.

See “Installing the software update plug-in” on page 14.

To uninstall the software update plug-in

1 In the Symantec Management Console, on the Actions menu, click Agents/Plug-ins >
Rollout Agents/Plug-ins.

2 In the left pane, click Software > Patch Management > Software Update Plug-in
Uninstall.

3 (Optional) In the right pane, make any wanted changes.

For help, press F1 or click Help > Context.

4 Turn on the policy.

5 Click Save changes.

Configuring software updates download location
You can configure to which location on Notification Server the software updates should be
downloaded.
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The settings that you configure apply to Windows and Linux components of Patch Management
Solution.

See “Preparing your environment for Patch Management” on page 12.

To configure software updates download location

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, expand Software > Patch Management > Core Services.

3 In the right pane, on the Locations tab, specify the software updates download location.

4 Click Save Changes.

If you change the location and you want to relocate existing software update packages, use
the Check Software Update Package Integrity task.

See “Relocating or checking the integrity of software update packages” on page 37.

The next step is to configure the software updates installation settings.

Creating and assigning custom severity levels
A software update marked critical may not necessarily be critical in your environment. You
can create your own custom severity levels and assign them to software bulletins.

You first create custom severity levels, and then assign them to bulletins. You can alter custom
severity levels. You cannot alter the vendor-specified severity levels.

The settings that you configure apply to Windows and Linux components of Patch Management
Solution.

To create a custom severity level

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, expand Software > Patch Management > Core Services.

3 In the right pane, click the Custom Severity tab.

4 On the Custom Severity tab, in the Severity Level box, type the name that you want to
give the custom severity level. For example, "Install right away!"

5 Click Add.

6 Click Move Up or Move Down to position the custom severity levels in the list.

7 Click Save Changes.
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To assign a custom severity level to a software bulletin

1 In the Symantec Management Console, on the Actions menu, click Software > Patch
Remediation Center.

2 On the Patch Remediation Center page, in the software bulletin list, right-click a software
bulletin, and then click Custom Severity.

3 Click a severity level.

4 Click Refresh to view the new data in the Custom Severity column.

Configuring software updates installation settings
The Default Software Update Plug-in Policy page lets you configure when the software
update plug-in can install software updates and restart the target computer.

See “Preparing your environment for Patch Management” on page 12.

To configure the software updates installation settings

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, expand Agents/Plug-ins > Software > Patch Management > Windows
> Default Software Update Plug-in Policy.

3 In the right pane, configure when and how you want to install the updates, or leave the
default values.

For help, press F1 or, on the Help menu, click Context.

4 Click Save changes.

ConfiguringWindowsSystemAssessmentScanpolicy
Windows system assessment scan detects applicable and installed updates on client computers
with the software update plug-in installed. System assessment information is then used to
determine which software updates are required. Based on this information, filters targeting the
software update policies are created automatically.

System assessment scan runs automatically in the following cases:

■ When the client computer receives a new or changed Windows Assessment Scan Policy

■ When the client computer receives a new or changed Software Update policies

■ According to the custom schedule defined by the user

■ During the maintenance window

■ Before an update is deployed
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■ After an update is deployed

■ When Symantec Management Agent starts after a reboot that was initiated by an update
deployment

Windows system assessment scan can report assessment data in full or delta mode. Delta
scan reports only the data that has changed since the last full scan. Delta scan helps reduce
the network load.

In addition to gathering and sending full or delta assessment data, each system assessment
scan sends NSEs with data recency information to Notification Server to ensure that the
assessment data is current. Data recency information helps maintain the assessment data
consistency.

The assessment data on the client computer may not be consistent with the information in the
Configuration Management Database (CMDB) if you make significant changes to the
environment. The assessment data files may also get occasionally corrupted or not fully
processed by Notification Server. Patch Management Solution helps you automatically detect
the computers with assessment data discrepancies and maintain the data consistency without
overloading your environment as follows:

First assessment scan runs on managed client computers, stores assessment
data on the computers, and then sends the data to Notification Server in full
mode.

Step 1

Each new assessment scan compares newly gathered assessment data to
the data that is stored on the computers, updates this information, and then
sends the changed data (delta assessment data) to Notification Server.

Step 2

On the client computers, the predefinedNS.Daily task runs automatically every
day at 2:10 A.M. and triggers the hidden task that monitors managed computers
for outdated assessment data.

Step 3

If assessment data discrepancy is found, predefined and hidden Assessment
Data Consistency Maintenance Policy runs on the relevant computers and
starts new system assessment scan that sends assessment data to Notification
Server in full mode.

Step 4

To change the default scan settings, configure the Windows System Assessment Scan policy.

See “Preparing your environment for Patch Management” on page 12.

To configure Windows System Assessment Scan policy

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, expandSoftware > PatchManagement, and then clickWindows System
Assessment Scan.
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3 In the right pane, under Schedule, configure how often you want the system assessment
scan to run on client computers.

If you want the plug-in to report inventory only if it has changed, check Send Inventory
Results Only if Changed .

4 This option is checked by default.

5 (Optional) Under Applied To, choose on which client computers you want the scan to
run.

Symantec recommends that you do not change the default filter fromWindowsComputers
with Software Update Plug-in Installed Target unless you have a specific reason to do
so.

6 Turn the policy on.

7 Click Save changes.

Relocating or checking the integrity of software
update packages

When you change package or program settings in the Patch Remediation Settings policies,
you can choose to run the Check Software Update Package Integrity task.

See “Configuring Windows software updates distribution” on page 15.

This task checks that all software update packages have the correct new settings and values.

If some physical files are missing on the file system in the software update package location,
this task uses the URL from the latest imported patch metadata to re-download the required
files.

You can run this task manually to verify that software update packages in software update
tasks have the correct global server settings applied.

The task also relocates the software update packages in case you changed the default software
update package location on the Core Services page.

See “Configuring software updates download location” on page 33.

To relocate or check the integrity of software update packages

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Software > Patch Management,
and then click Check Software Update Package Integrity.

3 CheckDelete the downloaded packages that are no longer in use if you want to delete
the following downloaded Windows software update packages:

37Performing Advanced Configuration
Relocating or checking the integrity of software update packages



■ The packages that have no association with any software update.

■ The packages that are not part of any software update policy and belong to a disabled
bulletin.

Warning:The deletion of Linux packages removes the additional packages that have been
downloaded during client-base dependency resolving. If any Linux client computer needs
the deleted packages to install an update, the packages will be re-downloaded.

For more information about client-base dependency, see the following knowledge base
article:

https://www.symantec.com/docs/DOC9722

4 If you changed the Software Update Package Location value on the Core Services
page and want to relocate downloaded updates to the new location, check Relocate
existing packages if default Software Update package location on Core Services
page has changed.

When you enable this option, theCheck Software Update Package Integrity task works
as follows:

■ If some physical files are missing on the file system in the old location, the task
re-downloads the required files to the old location but fails to relocate the files to the
new location. The overall task result is Failed. You need to re-run the task with this
option checked to successfully relocate the files to the new location.

■ The task successfully relocates the downloaded updates to the new location only when
the new location is accessible.

■ The task fails if the old or new location is inaccessible. No physical files are relocated.

5 Under Task Status, click New Schedule and specify a schedule on which to run the task.

Staging software bulletins
You can download a software bulletin and its associated updates to the Notification Server
computer.

See “About downloading and distributing software updates” on page 18.

Symantec recommends that you download only the bulletins that the target computers require.
On the Patch Remediation Center page, in the compliance reports, you can view how many
computers require an update.

After the updates are downloaded, you can create a software update policy to distribute the
updates to managed computers.
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See “Downloading and distributing software updates” on page 20.

When you choose to download a software bulletin, a task is created that downloads the
associated software updates. Note that only one instance of a download task may run at same
time for software update packages. A queue of download tasks may appear on Notification
Server or a package server, and the software update packages may be downloaded with a
delay. You can view the status of this task to troubleshoot the download of software updates.

See “Preparing your environment for Patch Management” on page 12.

Before you perform this step, esure that you have run the compliance and vulnerability reports.

See “Running compliance and vulnerability reports” on page 17.

To download software updates

1 In the Symantec Management Console, on the Actions menu, click Software > Patch
Remediation Center.

2 In the right pane, in the Show drop-down box, click Windows Compliance by Bulletin,
and then click the Refresh symbol.

These reports let you see which updates the client computers require.

3 Select the bulletins that you want to download.

For example, select the bulletins that have a high number in the Not Installed column.
You can select multiple items while holding down the Shift or Ctrl key.

4 Right-click the selected bulletins, and then click Download Packages.

You can close the status dialog box or leave it open in a new window; the download
continues in the background.

To view the status of a software updates download

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Software > Patch Management >
Download Software Update Package.

3 In the right pane, view the status of download tasks.

The next step is to view the results.

See “Viewing software update delivery results” on page 23.
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Replicating Patch
Management Solution for
Windows data in hierarchy

This chapter includes the following topics:

■ About replicating Patch Management Solution for Windows data in hierarchy

■ Replicating patch management language alerts

■ Replicating the software updates catalog

■ Replicating a software update policy

About replicating Patch Management Solution for
Windows data in hierarchy

Downloading software update catalog files (patch management metadata, or patch management
import files) to multiple Notification Server computers can consume considerable network
resources and time. Notification Server hierarchy features remove the need to download patch
management metadata files individually. You can download the files once to a single parent
Notification Server. Then you can use Patch Management Solution replication rules to send
the relevant data to any number of child Notification Server computers. The replicated data
on the child Notification Server computers is identical to the data on the parent.

Patch Management Solution supports only two-level hierarchy. A child Notification Server
computer cannot be a parent to another child.

A Package DistributionHierarchy Editable Property (HEP) allows you to control on the parent
Notification Server, if the Package Distribution section on the Windows Patch Remediation
Settings page is editable on the child Notification Server.
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If you enable this feature on the parent Notification Server, and then replicate it down to the
child Notification Servers, theWindows Patch Remediation Settings page becomes editable
on these child Notification Servers. This means that these settings can then be managed on
the child Notification Servers independently from the parent Notification Server.

If you disable this feature on the parent Notification Server, and the replicate this change down
the hierarchy, the Windows Patch Remediation Settings page becomes read-only on the
child Notification Servers and the corresponding settings then become inherited from the parent
Notification Server.

See “About hierarchy and data replication direction” on page 44.

Before you can replicate data, you must run the Patch Management Language Alerting rule.

See “Replicating patch management language alerts” on page 41.

See “Replicating the software updates catalog” on page 42.

See “Replicating a software update policy” on page 43.

Replicating patch management language alerts
Different Notification Server computers within a hierarchy may manage different patch
management language resources. The Patch Management Language Alerting replication
rule ensures that child Notification Server computers only receive data and software update
policies for their managed languages. This rule replicates information about the managed
languages of the child Notification Server computer up to the parent. You must run this rule
on a child before any attempt is made to replicate patch management data or software update
policies. A parent Notification Server computer must manage all of the languages that its
children require.

The rule is preconfigured to run daily at 20:00.

See “About replicating Patch Management Solution for Windows data in hierarchy” on page 40.

To replicate patch management language alerts on a schedule

1 On the child Notification Server computer, in the Symantec Management Console, on the
Settings menu, click Notification Server > Hierarchy.

2 In the left pane, click Hierarchy > Hierarchy Management.

3 In the right pane, click the Replication tab.

4 Expand the Resources section.

5 Click Patch Management Language Alerting.

6 Click the Edit symbol.

7 Set a schedule to run before running other patch management replication functions.
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Replicating the software updates catalog
Downloading Windows patch management software update catalog files to multiple Notification
Server computers can consume considerable network resources. Notification Server hierarchy
features remove the need to download patch management software update catalog files
individually. You can download the files once to a single parent Notification Server computer.
Then you can use the Patch Management Import Data Replication for Windows rule to
send the relevant data to any number of child Notification Server computers. The replicated
data on the child Notification Server computers is identical to the data on the parent, depending
on managed languages.

The rules are preconfigured to run daily at 23:00.

Warning: You must configure the Patch Management Language Alerting rule to run on the
child Notification Server computer before the software catalog data replication.

See “Replicating patch management language alerts” on page 41.

See “About replicating Patch Management Solution for Windows data in hierarchy” on page 40.

To replicate the software updates catalog on a schedule

1 On the parent Notification Server computer, in the Symantec Management Console, on
the Settings menu, click Notification Server > Hierarchy.

2 In the left pane, select Hierarchy > Hierarchy Management.

3 In the right pane, click the Replication tab.

4 Expand the Resources section.

5 Click Patch Management Import Data Replication for Windows.

6 Click the Edit symbol.

7 Under Replicate, select Differential if you want to only replicate changed or new data.
Select Complete to send all Windows patch management software update catalog files
to child Notification Server computers each time the task runs.

8 Under Schedule, set the schedule a few hours after the Patch Management Language
Alerting rule schedule.

9 UnderData Verification, specify a percentage of data to be verified during each replication,
and check Verify data integrity if you want.

10 Turn on the rule.

11 Click Save changes.
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Replicating a software update policy
Software update policies distribute software updates to the target computers.

See “Downloading and distributing software updates” on page 20.

In Patch Management Solution 7.1 and later, the software update policies are always replicated
to child Notification Server computers. Replication occurs on the default Notification Server
replication schedule.

All software update policies are replicated to child Notification Server computers on the default
replication schedule. If you want, you can also manually replicate a policy immediately.

Another option is to replicate a policy immediately after you create it. To do this, check the
Immediately replicate that policy down the hierarchy option in the Distribute Software
Updates wizard.

Replicating software update policies does not replicate the actual software update files. Child
Notification Server computers download the needed software update files from the vendor.

You can replicate a single policy or a collection of policies. If you want to manually replicate
a collection of policies, you must create a new folder and move policies under this folder. Then
you can right-click the folder and launch replication.

Warning: Before you replicate software update policies, ensure that the Patch Management
Language Alerting rule and the Patch Management Import Data Replication rule have run.

See “Replicating patch management language alerts” on page 41.

See “Replicating the software updates catalog” on page 42.

See “About replicating Patch Management Solution for Windows data in hierarchy” on page 40.

To replicate a software update policy manually

1 In the Symantec Management Console, on the Manage menu, click Policies.

2 In the left pane, expand Software > Patch Management > Software Update Policies.

3 Right-click a policy or a folder, and then click Hierarchy > Replicate Now.
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Technical reference

This appendix includes the following topics:

■ About hierarchy and data replication direction

■ About Patch Management Solution security roles

About hierarchy and data replication direction
Patch Management Solution for Windows and Patch Management Solution for Linux support
the hierarchy and the replication features of the Symantec Management Platform. These
features let you create settings, schedules, and other data at the top-level Notification Server
computer and replicate them to child-level Notification Server computers.

Patch Management Solution for Mac does not support replication.

See “About replicating Patch Management Solution for Windows data in hierarchy” on page 40.

Table A-1 Items that are replicated by the default Notification Server replication schedule
with no custom replication rules

Replication directionItem

DownAll the server tasks settings and schedules:

■ Check Software Update Package Integrity
■ Import Patch Data for Windows/Red Hat/SUSE/CentOS

DownRun System Assessment Scan on Windows/Linux Computers task settings and
schedules

DownWindows/Linux System Assessment Scan policy settings

DownWindows/Red Hat/SUSE/CentOS Patch Remediation Settings policy

DownDefault Software Update Plug-in Policy settings
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Table A-1 Items that are replicated by the default Notification Server replication schedule
with no custom replication rules (continued)

Replication directionItem

DownSoftware update plug-in install, upgrade, and uninstall policy settings

DownSoftware update policies

Table A-2 Items that are replicated with custom replication rules

DescriptionReplication
direction

Item

This information is replicated when the Patch Management
Language Alerting rule is enabled.

UpLanguage support information

(Patch for Windows only)

This information is replicated when the Patch Linux OS
Channel Resource Replication Rule is enabled.

UpOS inventory data

(Patch for Linux only)

This information is replicated when the Patch Management
Import Data Replication for Windows/Red
Hat/SUSE/CentOS rules are enabled.

For Windows, only the updates and bulletins that are
associated with the child computer's supported languages
are replicated.

For Linux, only the metadata for the channels that are relevant
to the child Notification Server's client computers is replicated.

DownPatch management metadata

This information is replicated when the Patch Compliance
Summary Replication rule is enabled.

The system assessment scan result is replicated up as a
summary.

UpCompliance summary

About Patch Management Solution security roles
You can assign the following security roles to Symantec Management Console users:

■ Patch Management Administrators

■ Patch Management Rollout

Users with thePatchManagement Administrators role have full access to Patch Management
Solution functionality, but no access to the rest of the Symantec Management Console.
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Users with the Patch Management Rollout role have limited access to the following Patch
Management Solution functionality:

■ Software update policies

■ Reports

■ Patch Remediation Center page

Users with the Patch Management Rollout role can perform the following actions:

■ Enable, disable, and change settings in the software update policies.

■ View reports.

See “About Patch Management Solution for Windows” on page 7.
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Check Software Update

Package Integrity task

A task that checks that all software update packages have the correct new settings
and values. This task runs when the package or program settings in the Patch
Remediation Settings policies have been changed.

custom severity level A user-defined level of importance that is applied to software updates.

data replication A one-way transfer of data between Notification Server and a client computer or
another Notification Server.

Distribute Software

Updates wizard

A wizard that is used to create software update policies.

patch An update or a hot fix that is used to improve or fix a software product.

Patch Management

Import Data Replication

for Windows rule

A component of Patch Management Solution that is used to send the patch
management software update catalog files to any number of child Notification Server
computers after these files are downloaded to a parent Notification Server computer.

patch management

metadata

The information about the available updates.

Patch Remediation

Center page

A page in the Symantec Management Console that lists all available software
updates. From this page, users download (stage) the files and create Software
Update policies.

remediation status

report

An account that summarizes and details software associations and activities.

software bulletin A collection of software update patches that are released in a bundle.

software update plug-in A component of Patch Management Solution that handles the patch management
functionality on a client computer. When a client computer requires a certain software
update, the update is sent from the Notification Server computer to the software
update plug-in. The software update plug-in ensures that the update is applicable
and not already installed, and then installs it.

software update policy An element of Patch management that distributes software updates to the client
computers.

Software Update Policy

Wizard

A wizard that is used to create the executables that deliver software updates to
managed computers.

stage To prepare a software bulletin or update for distribution. When a user stages a
software bulletin, all included software updates are downloaded from the vendor.
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system assessment

scan

A process that is used to periodically inventory operating systems, applications,
and installed patches on the client computers that have the software update plug-in
installed.

targeted deployment A process of deploying a software update to a client computer that specifically
needs that particular update.

Windows remediation

settings

The configuration of the way the Windows software updates are to be distributed.
The settings include package server settings, program execution options, and
language settings.
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