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Introducing Real-Time
System Management

This chapter includes the following topics:

■ About Real-Time System Management

■ Where to get more information

About Real-Time System Management
The Real-Time Console Infrastructure software provides the necessary infrastructure for real
time management using the Real-Time System Manager. Also, Real-Time Console Infrastructure
lets you perform one-to-many out-of-band management tasks on a group of computers that
support DASH or AMT.

With Real-Time System Manager, you can view detailed real time information about the
managed computers and remotely perform various administrative tasks. For example, you
can collect the hardware and the configuration inventory even if the computers are turned off.
Also, you can restart the computer, reset a password, run a port scan, terminate a process.
Real-Time System Manager also lets you run some of the management tasks on a group of
computers, immediately or on a schedule.

Using Real-Time System Management with properly configured out-of-band capable computers,
you can manage the computers that are turned off or that failed to load an operating system.
Managing computers remotely out of band lets you significantly reduce the number of desk-side
visits.

Some of the supported out-of-band features are as follows:

■ Remote boot through Integrated Drive Electronics Redirection (IDE-R)
See “Booting a computer from remote location using IDE-R” on page 31.

■ Remote console redirection
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See “Starting a Serial-over-LAN (SOL) remote control session” on page 30.
See “Running a Keyboard-Video-Mouse (KVM) remote control session” on page 27.

■ Hardware filtering of network traffic (Circuit Breaker) using Intel vPro System Defense
technology
See “Blocking network traffic from and to the computer ” on page 32.

■ Hardware alerts for Intel AMT and DASH
See “Updating Intel AMT and DASH alert settings ” on page 19.

Where to get more information
Use the following documentation resources to learn about and use this product.

Table 1-1 Documentation resources

LocationDescriptionDocument

The Supported Products A-Z page, which is available at
the following URL:

https://www.symantec.com/products/products-az

Open your product's support page, and then underCommon
Topics, click Release Notes.

Information about new
features and important
issues.

Release Notes

■ The Documentation Library, which is available in the
Symantec Management Console on the Help menu.

■ The Supported Products A-Z page, which is available
at the following URL:
https://www.symantec.com/products/products-az
Open your product's support page, and then under
Common Topics, click Documentation.

Information about how to
use this product,
including detailed
technical information and
instructions for
performing common
tasks.

User Guide
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Table 1-1 Documentation resources (continued)

LocationDescriptionDocument

The Documentation Library, which is available in the
Symantec Management Console on the Help menu.

Context-sensitive help is available for most screens in the
Symantec Management Console.

You can open context-sensitive help in the following ways:

■ Click the page and then press the F1 key.
■ Use the Context command, which is available in the

Symantec Management Console on the Help menu.

Information about how to
use this product,
including detailed
technical information and
instructions for
performing common
tasks.

Help is available at the
solution level and at the
suite level.

This information is
available in HTML help
format.

Help

In addition to the product documentation, you can use the following resources to learn about
Symantec products.

Table 1-2 Symantec product information resources

LocationDescriptionResource

Knowledge BaseArticles, incidents, and
issues about Symantec
products.

SymWISE Support
Knowledgebase

Unified Help SystemAll available IT
Management Suite and
solution guides are
accessible from this
Symantec Unified Help
System that is launched
on cloud.

Cloud Unified Help System
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Table 1-2 Symantec product information resources (continued)

LocationDescriptionResource

The links to various groups on Connect are as follows:

■ Deployment and Imaging
■ Discovery and Inventory
■ ITMS Administrator
■ Mac Management
■ Monitor Solution and Server Health
■ Patch Management
■ Reporting
■ ServiceDesk and Workflow
■ Software Management
■ Server Management
■ Workspace Virtualization and Streaming

An online resource that
contains forums, articles,
blogs, downloads,
events, videos, groups,
and ideas for users of
Symantec products.

Symantec Connect
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Running one-to-many tasks

This chapter includes the following topics:

■ About one-to-many tasks

■ Managing the power state of computers remotely

■ Using the Restore State power action

■ Automatically turning off computers in critical state

■ Collecting and viewing Intel AMT, DASH, and IPMI inventory

■ Updating BIOS settings

■ Resetting a local user password on multiple computers

■ Managing a process on multiple computers

■ Managing a service on multiple computers

■ Updating Intel AMT and DASH alert settings

■ Booting multiple computers from a remote location

■ Filtering the network traffic on multiple computers

About one-to-many tasks
One-to-many tasks let you manage multiple computers at the same time, but limit the options
that are available. Full list of remote management features is available using real time
one-to-one management.

One-to-many actions are carried out in a form of scheduled tasks. You must install Symantec
Management Agent on the client computer for in-band management. For out-of-band
management, client computers also must support DASH or AMT technology.

2Chapter



For example, you can perform the following one-to-many tasks:

■ Boot a group of computers from either a PXE, a floppy/HDD/CD device, or an image that
is located in a remote location.

■ Block network traffic to and from the client computer's operating system.

■ Remotely reset a password for a local user account on a group of computers.

■ Remotely start or stop a process on a group of computers.

■ Perform various power operations: start, stop or reboot a group of computers.

See “List of available operations” on page 42.

For more information on how to discover out-of-band capable computers, see
http://www.symantec.com/docs/DOC6628.

Managing the power state of computers remotely
You can manage the power state of client computers remotely using WMI, Intel AMT, IPMI,
and DASH technologies.

For example, you can turn on the computers before delivering a software package. You can
also turn off the computers that have sent critical SNMP alerts to Notification Server.

See “Automatically turning off computers in critical state” on page 14.

Note: A graceful Reboot and Power Off through the WMI is always tried first. If the WMI
operation fails, the Power Off, Reboot/Reset, and Restore State actions perform a hard
shutdown (losing all unsaved data) through DASH, IPMI, or Intel AMT. To perform a hard
shutdown, the target computers must support and be properly configured to use these
technologies. For Intel AMT 9.0 and higher, graceful shutdown is performed through WSMan.

To manage the power state of computers remotely

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time Console Infrastructure
> Power Management.
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3 In the right pane, under Power action, select the power action to execute.

Choose from the following actions:

Turns on the target computers using the out-of-band management
technology (DASH, IPMI, or Intel AMT) that the target computers
are configured to use.

Power On

Uses graceful shutdown to turn off the target computer. WMI is used
for pre Intel AMT 9.0. For later technology, WSMan is used.

Power Off

Attempts to restart the target computer through WMI. If WMI fails,
a hard reset is performed using one of the out-of-band management
technologies.

Reboot/Reset

You can use this power action when you include the power
management task in a server job. You cannot use this power action
in a standalone task. This power action lets you restore the power
state that you changed by running another power management task
earlier in the server job.

For example, you can run the Power On action, and later in the
server job, you can run the Restore State action. The latter turns
off the computers that were turned off, but the computers that were
turned on stay turned on.

See “Using the Restore State power action ” on page 13.

Restore State
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4 (Optional) Configure the advanced boot options.

The options are as follows:

Prevents the users from interacting with the target computer.Lock client keyboard

Prevents the users from turning off and restarting the computer
using the buttons that are located on the computer case.

Disable power buttons

Lets you start the computer without the startup password.

Note:Please note, that there are several types of BIOS startup
password. The behavior of the Bypass computer's Startup
Password option varies depending on the manufacturer and
the AMT version. Some computers do not support bypassing
the BIOS password for AMT management.

Bypass computer's startup
password

When the computer starts, it can send the detailed progress
PET events to the SNMP server.

Use the Update Out-of-Band Alert Settings task to configure
the event's destination address.

See “Updating Intel AMT and DASH alert settings ” on page 19.

Client's firmware transmits all
progress PET events

The availability of these features depends on the hardware that you use.

5 Click Save changes.

6 Run the task once or on a schedule.

For more information, view the topics about running and scheduling tasks in the Symantec
IT Management Suite powered by Altiris technology User Guide.

Choose a connection profile that is configured with correct WMI, DASH, IPMI, or Intel
AMT credentials.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Using the Restore State power action
The Restore State power action of the Power Management task returns computers to the
power state they were in, before the previous power action ran.

The Restore State power action lets you run different jobs. For example:

■ Run the Power On action to turn on computers.

■ After that, run another task.

■ After that, run the Restore State task, to restore the power state of the computers.
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In this example, if a computer was turned off, the Restore State action turns off the computer.
If a computer was turned on, the Restore State action keeps the computer turned on.

The Sample Job is an example of the Restore State power action usage in a job. For this
power action to work, you must configure the Task Input to use the output from the previous
power management task, as shown in the sample job. You can use the Restore State power
action only in a job.

To use the Restore State power action

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand Samples > Real-Time Console Infrastructure > Sample Job.

3 On the Sample Job page, under Jobs/Tasks, click Run "Restore power state".

4 Under Task Input, see how the task input is configured.

Automatically turning off computers in critical state
Using Real-Time Console Infrastructure with Event Console lets you automatically turn off the
computers that have sent critical SNMP alerts (for example, the hardware failure alerts) to
Notification Server. If the computers support and are properly configured to use any of the
out-of-band management technologies, you can remotely turn off the computers even if the
computers have failed to load an operating system.

See “Updating Intel AMT and DASH alert settings ” on page 19.

To automatically turn off computers in critical state

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, expand Monitoring and Alerting > Alert Rule Settings.

3 In the right pane, click the Task Rules tab.

4 On the toolbar, click Add.

5 Under Rule, on the toolbar, click Add > Alert protocol.

6 In the Select comparison drop-down list, click equals.

7 In the Enter value drop-down list, click Simple Network Management Protocol.

8 Under Rule, on the toolbar, click Add > Alert severity.

9 In the Select comparison drop-down list, click equals.

10 In the Enter value drop-down list, click Critical.

11 Under Task, click New.

12 In the Create New Task dialog box, in the left pane, click Real-Time Console
Infrastructure > Power Management.
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13 In the right pane, click Power Off.

14 Click OK.

15 Turn on the task rule.

At the upper right of the page, click the colored circle, and then click On.

16 Click Save.

Collecting and viewing Intel AMT, DASH, and IPMI
inventory

You can collect the hardware and the configuration inventory even if the computers are turned
off. The inventory is stored in the NVRAM of properly configured Intel AMT and DASH
computers. On computers with IPMI, the inventory is obtained from the Baseboard Management
Controller.

To collect Intel AMT, DASH, or IPMI inventory from a client computer

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, click System Jobs and Tasks > Real-Time Console Infrastructure >
Get Out-of-Band Inventory.

3 Run the task once, or on a schedule.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Choose a connection profile that is configured with correct Intel AMT, DASH, or IPMI
credentials.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

To view the Intel AMT, DASH, or IPMI inventory for a client computer

1 Open the Resource Manager for a computer by double-clicking on a specific resource
that is found in a filter.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

2 On the View menu, click Inventory.

3 In the tree view pane, expand the Real-Time Console Infrastructure folder and select
an inventory data class.

You can also view out-of-band inventory from the Reports page.
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To view Intel AMT, DASH, and IPMI inventory using a report

1 Click Reports > All reports.

2 In the left pane, click Reports > Remote Management > Real-Time Console
Infrastructure > Out-of-band Harware Inventory.

3 In the right pane, on the Out-of-Band Hardware Inventory page, under Parameters,
choose the setting for the report that you want to view.

Updating BIOS settings
The Update BIOS settings task lets you remotely view and update the BIOS settings of the
target computers that can be managed through the DASH technology. To identify these
computers, you must collect the DASH settings inventory.

Note: After you update BIOS settings, you must restart the target computers for the settings
to take effect. You can combine the BIOS management and power management tasks into a
job.

You can also manage BIOS settings on a single computer in real time.

Run the Get Out-of-Band Inventory task.

See “Collecting and viewing Intel AMT, DASH, and IPMI inventory ” on page 15.

In the Resource Manager, in the Inventory view, expand Real-Time Console Infrastructure
> RTCI DASH Registered profile. If the computer supports WS-MAN BIOS Management,
the BIOS Management profile is displayed on this page.

To update BIOS settings

1 In the Symantec Management Console, on the Manage menu, click Jobs and Taks.

2 In the left pane, expand System Jobs and Tasks > Real-Time Console Infrastructure
> Update BIOS Settings.

3 Under the Select and configure BIOS settings, add the settings that you want to modify.

4 Click Save changes.

5 Run the task once or on a schedule.

6 Restart the target computers to apply the new BIOS settings.

Note: If BIOS is password protected, Symantec recommends, that you create a job that
includes the Set Administrator Password task and the Update BIOS settings taks

See “Managing the power state of computers remotely ” on page 11.
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Resetting a local user password on multiple
computers

You can reset the password for a local user on multiple computers at a time.

You can also perform this task on a single computer in real time.

You can also use Real-Time System Management to reset the password for a domain user.

See “Resetting a domain user password” on page 39.

To reset a local user password on multiple computers

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time System Manager.

3 Click Password Management.

4 Type the user name that you want to reset the password for in the following format:
COMPUTER\User

5 Type and confirm a new password.

6 Type the name and password of an administrative user with permissions to manage the
specified user account.

7 Click Save changes.

8 Run the task once or on a schedule.

FFor more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Managing a process on multiple computers
You can run or stop a process on multiple computers at a time.

You can also manage processes on a single computer in real time.

See “About one-to-one real time management” on page 24.

To manage a process on multiple computers

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time System Manager.

3 Click Process Management.
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4 Type the name of the process to run or stop.

Example: AeXNSAgent.exe

You can also type a full UNC path (Example: \\server\share\AeXNSAgent.exe) as long
as you have the authentication infrastructure to support that. This means that either you
have no authentication (null session shares) or you have Kerberos with the intermediate
computer trusted for delegation, and delegatable credentials for the user.

5 Select an action.

6 Click Save changes.

7 Run the task once or on a schedule.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Managing a service on multiple computers
You can start, stop, restart a service on multiple computers at a time. You can change the
startup mode of a service.

You can manage services on a single computer in real time.

See “About one-to-one real time management” on page 24.

To manage a service on multiple computers

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time System Manager.

3 Click Service Management.

4 Type the name of the service to manage.

Example: cisvc

5 Select an action.

6 Click Save changes.

7 Run the task once or on a schedule.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.
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Updating Intel AMT and DASH alert settings
Intel AMT and DASH alerts help you respond to memory faults, temperature issues, hard drive
warnings, chassis intrusion, and so forth. These alerts help you fix issues before they become
destructive.

The Update Out-of-Band Alert Settings task lets you remotely update the Intel AMT and
DASH alert settings on properly configured client computers with Intel AMT or DASH.

You can configure the following alert settings:

■ Where to send the alerts.

■ Which alerts to send.

■ Which alerts to log.

You can also run this task on the computers that are turned off.

To update Intel AMT and DASH alert settings

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time Console Infrastructure
> Update Out-of-Band Alert Settings.

3 Under Subscription settings, type the SNMP server’s IP address. This value is applied
to computers with Intel AMT.

By default, the task is configured with the Notification Server computer’s IP address. In
this case, Event Console (a component of Notification Server) accepts and displays the
SNMP events that the client computers send.

For more information, view topics about alert management in the Altiris Monitor Solution
for Servers from Symantec User Guide.

4 Type the SNMP community string.

Example: public

5 Type the destination URI for DASH alerts.

By default, the value is set to the Notification Server’s Web service event listener, which
is part of the Pluggable Protocol Architecture component: http://<Notification Server

IP>/Altiris/WSEL/wsel.aspx

Currently, DASH does not support sending alerts through an HTTPS connection. If your
Notification Server is installed on a secure Web site, configure the wsel.aspx file so that
it can be accessed through HTTP.
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6 Select the DASH alerts delivery mode.

The options are as follows:

The DASH client computer does not verify if the event listener accepted
the alert.

Push

The DASH client computer verifies if the event listener accepted the
alert. If no reply is received from the event listener, the client computer
can unsubscribe this particular event filter (vendor dependent).

Push with acknowledge

7 Under Select and configure event filters, click Add, select the alerts that you want to
configure with the task, and then click OK.

8 Under Select and configure event filters, select one or more alerts, and, on theActions
menu, click what you want to do with this alert.

The options are as follows:

Activates the alert. When the alert triggers, a message is sent to the
destination address that you provided in the Subscription settings section.

Subscribe

Deactivates the alert, but does not remove it from the memory.Unsubscribe

Removes the alert from the client computer’s memory and reclaims space.Remove from client

9 (Optional) If the client computer does not have enough free space to fit all of the alerts
that you configured. To allow partial alert subscription, check Allow partial alert
application.

10 (Optional) To remove all previous alert subscriptions from the client computer and reclaim
space before applying new subscriptions, check Remove 3rd party filters and alert
subscriptions.
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11 Click Save Changes.

12 Run the task once or on a schedule.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Choose a connection profile that is configured with correct Intel AMT, DASH, or WMI
credentials.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Note:Alerts that are marked as critical power down the client computers. You can configure
which alerts are considered critical.

Booting multiple computers from a remote location
(Intel AMT, and DASH)

You can boot the computers with DASH or Intel AMT from a remote disk drive or image.

You can also perform this task on a single computer in real time.

See “Booting a computer from remote location using IDE-R” on page 31.

To boot multiple computers from a remote location

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time System Manager.

3 Click Boot Redirection.

4 In the right pane, click a device to boot from.

5 To start the computer from an image, click Browse to navigate to a network share where
the image is located.

Warning: Do not use an image file that is placed on a CD or a DVD-ROM to start the
computer. Use only the images that are stored on local or network hard disk drives.
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6 Click Save changes.

7 Run the task once or on a schedule.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.

Warning: If there is already an active IDE-R session, it is terminated when the task runs.

Filtering the network traffic on multiple computers
(Intel AMT only)

The Intel AMT network filtering (Circuit Breaker) functionality lets you block network traffic from
and to the target computers' operating systems. For example, you can use this feature to
isolate infected computers from the network.

Note: Network Filtering works only if both the client operating system and Intel AMT network
settings are configured to use Dynamic Host Configuration Protocol (DHCP).

Some ports stay open when network filtering is active.

See “Network filtering ports and settings” on page 60.

You can customize the ports that you want to stay open.

See “Modifying the list of open network filtering ports” on page 40.

You can also manage network traffic on a single computer in real time.

See “Blocking network traffic from and to the computer ” on page 32.

To filter the network traffic on multiple computers

1 In the Symantec Management Console, on the Manage menu, click Jobs and Tasks.

2 In the left pane, expand System Jobs and Tasks > Real-Time System Manager.

3 Click Network Filtering.

4 If you want to block network traffic to and from the operating system, do the following:

■ Click Filter network traffic other than to and from the Notification Server.

■ Choose if you want to use the default solution filtering settings or browse for a custom
.xml file.

■ (Optional) To prevent the client computer from sending malicious packets, check
Enable anti-spoofing filter. This feature forces the identity verification of outgoing
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network traffic and drops packets if the computer is suspected of originating malicious
attacks that are known as IP spoofing.

5 (Optional) To protect the client computer from network flooding, click Limit the number
of PING packets to, and type the number of packets per second allowed to pass through
the Intel AMT network filter.

Default: 10 packets per second.

6 (Optional) To disable network filtering, click Allow all network traffic.

7 Click Save changes.

8 Run the task once or on a schedule.

For more information, view the topics about connection profiles in the Symantec IT
Management Suite powered by Altiris technology User Guide.
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Managing resources
one-to-one in real time

This chapter includes the following topics:

■ About one-to-one real time management

■ Initiating real time connection

■ Turning off, turning on, or restarting a client computer

■ Running a Keyboard-Video-Mouse (KVM) remote control session

■ KVM Viewer power actions

■ Starting a Serial-over-LAN (SOL) remote control session

■ Booting a computer from remote location using IDE-R

■ Blocking network traffic from and to the computer

■ Configuring the Intel AMT device settings

■ Viewing client computer logs

■ Managing BIOS settings

■ Managing the properties of Symantec Management Agent in real time

■ Activating a virtual layer

About one-to-one real time management
Real time one-to-one management allows you to use the full list of remote features available
in Real-Time System Manager.
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For example, you can perform the following one-to-one tasks:

■ Take full control of the client computer with active keyboard, display and mouse.

■ View detailed information and audit dynamic proccesses.

■ Manage BIOS settings with console view.

■ Change the NS server that the client computer is assigned to.

■ Manage software virtualization layers.

Real-Time System Manager can connect to the target computer using the following protocols:
WMI, Intel AMT, DASH, SNMP, IPMI. Connection protocols define which features are available.

See “List of available operations” on page 42.

Setting up the connection profiles and credentials:
http://www.symantec.com/docs/HOWTO62827.

With Real-Time System Manager, you can manage computers in-band and out-of-band.
Out-of-band means that computer is not turned on or the operating system is not running. You
can manage a computer in such state if the client computer has AMT, DASH, or IPMI technology
present and is configured for out-of-band management.

For more information on how to discover out-of-band capable computers, see
http://www.symantec.com/docs/DOC6628.

Initiating real time connection
There are three different ways to initiate a real time connection to a client computer that you
want to manage.

You can open a management session in a pop-up dialog box, while maintaining your current
position in the Symantec Management Console.

To connect to a client computer using a pop-up dialog box

1 In the Symantec Management Console, on theActionsmenu, clickRemoteManagement
> Real-Time Management.

2 On the Real-Time Management page, type the host name or the IP of the computer that
you want to connect to, and then click Connect.

You can use the Real-Time System Manager Portal, that also displays the portal actions that
are available to you before establishing a real time connection.

See “Additional functionality and portal actions available in Real-Time System Manager”
on page 39.
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To connect using the Real-Time System Manager Portal

1 In the Symantec Management Console, on the Home menu, click Remote Management
> Real-Time System Manager Portal.

2 On the Real-Time System Manager Portal page, in the Manage Web Part, in the
Computer text box, type the IP address or the name of the computer that you want to
manage, and then click Connect.

You can initiate a real time connection to a client computer from any resource list in the
Symantec Management Console.

To initiate real time connection from a resources list

1 Open a list of computer resources.

2 Right-click the computer resource, click Remote Management, and then click one of the
following:

■ Manage

■ Manage Power State and Redirection
See “Turning off, turning on, or restarting a client computer” on page 26.

■ Manage Users

■ Port check
See “Running the port check” on page 40.

■ Trace Route

Turning off, turning on, or restarting a client computer
You can view the power state of a remote computer, and then turn off, turn on, or restart the
client computer remotely.

Note: The availability of power commands depends on the current power state and the
technologies (WMI, Intel AMT, DASH, IPMI) that are available on the target computer. For
example, WMI power management is limited to Reboot and Power off commands and can
be performed on a computer with a running operating system. This limitation is because WMI
is an in-band functionality.

For client computers with properly configured out-of-band technologies, you can configure the
Redirection options before restarting or turning on the client computer.
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Turning off, turning on, or restarting a client computer

1 Connect to the client computer, that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, underReal-Time Consoles, expandReal-Time SystemManager
> Management Operations > Manage Power State and Redirection.

3 In the right pane, on the Manage Power State and Redirection page, under Remote
power management, select a power action.

4 (Optional) To perform a graceful restart or shutdown through WMI, check Allow user to
save data before power operation.

If the WMI operation fails, the hard shutdown of the target computer is performed
out-of-band using DASH, Intel AMT, or IPMI. The hard shutdown is possible if any of these
technologies are supported and properly configured on the target computer.

5 Click Run task now.

Running a Keyboard-Video-Mouse (KVM) remote
control session

Keyboard-Video-Mouse remote control lets you access any client computer and manage it
in-band or out-of-band. This type of remote control does not depend on any features of the
operating system, it is fully hardware-based and it can bypass virus protection firewall. It lets
you troubleshoot a client computer remotely, with full access to video and to input devices.

Note: If the User Consent option is enabled on a client computer, the client computer user
must provide to the administrator a six-digit code that pops up once a remote control session
is requested.

Client computer user is always aware of an active remote control session by a specific frame
around the screen.

If the operating system of the client computer is turned off, the booting process can be redirected
to an external location or a network drive.

The prerequisites to run the remote control session are the following:

■ Intel® vPro Technology (Intel AMT), version 6 or later

■ Integrated Intel video adapter

■ Power cable plugged in

■ Network cable plugged in
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■ AMT and WS-MAN protocols are enabled in selected connection profile.

Note that remote control sessions must be allowed on the client computer to start the KVM
remote control session.

Note: You can remotely access a client computer with Intel AMT below version 6 using Intel
AMT feature Serial-over-LAN (SOL).See “Starting a Serial-over-LAN (SOL) remote control
session” on page 30.

Note that remote control sessions must be allowed on the client computer (in order) to start
the KVM remote control session.

To run a KVM remote control session

1 In the Symantec Management Console, on the Home menu, click Remote Management
> Real-Time System Manager Portal.

2 On the Real-Time System Manager Portal page, in the Manage Web Part, in the
Computer text box, type the IP address of the computer that you want to manage, and
then click Connect.

3 On the Resource Manager page, in the right pane, under Supported protocols, click
Default Connection Profile.

4 In the Select connection profile dialog box, enable AMT and WSMAN protocols, and
then click OK.

For more information on setting up the connection profiles and credentials, see:
http://www.symantec.com/docs/HOWTO62827

5 In the navigation pane, underReal-Time Consoles, expandReal-Time SystemManager
> Management Operations, and then click Remote Control.

28Managing resources one-to-one in real time
Running a Keyboard-Video-Mouse (KVM) remote control session

http://www.symantec.com/docs/HOWTO62827


6 In the right pane, under Remote control options, click Start Remote Control.

7 In the KVM viewer window, perform any of the following tasks:

ActionTask

On the upper toolbar, clickConnect/Disconnect.To activate or deactivate KVM Viewer session

1. On the upper toolbar, click Power action.

2. In the Power Actions dialog box, select the
required power operation. List of applicable power
actions is automatically detected according to
current power state capabilities of the client
computer.

See “KVM Viewer power actions” on page 29.

To run power actions

On the upper toolbar, you can set KVM Viewer
image compression and color mode.

You can also set the screen presentation mode
either to automatically fit the screen size or show
the actual image size.

To configure the screen view

KVM Viewer power actions
After clicking Power action button in top toolbar of the KVM Viewer windows, the Power
Actions dialog box opens, where you can select different power operations. List of applicable
power actions is automatically detected according to current power state capabilities of the
client computer

Table 3-1 KVM Viewer power actions

DescriptionActions

Completely turns off the client computer and then
turns it back on again.

Power Cycle

Turns off client computer.Power Off

Turns on the client computer.Power On

Turns on the client computer and enters BIOS.Power On to BIOS

Turns on the client computer and enters BIOS in
Terminal mode.

Power On to BIOS (Terminal)

Restarts the client computer.Reset
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Table 3-1 KVM Viewer power actions (continued)

DescriptionActions

Restarts the client computer and enters BIOS.Reset to BIOS

Restarts the client computer and enters BIOS in
Terminal mode.

Reset to BIOS (Terminal)

See “Running a Keyboard-Video-Mouse (KVM) remote control session” on page 27.

Starting a Serial-over-LAN (SOL) remote control
session

(Intel AMT only)

The Intel AMT feature Serial-over-LAN (SOL) redirects the remote computer's screen text
output to a virtual serial port that Real-Time System Management can read and display in the
Symantec Management Console. For example, this feature lets you access the remote
computer's BIOS using the remote terminal window and change BIOS settings, or watch the
boot process.

To use this feature with the Intel AMT client computers that are configured in secure mode,
their Fully Qualified Domain Name (FQDN) must be resolved correctly on the Notification
Server computer. Also, you must configure the connection profile to use the right certificates
for authentication.

If the SOL session cannot start, make sure that the Intel AMT device is configured to allow
this functionality.

See “Configuring the Intel AMT device settings ” on page 34.

To start a SOL remote control session

1 Connect to the client computer that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Management Operations > Manage Power State and Redirection.
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3 To create a new SOL session after you turn on the target computer, in the right pane,
under Redirection options, check Display task progress and remotely control
computer.

Note that, if the session is closed from the client side (for example, the computer is restarted
locally), the Remote Control Terminal is not closed automatically. In this case, you must
close the terminal window manually.

Note:Boot redirection to local devices (PXE server, CD-ROM, local HDD) is not supported
during a SOL remote control session. You can only redirect the boot to a remote device
(CD or floppy image, remote CD-ROM, or to a server).

Warning: If there is already an active SOL session, it is terminated when the task runs.

4 (Optional) To change the BIOS settings remotely during the SOL session, check Enter
BIOS on startup.

Note that, when you exit the BIOS on the client computer, the client computer stops
sending the information to the terminal. However, theRemote Control Terminalwindows
is not closed automatically. In this case, you must close the terminal window manually.

5 Turn on or restart the computer.

See “Turning off, turning on, or restarting a client computer” on page 26.

To view the details of an active SOL session

1 On the Manage Power State and Redirection page, click Details.

2 (Optional) To disconnect an active SOL session, in the Redirection Details dialog box,
click Stop remote control.

3 Click Close.

Booting a computer from remote location using IDE-R
(Intel AMT and DASH)

The IDE-R feature of Intel AMT and DASH technologies lets you boot the target computer
from a remote disk drive or image. This feature lets you diagnose and fix the operating system
problems.

To use this feature with the Intel AMT client computers that are configured in secure mode,
their Fully Qualified Domain Name (FQDN) must be resolved correctly on the Notification
Server computer. Also, you must configure the connection profile to use the right certificates
for authentication.
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If the IDE-R session cannot start, make sure that the Intel AMT device is configured to allow
this functionality.

See “Configuring the Intel AMT device settings ” on page 34.

You can also run this task on multiple computers, immediately or on a schedule.

See “Booting multiple computers from a remote location ” on page 21.

To start an IDE-R session

1 Connect to the client computer you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Management Operations > Manage Power State and Redirection.

3 In the right pane, on theManage Power State and Redirection page, underRedirection
options, check Perform boot from, and then, in the drop-down menu, click the device
to boot from.

Warning: If there is already an active IDE-R session, it is terminated when the task runs.

4 To start the computer from an image, on the right, click Browse to navigate to a network
share where the image is located.

Warning: Do not use an image file that is placed on a CD or a DVD-ROM to start the
computer. Use only the images that are stored on local or network hard disk drives.

5 Turn on or restart the computer.

See “Turning off, turning on, or restarting a client computer” on page 26.

To view details of active IDE-R session

1 On the Manage Power State and Redirection page, under Redirection options, click
Details.

2 (Optional) To disconnect a boot device, in the Redirection Details dialog box, click Stop
redirection.

3 Click Close.

Blocking network traffic from and to the computer
(Intel AMT only)
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The network filtering (Circuit Breaker) functionality on Intel AMT lets you block network traffic
from and to the target computer's operating system. For example, you can use this feature to
isolate an infected computer from the network.

Note:Network filtering works only if both client operating system and Intel AMT network settings
are configured to use Dynamic Host Configuration Protocol (DHCP).

Note: Some ports stay open when network filtering is active.

See “Network filtering ports and settings” on page 60.

You can also run this task on multiple computers, immediately or on a schedule.

See “Filtering the network traffic on multiple computers ” on page 22.

To block network traffic from and to the computer

1 Connect to the client computer that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Networking > Intel AMT Network Filtering.

3 In the right pane, under Intel AMT Network Filtering, select Filter network traffic other
than to and from the Notification Server.

4 (Optional) To prevent the target computer from sending malicious packets, check Enable
anti-spoofing filter.

This feature forces the identity verification of outgoing network traffic and drops packets
if the computer is suspected of originating malicious attacks that are known as IP spoofing.

5 Click Save changes.

To protect the target computer from network flooding

1 Connect to the client computer that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Networking > Intel AMT Network Filtering.

3 In the right pane, under Intel AMT Network Filtering, select Limit the number of PING
packets to, and then type the number of packets per second, that are allowed to pass
through the Intel vPro network filter.

The default setting is packets per second.

4 Click Save changes.
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Configuring the Intel AMT device settings
(Intel AMT only)

You can allow or forbid SOL and IDE-R sessions. You can configure Intel AMT power-saving
settings.

To allow SOL and IDE-R sessions

1 Connect to the client computer that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Configuration > Intel AMT Settings.

3 To allow the target computer to start SOL sessions, in the right pane, under Allow
following settings, check Task progress window and remote control.

4 To allow the target computer to start IDE-R sessions, in the right pane, under Allow
following settings,check Redirect to optical/floppy drive or image on a server.

5 Click Save Changes.

To change the Intel AMT power-saving settings

1 Connect to the client computer that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Configuration > Intel AMT Settings.

3 To allow the Intel AMT device to enter sleep state, in the right pane, underAllow following
settings, check Use Manageability Engine's power saving mode after, and then type
the timeout value.

Example: 5 minutes.

4 Click Save Changes.

See “Starting a Serial-over-LAN (SOL) remote control session” on page 30.

See “Booting a computer from remote location using IDE-R” on page 31.

Viewing client computer logs
You can view the client computer events logs.

■ Windows event logs (application, security and system logs)

■ Intel AMT log

■ Symantec Management Agent diagnostic log
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See “Managing the properties of Symantec Management Agent in real time” on page 36.

To view Windows Application Log

1 Connect to the client computer, that you want to see the Application Log for.

See “Initiating real time connection” on page 25.

2 In the Navigation pane, expand Real-Time Consoles > Real-Time System Manager >
Event Logs > Application Log.

3 In the right pane, view the application log information.

Note:By default, only error type of events are viewed in the list. To change the parameters,
on the Appliction Log page, double-click Event filters, and apply new filters.

To view the Intel AMT log

1 Connect to the client computer, that you want to see the AMT Log for.

See “Initiating real time connection” on page 25.

2 Click Real-Time System Manager > Event Logs > Intel AMT Event Log.

Managing BIOS settings
(Broadcom DASH only)

You can use the Manage BIOS Settings page to remotely view and update the BIOS settings
of the target computers that are capable of BIOS management through the DASH technology.
To identify these computers, you must collect the DASH settings inventory.

To check if the functionality is supported by the client computer

1 In the Resource Manager, in the Inventory view, expand Real-Time Console
Infrastructure > RTCI DASH Registered profile.

2 If BIOS Management profile is displayed on this page, then the client computer supports
WS-MAN BIOS Management.

You can also run this task on multiple computers, immediately or on a schedule.

See “Updating BIOS settings” on page 16.

To update BIOS settings

1 Connect to the client computer that you want to manage.

See “Initiating real time connection” on page 25.

2 In the navigation pane, under Real-Time Consoles, click Real-Time System Manager
> Management Operations > Manage BIOS Settings.
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3 In the right pane, on the Manage BIOS Settings page, under Available BIOS settings,
configure BIOS settings.

If BIOS is protected by administrator or system passwords, specify the passwords.

4 Click Save changes.

5 Restart the client computer for the new settings to take effect.

See “Turning off, turning on, or restarting a client computer” on page 26.

If you have a system password set on the target computer, on the Manage Power State
and Redirection page, check Bypass computer's startup password, and then restart
the computer.

Note: Please note, that there are several types of BIOS startup password. The behavior
of the Bypass computer's Startup Password option varies depending on the
manufacturer and the AMT version. Some computers do not support bypassing the BIOS
password for AMT management.

Managing the properties of Symantec Management
Agent in real time

To manage Symantec Management Agent properties using Real-Time System Manager, you
must connect to a client computer with a WMI profile and credentials.

To manage the properties of Symantec Management Agent in real time

1 In the Symantec Management Console, on the Home menu, click Remote Management
> Real-Time System Manager Portal.

2 On the Real-Time System Manager Portal page, in the Manage Web part, in the
Computer text box, type the IP address of the computer, that you want to manage, and
then click Connect.

3 On the Resource Manager page, in the right pane, under Supported protocols, click
Default Connection Profile.

4 In the Select connection profile dialog box, choose the WMI profile, and then click OK.

For more information on setting up the connection profiles and credentials see:
http://www.symantec.com/docs/HOWTO62827

5 In the navigation pane, underReal-Time Consoles, expandReal-Time SystemManager
> Software > Symantec Management Agent, and then click one of the following
management or audit nodes.
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View and filter Symantec Management Agent logs. You can filter by
severity, or view all entries: errors, warnings, and information. Diagnostic
log can be exported into a file.

Diagnostic Log

View, turn on/off the maintenance windows on the client computer.Maintenance Windows

View the full list of plug-ins that are installed on the client computer.Registered Plug-ins

■ Assign the client computer to a different Notification Server.
■ Force an update for Symantec Management Agent.
■ Force a collection of basic inventory.
■ Enable diagnostics.

Settings

Review the tasks that are currently running on the client computer.Tasks

Activating a virtual layer
Symantec Workspace Virtualization only virtualizes the application environment, not the
complete PC. It installs the Symantec Workspace Virtualization Agent that provides false
information to the host operating system. The operating system works as if it is running a
normal application, while in fact the associated file and registry calls are redirected to a newly
created virtual layer, where the application actually resides. You can install several applications
into the same layer, or configure them separately in their own individual environments, to avoid
any potential conflicts. The initial layer, that is created when the application is installed is
read-only, so it cannot be corrupted. A separate associated editable layer holds the program
data, configuration files, etc. After you delete that information, the application returns to its
initial condition.

After you install Symantec Workspace Virtualization and create layers, you can manage existing
layers using Real-Time System Manager.

For more information about the requirements, installation, and configuration of Symantec
Workspace Virtualization, see Symantec Workspace Virtualization User Guide.

http://www.symantec.com/docs/DOC7392

The prerequisites for managing virtual layers in real time are as follows:

■ Connection to the client computer with a WMI profile and credentials

■ Software Virtualization Solution installed in a mode that provides WMI classes

Real-Time System Manager lets you:

■ Activate and deactivate existing layers

■ Enable layers to start automatically after the boot of the client computer
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■ Reset layers

■ Remove existing layers

■ View details for existing layers

To activate a virtual layer

1 In the Symantec Management Console, on the Home menu, click Remote Management
> Real-Time System Manager Portal.

2 On the Real-Time System Manager Portal page, in the Manage Web part, in the
Computer text box, type the IP address of the computer, that you want to manage, and
then click Connect.

3 On the Resource Manager page, in the right pane, under Supported protocols, click
Default Connection Profile.

4 In the Select connection profile dialog box, activate the WMI profile, and then click OK.

For more information on setting up the connection profiles and credentials see:
http://www.symantec.com/docs/HOWTO62827

5 In the navigation panel, underReal-Time Consoles, expandReal-Time SystemManager
> Software > Manage Virtual Layers.

6 In the right pane, click the layer in the list, that you need to activate, and then, on the
toolbar, click Activate.

On the toolbar, to allow or deny the layer to start automatically after the restart of the
operation system on the client computer, click Auto or Manual.
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Additional functionality

This chapter includes the following topics:

■ Additional functionality and portal actions available in Real-Time System Manager

■ Resetting a domain user password

■ Running the port check

■ Configuring the port check settings

■ Modifying the list of open network filtering ports

■ Adding or removing custom views

Additional functionality and portal actions available
in Real-Time System Manager

Additional functionality and customization capabilities are available in Real-Time System
Manager.

Resetting a domain user password
You can reset a domain user password.

To reset a domain user password

1 In the Symantec Management Console, on the Home menu, click Remote Management
> Real-Time System Manager Portal.

2 In the Tools Web part, click Reset Domain Password.

3 In the Reset Domain Password dialog box, fill in the required fields, and then click OK.

You can also reset user passwords on multiple computers.
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See “Resetting a local user password on multiple computers” on page 17.

Running the port check
The Port Check tool lets you detect which ports are open on the target computer. You can
run the Port Check tool from a computer filter.

See “Configuring the port check settings” on page 40.

To run the port check

1 In the Symantec Management Console, on the Manage menu, click Filters.

2 In the left pane, select a filter.

For example, click Computer Filters > All Computers.

3 In the right pane, right-click on a computer resource, and then click Remote Management
> Port check.

Configuring the port check settings
Real-Time Console Infrastructure includes a Port Check tool. This tool lets you detect which
ports are open on the target computer. You can run the Port Check tool from a computer filter.

See “Running the port check” on page 40.

You can configure the port check settings that the Port Check tool uses. For example, you
can configure which ports to check.

To configure port check settings

1 In the Symantec Management Console, clickHome > RemoteManagement > Real-Time
System Manager Portal.

2 In the left pane, click Port Check.

3 On the Port Check page, click Configure Ports.

4 On the Modify Ports page, add or remove ports to check.

5 Click OK.

Modifying the list of open network filtering ports
You can modify the list of ports to keep open when network filtering is active on the Network
Filters page.

See “Network filtering ports and settings” on page 60.

See “Blocking network traffic from and to the computer ” on page 32.
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See “Filtering the network traffic on multiple computers ” on page 22.

To modify the list of open network filtering ports

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, click Remote Management > Real-Time System Manager > Network
Filters.

3 Modify the filters.

Adding or removing custom views
You can add or remove custom views, which appear in the Resource Manager's Real-Time
view.

For example, you can add the Linux OpenWSMan view, which is included in Real-Time
Console Infrastructure.

The location of the custom view file is C:\Program

Files\Altiris\RTCI\Web\Samples\Linux-Demo.config

For more information on how to configure the Linux OpenWSMan sample view, see
http://www.symantec.com/docs/HOWTO10140.

To add or remove a custom view

1 In the Symantec Management Console, on the Settings menu, click All Settings.

2 In the left pane, click Remote Management > Real-Time Console Infrastructure >
Manage Custom Views.

3 On the Manage Custom Views page, add or remove a view.
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List of available operations

This appendix includes the following topics:

■ List of available operations

■ Managements processes

■ Audit Nodes

■ Information Nodes

List of available operations
By default, all of the actions in Real-Time System Manager and Real-Time Console
Infrastructure are available in-band and one-on-one, with a few exceptions that are marked in
the footnotes. Actions that are available out-of-band or as one-to-many tasks are marked with
X-s in corresponding columns.

Nodes are divided into 3 groups: management processes, audit and information sections.
Information nodes provide constant data about client computers. Audit nodes allow you to
track variable information about client computers in real time.

Managements processes
Table A-1 Management Operations

1- to-manyOut- of-
band

Technical
Requirements

Available Data

xWMI
Manage Local
Users and Groups

-WMIManage Printers
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Table A-1 Management Operations (continued)

1- to-manyOut- of-
band

Technical
Requirements

Available Data

xWMIManage Processes

xWMIManage Services

xxAMT or DASHManage Alerts

-xAMTMedia redirectionRemote Control

-xDASHRemote control *

xx
WMI or AMT or DASH

or IPMI

Power Up

Power Down

Restart

Basic Power
Operations

Manage Power
State and
Redirection

xxAMT

Bypass boot
password

Lock Keyboard

Advanced Power
Options

xAMTConsole Terminal Redirection (SOL)

xAMTBIOS Management with SOL

xxAMTLocal media redirection

xxAMTRemote media redirection

xxDASHBIOS Management **

* Remote control is currently supported only on Intel AMT clients with AMT version 6+ and
Intel integrated Video Adapter.

** To use BIOS Management under DASH, client computer must support BIOS Management
DASH Profile.

Table A-2 Configuration

1- to-manyOut- of-
band

Technical
Requirements

Available Data

xxAMTUnconfigure Intel AMT DeviceIntel AMT
Configuration
Mode

xxAMTIntel AMT Settings
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Table A-2 Configuration (continued)

1- to-manyOut- of-
band

Technical
Requirements

Available Data

xAMTIntel Remote Access Policy

Table A-3 Software

Technical RequirementsAvailable Data

WMIDiagnostic Log *

WMIMaintenance Windows *

WMIRegistered Plug-ins *

WMISettings *

WMITasks *

WMIDetails

Activate

Deactivate

Reset

Auto or
Manual

Remove

Software Virtualization Layers **

* Symantec Agent must be installed.

** Requires Symantec Workspace Virtualization Agent with Admin Tools.
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Audit Nodes
Table A-4 Summary

Out- of-
band

Technical
Requirements

Available Data

xWMI or AMT or DASHComputer nameBasic Information

WMIPrimary owner name

WMICurrently logged in user

WMIDomain

WMIOperation system

AMTProduct

xWMIVersion

xWMI or AMTNameCPU Information

WMI or AMT or DASHCurrent/max speed

WMILoad percentage

WMI or AMT or DASHVirtualMemory Usage

xWMI or AMT or DASHPhysical

WMICommitted

WMIPage file @ C

WMI or AMTCapacityDisk Usage

WMIUsed

WMIFree

WMIFile system

WMI or AMTNetwork Connectivity

WMISecurity
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Table A-5 Event Logs

Out- of-
band

Technical
Requirements

Available Data

WMIApplication Log

WMISecurity Log

WMISystem Log

WMIDirectory Service Log *

WMIDNS Server Log *

WMIFile Replication Service Log *

xIPMISystem Event Log

xAMTIntel AMT Event Log

* This log is only available for clients that are Domain Controllers.

Information Nodes
Information nodes are mostly available as in-band one-on-one actions, exceptions are marked
in the footnotes.

In some cases it is possible to modify the settings from the Detailed view of some of the
information nodes.
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Table A-6 Information nodes (static)

1- to-manyOut- of-
band

Technical
Requirements

Available DataNodes

WMILocal TimeOperating System

WMIOperating System

WMIPage File Settings

WMIPrinting Job

WMIProxy Server

WMIQuick-Fix Engineering

WMIRegistry

WMIRegistry

WMIShare

WMITerminal Server

WMIKeyboardInput and Output Devices

WMIModem

WMIMonitor

WMIPointing Device

WMIPrinter

WMIVideo Adapter

WMIIDE ControllerControllers and Ports

WMIParallel Port

WMISerial Port

WMIUSB Controller

WMISCSI Controller

WMIUSB Hub
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Table A-6 Information nodes (static) (continued)

1- to-manyOut- of-
band

Technical
Requirements

Available DataNodes

xAMTAgent WatchdogsPhysical System

AMTBattery

xWMI or AMT or
IPMI

BIOS

xWMI or AMT or
DASH or SNMP or
IPMI

Computer System

DASHDASH Registered Profiles

DASHDASH Software

DASHFanPhysical System

AMT or DASHField Replaceable Unit

xWMI or AMT or
DASH or IPMI

Motherboard Device

DASHPower Supply

WMI or AMT or
DASH

Processor

xDASH or IPMISensors

WMISMBIOS

WMISound Device

WMI or DASHCache MemoryMemory

WMILogical Memory
Configuration

xWMI or DASHPhysical Memory

xWMI and AMTDisk DriveMass Storage

WMILogical Drive

xWMIMedia Device
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Table A-6 Information nodes (static) (continued)

1- to-manyOut- of-
band

Technical
Requirements

Available DataNodes

WMI and SNMPIP Route TableNetworking

WMI and SNMPNetwork Adapter

xWMI or AMT or
SNMP or IPMI

Network Adapter
Configuration

WMINetwork Connection

WMIServer Connection

WMIServer Session

xxAMTFilter network
traffic

Intel AMT
Network
Filtering

xAMTExport
filtering
settings

xIntel AMT Network Settings

xWireless Profile
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Troubleshooting

This appendix includes the following topics:

■ Troubleshooting Real-Time System Manager connection

Troubleshooting Real-Time System Manager
connection

Listed bellow are some of the reasons why Real-Time System Management cannot establish
a real time connection.

BAppendix



Table B-1 Possible reasons of real time connection errors

Possible reasonsTechnology

The connection credentials are incorrect.

The computer is turned off .

The operating system is not loaded.

The computer is not connected to the network.

The firewall does not allow incoming WMI connections.

See “Configuring the firewall to allow WMI connection” on page 52.

Simple file sharing is enabled.

See “Disabling simple file sharing on Windows XP SP3” on page 55.

User Access Control is turned on.

See “Configuring User Access Control on Windows Vista or later versions of Windows”
on page 55.

You are connecting to Microsoft Windows Home (Basic) editions, where WMI remote
connection is not available.

You are connecting with a user that has an empty password.

WMI

The connection credentials are incorrect.

The Intel AMT device is not configured.

The Intel AMT device is in secure mode, but the connection profile is not configured to
use the correct certificates, and vice versa.

For more information on configuring connection profiles, see theSymantec ITManagement
Suite powered by Altiris technology User Guide.

Intel AMT is turned off in the BIOS.

The computer is not connected to the network.

The computer is not Intel AMT capable.

WSMan protocol is not enabled.

Intel AMT

The connection credentials are incorrect.

DASH is turned on in the BIOS but not configured.

DASH is turned off in the BIOS.

The computer is not connected to the network.

The target computer is not DASH capable.

DASH
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Table B-1 Possible reasons of real time connection errors (continued)

Possible reasonsTechnology

The connection credentials are incorrect.

The IPMI device is not configured.

The IPMI device is in secure mode, but the connection profile is not configured to use the
correct certificates.

IPMI is turned off in the BIOS.

The computer is not connected to the network.

The target computer is not IPMI capable.

IPMI

The SNMP community string is incorrect.

SNMP is not installed on the target computer.

The SNMP service is not running on the target computer.

The Notification Server computer is not in the list of hosts to accept the SNMP packets
from. Check SNMP service properties.

SNMP

Configuring the firewall to allow WMI connection
WMI connection through the Real-Time view can fail when you try to connect to a computer
with Microsoft Windows XP Service Pack 2, Windows Vista, or Windows 7 operating system.

This issue can occur when the default configuration of the Windows Firewall program blocks
incoming network traffic for Windows Management Instrumentation (WMI) connection. For the
connection to succeed, the remote computer must permit incoming network traffic on TCP
ports 135, 445, and additional dynamically-assigned ports, typically in the range of 1025 to
5000 and 49152 to 65535.

You can resolve this issue in one of the following ways:

■ Configure the firewall on the computer that you want to connect to.
See “Configuring the firewall on a single computer” on page 52.

■ Configure the firewall on all computers in the domain using a group policy.
See “Configuring the firewall on multiple domain computers with a group policy” on page 53.

■ Temporarily disable the firewall.

See “Troubleshooting Real-Time System Manager connection” on page 50.

Configuring the firewall on a single computer
You can configure the firewall using the computer’s local settings.
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See “Configuring the firewall to allow WMI connection” on page 52.

To configure the firewall on Windows XP SP2

1 Log on to the target computer as the administrator.

2 Click Start > Run, in the Open field, type gpedit.msc, and then click OK.

3 In theGroup Policywindow, expand Local Computer Policy > Computer Configuration
> Administrative Templates > Network > Network Connections > Windows Firewall,
and the click one of the following:

■ If the computer is in a domain, click Domain Profile.

■ If the computer is not in a domain, click Standard Profile.

4 In the right pane, double-click Windows Firewall: Allow remote administration
exception, in the Windows firewall dialog box, select Enable, and then click OK.

To configure the firewall on Windows Vista

1 Log on to the target computer as the administrator.

2 From the Control Panel, open the Windows Firewall Settings dialog box.

3 On the Exceptions tab, check Windows Management Instrumentation (WMI).

To configure the firewall on Windows 7

1 Log on to the target computer as the administrator.

2 From the Control Panel, locate and open the Windows Firewall configuration dialog box.

3 In the left pane, click Allow a program or feature through Windows Firewall.

4 Check Windows Management Instrumentation (WMI).

Configuring the firewall on multiple domain computers with a group
policy

Before you start the firewall configuration, ensure sure that all the computers that you want to
manage with this policy are in the same organizational unit.

For more information about how to use a group policy, visit the following Microsoft Web site:

http://technet.microsoft.com/en-us/windowsserver/grouppolicy/default.aspx

These steps assume that Windows Firewall is configured to use the domain profile. The domain
profile is the most typical scenario.

For more information about Windows Firewall profiles and about how Windows selects the
profile to load, see the Deploying Windows Firewall Settings for Microsoft Windows XP with
Service Pack 2 guide.

For more information, visit the following Microsoft Web site:
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http://www.microsoft.com/downloads/details.aspx?FamilyID=
4454e0e1-61fa-447a-bdcd-499f73a637d1&DisplayLang=en

See “Configuring the firewall to allow WMI connection” on page 52.

To configure the firewall on multiple domain computers with a group policy

1 Create a group policy object for the organizational unit that contains the Windows XP SP2
computers that you want to manage:

■ Log on to a domain controller.

■ Click Start > Run, type dsa.msc in the Open dialog box, and then click OK.

■ Expand your domain, right-click the organizational unit in which you want to create the
group policy, and then click Properties.

■ On the Group Policy tab, click New.

■ Type a name for the group policy object, and then press Enter.

■ Click Close.

2 Log on to a domain-member computer that is running Windows XP SP2. Log on with a
user account that is a member of one or more of the following security groups:

■ Domain Admins

■ Enterprise Admins

■ Group Policy Creator Owners

3 Click Start > Run, in the Open field, type mmc, and then click OK.

4 On the File menu, click Add/Remove Snap-in.

5 On the Standalone tab, click Add.

6 In the Add Standalone Snap-in dialog box, click Group Policy, and then click Add.

7 In the Select Group Policy Object dialog box, click Browse.

8 Click the group policy object that you want to update with the new Windows Firewall
settings.

For example, click the organizational unit that contains the Windows XP SP2 computers,
click OK, and then click the group policy object that you created in step 1.

9 Click OK, and then click Finish.

10 Click Close, and then click OK.

11 Under Console Root, expand the group policy object that you selected in step 8, and
then click Computer Configuration > Administrative Templates > Network > Network
Connections > Windows Firewall > Domain Profile.
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12 In the right pane, double-click Windows Firewall: Allow remote administration
exception.

13 Click Enabled, and then specify the administrative scope in the Allow unsolicited
incoming messages from dialog box.

For example, to permit remote administration from a particular IP address, type that IP
address in theAllow unsolicited incomingmessages from dialog box. To permit remote
administration from a particular subnet, type that subnet by using the Classless Internet
Domain Routing (CIDR) format. In this scenario, type 192.168.1.0/24 to specify the network
192.168.1.0 with a 24-bit subnet mask of 255.255.255.0.

For more information on how to specify a valid administrative scope, see the Syntax area
of the Setting tab in this policy.

14 Click OK, and then on the File menu, click Exit .

Disabling simple file sharing on Windows XP SP3
The “ForceGuest” option that is enabled by default on all Windows XP computers that are
members of a workgroup (in contrast to domain members). All users who log onto such
computers over the network are forced to use the Guest account. This is limitation is Windows
XP specific.

See “Troubleshooting Real-Time System Manager connection” on page 50.

To disable simple file sharing on Windows XP SP3

◆ Do one of the following steps:

■ Open Control Panel, double-click Folder Options, and on the View tab, uncheck
Use simple file sharing. Click OK.

■ On the client computer, in the Windows registry, set the “ForceGuest” DWORD value
equal to 0 (zero) under the
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa] key.
For more information, see Microsoft knowledge base articles :
http://support.microsoft.com/default.aspx?scid=KB;EN-US;180548
http://support.microsoft.com/default.aspx?scid=kb;en-us;290403

Configuring User Access Control on Windows Vista or later versions
of Windows

You must turn off the User Access Control (UAC) on non-domain computers if you want to
install the Symantec Management Agent to those computers and manage the computers
remotely through WMI.
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For more information, see Microsoft article http://technet.microsoft.com/en-us/
windowsvista/aa905108.aspx.

See “Troubleshooting Real-Time System Manager connection” on page 50.

To configure User Access Control on Windows Vista

1 On the client computer with the Microsoft Windows Vista operating system, open the
Control Panel.

2 Double-click User Accounts.

3 In the User Accounts dialog box, click Turn User Account Control on or off.

4 Uncheck Use User Account Control (UAC) to help protect your computer, and then
click OK.

To configure User Access Control on Windows 7

1 On the client computer with the Microsoft Windows 7 operating system, open the Control
Panel.

2 Click User Accounts.

3 Click Change User Account Control settings.

4 Move the slider to Never notify, and then click OK.
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Technical Reference

This appendix includes the following topics:

■ Ports used by Real-Time System Manager

■ How authentication works

■ About changes in default system security

■ Network filtering ports and settings

■ Power management and redirection capabilities

Ports used by Real-Time System Manager
The following table lists the ports that are used for communication by Real-Time System
Management, Symantec Management Platform, and the Symantec Management Console.
You can use the table to configure the firewall between your console, server, and managed
computers as needed.

See “Configuring the firewall to allow WMI connection” on page 52.

Table C-1 Ports used by Real-Time System Manager

BindingDirectionDescriptionPortProtocol

Symantec Management Console —
Symantec Management Platform

bothWWW (HTTP)80TCP

Symantec Management Console —
Symantec Management Platform

bothLDAP389TCP

Symantec Management Console —
Symantec Management Platform

both(optional) SSL
(HTTPS)

443TCP/UDP
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Table C-1 Ports used by Real-Time System Manager (continued)

BindingDirectionDescriptionPortProtocol

Symantec Management Platform —
managed computer

bothEcho (ICMP)7TCP/UDP

Symantec Management Platform —
managed computer

bothDCE endpoint
resolution

135TCP/UDP

Symantec Management Platform —
managed computer

bothMicrosoft-DS445TCP/UDP

Symantec Management Platform —
managed computer

bothRPC1025 - 5000TCP/UDP

Symantec Management Platform —
managed computer

bothRPC49152 - 65535TCP/UDP

Real-Time System Management —
managed computer

bothSNMP161UDP

Real-Time System Management —
managed computer

bothSNMP trap162UDP

Real-Time System Management —
managed computer

bothNon-secure IPMI
connection port

623UDP

Real-Time System Management —
managed computer

bothSecure IPMI
connection port

664UDP

Real-Time System Management —
managed computer

bothNon-secure
DASH connection
port

623TCP/UDP

Real-Time System Management —
managed computer

bothSecure DASH
connection port

664TCP

Real-Time System Management —
managed computer

bothNon-secure Intel
AMT connection
port

16992TCP

Real-Time System Management —
managed computer

bothSecure Intel AMT
connection port

16993TCP

Real-Time System Management —
managed computer

bothNon-secure Intel
AMT remote
control port
(KVM/SOL/IDE-R)

16994TCP
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Table C-1 Ports used by Real-Time System Manager (continued)

BindingDirectionDescriptionPortProtocol

Real-Time System Management —
managed computer

bothSecure Intel AMT
remote control
port
(KVM/SOL/IDE-R)

16995TCP

How authentication works
Authentication accurs on the Notification Server computer where Real-Time System
Management is installed.

When you use Real-Time System Management, the following authentication points apply:

■ When you try to access the Symantec Management Console or the Resource Manager
page, Notification Server verifies that the user has the rights to access Real-Time System
Management. You can access the console either as a user who is interactively logged on
to the Notification Server computer or as a user who is connected to the Notification Server
computer remotely through a browser. In case of an interactively logged on user, the
Windows logon information is passed to Notification Server. When a computer is managed
locally from a target computer, the Internet Explorer credentials are used.

■ By default, Real-Time System Management uses the Notification Server Application Identity
credentials (WMI Credential for Default Connection Profile) to connect to remote
computers. If the Notification Server Application Identity account has no administrator rights
to access the remote computer, the connection fails. Create a new connection profile with
correct credentials.

■ Once successfully authenticated, Real-Time System Management administrative-user
credentials are used as “administrative” credentials for all WMI commands until the Resource
Manager page is closed.

■ The Notification Server computer and the target computer can be on different domains. In
this case, you must specify the user in the form of "domain\username" in the connection
profile. This is not true for the following cases:

■ If there is a trust relationship between domains that ensures that users from the
Notification Server domain have a sufficient privilege level (on the target Real-Time
System Management host) that WMI requires.

■ If the target computer has a local account (with sufficient WMI rights) with the user name
and password identical to the user whose credentials were used to access Real-Time
System Management.
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About changes in default system security
During installation and setup of Real-Time System Management, the access list for the
Windows_Folder\Temp directory is changed as follows:

■ The IIS_WPG (SERVER_NAME\IIS_WPG) group is added with full control for the folder,
subfolder, and files.

■ The ASP.NET computer account (SERVER_NAME\ASPNET) user is added with full control
for the folder, subfolder, and files.

Network filtering ports and settings
To allow communication with the Notification Server computer for remediation, the following
ports stay open on the target computer when network filtering is active.

Table C-2 Ports kept open when network filtering is active

DirectionTypeName and descriptionPort #

Receive/TransmitTCP/UDPDNS port53

Receive/TransmitUDPDHCP boot protocol server67

Receive/TransmitUDPDHCP boot protocol client68

Receive/TransmitTCPNotification Server port80*

Receive/TransmitUDPKerberos port88

Receive/TransmitTCPNETBIOS Name Service137

Receive/TransmitTCP/UDPLDAP port389

Receive/TransmitTCP/UDPSecure LDAP port636

Receive/TransmitEthernet
frame

ARP2054

Receive/TransmitTCPNotification Server Tickle port52028*

* Depends on Notification Server configuration

See “Modifying the list of open network filtering ports” on page 40.

See “Blocking network traffic from and to the computer ” on page 32.

See “Filtering the network traffic on multiple computers ” on page 22.
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Power management and redirection capabilities
The following table displays the power management and redirection capabilities for the Intel
AMT-capable computers in different power states.

Table C-3 Intel AMT power management capabilities

Boot redirectAMT power
on

AMT power
off

AMT rebootPower state

Yes2NoYesYesS0/G0 “working”

YesNoYesYesS1 “sleeping with system h/w & processor context
maintained”

YesNoNoNoS2 “sleeping, processor context lost”

Yes2YesYes1Yes1S3 “sleeping, processor & h/w context lost, memory
retained”

Yes2YesYes1Yes1S4 “non-volatile sleep / suspend-to disk”

YesYesNoNoS5/G2 “soft-off”

YesNoNoNoS4/S5 soft-off, particular S4/S5 state cannot be
determined

NoNoNoNoG3/Mechanical Off

YesNoNoNoSleeping in an S1, S2, or S3 state (used when
particular S1,S2, S3 state cannot be determined),
or Legacy SLEEP state

YesNoNoNoG1 sleeping (S1-S4 cannot be determined)

YesNoNoNoS5 entered by override, for example, by 4-second
power button override

YesNoNoNoLegacy ON, for example, non-ACPI OS working
state

YesNoNoNoLegacy OFF, for example, non-ACPI OS off state

YesNoNoNoUnknown

1 Performed through the power on command.
2 Redirection can be enabled only for the reboot command.
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alert A notification about issues, failures, and particular states of the system. The user
can customize which alerts are sent, logged, and where the alerts are sent.

authentication The process of verifying the user's rights.

BIOS management The process of remotely managing BIOS settings on a client computer.

boot redirection An action that redirects the booting process of a client computer to a local or remote
device, or a binary image.

custom views Customizable layouts in which the information appears in the real-time view of the
Resource Manager.

in-band management A type of remote computer management that requires the client computer to be
turned on, its operating system to be initialized and function properly.

KVM

(Keyboard-Video-Mouse)

A type of remote computer management that allows remote access to a client
computer both in-band and out-of-band. KVM does not depend on any features of
the operating system, is fully hardware-based, and can bypass the virus protection
firewall. KVM gives full access to video and input devices on the client computer.

network filtering A functionality that allows blocking or limiting the network traffic from and to the
client computer's operating system. Network filtering can be used to isolate an
infected computer from the network.

one-to-many tasks A group of scheduled tasks that allow managing multiple computers at the same
time.

one-to-one

management

A type of management that allows using the full scope of features that are available
in the Real-Time System Manager in real time on a single client computer, in-band
as well as out-of-band.

out-of-band

management

A type of remote computer management that lets the user manage the computers
that failed to load, have no operation system installed or are turned off. Network
cable and the power cord must be plugged in. Out-of-band management can be
performed on the client computers that have Intel AMT, DASH, or ASF-capable
network adapters. To manage a client computer in an out-of-band state, it must be
discovered as a resource from Notification Server, or be accessible either by known
IP address or by network name.

password management The process of resetting passwords for local users or domain users on client
computers.
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Port Check A tool that lets the user detect which ports are open on a client computer.

power management The process of remotely managing the power state of a client computer using WMI,
Intel AMT, ASF, IPMI, and DASH technologies.

real-time management The process of remotely performing various administrative tasks on the client
computers in real time using Real-Time System Manager.

remote control A feature that allows managing a client computer from a remote location without
the direct access to the client computer.

Software Virtualization

Solution

A product and a technology for creating and managing virtual software layers.

Update BIOS Settings

task

A task that updates the BIOS settings on one or multiple client computers remotely.

web console A means of accessing management options using the web interface instead of an
installed version of the component.
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