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About Authentication and Authorization
Authentication is the process of verifying the identity of a user so that the user becomes known by the system. You can deny
access to users who fail to authenticate successfully, thereby eliminating the threat of malicious clients posing as legitimate
network users. For users who authenticate successfully, you can define policies that enforce your corporate usage rules and
standards. You can also leverage your existing user groups to enforce policy. For example, youmight want to allow your HR
department access to social networking sites so that they can research potential candidates, but deny access to other user
groups. This process of determining which resources a user or group can access —called authorization—can only occur after
successful authentication.

You can also configure the appliance to log the activities of authenticated users so that you canmonitor user activity in logs
and reports. This allows you to assess how well your policies are working or track down users who aremisusing resources or
exposing your network to potential threats.

To verify the identify of the user sending a request, youmust employ an authentication scheme that either challenges the user
for credentials or gets those credentials from the browser (or other user agent) automatically without prompting the user (this is
known as single sign-on). The ProxySG provides a flexible authentication facility that enables you to integrate with your
existing authentication services, such as Active Directory, LDAP, RADIUS, andmany more.

Integrating the ProxySGwith your authentication systems is just the first step in configuring authentication.The next step is to
create rules that instruct the ProxySG how to authenticate users and exactly which resources they can, and cannot, access.
You define these rules by creating policy using the Visual Policy Manager (VPM) or the Content Policy Language (CPL).
Because the policy engine on the ProxySG is so flexible, you can define rules that are as strict or as lenient as necessary to
meet your corporate usage goals. For example:

n You could define a simple rule that allows all authenticated users access to all resources and denies all access to users
who fail to authenticate successfully.

n You could allow some error tolerance in your policy or create policy that allows limited access to guest users.

n You can also define very specific rules that grant access to some resources to some users, but not all, or that limit
access to resources based on the time of day or up to certain bandwidth limits.
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About AuthenticationModes
Before the ProxySG appliance can authenticate intercepted connections, youmust create the authentication
policy that tells the appliance when and how to authenticate client requests. One of the policy settings you
must define is the authenticationmode. The authenticationmode specifies the type of authentication
challenge to use to obtain the client credentials and the type of surrogate credential to use, if any. You define
the authenticationmode when you create your policy. When creating policy using Content Policy Language
(CPL), you set the authenticationmode using the authenticate.mode() statement. When creating policy
using the Visual Policy Manager (VPM), you set the authenticationmode when creating the Authenticate
object.

The appliance will automatically override the configuredmode if the client
cannot support the requestedmode. For example, if you set the
authenticationmode to Origin-Cookie-Redirect, but the client does not
support cookies, the appliance will automatically downgrade to Origin-IP-
Redirect mode.

If you do not set an authenticationmode, the appliance uses the default mode, Auto. In Automode the
appliance will automatically determine whichmode to use. However, in most cases it is best to explicitly set
themode.

The following table lists the authenticationmodes and when to use them.

Authentication
Mode

Challenge Type Surrogate
Credential

Use With

Proxy The ProxySG appliance issues a proxy challenge
(HTTP 407) for every new connection.

None Explicit
proxy

Proxy IP The ProxySG appliance issues a proxy challenge
(HTTP 407) for the first connection request from an
unauthenticated client. It only reissues the
challenge when the IP surrogate expires.

IP address Explicit
proxy,

Windows
SSO, or

Novell SSO

Origin The ProxySG appliance issues anOCS-style
challenge (HTTP 401) for every new connection.

None Reverse
proxy

Origin IP The ProxySG appliance issues anOCS-style
challenge (HTTP 401) for the first connection
request from an unauthenticated client. It only
reissues the challenge when the IP surrogate
expires.

IP address Reverse
proxy
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Authentication
Mode

Challenge Type Surrogate
Credential

Use With

Origin IP
Redirect

Redirects the client to the virtual URL and then
issues anOCS-style challenge (HTTP 401). It only
reissues the challenge when the client's IP
surrogate expires.

IP address Transparent
proxy

Origin Cookie The ProxySG appliance issues anOCS-style
challenge (HTTP 401) for the first connection
request for each new OCS domain per client. It
only reissues the challenge when the client's
cookie surrogate for the domain expires.

cookie Reverse
proxy

Origin Cookie
Redirect

Redirects the client to the virtual URL and then
issues anOCS-style challenge (HTTP 401) for the
first connection request for each new OCS domain
per client. It only reissues the challenge when the
client's cookie surrogate for the domain expires.

cookie Transparent
proxy

Form IP The ProxySG appliance returns a form to the client
to request credentials. It only reissues the
challenge form when the client's IP surrogate
expires.

IP address Reverse
proxy

Form IP Redirect Redirects the client to the virtual URL and then
returns a form to the client to request credentials. It
only reissues the challenge when the client's IP
surrogate expires.

IP address Transparent
proxy

Form Cookie The ProxySG appliance returns a form to the client
to request credentials for the first connection for
each new OCS domain requested. After the client
successfully authenticates to a domain, the
ProxySG appliance will only present the form when
the client's cookie surrogate for that domain
expires.

Cookie Reverse
proxy

Form Cookie
Redirect

Redirects the client to the virtual URL and then
returns a form to the client to request credentials
for the first connection for each new OCS domain
requested. After the client successfully
authenticates to a domain, the ProxySG appliance
will only present the form when the client's cookie
surrogate for that domain expires.

Cookie Transparent
proxy
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About Authentication Challenge Types
To verify the identify of the user sending a request, youmust employ an authentication scheme that either
challenges the user for credentials or gets those credentials from the browser (or other user agent)
automatically without prompting the user (this is known as single sign-on).The type of challenges the
ProxySG presents depends on the type of authentication (that is, what realm is in use), the authentication
mode, the proxy type (explicit or transparent) and the protocol of the client request.

There are three types of challenge supported by the ProxySG:

n Proxy—The proxy issues a challenge direct to the client (using an HTTP 407 request for HTTP and
HTTPS requests). For this type of challenge, the client browser or other user agent must know that it is
being proxied (that is, it is configured for explicit proxy). This challenge type is used with the Proxy and
Proxy-IP authenticationmodes.

n Origin—This challenge type is used in transparent proxy deployments in which the client does not
know it is being proxied. In this type of challenge, the proxy impersonates the origin content server
(OCS) and returns an unauthorized response to the request (using an HTTP 401 request for HTTP and
HTTPS requests). This challenge type is used with the Origin, Origin-Cookie, Origin-IP, Origin-Cookie-
Redirect, andOrigin-IP-Redirect authenticationmodes.

n Form—The ProxySG returns a form or redirects the client to a form that prompts for the required
credentials, such as a user name and password. This challenge type is used with the Form-IP, Form-
Cookie, Form-IP-Redirect, or Form-Cookie-Redirect authenticationmodes.
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About Surrogate Credentials
Most Web pages are composed of multiple objects, such as text, images, scripts, and data feeds. Therefore,
when downloading a singleWeb page, your browser may require multiple connections in order to download all
the content on the page. When authentication is enabled, each connectionmust be authenticated, which can
result in a large volume of authentication requests and a huge load on your authentication systems. To reduce
the load on your authentication systems, the ProxySG appliance can be configured to cache a token after it
successfully authenticates a client request. It can then use this token—called a surrogate credential—to
authenticate subsequent requests from the same user, eliminating the need to consult the authentication
server each time.

The ProxySG appliance supports two types of surrogates:

n Cookie surrogates—After the ProxySG appliance successfully authenticates the first connection from
the client it sets a cookie, which it uses to authenticate subsequent connections from the same user to
any host in the same origin content server (OCS) domain. The ProxySG appliance uses a Hash-based
Message Authentication Code (HMAC) to ensure that the cookie is not tampered with or copied. For
added security, you can optionally configure the authentication realm to verify that the IP address in the
request matches the IP address in the cookie. When configuring the realm you can also define whether
to use persistent cookies, which are stored on the client system and persist across sessions, or
session cookies (the default), which are only good for the browser session. Cookie surrogates only
work with HTTP- and HTTPS-based connections. If the realm is configured to use cookie surrogates, it
will automatically downgrade to an IP surrogate for user agents that do not support cookies.

n IP surrogates—After the ProxySG appliance successfully authenticates the first connection from an
IP address, it keeps the IP address as a token in its surrogate cache. It then uses this surrogate to
authenticate subsequent requests from the same IP address. IP surrogates are less secure than
cookie surrogates because IP addresses can be spoofed. In addition, they should not be used in
environments with multi-user systems (such as Citrix) or with clients behind NAT devices.

Even if you choose an authenticationmode that does not use surrogate
credentials, after a transaction has been authenticated, transactions on the
same persistent connection are also considered authenticated.

You define how and if surrogate credentials are used when you configure authentication. When you define the
authentication policy, you set the authenticationmode, which specifies the type of challenge and the type of
surrogate, if any, to use when authenticating requests. You set the length of time for which the surrogate
credentials are valid—called the surrogate refresh time—when you configure the realm. By default, surrogate
credentials are good for 15minutes, whichmeans that if the ProxySG appliance receives a request that
requires authentication from the same client during this time period, it uses the surrogate credential to
authenticate the request; if the surrogate credential has expired, it must reauthenticate the user and then reset
the surrogate. You can also override the setting in the realm configuration by setting the surrogate refresh time
in policy, for example if you want to allow a longer or shorter surrogate refresh time for different users,
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subnets, destinations, or user agents. Any setting you define in policy overrides settings you define in the
realm configuration.
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About Active Directory Integration
If you are usingWindows Active Directory (AD) in your network, you can configure the ProxySG appliance to
authenticate users against your AD. There are three ways to integrate ProxySG appliance with your AD
deployment:

n IntegratedWindows Authentication (IWA)

n Windows Single Sign-On (Windows SSO)

n Lightweight Directory Access Protocol (LDAP)
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About IWA
IntegratedWindows Authentication (IWA) is an authentication scheme that allows you to authenticate and
authorize users against yourWindows Active Directory (AD). One of themain benefits of IWA is that it can
provide a single sign-on experience for your users. When configured properly, the user agent or browser will
automatically provide the users' domain credentials to the ProxySG appliance when challenged without
prompting the user.

When the ProxySG appliance receives a request that requires authentication, it consults the IWA
configuration settings you have defined to determine what type of challenge to return to the client. It will try to
use the strongest challenge protocol that is configured and, if the browser cannot use that protocol or if it is not
configured properly, the appliance will downgrade to the next protocol. For example, if you configure the IWA
realm to allow Kerberos and NTLM, but the user agent/browser does not support Kerberos, the ProxySG
appliance will automatically downgrade to NTLM.

Another benefit of IWA is that it provides authorization without any additional configuration because a
successful authentication response automatically includes information about the groups to which the user
belongs. The ProxySG appliance can then use this groupmembership information to enforce its authorization
policies.

When integrating the ProxySG appliance with AD using IWA, you can either connect the appliance directly to
your AD domain (using IWA Direct) or you can connect via an authentication agent running on aWindows
server in your domain (using IWA BCAAA).
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About IWA Challenge Protocols

The ProxySG appliance determines which of the following protocols to use to obtainWindows domain login
credentials each time it receives a client request that requires IWA authentication:

n Kerberos—This is themost secure protocol because it establishes mutual authentication between the
client and the server using an encrypted shared key. This protocol requires additional configuration and
the ProxySG appliance will silently downgrade to NTLM if Kerberos is not set up properly or if the client
cannot do Kerberos. For more information, see "Preparing for a Kerberos Deployment" on page 56.

n NTLM—Uses an encrypted challenge/response that includes a hash of the password. NTLM requires
two trips between the workstation and the ProxySG appliance, and one trip between the appliance and
the Domain Controller. It therefore puts more load on the network than Kerberos, which only requires
one trip between the workstation and the ProxySG appliance and doesn't require a trip between the
appliance and the Domain Controller.

n Basic—Prompts the user for a username and password to authenticate the user against theWindows
Active Directory.

When the ProxySG appliance receives a request that requires authentication, it consults the IWA
configuration settings you have defined to determine what type of challenge protocol to return to the client. It
will try to use the strongest protocol that is configured and, if the browser cannot use that protocol or if it is not
configured properly, the appliance will downgrade to the next strongest protocol. For example, if you configure
the IWA realm to allow Kerberos and NTLM authentication, but the user agent/browser does not support
Kerberos, the ProxySG appliance will automatically downgrade to NTLM.
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About LDAP
LDAP (lightweight directory access protocol) is a communication protocol used to access directory
information over your network. Typically an LDAP directory, such as Microsoft Active Directory or
OpenLDAP, stores information about your end users and network resources into various entries, which can be
referenced by various LDAP-aware client applications, such as email client. A benefit of using LDAP is you
can take advantage of your existing LDAP solution and apply it to your ProxySG deployment. As a result, all
applications using LDAP resources can bemanaged from a single source, simplifying administration
tasks.The ProxySG appliance can be configured to use any LDAP-compatible directory service to provide
user information to authenticate users in your deployment.

When the ProxySG appliance receives an authentication request, it attempts to establish a session with the
LDAP directory by authenticating (or binding) to the server. A client can then perform various LDAP operations
on the directory data, like searching for a user, to make decisions based on authentication and authorization
policy. Keep inmind, you'll need to create authentication and authorization policies using the VPM or CPL
before network access controls are put into effect.

When users attempt to access network resources (such as the Internet), they are prompted to enter their user
credentials. As these credentials are not retained upon application shutdown, users are generally required to
submit their credentials more frequently. This repeated sign on is one of the disadvantages of LDAP
authentication. If you are looking for a true single sign on solution, consider using IntegratedWindows
Authentication (IWA) orWindows SSO authentication.

Alternatively, if you need something that provides additional security, you can use Kerberos authentication via
IWA.
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About Windows SSO
WithWindows SSO authentication, client IP addresses aremapped to usernames based onWindows Active
Directory logins. Therefore, this type of authentication will only work if your clients are running in aWindows
domain environment. In addition, because usernames are derived from IP address mappings, Windows SSO
authentication only works well in environments where one IP address maps to one user. Environments with
multi-user systems (such as Citrix) or with clients behind NAT devices are not suitable forWindows SSO
authentication.

One of the benefits of Windows SSO authentication is that users are never prompted for credentials. Instead,
there are two ways that the BCAAAWindows SSO agent can obtain the users IP address-user name
mapping:

n Domain Controller Query—Whenever a user logs in to theWindows domain, the client system
establishes a NetBIOS session with theWindows Domain Controller (DC). When you configure the
BCAAAWindows SSO agent to use DC query (DCQ), the agent immediately begins querying the DC
(s) for the user name associated with each current NetBIOS session (that is, it does not wait until it
receives an authentication request from the appliance). The agent then uses this information to create
a IP-to-user mapping table and stores in the RAM. When the appliance sends an authentication
request to the BCAAAWindows SSO agent, the agent checks to see if it has the IP address contained
in the authentication request in its mapping table. If it has themapping and themapping is still valid
(based on the freshness of the entry), authentication succeeds and it returns the username to the
appliance.

If it does not have the IP address, one of two things will happen:

o If the authentication realm is configured to perform client query (CQ) in addition to DC query, at
this point it will perform CQ.

o If CQ is not enabled, the agent will return an authentication failed response to the appliance. In
this case, report entries detailing network behavior for this user will contain IP addresses
instead of user names until the next successful authentication.

To use DCQ, youmust explicitly enable it both in theWindows SSO agent configuration on the
BCAAA server and in theWindows SSO realm settings on the appliance. When you configure the
agent, you also specify settings such as which DCs to query (by default, it queries all of them) and how
long an IP-to-user mapping is valid.

n Client Query—With CQ, the BCAAAWindows SSO agent obtains login information for a user by
directly querying the client system. To do this, it opens a Server Message Block (SMB) connection
with the client to determine the user name of the logged in user. If the agent finds one logged in user,
authentication succeeds; if it does not find a logged in user, or if it finds more than one logged in user,
authentication fails. In this case, report entries detailing network behavior for this user will contain IP
addresses instead of user names until the next successful authentication request.
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For CQ to work, theWindows SSO agent must be able to open an SMB connection to the client
systems over port 445. TheWindows firewall onmany Windows client operating systems block this
port by default. In this case, youmust modify theWindows firewall settings to allow remote access to
client systems through port 445.
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About SAML
SAML 2.0 was developed by the OASIS Security Services Technical Committee. It is an industry standard for
retrieving authorization and identity information in XML documents to facilitate single sign-on (SSO)
applications or services on the Internet. In SAML authentication, the following entities exchange information:

n Identity providers (IDPs), which are identity stores. For example, an IDP may have a back-end
directory of users. The IDP authenticates the users. See "Checklist: Prepare the IDP" on page 21 for
supported IDPs.

n Service providers (SPs), which provide access to applications or services to users. It is the entity that
creates an authenticated session for the user. In SGOS 6.5.x, the ProxySG appliance acts as the
service provider.

SAML realms are not compatible with administrative authentication to the
Management Console.

After you have defined and configured a SAML realm, and both the IDP and SP have federated and
exchangedmetadata, authentication can occur.

See "SAML Reference" on page 152 for descriptions of key concepts in
SAML.

The following is an overview of what happens when a user goes to a website that requires authentication.

Step 1- Initial user request
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The ProxySG appliance intercepts the user’s request and redirects the web browser to the IDP. The redirect
URL includes the SAML authentication request that should be submitted to the IDP’s SSO service.

If the Disable Client Redirect option is enabled, the appliance does not
redirect the client to the IDP. See "Configure the SAML Realm" on page 125
for information.

Step 2 - Authentication request and response

The IDP requests user credentials from the appliance, such as requesting a valid login/password or checking
valid session cookies for stored credentials.

If the appliance responds with valid credentials, the IDP:

n Signs an authentication response with its private signing key. If the IDP has been configured to send
encrypted assertions, the IDP encrypts the assertion before sending it to the appliance.

n Sends the authentication response to the appliance. The response contains the user's username,
which is not exposed to the appliance.

Step 3 - Assertion decryption and validation
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The appliance:

n Decrypts encrypted assertions and rejects any unsigned assertions.

n Validates the assertions and uses the private key to retrieve the user’s name and groupmemberships
(as specified in assertion attributes) from the assertion.

Step 4 - User request validation

The appliance:

n Uses the corresponding public key, which is embedded in the IDP's signing certificate, to validate the
user request.

n Redirects the user to the website and creates an authenticated session for the user.
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SAML Requirements

Setting up a SAML realm for the ProxySG appliance requires one of the following IDPs:

n Microsoft® Active Directory Federation Services (AD FS) 2.0

AD FS 1.0 ships withWindows Server 2008. If you want to use the SAML
realm with AD FS, youmust download AD FS 2.0 from theMicrosoft
website and install it.

n CA SiteMinder® Federation Partnership R12

n Oracle® Identity Federation 11g

n (Available in SGOS 6.5.2 and later) Shibboleth 2.3.5

Checklist: Prepare the IDP
Before you set up a SAML realm, make sure that you have done the following for your IDP:

n Installed and configured the administration software

n Set up the identity store for authentication

n Identified the default user attribute to be passed in SAML assertions, for example, the User Principal
Name attribute in LDAP

n Identified any additional attributes that you want to be passed in assertions, for example, the
memberOf attribute, which identifies the groups of which a user is a direct member in LDAP

n Determined the location (URL) of the IDP’s metadata file. You require this to complete the steps in
"Configure the SAML Realm" on page 125. If you import metadata, the realm uses its preconfigured
settings. See "Export the IDP Metadata File" on page 119 for instructions on locating themetadata file
for the IDP.

n To import SiteMinder, Oracle, or Shibboleth metadata, use the following CLI command:

#(config saml <realm-name>)inline idp-metadata <XML>

To avoid errors, Blue Coat recommends that you import metadata through the CLI instead of entering the
informationmanually in theManagement Console.
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Integrate ProxySG Authentication with Active Directory
Using IWA
With IntegratedWindows Authentication (IWA), users are authenticated based on theirWindows Active Directory domain
logins. There are two ways you can integrate the ProxySG appliance with your Active Directory using IWA:

n IWA Direct—The ProxySG appliance will communicate directly with your Domain Controllers (DCs) to obtain
authentication information. This option requires that you join the ProxySG appliance to yourWindows domain. See
"Configure IWA Direct" on the facing page.

n IWA BCAAA—The ProxySG appliance will contact the BCAAA server when it needs to authenticate a user. This
option requires that you install the Blue Coat Authentication and Authorization Agent (BCAAA) on a dedicated server in
yourWindows domain and configure it to communicate with both the DC and with the appliance as an authentication
agent. Use this option if you do not want to allow the ProxySG appliance to join yourWindows domain. See
"Configure IWA BCAAA" on page 57.
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Configure IWA Direct
To configure IWA Direct authentication, youmust complete the following tasks:

1. Join the ProxySG appliance to theWindows domain. See "Integrate the ProxySGApplianceWith Your
Windows Domain" on the next page.

2. (Kerberos only) If you plan to use Kerberos authentication, youmust make sure that authentication
requests are directed to the DNS name of the appliance’s Active Directory machine account name.
See "Enable Kerberos in an IWA Direct Deployment" on page 27.

3. Configure the ProxySG appliance for IWA. See "Create an IWA Direct Realm" on page 28.

4. Verify that the appliance can successfully authenticate an Active Directory user using the IWA realm
you created. See "Validate the IWA Realm Configuration" on page 70

5. Create a DNS entry for the ProxySG authentication URL. See "Create a DNS Entry for the
Authentication Domain" on page 71.

6. Configure the client browsers for single sign-on. See "Configure theWeb Browser for IWA" on page 72.

7. Create the policy rules that will enforce authentication and, optionally, authorization. See "Create an
IWA Authentication Policy" on page 74.

8. (Kerberos only) Verify that Kerberos is configured properly. See "Verify Kerberos Authentication" on
page 81.

9. (optional) Enable authentication for HTTPS traffic. This step is only required if you want to authenticate
HTTPS traffic in a transparent deployment. Explicit deployments can authenticate HTTPS traffic
without any additional configuration provided that you have a valid SSL license installed. See "Enable
IWA Authentication for SSL Traffic in a Transparent Deployment" on page 83.

For details on optimizing your IWA-Direct or BCAAA configuration, seeOptimize IWA Authentication .
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Integrate the ProxySG Appliance With Your Windows Domain
To integrate the ProxySG appliance into yourWindows domain, youmust complete the following tasks:

Step 1- Synchronize the ProxySG appliances and DC Clocks

The ProxySG cannot join aWindows domain unless its internal clock is in sync with the Domain Controller.
To ensure that the ProxySG clocks are synchronized with the Domain Controller clock, use either of the
following techniques:

n Specify the sameNTP servers for the ProxySG appliances and the Domain Controller.

n Configure the ProxySG appliances to use the Domain Controller as the NTP source server.

The ProxySGNTP configuration options are located on the Configuration > General > Clock tab.

Step 2 - Join the ProxySG appliance to the Windows Domain

After you have synchronized the ProxySG appliance’s internal clock with the Domain Controller, you can join
the appliance to theWindows Domain as follows:

1. From the ProxySGManagement Console, select Configuration > Authentication > Windows
Domain > Windows Domain.

2. Click New; the AddWindows Domain dialog displays.

3. Enter a Domain name alias and then click OK.

4. Click Apply and then click OK.

5. Select the domain Name you created. When you select it, the Details fields become active.
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6. In the DNS domain name field, enter the DNS name for theWindows Active Directory domain. This is
not the fully qualified domain name of the ProxySG.

The ProxySG appliancemust be able to resolve the DNS domain
name you supply for the Active Directory domain or the appliance will
not be able to join the domain. If DNS resolution fails, check your DNS
configuration.

7. In the SG host name field, enter the hostname to use for this ProxySG appliance. Blue Coat
recommends the appliance name or any name helpful for your recognition. The name you enter must be
unique in your Active Directory.

8. Click Join Domain; the Join domain dialog displays.

9. Enter the primary domain access Username and Password in the format: username@dnsname. For
example: administrator@blue9.acme.com. This account must have administrator privileges.
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10. Click OK. The appliance displays amessage indicating that the domain was successfully joined.

11. Click OK to close the dialog. The value in the Joined field changes to Yes.
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Enable Kerberos in an IWA Direct Deployment
In an IWA Direct realm, Kerberos configuration is minimal because the appliance has its ownmachine
account in Active Directory and it uses its account password to decrypt service tickets from clients.
Therefore, there is no need for you to create a privileged Active Directory account or generate a service
principal name (SPN) for the appliance (as is required with an IWA BCAAA realm).

To ensure that IWA uses the Kerberos protocol rather then downgrading to NTLM, you need tomake sure that
authentication requests are directed to the DNS name of the appliance’s Active Directory machine account
name as follows:

1. Create a DNS “A” record for the ProxySG that resolves to the DNS name of the appliance’s Active
Directory machine account name. For example, if you have an appliance named ProxySG1with IP
address 1.2.3.4 in the blue9 Active Directory domain at acme.com, you would create the following
DNS record:ProxySG1.blue9.acme.com Host(A) 1.2.3.4

2. Ensure that client requests are directed to the DNS name for the ProxySG appliance’s Active Directory
machine account:

n Explicit deployments—Configure the explicit proxy settings on the client browser to point to
this DNS name.

n Transparent deployments—Set the Virtual URL in the realm configuration (on the IWA
General tab) to this DNS name. In addition, make sure that the DNS name for the ProxySG
appliance's Active Directory domain is either included in the workstation's list of imputing DNS
suffixes or explicitly specified as part of IE's local intranet zone. For example, if your AD
domain DNS name is blue9.acme.com, then you would add *.blue9.acme.com to IE's local
intranet zone. See "Create an IWA Direct Realm" on the next page for details.
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Create an IWA Direct Realm
The IWA realm contains the configuration settings that the ProxySG appliance needs to be able to perform
IWA authentication, including how to connect to the Active Directory, which authentication protocols to
support, how long to wait before timing out, and where to redirect transparent requests, if applicable. After you
join the ProxySG appliance to theWindows domain, you can create the IWA Direct realm as follows:

1. Create the realm.

a. Select Configuration > Authentication > IWA > IWA Realms.

b. Click New.

c. Enter a Realm name. The name can be 32 characters long and composed of alphanumeric
characters and underscores. The namemust start with a letter.

d. In the Active Directory Connection field, select Direct.

This option will be grayed out if you have not yet joined the
appliance to aWindows domain.

e. Click OK to close the dialog.

f. To save your settings, click Apply.

2. Select the IWA Servers tab.
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3. From the Realm name drop-down list, select the IWA realm you want to configure.

4. Specify the type of credentials to accept from the browser/user agent.

By default, all credential types are allowed and the ProxySG appliance will try to use Kerberos (the
default authenticationmethod forWindows clients), but will automatically downgrade to a different
challenge type depending on the browser/user agent capabilities.

n Allow Basic credentials—Prompts the user for a username and password to authenticate the
user against theWindows Active Directory.

n Allow NTLM credentials—Uses an encrypted challenge/response that includes a hash of the
password.

n Allow Kerberos credentials—Uses a ticket containing an encrypted session key in place of a
user name and password.If you select this option, NTLM is automatically selected as well; in
the event that the browser/user agent and/or the ProxySG are not configured properly for
Kerberos, the appliance will automatically downgrade to NTLM.

5. (Optional) If you are sharing a service principal name (SPN) across multiple ProxySG appliances in a
load balancing configuration, click Set credentials, enter the User name and Password for an Active
Directory account, and then click OK. For details, see "Using IWA Direct in an Explicit Kerberos Load
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Balancing/Failover Scenario" on page 54.

6. (Optional) To change the amount of time the appliance will wait for an authentication response before
timing out, enter a new value in the Timeout request after x seconds field (default 60 seconds).

7. Click Apply.

8. Verify that you have configured the realm successfully.

a. Click Test Configuration.

b. When prompted, enter the username and password of a user in theWindows domain and then
click OK.

c. The appliance sends an authentication request to the configured server and then displays a
message indicating whether the authentication succeeded or failed. If the test failed, go back
andmake sure you have configured the realm properly. If the test succeeds, themessage also
displays a list of groups to which the user belongs.
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9. Select the IWA General tab.

10. Select the Realm name.

11. (Optional) By default, the ProxySG appliance displays the authentication realm namewhen prompting
the user for authentication credentials. To change the name that is displayed when the ProxySG
appliance challenges the user for credentials from the default realm name, enter a new value in the
Display name field, up to amaximum of 128 characters. This field cannot be left empty.

12. (Optional) If you want to change how often the appliance reauthenticates a client, modify the refresh
and timeout values.

n Credential refresh time—(Basic credentials only) Specifies the amount of time the appliance
will cache Basic credentials (username and password) and use these cached credentials to
authenticate the user rather than sending another request to the authentication server. By
default, basic credentials are good for 900 seconds (15minutes).

n Surrogate refresh time—After the appliance successfully authenticates a client, it caches the
client’s IP address or a cookie (depending on the authenticationmode that is in use) in its
surrogate cache. If it receives subsequent requests from the same client during the surrogate
refresh time, it uses the IP address or cookie in its cache to authenticate the user instead of
sending a request to the authentication server. By default, the surrogate credential is good for
900 seconds (15minutes).

n Inactivity timeout—When a client request is successfully authenticated, the appliance
establishes an active session with the client and as long as that session stays active, the
appliance will not attempt to reauthenticate requests from that client. This setting specifies how
long the client session can be inactive before the appliance terminates the session; subsequent
requests from that client will require authentication. By default, the client can be inactive for 900
seconds (15minutes).

If the Challenge user after logout option is selected, the
appliance will automatically challenge the client for credentials
when the session becomes inactive. If you are using a challenge
method that prompts the user for credentials, youmay want to
deselect this option.

n Rejected credentials time—(Basic credentials only) Specifies whether to cache failed
authentication attempts (bad password, expired account, disabled account, old password, or
server down). If the client attempts to connect again during the rejected credentials time, the
appliance will automatically reject the request for the specified period of time. Enter a value from
1 second (the default) to 10 seconds. Or, to disable this option, enter 0.

13. (Optional) Modify how the appliance uses cookie surrogates by modifying the Cookies settings. These
settings are only applicable if you plan to use an authenticationmode that uses cookie surrogates.

n Use persistent cookies—By default, this option is deselected, whichmeans that the appliance
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will use session cookies when creating a cookie surrogate for a client. Session cookies are only
valid during the current browser session and are deleted when the user closes the browser.
Therefore, the ProxySG appliancemust reauthenticate the client each time the user starts a
new browser session. If you select this option, the appliance will use persistent cookies instead
of session cookies. Persistent cookies are stored on the client system and are therefore not
deleted at the end of the browser session. When using persistent cookies, the appliance will
only need to reauthenticate a client when the cookie in its surrogate credential database
expires.

n Verify the IP address in the cookie—By default, this option is selected, whichmeans that the
appliance will only accept a cookie from a client if the client IP matches the IP address in the
surrogate cookie. To enable the appliance to accept cookies from IP addresses that do not
match the address in the cookie—for example if you use DHCP— deselect this option.

14. (Transparent proxy only) Specify the URL to which to redirect client requests that require
authentication in the Virtual URL field.

The way you configure the Virtual URL depends on what authenticationmethod you are using:

n NTLM—The Virtual URL must contain a simple hostname that does not contain any dots (for
example, use http://myproxy rather than http://myproxy.acme.com. This allows IE to
recognize the URL as part of the Intranet zone rather than the Internet zone so that the browser
will automatically return credentials when challenged rather than prompting the user.

In addition, the Virtual URL must resolve to the IP address of the ProxySG appliance. To
accomplish this, youmust add an "A" record to your internal DNS server that associates the
Virtual URLwith the IP address of the ProxySG appliance.

n Kerberos—If you’re using Kerberos in a non-load balancing IWA Direct realm, the Virtual URL
must be the DNS name of the ProxySG appliance in the Active Directory domain. Typically this
will be the DNS name of the Active Directory domain prefixed with the ProxySG appliance
machine account name. For example, sg.blue9.local. If you do not use the Active Directory
DNS name of the ProxySG as the Virtual URL, all authentication transactions will be
downgraded to NTLM.

15. (Optional) If you want to prompt the client for authentication credentials whenever the inactivity timeout
expires, select the Challenge user after logout check box.

16. To save the realm configuration, click Apply.
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Validate the IWA Realm Configuration
After you configure an authentication realm on the ProxySG, youmust verify that the ProxySG appliance can
successfully connect to the authentication server and successfully authenticate a user as follows:

1. In theManagement Console, select Configuration > Authentication > IWA > IWA Servers.

2. Click Test Configuration.

3. When prompted, enter the username and password of a user in theWindows domain and then click
OK.

4. The appliance sends an authentication request to the configured server and then displays amessage
indicating whether the authentication succeeded or failed.

n If the test fails, go back andmake sure you have configured the realm properly.

n If the test succeeds, themessage also displays a list of groups to which the user belongs (IWA
Direct) or a list of groups of interest to which the user belongs (IWA BCAAA). A group of interest
is a group that is referenced in ProxySG policy.
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Create a DNS Entry for the Authentication Domain
For IWA authentication to be successful, your clients must be able to resolve the fully qualified domain name
of the ProxySG authentication URL to the IP address of the ProxySG appliance.

1. Create a DNS "A" record that associates the ProxySG authentication domain with the IP address of
the ProxySG appliance. The fully qualified domain name (FQDN) that you use depends on whether you
are using an explicit or transparent deployment:

n Explicit deployments—Set the hostname in the DNS A record tomatch the ProxySG domain
name specified in the browser's explicit proxy configuration.

n Transparent deployments—Set the hostname in the DNS A record tomatch the Virtual URL in
the IWA configuration.

2. Configure the client systems to use the DNS server where you created the "A" records for the
ProxySG appliance.

3. From a client system, ping the hostname specified in the A record to ensure that it resolves to the IP
address of the ProxySG appliance.
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Configure the Web Browser for IWA
One of themain benefits of IWA is that it can provide a single sign-on experience for users because it uses the
workstation login to authenticate users. When configured properly, the browser will provide the credentials to
the ProxySG appliance transparently when challenged for NTLM or Kerberos credentials (the user will always
be prompted for Basic authentication credentials).

IWA only works withWindows domain credentials. If users log in to the
workstation using local credentials instead of domain credentials, they will
be always be prompted whenever the ProxySG returns an authentication
challenge.

Both Internet Explorer (IE) and Firefox can be configured to provide authentication credentials to the ProxySG
appliance transparently:

n By default, IE will automatically provide authentication credentials to any site in the local Intranet zone.
If the URL for your ProxySG appliance (explicit deployments) or virtual URL (for transparent
deployments) contains a single hostname (that is, http://myproxy instead of
http://myproxy.acme.com) you will not have to configure IE for IWA. If your ProxySGURL (virtual or
explicit) does not fall within the Intranet zone, you will need to configure the IE to trust the URL. Keep
inmind, however, that Kerberos deployments will require you to use the full URL for the Active
Directory machine account (either the BCAAA machine account for IWA BCAAA or the ProxySG
machine account for IWA direct). In these cases, you will need to add the full URL to the local Intranet
zone.

n Firefox does not provide support for IWA by default and will therefore always need to be configured if
you want to provide a single sign-on experience for your users.

For explicit proxy deployments, youmust alsomake sure the browser is
configured to send requests to the ProxySG appliance. See "Configure
Client Web Browsers for Explicit Proxy" on page 37.

The procedure for configuring the browser to automatically provide login credentials to the ProxySG appliance
is browser-specific:

n Internet Explorer

1. Select Tools > Internet Options.

2. Select the Security tab.

3. Select the Local intranet zone and click Sites > Advanced.

4. Enter the fully qualified domain name of the ProxySG appliance (for explicit deployments) or the
virtual URL (for transparent deployments) in the Add this website to the zone field and then
click Add > Close > OK.
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5. Select the Advanced tab andmake sure the Security > Enable Integrated Windows
Authentication option is selected.

6. Click OK to save your changes and close the Internet Options dialog.

n Firefox

1. In the browser's Location field, enter about:config.

2. Click I'll be careful, I promise! to continue to the about:config page.

3. To get the browser to trust the ProxySG appliance and negotiate authentication with it, you
must set values for the following options: network.automatic-ntlm-auth.trusted-uris,
network.negotiate.auth.delegation-uris, network.negotiate-auth.trusted-uris. For each
option, complete the following steps:

a. Locate the option you want to set by scrolling or entering the option name in the Filter
field.

b. Double-click the option to open the Enter string value dialog.

c. Enter the fully-qualified domain name of the ProxySG appliance (for explicit
deployments) or the virtual URL (for transparent deployments). If you havemore than
one ProxySG appliance that will challenge users for authentication credentials, separate
the entries with commas.

d. Click OK.
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Configure Client Web Browsers for Explicit Proxy

When you deploy the ProxySG appliance explicitly, the appliance is not in the direct path of network traffic. To ensure that all
Web requests aremanaged by the appliance, youmust configure theWeb browsers for all network users to point to the
appliance.

There are two ways to configure client browsers for explicit proxy:

n Manually configure theWeb browsers to sendWeb requests to the ProxySG appliance

n Automatically configure theWeb browsers using PAC files
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Configure the Web Browser to Use the Explicit Proxy

If you do not use PAC files to automatically configure network access information for clients in your network, youmust
manually configure theWeb browser to sendWeb requests to the ProxySG appliance.

Typically, the browser proxy configuration requires the IP address or hostname of the ProxySG appliance and the port on
which the ProxySG appliance will listen for traffic. The default port is 8080. The required hostname format (that is, whether you
must provide a fully qualified DNS hostname or a short hostname) depends on the DNS configuration on your client systems.

The procedure for manual configuration varies by yourWeb browser version. Select the appropriate set of instructions from the
list below:

n Internet Explorer

1. Select Tools > Internet Options.

2. Select the Connections tab.

3. If you are using a LAN, click LAN Settings. If you are using a Dial-up or Virtual Private Network connection,
click Add to set up the connection wizard.

4. Make sure the Automatically detect proxy settings and Use automatic configuration script options are not
checked.

5. Select Use a proxy server for your LAN.

6. Select Advanced. The Proxy Settings dialog displays.

7. For HTTP, enter the IP address of the ProxySG appliance, and add the port number; 8080 is the default.

8. Select Use the same proxy server for all protocols.

9. (Optional for non-administrative users, best practice, recommended when setting up theWeb browser for
ProxySG appliance administrators) Enter the ProxySG appliance IP address for Do not use the proxy server
for addresses beginning with:

This setting ensures that administrators are never locked out from access to theManagement Console; requests
that match the entries above are not intercepted by the ProxySG appliance.

10. (Optional) If you do not want to intercept your local or internal Web servers, enable Bypass proxy server for
local addresses and enter the IP addresses.

11. Click OK to save your settings and close all open dialogs.

n Firefox

1. Select Tools > Options.

2. Select Advanced icon.

3. Select the Network tab.
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4. Click Settings under the Connection panel.

5. Select Manual proxy configuration.

6. In the HTTP Proxy field, enter the ProxySG appliance's IP address and port number; 8080 by default.

7. Select Use this proxy server for all protocols.

8. (Optional for non-administrative users, Best practice, recommended when setting up theWeb browser for
ProxySG appliance administrators) Enter the IP address of the ProxySG or the subnet to exclude in the No
proxy for field.

9. Click OK to save your settings and close all open dialogs.
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Set Up the Explicit Proxy to Use a PAC File

The Proxy Auto Configuration (PAC) file is ameans of controlling user access to the Internet or the intranet. A PAC file is a
JavaScript file with a .pac extension that contains instructions on when and whether theWeb browser should use the ProxySG
appliance for retrieving requested content. Network administrators like to use PAC files because they are centrally
administered, and easy to update.

If you already have a PAC file on aWeb server in your network, add the URL for this file to theWeb browser configuration for
all clients in your network. Defining the location of the PAC file enables theWeb browser to discover and download the proxy
configuration instructions for handlingWeb requests.

To define the location of the PAC file on theWeb browser and test the configuration:

1. Launch theWeb browser.

2. Add the URL for the PAC file in theWeb browser. Follow the instructions for yourWeb browser:

Internet Explorer

a. Select Tools > Internet Options > Connections > LAN Settings.

If you are using a Dial-up or Virtual Private Network connection, select the necessary connection and click the
Settings button.

b. Select the Use automatic configuration script option and add the URL in the Address field.

c. Click OK to save your changes.

Firefox

a. Select Tools > Options > Advanced > Network > Connection Settings.

b. Select Automatic proxy configuration URL and add the URL in the corresponding input field.

c. Click OK to save your changes.

Web browsers typically cache the PAC file. To test modifications to your PAC
file settings, youmust:

o Reload the PAC file in Firefox.

o Close all browser sessions and clear the cache in IE.

Safari on Macintosh

a. Select Apple menu > System Preferences.

b. Select Internet & Wireless > Network.
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c. Select Advanced > Proxies.

d. Select Automatic Proxy Configuration and add the URL for the location of the PAC file in the input field.

e. Click Apply Now.

3. Verify that yourWeb requests are being intercepted by the ProxySG.

a. Enter a URL and click through a few links on theWeb page. For example, go to www.bluecoat.com and navigate
through the website.

b. Launch the ProxySGManagement Console.

c. Select Statistics > Summary > Efficiency.

d. Verify that the ProxySG appliance displays Explicit HTTP traffic in the Savings panel.
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Create an IWA Authentication Policy
After you verify that BCAAA and the ProxySG appliance can successfully authenticate users against your
Active Directory (AD), youmust create the policy that enables authentication on the appliance. You can
create a basic authentication policy that simply requires all requests to be authenticated and allows or denies
access upon successful authentication. Or you can definemore complex policies with rules that apply to a
specific source address, subnet, port, user agent, or request header. Or, you can define different rules for
different destinations. You can also create policies that allow access to guest users.

You can additionally create authorization policies that restrict access by user or groupmembership.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL). Refer to the Content Policy Language Reference for details.

Note that youmust create an IWA realm before you can define the corresponding authentication policy.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create the policy rule that enables the ProxySG appliance to authenticate client requests.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

3. Configure the authentication policy settings.

a. In the Action column of the first row, right-click and then select Set. The Set Action Object
dialog displays.

b. Click New and then select one of the following authentication objects:

n Authenticate—Use this option if you do not need to log user IDs for denied requests.
With this option, if policy causes a request to be denied before the user is authenticated,
the user ID associated with the request will not be available for access logging.

n Force Authenticate—Use this option to force the appliance to authenticate requests
even if they are denied before authentication would normally occur. This ensures that
user IDs are available for access logging.
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If you plan to create a guest authentication policy, create a
combined object that contains the Authenticate object and a
Permit Authentication Error object (be sure to select All
Except User Credentials Required).

c. (optional) Specify a Name for the authentication object.

d. Select the IWA Realm from the drop-down list.

e. Select the authenticationmode from theMode drop-down list. Although you can select Auto to
have the ProxySG appliance automatically choose an authenticationmode, it is usually better
to make a selection that is appropriate for your deployment as follows:

n Explicit deployments—Select Proxy or Proxy IP. The Proxy IP mode reduces the load
on the network because it uses an IP surrogate to reauthenticate clients that have
already successfully authenticated.

n Transparent deployments—Select Origin Cookie Redirect. This mode redirects the
client to the virtual URL for authentication and uses a cookie surrogate to reauthenticate
clients that have already successfully authenticated. The appliance will automatically
downgrade to the Origin IP Redirect mode for user agents that do not support cookies.

f. Click OK to close the Add Authenticate Object or Add Force Authenticate object dialog.

g. Click OK to close the Set Action Object dialog.

4. (optional) Restrict authentication to a subset of client requests, based on source or destination request
attributes.

The default settings in the policy rule will cause the ProxySG appliance to authenticate all client
requests. You can set the Source and/or Destination columns to restrict authentication to a specified
subset of requests. For example,

a. In the Source or Destination column of the first row, right-click and then select Set. The Set
Source Object or Set Destination object dialog displays.

b. Click New and then select an object that represents the subset of requests you want to
authenticate. After you select an object, you will be prompted to provide details. For example, if
you choose the Client IP Address/Subnet object, you will be prompted for an IP address and
subnet mask/prefix to which this rule will apply.

When you first deploy your authentication policy, youmay want
to limit authentication to the source address of a test workstation
or subnet. This allows you to identify and troubleshoot any
configuration issues before rolling the policy out into production.

5. (optional) Add additional policy rules to refine your authentication policy.

A singleWeb Authentication Layer rule with the authenticate action is all you need to enable
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authentication. However, theremay be some cases where you want to bypass authentication for
certain requests and enable it for others. For example, youmay have a certain client, subnet, or URL
on which you do not require authentication or youmay have some custom applications that do not
know how to handle authentication requests. In this case, you would add an additional rule to yourWeb
Authentication Layer policy to instruct the ProxySG appliance how to handle the exceptions.

a. Click Add Rule. A new row appears in theWeb Authentication Layer.

b. Specify which client requests this rule applies to by setting the Source or Destination
columns.

c. Specify what the ProxySG appliance should do with requests that match the source and/or
destination setting you have defined by right-clicking in the Action column of the row, and
selecting Set.

n If you want to authenticate requests that match the specified source and/or destination
request settings you have defined, click New and select Authenticate and click OK.

n If you want to bypass authentication for thematching requests, select Do Not
Authenticate and click OK.

d. Prioritize the order in which you want the ProxySG appliance to enforce therules by selecting
the rule you want to move and clickingMove up or Move down.The ProxySG appliance
evaluates the rules in the order in which they appear in the policy layer. As soon as it finds a rule
that matches the request, it will enforce the specified action (in this case, either to authenticate
or not authenticate the request). Therefore, you should put more specific rules above general
rules. For example, if you have a two rules in your policy—one that is set to authenticate
requests from any source or destination and one that is set to not authenticate requests from a
specific subnet—you would put the one that bypasses authentication in front of the general rule
that matches all requests.

6. Install the authentication policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Create an IWA Guest Authentication Policy

A guest authentication policy enables users who do not have aWindows domain account on your network to
access Internet resources.

To create an IWA guest authentication policy:

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create aWeb Authentication Layer for authenticating client requests for your domain users.

See "Create an IWA Authentication Policy" on page 74 for instructions.

3. Create a secondWeb Authentication Layer to provide guest access.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name to distinguish this layer from the previous layer (for example, Guest
Authentication) and then click OK. The first policy rule displays with default settings.

4. Configure the source.

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select User Authentication Error. The Add User Authentication Error
Object dialog displays.

c. Select Any errors and click OK twice to save the source object and close the dialogs.

5. Configure the action.

a. Right-click the Action column and then select Set. The Set Action Object dialog displays.

b. Click New and then select the Authenticate Guest object. The Add Authenticate Guest object
dialog displays.

c. Select Use realm and then select your IWA realm from the drop-down list.

d. Enter a Guest Username. This will be the name that appears in your access log whenever
guest access is granted; it does not correlate to an Active Directory user account.

e. Click OK twice to save the Action object and close the dialogs.

6. Make sure that theWeb Authentication Layer for your guest policy is positioned after the your main
Web Authentication Layer.
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To re-order the layers, select Edit > Reorder Layers.

7. Install the authentication policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Create an IWA Authorization Policy

One of the benefits of IWA is that it automatically returns authorization information for a user in response to an
authentication request. You do not have to perform any additional configuration to get authorization to work.
After successfully authenticating a user, the appliance receives a list of all groups (IWA Direct) or groups of
interest (IWA BCAAA) to which the user belongs.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL). Refer to the Content Policy Language Reference for details.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create aWeb Access Layer.

a. Select Policy > Add Web Access Layer.

b. Enter a Layer Name or accept the default name and then click OK.

3. Specify the user or group to authorize (the source).

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select the type of Active Directory object this rule will authorize:

n To create a rule for authorizing a group,select Group. The AddGroupObject dialog
displays.

n To create rule for authorizing a user, select User. The Add User Object dialog displays.

c. Select the IWA realm from the Authentication Realm drop-down list.

d. Specify the name of the Active Directory user or group that rule will authorize:

n If you know the name of the Active Directory user or group, enter it in the Group or User
field.

n If you don't know the Active Directory name of the user or group, click Browse and
select the group from the IWA Browser.

e. Click OK to close the AddGroupObject or Add User Object dialog.

f. Click OK to close the Set Source Object dialog.

4. Specify whether to allow or deny requests from the specified user or group.
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a. Right-click the Action column.

b. Select one of the following options:

n Allow—Select this option if the default proxy policy for the appliance is set to deny proxy
access through the ProxySG appliance. This is the default in a secure web gateway
deployment.

n Deny—Select this option of the default proxy policy for the appliance is set to allow proxy
transactions.

If you aren't sure what the default proxy policy is set to on your
appliance, go to Configuration > Policy > Policy Options.

5. (Optional) Define any additional parameters that you want this rule to enforce.

6. To create additional authorization rules, repeat Steps 3 through 5.

7. Install the policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Verify Kerberos Authentication
Even if you configure IWA to allow Kerberos, Kerberos will only be used if configured properly. If the ProxySG
appliance cannot successfully negotiate Kerberos with a client, it will silently downgrade to use NTLM
authentication. Because this happens behind the scenes, youmay not know whether you are using Kerberos
or NTLM.

1. To verify that the ProxySG appliance is attempting to negotiate Kerberos authentication, take a packet
capture on the client and look for the NEGOTIATEmessage.The client uses the NEGOTIATEmessage to
communicate the type of authentication it supports to the ProxySG appliance. This will show up as a
either a WWW-Authenticate: NEGOTIATE (transparent) or Proxy-Authenticate: NEGOTIATE
message. Note that this message alone does not indicate that Kerberos will be used.

2. To verify that the client is using Kerberos, take a packet capture from the client and use the display
filter to view Kerberos requests. If Kerberos authentication is in use you will see Kerberos requests and
responses between the client and the Domain Controller as well as the Kerberos ticket in the GET
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request.
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Enable IWA Authentication for SSL Traffic in a Transparent
Deployment
After you configure IWA, youmust complete the following additional tasks if you are using a transparent proxy
deployment and you want to authenticate SSL traffic:

1. Make sure you have an SSL license.

Although some ProxySG appliancemodels include an SSL license, other models require that you
purchase and install an add-on license. To see whether you have a valid SSL license, launch the
ProxySGManagement Console and select Maintenance > Licensing > View. You should check that
SSL displays in the list of licensed components.

2. Create an HTTPS Reverse Proxy service to listen for authentication requests.

a. Select Configuration > Services > Proxy Services.

b. Click New Service.

c. Enter a unique Name for the service to identify it as your IWA authentication service.

d. Select HTTPS Reverse Proxy from the Proxy drop-down list.

e. Select the Keyring that you want to use to establish SSL sessions for this service.
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f. To configure the listening port, click New and then configure the service as follows:

n Set Destination Address to Explicit.

n Set the Port range to the port number on which you want this service to listen for
incoming authentication requests. Note that you will need to use this same port number
in the Virtual URL you define for the realm.

n Set the Action to Intercept.

n Click OK to save the listener settings.

g. Click OK.

h. If necessary, configure your firewall to allow traffic between the client workstations and the
ProxySG appliance on the port you just configured.

3. Create an IWA realm for authenticating your HTTPS traffic.

You create the realm the sameway that you created the IWA realm for your HTTP traffic, with the
difference being the URL to which authentication requests are directed:

a. Create the IWA realm as described in "Create an IWA Direct Realm" on page 28 or "Create an
IWA BCAAA Realm" on page 60 .

b. On the IWA General tab, set the Virtual URL to a URL that points to the HTTPS Reverse
Proxy Service you created for IWA authentication. For example, if you configured your HTTPS
Reverse Proxy service to listen on port 4433, you would enter a URL such as
https://myproxy:4433.

c. Make sure your DNS server is set up to resolve the hostname to the IP address of the ProxySG
appliance.

4. Create the policy rule to enable the appliance to intercept HTTPS traffic.

a. Launch the Visual Policy Manager (VPM) by selecting Configuration > Policy > Visual Policy
Manager > Launch.

b. Select Policy > Add SSL Intercept Layer.

c. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

d. Right-click the Action column and select Set.

e. Click New and select Enable HTTPS Interception.

f. Check the Issuer Keyring check box and select the keyring you specified in the
HTTPS Reverse Proxy service settings.

g. Click OK.
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5. Create the policy rule that enables the ProxySG appliance to authenticate client HTTPS requests.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

c. In the Action column of the first row, right-click and then select Set. The Set Action Object
dialog displays.

d. Click Newand then select Authenticate.

e. Select the IWA Realm from the drop-down list. Make sure you select the realm you created for
your HTTPS traffic.

f. Select the authenticationmode from theMode drop-down list. For transparent authentication,
you will usually want to select Origin Cookie Redirect. This mode redirects the client to the
virtual URL for authentication and uses a cookie surrogate to reauthenticate clients that have
already successfully authenticated. The appliance will automatically downgrade to the Origin
IP Redirect mode for user agents that do not support cookies.

g. Click OK to close the Add Authenticate Object or Add Force Authenticate object dialog.

h. Click OK to close the Set Action Object dialog.

6. Install the policy rules you created.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Using IWA Direct in an Explicit Kerberos Load Balancing/Failover
Scenario
In a standard IWA Direct Kerberos deployment, the Kerberos service principal name (SPN) of the appliance is
the appliance’s own Active Directory machine account name. However, in a load balancing configuration,
multiple ProxySG appliances must be able to decrypt the service tickets from the clients. For this reason, all
ProxySG appliances in a load balancing groupmust share the same SPN. This will not work if each appliance
uses its ownmachine account to process Kerberos authentication requests. In this case, youmust create a
new Active Directory account and use it to create a SPN that can be used by all appliances in the group. To
deploy Kerberos in this configuration youmust:

1. Set up a load balancing device in front of your appliances and designate a virtual IP address to use for
all explicit proxy request. The load balancing device will then forward the requests to the ProxySG
appliances in the group based on the load balancing rules you have defined.

2. Create a DNS entry for the device that resolves to this IP address. Note that the DNS name that you
usemust not map to an existingmachine account name in Active Directory or the ProxySG appliance
will not be able to authenticate Kerberos service tickets and authentication will fail.

3. Create an Active Directory account for the Kerberos load balancing user. This account does not need
any special privileges. You will create the SPN using this account and the ProxySG appliances will
use the account credentials to decrypt the service tickets from clients.

4. Use the Active Directory account you just created to create an SPN for the load balancing group as
follows:

a. Open a command prompt as administrator on the Domain Controller.

b. Enter the following command:

setspn –A HTTP/<Load_Balancer_FQDN> <AD_Account_Name>

where <Load_Balancer_FQDN> is the fully qualified domain name (FQDN) of the load balancing
device and <AD_Account_Name> is the name of the Active Directory user you created for the
load balancing group. Note that this command is case-sensitive.

For example, if the FQDN of the load balancing device is lb.acme.com and the Active Directory
account name you created is KerberosLBUser, you would enter the following command:

setspn –A HTTP/lb.acme.com KerberosLBUser

Do not assign the same SPN tomultiple Active Directory
accounts or the browser will fall back to NTLM without providing
any warning or explanation. To list all SPNs that are currently
registered on an account, use the setspn -L <AD Account
Name> command. If you find a duplicate, remove the extraneous
SPN using the setspn -D <SPN> command.
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5. On each ProxySG, create an IWA Direct realm. When configuring the realm on each appliance, you
must provide the credentials for the AD Kerberos load balancing user you created. On the IWA
Servers tab click Set credentials, enter the AD account User name and Password, and then click
Update. Note that the user name you providemust be in the User Principal Name (UPN) format, for
example admin@acme.com.

6. Configure the client browser explicit proxy settings to point to the FQDN of the load balancing device.
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Preparing for a Kerberos Deployment
Kerberos is the recommended challenge protocol for IWA because it is more secure than NTLM or Basic and
it puts the least load on your network.

To ensure that IWA uses the Kerberos protocol rather then downgrading to NTLM, youmust make sure that
authentication requests are directed to the Kerberos service associated with the ProxySG appliance. The way
you configure this depends on how your IWA realm is connecting to the Active Directory as follows:

n "Enable Kerberos in an IWA Direct Deployment" on page 27

n "Enable Kerberos in an IWA BCAAA Deployment" on page 58
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Configure IWA BCAAA
To configure IWA BCAAA authentication, youmust complete the following tasks:

1. Install BCAAA on aWindows server that is amember of theWindows domain. Refer to the BCAAA
Service Requirements document for more information about installing BCAAA.

2. (Kerberos only) If you plan to use Kerberos authentication, register BCAAA as a Kerberos service. See
"Enable Kerberos in an IWA BCAAA Deployment" on the next page.

3. Configure the ProxySG appliance for IWA. See "Create an IWA BCAAA Realm" on page 60.

4. (optional) Set up secure communication between the ProxySG appliance and BCAAA. See "Enable
SSL Between BCAAA and the ProxySGAppliance" on page 64

5. Verify that the appliance can successfully authenticate an Active Directory user using the IWA realm
you created. See "Validate the IWA Realm Configuration" on page 70

6. Create a DNS entry for the ProxySG authentication URL. See "Create a DNS Entry for the
Authentication Domain" on page 71.

7. Configure the client browsers for single sign-on. See "Configure theWeb Browser for IWA" on page 72

8. Create the policy rules that will enforce authentication and, optionally, authorization. See "Create an
IWA Authentication Policy" on page 74.

9. (Kerberos only) Verify that Kerberos is configured properly. See "Verify Kerberos Authentication" on
page 81.

10. (optional) Enable authentication for HTTPS traffic. This step is only required if you want to authenticate
HTTPS traffic in a transparent deployment. Explicit deployments can authenticate HTTPS traffic
without any additional configuration provided that you have a valid SSL license installed. See "Enable
IWA Authentication for SSL Traffic in a Transparent Deployment" on page 83.

57

https://bto.bluecoat.com/doc/19467
https://bto.bluecoat.com/doc/19467


Integrate ProxySGAuthentication with Active Directory Using IWA

Enable Kerberos in an IWA BCAAA Deployment
For the BCAAA service to participate in an IWA Kerberos authentication exchange, it must share a secret
with the Kerberos server (called a KDC) and have registered an appropriate Service Principal Name (SPN).

To prepare for a BCAAA Kerberos deployment:

1. On your DNS server, create a DNS “A” record for the ProxySG that resolves to the appliance’s Fully
Qualified Domain Name (FQDN). Keep inmind that the DNS name you choosemust not match the
Active Directory machine account name for the appliance. For example, rather than using themachine
name, youmight create a DNS entry for the appliance using a name such as bcaaaUser1. Supposing
the appliance is in the acme.com domain and has an IP address of 1.2.3.4, you would create the
following DNS record:

bcaaaUser1.acme.com Host(A) 1.2.3.4

2. Create a domain user account for the BCAAA service in theWindows Active Directory (AD).

3. Install BCAAA. Refer to the BCAAA Service Requirements document for more information about
installing BCAAA.

4. Configure the BCAAAWindows service on the system where you installed BCAAA to log on using the
domain user account you created for it in Step 2 rather than using the local system account.

5. In the Local Security Policy of the server on which BCAAA is running, modify the user rights
assignment for the BCAAA domain user to have the following rights:

n Full access to the directory where you installed BCAAA

n Act as part of the operating system

n Log on as a service

6. Register the Kerberos Service Principal Name (SPN) for the ProxySG appliance:

a. Log in to the Domain Controller using an account with administrative access and open a
command prompt.

b. Enter the following case-sensitive command:

setspn -A HTTP/<FQDN_of_ProxySG> <AD_Account_Name>

Where <FQDN_of_ProxySG> is the FQDN of the ProxySG appliance as specified in the
browser's explicit proxy configuration (explicit deployments) or in the Virtual URL setting in the
IWA realm configuration (transparent deployments) and <AD_Account_Name> is the name of the
BCAAA domain service account.
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For example:

setspn -A HTTP/bcaaaUser1.acme.com AcmeDomain\BCAAAuser

Do not assign the same SPN tomultiple Active Directory
accounts or the browser will fall back to NTLM without providing
any warning or explanation. To list all SPNs that are currently
registered on an account, use the setspn -L <AD Account
Name> command. If you find a duplicate, use the setspn -D
<SPN> command to remove the duplicate SPN.

59



Integrate ProxySGAuthentication with Active Directory Using IWA

Create an IWA BCAAA Realm
After you install BCAAA, youmust configure the appliance to communicate with it. On the ProxySG
appliance, the settings required for the appliance to communicate with BCAAA are contained in a realm. To
enable IWA BCAAA authentication, youmust create an IWA realm and configure it to work with your
BCAAA server.

1. Create the IWA realm and configure it to communicate with the BCAAA server(s).

a. In the ProxySGManagement Console, select Configuration > Authentication > IWA > IWA
Realms.

b. To add a new IWA realm, click New.

c. When prompted, enter a Realm name.

d. In the Primary server host field, enter the hostname or IP address of the server where you
installed BCAAA. In addition, if you configured BCAAA to use a port other than the default
(16101), change the value in the Port field to match what you configured on BCAAA.

If you plan to secure communication between the appliance and
BCAAA, use a host name rather than an IP address. The
DNS server that the appliance is configured to usemust be able
to resolve the hostname.

e. Click OK. The realm you just created is added to the IWA Realms tab.

f. Select the IWA Servers tab and then select the Realm name to configure.

g. (Optional) If you have installed and configured a second BCAAA server for failover, enter the
Alternate server host and Port values in the Servers section.

h. (Optional) To change the amount of time the appliance will wait for an authentication response
from BCAAA before timing out, enter a new value in the Timeout request after x seconds field
(default 60 seconds).

2. Specify the type of credentials to accept from the browser/user agent.

By default, all credential types are allowed and the ProxySG appliance will try to use Kerberos (the
default authenticationmethod forWindows clients), but will automatically downgrade to a different
challenge type depending on the browser/user agent capabilities.

n Allow Basic credentials—Prompts the user for a username and password to authenticate the
user against theWindows Active Directory. Because the username and password are sent in
plaintext, it is important to enable SSL between BCAAA and the ProxySG appliance if you allow
Basic authentication.
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n Allow NTLM credentials—Uses an encrypted challenge/response that includes a hash of the
password. Because the plaintext username and password are not sent across the wire, this
method is more secure than Basic authentication.

n Allow Kerberos credentials—Uses a ticket containing an encrypted session key in place of a
user name and password. This is themost securemethod because it establishes mutual
authentication between the client and the server using an encrypted shared key. However, if
you select this option, NTLM is automatically selected as well; in the event that the
browser/user agent and/or the BCAAA server are not configured properly for Kerberos, the
ProxySG appliance will downgrade to NTLM.

3. Verify that you have configured the realm successfully.

a. Click Test Configuration.

b. When prompted, enter the username and password of a user in theWindows domain and then
click OK.

c. The appliance sends an authentication request to the configured server and then displays a
message indicating whether the authentication succeeded or failed. If the test failed, go back
andmake sure you have configured the realm properly. If the test succeeds, themessage also
displays a list of groups to which the user belongs.

4. (Optional) Modify the refresh and timeout values on the IWA General tab if you want to change how
often the ProxySG appliance reauthenticates a client.

n Credential refresh time—(Basic credentials only) Specifies the amount of time the ProxySG
appliance will cache Basic credentials (username and password) and use these cached
credentials to authenticate the user rather than sending another request to BCAAA. By default,
basic credentials are good for 900 seconds (15minutes).

n Surrogate refresh time—After the ProxySG appliance successfully authenticates a client, it
caches the client’s IP address or a cookie (depending on the authenticationmode that is in use)
in its surrogate cache. If it receives subsequent requests from the same client during the
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surrogate refresh time, it uses the IP address or cookie in its cache to authenticate the user
instead of sending a request to BCAAA. By default, the surrogate credential is good for 900
seconds (15minutes).

n Inactivity timeout—When a client request is successfully authenticated, the ProxySG
appliance establishes an active session with the client and as long as that session stays active,
the ProxySG appliance will not attempt to reauthenticate requests from that client. This setting
specifies how long the client session can be inactive before theProxySG appliance terminates
the session; subsequent requests from that client will require authentication. By default, the
client can be inactive for 900 seconds (15minutes).

If the Challenge user after logout option is selected, the
ProxySG appliance will automatically challenge the client for
credentials when the session becomes inactive. If you are using
a challengemethod that prompts the user for credentials, you
may want to deselect this option.

n Rejected credentials time—(Basic credentials only) Specifies whether to cache failed
authentication attempts (bad password, expired account, disabled account, old password, or
server down). If the client attempts to connect again during the rejected credentials time, the
ProxySG appliance will automatically reject the request for the specified period of time. Enter a
value from 1 second (the default) to 10 seconds. Or, to disable this option, enter 0.

5. (Optional) Modify how the appliance uses cookie surrogates by modifying the Cookies settings on the
IWA General tab. The cookie settings are only applicable if you plan to use an authenticationmode
that uses cookie surrogates.

n Use persistent cookies—By default, this option is deselected, whichmeans that the ProxySG
appliance will use session cookies when creating a cookie surrogate for a client. Session
cookies are only valid during the current browser session and are deleted when the user closes
the browser. Therefore, the ProxySGmust reauthenticate the client each time the user starts a
new browser session. If you select this option, the appliance will use persistent cookies instead
of session cookies. Persistent cookies are stored on the client system and are therefore not
deleted at the end of the browser session. When using persistent cookies, the ProxySG
appliance will only need to reauthenticate a client when the cookie in its surrogate credential
database expires.

n Verify the IP address in the cookie—By default, this option is selected, whichmeans that the
ProxySG appliance will only accept a cookie from a client if the client IP matches the
IP address in the surrogate cookie. To enable the appliance to accept cookies from
IP addresses that do not match the address in the cookie—for example if you use DHCP—
deselect this option.

6. (Transparent proxy only) Specify the URL to which to redirect client requests that require
authentication in the Virtual URL field.

For best results, the virtual URL you specify must:
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n Contain a simple hostname that does not contain any dots (for example, use http://myproxy
rather than http://myproxy.acme.com. This allows IE to recognize the URL as part of the
Intranet zone rather than the Internet zone so that the browser will automatically return
credentials when challenged rather than prompting the user.

n Resolve to the IP address of the ProxySG appliance. To accomplish this, youmust add an "A"
record to your internal DNS server that associates the virtual URLwith the IP address of the
ProxySG appliance.

7. (Optional) If you want to prompt the client for authentication credentials whenever the inactivity timeout
expires, select the Challenge user after logout check box.

8. Click Apply.
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Enable SSL Between BCAAA and the ProxySG Appliance
By default, transactions between BCAAA and the ProxySG appliance are not encrypted. You can secure the
transactions between BCAAA and the ProxySG by enabling SSL on this connection as follows:

1. Configure the BCAAA server for SSL.

You can do this either during the BCAAA installation process, if you haven't yet installed it, or after
installation by editing the bcaaa.ini file, which is by default installed to the C:\Program Files\Blue
Coat Systems\BCAAA.

The following table shows the configuration settings for bothmethods of configuring BCAAA:

BCAAA Installation SSL Settings bcaaa.ini SSL Settings

SSL Requirements—Select Permitted or
Required.

UseSSL=1

Certificate Subject—Enter the hostname of
the server where you are installing BCAAA;
do not use the IP address. Your DNS server
must be able to resolve the hostname you
supply.

CertificateSubject=<BCAAA_server_hostname>

Save the automatically generated
certificate in the certificate store?—Select
Yes. Note that this option only appears if the
BCAAA installation generated a new self-
signed certificate.

If you did not generate a certificate during the BCAAA
installation process, youmust obtain one for the
server and add it to the certificate store before you can
configure SSL. Or, re-run the BCAAA setup and allow
it to create a certificate and store it in the local
certificate store.

Require the ProxySG to provide a valid
certificate in order to connect?— Select
No.

VerifySG=0

2. Export the BCAAA CA server certificate.

a. From the BCAAA server, click Start > Run. The Run dialog opens.

b. To launch theMicrosoft Management Console (MMC), enter MMC in the Open field and then
click OK.

c. Select File > Add/Remove Snap-in. The Add/Remove Snap-in dialog displays.

d. Click Add. The Add Standlone Snap-in dialog displays.

e. Select Certificates from the Snap-in list and click Add. The Certificates snap-in wizard starts.

f. Select Service Account and then click Next.
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g. Select Local computer and then click Next.

h. From the Service account list, select the account you created for BCAAA and then click
Finish and then click Close.

i. Click OK to save your changes and close the Add/Remove Snap-in dialog.

j. In the list of certificate elements, select BCAAA > Personal > Certificates and then double-
click to open the certificate that corresponds to the hostname that you specified during the
BCAAA installation.

k. Select Details > Copy to File. The Certificate Export Wizard starts.

l. For the export file format, selectBase-64 encoded X.509 (.CER) and then click Next.

m. On the Files to Export screen, Browse to a location that is accessible from the system from
which you administer the ProxySG appliance, enter a File name to save the certificate as, click
Save, and then click Next.

n. Click Finish and then click OK.

o. Close theMMC console.

p. Restart the BCAAA services.

3. Import the BCAAA CA certificate into the ProxySG appliance.

a. From the system from which you administer the ProxySG appliance, browse to the file that
contains the certificate you extracted from the BCAAA server in Step 2m. Open the file using a
text editor (such as Notepad) and copy the contents to yourWindows clipboard.

b. From the ProxySGManagement Console, select Configuration > SSL > CA Certificates.

c. Click Import.

d. Enter a name for the new certificate (for example, BCAAA) in the CA Cert Name field.

e. Paste the certificate you extracted from the BCAAA server into the CA Certificate PEM field,
making sure to include the BEGIN CERTIFICATE and END CERTIFICATE.

f. Click OK. The BCAAA CA certificate gets added to the bottom of the list of CA certificates.

g. Click Apply.

4. Add the CA certificate to the CA Certificate List (CCL) that is associated with the device profile you
want the ProxySG appliance to use when connecting to BCAAA.

When you create an authentication realm and enable SSL, the default device profile is selected by
default. This device profile uses the browser-trusted CCL by default. Therefore, the easiest way to
associate the BCAAA CA certificate with the browser-trusted CCL and use the default device profile
as follows:
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a. In theManagement Console, select Configure > SSL > CA Certificate List.

b. Select the browser-trusted CA Certificate List and click Edit. The Edit CA Certificate List
dialog displays.

c. Select the BCAAA CA certificate you just imported from the list on the left and then click Add.
The certificate entry moves to the bottom of the list on the right.

d. Click OK and then click Apply.

5. Configure the ProxySG appliance to connect to BCAAA using SSL.

a. Make sure the field that specifies the BCAAA host is set to the DNS name of the server and
that it matches the CN name of the certificate you specified when you installed BCAAA.

o For IWA realms, you configure the BCAAA server name in the Servers section of the
IWA Servers tab.

o ForWindows SSO and Novell SSO realms, you set the BCAAA server name in the Host
field on the Agents tab.

b. Select the Enable SSL check box.

c. Select the SSL device profile to use when connecting to BCAAA over SSL. Make sure the
device profile you select has been configured to trust the BCAAA CA as described in Step 4.

The Enable SSL and SSL device profile fields are located on
the IWA Servers tab for IWA realms and on the Agents tab for
other realms.

d. Click Apply.
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Configure Mutual SSL Between BCAAA and the ProxySG

Withmutual authentication, both the client (the ProxySG appliance in this case) and the server (BCAAA)must
provide a valid certificate before the secure channel can be established. Therefore, to set upmutual
authentication, both the client and the server must have a valid certificate and eachmust have the CA
certificate for the other. In addition, youmust enablemutual authentication on the BCAAA server.

1. Configure the BCAAA server for SSL.

You can do this either during the BCAAA installation, if you haven't yet installed it, or after installation
by editing the bcaaa.ini file, which is by default installed to the C:\Program Files\Blue Coat
Systems\BCAAA.

The following table shows the configuration settings for bothmethods of configuring BCAAA:

BCAAA Installation SSL Settings bcaaa.ini SSL Settings

SSL Requirements—Select Permitted or
Required.

UseSSL=1

Certificate Subject—Enter the hostname of
the server where you are installing BCAAA;
do not use the IP address. Your DNS server
must be able to resolve the hostname you
supply.

CertificateSubject=<BCAAA_server_hostname>

Save the automatically generated
certificate in the certificate store?—Select
Yes. Note that this option only appears if the
BCAAA installation generated a new self-
signed certificate.

If you did not generate a certificate during the BCAAA
installation, youmust obtain one for the server and
add it to the certificate store before you can configure
SSL. Or, re-run the BCAAA setup and allow it to
create a certificate and store it in the local certificate
store.

Require the ProxySG to provide a valid
certificate in order to connect?— Select
Yes.

VerifySG=1

2. Export the BCAAA CA server certificate.

a. From the BCAAA server, click Start > Run. The Run dialog opens.

b. To launch theMicrosoft Management Console (MMC), enter MMC in the Open field and then
click OK.

c. Select File > Add/Remove Snap-in. The Add/Remove Snap-in dialog displays.

d. Click Add. The Add Standlone Snap-in dialog displays.

e. Select Certificates from the Snap-in list and click Add. The Certificates snap-in wizard starts.
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f. Select Service Account and then click Next.

g. Select Local computer and then click Next.

h. From the Service account list, select the account you created for BCAAA and then click
Finish and then click Close.

i. Click OK to save your changes and close the Add/Remove Snap-in dialog.

j. In the list of certificate elements, select BCAAA > Personal > Certificatesand then double-
click to open the certificate that corresponds to the hostname that you specified during the
BCAAA installation.

k. Select Details > Copy to File. The Certificate Export Wizard starts.

l. For the export file format, selectBase-64 encoded X.509 (.CER) and then click Next.

m. On the Files to Export screen, Browse to a location that is accessible from the system from
which you administer the ProxySG appliance, enter a File name to save the certificate as, click
Save, and then click Next.

n. Click Finish and then click OK.

o. Close theMMC console.

p. Restart the BCAAA services.

3. Import the BCAAA CA certificate into the ProxySG appliance.

a. From the system from which you administer the ProxySG appliance, browse to the file that
contains the certificate you extracted from the BCAAA server in Step 2m. Open the file using a
text editor (such as Notepad) and copy the contents to yourWindows clipboard.

b. From the ProxySGManagement Console, select Configuration > SSL > CA Certificates.

c. Click Import.

d. Enter a name for the new certificate (for example, BCAAA) in the CA Cert Name field.

e. Paste the certificate you extracted from the BCAAA server into the CA Certificate PEM field,
making sure to include the BEGIN CERTIFICATE and END CERTIFICATE.

f. Click OK. The BCAAA CA certificate gets added to the bottom of the list of CA certificates.

g. Click Apply.

4. Add the CA certificate to the CA Certificate List (CCL) that is associated with the device profile you
want the ProxySG appliance to use when connecting to BCAAA.

When you create an authentication realm and enable SSL, the default device profile is selected by
default. This device profile uses the browser-trusted CCL by default. Therefore, the easiest way to
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associate the BCAAA CA certificate with the browser-trusted CCL and use the default device profile
as follows:

a. In theManagement Console, select Configure > SSL > CA Certificate List.

b. Select the browser-trusted CA Certificate List and click Edit. The Edit CA Certificate List
dialog displays.

c. Select the BCAAA CA certificate you just imported from the list on the left and then click Add.
The certificate entry moves to the bottom of the list on the right.

d. Click OK and then click Apply.

5. Configure the ProxySG to appliance to connect to BCAAA using SSL.

a. Make sure the field that specifies the BCAAA host is set to the DNS name of the server and
that it matches the CN name of the certificate you specified when you installed BCAAA.

o For IWA realms, you configure the BCAAA server name in the Servers section of the
IWA Servers tab.

o ForWindows SSO and Novell SSO realms, you set the BCAAA server name in the Host
field on the Agents tab.

b. Select the Enable SSL check box.

c. Select the SSL device profile to use when connecting to BCAAA over SSL. Make sure the
device profile you select has been configured to trust the BCAAA CA as described in Step 4.

The Enable SSL and SSL device profile fields are located on
the IWA Servers tab for IWA realms and on the Agents tab for
other realms.

d. Click Apply.
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Validate the IWA Realm Configuration
After you configure an authentication realm on the ProxySG, youmust verify that the ProxySG appliance can
successfully connect to the authentication server and successfully authenticate a user as follows:

1. In theManagement Console, select Configuration > Authentication > IWA > IWA Servers.

2. Click Test Configuration.

3. When prompted, enter the username and password of a user in theWindows domain and then click
OK.

4. The appliance sends an authentication request to the configured server and then displays amessage
indicating whether the authentication succeeded or failed.

n If the test fails, go back andmake sure you have configured the realm properly.

n If the test succeeds, themessage also displays a list of groups to which the user belongs (IWA
Direct) or a list of groups of interest to which the user belongs (IWA BCAAA). A group of interest
is a group that is referenced in ProxySG policy.
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Create a DNS Entry for the Authentication Domain
For IWA authentication to be successful, your clients must be able to resolve the fully qualified domain name
of the ProxySG authentication URL to the IP address of the ProxySG appliance.

1. Create a DNS "A" record that associates the ProxySG authentication domain with the IP address of
the ProxySG appliance. The fully qualified domain name (FQDN) that you use depends on whether you
are using an explicit or transparent deployment:

n Explicit deployments—Set the hostname in the DNS A record tomatch the ProxySG domain
name specified in the browser's explicit proxy configuration.

n Transparent deployments—Set the hostname in the DNS A record tomatch the Virtual URL in
the IWA configuration.

2. Configure the client systems to use the DNS server where you created the "A" records for the
ProxySG appliance.

3. From a client system, ping the hostname specified in the A record to ensure that it resolves to the IP
address of the ProxySG appliance.
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Configure the Web Browser for IWA
One of themain benefits of IWA is that it can provide a single sign-on experience for users because it uses the
workstation login to authenticate users. When configured properly, the browser will provide the credentials to
the ProxySG appliance transparently when challenged for NTLM or Kerberos credentials (the user will always
be prompted for Basic authentication credentials).

IWA only works withWindows domain credentials. If users log in to the
workstation using local credentials instead of domain credentials, they will
be always be prompted whenever the ProxySG returns an authentication
challenge.

Both Internet Explorer (IE) and Firefox can be configured to provide authentication credentials to the ProxySG
appliance transparently:

n By default, IE will automatically provide authentication credentials to any site in the local Intranet zone.
If the URL for your ProxySG appliance (explicit deployments) or virtual URL (for transparent
deployments) contains a single hostname (that is, http://myproxy instead of
http://myproxy.acme.com) you will not have to configure IE for IWA. If your ProxySGURL (virtual or
explicit) does not fall within the Intranet zone, you will need to configure the IE to trust the URL. Keep
inmind, however, that Kerberos deployments will require you to use the full URL for the Active
Directory machine account (either the BCAAA machine account for IWA BCAAA or the ProxySG
machine account for IWA direct). In these cases, you will need to add the full URL to the local Intranet
zone.

n Firefox does not provide support for IWA by default and will therefore always need to be configured if
you want to provide a single sign-on experience for your users.

For explicit proxy deployments, youmust alsomake sure the browser is
configured to send requests to the ProxySG appliance. See "Configure
Client Web Browsers for Explicit Proxy" on page 37.

The procedure for configuring the browser to automatically provide login credentials to the ProxySG appliance
is browser-specific:

n Internet Explorer

1. Select Tools > Internet Options.

2. Select the Security tab.

3. Select the Local intranet zone and click Sites > Advanced.

4. Enter the fully qualified domain name of the ProxySG appliance (for explicit deployments) or the
virtual URL (for transparent deployments) in the Add this website to the zone field and then
click Add > Close > OK.
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5. Select the Advanced tab andmake sure the Security > Enable Integrated Windows
Authentication option is selected.

6. Click OK to save your changes and close the Internet Options dialog.

n Firefox

1. In the browser's Location field, enter about:config.

2. Click I'll be careful, I promise! to continue to the about:config page.

3. To get the browser to trust the ProxySG appliance and negotiate authentication with it, you
must set values for the following options: network.automatic-ntlm-auth.trusted-uris,
network.negotiate.auth.delegation-uris, network.negotiate-auth.trusted-uris. For each
option, complete the following steps:

a. Locate the option you want to set by scrolling or entering the option name in the Filter
field.

b. Double-click the option to open the Enter string value dialog.

c. Enter the fully-qualified domain name of the ProxySG appliance (for explicit
deployments) or the virtual URL (for transparent deployments). If you havemore than
one ProxySG appliance that will challenge users for authentication credentials, separate
the entries with commas.

d. Click OK.
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Create an IWA Authentication Policy
After you verify that BCAAA and the ProxySG appliance can successfully authenticate users against your
Active Directory (AD), youmust create the policy that enables authentication on the appliance. You can
create a basic authentication policy that simply requires all requests to be authenticated and allows or denies
access upon successful authentication. Or you can definemore complex policies with rules that apply to a
specific source address, subnet, port, user agent, or request header. Or, you can define different rules for
different destinations. You can also create policies that allow access to guest users.

You can additionally create authorization policies that restrict access by user or groupmembership.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL). Refer to the Content Policy Language Reference for details.

Note that youmust create an IWA realm before you can define the corresponding authentication policy.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create the policy rule that enables the ProxySG appliance to authenticate client requests.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

3. Configure the authentication policy settings.

a. In the Action column of the first row, right-click and then select Set. The Set Action Object
dialog displays.

b. Click New and then select one of the following authentication objects:

n Authenticate—Use this option if you do not need to log user IDs for denied requests.
With this option, if policy causes a request to be denied before the user is authenticated,
the user ID associated with the request will not be available for access logging.

n Force Authenticate—Use this option to force the appliance to authenticate requests
even if they are denied before authentication would normally occur. This ensures that
user IDs are available for access logging.
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If you plan to create a guest authentication policy, create a
combined object that contains the Authenticate object and a
Permit Authentication Error object (be sure to select All
Except User Credentials Required).

c. (optional) Specify a Name for the authentication object.

d. Select the IWA Realm from the drop-down list.

e. Select the authenticationmode from theMode drop-down list. Although you can select Auto to
have the ProxySG appliance automatically choose an authenticationmode, it is usually better
to make a selection that is appropriate for your deployment as follows:

n Explicit deployments—Select Proxy or Proxy IP. The Proxy IP mode reduces the load
on the network because it uses an IP surrogate to reauthenticate clients that have
already successfully authenticated.

n Transparent deployments—Select Origin Cookie Redirect. This mode redirects the
client to the virtual URL for authentication and uses a cookie surrogate to reauthenticate
clients that have already successfully authenticated. The appliance will automatically
downgrade to the Origin IP Redirect mode for user agents that do not support cookies.

f. Click OK to close the Add Authenticate Object or Add Force Authenticate object dialog.

g. Click OK to close the Set Action Object dialog.

4. (optional) Restrict authentication to a subset of client requests, based on source or destination request
attributes.

The default settings in the policy rule will cause the ProxySG appliance to authenticate all client
requests. You can set the Source and/or Destination columns to restrict authentication to a specified
subset of requests. For example,

a. In the Source or Destination column of the first row, right-click and then select Set. The Set
Source Object or Set Destination object dialog displays.

b. Click New and then select an object that represents the subset of requests you want to
authenticate. After you select an object, you will be prompted to provide details. For example, if
you choose the Client IP Address/Subnet object, you will be prompted for an IP address and
subnet mask/prefix to which this rule will apply.

When you first deploy your authentication policy, youmay want
to limit authentication to the source address of a test workstation
or subnet. This allows you to identify and troubleshoot any
configuration issues before rolling the policy out into production.

5. (optional) Add additional policy rules to refine your authentication policy.

A singleWeb Authentication Layer rule with the authenticate action is all you need to enable
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authentication. However, theremay be some cases where you want to bypass authentication for
certain requests and enable it for others. For example, youmay have a certain client, subnet, or URL
on which you do not require authentication or youmay have some custom applications that do not
know how to handle authentication requests. In this case, you would add an additional rule to yourWeb
Authentication Layer policy to instruct the ProxySG appliance how to handle the exceptions.

a. Click Add Rule. A new row appears in theWeb Authentication Layer.

b. Specify which client requests this rule applies to by setting the Source or Destination
columns.

c. Specify what the ProxySG appliance should do with requests that match the source and/or
destination setting you have defined by right-clicking in the Action column of the row, and
selecting Set.

n If you want to authenticate requests that match the specified source and/or destination
request settings you have defined, click New and select Authenticate and click OK.

n If you want to bypass authentication for thematching requests, select Do Not
Authenticate and click OK.

d. Prioritize the order in which you want the ProxySG appliance to enforce therules by selecting
the rule you want to move and clickingMove up or Move down.The ProxySG appliance
evaluates the rules in the order in which they appear in the policy layer. As soon as it finds a rule
that matches the request, it will enforce the specified action (in this case, either to authenticate
or not authenticate the request). Therefore, you should put more specific rules above general
rules. For example, if you have a two rules in your policy—one that is set to authenticate
requests from any source or destination and one that is set to not authenticate requests from a
specific subnet—you would put the one that bypasses authentication in front of the general rule
that matches all requests.

6. Install the authentication policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Create an IWA Guest Authentication Policy

A guest authentication policy enables users who do not have aWindows domain account on your network to
access Internet resources.

To create an IWA guest authentication policy:

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create aWeb Authentication Layer for authenticating client requests for your domain users.

See "Create an IWA Authentication Policy" on page 74 for instructions.

3. Create a secondWeb Authentication Layer to provide guest access.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name to distinguish this layer from the previous layer (for example, Guest
Authentication) and then click OK. The first policy rule displays with default settings.

4. Configure the source.

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select User Authentication Error. The Add User Authentication Error
Object dialog displays.

c. Select Any errors and click OK twice to save the source object and close the dialogs.

5. Configure the action.

a. Right-click the Action column and then select Set. The Set Action Object dialog displays.

b. Click New and then select the Authenticate Guest object. The Add Authenticate Guest object
dialog displays.

c. Select Use realm and then select your IWA realm from the drop-down list.

d. Enter a Guest Username. This will be the name that appears in your access log whenever
guest access is granted; it does not correlate to an Active Directory user account.

e. Click OK twice to save the Action object and close the dialogs.

6. Make sure that theWeb Authentication Layer for your guest policy is positioned after the your main
Web Authentication Layer.
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To re-order the layers, select Edit > Reorder Layers.

7. Install the authentication policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Create an IWA Authorization Policy

One of the benefits of IWA is that it automatically returns authorization information for a user in response to an
authentication request. You do not have to perform any additional configuration to get authorization to work.
After successfully authenticating a user, the appliance receives a list of all groups (IWA Direct) or groups of
interest (IWA BCAAA) to which the user belongs.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL). Refer to the Content Policy Language Reference for details.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create aWeb Access Layer.

a. Select Policy > Add Web Access Layer.

b. Enter a Layer Name or accept the default name and then click OK.

3. Specify the user or group to authorize (the source).

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select the type of Active Directory object this rule will authorize:

n To create a rule for authorizing a group,select Group. The AddGroupObject dialog
displays.

n To create rule for authorizing a user, select User. The Add User Object dialog displays.

c. Select the IWA realm from the Authentication Realm drop-down list.

d. Specify the name of the Active Directory user or group that rule will authorize:

n If you know the name of the Active Directory user or group, enter it in the Group or User
field.

n If you don't know the Active Directory name of the user or group, click Browse and
select the group from the IWA Browser.

e. Click OK to close the AddGroupObject or Add User Object dialog.

f. Click OK to close the Set Source Object dialog.

4. Specify whether to allow or deny requests from the specified user or group.
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a. Right-click the Action column.

b. Select one of the following options:

n Allow—Select this option if the default proxy policy for the appliance is set to deny proxy
access through the ProxySG appliance. This is the default in a secure web gateway
deployment.

n Deny—Select this option of the default proxy policy for the appliance is set to allow proxy
transactions.

If you aren't sure what the default proxy policy is set to on your
appliance, go to Configuration > Policy > Policy Options.

5. (Optional) Define any additional parameters that you want this rule to enforce.

6. To create additional authorization rules, repeat Steps 3 through 5.

7. Install the policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Verify Kerberos Authentication
Even if you configure IWA to allow Kerberos, Kerberos will only be used if configured properly. If the ProxySG
appliance cannot successfully negotiate Kerberos with a client, it will silently downgrade to use NTLM
authentication. Because this happens behind the scenes, youmay not know whether you are using Kerberos
or NTLM.

1. To verify that the ProxySG appliance is attempting to negotiate Kerberos authentication, take a packet
capture on the client and look for the NEGOTIATEmessage.The client uses the NEGOTIATEmessage to
communicate the type of authentication it supports to the ProxySG appliance. This will show up as a
either a WWW-Authenticate: NEGOTIATE (transparent) or Proxy-Authenticate: NEGOTIATE
message. Note that this message alone does not indicate that Kerberos will be used.

2. To verify that the client is using Kerberos, take a packet capture from the client and use the display
filter to view Kerberos requests. If Kerberos authentication is in use you will see Kerberos requests and
responses between the client and the Domain Controller as well as the Kerberos ticket in the GET
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request.
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Enable IWA Authentication for SSL Traffic in a Transparent
Deployment
After you configure IWA, youmust complete the following additional tasks if you are using a transparent proxy
deployment and you want to authenticate SSL traffic:

1. Make sure you have an SSL license.

Although some ProxySG appliancemodels include an SSL license, other models require that you
purchase and install an add-on license. To see whether you have a valid SSL license, launch the
ProxySGManagement Console and select Maintenance > Licensing > View. You should check that
SSL displays in the list of licensed components.

2. Create an HTTPS Reverse Proxy service to listen for authentication requests.

a. Select Configuration > Services > Proxy Services.

b. Click New Service.

c. Enter a unique Name for the service to identify it as your IWA authentication service.

d. Select HTTPS Reverse Proxy from the Proxy drop-down list.

e. Select the Keyring that you want to use to establish SSL sessions for this service.
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f. To configure the listening port, click New and then configure the service as follows:

n Set Destination Address to Explicit.

n Set the Port range to the port number on which you want this service to listen for
incoming authentication requests. Note that you will need to use this same port number
in the Virtual URL you define for the realm.

n Set the Action to Intercept.

n Click OK to save the listener settings.

g. Click OK.

h. If necessary, configure your firewall to allow traffic between the client workstations and the
ProxySG appliance on the port you just configured.

3. Create an IWA realm for authenticating your HTTPS traffic.

You create the realm the sameway that you created the IWA realm for your HTTP traffic, with the
difference being the URL to which authentication requests are directed:

a. Create the IWA realm as described in "Create an IWA Direct Realm" on page 28 or "Create an
IWA BCAAA Realm" on page 60 .

b. On the IWA General tab, set the Virtual URL to a URL that points to the HTTPS Reverse
Proxy Service you created for IWA authentication. For example, if you configured your HTTPS
Reverse Proxy service to listen on port 4433, you would enter a URL such as
https://myproxy:4433.

c. Make sure your DNS server is set up to resolve the hostname to the IP address of the ProxySG
appliance.

4. Create the policy rule to enable the appliance to intercept HTTPS traffic.

a. Launch the Visual Policy Manager (VPM) by selecting Configuration > Policy > Visual Policy
Manager > Launch.

b. Select Policy > Add SSL Intercept Layer.

c. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

d. Right-click the Action column and select Set.

e. Click New and select Enable HTTPS Interception.

f. Check the Issuer Keyring check box and select the keyring you specified in the
HTTPS Reverse Proxy service settings.

g. Click OK.
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5. Create the policy rule that enables the ProxySG appliance to authenticate client HTTPS requests.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

c. In the Action column of the first row, right-click and then select Set. The Set Action Object
dialog displays.

d. Click Newand then select Authenticate.

e. Select the IWA Realm from the drop-down list. Make sure you select the realm you created for
your HTTPS traffic.

f. Select the authenticationmode from theMode drop-down list. For transparent authentication,
you will usually want to select Origin Cookie Redirect. This mode redirects the client to the
virtual URL for authentication and uses a cookie surrogate to reauthenticate clients that have
already successfully authenticated. The appliance will automatically downgrade to the Origin
IP Redirect mode for user agents that do not support cookies.

g. Click OK to close the Add Authenticate Object or Add Force Authenticate object dialog.

h. Click OK to close the Set Action Object dialog.

6. Install the policy rules you created.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Integrating ProxySG Authentication with Active
Directory Using Windows SSO
WithWindows SSO authentication, users are authenticated based on theirWindows Active Directory logins. Therefore,
authentication will only work if your clients are running in aWindows domain environment. In addition, because usernames are
derived from IP address mappings, Windows SSO only works well in environments where one IP address maps to one user.
Environments with multi-user systems (such as Citrix) or with clients behind NAT devices are not suitable forWindows SSO
authentication.

To configure authentication, youmust complete the following tasks:

1. Install BCAAA on aWindows domain controller (DC) or amember server. Because the appliance cannot communicate
directly with aWindows DC, this agent software is required to act as an intermediary between the DC and the
appliance. Refer to the BCAAA Service Requirements document for more information about installing BCAAA.

2. Enable BCAAA to begin querying DCs for user logins so that it can begin building an IP address-to-usernamemapping
table. It will use this table to respond to authentication requests from the appliance. See "Configure theWindows SSO
Agent on the BCAAA Server" on the facing page.

3. Configure the appliance to communicate with BCAAA. See EnableWindows SSOAuthentication on the Appliance.

4. (optional) Set up authorization. TheWindows SSO realm itself cannot perform authorization. If you want to use
authorization in conjunction withWindows SSO, youmust create an LDAP realm and add it to theWindows SSO realm
configuration.

5. Create the policy rules that will enforce authentication and, optionally, authorization.

6. Verify authentication. The best way to verify that authentication is working properly is to look at your reports andmake
sure that they are displaying user names instead of IP addresses as expected. You can also view authentication
statistics to ensure a proper authentication configuration.
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Configure the Windows SSO Agent on the BCAAA Server
After you install BCAAA, youmust configure its Windows SSO agent to enable it to begin querying the DCs in
your network for user login information. You can optionally specify settings such as which DCs to query (by
default, it queries all DCs in the forest) and how long an IP-to-user mapping is valid (called a time-to-live, or
TTL, value).The way you configure the agent depends on whether you plan to use Domain Controller Query
(DCQ), Client Query (CQ), or both:

n "Configure theWindows SSOAgent for Domain Controller Query" on the next page

n "Configure theWindows SSOAgent for Client Query" on page 89
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Configure the Windows SSO Agent for Domain Controller Query
To use Domain Controller Query (DCQ), youmust explicitly enable it in theWindows SSO agent configuration
on the BCAAA server as well as in theWindows SSO realm settings on the ProxySG appliance. When you
configure the agent, you also specify settings such as which DCs to query (by default, it queries all of them)
and how long an IP-to-user mapping is valid (called a time-to-live, or TTL, value) as described in the following
procedure. For more information on DCQ, see "About Windows SSO" on page 16.

1. Open the sso.ini file in a text editor. This file is located in the BCAAA installation directory
(C:\Program Files\Blue Coat Systems\BCAAA by default).

2. Enable the agent to begin querying DCs by uncommenting the DCQEnabled=1 line in the DCQSetup
section of the file.

3. (Optional) Limit how long IP-to-user mappings are valid. By default, BCAAA considers all IP-to-user
mappings valid for one day (86400 seconds) unless replaced by a new mapping sooner (that is, if
another user logs in with an IP address that is already mapped, the oldmapping will be replaced by the
new one). However, because BCAAA does not track logouts, it is possible for its IP-to-user mappings
to get stale. To change the length of time that amapping is valid, uncomment the ValidTTL setting in
the DCQSetup section of the file andmodify the value.

4. (Optional) Limit which DCs BCAAA queries. By default it queries all DCs in the forest every ten
seconds. However, in a large forest that spans WAN links, this can cause excessive bandwidth
usage. To prevent this, you can define a list of DCs or an IP address range to which to limit queries by
entering values in the DCQDomainControllers section of the file; list the domain controllers you want
to query or the IP address ranges of interest. Keep inmind that BCAAA must query each DC that will
handle logins for ProxySG users in order to successfully authenticate them.

5. Save the sso.ini file. 

6. Restart the BCAAA service.
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Configure the Windows SSO Agent for Client Query
With Client Query (CQ), the BCAAAWindows SSO agent will directly query the client system to obtain the
username of the logged in user. The biggest factor in getting CQ to work is making sure that the client system
allows theWindows SSO agent to access its NetBIOS login information on port 445. Onmany versions of
Windows, theWindows firewall blocks remote access to the client workstation through this port; youmust
unblock this port for CQ to work.

There are no other required configuration steps for getting CQ to work. However, depending on how often IP
address-usernamemappings change within your organization youmay want to modify the length of time the
agent considers the authentication information valid. This is because theWindows SSO agent does not track
logouts and therefore its IP-to-user mappings can get stale; the time-to-live (TTL) settings in theWindows
SSO configuration specify how long to consider amapping valid. By default, all CQ TTL values are set to 15
minutes (900 seconds). If IP address assignments remain fairly static in your environment, youmay want to
increase the TTL for the authentication credentials to prevent excess traffic between the agent and the client
systems. Likewise, if users change IP addresses often, youmay want to decrease these values.

1. Open the sso.ini file in a text editor. This file is located in the BCAAA installation directory
(C:\Program Files\Blue Coat Systems\BCAAA by default).

2. Locate the ClientQuerySetup section of the file andmodify the time to live (TTL) settings as
appropriate for your network environment. Because theWindows SSO agent cannot monitor logouts, it
uses timeout values to limit how long it considers a login valid:

n ValidTTL—The number of seconds that a successful query is considered valid. During that
time, the client will not be requeried (default = 900 seconds).

n InvalidTTL—The number of seconds after an unsuccessful query before the client will be
queried again. During that time, the client will not be requeried and any ProxySG access will be
reported by IP address rather than username (default = 900 seconds).

n DCQTTL—When both DCQ andCQ are enabled, theWindows SSO agent will use a valid DCQ IP
address-usernamemapping if it has one rather than querying the client. This parameter
specifies the number of seconds that theWindows SSO agent will consider a DCQmapping
valid. If the DCQmapping is older than this value, theWindows SSO agent will query the client
(default = 900 seconds).

3. Save the sso.ini file.

4. Restart BCAAA.
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EnableWindows SSO Authorization on the ProxySG
Appliance
If you want to use yourWindows SSO realm for authorization—that is, to specify what a user can or cannot do
based on user name or groupmembership—youmust set up access to the Active Directory (AD) user and
group information using an LDAP realm. You can then configure yourWindows SSO realm for authorization.

1. In the ProxySGManagement Console, select Configuration > Authentication > LDAP > LDAP
Realms.

2. Create an LDAP realm.

a. Click New.

b. Enter a Realm name.

c. Select Microsoft Active Directory from the Type of LDAP server drop-down list.

d. Enter the IP address of the Active Directory server in the Primary server host field.

e. (Optional) If you are using a port other than the default, enter a value in the Port field.

f. Click OK.

g. Click Apply.

3. Specify the base DN(s) where you want the ProxySG to begin its search for user and group
information.

The base DN(s) you enter will depend on how your directory is organized. For example, if you want the
ProxySG appliance to search the entire directory for user and group information, youmight enter a
single entry that points to the folder where all users and groups are located such as
cn=Users,dc=acme,dc=com. However, if you want to search for users at the departmental level, you
might need to addmultiple entries such as ou=sales,dc=acme,dc=com and ou=development,
dc=acme,dc=com.

If you do not know the base DN for your AD server, go to the
command line on the AD server and enter the following command:
ldifde -f output.txt

You can then open the output.txt file that this command generates
in a text editor and search for the distinguishedName: entry.

a. Select the LDAP DN tab.

b. Click New. The Add LDAP Base DN dialog displays.
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c. Enter the base DN that represents the part of your Active Directory tree where you want
the ProxySG to begin searching for user or group entries and then click OK.

d. (Optional) If you want to add additional base DNs to search, repeat Step b. For, example, if you
have different AD servers distributed throughout your organization, youmay want to add an
entry for each one. Or, if you want to define user and group access at the departmental level,
youmay want to create a base DN entry for each organizational unit.

e. (Optional) Organize the base DN entries you have added by using the Promote entry or
Demote entry buttons tomove entries up or down. The ProxySG searches the base DNs in the
order listed, starting at the top.

f. Click Apply to save your entries.

4. (Optional) If your AD server does not support anonymous searches, youmust specify an Active
Directory user that the ProxySGwill use to log in to the directory.

a. Select the LDAP Search & Groups tab.

b. Deselect Anonymous search allowed.

c. Enter the fully qualified DN of the AD user the ProxySG should use to log in to the directory in
the Search user DN field. For example, cn=BC_Admin,cn=Users,dc=acme,dc=com.

d. Click Change Password and enter the password for the specified user in the New Password
and Confirm new Password fields. Click OK to close the dialog.

e. Click Apply.

5. Configure the LDAP authorization settings in theWindows SSO realm.

a. Select Configure > Authentication > Windows SSO > Authorization.

b. Select theWindows SSO realm from the Realm name drop-down list.

c. Select the LDAP realm you just created from the Authorization realm name drop-down list.

d. Click Apply.

You can now create policy rules for authentication and, if configured, authorization. The policy rules are what
instruct the ProxySG how to handle client requests after an authentication success or failure.
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Validate theWindows SSO Realm Configuration
After you configure an authentication realm on the ProxySG, youmust verify that the ProxySG appliance can
successfully connect to the authentication server and successfully authenticate a user as follows:

1. In theManagement Console, select Configuration > Authentication > Windows SSO > Agents.

2. Click Test Configuration.

3. When prompted, enter the IP address of a client system in theWindows domain and then click OK.

4. The ProxySG appliance will use the realm configuration you supplied to send an authentication request
to BCAAA and return the results as follows:

n If the ProxySG and the BCAAA server are configured properly, BCAAA will return the username
associated with the IP address you provided.

n If the test does not succeed, check that the settings on the Agents tab as well as the BCAAA
settings are configured correctly and then test the configuration again.
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Create aWindows SSO Authentication Policy
BecauseWindows SSO does not really authenticate users (that is, it does not challenge users for
credentials), it does not issue an HTTP 301/302 redirect or an HTTP 401/407 authentication request to the
browser. Therefore, the way you configure the authentication policy does not depend on whether the appliance
is deployed explicitly or transparently. Instead it simply checks the client IP address in the request against the
IP address-usernamemapping table maintained by BCAAA. This means that all Windows SSO
authentication policies can (and should) use the Proxy-IP authenticationmode.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL). Refer to the Content Policy Language Reference for details.

Note that youmust create theWindows SSO realm before you can define the authentication policy.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Select Policy > Add Web Authentication Layer.

3. Enter a Layer Name or accept the default name and then click OK.

4. In the Action column of the first row, right-click and then select Set. The Set Action Object dialog
displays.

5. Click New and then select one of the following authentication objects:

n Authenticate—Use this option if you do not need to log user IDs for denied requests. With this
option, if policy causes a request to be denied before the user is authenticated, the user ID
associated with the request will not be available for access logging.

n Force Authenticate—Use this option to force the appliance to authenticate requests even if
they are denied before authentication would normally occur. This ensures that user IDs are
available for access logging.

6. Click OK. The Add Authenticate Object or Add Force Authenticate object dialog displays.

7. Define the authenticate actions as follows:

a. (Optional) Specify a Name for the authentication object.

b. Select theWindows SSORealm from the drop-down list.

c. Select Proxy IP from theMode drop-down list.
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d. Click OK to close the Add Authenticate Object or Add Force Authenticate object dialog.

e. Click OK to close the Set Action Object dialog.

8. (Optional) Create an authorization policy. For instructions, see "Configure aWindows SSO
Authorization Policy" on the facing page.

9. Install the policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Configure aWindows SSO Authorization Policy
Because aWindows SSO realm simply maps the IP address in a client request to an Active Directory (AD)
login name, it does not have any additional information about the user, such as groupmembership information.
Therefore, if you want to use authorization with aWindows SSO realm, youmust create an LDAP realm to
connect to AD for access to user and group information and then configure theWindows SSO realm to point to
the LDAP realm. See "EnableWindows SSOAuthorization on the ProxySGAppliance" on page 90 for more
information.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL). Refer to the Content Policy Language Reference for details.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create aWeb Access Layer.

a. Select Policy > Add Web Access Layer.

b. Enter a Layer Name or accept the default name and then click OK.

3. Specify the user or group to authorize (the source).

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select the type of LDAP object this rule will authorize:

n To create a rule for authorizing a group,select Group. The AddGroupObject dialog
displays.

n To create rule for authorizing a user, select User. The Add User Object dialog displays.

c. Select the LDAP realm you created to authorize authenticatedWindows SSO users from the
Authentication Realm drop-down list.

d. Specify the LDAP name of the user or group that rule will authorize:

n If you know the name of the LDAP user or group, enter it in the Group or User field.

n If you don't know the LDAP name of the user or group, click Browse and select the
group from the LDAP Browser.

e. Click OK to close the AddGroupObject or Add User Object dialog.
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f. Click OK to close the Set Source Object dialog.

4. Specify whether to allow or deny requests from the specified user or group.

a. Right-click the Action column.

b. Select one of the following options:

n Allow Select this option if the default proxy policy for the appliance is set to deny proxy
access through the ProxySG. This is the default in a secure web gateway deployment.

n Deny Select this option of the default proxy policy for the appliance is set to allow proxy
transactions.

If you aren't sure what the default proxy policy is set to on your
appliance, go to Configuration > Policy > Policy Options and check
the Default Proxy Policy setting.

5. (optional) Define any additional parameters that you want this rule to enforce.

6. To create additional authorization rules, repeat Steps 3 through 5.

7. Install the policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Configure LDAP Authentication
To configure LDAP authentication on the ProxySG appliance, complete the following tasks:

1. Configure the ProxySG appliance to connect to and perform searches on the LDAP directory. See "Create an LDAP
Realm " on the next page.

2. Configure advanced LDAP realm settings. Review the details of your customized LDAP directory configuration and
security requirements, and configure your LDAP realm accordingly.

n Configure the object class attributes and group information tomap to your LDAP directory schema. See
"Configure the LDAP Realm for Customized Directories" on page 101.

n Configure resource availability settings, such as refresh and timeout cycles. See "Configure LDAP Realm
Resource Availability Settings" on page 103.

n Connect to an LDAP server using a secure connection (requires an LDAPv3 supported directory). See "Connect
to a Secure LDAP Server" on page 105.

3. Verify that the ProxySG appliance is configured for authentication. See "Verify LDAP Directory Connectivity" on
page 108.

4. Create policy rules to enforce authentication and, optionally, authorization. See "Create aWeb Access Policy" on
page 109

5. (Optional) Optimize your LDAP searches and group compare operations. See "Optimize Your LDAP Realm" on
page 112.
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Create an LDAP Realm
The LDAP realm on the ProxySG appliance needs to be configured in order to successfully communicate with
and search for entries contained within a specified LDAP directory. To configure the LDAP realm, you'll need
to have information about the LDAP hierarchy and the LDAP directory server settings. If you do not have
LDAP directory information, you can use a LDAP viewer to review the tree structure and other information
details about the LDAP directory. Due to the complexity of LDAP directories, Blue Coat recommends that you
retrieve this information from the LDAP directory administrator.

To enable LDAP authentication, you'll need to configure the LDAP authentication realm on the
ProxySG appliance to properly communicate with and recognize the directory structure — the complexity of
the configuration process depends on your LDAP directory deployment and the schema that you've decided to
use. SGOS provides limited default configuration options for more commonly used directories and built-in
schemas, but you'll still need to verify that all information is properly retrieved and processed by the appliance.

The procedure below shows the steps to configure the ProxySG appliance to connect with an LDAP directory
server using default settings. If you are running a customized LDAP directory, it might be necessary for you to
configure additional options or change the default LDAP realm settings on the ProxySG appliance. For more
information on these optional configuration items, see "Configure the LDAP Realm for Customized
Directories" on page 101.

1. Create an LDAP realm.

a. Select Configuration > Authentication > LDAP > LDAP Realms.

b. Click New.

c. Enter a Realm name.

d. Select the LDAP directory server you are using from the Type of LDAP server drop-down list.

The User attribute type is automatically selected based on your
LDAP directory selection, but you canmanually specify the user
attributes if you've implemented a customized LDAP schema.

e. Enter Primary server host and Port values of the LDAP directory server in the Servers
section. In most cases, LDAP directories uses the default port value of 389.

f. Click OK. The realm you just created is added to the LDAP Realms tab.

g. Select the LDAP Servers tab and then select the Realm name to configure.

h. Select the LDAP Protocol Version that your LDAP directory uses.

i. Select Follow referrals if your LDAP directories are distributed across several LDAP servers
using continuation references. This option allows your searches to follow referrals and return all
matching entries found during a search operation.
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j. Select Case sensitive if your LDAP directory uses case-sensitive values for the usernames
and passwords.

k. (Optional) If you have an alternate LDAP directory server for failover, enter the Alternate
server host and Port values in the Servers section.

l. (Optional) To change the amount of time the appliance will wait for an authentication response
from the LDAP directory server before timing out, enter a new value in the Timeout request
after x seconds field (default 60 seconds).

m. Click Apply.

2. Specify the base DN (distinguished name) that defines the point where you want the ProxySG to begin
its search for user and group information within the LDAP tree.

The base DN you enter depends on how your directory is organized. You can assemble the DN by
sequencing the RDNs (relative distinguished name) in a comma separated list beginning at the bottom
of the tree leading up to the directory root. Counterintuitively, LDAP directories have the root at the top
of the tree; so you'll need to determine the bottom-most point that you wish to search from.

For example, if you want to search the directory for user and group information, youmight point to the
folder where all users and groups are located such as cn=Users,dc=bluecoat,dc=com. However, if
you want to search for users at the departmental level, youmight addmultiple entries such as
ou=sales,dc=bluecoat,dc=com and ou=techpubs, dc=bluecoat,dc=com.

eDirectory users: make sure that the base DNs point to replica servers
and not just servers with a sub-ref on them. Blue Coat does not
recommend using a server that only contains subrefs on the replica
server.

a. Select the LDAP DN tab.

b. Click New. The Add LDAP Base DN dialog displays.

c. Enter the base DN that defines the point where a search begins in your LDAP tree and click OK.
You can assemble the DN by sequencing the RDNs (relative distinguished name) in a comma
separated list.

d. (Optional) If you want to add additional base DNs to expand the search areas of the LDAP tree,
repeat Step c. For, example, if you havemultiple LDAP trees distributed throughout your
organization, youmay want to add an entry for each one. Or, if you want to define user and
group access at the departmental level, youmay want to create a base DN entry for each
organizational unit.

e. (Optional) Organize the base DN entries you have added by using the Promote entry or
Demote entry buttons tomove entries up or down. The ProxySG searches the base DNs in the
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order listed, starting at the top.

f. Click Apply to save your entries.

3. Specify an LDAP user that the ProxySGwill use to log in and search the LDAP directory.

The LDAP realm defaults to anonymous user searches. However, Blue Coat recommends specifying
an LDAP search user with specific administrator rights. Depending on which LDAP directory you're
using and how it is configured, an anonymous search user might not have sufficient access to
attributes to return a valid search result.

For security purposes, youmight consider creating an authenticated
user with limited access that can only search a particular LDAP tree or
a limited set of attributes.

a. Select the LDAP Search & Groups tab.

b. Deselect Anonymous search allowed.

c. Enter the fully qualified DN of the LDAP user the ProxySG should use to log in to the directory in
the Search user DN field. For example, cn=BC_Admin,cn=Users,dc=acme,dc=com.

d. Click Change Password and enter the password for the specified user in the New Password
and Confirm new Password fields. Click OK to close the dialog.

e. Click Apply.

100



Configure LDAP Authentication

Configure the LDAP Realm for Customized Directories
The ProxySG appliance provides basic configuration settings based on your LDAP directory selection during
realm creation. These settings assume a default configuration for your schema, that is, types of objects,
attributes of each object type, and the rules that govern the LDAP directory. If you'vemodified your off the
shelf LDAP directory or are using a customized solution, you'll want to review and reconfigure the standard
LDAP realm settings to properly correspond to your customizations.

1. Provide additional details about how your LDAP directory organizes information about users and
groups.

For example, if your directory only searches a user object to retrieve information about the group that it
is associated with (like iPlanet), you'll need to specify groupmembership. Alternatively, if a group
object contains information about its users, (like Active Directory), you'll need to specify user
membership. These settings are typically dependent on the type of LDAP directory you are using. If
you are using a customized LDAP directory youmust review, and if necessary, manually specify group
information; otherwise youmight experience authorization difficulties.

a. In the ProxySGManagement Console, select Configuration > Authentication > LDAP >
LDAP Search & Groups.

b. Select aMembership type.

n Group — Specifies that information about your LDAP directory users are only stored
within groups objects.

n User — Specifies that information about your LDAP directory groups membership can be
stored within user entries.

c. Enter theMembership attribute used by your LDAP directory. This attribute is used to list the
groups that each user is amember of in the LDAP tree.

Select the type of username to lookup.

n Relative — Indicates that a relative distinguished name (RDN) is used to define the
membership attribute. This option is only available for Group membership types.

n FQDN — Indicates that a lookup is only performed on a user object that is explicitly
defined by a fully qualified distinguished name. FQDN can be selected when the
membership type is either Group or User.

d. Select Nested Groups Support if your LDAP directory has groups that aremembers of
another group. This enables a user that is amember of the 'child' group to be referenced along
with the 'parent' group.
Be sure not to introduce any looped references into your nested groups. For example, a loop
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forms if the groupmember Testgroup has the nested groupmember Testgroup2, which in turn
has the aforementioned Testgroup as a nestedmember.

When loops are removed from an LDAP directory, the Nested
Groups Support optionmust be disabled and then re-enabled
for the ProxySG to re-fetch the correct group structure.

e. Enter the name of the attribute that identifies the 'child' members of a group.

f. Click Apply to set the changes.

2. Add or modify the object class attribute values on the LDAP realm tomatch those on your LDAP
directory.

The contents of a directory entry is defined by the schema, including object types, which typically
defines what an object is or represents. These can include entities such as organizations and people,
or anything else the LDAP directory administrator defines it as. Because there is some interoperability
expected among various LDAP-enabled applications, there are usually some loosely standardized
values for the object classes. If your LDAP schema has been customized with new ormodified object
classes, you'll need to define (or redefine, as the casemay be) the values of the object classes to fit
your LDAP server schema configuration.

Object class attribute values are used by Blue Coat during a VPM search of an LDAP server. If an
administrator wants to browse the groups in a particular realm, the ProxySG appliance searches the
LDAP server for objects that have object class attribute values matching those in the group list and in
the container list. The list of object class attribute values in the container list is needed so that
containers that contain groups can be fetched and expanded correctly.
The object class attribute values used in directory entries can differ among LDAP servers. SGOS
includes standard object classes used by the LDAP directory. You can redefine the attribute values of
the stock object classes to fit your LDAP server schema configuration.

a. Select the LDAP ObjectClasses tab and then the LDAP realm where the object classes that
you want to modify are located.

b. Select the type of object that you want to redefine: container, group, or user.

c. Click New to add a new object class or Edit to change the value of an existing object class.

d. Enter or edit the object class attribute value(s) that must be available when performing searches
on the ProxySG.

e. Click OK and Apply to set the changes.
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Configure LDAP Realm Resource Availability Settings
The LDAP realm on the ProxySG appliance is preset with limited timeout and refresh values for various
authentication resources. Availability of resources can be adjusted to better suit your environment, user base,
and to address security issues. Depending on how your users access LDAP-enabled resources, these
settings might become intrusive, forcing users to reauthenticate multiple times during a single session.

1. In the ProxySGManagement Console, select Configuration > Authentication > LDAP > LDAP
Realms > LDAP General.

2. Enter the refresh and timeout values to change how often the ProxySG appliance reauthenticates a
client.

n Credential refresh time — (Basic credentials only) Specifies the amount of time the ProxySG
appliance will cache Basic credentials (username and password) and use these cached
credentials to authenticate the user. By default, basic credentials are good for 900 seconds (15
minutes).

n Surrogate refresh time — After the ProxySG appliance successfully authenticates a client, it
caches the client’s IP address or a cookie (depending on the authenticationmode that is in use)
in its surrogate cache. If it receives subsequent requests from the same client during the
surrogate refresh time, it uses the IP address or cookie in its cache to authenticate the user. By
default, the surrogate credential is good for 900 seconds (15minutes).

n Authorization refresh time — The Authorization Refresh Time allows you tomanage how often
the authorization data is verified with the authentication realm. It has a default setting of 900
seconds (15minutes). You can configure this in policy for better control over the resources as
policy overrides any settings made here.

n Inactivity timeout — When a client request is successfully authenticated, the ProxySG
appliance establishes an active session with the client and as long as that session stays active,
the ProxySG appliance will not attempt to reauthenticate requests from that client. This setting
specifies how long the client session can be inactive before theProxySG appliance terminates
the session; subsequent requests from that client will require authentication. By default, the
client can be inactive for 900 seconds (15minutes).

n Rejected credentials time — (Basic credentials only) Specifies whether to cache failed
authentication attempts (bad password, expired account, disabled account, old password, or
server down). If the client attempts to connect again during the rejected credentials time, the
ProxySG appliance will automatically reject the request for the specified period of time. Enter a
value from 1 second (the default) to 10 seconds. Or, to disable this option, enter 0.

3. Specify how the appliance uses cookie surrogates by setting the Cookies settings. The cookie
settings are only applicable if you plan to use an authenticationmode that uses cookie surrogates.

n Use persistent cookies — By default, this option is deselected, whichmeans that the ProxySG
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appliance will use session cookies when creating a cookie surrogate for a client. Session
cookies are only valid during the current browser session and are deleted when the user closes
the browser. Therefore, the ProxySGmust reauthenticate the client each time the user starts a
new browser session. If you select this option, the appliance will use persistent cookies instead
of session cookies. Persistent cookies are stored on the client system and are therefore not
deleted at the end of the browser session. When using persistent cookies, the ProxySG
appliance will only need to reauthenticate a client when the cookie in its surrogate credential
database expires.

n Verify the IP address in the cookie — By default, this option is selected whichmeans that the
ProxySG appliance will only accept a cookie from a client if the client IP matches the
IP address in the surrogate cookie. To enable the appliance to accept cookies from
IP addresses that do not match the address in the cookie—for example if you use DHCP—
deselect this option.

4. (Transparent proxy only) Specify a URL to which to redirect client requests that require authentication
in the Virtual URL field.

For best results, the virtual URL you specify must:

n Contain a simple hostname that does not contain any dots (for example, use http://myproxy
rather than http://myproxy.acme.com. This allows Internet Explorer to recognize the URL as
part of the Intranet zone rather than the Internet zone so that the browser will automatically
return credentials when challenged rather than prompting the user.

n Resolve to the IP address of the ProxySG appliance by adding an "A" record to your internal
DNS server that associates the virtual URLwith the ProxySG appliance IP address.
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Connect to a Secure LDAP Server
By default, LDAP traffic between the ProxySG appliance and the LDAP directory server is handled via an
insecure connection. You can encrypt traffic by enabling LDAP over SSL (LDAPS) in the LDAP realm. This is
accomplished by installing a CA certificate signed by the secure LDAP server onto the ProxySG appliance.
After the ProxySG validates the LDAP directory's server certificate, an encrypted communication channel is
established.

Your LDAP directory must conform to LDAPv3 standards to take advantage
of LDAPS.

1. Install the CA certificate on the ProxySG appliance to validate the certificate presented by the LDAP
directory server.

a. In the ProxySGManagement Console, select Configuration > SSL> CA Certificates.

b. Click Import and enter a name for the new certificate.

c. Copy and paste the certificate details into the CA Certificate PEM text box. Be sure to include
the entire certificate, beginning with -----BEGIN CERTIFICATE----- and ending with -----
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END CERTIFICATE-----, as shown below.

The CA certificate generated by the secure LDAP server needs
to be in a PEM (Privacy EnhancedMail) Base 64 encoded
format.

b. Click OK and Apply to set the changes.

2. Create a CA Certificate List restricting trust to the LDAP CA certificate(s).

a. Click the CA Certificate Lists tab.

b. Click New to create a new CA Certificate List. Name the profile so that is readily identifiable.

c. Select the newly imported certificate from the left column and then click Add >> to place it into
the CA Certificate List in the right column.

d. Click OK and Apply to set the changes.

3. Create a device profile to use the keyring.

a. Click Device Profiles from the left pane and then New to create a new device profile. Name the
profile so that is readily identifiable.
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b. Select the CA Certificate List that you just created from the CCL drop downmenu. All other
default settings should be retained.

c. Click OK and Apply to set the changes.

4. Enable SSL connections on the ProxySG LDAP realm.

a. In the ProxySGManagement Console, select Configuration > Authentication> LDAP>
LDAP Servers and select the realm to configure.

b. Click the Enable SSL check box.

c. Set the SSL device profile to the newly created device profile.

d. Click OK and Apply to set the changes.

5. (Optional) Add an alternate LDAP directory server.

a. Specify the IP address of the alternate LDAP directory server.

b. Specify the port. In most cases, LDAPS uses a default port of 636.

c. Click Apply to set the changes.
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Verify LDAP Directory Connectivity
Verify that the ProxySG appliance can successfully authenticate a user located on the LDAP directory server.
You can test authentication by entering the username and password of a specific user located in an LDAP
realm. Keep inmind, you can only test the credentials of a user that is under the DN(s) that are associated
with a particular LDAP realm.

1. In the ProxySGManagement Console, select Configuration > Authentication > LDAP > LDAP
Realms > LDAP Servers.

2. Click Test Configuration.

3. When prompted, enter the username and password of an LDAP user and then click OK.

4. The appliance sends an authentication request to the configured LDAP directory server and then
displays amessage indicating whether the authentication succeeded or failed. If the test failed, it could
be the result of incorrect user credentials or realm configuration. If the test succeeds, you'll receive a
message indicating a successful configuration.
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Create aWeb Access Policy
After you verify that the ProxySG appliance can successfully communicate with the LDAP directory server,
you can create specific rules to govern authenticated users and groups. If you do not add any Web Access
authorization rules, every available group (and users associated with the group) can be authenticated for
access to the network. The policy below limits the traffic to a specific group that can be granted access to
network resources.

When a user from the specified group attempts to access the network using an explicitly configured browser,
they are automatically prompted for username and password credentials.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL).

Note that youmust create an LDAP realm before you can define the corresponding access policy.

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create the policy rule that enables the ProxySG appliance to authenticate client requests.

a. Select Policy > Add Web Authentication Layer.

b. Enter a Layer Name to distinguish this layer from another layer and then click OK. The first
policy rule displays with default settings.

3. Configure the action.

a. Right-click the Action column and then select Set. The Set Action Object dialog displays.

b. Click New and then select the Authenticate... object. The Add Authenticate object dialog
displays.

c. Specify a Name for the authentication object you just created.

d. Select Realm and then select the LDAP realm that you wish to use from the drop-down list.

e. Select the authenticationmode from theMode drop-down list. Although you can select Auto to
have the ProxySG appliance automatically choose an authenticationmode, it is usually better
to make a selection that is appropriate for your deployment as follows:

n Explicit deployments—Select Proxy or Proxy IP. The Proxy IP mode reduces the load
on the network because it uses an IP surrogate to reauthenticate clients that have
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already successfully authenticated.

n Transparent deployments—Select Origin Cookie Redirect. This mode redirects the
client to the virtual URL for authentication and uses a cookie surrogate to reauthenticate
clients that have already successfully authenticated. The appliance will automatically
downgrade to the Origin IP Redirect mode for user agents that do not support cookies.

f. Click OK to close the Add Authenticate Object dialog.

g. Click OK to close the Set Action Object dialog.

4. (Optional) Restrict source IP addresses to specific test workstations or networks.

a. Right-click the Source column and then select Set.... The Set Source Object dialog displays.

b. Click New and then select the Client IP Address/Subnet... object. The Add Client IP
Address/Subnet object dialog displays.

c. Specify an IP Address or Subnet Mask of the workstation/network that you want to limit the
affects of the policy to and click Add. You can add as many IP addresses as you wish.

d. Click Close when you have finished entering the IP addresses/Subnet masks.

e. Click OK to close the Set Action Object dialog.

5. Create the policy rule that enables the ProxySG appliance to grant users access to the network.

a. Select Policy > Add Web Access Layer.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

6. Configure theWeb Access policy settings.

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select Group. The AddGroupObject dialog displays.

Enter the name of the LDAP group that you wish to authorize. Alternatively, you can add a User
to authorize a specific user instead of an entire group.
If you don't know what groups are available, you can view the LDAP directory using an LDAP
browser.

c. Select the LDAP Realm from the drop-down list.

d. Click OK to close the Set source object and close the dialog.

e. Click OK to close the Set Action Object dialog.

f. In the Action column of the first row, right-click and then select Allow.
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7. Install the access policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.

8. Test the authorization policy by accessing a network resource. Keep inmind, the browser must be
configured explicitly to pass through the ProxySG appliance.

a. Open your default Web browser and configure your browser to explicitly pass requests through
the ProxySG appliance.

b. Visit aWeb page, such as www.bluecoat.com.

c. When prompted, enter the user credentials. If the user is a valid entry in the LDAP group, the
URL loads properly within the browser.
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Optimize Your LDAP Realm
If you are experiencing poor LDAP performance when performing searches and comparisons, you can
performance tune your LDAP realm. The standard LDAP realm settings have been set to provide accurate
results over a range of possible configurations. Some of these options might generate unnecessary overhead,
depending on how your LDAP directory is configured. Keep inmind you'll need to verify the options you set in
the LDAP realm against the LDAP directory configuration, otherwise, the operations might return incorrect
values.

1. Specify how you want the LDAP realm to handle alias entries when performing a search operation.

When an LDAP alias entry points to another entry, the original entry is dereferenced, or removed from
the search results; only the entry that was referenced is considered to be found. This dereferencing
process can potentially reduce the performance of your LDAP deployment. However, to maximize
accuracy of searches, the default setting is Always. You can change the dereferencingmethod for
better search performance, but you'll need to verify that correct results are returned.

a. Select the LDAP Search & Groups tab.

b. Select a Dereference aliases option.

n Never — Never dereferences an alias entry. Offers the highest search performance, but
should only be selected only when alias entries are not present in the LDAP directory.

n Searching — Dereferences alias entries only after locating the base entry of a search.

n Finding — Dereferences alias entries only while locating the base entry of a search..

n Always — Always dereferences an alias entry. Returns themost accurate search results
when alias entries are present, but can cause reduced performance.

c. Click Apply.

2. Enter an LDAP search filter clause to reduce the number of results that a group search returns.

This option is only available for LDAP directories that store users within group entries.

a. In the ProxySGManagement Console, select Configuration > Authentication > LDAP >
LDAP Realms.

b. Select the LDAP Search & Groups tab.

c. Enter a Group constraint filter option.
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Constraints must be valid LDAP search filters and are AND’d to
the search filter when performing a group search. For more
information on valid LDAP search filters, refer to RFC2254.

n Example 1 — If you enter cn=p* into the Group constraint filter field, only groups starting
with the letter P are returned.

n Example 2 — If you enter cn=proxy into the Group constraint filter field, only the proxy
group is returned.

d. Click Apply.

3. Specify whether you want to perform group comparisons on the ProxySG appliance or send each
compare operation to the LDAP directory.

Typically compare operations are sent to the LDAP server for each query; however, if your network is
experiencing excessive lag times when performing compares, offloading the operation onto the
ProxySG appliance can significantly reduce load times, depending on how your LDAP directory is
configured. The default is Server.If you have a very large user or groups, you can perform the
comparisons on the ProxySG appliance. Depending on the LDAP schema and the number of users and
groups, this can result in reduced load on the LDAP server.

a. Select the LDAP General tab.

b. Select a Group comparison method option. The default is Server.

n Local — Offloads the compare operations onto the ProxySG after retrieving the LDAP
entries. Because the compares are performed locally, this method typically reduces load
on the LDAP server

n Server — Queries the LDAP server for each compare operation. Keep inmind, if there
are a large number of compare operations to perform, it can result in significant server
load.

There is a small possibility that local compares might produce
differing results from server compares. If you suspect erroneous
compare results, set to Server.

c. Click Apply.
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Create an LDAP Existence Check Policy
An LDAP existence check allows the client to verify whether or not a value of the specified LDAP attribute in
the user's entry is present. The LDAP attribute trigger enables you to create a policy rule that checks for the
existence of a specific LDAP attribute. If a match is found during the search, the specified action is executed.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL).

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create the policy rule that enables the ProxySG appliance to grant users access to the network.

a. Select a valid policy layer. The LDAP Attribute Object exists in the Admin Access, SSL
Access, Web Access, and Forwarding layers as Source objects. For example, to add an SSL
Access layer, select Policy > Add SSL Access Layer. An Add New Layer dialog box appears.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

3. Configure the settings for the policy rule that you created in the previous step.

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select LDAP Attribute. The Add LDAP Attribute dialog displays.

Enter the name of the LDAP attribute object that you wish to apply an action against.
If you don't know what attributes are available, you can view the LDAP directory using an LDAP
browser.

c. Select an LDAP Authentication Realm from the drop-down list.

d. Enter a valid LDAP Attribute Name.

e. Select Attribute exists to perform a existence check against the value of the specified LDAP
attribute from the user's entry.

f. Click OK to close the Set Action Object dialog.

g. In the Action column of the first row, right-click and then select Allow.

4. Install the access policy.
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a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Create an LDAP Attribute Comparison Policy
An LDAP compare operation allows the client to verify if a specified entry contains a given attribute. You can
perform a compare operation using the VPM, using an attribute trigger. The LDAP attribute trigger enables you
to create a policy rule that checks for a stringmatch from an entry. If a valid match is found during the search,
the specified action is executed.

This topic shows how to create a policy using the Visual Policy Manager
(VPM). You can also create policy using the Content Policy Language
(CPL).

1. Launch the VPM.

a. From theManagement Console, select Configuration > Policy > Visual Policy Manager.

b. Click Launch.

2. Create the policy rule that enables the ProxySG appliance to grant users access to the network.

a. Select a valid policy layer. The LDAP Attribute Object exists in the Admin Access, SSL
Access, Web Access, and Forwarding layers as Source objects. For example, to add an SSL
Access layer, select Policy > Add SSL Access Layer. An Add New Layer dialog box appears.

b. Enter a Layer Name or accept the default name and then click OK. The first policy rule
displays with default settings.

3. Configure the settings for the policy rule that you created in the previous step.

a. In the Source column of the first row, right-click and then select Set. The Set Source Object
dialog displays.

b. Click New and then select LDAP Attribute. The Add LDAP Attribute dialog displays.

Enter the name of the LDAP attribute object that you wish to apply an action against.
If you don't know what attributes are available, you can view the LDAP directory using an LDAP
browser.

c. Select an LDAP Authentication Realm from the drop-down list.

d. Enter a valid LDAP Attribute Name.

e. Select Attribute value match to perform a string comparison against the value of the specified
LDAP attribute from the user's entry.

f. Specify a value with which to compare the LDAP attribute name.

g. Select a comparison filter from the drop down.

h. Click OK to close the Set Action Object dialog.
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i. In the Action column of the first row, right-click and then select Allow.

4. Install the access policy.

a. Click Install policy.

b. Click OK to acknowledge that the policy was successfully installed.
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Configure SAML Authentication
Before you configure SAML, make sure that youmeet the requirements. The following
procedures assume that you have installed and configured the administration software for
your IDP.

1. Save a local copy of the IDP's configuration data by exporting the IDP metadata file.

2. Prepare the appliance for SAML authentication:

a. Import certificates to the CCL.

b. Create an HTTPS reverse proxy service for the HTTPS POST endpoint.

c. Define assertion attributes to specify which data the IDP should use to authenticate users.

d. Create the SAML realm.

e. After you create the SAML realm, configure general settings.

3. (Optional) To authorize users through one or more SAML realms, specify the criteria to use when searching for users.

4. Configure your IDP:

n "Configure AD FS" on page 129

n Configure Oracle

n "Configure SiteMinder" on page 132

n (Supported in SGOS 6.5.2 and later) "Configure Shibboleth" on page 140

5. Include the realm in your policy.
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Export the IDP Metadata File
To export the IDP metadata file, log in to the IDP’s administration software.

Exporting IDP metadata entails saving the XML document to disk. It is important to save themetdata file
without opening it in a browser first. Browsers do not necessarily support XML file structure andmay change
the XML tags.

If you use SiteMinder, Oracle, or Shibboleth, you will need to copy and paste themetadata file contents to the
CLI using the inline idp-metadata command. Because XML files are text-based, it is best to use a text editor
such as Notepad to open the file to copy its contents.

To ensure that the SAML realm is configured correctly, Blue Coat
recommends that you import metadata instead of entering the information
manually. If there are issues with realm configuration, the Authentication
debug log shows the following error: The SAML realm configuration is
invalid.

Export Metadata from AD FS

1. Log in to the AD FS MMC.

2. Select Endpoints and look under Metadata for the URL beside the Federation Metadata type.

3. Copy the URL and paste it into a browser address bar.

4. Save the XML file to a location that the appliance can access.

Export Metadata from SiteMinder

Before you can export metadata, make sure that you have created a SAML 2.0 IDP. This assumes that you
have already created the IDP (entity) in SiteMinder.

1. Log in to the CA FederationManager.

2. Select Federation > Entities.

3. Beside the entity you created, select Action > Export Metadata.

4. In the Partnership Name field, enter a name to identify the partnership between the ProxySG appliance
and SiteMinder. You will refer to this partnership name later, when you configure the partnership in
SiteMinder.

5. Click Export. SiteMinder generates themetadata document.

6. Save the XML file to a location that the appliance can access.
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Export Metadata from Oracle

1. Log in to the Oracle EnterpriseManager.

2. In the navigation tree on the left, select Identity and Access > OIF.

3. On themain page, select Oracle Identity Federation > Administration > Security and Trust.

4. Click the Provider Metadata tab.

5. In the GenerateMetadata section, select Identity Provider from the Provider Type menu.

6. Select SAML 2.0 from the Protocol menu.

7. Click Generate. OIF generates themetadata document.

8. Save the XML file to a location that the appliance can access.

Export Metadata from Shibboleth

1. On the server where Shibboleth is installed, browse to the <shibboleth>/metadata folder.

2. Copy the idp-metadata.xml file.

3. Save the XML file to a location that the appliance can access.
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Configure the CCL
The ProxySG appliance CCLmust contain at least a root certification authority (CA) certificate, but depending
on other considerations, youmay require more certificates. Determine which certificates youmust import to
the CCL:

n Root CA certificate—Required. Add the certificate for the root CA that issued the IDP‘s signing
certificate to the CCL.

n IDP’s signing certificate—Required if self-signed. If the IDP’s signing certificate is self-signed, add it
to the CCL. CA-signed certificates are included in SAML assertions.

n Intermediate CA certificate—Optional. Youmust import intermediate CA certificates to the ProxySG
appliance, but it is not necessary to add them to the CCL. For instructions on importing certificates to
the appliance, refer to the "Importing CA Certificates" section in the "Managing X.509 Certificates"
chapter in the SGOS Administration Guide.

In explicit deployments, if you do not add the certificate for the CA that
issued the IDP’s certificate to the appliance's CCL, HTTPS connections to
the IDP fail.
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Set up an HTTPS Reverse Proxy Service
You should create an HTTPS reverse proxy service only if the SAML realm uses an HTTPS, rather than
HTTP, POST endpoint.

Determine whether to use an HTTP or HTTPS POST endpoint:

n If you use AD FS, the POST endpoint must use HTTPS.

n If you use SiteMinder or Oracle, the POST endpoint can use either HTTPS or HTTP.

n If you want greater security, use an HTTPS POST endpoint.

Regardless of which IDP you use, Blue Coat recommends using an HTTPS
POST endpoint.

Create an HTTPS reverse proxy service to act as the SAML realm’s HTTPS POST endpoint. The IDP
redirects browsers to this service when it creates assertions.

SSL connections require a certificate and a private key. Browsers must trust the certificate that the HTTPS
reverse proxy service uses, and the certificate’s Subject valuemust match the Virtual host configured in the
SAML realm (see "Configure the SAML Realm" on page 125). If the names do not match, SSL hostname
mismatch errors occur.

For instructions on creating the HTTPS reverse proxy service, refer to the Reverse Proxy Deployment
WebGuide.
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Define Assertion Attributes
The ProxySG appliancemaps policy conditions to assertion attribute values. If you require more attributes
than the ones included in SAML assertions, you can define them in the SAML realm.

1. In theManagement Console, select Configuration > Authentication > SAML > Attributes.

2. Click New. The console displays the Add SAMLAttribute dialog.

3. Enter attribute settings:

n Attribute name—This is the name of the attribute as it appears in the appliance and IDP
configuration, and when referring to the attribute in the attribute.<name>= policy condition.
The namemust be unique.

n Attribute data type—Select case-exact-string or case-ignore-string. The appliance uses
this setting tomatch assertion attribute values with policy conditions.

n SAML name—This is the name of the attribute as it will appear in assertions from the IDP, in the
Name= XML attribute of the <Attribute> element. For example, an assertionmight include the
line <saml:Attribute Name="mail">wheremail is the SAML attribute name.

4. Click OK, and then click Apply.

Starting in SGOS 6.6.2.x, you can forward SAML attributes in SAML 2.0 assertions through HTTP headers to
back-end servers by creating substitution policy. See "SAML Attribute Substitutions" below.

SAML Attribute Substitutions

(Introduced in SGOS 6.6.2.x) You can forward SAML attributes (including the user name) in SAML 2.0
assertions through HTTP headers to back-end servers by creating substitution policy. The SAML substitution
uses the following CPL syntax:

$(saml.attribute.<name>)

To forward SAML attributes using substitution policy:

1. In the SAML realm configured on the appliance, define the attribute you want to forward.

If you remove an attribute that is referenced in policy, the appliance
issues a warning the next time that policy is compiled.

2. In the VPM, add aWeb Access Layer.

3. In the Source column, add a SAML Attribute object that specifies the attribute to forward.
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If the attribute you specify does not exist in the SAML realm, the
appliance issues a warning when it compiles policy.

4. In the Action column, add a Control Request Header or Control Response Header object. Select
Set Value and enter the substitution:

$(saml.attribute.<name>)

where <name> is the name of the attribute to forward.

5. Install the policy.

After you install the substitution policy, the appliance evaluates the configured policy rules and
modifies the HTTP request/response headers with the additional x-header fields corresponding to
attribute names with the attribute values. When the appliance compiles policy, it validates the field
attribute <name> against configured SAML attributes.

You can alternatively add the substitution policy through the #inline policy command or CPL. For information
on thosemethods, refer to the Command Line Interface Reference and the Content Policy Language
Reference, respectively.
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Configure the SAML Realm
1. In theManagement Console, select Configuration > Authentication > SAML.

2. Click New.

3. On the Add SAMLRealm dialog, in the Realm name field, enter a name for the realm. The realm name
identifies the realm in areas of theManagement Console such as logs and the Visual Policy Manager.

4. Select the trusted CCL. From the Federated IDP CCL menu, select the CCL you created in
"Configure the CCL" on page 121.

5. Specify configuration parameters:

n (AD FS only) Use preconfigured settings for the IDP. Copy and paste the URL for themetadata
into the Federated IDP metadata URL field.

n (SiteMinder, Shibboleth, andOracle) Import metadata through the #(config saml <realm-
name>)inline idp-metadata <XML> CLI command.

6. From the Encryption keyring (optional) menu, select the keyring to use for decrypting encrypted
assertions.

7. (Optional) If you require that assertions from the IDP be encrypted, mark the Require encryption
check box. If youmark the check box, the ProxySG appliance rejects unencrypted assertions.
Note that as long as the encryption keyring is configured, the appliance attempts to decrypt encrypted
assertions whether or not the Require encryption check box is marked.

8. Specify the hostname for the SAML endpoint; in other words, point to the HTTPS reverse proxy
listener you set up. In the Virtual host field, enter the host and port in format <hostname_or_IP_
address>:<port_number>. The hostnamemust match the name of the SSL certificate for the HTTPS
reverse proxy service. See "Set up an HTTPS Reverse Proxy Service" on page 122.

9. (Optional) Define limits for assertions’ timestamps. Assertions with timestamps that fall outside of
these limits are invalid.

n Specify an interval before the current time. Assertions stamped before this interval are invalid.
In the Not before field, specify the number of seconds. The default value is 60.

n Specify an interval after the current time. Assertions stamped after this interval are invalid. In
the Not after field, specify the number of seconds. The default value is 60.

10. (If applicable) If you defined your own assertion attributes ("Define Assertion Attributes" on page 123),
select them from the followingmenus:

n SAML user attribute—This is the attribute containing the relative username. If you do not
specify the attribute, the appliance uses the SAML Name ID value for the username.

n SAML fullname attribute—This is the attribute containing the full username.
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n SAML group attribute—This is the name of the groupmembership attribute. Values of this
attributematch the group= policy condition.

11. (Optional; available in SGOS 6.5.2 and later) Select an SSL device profile to use to communicate with
the IDP when the redirect/POST URL uses HTTPS.

12. (Optional; available in SGOS 6.5.2 and later) If the client cannot be redirected to, or communicate
directly with, the IDP—for example, if a firewall exists between users and the IDP—select Disable
client redirects to disable the appliance’s ability to redirect the browser to the IDP for authentication.
When you disable client redirects, the appliance handles all communication with the IDP andOCS on
behalf of the client.

13. (If you selected Disable client redirects in the previous step) Determine if you want to prevent the
appliance from adding a BCSI-SWR- prefix to IDP cookies; this prefix prevents IDP cookies andOCS
cookies from having the same name.
The Prefix IDP cookies option is available and enabled by default when you select Disable client
redirects; clear the Prefix IDP cookies option if you do not want to add the prefix to cookies.

14. Click OK to save the realm.
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Configure General Settings
1. In theManagement Console, select Configuration > Authentication > SAML > SAML General.

2. From the Realm name menu, select the SAML realm.

3. Configure the following as required.

n Display name—Set the display name of the realm.

n Refresh Times—Do one of the following.

o Mark the Use the same refresh time for all check box to set the same refresh time for
credentials and surrogates.

o Enter different refresh times (in seconds) for credentials and surrogates.

n Inactivity timeout—Enter the number of seconds a session can be inactive before it times out.

n Rejected credentials time—Enter a refresh time (in seconds) for rejected credentials.

n Cookies—Do one or both of the following:

o Use persistent cookies—Mark this to use persistent cookies; leave this unmarked to
use session cookies.

o Verify the IP address in the cookie—Mark this to enable verification of cookies’ IP
addresses.

n Challenge user after logout—Mark this to enable challenging after logout. For example, if this
setting is enabled and a user logs out of a web site, the user must enter credentials again the
next time they access the web site.

4. Click Apply to save your changes to general SAML settings.
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Configure SAML Authorization
1. In theManagement Console, select Configuration > Authentication > SAML > Authorization.

2. From the Realm name drop-down list, select the SAML realm for which you want to configure
authorization settings.

3. (If applicable) To authorize with the current realm, mark the Self check box. If you select Self, the
Authorization username is set automatically to Use FQDN.

4. If you use LDAP for authorization and Use FQDN is selected, ensure that the SAML fullname
attribute (see "Configure the SAML Realm" on page 125) contains the user's distinguished name.
Later, youmust also configure the IDP to send the distinguished name in assertions.
To authorize with another realm, go to the next step.

5. (If applicable) Select the realm with which to authorize from the Authorization realm name menu.
Then, choose one of the following options:

n Authorization username—Enter the username in the field.

n Use FQDN—Use the fully-qualified domain name (FQDN).

n Determine by search—Determine the username by LDAP search. Specify the following.

o LDAP search realm name—Enter the name of the LDAP search realm.

o Search filter —Specify the LDAP search filter.

o User attribute or FQDN—Specify either the LDAP attribute name or the FQDN as the
username attribute for search results.

o Set Users to Ignore—Add, edit, or remove usernames from the list of users to ignore
when determining authorization.

6. Click Apply to save your changes to SAML authorization settings.

Policy Conditions
The ProxySG appliance uses existing policy conditions tomake authorization decisions for the user. These
policy conditions map to assertion attribute values.

n group=

The group= conditionmaps to the values of the SAML group attribute setting specified in the realm.

n attribute.<name>=

The attribute.<name>= conditionmaps to the values of the Attribute name setting specified in the realm.
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Configure AD FS
The following steps comprise theminimum required settings to create trust between the ProxySG appliance
and AD FS. For other settings that youmay require for your deployment, refer to the AD FS documentation.

To perform the procedures in this section, youmust be logged in with administrator credentials on the AD FS
server.

Step 1 - Import the ProxySG Certificate to AD FS’s Trust List

Before the AD FS server can import metadata from the SAML realm, AD FS has to trust the ProxySG
appliance’s default certificate. To create trust, add the certificate to AD FS’s trust list.

The following procedure describes how to add the certificate to AD FS's trust list in Microsoft Internet Explorer
9.x.

1. In the browser, select Tools > Internet Options > Content.

2. Click Certificates, and then click Import.

3. When you are prompted to specify a store in which to install the certificate, select Trusted Root
Certification Authorities.

If you do not select the Trusted Root Certification Authorities store, any error
messages that occur may be inaccurate or unintuitive.

Step 2 - Import ProxySG Metadata to AD FS

1. In the AD FS MCC, select AD FS 2.0 > Trust Relationships > Relying Party Trusts.

2. Select Relying Party Trusts, right click, and then select Add Relying Party Trust.

3. TheMMC displays a wizard. Click Start.

4. Make sure that Import data about the relying party published online or on a local network is
selected.

5. In the Federation metadata address (host name or URL) field, enter the following URL:
https://<IP-address>:8082/saml/metadata/<realm-name>/sp
In the URL, <IP-address> is the address of the appliance, and <realm-name> is the name of the SAML
realm.

6. Click Next.
If an error message displays when you click Next, verify that you imported the certificate correctly and
verify that the hostname you specified in the URL in the previous stepmatches the certificate’s
Subject value.
In addition, if AD FS fails to validate the certificate, a generic error message displays; themessage
does not indicate that the certificate is invalid.
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7. Enter a display name for the relying party trust and then click Next.

8. To allow access to the appliance for all users, select Permit all users to access this relying party.
Do not select this option if you want to limit access to the appliance to authorized users. Click Next.

9. Review your settings and click Next.

10. Make sure that Open the Edit Claim Rules is selected, and then click Close. AD FS prompts you to
edit claim rules.

Step 3 - Set up Claim Rules for Assertions

1. In the AD FS MMC, select AD FS 2.0 > Trust Relationships > Relying Party Trust.

2. Select the relying party trust that you created inStep 2, right click, and click Edit Claim Rules.

3. TheMMC displays a dialog. Click Add Rule.

4. Make sure that Send LDAP Attributes as Claims is selected for Claim rule template, and then click
Next.

5. Configure the rule. You can configure the rule to send any attribute, but this procedure describes the
following:

Send User Identity

The procedures for configuring assertion attributes refer to the attribute’s
SAML name. The SAML name is the name that you specified for the
attribute in "Define Assertion Attributes" on page 123.

The following procedure tells you how to pass the User Principal Name attribute in the SAMLName ID
assertion.

1. Specify the following in the claim rule wizard:

n In the Claim rule name field, enter the attribute’s SAML name.

n For Attribute store, select Active Directory for the attribute store.

n For LDAP Attribute, select the User-Principal-Name attribute.

n For Outgoing Claim Type, select Name ID.

2. Click Finish, and then click OK.

3. (If required) To add another claim rule, repeat steps 2 through 4 inStep 3.

Send Distinguished Name

If you use LDAP for authorization, youmust configure a claim rule to send the distinguished name in
assertions.
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1. Specify the following in the claim rule wizard:

n In the Claim rule name field, enter the attribute’s SAML name.

n For Attribute store, select Active Directory for the attribute store.

n For LDAP Attribute, enter distinguishedname in lower case. (You can type in the drop-
downmenu.)
Due to a limitation in AD FS, the attribute name disappears if you enter the name once and
then go to next field. When this happens, enter the attribute name again exactly as it is
shown above.

n For Outgoing Claim Type, enter DN.

2. Click Finish, and then click OK.

3. (If required) To add another claim rule, repeat steps 2 through 4 inStep 3.

Send Group Membership

You can set up AD FS to send groupmemberships in assertions. Create another claim rule to specify the
attribute, and then add an attribute in SAML.

1. Specify the following in the claim rule wizard:

n In the Claim rule name field, enter the attribute’s SAML name.

n For Attribute store, select Active Directory for the attribute store.

n For LDAP Attribute, select the Token Groups-Unqualified Names attribute.

n For Outgoing Claim Type, select Group.

2. Click Finish, and then click OK.

3. (If required) To add another claim rule, repeat steps 2 through 4 inStep 3.
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Configure SiteMinder
The following steps comprise theminimum required settings to create a partnership between the ProxySG
and SiteMinder. For other settings that youmay require for your deployment, refer to the CA SiteMinder
documentation.

To perform the procedures in this section, youmust be logged in with administrator credentials on the
SiteMinder server.

Step 1 - Import Metadata to SiteMinder

1. In a browser, go the following URL to export ProxySG appliancemetadata:
https://<IP-address>:8082/saml/metadata/<realm-name>/sp

2. Save the file to disk.

3. In the CA FederationManager, select Federation > Entities.

4. Click Import Metadata.

5. Beside theMetadata file field, browse to themetadata file you saved in the first step.

6. Make sure that the following are selected:

n For Import As, select Remote Entity.

n For Operation, select Create New.

7. Click Next.

8. In the Entity Name field, enter a name for the appliance as a service provider.

9. Click Next. (The Import Certificates step is skipped if the appliancemetadata doesn’t contain a
certificate.)

10. Confirm your settings, and then click Finish.

Step 2 - Configure the Partnership Between SiteMinder and the ProxySG

1. Select Federation > Partnerships.

2. Locate the partnership you created when you exported SiteMinder metadata ("Export the IDP Metadata
File" on page 119). Beside the partnership name, select Action > Edit.

3. Specify the following:

n For Remote SP, select the remote entity you specified when you imported appliancemetadata.

n From Available Directories, select the LDAP directories you want to use. On the right, you can
move directories up or down to dictate the search order.
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4. Click Next.

5. (Optional) On the Federation Users step, specify search filters or users to exclude from accessing
the appliance.

6. Click Next. The next step is Assertion Configuration; seeStep 3.

Step 3 - Configure Assertions

After you configure the partnership, you are at the Assertion Configuration step. To send user attributes in
SAML assertions:

1. In the Name ID section, for Name ID Format, select the identity format to be passed in SAML
assertions.

2. For Name ID Type, select User Attribute.

3. In the Value field, specify the primary user attribute, for example, sAMAccountName for Active
Directory.

4. In the Assertion Attributes section, click Add Row.

Configure attributes for the assertion. You send any attribute in assertions, but this procedure describes the
following:

The procedures for configuring assertion attributes refer to the attribute’s
SAML name. The SAML name is the name that you specified for the
attribute in "Define Assertion Attributes" on page 123.

Send User Identity

1. In the Assertion Attribute field, enter the attribute’s SAML name.

2. For Type, select User Attribute.

3. For Value, enter the name of the attribute you want to send.

4. Click Next or add another attribute.

5. To add another attribute, click Add Row in the Assertion Attributes section.

Send Group Membership

Add the memberOf attribute to send groupmembership information in assertions.

1. In the Assertion Attribute field, enter the attribute’s SAML name.

2. For Type, select User Attribute.

3. For Value, enter memberOf.
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4. If any users aremembers of multiple groups, change the Value to FMATTR:memberOf. If you do not
modify the attribute value, SiteMinder incorrectly adds the attribute to the assertion, combining all
attribute values in a single XML element.

5. Click Next or add another attribute.

6. To add another attribute, click Add Row in the Assertion Attributes section.

Send Distinguished Name

If you use LDAP for authorization, youmust configure SiteMinder to send the distinguished name in
assertions.

1. In the Assertion Attribute field, enter the attribute’s SAML name.

2. For Type, select User Attribute.

3. For Value, enter distinguishedName.

4. Click Next or add another attribute.

5. To add another attribute, click Add Row in the Assertion Attributes section.

Step 4 - Select Authentication Mode

1. After you configure assertions, you are at the SSO and SLO step.

2. In the SSO section, select HTTP-POST for the SSOBinding.

3. Click Next.

Step 5 - Configure Signing and Encryption

After you select the authenticationmode, you are at the Signature and Encryption step.

1. In the Signature section, for Signing Private Key Alias, select the key that is used to sign assertions.

2. Alternatively, or if there is no private key in the certificate data store, you can generate a signing key or
import one from a PKCS#12 (private key and certificate) file.

3. For Post Signature Options, select Sign Assertion.

4. Make sure that Require Signed Authentication Requests is not selected.

5. Click Next.

6. Confirm your settings and click Finish.

Step 6 - Send Encrypted Assertions

If SiteMinder will be sending encrypted assertions to the ProxySG appliance, create an encryption keyring in
the SAML realm. For instructions, see "Creating a Keyring" in the "Managing X.509 Certificates" chapter in
the SGOS Administration Guide. Then, export appliancemetadata. Importing themetadata to SiteMinder
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imports the certificate from the keyring.

You can select the Show key pair option so that you can view and copy the
keyring as a backup. Backing up the keyring lets you easily import it again
should you need to back up the appliance configuration later.

1. In the Oracle EnterpriseManager, select Federation > Partnerships.

2. Beside the partnership you created, select Action > Edit.

3. Select the Signature and Encryption step.

4. In the Encryption section, select Encrypt Assertion.

5. Beside Encryption Certificate Alias, click Import and browse to the certificate you exported.

6. Click Next.

7. Click Finish.

Step 7- Activate the Partnership

After you have defined the partnership, youmust activate it. If users attempt to authenticate while the
partnership is not activated, SiteMinder provides an HTTP 500 error message without an explanation of the
cause of the error.

1. In the CA FederationManager, select Federation > Partnerships.

2. Beside the partnership you created, select Action > Activate. The FederationManager displays a
confirmation dialog. Click Yes.
After you activate a partnership, you cannot edit it unless you deactivate it first (Action > Deactivate).
After you have edited the partnership, it is in an inactive state until you activate it again.

3. Confirm the settings and then click Finish.

4. Beside the partnership, select Action > Activate.
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Configure Oracle
The following steps comprise theminimum required settings for federation between the ProxySG appliance
andOracle. For other settings that youmay require for your deployment, refer to the Oracle documentation.

To perform the procedures in this section, youmust be logged in with
adminstrator credentials on the Oracle server.

Step 1 - Import Metadata in Oracle

1. Go the following URL to export appliancemetadata:
https://<IP-address>:8082/saml/metadata/<realm-name>/sp

2. Save the file to disk.

3. In the Oracle EnterpriseManager, select Oracle Identity Federation > Administration >
Federations.

4. In the table of Trusted Providers, click Add.

5. In the Add Trusted Provider dialog, besideMetadata Location, click Choose File and browse to the
location of themetadata file that you saved in step 2.

6. Click OK.

Step 2 - Set up Federation Between the ProxySG Appliance and Oracle

To set up federation, first configure the appliance as a service provider. Then, configure Oracle as the identity
provider.

1. In the Oracle EnterpriseManager, select Oracle Identity Federation > Administration >
Federations.

2. In the table of Trusted Providers, select the Provider ID you added when the appliancemetadata was
imported, and then click Edit.

Step 3 - Select Update Provider Manually

1. For Provider Types, make sure that both Service Provider and Authentication Requester are
selected.

2. On theOracle Identity Federation Settings tab, select Enable Attributes in Single Sign-On (SSO) .

3. In the list of attributes, select Email Address and clear all other selections.

4. Click Apply.

5. Select Oracle Identity Federation > Administration > Identity Provider.

6. On the SAML 2.0 tab, select Enable Identity Provider.
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7. In the Assertion Settings section, select Send Signed Assertion.

8. Click Apply.

Step 4 - Set up Attribute Mappings

When you set up attributemapping, you specify the namewith which an attribute should be defined in the
SAML assertions.

1. In the Oracle EnterpriseManager, select Oracle Identity Federation > Administration >
Federations.

2. Select the Provider ID for the appliance and then click Edit.

3. On theOracle Identity Federation Settings tab, next to AttributeMappings and Filters, click Edit.

4. Configure the assertion. You can send any attribute, but this procedure describes the following:

Send User Identity

1. On the NameMappings tab, click Add.

2. On the Add Attribute NameMapping dialog, specify the following:

n For User Attribute Name, enter sAMAccountName.

n For Assertion Attribute Name, enter the attribute’s SAML name.

n Select Send with SSO Assertion in order for the attribute to appear in the assertion.

3. Click OK.

4. Click OK to save your changes. Alternatively, click Add to add another attribute.

Send Distinguished Name

The procedures for configuring assertion attributes refer to the attribute’s
SAML name. The SAML name is the name that you specified for the
attribute in "Define Assertion Attributes" on page 123.

1. Click Add.

2. On the Add Attribute NameMapping dialog, specify the following:

n For User Attribute Name, enter distinguishedName.

n For Assertion Attribute Name, enter the attribute’s SAML name.

n Select Send with SSO Assertion in order for the attribute to appear in the assertion.

3. Click OK.

4. Click OK to save your changes. Alternatively, click Add to add another attribute.
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Send Group Membership

Add thememberOf attribute to send groupmembership information in assertions.

1. Click Add.

2. On the Add Attribute NameMapping dialog, specify the following:

n For User Attribute Name, enter memberOf.

n For Assertion Attribute Name, enter the attribute’s SAML name.

n Select Send with SSO Assertion in order for the attribute to appear in the assertion.

3. Click OK.

4. Click OK to save your changes. Alternatively, click Add to add another attribute.

Step 5 - Sign Outgoing Assertions

If you have not already set up Oracle with a signing certificate, select a keystore to sign outgoing assertions.
If you have already set up a signing certificate, skip this step.

1. In the Oracle EnterpriseManager, select Oracle Identity Federation > Administration > Security
and Trust.

2. Click Wallet.

3. Click Update.

4. In the UpdateWallet dialog, in the Signature section, select a keystore that contains the certificate and
private key to use for signing outgoing assertions.

5. Click OK.

Step 6 - Send Encrypted Assertions

If Oracle will be sending encrypted assertions to the ProxySG appliance, create an encryption keyring in the
SAML realm. For instructions, refer to "Creating a Keyring" in the "Managing X.509 Certificates" chapter in the
SGOS Administration Guide. Then, export appliancemetadata. Importing themetadata to Oracle imports the
certificate from the keyring.

To send encrypted assertions after you have imported the certificate:

1. In the Oracle EnterpriseManager, select Oracle Identity Federation > Administration >
Federations.

2. In the table of Trusted Providers, select the Provider ID for the appliance, and then click Edit.

3. On theOracle Identity Federation Settings tab, scroll down to Identity Provider/Authority Settings.
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4. Verify the following options.

n In the Assertion Settings list, select Send Encrypted Assertions.

n In the Protocol Settings list, select Include Signing Certificate in XML Signatures.

n In theMessages to Send/Require Signed list, beside Response with Assertion - HTTP POST,
clear Send Signed.

5. Click Apply.

Be sure to update themetadata after enabling encrypted assertions if the last metadata file you uploaded
didn't include the encryption keyring.
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Configure Shibboleth

You can configure Shibboleth as an IDP in SGOS 6.5.2 and later.

The following steps comprise theminimum required settings to create a partnership between the ProxySG
appliance and Shibboleth. For other settings that youmay require for your deployment, refer to the Shibboleth
documentation.

Step 1 - Import Shibboleth's Certificate to the ProxySG Appliance

1. Copy the contents of <shibboleth>/conf/idp.cert.

2. In theManagement Console, select Configuration > SSL > CA Certificates. Click Import.

3. Click Paste from Clipboard. Click OK.

4. Include this certificate in a CCL. See "Configure the CCL" on page 121.

Step 2 - Configure the Partnership

1. Download the ProxySG’s SAML realm metadata. It is located in
https://<IP_address>:8082/saml/metadata/<realm-name>/sp.

2. In theManagement Console, select Statistics > Advanced. The console displays a list of advanced
URLs.

3. Scroll to SAML2 and look for SP metadata for SAML2 realms. Make note of the followingmetadata:

n The ID (“entityID” in EntityDescriptor element)

n The virtual protocol, hostname, and port number ("Location" attribute in
"AssertionConsumerServiceElement")

You require this information for the next step.

4. Copy themetadata to <shibboleth>/metadata/<my-metadata>.xml.

5. Add a new relying party in Shibboleth. Add the following in <shibboleth>/conf/relying-
party.xml:

<rp:RelyingParty provider="<virtual-host>/saml/<realm-name>" id="<virtual-
host>/saml/<realm-name>" defaultSigningCredentialRef="IdPCredential">
<rp:ProfileConfiguration xsi:type="saml:SAML2SSOProfile"
includeAttributeStatement="true" assertionLifetime="PT5M" assertionProxyCount="0"
signResponses="never" signAssertions="always" encryptAssertions="never"
encryptNameIds="never"/>
</rp:RelyingParty>
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6. Add the XML element <metadata:MetadataProvider> in <shibboleth>/conf/relying-party.xml.
Note that the “id” attributemust be unique among other existingmetadata providers.

<metadata:MetadataProvider id="<an id>
"xsi:type="metadata:ResourceBackedMetadataProvider">
<metadata:MetadataResource xsi:type="resource:FilesystemResource"
file="<shibboleth>/metadata/<my-metadata>.xml"/>
</metadata:MetadataProvider>
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Add the Realm to Policy
After completing SAML realm configuration, you can install policy using content policy language (CPL). Be
aware that the examples below are just part of a comprehensive authentication policy.

The following examples assume that the default policy condition is allow.

Refer to the Content Policy Language Reference for details about CPL and how transactions trigger the
evaluation of policy file layers.

SAML realms do not work with any "form" authenticationmode.

To allow every SAML-authenticated user access to the ProxySG appliance:

<Proxy>
authenticate(<realm-name>)

To specify groupmembership as the determining factor in granting access to the appliance:

<Proxy>
authenticate(<realm-name>)
<Proxy>
group="saml_users" ALLOW
deny

In the previous examples, <realm-name> is the name of the SAML realm you created.

142



Blue Coat ProxySGAuthentication Guide

How can I verify authentication and troubleshoot authentication
problems?
To ensure that authentication is working properly and to troubleshoot authentication problems, you can view user login
statistics. You can choose to display all logged in users, filter the display of logged in users by username, realm, or IP address,
or use a combination of these filters to display only the users you are interested in.

1. In the ProxySGManagement Console, select Statistics > Authentication.

2. (Optional) If you only want to view login statistics for a particular realm, select a Realm from the drop-down list.

(Optional) To filter logins by user name pattern, enter a regular expression in the User pattern field to display the
usernames that match the pattern. You can use the following operators when specifying a user pattern: 

Operator Matches

* Zero or more characters

? Exactly one character

[x-y] Any character in the character range from x to y

3. (Optional) To filter logins by address, enter an IP address or subnet to match in the IP prefix field. The IP address
subnet notation is based on Classless Inter-Domain Routing (CIDR), a way of interpreting IP addresses. For example:

n 1.2.3.4: represents the IP address 1.2.3.4

n 1.2.3.0/24: represents the subnet 1.2.3.0 with netmask 255.255.255.0

4. To display all authenticated user logins (or, those that match the defined filters, if any) click one of the following:

n Display by user—Displays login statistics by username.

n Display by IP—Displays login statistics by IP address.

Optimize IWA Authentication
When planning your deployment of of IWA-based authentication, consider the following points.

Causes of Authentication Delays

The following items are common causes of authentication delays:

Queued Client Workers
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If the ProxySG appliance receives NTLM authentication requests faster than the Domain Controller (DC) can process them,
HTTP client workers will queue, waiting on authentication. That results in a slow browsing experience for users. If enough
requests queue, somewill time out, resulting in users receiving an exception page being returned to the browser.

Domain Controller Instability

If a configured DC goes offline, the ProxySG appliance will connect to the alternate DC, and will periodically attempt to re-
connect to the primary in the background. If the alternate is also offline, the ProxySG appliance will connect to the fastest DC
available, as determined by an LDAP Ping.

Symantec recommends using the primary and alternate Domain Controller configuration to deploy a dedicated DC physically
near each ProxySG appliance for low network latency.

Using Read-Only Domain Controllers

Read-only (R/O) DCs can be configured as the preferred and alternate DC. However, it’s important to ensure that the R/O
Domain Controllers use an Active Directory Password Replication Policy that allows them to hold the password hashes for
users authenticating to the ProxySG appliance. If the R/ODomain Controller doesn’t have the password hash for an
authenticating user, then it must forward the authentication request to an R/W Domain Controller, which can introduce
substantial latency.

Trusted Domain Configurations

A trusted domain is a domain that has a trust relationship with the domain used by the IWA-Direct realm. To NTLM-
authenticate those users, the ProxySG appliance sends the authentication request over the same Schannel connection as the
others. In other words, the request is sent to a DC in the domain of the IWA-Direct realm. and that Domain Controller must
then forward the request to a DC from the user’s domain. That can introduce substantial latency if the DC from the user’s
domain is slow to respond.

Report Statistics to Watch

You can identify authentication speed issues by monitoring the access logs your ProxySG appliances produce. The x-cs-
auth-domain field contains the user’s domain, and the x-server-auth-time field contains the amount of time it took to
process the authentication request. Consult your Symantec Reporter documentation for steps to create a custom report with
these log fields.

Optimal Authentication Configuration

Symantec recommends the following authentication settings:

n Increase Schannel connections for IWA-Direct
IWA-Direct allows you to increase the number of concurrent Schannel connections that the ProxySG appliance will
make to each DC. That setting is calledMax Concurrent API, and can be found in the ProxySGManagement Console
under Configuration > Authentication > Windows Domains. The default value is 2, but it can be set as high as 150.

n IncreaseMax Concurrent API setting for IWA-BCAAA
IWA-BCAAA performs NTLM authentications by invoking aWindows system call to SSPI (Security Support Provider
Interface). SSPI invokes Netlogon, and Netlogonmanages the Schannel connection. For IWA-BCAAA deployments,
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Max Concurrent API is controlled through a Netlogon registry setting. Microsoft has documented that setting here:
https://support.microsoft.com/en-us/help/2688798/how-to-do-performance-tuning-for-ntlm-authentication-by-using-the-
maxc

Preferred and alternate DCs cannot be configured for IWA-BCAAA, because BCAAA doesn’t have control over which DC
Windows chooses for Schannel.
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Why don't my reports show user names for blocked
requests?
Whether or not your reports show user names for blocked requests depends on the order in which denial and
authentication occur in the policies you have defined. When the ProxySG intercepts a client request, it uses
the URL to determine the content category and, if the category is blocked based on your content filtering
policies, the request will be denied before the user has been authenticated and the user name is therefore not
available for logging. This is because Deny has precedence over authentication.

To force requests to be authenticated even in the case where the request is denied, youmust include the
authenticate.force(yes) property in the Proxy layer of your policy. For example, in the following example,
requests for gambling websites will be denied before authentication occurs:

define subnet corporate_subnet
10.10.12.0/24
end

<Proxy>
client.address= ! corporate_subnet deny ; filter out strangers
authenticate (MyRealm) ; this has lower precedence than deny

<Proxy>
category=Gambling exception (content_filter_denied)

However, by adding the authenticate.force(yes) property, you can ensure that authentication will occur
before the request is denied, allowing you to log the user names of the users who attempt to access gambling
sites:

define subnet corporate_subnet
10.10.12.0/24
end

<Proxy>
client.address= ! corporate_subnet deny ; filter out strangers
authenticate(MyRealm) authenticate.force(yes); this has higher precedence than deny

<Proxy>
category=Gambling exception (content_filter_denied)
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Why are users being prompted to authenticate?
One of themain benefits of IWA is that it can provide a single sign-on experience for users. When configured
properly, the user agent or browser will automatically provide the client's domain credentials when challenged
by the ProxySG appliance. Although you cannot guarantee that single sign-on will work in all situations, make
sure you have taken the following steps to enable single sign-on:

n Configure the IWA realm to allow Kerberos and/or NTLM credentials. When using Basic credentials,
the user will always be prompted to authenticate.

n Ensure that users are logging in to their workstations using domain credentials rather than local
credentials. The ProxySG appliance can only use domain credentials to authenticate users.

n Ensure that the client browsers support IWA single sign-on. At this time only Internet Explorer (IE) and
Firefox support single sign-on.

n Make sure the client browsers are configured to automatically provide credentials to the ProxySG
appliance.

n Create a DNS "A" record that maps the ProxySG appliance fully qualified domain name (FQDN) with
its IP address. In explicit deployments, the DNS A record shouldmap the FQDN in the browser explicit
proxy configuration; in transparent deployments, the DNS A record shouldmap the Virtual URL in the
IWA realm configuration to the IP address of the ProxySG appliance.

n Ensure that clients are using the DNS server you configured. To test this, ping the FQDN you specified
in the DNS configuration from a client system and ensure that it resolves to the correct IP address.
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Why is the BCAAA upgrade uninstalling previous BCAAA
versions?
Problem:When I try to upgrademy BCAAA server, the installation wizard indicates that it is uninstalling the
previous versions of the software. However, I still need the previous versions to support the appliances that I
do not plan to upgrade yet. What should I do?

Resolution:Although the BCAAA installation wizard says that it is uninstalling previous versions of BCAAA
during an upgrade, it will not remove the bcaaa.ini and bcaaa-nn.exe files for each version that was
previously installed. This allows it to continue to run any previous versions of BCAAA that were installed on
the server. After upgrading, your BCAAA server will continue to work with all SGOS versions it previously
worked with.
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Why are connections dropping with a default Deny policy?
Problem: If you have set up a SAML realm, users might experience dropped connections if the ProxySG
appliance uses the default policy of Deny. When the policy is set to Deny, the appliance intercepts and denies
requests to the IDP.

Resolution: Install the following policy to allow requests to the IDP:

<Proxy>
authenticate(<realm-name>)
<Proxy>
allow group=saml_users
<Proxy>
allow url.host=<hostname>

In the previous policy example, <realm-name> is the name of the SAML realm and <hostname> is the
hostname of the IDP.
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BCAAA Service Requirements
Refer to the following documentation for details on operating system and BCAAA compatibility:

BCAAA 6.1.x Service Requirements

n BCAAA 5.5.x Service Requirements

The information in these documents supersedes any and all other BCAAA information.
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Locate Browser Proxy Settings
If you are using an explicit proxy deployment, youmust set up each client Web browser to use the ProxySG appliance as its
proxy server.

Use the following table to help you locate the browser proxy settings:

Browser Proxy Configuration Settings

Internet Explorer Tools > Internet Options > Connections > LAN Settings

Firefox Tools > Options > Advanced > Network > Settings >
Manual Proxy Configuration

Chrome Options > Under the Hood > Change proxy settings >
LAN settings

Safari (Macintosh) Apple menu > System Preferences >Internet & Wireless
> Network > Advanced > Proxies

Safari (Windows) Settings menu > Preferences > Advanced > Proxies >
Change Settings > LAN settings
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SAML Reference
This section describes key concepts and terms in SAML authentication.

Federation and Metadata
The entities (IDP and SP)must federate before authentication can occur. During federation, configuration data is exchanged in
metadata files. Each entity publishes information about itself in these files and publishes them to a specific location, for
example, on the internet or a network drive. When the entities sharemetadata, they establish and agree on the parameters that
they will use for authentication requests and responses. They also share information such as:

n Entity IDs, which entities use to identify themselves to each other. For example, the Entity ID tells the IDP if an
authentication request comes from a federated relying party.

n The SSOPOST endpoint and SSO redirect endpoint to which entities send assertions during authentication.

n Each entity’s public key certificate, which is used to validate assertions.

n Whether each entity requires encryption. If one of the entities requires encrypted assertions, it will publish a separate
encryption certificate.

The appliancemay consume encrypted assertions from the IDP, but it does not encrypt
authentication requests that it sends to the IDP.

Assertions
The appliance and the IDP exchange data in XML documents called assertions. After a user is authenticated, the IDP sends
an authentication assertion and the appliance establishes an authenticated session with the appropriate authorization for the
user.

The appliance processes SAML authentication responses from the IDP; these responses may contain assertion attributes that
describe the authenticated user. For example, <saml:Attribute Name="mail"> is an assertion attribute that contains
the user’s email address inside the <saml:AttributeValue> element.

You can configure the appliance to use assertion attributes in authorization decisions. For more information on attributes, see
"Define Assertion Attributes" on page 123.

Profiles and Bindings
A profile contains information about how SAML supports a defined use case. For example, theWeb Browser SSOProfile
enables single sign-on authentication for resources on the internet.

SAML 2.0 includes protocol-specific bindings, which describe how SAML data is exchanged over those protocols. In SGOS
6.5, SAML authentication supports the following for theWeb Browser SSOProfile:
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n The HTTP POST binding for authentication responses

n The HTTP POST binding and the redirect binding for authentication requests
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Backing up the ProxySG Appliance
Youmay need to back up the ProxySG appliance configuration and save the backup file (called an archive) on a remote
system, which you can restore in the unlikely event of system failure or replacement. For more information on configuration
backups, refer to "Backing Up the Configuration" in the "Backing up the Configuration" chapter in the SGOS Administration
Guide.

Step 1 - Save Keyrings Before Backing up the Configuration

Backing up the configuration does not automatically save keyring data; thus, youmust save all keyrings and certificates before
creating a configuration archive.

1. In the command line interface (CLI), enter configurationmode and issue the following command:
#(config ssl)show ssl keypair <keyring_name>

2. Copy and paste the output from the command into a text editor. You will copy and paste this text into the CLI after you
restore the appliance.

Step 2 - Import Saved Keyrings After Restoring the Configuration

After restoring the ProxySG appliance, but before applying the archived configuration, issue the following CLI command:

#(config ssl)inline keyring show <keyring_name> <eof marker>
<copy and paste text here>
<eof marker>

You should now be able to apply the archived configuration without having to create and import a new keyring.

Step 3 - Re-Import the Appliance Certificate to the Trust List (AD FS only)

To establish an HTTPS connection to the ProxySG appliance, AD FS must trust the default certificate set in theManagement
Console; however, after you back up and restore a configuration archive, youmust re-import the certificate to AD FS. For
instructions, see "Configure AD FS" on page 129.
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