CA PPM 15.4 and 15.4.1 | Resolved Defects
The following customer-reported issues were corrected in the following releases:
March 9, 2018: CA PPM 15.4.0.0. Major Release
June 4, 2018: CA PPM 15.4.1 Service Pack

Note: All defects resolved in the 15.4.0.1 maintenance patch released on May 23 are also included in the 15.4.1 service pack.
See https://docops.ca.com/x/Z908Gw.

DE31552

New 'Team Rates Only' parameter to address Rate Matrix Extraction job taking very long time on 14.3 + on large datasets

Major Problem

Rate Matrix Extraction job takes very long time on 14.3+ on large datasets.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Set up an environment with a lot of matrix values.
2. Run the RME job with the first three options enabled.
Expected Results: Rate Matrix Extraction job to complete within reasonable time under 120 minutes.
Actual Results: Rate Matrix Extraction runs for 16-19 hours.
Workaround: None

DE31677

PPMOP_15.1_DEFECT - Loading time to show all resources in review & approve page in timesheets

Major Problem

Performance of the new UI Timesheet is slow when user has Timesheet Navigate Right

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
• Login to Classic PPM
• Navigate to new UI Timesheet
• Ensure a user has Timesheet Navigate Right
• Ensure you have at least 5k team member for whom you can approve
Expected Results: The new timesheet should be quick and less than 10 seconds
Actual Results: The timing of the new UI takes about 2.4 minutes to load 5k users

DE33331
Major Problem
Fixed in 15.4.0.0

PPMSAAS_15.1_DEFECT - CA PPM not exporting Assignment Max % Load to MS Project when Windows regional setting to
Portuguese language (New Driver)
(See DE33307 for a similar issue with Windows regional settings in Portuguese.)
STEPS TO REPRODUCE:
To reproduce this issue, you must have installed the MSP 2013 in Portuguese and English Language and Windows in Portuguese and English.
1. Go Administration > Project Management
2. Select Setting -Checkbox MSP Assignment Units Mapping with PPM Assignment 'Max % Load'
3. Go Home > Projects and select any project.
4. Create a task and assign any resource
5. Instead of 100% set Max % Load to 50%
6. Export to MSP
Expected Results: MSP Driver download Max % Load to MS Project
Actual Results: MSP Driver doesn’t download Max % Load to MS Project
Workaround: Change the OS level setting of 'Decimal symbol from comma ',' to period '.'
1. Go to Control Panel->Region->
2. Click the 'Additional Settings' button.
3. Change Decimal symbol value to '.'
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DE33583
Major Problem
Fixed in 15.4.0.0

Project Baseline in OWB or MSP from Different Timezone Causes Future last_updated_date in PRJ_BASELINE_DETAILS and Orphan
Records in DWH_INV_PROJECT
Adding a baseline in a project in a supported scheduler (Open Workbench or Microsoft Project) from a user in a different timezone that is ahead in time from
the app/db server results in future last_updated_date for the project in PRJ_BASELINE_DETAILS and orphan records in DWH_INV_PROJECT in the data
warehouse. (See also CLRT-80691.)
Steps to Reproduce:
1. Configure CA PPM with Data Warehouse and app/db on same date/time/timezone
2. Ensure Load Data Warehouse runs fine with no errors
3. Now prepare a separate server with OWB installed
4. Check the app/db time and set the server time for OWB server to be AHEAD in time. For example, the time difference should be 16 hours ahead (PST to
JST). In those cases the date will be sometimes on the next day.
5. Now restart OWB and open a project from CA PPM. Go to Project Tab.
6. Select Scope Project, Baseline Settings - Set, click OK
7. When prompted if you would like to continue, confirm with Yes
8. Now check in PRJ_BASELINE_DETAILS for the same project (example query below, replace the internal id with the correct one): select LAST_UPDATED_DATE
from PRJ_BASELINE_DETAILS where object_type ='PROJECT' and object_id =5006002
9. Note the time saved there is the actual time in future, which is set on the OWB client server
10. Now run Load Data Warehouse job - Full Load
Expected Results: The project to be brought in Data Warehouse investments successfully
Actual Results: Load Data Warehouse job fails, with error: ORA-02298: cannot validate (PPM_DWH.DWH_INV_PROJECT_LN_FK1) - parent keys not found. Any
subsequent runs will fail too, until the future date from step 9 is reached.
Workarounds:
1. Query the Data Warehouse database to find out the orphans with query: select investment_key from dwh_inv_project where investment_key not in (select
investment_key from dwh_inv_investment)
2. Feed in the exact investment keys in the following update query, and run it on PPM database: update PRJ_BASELINE_DETAILS set last_updated_date =
sysdate where object_type ='PROJECT' and object_id = and last_updated_date > sysdate commit
3. Then run Load Data Warehouse with Full Load.
Notes:
(1) Any subsequent runs will fail with the same message until we reach the exact time in future that corresponds to the PRJ_BASELINE_DETAILS.LAST_UPDATED_DATE Full error
message: Caused by: org.pentaho.di.core.exception.KettleDatabaseException: Couldn't execute SQL: ALTER TABLE DWH_INV_PROJECT_LN ENABLE VALIDATE CONSTRAINT
DWH_INV_PROJECT_LN_FK1 [CA Clarity][Oracle JDBC Driver][Oracle]ORA-02298: cannot validate (CLARITY144_DWH.DWH_INV_PROJECT_LN_FK1) - parent keys not found
(2) Upon checking we can see that the project record is in DWH_INV_PROJECT, but not in DWH_INV_INVESTMENT table. When verifying the view DWH_DW_INVESTMENT_V we
can see that it takes the greatest date on line 39:
WHEN BASEREC.LAST_UPDATED_DATE IS NULL
THEN INV_INVESTMENTS.LAST_UPDATED_DATE
ELSE
GREATEST(INV_INVESTMENTS.LAST_UPDATED_DATE, BASEREC.LAST_UPDATED_DATE)
END
(3) It will actually take the baseline date as it is in future (greatest) and not import the investment. However the dwh_project_v does not have this condition, so the project gets
imported in ppm_dwh.dwh_inv_project.

DE33585
Minor Problem
Fixed in 15.4.0.0

PPMOP_14.3_DEFECT - Data Warehouse: The Load Data Warehouse job bg-dwh logs are not ordered by date and time or by event
and the logging is not coherent
(See also CLRT-80146.)
Steps to Reproduce:
1. Connect to PPM - Home - Reports and Jobs - Jobs.
2. Run Load Data Warehouse job : either Incremental or Full Load.
3. Now connect to the server, and open the logs: bg-dwh.log bg-dwh.log.1 bg-dwh.log.2 bg-dwh.log.3
Expected Results: Logging to be consistent with other PPM logging, so ordered by date and time, and by event order.
Actual Results: Logging dates are going back and forward in the logs. It is not clear when each event occurred, and what was the exact order of the DWH
updates. Errors are thrown in the middle of the logs as well. The dates are not following the correct logical order.

DE33733

PPMSAAS_14.3_DEFECT - Delete Process Instance job can bring BG down with OutOfMemory error

Minor Problem

Delete Process Instance job can bring background service down with OutOfMemory error.

Fixed in 15.4.0.0

Steps to Reproduce:
1. Use an environment with millions of process instances.
2. Run the Delete Process Instance job with parameters to make sure it returns over 4 million processes.
Expected Results: The job to complete successfully.
Actual Results - The job crashes the BG service.
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DE33778

PPMSAAS_15.2_DEFECT - Task and project action items overriding each other

Major Problem

Action menu items are overwriting each other between different views and objects. Actions menu becomes unusable for affected object views.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Stop app services
2. Alter the sequences for CMN_GRIDS_S1 such that it is exactly 6 ahead of ODF_VIEWS_S1 at the database level.
(For example, alter sequence cmn_grids_s1 increment by {the absolute difference between cmn_grids_s1.last_number and
odf_views_s1.last_number, plus 6}, select cmn_grids_s1.nextval from dual, then alter sequence cmn_grids_s1 increment by 1)

3. Start app services
4. Go to Administration > Studio: Objects
5. Create a new object, call it menuclash1, then Save and Return
6. Create a new subobject of menuclash1, called it subclash1, then Save (don't Return)
7. Go to Views > subclash1 List > [Actions Menu]
10. Click on General, change the Menu Name to subGeneral and pick the action "New subclash1" from Available Actions to Selected Actions and click on Save.
Expected results: Menu name would change to subGeneral and Selected Actions includes "New subclash1"
Actual results: Menu name says General, Selected Actions includes "New subclash1"
11. Go to Administration > Studio: Objects
12. Open menuclash1 and go to Views > Properties > [Actions Menu] Expected results: Menu name would say General Actual results: Menu name says
subGeneral
13. Click on subGeneral to open the properties, change the Menu Name to menuGeneral, and add "New menuclash1" from Available Actions to Selected
Actions and click on Save.
14. Go to Administration > Studio: Objects
15. Open subclash1 and go to Views > subclash1 List > [Actions Menu], note the name says 'General' and click on it
Expected results: Menu name would show General (per earlier part of the problem) and Selected Actions shows "New subclash1"
Actual results: Menu name would show General (per earlier part of the problem) and Selected Actions for "New subclash1" is gone. The action "New
menuclash1" is showing as Selected instead.

DE34093

PPMOP_15.2_DEFECT - PDS_Excel_Export_shows_no_data_for_drilldown_portlets

Minor Problem

If you have a drilldown portlet on a project dashboard, you cannot export all data via "Export to Excel" or "Export to PowerPoint". The parameter which is used
for drilldown portlets is not taken into account for Excel/PowerPoint Exports and finally the data is not exported.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1* Create a new NSQL query with the following NSQL Name = Drilldown1 and the following code:
z_drill_1 SELECT @SELECT:DIM:USER_DEF:IMPLIED:BL:BL.ID:ID@, @SELECT:DIM_PROP:USER_DEF:IMPLIED:BL:BL.NAME:NAME@, @SELECT:DIM_PROP:USER_DEF:
IMPLIED:BL:BL.CODE:CODE@ FROM ( SELECT 1 as ID, 'BL1' as CODE, 'Baseline1' as NAME from dual union SELECT 2 as ID, 'BL2' as CODE, 'Baseline2'
as NAME from dual union SELECT 3 as ID, 'BL3' as CODE, 'Baseline3' as NAME from dual union SELECT 4 as ID, 'BL4' as CODE, 'Baseline4' as NAME
from dual union SELECT 5 as ID, 'BL5' as CODE, 'Baseline5' as NAME from dual ) BL WHERE 1=1 AND @FILTER@

2* Open Administration > Portlet Pages > Project Default Layout Page, and create new link parameter: Label = DrillParameter Parameter ID = BL
3* Open NSQL Query “Drilldown1” again and create a new link: Name = link to itself Link ID = z_link_to_itself Action = "Dashboard" (if Dashboard is not
selectable, check that the Dashboard is linkable - Project Default Layout > Tabs > Dashboard > Linkable: Yes) DrillParameter = code
4* Create another NSQL Query “Drilldown2” with following NSQL including an xml parameter to use the page parameter:
SELECT
FROM (
SELECT
as ID,

@SELECT:DIM:USER_DEF:IMPLIED:X:ID:ID@, @SELECT:DIM_PROP:USER_DEF:IMPLIED:X:NAME:NAME@, @SELECT:DIM_PROP:USER_DEF:IMPLIED:X:CODE:CODE@
SELECT 1 as ID, 'BL1' as CODE, 'Baseline1' as NAME from dual union SELECT 2 as ID, 'BL2' as CODE, 'Baseline2' as NAME from dual union
3 as ID, 'BL3' as CODE, 'Baseline3' as NAME from dual union SELECT 4 as ID, 'BL4' as CODE, 'Baseline4' as NAME from dual union SELECT 5
'BL5' as CODE, 'Baseline5' as NAME from dual ) x WHERE @FILTER@ AND x.CODE = @where:param:xml:string:/data/BL/@value@

5* Create a Grid Portlet "Drill1" and add Drilldown1 query as provider.
6* Add link "link to itself" to field "Name" in Portlet "Drill1"
7* Create another Grid Portlet "Drill2" and add "Drilldown2" query as provider.
8* Add both portlets to the "Dashboard" tab on the Project Default Layout Page. Change Layout to place Drilldown1 before Drilldown2
9* Open a project and navigate to Dashboard tab.
10* Click on the link of first portlet so that the second portlet shows the entry of selected value
11* On the Drilldown2 portlet, click Configure > Export to Excel (also with Export to PowerPoint)
Expected result: Entry is exported to Excel and PowerPoint
Actual result: Excel/PowerPoint do not have the entry, just the grid headers.
Workaround: Use Export to Excel (Data only). This option does export the entry.

DE34128

PPMSAAS_15.1_DEFECT - Due date shown in portlets and due date shown in the Reports does not match

Minor Problem

The same Due Date in portlets and reports does not match for the same end user.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Have servers located in some other region from where the end user is located (time difference between the server location and user location)
2. Servers are located in USA
3. Login to clarity as user from Sydney (make sure that user Account Setting has TimeZone as (GMT+10:00) Canberra, Melbourne, Sydney))
4. Create a Project "Test Due date"
5. Create a Risk say "Risk Due Date"
6. Create below Action Items form the created risk:
a) Action Item # 1 -- Due Date 5/13/17 12:00 AM
b) Action Item # 2 -- Due Date 5/20/17 12:00 AM
c) Action Item # 3 -- Due Date 5/27/17 12:00 AM
7. The Action Item portlets show the same due date as created.
8. Run the Load datawarehouse job with full load.
9. Navigate to Advanced Reporting and run Project Risk Register from above created project "Test Due date"
Expected Results: The due date shown for the created action items should be same as that what we see in the Action Item portlet.
Actual Results: The due date shown for the created action items is not same as that what we see in the Action Item portlet.
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DE34183
Major Problem
Fixed in 15.4.0.0

PPMOP_15.2_DEFECT - JDBC driver causes Upgrade Failure with message ORA-01017: invalid username/password; logon denied on
some Oracle environments
JDBC driver causes Upgrade Failure with message ORA-01017: invalid username/password; logon denied on some Oracle environments. This is an intermittent
environmental issue with specific JDBC drivers. See also CLRT-80922.
STEPS TO REPRODUCE:
Start a fresh install or upgrade to 14.x or 15.x.
Expected Results: The upgrade to proceed successfully
Actual Results: Upgrade fails with ORA-01017: invalid username/password; logon denied
Workarounds: Replace the c-oracle.jar in /lib and package/lib with the latest one from the highest build /package/ possible in the install.jar. Then jar
everything back. Important: Creating the jar on UNIX environment may cause an issue with the files, due to the .setup folder, prefixed with . (which is
indicative of hidden files in UNIX). Those files will NOT be added to the jar if not explicitly indicated. To workaround the issue use the command below to
create your jar: Where you normally would do this: jar -cvfM ../myjar.jar * you need to explicitly add the folder with this:
jar -cvfM ../myjar.jar * .setup/
-c is for create
-u for update
Notes: Due to Progress (JDBC) bug PSC00294082 (http://knowledgebase.progress.com/articles/Article/000048244) upgrades using that driver version may fail.
The 14.1 and 14.2 installer packages have the driver as it shipped with those versions. In order to remedy this problem, we set the release overrides by adding
the c-oracle.jar in the following directories:
C:\ca\clarity\trunk\upgrade\release-overrides\14.2.0\files\lib
C:\ca\clarity\trunk\upgrade\release-overrides\14.2.0\files\lib directories

DE34258

PPMSAAS_15.1_DEFECT - Upcoming Milestones Portlet Renders Milestone Outside Portlet Frame

Minor Problem

On the Upcoming Milestones Portlet, the Milestone marker icon in the Gantt Schedule columns do not appear in the correct column in Daily, Monthly,
Quarterly, or Yearly views.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1) Add the Upcoming Milestones portlet (Portlet ID = cop.prt.prjMilestones) to the Dashboard tab of the Project.
2) In the Tasks tab of an existing project, add several Milestone tasks with the following Finish dates:
Milestone 1: 5/31/17
Milestone 2: 6/30/17
Milestone 3: 7/28/17
Milestone 4: 8/31/17
Milestone 5: 9/29/17
Milestone 6: 10/31/17
Milestone 7: 11/30/17
Milestone 8: 12/29/17
Milestone 9: 1/31/18
3) Go to Dashboard tab to see Upcoming Milestones portlet. Make sure to Configure the Time Scale of the Gantt Schedule field to Day, Month, Quarter, and
Year. The Week time scale seems to be the only one that is displayed properly.
Expected Results: Milestone marker should be displayed in the correct column based on the Finish Date of the Milestone.
Actual Results: Milestone marker is not displayed in the correct column based on the Finish Date.
Examples:
DAY: Marker is always displayed in the column for the next day after the Milestone Finish Date.
MONTH: If Milestone Finish Date is early in the month or towards the middle of the month, then marker appears in the correct column. If Milestone Finish
Date is towards the end of the month, then the Milestone marker appears in the next month's column.
QUARTER: If Milestone Finish Date is early in the quarter or towards the middle of the quarter, then marker appears in the correct column. If Milestone Finish
Date is towards the end of the quarter, then the Milestone marker appears in the next quarter's column.
YEAR: If Milestone Finish Date is towards the end of the year, then the Milestone marker appears in the next year's column.

DE35074

PPMSAAS_15.2_DEFECT - Unable to XOG out portlet when using singleContentType argument.

Major Problem

This capability would save a lot of time for end users who require the removal of unnecessary content.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Issue is reproduced in both XOG client as well as SoapUI, but behavior is different. When using XOG client you are getting a client side error and when using
SoapUI you are getting server side error.
2. Using XOG client read portlet using contentpack xog (for example, ks_chart).
3. Notice error below in the command window: Login SucceededRequest Document: ..\xml\portlets_read_ks.xml Writing output to portlets_read_ks_out.
xmlFailed to retrieve response documentjava.lang.NumberFormatException: For input string: ""
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
at java.lang.Integer.parseInt(Integer.java:504)
at java.lang.Integer.parseInt(Integer.java:527)
at com.niku.xog.client.XOGClient.mergeResponseToStream(XOGClient.java:824)
at com.niku.xog.client.XOGClient.processRequestAsStream(XOGClient.java:896)
at com.niku.xog.client.XOGClient.processRequest(XOGClient.java:585)
at com.niku.xog.client.XOGClient.processRequests(XOGClient.java:1444)
at com.niku.xog.client.XOGClient.invokeCommand(XOGClient.java:1237)
at com.niku.xog.client.XOGClient.main(XOGClient.java:142)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at com.werken.forehead.Forehead.run(Forehead.java:551)
at com.werken.forehead.Forehead.main(Forehead.java:581)
Logout Succeeded

4. When using SoapUI sending below request you are getting an error as well (Put your session number here)
5. You will see below error when using SoapUI: FATAL
Exception while processing client request

ks_chart

Expected Results: To XOG out portlet when using singleContentType argument.
Actual Results: Errors as described above.
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DE35297

PPMOP_14.4_DEFECT - Release plan edit rights problem

Minor Problem

Resources with all instance rights on release and release plan objects, are not able to see the "Add Release" and "Remove Release" buttons in the Release Plan
detail screen - Release Planner tab - Release section. Only when adding the global right "Release Plan - Edit All" , he is able to to see the tabs, but then he can
see all Release Plans which is not desired.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a user and assign following rights:
Instance: For a specific Release plan instance assign:
- Release approve - Release Edit
- Release View
- Release View Access Rights
- Release plan Edit
Global:
- Portlet viewer All
- Release Plan Navigate
- Release Approve All
- Release Navigate
- Release Create
- Release Edit All
- Release View All
2. Log in as this user.
3. Navigate to Home - Release Planning and open the Release Plan where rights were granted.
4. In the Release Planner tab - Releases section only "Save" and Approve Release" are seen.
Expected: To also see the "Add Release" and "Remove Release" tabs.
Actual: In the Release Planner tab - Releases section only "Save" and Approve Release" are seen.
Workarounds: If appropriate, give the user the Release Plan - Edit All global access right.

DE35328
Cosmetic

PPMOP_15.2_DEFECT -Deleting a Task in MSP Leaves Orphan Process Instances Associated to that Task
Deleting a Task in MSP Leaves Orphan Process Instances Associated to that Task.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create an 'On Demand' process on the Task Object that does not immediately complete (For example: One that does not complete until an Action Item is
Approved. )
2. Create a project in PPM
3. Create a task on that project
4. Go to the Processes tab on the Task Properties
5. Select the Available link on the tab
6. Select the process created on Step1 and click on Start
7. The process instance on the task has a status of 'Running'
8. Go to Home > Organizer > Notifications tab
9. Click on the Properties icon next to the Action Item associated to this task instance
10. Approve the Action Item
11. Go back to the Project
12. Go to the Processes tab of the Task created previously and confirm that the process in 'Completed'
13. Go to the Task list and delete the task
14. Go to Home > Organizer > Processes tab (Or Administration > Processes > Initiated tab) and confirm that the related Process instance has been deleted.
15. Repeat Steps 3-12
16. Export the project to MSP
17. Delete the task in MSP
18. Save the project back to MSP
Expected Results: Similar results to when the task is deleted via the UI. The associated process instance is automatically deleted.
Actual Results: The associated process instance remains in PPM. Workaround: Delete the orphan process instance manually.

DE35410

PPMOP_14.4_DEFECT - XOG client query missing xsi namespace for nillable values

Minor Problem

The XOG client pulls out the SOAP body and saves this as the response output. When a null value is present in the output, it is rendered as .

Fixed in 15.4.0.0

The xsi (XML Schema Instance) namespace is defined in the SOAP envelope. When saving and working with only the SOAP body you do not have access to
this namespace's declaration, and that effectively hides the attribute from XPath processors and XSLT. Reference CLRT-69613 for the improvement to null
handling and an example of the output generated.
STEPS TO REPRODUCE:
1. Create a basic NSQL query called check_nillable, with this column added to the select clause of the default SQL provided to you by the UI: @SELECT:
DIM_PROP:USER_DEF:IMPLIED:RESOURCE:null:CHECKME@,
2. Create a minimal XOG query request file to pull the results out of this query: check_nillable
3. Login to the XOG client and set the output file and then call this XOG query request file above.
4. Examine the ouput
Expected Results: The xsi namespace referenced in each of the records should be declared in the output in a prior element.
Actual Results: The only namespace declared is the one for http://www.niku.com/xog/Query, and xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
is missing.
Workarounds: Pre-parse the file as plain text and inject the namespace declaration for xsi into the file, or use another tool/technology than the XOG client that
will let you persist the full response including the SOAP envelope.

June 6, 2018 | Downloaded from docops.ca.com

page 5

Fixed in 15.4.0.0 | Resolved Defects

DE35454

PPMSAAS_15.1_DEFECT - MSP elapsed duration is not retained after project is saved

Major Problem

There is an MSP elapsed duration issue identified where % complete is not getting retained in the schedule when duration is edays or ewks.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create new project in Clarity
2. Create a new task with start date of 1st May 2017 and end date 5th June 2017.
3. Save Project then open it in MSP4. Change the Duration in 27 days to 5 ewks
5. Save the project back to Clarity
6. Insert a new column for the project select the % Complete and set it to 70%
7. The the project back to Clarity and close it in MSP
8. Re-open the project in MSP
9. Re-insert the % Complete column and note the value.
Expected Results: The % Complete is still 70%
Actual Results: The % is longer 70% and subsequent saves and re-openings of the project without making any changes reduces the % complete further. This
also happens with a assignee attached to the task.

DE35497

PPMOP_15.2_DEFECT - Autoschedule changes date resource with actuals

Major Problem

We have a task with an assigned resource on a project with Actuals in the past and so a start date in the past as well. When using the "Autoschedule with
Publish" from Gantt, the task start date is respected but the resource assigned to this task, which has the Actuals assigned in the past, has a new start date
similar to other tasks/resources of the project with no Actuals.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a project with team, tasks and assigned resources.
2. Assign actuals for one resource on a task, make the start and finish in the past.
3. Open Gantt and do an "Autoschedule with Publish"
Expected: The same Start Date in the past for both task and resource because there are Actuals assigned in the past.
Actual: The Start Date unchanged for the task, which is correct, but the Start Date for the resource has changed to today's date or later.
Workarounds: None.

DE35651

PPMOP_144_DEFECT - Users receive 'An unexpected error occurred with method.' error message with the new MSP XML Driver

Major Problem

An unexpected error occurred with method appears after attempting to export a project to MSP for the first time after the new MSP driver is installed. After
clicking OK to this message, you may then also see the following error ‘SchedLink MFC Application has stopped working’. While users can click OK to clear the
message, it does cause a false alarm after upgrading, and is not expected. (See also CLRT-78950.)

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Install the new CA PPM MSP driver.
2. Log in to CA PPM.
3. Go to any project, and Open in Scheduler > Microsoft Project.
Expected Results: The project opens in MSP without error.
Actual Results: Project does not open in MSP and instead we get the following error message: An unexpected error occurred with method.
After clicking OK, you may also see the following error message: SchedLink MFC Application has stopped working.
Notes: As a best practice, first open Microsoft Project to verify the MSP interface is installed successfully. Do not attempt to automatically populate your PPM
login information by launching a project first from PPM. Use MSP first.

DE35677

PPMOP_15.2_DEFECT - Effort Task as phase

Minor Problem

Effort Task that has been made a Phase can still have a resource assigned to it. This has an unexpected effect on ETC and Allocation values and aggregations.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Make sure Admin > Project Management Settings allows for “Effort Task creation”
2. Create a new Project (without using a template)
3. Add a team member to the project (I call it “resource A”)
4. Create one task on the project (“new task”)
5. Open Gantt. It should show the effort task and the new task
6. Remove the assignment (if existing) from the effort task
7. Indent the new task such that the effort task becomes a phase
8. Add another team member to the project
Expectation: Prevent the effort task from becoming a phase even when there are no assignments on it.
Result: The effort task is a phase which has an assignment.

June 6, 2018 | Downloaded from docops.ca.com

page 6

Fixed in 15.4.0.0 | Resolved Defects

DE35690

PPMOP_15.2_DEFECT - Load DWH Failure when including Calculated String Attribute (size 260 Plus)

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Create a custom string attribute "review_comment" under Project Object with:
- Data Type=String
- Maximum Size = Between [260 to 2000]
- Include in the Data Warehouse = checked
2. Next create a calculated attribute "final_comment" with:
- Data Type = Calculated
- Result Data Type = String
- Current Expression = Concat(review_comment)
- Include in the Data Warehouse = checked
3. Put both attributes on the Project Properties Edit Views
4. Open an existing project and put string for review_comment=
5. Ensure the same is reflected on screen for 'final_comment' calculated attribute.
6. Run the Load DWH FULL or PARTIAL load Job fails.
Expected Results: Load DWH [Full | Partial] Job should complete successfully including both the attributes in DWH schema.
Actual Results: Load DWH [Full | Partial] Job fails.

DE35708

PPMSAAS_15.2_DEFECT: Agile Central Feature unable to come over as a task in PPM

Major Problem

Agile Central integration can't be used if task name is over 150 characters.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a feature (task) in CA Agile Central (formerly Rally) and create the title of the feature to be the max character limit (256).
2. Run the Rally Sync job.
Expected Results: Job to run successfully
Actual Results: Job Fails with following: There was a problem Syncing Clarity Tasks for Project: Tab test project HTTP/1.1 400 Bad Request "validation.
dataNotMaxSizeWithParam" "'Name' is too large. Maximum size is 150."

DE35733

PPMOP_15.1_DEFECT - Executing Time Compliance Report in 15.1 takes too long

Major Problem

Client users believe they are waiting too long for report output. Time Compliance Report takes 6-10 minutes to run whereas the query behind the report takes
about 45 seconds.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log into Clarity as the admin user
2. Select the Home tab then Advanced Reporting
3. Select Time Compliance report
4. Set the Resource OBS Type to IMG Team OBS
5. Set the Resource OBS Unit to Imagination Technologies | MIPS IP
6. Set Time Period to the Previous Period
7. Set Compliance % Yellow Threshold to 90
8. Set Compliance % Red Threshold to 75
9. Number of OBS Levels to 2
10. Click the Apply button
Expected Results: That the report takes not much longer that the query takes to run directly against database
Actual Results: The report takes between 6-10 minutes to run.

DE35785

PPMOP_15.2_DEFECT - Wrong WHERE condition with large selection in multi-select input control

Minor Problem

Incorrect number of rows of data returned when filtering on Data Items with over 2000 rows in Ad Hoc Views (Jaspersoft bug JS-33416).

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Find an object in the domains with > 2,000 instances, e.g. the Project or Task
2. Create an ad hoc view which shows you the number of rows, e.g. a table with a Total Sum for counting the project or Task names
3. Create a filter on a string field of this object, e.g. the Project Name or Task Name
4. Change the filter type to "is one of" and select more than 2,000 elements BUT NOT ALL ELEMENTS, e.g. Tick 'Select all' and then deselect at least one
element
5. Click on 'Apply' button to execute the filter
Expected Result: The 'Selected' data in the Filter to be reduced by one so for eg: if total number is 2245 then deselecting one item should return 2244
Actual Result: The 'Selected' data in the Filter is reduced by an explained amount eg: number of 'Selected' data is reduced to 2217 instead of 2244 and also
the number of rows of data returned in Ad Hoc View is further reduced by a 1000 rows which is 1217.

DE35789
Cosmetic
Fixed in 15.4.0.0

PPMSAAS_15.2_DEFECT - List header only partially locks on various lookup popup screens throughout the application when using IE
11
STEPS TO REPRODUCE:
Note: This issue is not always reproducible when Microsoft Internet Explorer 11 is maximized on the laptop screen. However, it will be reproducible every time
if the IE window is NOT maximized on the laptop screen. Issue will also occur if IE is being used on a different monitor either maximized or not.
1. Go to any page that has a lookup that returns enough records that require scrolling down the list. Example: Project Properties.
2. Click on the binoculars on this lookup. Example: Manager
3. Scroll down the list
Expected Results: The entire list header remains fixed at the top of the list.
Actual Results: Parts of the list header remains fixed. The remainder of the list header scrolls up with the list and eventually disappears. Users are scrolling
through the lookup lists, and are having to scroll back down on the list in order to see the full header. A related new feature was added back in 13.1, but does
not fully work when using IE 11.
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DE35826

PPMSAAS_14.4_DEFECT - Error 401 when removing a tab from General View

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0
Setup a non-admin user with below access rights.
Groups -- No groups
Resource Access Rights - Instance:
Resource - Enter Time
Resource - Self (Auto)
User Favorites Menu - Edit
Resource Access Rights - Global:
Organizer - Access
Time Period - XOG Access
Timesheet approval - XOG Access
Timesheets - Approve All
Timesheets - Edit All
Timesheets - Navigate

1. Under General view, click Mange Tabs, then click New.
2. Add a new tab then Save.
3. Return to the General view. You will see the new Tab.
4. Click on the new tab.
5. Go back to Manage Tabs and remove the newly added tab.
6. Click Return.
Expected Results: User should be directed to the available Tab without any error.
Actual Results: Error 401 - Unauthorized to view the page. If you are sure you have access, try logging in again or contact your system administrator. In the
current context, it is trying to navigate to http://CA-PPM-INSTANCE/niku/nu#action:copIssuesRisks (Risks, Issues and Changes tab ), for which user does not
have access. In other environments, it might be a different page.
Workaround:
1. Log in to CA PPM.
2. Create a new tab using Manage Tabs option and return. User would see Newly added tab along with other available tab for his login. Whenever user wants
to delete the newly added tab, have users be in General tab and make use of Manage tabs to delete the newly added tab.

DE35878

PPMOP_15.2_DEFECT - Portfolio Waterlines Primary Constraint for Budgeted Cost

Minor Problem

When you go into the Portfolio, Waterline page and click on Define Ranking rules, you see a lookup list for ‘Primary Constraint’. Users cannot use the
Budgeted Cost as a Primary Constraint in their Waterlines

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a portfolio with some investments with different planned and budgeted costs and benefits and some risks. Use ‘Application Management’ portfolio
from sample PMO Accelerator data
2. Set up the portfolio distributed targets for costs and benefits
3. Define the Primary Constraint = Planned Cost
4. Define the Weighted Ranking Rule = Risk / higher is better
5. Run Ranking Rules
6. As Expected - The list is properly ranked by Risk and the waterline appears in the proper position to separate investments based on the primary constraint
for planned costs
7. Now change the Primary Constraint = Budgeted Cost
8. Keep the Weighted Ranking Rule = Risk / higher is better
9. Run Ranking Rules
EXPECTED: the waterline should appear above line 10
ACTUAL: The waterline is above row 1 – not in the correct place.
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DE35907

Unable to open a project in MSP if a calendar associated with the project has more than 51 characters

Minor Problem

Unable to open a project in MSP New Driver if a calendar associated with the project (either the Standard Calendar, or any resource calendar that is on the
team) has more than 51 characters. When you open the project, you see a Microsoft Project message “An Import error occurred. The element in the element
with = 1 (Or ID of the respective calendar) has invalid data. The calendar name does not exist. Click a calendar in the list, and then press Enter. After you click
OK, the project opens blank. This does not happen in the legacy driver, and is not reproducible in MSP Standalone. In 15.1/15.2, the behavior observed can be
slightly different in that you can't always reproduce this issue unless the Calendar is the Standard Calendar in the application. (See also DE32693 and https://www.

Fixed in 15.4.0.0

ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1185235.html.)

STEPS TO REPRODUCE:
1. In PPM, create a calendar with more than 51 characters:
• Go to Administration->Project Management ->Base Calendars and click New.
• In the Calendar Name field, enter a name with more than 51 characters (Calendarcharacterlengthissuewithmspnewdrivertest1234)
• Click the check box next to Standard to make it the Standard calendar
• Click ‘Save’
2. Create a new project in PPM with one task (No tasks are needed to reproduce this issue, this is to show the affect of the project also being blank in MSP)
3. Attempt to open the export the project from PPM to MSP
Expected Results: Project opens successfully with the one task shown on the project
Actual Results: When you attempt to open the project, you first see a Microsoft Project message “An Import error occurred. The element in the element with
= 1 (Or ID of the respective calendar) has invalid data. The calendar name does not exist. Click a calendar in the list, and then press Enter.” Once you click OK
to the message, the project opens blank with no data.
Notes:
1. You can also reproduce this issue with calendars that are not the standard by associating a resource on the project team with that calendar in 14.4 (In
15.1/15.2, the behavior is slightly different in that you can't always reproduce the error unless the Calendar is the Standard Calendar in the application which
appears to be because of a separate calendar defect DE32693 that was introduced in 15.1 and then fixed in 15.3. In 15.1 and 15.2, the resource calendar with
the issue may not always be exported to MSP because of DE32693)
2. If this project is a subproject of another project, when you attempt to open the master project associated with the problem project, you'll see the following:
A popup window opens looking for the file in the MSP Bin folder "Example: Program Files (x86) -> CA -> PPM - CA PPM MSP Interface -> Bin". A message at
the top of the window states "Cannot find inserted project - ...". When you click Cancel, it takes you to just a list of the sub projects, and no actual tasks for the
projects.
Workarounds: Reduce the length of the calendar name to be less then 51 characters:
1. Go to Administration->Project Management ->Base Calendars
2. Click on the calendar with the issue
3. Click on the ‘Edit Calendar Properties’ tab
4. In the Calendar Name field, change the name of the calendar to be less than 51 characters
5. Click Save.

DE35921
Cosmetic
Fixed in 15.4.0.0

'Capacity vs Demand by Role' report doesn't show the unstaffed role when only one role is selected
In the 'Capacity vs Demand by Role' report in Jaspersoft, "Populate Resource Role", "Show Roles With No Capacity" and "Include Unstaffed Roles" options are
selected. When we select multiple roles, both staffed and unstaffed, the report displays correctly, showing lines for all roles. When we select only unstaffed
roles, the report shows no data. We suspect there is a bug in the query for the Allocation Subreport.
STEPS TO REPRODUCE:
1. Create a new role with Availability 7 hours. Check the Include Unstaffed Roles box and leave all other filter options as default.
2. Allocate the new role to 2 or 3 projects as a team member, no assignments to tasks and keep the role unstaffed.
3. Run the Load Data Warehouse jobs
4. Run the Capacity vs. Demand by Role report filtering by the role previously created.
Expected Results: To see data returned for the new role
Actual Results: This message appears when the new role is selected: “No matching records were found”. (Results are found when both DBA and the new role
are selected.)

DE35923

Allocations entered on Team Detail page are not rounding correctly for XOG'd in project

Major Problem

Entering allocation values entered on team detail page are rounding incorrectly for project that has been imported through the XOG with no start and end
dates specified in the file. Entering allocations into the team detail page cannot be guaranteed to store or display the values correctly.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Set admin option "Allow mixed booking" to true
2. Create a 'template' project. Dates are not important
3. Create a XOG which creates a new project from this template and WITHOUT the start/finish dates (example below)
4. In Classic PPM, staff the new project with one team member
5. Navigate to team detail grid and then configure the 'Allocations by Period' field to show 'Allocations' and 'Hard Allocations'
6. Back in the detail grid, enter a different value for Allocation and Hard Allocation in the first period and 'Save'
Expect: Values are retained
Actual: Hard allocation value changes to a different value.
Example XOG:
<?xml version="1.0" encoding="UTF-8"?>
<NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_project.xsd">
<Header version="6.0.11" action="write" objectType="project" externalSource="NIKU"/>
<Projects>
<Project name="myFromTemplate2" projectID="mytemplate2"
managerResourceID="admin" fromTemplate="mytemplate1" active="1" openForTimeEntry="true" trackMode="2" format="0">
<General addedBy="admin" addedDate="2017-07-14"/>
</Project>
</Projects>
</NikuDataBus>

Expected Results: All the allocations will display the values entered correctly
Actual Results: For a number allocations entered the value is rounded down but not all.
Workaround: Add a project start and end date to the XOG file.

DE35935

Vulnerability CWE 255 Credentials Management

Minor Problem

This security issue has been resolved.

Fixed in 15.4.0.0
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DE35949
Major Problem
Fixed in 15.4.0.0

“Change in ETC” Red Instead of Green in Investment Time and Estimate Review Report; “Adjusted Plan ETC” on Timesheet Overview,
Pending Estimates Review Page Also Red Instead of Green
The Investment Time and Estimate review report highlights the 'Change in ETC' as RED when it is negative (ETC is reduced). It should be green. Similarly, the
'Change in ETC' is highlighted as GREEN when the ETC is positive (increased). It should be red. In the PDF guide it states the following under the section titled:
Investment Time and Estimate Review “Green. The recommended Change in ETC is negative, indicating the ETC should be decreased for the task. Red. The
recommended Change in ETC is positive, indicating the ETC should be increased for the task.”
STEPS TO REPRODUCE:
1. Create a project and assign a resource to a task
2. In the ‘Task Assignments’ page, click on the properties icon for the assigned resource
3. In the ‘Assignment Properties’ page enter in a value of say 100 in ‘Pending ETC’ field and click ‘Save And Return’
4. Go to ‘Resource Management: Timesheet Overview’ page and see that the ‘Recommended Change in ETC’ is 36.00 and the ‘Increase/Decrease in ETC is a
white cross in a red diamond icon.
5. Go back to the ‘Task Assignments’ page, click on the properties icon for the assigned resource and in the ‘Assignment Properties’ page make the field
‘Pending ETC’ field blank and click ‘Save And Return’
6. Go to ‘Resource Management: Timesheet Overview’ page and see that the ‘Recommended Change in ETC’ is (54.00) in red and the ‘Increase/Decrease in
ETC is a green diamond icon. ETC should be green not red.
7. Run ‘Load Data Warehouse’ job
8. Go to Advanced Reporting and run the ‘Investment Time and Estimate Review’ report.
Expected Results: To see the “Change in ETC” in green in the “Investment Time and Estimate Review” report and to see the “Adjusted Plan ETC” in the
“Timesheet Overview -> Pending Estimates Review” page to be green.
Actual Results: The “Change in ETC” is in red in the “Investment Time and Estimate Review” report and the “Adjusted Plan ETC” in the “Timesheet Overview ->
Pending Estimates Review” page to is red.

DE35999

Session logout issue while Navigating between Classic and New UX

Minor Problem

The Classic UX session gets logged out while navigating to new UX and coming back to Classic.

Fixed in 15.4.0.0

DE36017

When creating instances of the grand child object via XOG it is only creating/updating instances in the first project

Major Problem

When creating instances of the grand child object via XOG it is actually only creating/updating instances in the first project mentioned in the XOG input file.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create subobject of project object called ks_sub1.
2. Create subobject of object ks_sub1 called ks_sub_sub1
3. Navigate to Home->Projects and create or select any project.
4. Under Properties drop down select ks sub1 list and create an instance with name and code equals to "ddd"
5. Navigate to Home->Projects and create or select another project.
6. Under Properties drop down select ks sub1 list and create an instance with name and code equals to "ddd"
7. Attempt to create instances via XOG for ks_sub_sub1 object that was created in Step 2.
8. Notice that a second instance that should be created in the second project is not created; instead it updates the same instance that was created in the first
project.
Expected Results: Instances should be created/updated for different projects.
Actual Results: Instances are created/updated in the first project mentioned in the XOG input file.
Workarounds: Do not reference same parentInstanceCode in the same input file when creating/updating instances of the grand child object.

DE36029
Cosmetic
Fixed in 15.4.0.0

PPMSAAS_15.2_DEFECT: Issues with the post timesheets when you adjust it ETC change
Problems with ETC when you adjust the timesheet. When you post a timesheet leaving a task with 0 ETC and then you make an adjustment, the ETC value
increments by itself. It looks like it takes the value of the total. This also happens with fixed duration tasks.
STEPS TO REPRODUCE:
1. In classic PPM, create a project and assign resource to the project.
2. Create a task and assign the resource to that task at 100%. (For example, a task of 16 hours for 14 and 15 of August)
3. Go to timesheet and search the timesheet for that resource.
4. Populates the timesheet for the 2 days, 16 hours, leaving the ETC at 0.
5. Post the timesheet.
6. Go to the posted timesheet and click on adjust.
Expected Results: The timesheet should show 0 ETC since we populate the timesheet with all the hours (in this case 16).
Actual Results: The timesheet populates with 16 total hours but the ETC increments to 16 hours as well.

DE36050
Cosmetic
Fixed in 15.4.0.0

PPMOP_15.2_DEFECT - New User Experience site - uploaded documents error
In New UI at some places like document upload page, x-api-next-string is passed as request parameter instead of header ad this causes the URL to be long
and doesn't work in load balancer like IIS.
STEPS TO REPRODUCE:
1. Set up a PPM 15.2 instance on IIS
2. Navigate to Document upload page and URL will look like:
https://EXAMPLE-sandbox2.EXAMPLE.com/ppm/rest/v1/virtual/attachments/eyJyZXNvdXJjZMTMyLCJ2ZXJzaW9uSWQiOjcmNlTmFtZSI6%0AInByb2plY3QU2MTUwMTN9?
x-api-next-string=U1dWS1pGZDJeFJNbmhvWTCamJUbDFXbmM5UFE9PQ==.....

Expected Results: The user should be able to upload a document
Actual Results: User get 401 page not found. (microsoft IIS has limitation on 260 and it truncates the URL)
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DE36104

PPMOD_15.1_DEFECT - Waterlines horizontal layout

Minor Problem

In PPM 15.2, if I use large digits cost value, bottom boxes of waterlines are not aligned horizontally.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create portfolio and including some project.
2. Set large cost value.

DE36128

Allocation cost is not calculate correctly

Major Problem

The Allocation Cost in the Team Tab is always calculated as $3600 per hour even if there is a rate matrix defined or not. The allocation cost is reporting
incorrectly; not helping us forecast the cost on the project from the Team page.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login and navigate to Projects
2. Create a new project but don't define the rate matrix
3. Navigate to the team tab and add any resource
4. Allocate the resource for a total of 10 hours.
5. Run the Rate Matrix job (required to be executed if you have a matrix and when on-the-fly option is turned off)
6. Run the Update Cost Totals from the Team tab
Expected Results: The allocation cost should either be 0 or should be using 1$ per hour.
Actual Results: The cost is calculated with $3600 per hour. In the above example, the allocation cost shows as $36,000.

DE36155
Minor Problem
Fixed in 15.4.0.0

PPMSAAS_15.2_DEFECT -Converting an Idea with a Benefit Plan (having a Null Benefit and non-zero Realized Benefit) to a project
throws Error 500
Converting an idea with a Benefit Plan (having a Null Benefit and non-zero Realized Benefit) to a project throws an Error 500.
STEPS TO REPRODUCE:
1. Create an Idea and fill in all required fields
2. Create a Benefit Plan
3. Create at least one row on the Benefit Plan
4. Enter a value for the 'Realized Benefit' field for at least one period on the TSV
5. Leave the Benefit amount blank
6. Submit the Idea for Approval, Approve and Convert the Idea to a Project with the 'Copy Financial Properties and Financial Plans' box checked.
Expected Results: The Idea is converted, the Benefit Plan copied over, and no errors are thrown.
Actual Results: The Idea is converted, but the Benefit Plan does not get transferred over. The new project properties throw an 'Error 500 - Internal Server
Error...' error as soon as the page is saved.
ALTERNATE STEPS TO REPRODUCE: This issue also occurs when copying a project from template:
1. Create a Project and fill in all required fields.
2. Create a Benefit Plan
3. Enter at least one row on the Benefit Plan
4. Enter a value for the 'Realized Benefit' field for at least one period on the TSV
5. Leave the Benefit amount blank
6. Mark the project as a template
7. Go to the project list and create a new project from template using the template created on steps 1-6
Expected Results: The project is created successfully. The Benefit Plan is copied over, and no errors are thrown.
Actual Results: The project is created, but the Benefit Plan does not get transferred over. The new project properties throw the following two errors: 'Error 500
- Internal Server Error...' and 'The Copy from Template operation failed to complete successfully. The project has not been fully realized based on the
template.'

DE36169

New UI - Published Status Report has incorrect report date

Major Problem

New UI - Published Status Report has got incorrect report date.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
Scenario # 1:
1. Login into the application using classic UI.
2. Navigate to any project and create a draft status report with Report date as "01-Jul-2017"
3. Login in to application using New UI
4. Navigate to the same project what we have used in Step #2
5. Publish a status report
Expected Results: The Status Report should get created with today's date, 16-Aug-2017.
Actual Results: The Status Report is picking up the Report date of the latest draft available in the project: 01-Jul-2017 in this example.
Scenario # 2:
1. Login into the application using new UI.
2. Navigate to any project and publish a status report.
3. We will be getting one Final Report & one Draft report with current date (if today is 16-Aug-2017, we get a Draft Report dated 16-Aug-2017).
4. Now, users publishes a status report on the same project very next day (17-Aug-2017)
Expected Results: The Status Report should get created with 17-Aug-2017 date.
Actual Results: The Status Report is picking up the Report date of the latest draft available in the project: 16-Aug-2017 in this example.
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DE36193

When XOG in process definitions Notification information for Custom Script Action is not carried over

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Create a process no need for associating to any object.
2. In the Start Step click on New under Actions and select Custom Script
3. Provide Action Name and Action ID, just put any sample gel script (will attach to the defect).
4. Update Notifications section, check When step action is performed, add resource to Send Notification To and check Notify Owner.
Click Save and Return.
5. Connect Start and Finish step and Validate the process
6. XOG out process using bpm_processes_read.xml
7. XOG in the output from step 6
8. Notice on the target system that Notifications section did not get updated
Expected Results: Notification section should be updated.
Actual Results: Notification section does not get updated.

DE36194

Notify Owner under Notifications section does not get updated when process is being XOGed in

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Create a process no need for associating to any object.
2. In the Start Step click on New under Actions and select Manual Action
3. Provide Action Name and Action ID, Subject and Assignees.
4. Update Notifications section, check When step action is performed, add resource to Send Notification To and check Notify Owner.
Click Save and Return.
5. Connect Start and Finish step and Validate the process
6. XOG out process using bpm_processes_read.xml
7. XOG in the output from step 6
8. Notice on the target system that Notify Owner under Notifications section did not get updated
Expected Results: Notify Owner under Notifications section should be updated
Actual Results: Notify Owner under Notifications section does not get updated

DE36233

Attachment on Collaboration tab not working properly in Microsoft Internet Explorer

Minor Problem

When you go to any project in collaboration tab > documents, when you try to click a document with accent like "Planificación" instead to download the files
it appear the following message: The webpage cannot be found. This only happen in internet explorer, in chrome works OK.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. In Internet Explorer, log in to Classic PPM.
2. Go to Home > Projects
3. Choose any project with a document title that shows an accent mark symbol such as "Planificación" or add a document with the symbol.
4. Go to Collaboration tab
5. Go to the document with accent.
6. Click on the name
Expected Results: The system should ask to download
Actual Results: It appears the following error: The webpage cannot be found.
Workaround: Download documents using another procedure or remove the accent mark symbol on the documents.

DE36242

New UI - Incorrect behavior while accessing Project Status Report via notification URL

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Log in to CA PPM New UI.
2. Navigate to any project and publish a status report
3. Copy the Project Status Report URL (this is ideally what process sends out via Notification to Project Managers).
4. Try accessing Project Status Report URL while User is already logged in which successfully redirects user to the Status Report page
5. But when accessing Project Status Report URL while User is logged out, the application prompts User to login to New User Interface and redirects user to
Project List page instead of Project Status Report page.
Expected Results: Project Managers should land on to Project Status Report page for the URL they are accessing even after login.
Actual Results: After clicking on the Project Status Report URL, we are prompted to log in to New UI and taken to the Project List page.

DE36247

PPMOP_15.2_DEFECT_ Internal Server Error when adding attributes to audit for Fiscal Time Period

Minor Problem

Receiving Error 500 - Internal Server Error when adding attributes to audit for Fiscal Time Period; There are numerous admins watching the timecards. If any of
them have to reopen a time period, it needs to be logged that they reopened a period, who did it, and for how long.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1.
2.
3.
4.
5.
6.

Log on to CA PPM.
Go to Administration>>Objects.
Search for 'Fiscal Time Period'. Select Fiscal Time Period
Click on 'Audit Trail' tab
Under Attribute Audit section select an attribute and move to the Audited Attribute section
Select 'Save'

Expected Results: User will be able to save this change
Actual Results: Receive a 500 error.
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DE36311
Cosmetic
Fixed in 15.4.0.0

PPMSAAS_15.2_DEFECT: Processes that auto-start on benefit plan creation, cause system errors if the benefit plan gets deleted,
before the process instance initiates
Processes that auto-start on benefit plan creation, cause system errors if the benefit plan gets deleted, before the process instance initiates. Sometimes a user
can delete a benefit plan, because it was copied wrong. If the user deletes the benefit plan, before the process initiates causes system errors across the
application
STEPS TO REPRODUCE:
1. Go to Administration > Data Administration > Processes
2. Create a process (bp) based on the Benefit plan object that auto-starts on creation and link it to the finish step
3. Create a project and financially enable it
4. On The Financial Plans tab, create a cost plan called CP, bigger the better
5. On The Financial Plans tab, create a benefit plan called BP, bigger the better and link it to the cost plan
6. Submit the cost plan for approval and approve it
7. Go to Administration > Data Administration > Process Engines and note the number of Completed Processes
8. On the Benefit Plan list, select the BP benefit plan and on the Actions menu click on Copy Benefit Plan
9. Create the copy of the Benefit Plan and click on Save and Return
10. Select the Benefit Plan copy just created and delete it
11. Go to Administration > Data Administration > Process Engines and check the number of Completed Processes again. There should be 1 more.
12. Click on the Completed Processes number and you get a system error The initiated process tab also throws a system error if you click on show all The
Organizer processes tab also throws a system error
Expected result: A process should not auto-start if the linked instance is deleted. This should not cause a system error
Actual result: If you delete the benefit plan instance before the process initiates, you get errors.
Workarounds: Run the Delete Process Instance job and run it against the process that generated this instance.

DE36343

MS Project integration fails when a task has Notes

Minor Problem

In projects with tasks that include notes, attempting to open the project in Microsoft Project fails. If all notes of all tasks of the project are removed, the
project can be opened in MS Project without problems.

Fixed in 15.4.0.0

Steps to reproduce:
1- Create a new project
2- Add one task with name 'test'
3- Save it and open through MS Project 2013 PT_BR language (integrated with the new PPM driver)
4- Closed it
5- Open the project through PPM
6- Click on the 'Task' tab and select a task (test)
7- Click on the link in the right called [Notes]
8- Click in 'new' button to add
9- Type 'test' in the Category and Note Text fields
10- Save and return
11- Try open this project through MS Project to see the error message
12- Closed the Project without save it, and remove from that task the note inserted
13- Now do you could open the Project through MS Project without error.
NOTE: With Project 2016 or 2013 (in English) we could not reproduce this issue.

DE36359

PPMSAAS_15.2_DEFECT - Cannot use New Res Planning Interface with NL keyboard

Minor Problem

Inline edit of the allocation figures, on the Resource Planning grid in the new PPM GUI, is not feasible, when using AZERTY keyboard. In the AZERTY keyboard,
the numbers are inputted using the combination keys, Shift + Numbers. This does not work in the Resource Planning grid.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Ensure that AZERTY keyboard is set (such as French - Luxembourg, French - Belgium), on the language bar, for input purpose
2. Log into the new GUI of CA PPM of 15.1 / 15.2
3. From the Menu click on Resources link
4. Expand a Resource and click on the plus icon in order to search and add investments
5. Carry on inline edit, in order to input numbers in the Resource Planning grid, using the AZERTY keyboard
Expected Results: User should be able to input numbers in the Resoure Planning Grid in the new GUI
Actual Results: User is unable to input any numbers in the Resource Planning Grid

DE36369

Overall Status indicator in New GUI does not reflect the data as per the latest Status Report

Minor Problem

Overall Status indicator in New GUI does not reflect the changes made to the draft from Classic UI.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login as Administrator to CA PPM and Create a new project
2. Create status report from Classic UI with Status Report Update as “From Classic”, Schedule Status, Scope Status and Cost and Effort Status as “At Risk” and
change Report Status to Final and Save the Report.
3. Go to new UI and look for the project – in the Project Tile page – the status of the Project Shows “On Track”
4. Click on the project and the status changed to “At Risk”
5. Go to the Status Tab and this will create a New Draft Status Report. Close the New UI Tab.
6. Get back to classic UI and list the status reports to see the latest Draft.
7. Edit the draft status report and change the Schedule Status, Scope Status and Cost and Effort Status as “Needs Help”.
8. Also Change the “Status Report Update” field to “From Classic draft edit” and change Report Status to Final and Save the report.
9. Navigate again to New UI in the Project Tiles page – you will still see the Project status as “On Track”
10. Click on the Project and the Conversation tab has the Status as At Risk
11. Go to Status tab and that has the status as “At Risk” still and is still reflecting the old Status Report. You can confirm this by looking at the Status Update
filed which still has the text we entered in the first status report in step 2.

Expected Results: The Overall status indicator should show the status based on the latest Final Report.
Actual Results: The Overall status indicator continues to show the status based on the previous report from Classic UI
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DE36409
Major Problem
Fixed in 15.4.0.0

When changing % Complete on a task, Material Resource cost changes by a small amount dependent on duration of the task using
MSP
When changing % Complete on a task, Material Resource cost changes by a small amount dependent on duration of the task. Example, for a task that has a
Material Resource assigned for 35 days at 5000 Units, the cost will decrease incorrectly by $.01 when you change the task % Complete to 50%. If you set up a
task the exact same way, except the duration of the task is 32 days, the issue doesn’t happen.
STEPS TO REPRODUCE:
1. In PPM, create a rate matrix with a rate of $1 for all resources for 1/1/2016-12/31/2017
2. Create a project, Open for Time, Track Mode set to None
3. Financially Enable the project (Financial Status = Open), and associate the project with the material rate matrix from Step 1 4. Add a Material Resource to
the Team tab (ensure this Resource's track mode is set to None)
5. Run the Rate Matrix job with the first 3 options checked
6. Export the project to MSP
7. Add % Complete, Remaining Cost, Actual Cost, and Cost to the view in MSP (It’s important to add Cost, as sometimes Remaining Cost and Actual Cost will
appear okay, but Cost is incorrect.
8. Create a fixed unit task (auto scheduled) with duration of 35 days. (Example: Start date of 8/30/17 and Finish date of 10/17/17)(Note, it seems the duration
impacts whether this issue will happen not. If you create a Fixed Unit task with a duration of 32 days, the Start date is 8/30/17, but the Task finish date is then
10/12/17 to coincide with the 32 duration, the cost issue does not happen)
9. Assign the material resource to the task and change the units to 5,000 so that Remaining Cost is now 5,000
10. To change the units, double click on the task and go to the Resources tab, change the value under Units for the resource to 5000 and click OK
11. Save the project plan to PPM and close the project in MSP
12. Open the project in MSP and change the task % Complete to 50%, then save and close the project (At this point everything is correct if you view the task
assignment details in PPM)
13. Open the project in MSP and view the Cost value in MSP
Expected Results: Cost still shows as 5,000
Actual Results: Cost has decreased to 4,999.99 (If you save the project back to PPM, then ETC/Cost will decrease there as well)

DE36435

PPMSAAS_15.2_DEFECT - Can't navigate "Back" from "Delete Instance" on Benefit Plan

Minor Problem

Can't use "Back" button to return back to the Benefit Plan, once you have used "Delete Instance."

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
* Home, Projects, choose a Project.
* Financial Plans, Benefit Plans, choose a Benefit Plan. Create a process to run on a Benefit Plan. It can be as simple as Start to Finish.
* Run the Process on a Benefit Plan: Processes, Available, select a Process and "Start"
* "Filter" until complete.
* Select Process and "Delete" (Delete the Process Instance on the Benefit Plan.
* "Yes" to "Alert: Do you want to delete the following process instances?"
Expected Results: Should have all menus present and be able to Back into the "Processes, Available" tab.
Actual Results: You are not returned to the correct location. You are returned to "Initiated" and the "Properties" and "Detail" tabs are missing. "Back" button
doesn't get you back to where you were in one click.
Workarounds: Manually go back through Project - Benefit Plan. (Click back twice and chose from menu again.) Or take it from the Recently Viewed Items.

DE36468

Baseline create [layout] view attributes discrepancy

Minor Problem

When you 'create' a new baseline, it is NOT using the 'create' properties layout but instead using 'edit'.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log in as an Administrator
2. Navigate to Administration menu ->Studio->Objects and search for Baseline.
3. Click on Views tab and under Baseline Revision Properties and click on Layout: Edit
4. Add attribute to any section or if you change the section titles in the EDIT layout, you definitely see that it is using the EDIT layout.
5. Navigate to Home->Projects and select any project.
6. Under Properties select Baseline
7. Click on New and notice that when you 'create' a new baseline, it is NOT using the 'create' properties layout.
Expected Results: When you 'create' a new baseline, it is suppose to be using the 'create' properties.
Actual Results: When you 'create' a new baseline, it is NOT using the 'create' properties layout but instead using 'edit'.

DE36523

Creating more than one TSV attribute in any Object results in negative values of these TSVs being put to DWH as zeros

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

Project object is being taken as an example here. The STR holds good for other objects as well.
1. Navigate to the Project object
2. Create two TSV attributes
3. Populate negative values against these two TSV attributes
4. Open the PPM Database, and run the following query:select *from dwh_fct_project_v
5. Run Load Data warehouse job, and run the following query in the DWH Schema:select *from dwh_project_facts
Expected Results: The negative values mentioned in step 3, should be visible in steps 4 and 5.
Actual Results: The negative values have been replaced by zero in both steps 4 and 5.

DE36556
Minor Problem
Fixed in 15.4.0.0
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DE36561
Cosmetic
Fixed in 15.4.0.0

Jaspersoft Server Cumulative Patch 6.2.1_5.2.1.4 Fails to Install
From the log file: .... [echo] Validating ${js.db.displayName} database connection at jdbc:oracle:thin:@oFl2-cpf-vir.EXAMPLE.net:1521/O121T:${oracleAttr.2}.
Phase: [import-export-test] [echo] About to validate JDBC jar existence [echo] Look in: D:/jspatch4/bin/ieUtil/conf_source/db/oracle/native.jdbc [echo]
Found jar file: assuming OK [echo] Jar or Jars found: ojdbc7-12.1.0.1.jar [select-sql] Failed to connect: IO Error: Invalid number format for port number [echo]
Connection failed: [echo] SQLState: 08006 [echo] Vendor specific error code: 17002 [echo] Message: [IO Error: Invalid number format for port number]
BUILD FAILED We edited the \webapps\reportservice\META-INF\context.xml file, changing the jdbc URL from "jdbc:oracle:thin:@oel2-cpf-vip.bankoh.
net:1521/O121T" to "jdbc:oracle:thin:@//oel2-cpf-vip.bankoh.net:1521/O121T" The patch then failed again.
STEPS TO REPRODUCE:
1. Stop Jaspersoft Tomcat service.
2. Navigate to /bin from a Windows command line
3. Execute the command install.bat interactive
4. provide information prompts from the installer.
Expected Results: Jaspersoft patch installs without issue.
Actual Results: Jaspersoft patch fails to install when using an Oracle RAC that only has Oracle Service name, not Service ID.
(Note: Unable to reproduce in a test environment.)

DE36575

Synchronization Agile Central job fails when projects or tasks are associated to milestones

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1 – In PPM, create an AC to PPM integration with Agile Central providing the workspace, project and owner
2 – Create a project in PPM and link it to the integration created above
3 – Run the Synchronization Agile Central job (Rally Synchronization job)
4 - In Agile Central, add more than 20 milestones to the project used for the integration
5 – Still in Agile Central, create 3 or 4 features to the initiative created for the PPM project
6 – Add all milestones (more than 20) to the features (divide them by each feature)
7 – Run the Synchronization Agile Central job again
Expected Results: Features are created with the respective milestones and job completes.
Actual Results: Job fails with the following error because not all milestones are loaded from Agile Central java.lang.ClassCastExceptioncom.niku.nmc.agile.
AgileIOException: 500api.internal ErrorAPI-1019 : Could not process the request due to internal error.

DE36585

Financial Forecast Review by Investment report not showing correct numbers

Minor Problem

The report Financial Forecast Review by Investment does not calculate correctly when there are unplanned lines. (See also DE33066.)

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a manual cost plan with 2 lines.
2. Create and Post financial transactions with some that match the plan lines and make some for unplanned lines as well.
Detailed Steps:
1. Financially enable a project and add 2 financially enabled resources. - If possible choose 2 resources with the same TRANSCLASS
2 Create a task so you can post transactions to it. You do not need to assign the resources to the task.
3 Create a manual cost plan. - Group by TRANSCLASS and RESOURCE - Add costs in current month for both lines.
4 Create and post a total of 4 transactions - 2 transactions for each resource - Use different transclass on second transaction for each resource My
resources both had transclass of INTLABOR. I created 1 transaction for each resource with this transclass, and then 2 transactions for EXTLABOR transclass to
create unplanned lines on the cost plan.
5. Post to WIP
6. Run Load DW
7. Run Financial Forecast Review by Investment for the specific investment. Choose Planned as the Financial Planned Type. Choose correct Fiscal Year.
(No need to import the actuals back to the project.)
Expected Results: Numbers match the cost plan.
Actual Results: All numbers are doubled. Are they doubled because there are 2 unplanned lines?

DE36595
Cosmetic
Fixed in 15.4.0.0

When adding "Other Time" in Classic UX Timesheets, list filter section cannot be configured
The list filter section of "Add Other Time" for Classic UX Timesheets cannot be configured. After doing any changes in the filter layout (and/or adding or
removing any attributes for the filter), all changes are lost after saving.
STEPS TO REPRODUCE:
(For a resource that is able to enter time for an "Other Work" NPIO)
1* Go to Home > Personal > Timesheets (classic UX)
2* Open a Timesheet where Other Time can be entered
3* Click "Add Other Time"
4* Click on Options > Configure
5* Click on List Filter Section > Layout
6* Change the List Filter configuration (i.e., move, add or remove an attribute)
7* Click on Save
Expected Results: Changes are saved
Actual Results: Changes are lost Note that when using the Save and Return button, the behavior is the same. Once the portlet is shown, it will still show older,
unchanged layout.
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DE36609
Cosmetic

Role count message appears twice after navigating beyond 1st page of 'Add Roles" in Targets tab of a portfolio
The limit count message appears twice after adding role from 2nd page or beyond of Add Roles popup in Targets of a portfolio.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Be sure you have more than 20 (or more than 40) Labor Roles defined in the system so that the browse dialog window will generate more than 1 page of
results for this issue
2. Create a portfolio
3. Click 'Targets' tab
4. Click 'Add Roles' button
5. Scroll to bottom of the 'Add Roles' popup - notice that the message is '0 towards the limit of 75 roles have already been added to the portfolio'
6. Click navigation arrow to go to 2nd page of 'Add Roles'
Expected Results: The message '0 towards the limit of 75 roles have already been added to the portfolio' should only display once
Actual Results: The message is shown twice:
0 towards the limit of 75 roles have already been added to the portfolio.
0 towards the limit of 75 roles have already been added to the portfolio
The message is duplicated on page 2 regardless if there has or has not been any roles added to the portfolio. If you have more than 40 labor roles, you can
navigate to page 3 and the message is duplicated there as well.

DE36631

When two attachments are deleted on the same subpage, you get redirected to the CA PPM Home page

Minor Problem

Users lose track of where they were as the page gets redirected to the CA PPM Home page

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
This only happens on an SSL (verified on a few OD environments) environment
1. Go to Administration > Studio > Objects > Project object
2. Create 2 attachment (single document) type attributes At1 and At2
3. Add these two fields to any project object subpage, let say the General section
4. Open an existing project and add a document to each one of the attachment type attributes
5. Save the changes
6. Click on X icon to remove the document from At1. Once done do the same for At2
Expected result: Documents are removed and you remain on the same page
Actual result: Documents get removed, but you get redirected to the CA PPM Home page
Workarounds: Click back on the back arrow of the browser to return to the previous page OR Remove the document from the At1 field > click save >
Remove the document from At2 field.

DE36633

Unable to add a team member to a project using the XML Open Gateway (XOG) if the resource ID contains an apostrophe

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Go to Home > Resource Management > Resources
2. Create a new resource called joxi. Ensure the resource ID contains an apostrophe: joxi'o
3. Create a project called joxi and add the resource created as a team member
4. XOG the project out by using the prj_projects_read.xml file
5. Delete the team member from the project
6. XOG the output file to add joxi as a team member
Expected result: Team member is added
Actual result: The XOG write throws an error and the team member is not added
Workarounds: Remove apostrophes from resource IDs. (However, if the resource is financially enabled, you can not modify the resource ID.)

DE36635

New timesheet UX misaligned on large screens

Minor Problem

When using a large screen, the new timesheet UX is not correctly aligned; refreshing the browser tab realigns the page correctly.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. On a large monitor, open any browser and get to the new UX login page.
2. Ensure the browser tab is maximized
3. Log in and go to the new timesheet UX
4. Open any timesheet and add some time entries, or edit an existing one that contains time entries
5. Timesheet details appear
Expected result: The daily headers and time entry cells to be aligned
Actual result: The daily headers and time entry cells are mis-aligned
Workarounds: Refresh the browser tab or minimize and maximize the browser tab.

DE36638

Action Item throwing error when clicking Return

Minor Problem

STEPS TO REPRODUCE:
1. Create a Process
2. Kick off the Process under Project>>Task
3. Create a New Portlet 'My Action Items''
4. Navigate to Task via Portlet.
5. From Main Page under My Action Items click on Action Item
6. There is an Object Link section. Click on the object
7. Once at the Object click 'Save and Return'

Fixed in 15.4.0.0

Expected Results: It will return to the General Overview page
Actual Results: Throws a CL-06036 error. Log files show below error Invalid Throw element, missing sub elements:com.niku.xql2.XQLVisitorException After
troubleshooting we found that this is being caused by the Link defined in a field under the List Column Section.
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DE36641

Memory leak in PPM sync job with Agile Central may cause OutOfMemoryExceptions in the BG

Minor Problem

BG is getting OOM exceptions. Analysis of heap dumps shows PerformanceMonitor TimingElements left over in threads that have run the Agile Central Sync
job. Since the BG uses a thread pool and currently doesn't clear the thread local storage when the thread is finished executing a job these TimingElements can
build up over time resulting in OutOfMemory.

Fixed in 15.4.0.0

Steps to Reproduce:
Not reproducible in house.

We suspect the Performance Monitoring of the sync job is implicated because a post-mortem study of the heap dumps shows the TimingElement of the
Performance Monitor stack are still around for a few threads.
To resolve this issue, we clear the UtilityThreadLocal at the end of the BGTask execution, which is the thread used for a job. Since job threads are pulled from a
threadpool any thread local storage allocated on that thread will remain active in the VM heap until the thread is re-used to process another job. Clearing the
thread local storage at the end of the job thread processing will ensure the memory is reclaimed by the VM.
We also addressed the TimingElement stack entries piling up in the Performance Monitor. This was caused by a call to the PerformanceMonitor.start() without
a corresponding PerformanceMonitor.end() for a particular monitor within the AC sync job.

DE36642

Action Item Status is Open, but Process moved forward and Completed

Minor Problem

Clarity lets the user change the status of the Action Item to Open after the user took an action and the process moved forward to the Next step.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1, Login with Admin User and create a simple process 'myprocess': Primary Object=Project. Start Option On-Demand.
2. Create new Step 'mystep1' with a manual action 'myaction1'.
3. In action 'myaction1': Select Actions Approved and Rejected. Complete Action Item Message For Assignee: select resources A and B
4. Step 'mystep1': Post Condition: Decision Point (XOR) IF ( Action Item.nt_step1.nt_action1 Number of assignees with Status Rejected >= 1 ) THEN GO TO
Finish IF ( Action Item.nt_step1.nt_action1 Number of assignees with Status Approved >= 1 ) THEN GO TO Finish
5. Start Step: Split Condition: Serial Go to Step 'mystep1' So, process Flow Diagram: Start -> 'mystep1' -> Finish
6. Validate and Activate the process
7. Open a Project. Go to Processes Tab. Initiate process 'myprocess'.
8. Go to Admin side. Processes. Initiated Tab. Filter by process 'myprocess'. Click on 'myprocess'. Click on 'mystep1'. This takes you to the Step Details page.
Observe Status is Open for the Action Items for assigness A and B. = Browser 2, Login with User A:
9. Go to Organizer. Action Item tab. Click on the Action. This takes you to Action Item Details page. Observe Status is Open.
10. User takes an action by changing the status to Approve and clicks on Save button. Observe Status.
Expected Results: The status doesn't change immediately to Closed and doesn't get grayed out, so the user can still change the status. Stay in the Action
Item Details page. 5. Refresh the Step Details page. Observe Status is Approved. = Browser 2, logged with User A: 6. User changes the status to Open and
clicks on Save button. Observe Status. It gets changed to Closed and gets grayed out. = Browser 1, logged with Admin User: 7. Refresh the Step Details
page. Observe Status is Open. Click on Back. Click on Return. 8. Observe process 'myprocess' status. Status is Complete.
Actual Results: The status should change immediately to Closed and get grayed out, so the user cannot longer change the status.

DE36645
Cosmetic

Error message when using Resource Management tool in new UX
When filtering on 'Resource Manager in new UI Resource Management, the message 'Creating instance of: odf personalization' occurs.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log in to the CA PPM New User Experience.
2. Navigate to the Resource Management (Staffing) page.
3. Select filters in 'Investment Resources' by selecting 'Investment Manager' and select one from the list.
Expected Results: the message 'Creating instance of: odf personalization' should not occur
Actual Results: 'Creating instance of: odf personalization' occurs towards the top while the filter is processing
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DE36656

Time Scaled Value Navigation Jumps Periods

Major Problem

For the Object based Portlet to set up a Budget Capital view, the time scaled value navigation is not working properly. By changing the configuration of the
Portlet (Number of Time Periods and Time Period Offset), we can see the amount in the desired Financial year but the same thing does not work when
navigating right or left. It is showing incorrect data mixing one year with another while navigating.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log into CA PPM -> ‘Administration’ -> Studio: ‘Portlets’
2. Click the ‘New’ button -> select ‘Grid Portlet’
a. Portlet Name: m_mags
b. Portlet ID: m_m1
c. Content Source: Customer
d. Category: Business Intelligence
e. Instance Type: General
f. Object: Cost Plan Detail
3. Go to ‘List Column Section’ tab -> ‘List Column Fields’ -> click ‘New’ -> for the ‘Display Type’ select ‘Time Scaled Value -> click on the ‘Next’ button and fill
in these fields:
Value Attributes: select ‘Actual Cost’ Column Label: call it ‘test’
Display Type: Number Start Date: Other date
Time Scale: Year
Number of Time Periods: 4
4. Go to the ‘List Column Section’ tab -> ‘List Column Layout’ -> move over the following from ‘Available Columns’ to ‘Selected Columns’:
'Actual Units', 'Investment Code', 'Investment Name', 'Cost Type' ‘test’
5. Then ‘Publish’
6. Go to Home -> General page -> click on ‘Manage My Tabs’ (spanner icon)
7. Click on the ‘New’ button Tab Name: Test TSV
8. Go to the ‘Content’ tab and select ‘m_mags’
9. Go back to the General page and click on the ‘Test TSV’ tab
10. In the ‘Test TSV’ tab click on Options icon which is located to the right hand side of the screen (it’s the cog wheel icon) -> select ‘Time-scaled Value’
11. Change the 'Time Period Offset' from '4' to '0' -> Save and Return
12. You should see the years 2017, 2018, 2019, 2020 for the TSV
13. Go back to the ‘Test TSV’ page and go to the TSV and click on the ‘>’ icon to move forward in time
14. Now click on the ‘<’ icon to move back in time
Expected Results: to see 2017, 2018, 2019, 2020
Actual Results: you see 2013, 2014, 2015, 2016, it misses out 4 periods, the ‘Time Period Offset’ is now -4

DE36657

When the Gantt Primary bar is configured to show the label for the bar, the label is hidden behind the bar and is unreadable

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Go to Administration > Studio > Objects
2. Edit the Task object and go to Views > Gantt > Fields
3. Edit the Properties of the Schedule field
4. Primary Bar > Label for Bar > Set it to Task
5. This will display the task name along the Gantt bar
6. Go to any project and open it in Gantt
7. The Gantt bars display and the task name label is there.
Expected result: The bar label to be readable or placed above the bar.
Actual result: The bar label is behind and is un-readable.
Workaround: Mousing over gives you the details of the task behind.

DE36658
Cosmetic
Fixed in 15.4.0.0

Health report shows Oracle 11.2.* as compatible on CA PPM 15.3
As per the Release Notes, CA PPM 15.3 is compatible with the following releases (with some patch caveats)
* Oracle 12c R2
* Oracle 12.2.0.1 Standard and Enterprise Edition: version 12.2.01
* Oracle 12.1.0.2 Standard and Enterprise Edition: version 12.1.0.2.x
However, the CA PPM Health Report shows Oracle 11.2.* as compatible.
STEPS TO REPRODUCE:
1* Run the CA PPM Health Report from Administration > Security and Diagnostics > Health Report
2* Click on Database tab
3* Check the Database Parameters section
Expected Results: Only 12c R2, 12.2.01 and 12.1.0.2.x are marked as compatible.
Actual Results: Recommended (green) "Version" shows as "11.2.*||12.1.*||12.2.*" and Compatibility level, "11.2.0.4.*||12.1.0.2.*||12.2.0.*"

DE36665
Cosmetic
Fixed in 15.4.0.0

Health Report shows an error for Timeslice Setup for Week Start Dates on MS SQL environments
The Health Report is showing an error (red diamond) on MS SQL environments for the Data Warehouse > Timeslice Setup > Week Start Dates even if they are
correct.
STEPS TO REPRODUCE:
(On a properly configured PPM environment using MS SQL)
1* Make all Weekly Time Slices start on Monday; verify the Administration > Project Management > Settings for the First Day of Work Week is a Monday.
2* Run the Administration > Security and Diagnostics > Health Report.
3* Go to Data Warehouse tab
Expected Results: If everything is properly configured, 100% will show up as green.
Actual Results: Week Start Dates will appear as red and a link to Fix it, pointing to Time Slice configuration.
(Note that in the described scenario, changing the First Day of Work Week setting to "Wednesday" will make it appear as correct / green).
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DE36673

Auto Numbering Issue For Resource ID Attribute

Minor Problem

Auto-Numbering for Resource ID does not increment the numeric portion of the ID by one. There is large difference between the numeric portion of the ID
that appears to be a function of time. This affects single app server systems and multiple-node app clusters alike.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
(1) Create an auto-assignment schema for the resource ID attribute on the resource object in Studio as follows: RES0000N, where N is the auto-assigned
number.
(2) Create a new resource in Administration > Resources > New
(3) Wait several hours or days and then create a second ID on the same system
Expected Results: the resource IDs should only have a difference of one between the first resource and the second resource
Actual Results: is an increasingly large difference between N on the first resource ID created and the second resource ID that is created later, depending on
the amount of time that has passed between creations.

DE36676

Timesheet filter screen: Filter label name mis-description in Japanese

Major Problem

In PPM 14.4, 15.1, 15.2, Label name of Date range: From/To in timesheet filter is not translated correctly in Japanese. On Date Range, "From" is translated in
Japanese correctly, but "To" is not translated in Japanese correctly.

Fixed in 15.4.0.0

DE36682
Cosmetic
Fixed in 15.4.0.0

Cost Plan XOG Error
Cost plan XOG write only provides generic error message for business rules related issues, such as cost plan details having a clash (identical values) for
grouping attributes.
STEPS TO REPRODUCE:
1. Install and configure PPM to be able to create a cost plan on an investment (e.g. requires entity and to populate department on investment record).
2. Create a cost plan on a new investment using the UI with basic details for just 1 cost plan detail entry, e.g.: Cost type: Operating Charge code: Labor
Resource: admin Fiscal TSV: Any start date and period Value: 1
3. Once populated click Save and Return.
4. Use XOG costPlan_read.xml to read this cost plan for your investment. Put the results into my_costplan.xml
5. Delete the cost plan that you created in the UI.
6. Modify the XOG file my_costplan.xml and duplicate the element to create a second one with the same grouping attributes.
7. Use my_costplan.xml to write this cost plan to the investment.
Expected Results: It is expected to fail, but with a message that clearly states the grouping attributes in the detail that caused the issue to make it easier to
identify and fix in a large cost plan entry.
Actual Results: The xog fails, but only gives this simple error message, and nothing goes into the app-ca log file either: An exception occurred while trying to
update an object instance costplandetail

DE36698

The same instance of the role cannot be assigned to a task if they are both not assigned at the same time

Minor Problem

The same instance of the role cannot be assigned to a task if they are both not assigned at the same time. PMs are not able to assign multiple instances of the
same role to a task, and they do not always have access to edit the 'Assignment Pool' field.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a project in PPM
2. On the project properties change the Assignment Pool value to 'Resource Pool', if not already
3. Add the same role twice on the project. (For example: Architect)
4. Notice how the Team list has the same role listed twice: Architect and Architect(2)
5. Create a new task on this project
6. Under the Assignments section, click on Assign (Notice how both instances of the Architect (Architect and Architect(2)) appear on the list to select resource
from.)
7. Select only one instance of the role (either one) and click on Assign
8. Click on Assign again to add the second instance of the role
Expected Results: The second instance of the role appears on the list of resources to select.
Actual Results: The second instance of the role does not appear on the list, so we can no longer assign the second instance of the role to this same task.
Workarounds: Change the 'Assignment Pool' value on the project to be 'Team Only'

DE36701

When update date value of project sub-object, other string value is not updated if date value is incorrect date format

Minor Problem

In PPM 14.4, 15.1, 15.2, when update date value of project sub-object, other string value is not updated if date value is incorrect date format.

Fixed in 15.4.0.0
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DE36745

Idea Manager(Auto) Instance rights missing post-upgrade

Major Problem

Hundreds of instances of the 'Idea - Manager (Auto)' right were deleted from an environment. They are missing in both the UI and the database. They existed
on a 13.3 instance, but once upgraded to 15.2, the majority of the instances (but not all) of this access right were deleted.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
NOTE: This is only reproducible with customer data. The customer has reproduced with two of their lower environments. Support has also reproduced by
upgrading a copy of the customer 13.3 database to 15.2.
1. Start with a PPM 13.3 instance
2. Run the following query in the 13.3 database:
select count(*) from cmn_sec_assgnd_obj_perm
where right_id = (select id from cmn_sec_groups_v
where group_name like 'Idea - Manager (Auto)')

Take a note of the count.
3. Upgrade this instance directly to 15.2
4. Run the same query from Step 2 on the upgraded database
Expected Results: The count to be the same as prior to the upgrade. The same query results as in Step 2.
Actual Results: The counts on Step 2 and Step 4 are not the same.

DE36786

Fiscal Time Period Error

Minor Problem

New periods must not create a gap with the existing periods message appears when modifying Period Name where there is no gap in periods.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create an Entity.
2. Create 24 monthly fiscal time periods (ensure there is no overlap of dates).
3. Open up one of the monthly fiscal time periods and modify the name.
Expected Results: A user should be able to successfully change the period name.
Actual Results: The message 'New periods must not create a gap with the existing periods' occurs

DE36806
Cosmetic

Cannot select custom attribute when building a Condition using “Days elapsed since step began”
Cannot select a custom attribute when building a Condition using “Days elapsed since step began”.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Open Object: Project and create a Custom Attribute type Number with two Decimal Places. Id=mynum
2. Create a Process with Primary object Project
3. Go to Step: Start
Under Post Condition click on [Build Condition]
4. In the Condition Builder:
- Left: Object=Step.Star Field=Days elapsed since step began Operator=
- Right: Object= Project.thisProject Field= try to select the custom attribute I created in step 1: mynum.
Expected Results: I should be able to select a custom field type number
Actual Results: The field mynum is not displayed in the list. The only fields available to select are: Actuals, Actuals Sum for Labor Resources, Current Baseline
for Labor Resources, Current Baseline Sum for Labor Resources, EAC Sum for Labor Resources, ETC, ETC Sum for Labor Resources, Total Effort.
(Note: At the time, CA Support could not explain why those fields appear. Most of them are type Number and columns in INV_INVESTMENTS table and some
are virtual.)
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DE36817

Database metadata requested by portfolio sync accumulates in jdbc statement pool

Major Problem

Synchronize Portfolio Investments job makes calls to get the database metadata from the DBMS through the driver. Unless this metadata is changed during runtime, the data
should be cached and reused. Instead, each run of the job repeats the same activity. When there are a lot of database connections in the pool due to normal usage (processes,
gel scripts, background jobs) and then a large number of portfolios are scheduled to be synchronized, the potential for different connections to repeat this same effort (due to
round-robin style use of the connections) increases further. Progress DataDirect drivers implement "statement pooling" as a client-side optimization. This can result in a large
accumulation of the same statements in separate connections of the pool. Note: This might be an Oracle specific problem. Observations include 150-400 statement references
per connection, >15k total for the connection pool, and then ultimately causing a BG crash due to java.lang.OutOfMemoryError.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Pause all jobs
2. Restart the bg services and wait 5 minutes.
3. Capture a heap dump of the bg service with name initial.hprof, e.g. jmap -dump:format=b,file=initial.hprof {pid of bg service java.exe process}
4. Schedule and run a single instance of Synchronize Portfolios for a portfolio in the system. Aim for a simple portfolio with just a single project added to the portfolio contents.
5. When it completes, capture a heap dump of the bg service with the name first.hprof
6. Schedule and run the Synchronize Portfolios again with the same portfolio as before. Do this 5 times in total (so you will now have run the job a total of 6 times since starting).
7. When it completes, capture a heap dump of the bg service with the name second.hprof
8. Schedule and run a single instance of Synchronize Portfolios with a different portfolio ID than before. Aim for a different mix of investments in this one, you can also choose to
include a child portfolio.
9. When it completes, capture a heap dump of the bg service with the name third.hprof
10. Analyze first.hprof, second.hprof, and third.hprof in Eclipse MAT
11. Open the OQL window for each parsed heap dump in MAT and issue the following query: select * from java.lang.String s where toString(s) like "SELECT null AS TABLE_CAT,.*"
Expected results: The quantity of results found by OQL between the "first" and "second" heap dump files should be approximately the same. It is expected that between "initial"
and "first" there will be an increase (from zero). It is also reasonable to expect some small amount of increase between "second" and "third" dumps.
Actual results: The quantity of results found by OQL between the "first" and "second" heap dump files has increased significantly, maybe 5 times as much, although the actual
amount will fluctuate and depends on various factors including the size of the database connection pool. The larger the number of connections due to processes and jobs
concurrency, as well as having a larger number of portfolio sync jobs scheduled in a batch with the heap dump being taken during or immediately after this activity, will result in
greater numbers. In some cases, this results in a complete BG outage as over 15k instances are found by OQL and the system crashes with a java.lang.OutOfMemoryError fault.
No portfolio sync jobs run, no processes exist, all jobs paused. OQL: 0 records
-First: Single portfolio sync job run, with a single project investment. OQL: 60 records
-Second: Single portfolio sync job run, with a single project investment. OQL: 118 records
-Third: 5 more portfolio sync jobs run, with a single project investment. OQL: 368 records
-Fourth: Single portfolio sync job run, with 'all' investments added. OQL: 368 records
-Fifth: Single portfolio sync job run, with a portfolio made up with just the other 2 portfolios added as children. OQL: 366 records
-Sixth: Resumed a number of other non-portfolio sync jobs, and took heap dump in middle of a portfolio sync run from with 2 portfolios added as children. OQL: 396 records
-Seventh: Heap dump taken after previous portfolio sync job completed. OQL: 396 records

DE36820

Portlet filter field issue

Major Problem

The root cause of this issue is with the object filter field properties POST request. It lacks URL encoding during the POST request for the url and return_url
parameters. Examples of non-encoded parameters: &return_url=/niku/app?action=mainnav.work&url=/niku/app?action=mainnav.work

Fixed in 15.4.0.0

This should be URL encoded as the all other instances of the same parameter are encoded in PPM as…&return_url=/niku/app%3Faction=mainnav.
work&url=/niku/app%3Faction=mainnav.work
Even the page before this properties page, the Filter List Column Fields page has its url parameter encoded properly.
Request URL: http://EXAMPLEdev221.webR.EXAMPLE.com/niku/nu?uitk.vxml=1&action=odf.
objectUserFilterFields&view_code=projectList&object=project&component=projmgr&url=/niku/app%3Faction%3Dmainnav.work%26classCode%
3Dproject&isUserPortlet=true&ui.page.space=mainnav.work&ui.page.template=union.appPage&viewCode=projmgr.projectList&id=projmgr.
projectList&portletId=projmgr.projectList&portletType=grid&portletInstanceId=projmgr.projectList_odf&displaySelectedTypes=selected

STEPS TO REPRODUCE:
1. Navigate to the Project List View Home > Projects (or any other list view or portlet)
2. Select the configure (gear) icon on the portlet
3. Select the List Filter Section tab
4. Select the List Filter Section tab to expose subtabs
5. Select the 'Fields' subtab
6. Click on the properties icon of any field in the list
Expected Results: The properties page is displayed
Actual Results: A pop-up window is displayed with this error message: "Unable to process request - Server or Network error"

DE36843

Cannot filter for timesheets using the ampersand character (&) in the New User Experience

Minor Problem

Using & in project names and tasks is causing problems when searching in the new UI timesheets.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a Task called "Work & Travel" and assign a Resource
2. Create a Task called "Work > Travel" and assign a Resource
3. Click on Home -> click on ‘Link to New Timesheet’
4. Navigate to Timesheets and select the assigned resource.
5. Select ‘+ WORK’
6. In Search window use field task and Type " Work &"
Expected Results: For the filter to return results containing the “Work &”
Actual Results: Error Message API-1006 : The value ''work' for Attribute 'taskName' is not in expected format or is invalid. appears.
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DE36864

Update PPM SaaS Health Check Report

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Log in to CA PPM SaaS 15.2 or 15.3.
2. Navigate to the new Health Report.
Expected Results: All data is appropriate for SaaS instances. On-prem health reports show appropriate data for on-premise configurations.
Actual Results: Some of the on-prem data does not apply for SaaS instances.

DE36869

Save and Return from subobject instance is taking you to the list instead of going back to the portlet

Minor Problem

Save and Return from subobject instance is taking you to the list instead of going back to the portlet where you came from.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login as Admin to CA PPM.
2. Create subobject i called (maria) with project as parent.
3. Create query as below:
SELECT
@SELECT:DIM:USER_DEF:IMPLIED:obj:id:id@,
@SELECT:DIM_PROP:USER_DEF:IMPLIED:obj:name:name@, @SELECT:DIM_PROP:USER_DEF:IMPLIED:obj:code:code@,
@SELECT:DIM_PROP:USER_DEF:IMPLIED:obj:last_updated_date:last_updated_date@,
@SELECT:DIM_PROP:USER_DEF:IMPLIED:obj:last_updated_by:last_updated_by@ FROM
odf_ca_maria
WHERE
@filter@

4. Under linking tab in the Query click on New Link and select Action to point to Maria Properties (subobject created in step 2)
5. Create portlet based on based on query created in step 3.
6. Click on List Column Section and Fields and click on id field properties to make it appear as link, under Link select the link you created in step 4 and then
also select 'Open as Pop-up' now click Save and Return
7. Navigate to Home->Projects and select any project to open Properties
8. Click on Dashboard tab and click on manage Project Tabs and create new Tab
9. Place newly created portlet from step 5 on the tab
10. Navigate to the Tab and click on the id link to go to the properties of that subobject instance and then click on Save and Return or Return and it will take
you to list of instances of that subobject instead of back to portlet.
Expected Results: It should take user to the portlet from where you click to the link.
Actual Results: It is taking user back to the subobject instance list.

DE36882

Load Data Warehouse job fails with database lock ORA-00054: resource busy and acquire with NOWAIT specified or timeout expired

Minor Problem

Load Data Warehouse job fails with database lock ORA-00054: resource busy and acquire with NOWAIT specified or timeout expired.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
This is a new defect (or a scenario related to DE28864 CLRT-81011). It's very intermittent so not possible to reproduce in house.
Expected Results: The job to complete successfully every time.
Actual Results: The Load Data Warehouse job fails intermittently (sometimes once per month) with error ORA-00054: resource busy and acquire with NOWAIT
specified or timeout expired. Any Full or Incremental Load after this will also fail until the lock is removed.
This was partly fixed by the fix for defect DE28864 CLRT-81011. However it doesn't seem like all the scenarios were addressed.

DE36919

The term 'Blueprints' has a bad translation into Brazilian Portuguese

Minor Problem

The term 'Blueprints' has been translated as “Planos estratégicos” rendering a completely different meaning. “Blueprints” is a term we should not translate, in
Brazilian Portuguese – although it is a foreign word – we use the same term as in English, “Blueprints” – if absolutely necessary to find a term in Portuguese,
please use “Esquema” (singular) or “Esquemas” (plural) but preferably we would like to keep “Blueprints” as “Blueprints” in Portuguese.

Fixed in 15.4.0.0

DE36920

The term 'Blueprints' has a bad translation into Spanish

Minor Problem

The term 'Blueprints' has been translated as “Planes técnicos”, rendering a different meaning. “Blueprints” in Spanish should be translated as “Esquemas”
(plural form) or “Esquema” (singular form).

Fixed in 15.4.0.0

DE36934

Over/Under Allocation by Resource report for week ending displays columns with dates that are at the start of the week

Minor Problem

Users find the Over/Under Allocation by Resource report when using a period of week because the week ending starts at the beginning of the week. After
selecting a value of Week for Period Type input control of the Over/Under Allocation by Resource report, the output shows weekly columns with dates that
start at the beginning of the week and not the end of the week as the subheading suggests.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log into CA PPM with a user that has access to Advance Reporting.
2. Select the Home tab then Advanced Reporting
3. Select Over/Under Allocation by Resource report
4. Make sure the Period Type is Week.
5. Click the Apply button
Expected Results: The Remaining Capacity Week Ending columns should have dates that are at the end of the week
Actual Results. The Remaining Capacity Week Ending columns have dates that are at the start of the week.

DE36936

Link broken to Classic view from new UX

Minor Problem

When trying to get back to the Classic UX from the new UX page, we get a 404 error.

Fixed in 15.4.0.0
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DE36948

OWB error "com.niku.sse.exceptions.SEInvalidDateException IDR_DATE_ERROR_IN_AUTOSCHEDULE"

Major Problem

Cannot use the workaround provided in CLRT-15366. In a project, auto scheduling results in the following error message: com.niku.sse.exceptions.
SEInvalidDateException IDR_DATE_ERROR_IN_AUTOSCHEDULE: IDR_DATE_ERROR_IN_AUTOSCHEDULE

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. In OWB click on Autoschedule
2. Only tick 'Schedule Assignments on Locked Tasks'
3. Click 'OK'
Expected Results: For the task to autoschedule successfully.
Actual Results: com.niku.sse.exceptions.SEInvalidDateException IDR_DATE_ERROR_IN_AUTOSCHEDULE: IDR_DATE_ERROR_IN_AUTOSCHEDULE
In some cases, the scheduling of the ETC does not work.

DE36970

Budget Plan revision number is duplicating

Minor Problem

When a cost plan is submitted for approval using the merge option, the budget plan is created but the revision number which should ideally be incremented
remains the same. In short, there are more than one Budget Plan in the system for the same project with the same revision number.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
- Select any project which already has one cost plan and atleast one budget plan
- Create a monthly cost plan for a project Start : 2017-12 Finish: 2018-03
- Navigate to details tab of the cost plan and input Planned Cost for few months
- Save and return back to the Cost Plan List page
- On the right corner, under Actions, Submit Plan of Record for Approval
- Retain all values as it is and make sure the SUBMIT OPTION is MERGE.
- Submit for Approval
Expected Results: The revision number of the above submitted budget plan will have the highest number and there are no duplicates.
Actual Results: The revision number is 0 and is duplicated.

DE36987

Capacity vs. Allocation by OBS filters out the Roles incorrectly

Minor Problem

Capacity vs. Allocation by OBS filters out the Roles incorrectly

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. On an environment with many roles and Data Warehouse and Jaspersoft configured, connect to Advanced Reporting
2. Open report Capacity vs. Allocation by OBS
3. Fill in a general OBS to cover all scenarios
4. Now select Populate Resource Role
5. Select one Role
6. Uncheck Show Graphs
7. Click Apply
8. Repeat until you find a role that returns "No Matching Results"
9. Find a role that has results returned
10. Once done, select both roles and run the report
Expected Results: Report to return data for one role only as the other one has "No Matching Results"
Actual Results: Report returns data for both the 'empty' role and the role with data. The affected 'empty' roles had data but not on project with OBS set up. Or
some had no capacity but demand only.

DE37003

Advanced Reporting - Time Compliance Detail CSV download corrupt - shifting column - OBS Levels

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Make sure you have timesheets for several resources in different levels of a top OBS.
For example: I have timesheets for resources in these levels:
DWH Default - Level 1
Business Systems - Level 2
Presales - Level 2
2. Run the Time Compliance Detail Report and choose the Resource OBS Type for the above resources.
Choose the Resource OBS Unit: top level
Select several time periods
3. Run the Report
4. Verify that the report shows the different OBS Levels in the left column.
5. Save as CSV and open in Microsoft Excel.
Expected Results: All columns will line up.
Actual Results: At the row where there is the second level OBS, the columns shift to add the OBS to column B.
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DE37004

Static Multi Valued Lookup Attributes not working on Baseline Object

Major Problem

When defining a Static Multi Valued Lookup Attribute on the Baseline Object and adding the attribute as required to the Properties Create and Change layout,
the attribute can be saved without a value on a Change, and when using Auto Suggest to enter a value, the value is not saving on the Create or the Change.
This problem appears to be related to the Baseline object because if the same Lookup is used for an attribute on other objects, such as Project, it works as
expected.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1) Create a new static lookup (Baseline Reason) with a Sort Order of Alphanumeric and the following:
a) Hidden Key can be LOOKUP_CODE or LOOKUP_ENUM; Display Attribute of NAME.
b) Add several Lookup Values (ie. Other, Required, Design, Scope, Software, Resources, Requirements).
c) Make sure "Auto Suggest Enabled" is checked.
2) Select the Baseline object and add a New Attribute (Primary Baseline Reason) with the following:
a) Select Data Type of Multi Valued Lookup.
b) Select lookup of "Baseline Reason".
c) Check the "Value Required" checkbox.
3) Go to the Baseline Views tab and add the "Primary Baseline Reason" attribute to the General section of both the Create and Edit layouts.
4) Go to Home -> Projects and select any Project.
5) Create a new Baseline for the project. Fill in the required fields (Revision Name, Revision ID). For the Primary Baseline Reason, type "s" to enable the Auto
Suggest and select "Scope" or "Software". Click Save. Notice the value is wiped out, but since it is required, you cannot save without a value. So, you have to
use the Browse to select a value, and then click Save and Return.
6) Edit the same Baseline created in step 5. Click the "x" in the Primary Baseline Reason to clear the value. Click Save and Return. Notice it saves even though
this is a required field.
7) Edit the same Baseline again. Type "re" in the Primary Baseline Reason, and select one of the 3 values. Click Save. Notice the selected value is cleared.
Expected Results: A Required attribute on the Baseline object that is left blank on a Change is flagged with an Error. When Auto Suggest is used to enter a
value on a Baseline attribute, the value should be Saved when pressing Save or Save And Return.
Actual Results: A Required attribute on the Baseline object can be Saved with a Null value when Changing an existing Baseline. When Auto Suggest is used to
enter a value on a Baseline attribute, the value is cleared when pressing Save or Save And Return.

DE37008
Major Problem

Load Data Warehouse - Incremental fails with ORA-01452: cannot CREATE UNIQUE INDEX; duplicate keys found ORA-06512: at
"PPM_DWH152.DWH_INV_TASK_PERIOD_FACTS_LOAD"

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Complete the required setup steps unique to each installation.
2. Run Load Data Warehouse - Full
3. It completes successfully
4. Run Load Data Warehouse - Incremental
Expected Results: The Incremental job to complete successfully
Actual Results: The jobs fails with error:[CA Clarity][Oracle JDBC Driver][Oracle]ORA-20100: ENCOUNTERED EXCEPTION WHILE INSERTING INTO
DWH_INV_TASK_PERIOD_FACTS_LOAD. SQLERRM : ORA-20100: ENCOUNTERED EXCEPTION WHILE INSERTING INTO DWH_INTERNAL_MD. SQLERRM : ORA
-01452: cannot CREATE UNIQUE INDEX; duplicate keys foundORA-06512: at "PPM_DWH152.DWH_INV_TASK_PERIOD_FACTS_LOAD", line 56ORA-06512: at
line 2. (Upon checking we see many hundreds (thousands) of duplicates. On the source we do not see any duplicates. We were able to consistently reproduce
the issue. Any time Incremental runs it would be a problem. Full always runs fine.)

DE37020

Populate from investment team very slow

Minor Problem

The Populate from Investment team option to create a Cost Plan is very slow.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1 - Login to classic PPM application with user having project edit access rights
2 - Click on Project and search for a financial project
3 - Click on Team tab and add many resources (see table below showing how long it takes based on number of resources)
4 - Click on Financial Plans tab 5 - Under Actions, click on New from Investment Team
6 - Enter required details and click on Save to create new cost plan from Investment Team
7 - Open cost plan created in Step #5
8 - Under Actions, click on Populate from Investment Team, this action is taking around 28 seconds of time during load test.
14 resources
51 resources
65 resources
78 resources
239 resources
20 resources
869 resources
503 resources

30 secs
37 secs
37 secs
38 secs
85 secs
23 secs
480 secs
180 secs

80 tasks
11 tasks
115 tasks
98 tasks
103 tasks
89 tasks
86 tasks
31 tasks

Expected Results: Process should be much faster.
Actual Results: Takes a very long time depending on the number of resources on the team.
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DE37021
Minor Problem
Fixed in 15.4.0.0

Clarity NEW UX - Task Assignment Error - API-1007 : You are not authorized to POST resource(s). Contact your system administrator
for necessary security rights
When Project Manager tries to assign/add the existing Team members to Task, users are receiving the following error: "API-1007: You are not authorized to
POST resource(s). Contact your system administrator for necessary security rights." The error appears on the new UX, but not with Classic PPM.
STEPS TO REPRODUCE:
1. Create a Project
2. Add few team members
3. Make sure that Project Manager does not have any booking rights on the added team members
4. Log in as Project Manager making use of new UI.
5. Navigate to the project
6. Navigate to the Tasks tab.
7. Create a new task.
8. Click on [+Member] button to add the team member.
9. Search for the user who is already in the team tab in the ""Add team Member" popup and click Add.
Expected Results: Team member should get assigned to the task with out any error/issue.
Actual Results: Team member successfully gets assigned to the task, but gets "API-1007 : You are not authorized to POST resource(s). Contact your system
administrator for necessary security rights."

DE37023

Resource Management cannot show User Names in Japanese format

Minor Problem

Resource Management cannot show User Names in Japanese format.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a resource with Japanese characters.
2. Login with New UI (in 15.2 or higher) and go to Resource Management (Staffing).
Expected Results: It is expected to change the order as Family Name(Last Name) / First Name for Japanese. New UI Resource Management Screen show user
names as First Name / Family Name orders even in the locale is set for Japanese.
Actual Results: New UI - Resource Management cannot show User Names in Japanese format. New UI Resource Management Screen show user names as
First Name / Family Name orders even in the locale is set for Japanese.

DE37025

New UI Date Format issue for Japanese

Minor Problem

New UI Project Management - Tasks tab. The date format for the task tab is incorrect in Japanese UI.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a project.
2. Login with Japanese Language account and go to New UI Project Management.
3. Select Task and check Date format.
Expected Results: New UI Project Management shows correct Date format in Japanese.
Actual Results: New UI Project Management shows incorrect Date format in Japanese.

DE37027

New UI Status Report cannot export Japanese chars to PDF

Minor Problem

New UI Status Report cannot export Japanese chars to PDF.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login with Japanese Language account and go to New UI Project Management.
2. Create a project.
3. Select Report and check characters in report. Also check downloaded PDF file.
Expected Results: New UI Project Management shows correct characters in Japanese.
Actual Results: New UI Project Management shows incorrect characters in Japanese.

DE37043

Resource Skill and Remaining Capacity Detail report shows inactive skills

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Go to Home>Resources in the Classic CA PPM user interface.
2. Select the desired resource.
3. Go to the Skills tab
4. Click the add button and add at least one active skill to the resource.
5. Save and Return
6. Go to Administration>Skills Hierarchy
7. Select the Skill(s) just added to the resource.
8. Remove the check mark next to Active.
9. Save and Return.
10. Go back to the resource from step 2 and confirm the now inactive skill(s) are no longer listed on the skills tab.
11. Run the Resource Skill and Remaining Capacity Detail report from Advanced Reporting.
Expected Results: Only active skills are shown in the report.
Actual Results: All skills assigned to the resource are shown in the report.
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DE37066

Resetting Password for Force Password Change in new UX

Major Problem

Cannot change password and login if the 'Force Password Change' box is checked.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Set up a user in CA PPM Classic administrative interface and check the 'Force Password Change' check box.
2. Have the user try to log into the new UX. [An error message appears: Error during login API-1030: Password is expired or needs to be changed. Contact
your system administrator for necessary action.]
NOTE: The message is not clear - it should tell the user to click on the 'Forgot Password?' link to change your password.
3. The user clicks on the 'Forgot Password?' link to display a new dialog
Message: Enter your username. The password reset instructions will be sent to you by email.
4. The user enters in the 'username' , clicks 'Send Email' button. (The dialog remains - no message indicating that an email message is sent.)
5. The user checks their email incoming box or quarantine box to see a new message with the instructions and a link to reset the password
6. The user clicks on the link and the user is taken to a page with 'New Password' and 'Confirm Password' fields
7. The user fills in the password fields, clicks 'Continue' button and sees a message with a 'Continue' button
Message: Password has been updated successfully.
8. The user clicks 'Continue' button and the user is taken back to the login page
9. The user enters the username and the new password
Expected: The user should be able to log in with the new credentials.
Actual: The user is not able to log in and gets the Error during login API-1030: Password is expired or needs to be changed. Contact your system administrator
for necessary action. It seems the 'Force Password' box did not get unchecked when the user reset the password. This will require the Admin to uncheck the
'Force Password Change' option on the resource profile.

DE37086

Classic PPM Timesheet Total displays incorrect values

Major Problem

When actuals are inserted in fractions and saved, the rounding keeps changing when saved the second time as compared to the first time without making any
changes to the actuals.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login to Classic CA PPM as Timesheet user
2. Open any Timesheet with OPEN status
3. Add two or three investments
4. Enter time as follows
a. Day 1;(16/10); INV 1: 1.99
b. Day 1;(16/10); INV 2: 5.00
c. Day 1;(16/10); INV 3: .505
Expected total: 7.495 and displayed as 7.50
5. Click Save and note the day total: Day total shows 7.5 (Correct)
6. Click Save again and note the day total: Day total shows 7.49 (Incorrect)
7. Click Save again and note the day total: Day total shows as 7.49 (Incorrect)
Expected Results: The actual hours at any point of time should be 7.50 in the totals.
Actual Results: The first SAVE in the timesheet page shows 7.5 hours which is correct and subsequent SAVE shows 7.49 which is incorrect.

DE37133

Program Milestone Report Not Filtering by Program Manager

Minor Problem

When the Program Milestone Dependencies Report runs and the user filters by the Program Manager, the results appear as “No matching records were
found”

Fixed in 15.4.0.0

STEPS TO REPRODUCE: Part I
1. From the Home Menu navigate to Programs, click on ‘New’ and create a new Program
2. Create at least one milestone with a dependency to a milestone in a separate project to display in the report
3. For the program summary section, the program must have budgeted or planned cost that is entered on the financial summary of the program. If the
program has a detailed budget or cost plan, then the approved budget amount or cost plan amount for the plan of record displays based on the financial plan
type parameter that is selected when running the report
STEPS TO REPRODUCE: Part II
1. From the Home menu, navigate to Advanced Reporting
2. Click on the ‘View List’ under Reports
3. In the Search bar type ‘Program Milestone Dependencies’
4. Check the ‘Populate Program Manager?’ checkbox in the Options window
5. After the search list has populated, choose the program manager in the program created in the prerequisite
6. Click the Apply button at the bottom of the Options window
Expected Results: The Program Milestone Dependencies Report should appear with a Program Summary and Program Dependency Diagram
Actual Results: A “No matching records were found” result appears
Workaround: Check the ‘Populate Program?’ check box and click the ‘Apply’ button to generate the Program Milestone Dependencies report.

DE37137

When click Japanese file name in Knowledge Store, it returns HTTP400 error.

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Add Japanese file name document in Knowledge Store.
2. Click Japanese file name in Knowledge Store with IE11 browser.
Expected Results: Document of Japanese file name can be opened by clicking in IE11.
Actual Results: Document of Japanese file name can NOT be opened by clicking in IE11. It returns HTTP400 error.
Workaround: Chrome and Firefox can open it by clicking.
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DE37150

Duplicate Workflow Action item

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Login as an Admin
2. Create an attribute on the project object that is basically going to be holding resources as a multi-valued lookup.
3. Create a process as described in the document attached.
4. Navigate to project and then Change Requests
5. Create new Change Request as one of the users that action item will be sent to
6. Process should have triggered and now you can navigate to Organizer and observe duplicate Action Items
Expected Results: only one action items should be received
Actual Results: two action items received

DE37156

About insertedRecords = "- 1" after Qualol PPM XOG-IN

Minor Problem

When we XOG--IN the data then we can see insertedRecords="-1" in result. When we try to XOG-IN with XOG-Out file without any changes then we can see
the error : insertedRecords="-1".

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. create a custom object. add 2 fileds.
2. input instances for the custom obejct.
3. XOG-Out for the customer object by using custom_object_read.xml.
4. Get the XOG-OUT result.
5, When I try to XOG-IN with XOG-Out file without any changes then I can see the following error : insertedRecords="-1".
This is the problem.
Expected Results:
Actual Results:

DE37181
Cosmetic

I can see the result : insertedRecords="0".

I can see the following error : insertedRecords="-1".

Project document version does not start a process
After a process created based on the "Document Version" object. When it was fired the process not be initiated automatically.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a new process called docver_start
2. Use Document Version (note: not Document) as the Primary Object
3. Auto-Start the process using either a condition on the Status attribute or a simpler "1==1" condition.
4. For the Start step, set a System Action that changes the value of the Status attribute.
5. Set the Finish step as the next step to go to.
6. Go back to the General page of the process and perform a Save-As and call this new process docver_update
7. For the Auto-Start conditions of this process, just change it from Create to Update.
8. Validate and Activate both processes.
9. As a user who has rights to add documents to a project and can start these processes, go to the Documents tab of a project.
10. Add a new document, optionally setting the status of the attribute such that it matches the docver_start auto-start condition.
11. Observe in the database that the record was created in CLB_DMS_VERSIONS for this document.
12. Observe in the Process Engines: Events tab of the Admin Tool that this did not cause any events to fire.
13. Modify the Document properties and set the Status to another value (if needed to be a specific value for the docver_update auto-start condition, use that
value).
14. Observe in the database that the record was updated in CLB_DMS_VERSIONS for this document with the changed value.
15. Observe in the Process Engines: Events tab of the Admin Tool that this did not cause any events to fire.Detail the steps to reproduce the problem
Expected Results: Changes that cascade from the Document to the Document Version should result in appropriate Document Version process engine events
that start processes.
Actual Results: No Document Version events are created, and so no Document Version processes are auto-started.

DE37186

Multi select filter populates two similar values when user only selected one value for Location or Department

Minor Problem

Multi-select Location filters automatically select a similar location in addition to the original location. Cannot extract data for a single location.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Administration -> Organization and Access -> OBS -> Create a department OBS with two units: HR and TC
2. Create a location OBS with two units: "UK" and "UK Like"
3. Add the Project object as associated Object to both OBS structures.
4. Go to Administration -> Finance -> setup
5. Go to Entities -> Create an entity associated to the above OBS
6. Go to Locations -> Link the locations and departments created
7. Go to Administration -> Studio -> Portlets
8. Create a grid portlet based on the project object
9. On the filter section, add the location field
10. On the field properties set the Lookup Style to multiple-select
11. Add the portlet to the general overview tab
12. On the filter section of the portlet, open the location field and select UK as location
13. Click on filter
Expected Results: The selected UK location to remain selected and filter by the appropriate projects linked to that location
Actual Results: After filtering, the selected UK location remains selected and also the ‘UK Like’ location has now been added. However, it filters by the projects
linked to that UK location.
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DE37213

Creating a Content pack with workflows does not bring group steps when content package installed

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Create a process that has group steps.
2. Create Content Package by navigating to Administration -> Content Packages
3. Add process you created in Step 1 to the package.
4. Once content package is created right-click on JAR package created under Properties tab and save it locally so you can import in another environment
5. Login to another environment where this process does not exist
6. Navigate to Content Add-Ins and upload content package.
7. Notice that Groups did not migrate, the reason they did not migrate is because they are not present in process XML file created by Content Package.
Expected Results: Step groups should be migrated along with the process.
Actual Results: Step groups are not migrated along with the process.

DE37219

MSP New Driver: Summary task duration is incorrect in PPM after Saving back from MSP

Major Problem

When saving a project back to PPM, the duration of the Summary task is different then that of that task in MSP 2016, while the dates of the Summary task are
correct. This causes an incorrect duration in PPM which does not correlate based on the dates set in PPM.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
(Tested with MSP Option Hours per day set to 7 and hours per day set to 35. The issue also occurs if hours per day is set to 8 but requires an extra round trip from MSP.)

1. Set the Base Calendar in PPM to 7 hours per day:
a. In PPM go to Administration->Base Calendars
b. Click on the Base calendar
c. Select the check boxes next to all work days (Mon, Tues, Wed, Thurs, Fri)
d. Click the Set Shifts button
e. Set Shits as: Shift 1: 08:00 AM - 12:00 PM Shift 2: 01:00 PM - 4:00 PM
f. Click Save and Return
2. Create a new project in MSP
3. Create a Summary task with 2 sub tasks
a. Set up the tasks with the below dates
Summary Task: Duration 10.71 days (Default set by MSP with hours per day set to 7) Start: 10/20/17 Finish: 11/2/17
Sub tasks: Task 1 Duration 5 days Start: 10/20/17 Finish: 10/26/17 Task 2 Duration 5 days Start: 10/27/17 Finish: 11/2/17
Ensure there is a Start No Earlier constraint of 10/27/17
b. Task type for all tasks: Fixed Units
4. Save the project back to PPM (At this point, the issue occurs if your work hour are set to 7 hours in MSP, but if your work hours in MSP for the project are
set to 8 hours, it will take an additional round trip of MSP for the issue to occur.)
5. Go into the Gantt view in PPM and check the duration of the Summary task.
Expected Results: The duration of the summary task matches that set in MSP.
Actual Results: The Duration in PPM for the summary task has changed (In the above example, changed to 9 days).

DE37225

Email notifications sent by PPM display odd characters in the logo area

Major Problem

Email notifications sent out by the PPM server for action items and other notifications display unexpected characters in the header. This occurs regardless of
the UI theme applied. When looking at the CSS for the theme applied, the rule for the 'Product name text' does not seem to contain any odd characters. The
odd characters can be highlighted so it seems they come from defined text and not from the logo.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Configure an email server (or mock SMTP server to be able to view attempted outgoing emails) in CSA.
2. Create a new resource -- or use an existing one -- but be sure they have a defined and valid email address
3. Go to Home > Organizer > Action Items tab
4. Click on 'New' to create a new Action Item and populate the required fields
5. Check the box titled 'Notify Assignees' and assign it to the resource from Step 2
6. Click 'Save and Return' and await the email notification to be sent out
Expected Results: Email notifications are sent out normally with no peculiar unexpected text
Actual Results: Email notifications are sent out with this text 'â„¢' appended next to the CA PPM logo and text.

DE37237

PPMOD_15.2.0.1_CASUP: Page loading wheel on top right corner keeps spinning even after completing Export to Excel

Minor Problem

The 15.2 SaaS environment page loading wheel at top right corner keeps spinning even after completing export to excel.

Fixed in 15.4.0.0

Steps to reproduce:
1) Go to any portlet or list view on PPM 15.2.0.1
2) export to excel (any of the 2 options)
3) Even after the export is complete, the wheel keeps loading.
Expected: Spinning user interface element stops spinning.
Actual: Somewhat confusing as it indicates that something is still pending.

DE37239

Certain projects hang at writing to XML when opening in the MSP New Driver due to a baseline issue

Minor Problem

Certain projects hang at writing to XML when opening in the MSP New Driver due to a baseline issue. (Does not happen in the legacy driver.)

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
Attempt to open the problem project from PPM to MSP that has a baseline.
Expected Results: Project opens successfully
Actual Results: Project hangs at "Writing to XML)
Workarounds: Rebaseline the project in PPM. However, if you delete that baseline, the issue comes back.
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DE37269

Rally Sync job fails with TASK_STATUS_INVALID_ACTUALS and API errors

Minor Problem

Errors occur when the Rally sync job runs and fails: api.internalErrorjava.lang.String cannot be cast to java.lang.Numberprojmgr.
TASK_STATUS_INVALID_ACTUALSPRJ-07234: Invalid status for task having non-zero actuals.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Set up a project in an integrated environment that is ready to be synced to AC.
2. Run the Rally Sync job
Expected Results: Job completes without issues
Actual Results: Following error messages are seen as the Rally sync job fails:
projmgr.TASK_STATUS_INVALID_ACTUALSPRJ-07234: Invalid status for task having non-zero actuals.api.internalErrorjava.lang.
String cannot be cast to java.lang.Number

DE37274

Unable to Update Action Item Status

Major Problem

Unable to communicate to the PPM server. Please try again and if problem persists contact your system administrator. Unable to update Action Item status if
it is assigned to more then 1 assignee

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login to CA PPM 15.3 as Administrator
2. Navigate to Home->Projects
3. Select any project and click on Collaboration tab
4. Click on the arror in the tab and go to Action Items
5. Create Test AI and assign to yourself and someone else (remember Action Item can only be assigned to participants)
6. Navigate to Home->Organizer
7. Under Action Items locate the AI you created in Step 5.
8. Click on AI and attempt to update the status of AI
Expected Results: Action Item status be updated successfully
Actual Results: Action Item status does not get updated, instead you observe an error "Unable to communicate to the PPM server. Please try again and if
problem persists contact your system administrator."
In 15.2 you don't get the error; however, it does not save and you get blank screen for few seconds and it comes back without getting saved.

DE37311
Cosmetic
Fixed in 15.4.0.0

When doing a role replace for a resource that is 100% available, a message appears prompting to over-allocate the resource
When doing a role replace, the role still remains on the project with a small amount of allocation if the availability of the resource and role do not match. This
is expected behavior within Classic PPM. When doing the SAME configuration and role replacement within the new UX Staffing functionality, the entire
amount of the role request is consumed.
STEPS TO REPRODUCE:
1. Set up a role with 8 hours of availability (Go to Home->Resources, click on the Role, and check that the Availability is set to 8 hours)
2. Set up a resource with 7.5 hours of availability in PPM and set their primary role as the role being used in #1 Steps to Reproduce:
3. Create a new project in PPM
4. Add the role above to the project
5. Set the Start/Finish dates of the role for one week (in this example 10/20/17 - 10/26/17)
6. Click the Resource Finder (Magnifying glass) icon next to the role
7. Check the check box next to the resource that was set up with 7.5 hours of availability and click Replace
Expected Results: The user should NOT see a message prompting an action to over allocate the resource. The Resource is available for 100% of the time.
Actual Results: A message appears prompting an action to over allocate the resource.
Workarounds: 1. Update the role calendar to match that of the resource it is replaced with. If using multiple calendars (Example, one with 7.5 hour shifts, and
another with 8 hour shifts), create a role for each calendar). 2. Delete the role from the project (though in this case, you will also lose any remaining
allocation/ETC on the role). See also CLRT-74594.

DE37320

PPMSAAS_15.3_DEFECT - The email notifications sent for any Risk which is Deleted or Reassigned does not contain the latest data

Minor Problem

Users are getting Risk Notifications with incorrect information.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1) Navigate to Administration - Notification - Notification Name: Risk
2) Update the Deleted risk and Reassigned risk and Save as follows:
a) Risk - Deleted risk: This risk assigned to you has been deleted: Risk Name: $[Risk.name] Probability: $[Risks.probability] Impact: $[Risks.impact]
Updated By: $[Risks.updated_by] Deleted By: $[Risk.updated_by] Deleted On: $[Risk.last_updated_date]
b) Risk - Reassigned risk The following risk has been reassigned. Risk Name: $[Risks.name] Risk ID: $[Risks.rim_risk_issue_code] Investment: $[Risks.
pk_name] Probability: $[Risks.probability] Impact: $[Risks.impact] Updated By: $[Risks.updated_by] To review risk, @[:itl.riskObject!~:~:Click Here]
3) Navigate to Home - Portfolio Management - Projects
4) Create a Project.
5) Navigate to Risks/Issues/Changes - Risks - Create 2 new Risks, Risk 1 and Risk 2 with Priority, Probability, and Impact.
**Make sure that a category is selected for the risk**
6) Assign the Risk to User 1 and User 2 respectively; this will send notifications to User 1 and User 2.
7) Once assigned, update the Owner (assignee), with Priority, Probability, and Impact. for both the Risks and save the changes.
8) The email notification sent to the users.
Expected Results: Email notification sent to the users should have updated information.
Actual Results: The latest information is not getting conveyed through the notifications.
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DE37343

Company Properties Menu Problems

Minor Problem

Company Properties Menu does not work as expected and does not work like other menus.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1) HOME -> Financial Management - > Companies
2) Click on any Company to go to Company Properties page
3) Hover over Properties tab and notice the Main and General menu items are both selected, like they are tied together. Click on the Supplemental menu
option and notice that Main and Supplemental are both selected. These options should not be tied together.
4) From the Properties tab, select the "Address" menu option. Hover over the Properties tab and notice that the "General" and "Supplemental" options
disappear.
5) From the Properties tab, select the "Financial" menu option. Notice that the "Properties" and "Document Manager" tabs disappear that you can't even click
on either tab. Notice that there is not a way to get back to any of the other sections unless you press Return.
Expected Results: For step 3: This should be a cascading menu, just like in Project Properties. When "Main" is selected, you should have the cascading menu
options of "General" and "Supplemental" over to the right. For step 4: It is expected for the "General" and "Supplemental" options to disappear IF step 3 is
fixed so that "Main" is a cascading menu. For step 5: The "Properties" and "Document Manager" tabs should not disappear, and you should be able to still get
to all other Company sections without pressing Return. Return should only be used for taking you back to the Company List, like all other pages work.
Actual Results: For step 3: The "Main" option is tied with the "General" and "Supplemental" options. For step 4: The "General" and "Supplemental" options to
disappear. This part is OK, IF "Main" is fixed to be a cascading menu that takes you to "General" and "Supplemental". For step 5: The "Properties" and
"Document Manager" tabs disappear that you can't click on either tab. There is no way to get back to any of the other sections unless you press Return.

DE37425

XOG entity read failing on SQL Exception with error code : 904

Minor Problem

Systems upgraded from earlier versions of PPM where custom portfolio attributes were created (prior to version 13.2) cause errors with XOG using the Entity
read request due to the custom attribute table (odf_ca_portfolio) not having code or name columns.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Use or install PPM prior to 13.2
2. Create a custom attribute for the Portfolio object.
3. Upgrade PPM
4. Create an entity
5. Use XOG to read the entity
Expected Results: XOG request completes with the entity contained in the response
Actual Results: XOG request completes with only the error "SQL Exception with error code : 904" inside and no additional details about what caused it

DE37439

Baseline creation by a process is not populating Baseline Start and finish on tasks

Minor Problem

When you use system action to create baseline, it creates the baseline but Baseline Start and Baseline finish are not displayed for the tasks. You can see this
behavior in task list and Gantt.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
Create the process:
-Go to administration > Processes
-Click new -In object tab put project object
-In Start option tab put On Demand
-In Start Step on actions, create a system action
In the system action choose the option 'Baseline Investment', set the "New Revision": YES and "Make current revision": NO
-In post condition go to the finish process.
-Validate and activate
Create a project:
-Go to Home Projects
-Click new and create one task with 15 day as example (It can be any days)
-Go to process > Available process and choose the process that we created in an earlier step and run it.
Expected Results: A new baseline is created with all his attributes
Actual Results: A new baseline is created but if you go to Gantt or task list, you will notice that 'Baseline Start' and 'Baseline Finish' are blank.

DE37459

Scheduled job continues to run after the Recur Until date

Major Problem

A recurring scheduled job runs at least once after the Recur Until date.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Login to CA PPM
2. Create a Scheduled job with recurrence as follows:
Start date: Tomorrow's Date Weekly: On: Months: Hours: Minutes: Recur Until:
Example:
Start date : 10/19/2017 Weekly: On: Thursday Months: October Hours: 13 Minutes: 00 Recur Until: 10/24/17
Expected Results: The scheduled job should run once on the Start date and then not run thereafter. It should not show as scheduled to run when checked
after the first run on the start date. In the above example, the job should have run on 19th and then stopped.
Actual Results: The Scheduled job continues to run at least one more time after a week. It also shows scheduled when checked after the first run. In the above
example the job ran on 26th and then did not run thereafter. The extra run of the scheduled job is impacting other scheduled jobs.
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DE37471

Time Periods in Jaspersoft Reports and Reports and in Jobs in PPM show different periods

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Go to Home: Reports and Jobs. Open a report, for example, ‘Resource Time Summary and Detail ‘Report.
2. Click on the binoculars to select the Time Periods.
3. Observe the Result. It shows all time periods that have been created through even though they are inactive.
For example, if I created periods through 2018 I get below periods:
ROW_NUM NUM_ROWS TIME_PERIOD_KEY R START_DATE FINISH_DATE DESCRIPTION
1 140 -3 C 05-NOV-17 11-NOV-17 Next Period
2 140 -2 B 29-OCT-17 04-NOV-17 Current Period
3 140 -1 A 22-OCT-17 28-OCT-17 Previous Period
4 140 5001001 D 01-MAY-16 07-MAY-16 5 140 5001002 D 08-MAY-16 14-MAY-16 ....... ....... .......
80 140 5002042 D 15-OCT-17 21-OCT-17 81 140 5002046 D 12-NOV-17 18-NOV-17 82 140 5002047 D 19-NOV-17 25-NOV-17 83 140 5002048 D 26-NOV-17 02-DEC-17 84 140 5002049 D 03-DEC-17 09-DEC-17 85 140 5002050 D 10-DEC-17 16-DEC-17 86 140 5002051 D 17-DEC-17 23-DEC-17 87 140 5002052 D 24-DEC-17 30-DEC-17 88 140 5002053 D 31-DEC-17 06-JAN-18 89 140 5002054 D 07-JAN-18 13-JAN-18 90 140 5002055 D 14-JAN-18 20-JAN-18 91 140 5002056 D 21-JAN-18 27-JAN-18 92 140 5002057 D 28-JAN-18 03-FEB-18 93 140 5002058 D 04-FEB-18 10-FEB-18 94 140 5002059 D 11-FEB-18 17-FEB-18 95 140 5002060 D 18-FEB-18 24-FEB-18 96 140 5002061 D 25-FEB-18 03-MAR-18 97 140 5002062 D 04-MAR-18 10-MAR-18 98 140 5002063 D 11-MAR-18 17-MAR-18 99 140 5002064 D 18-MAR-18 24-MAR-18 100 140 5002065 D 25-MAR-18 31-MAR-18 101 140 5002066 D 01-APR-18 07-APR-18 102 140 5002067 D 08-APR-18 14-APR-18 103 140 5002068 D 15-APR-18 21-APR-18 104 140 5002069 D 22-APR-18 28-APR-18 105 140 5002070 D 29-APR-18 05-MAY-18 106 140 5002071 D 06-MAY-18 12-MAY-18 107 140 5002072 D 13-MAY-18 19-MAY-18 108 140 5002073 D 20-MAY-18 26-MAY-18 109 140 5002074 D 27-MAY-18 02-JUN-18 110 140 5002075 D 03-JUN-18 09-JUN-18 111 140 5002076 D 10-JUN-18 16-JUN-18 112 140 5002077 D 17-JUN-18 23-JUN-18 113 140 5002078 D 24-JUN-18 30-JUN-18 - 114 140 5002079 D 01-JUL-18 07-JUL-18 - 115 140 5002080 D 08-JUL-18 14-JUL-18 116 140 5002081 D 15-JUL-18 21-JUL-18 - 117 140 5002082 D 22-JUL-18 28-JUL-18 - 118 140 5002083 D 29-JUL-18 04-AUG-18 119 140 5002084 D 05-AUG-18 11-AUG-18 - 120 140 5002085 D 12-AUG-18 18-AUG-18 - 121 140 5002086 D 19-AUG-18 25-AUG-18
4. Go to Advance Reporting. Open the same report ‘Resource Time Summary and Detail ‘.
5. Observe values in Time Periods input parameter. It shows periods until 11/19/2017 11/25/2017 D 19-NOV-17

-

Actual Results: Time Periods input control in Advance Reporting shows different periods from Time Periods Lookup in Reports and Jobs. Expected Results: Time Periods input control in Advance Reporting should show the same periods as Time Periods Lookup in Reports and Jobs. The behavior in PPM should be the same as Advanced Reporting.

DE37509

Overview Page, General tab shows incorrect Layout on log in when you have an HTML Portlet with comments in HTML code

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. In Admin side, Create an html portlet (named for example 'myhtml') with the following code:
Hello World! Notice that there are no comments.
2. In Admin side, open portlet Page: Overview. - Go to Tabs. Click on General. Go to Content Tab. Add the portlet created in step 1. - Go to Layout Tab. Set
Layout: Two Columns 50-50 In the Left column put only the portlet 'myhtml' In the Right column put the rest of the portlets. - Go to Properties Tab. Publist
the General Tab.
3. Logout. Log in. Observe the General Tab Layout. - Actual Result and Expected Result : You see Two Columns
4. In Admin side, Open the portlet created in step 1. Modify the code by adding a comment. The new code will be: Hello World!
5. In Admin side, open portlet Page: Overview. Go to Properties Tab. Publish the General Tab.
6. Logout. Log in. Observe the General Tab Layout. Expected Result : You see Two Columns.
Actual Results: You see One Column.
Workaround: Navigate to another page and come back to the Overview:General tab. The Layout now shows Two Columns as expected.

DE37511

Timesheet Review Portlet and Query issues

Major Problem

Timesheet Review portlet shows no data after you return from the Assignment Properties Page.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Put the OOTB Timesheet Review portlet in the Overview Page, General Tab.
2. Log in and go to Overview Page, General Tab to see the portlet. Portlet shows data. Example 700 rows.
2.1. Click on the Timesheet on any row. It goes the the Timesheet Page. Click on Cancel.
It navigates back to the Timesheet Review portlet. Portlet shows data. Example 700 rows. Works as expected.
2.2. click on the Task on any row. It goes the the Project Task Page. Click on Return.
It navigates back to the Timesheet Review portlet.Portlet shows data. Example 700 rows. Works as expected.
2.3. click on the Resource name on any row. It goes to the Project: xxx | Task: yyy - Assignment Properties Page. Click on Return.
It navigates back to the Timesheet Review portlet.
Expected Results: Portlet shows data. Example 700 rows.
Actual Results: the Timesheet Review portlet shows NO records
2.3.1. Click Filter or Show All.
Expected Results: Portlet shows data based on filters.
Actual Results: It will not respond. the Timesheet Review portlet shows NO records.
2.3.2. Refresh the Page.
Actual Results: It will not respond. the Timesheet Review portlet shows NO records.
2.3.3. Navigate to another page. Then go back to the Overview: General page.
Expected Results: Portlet shows data based on filters.
Actual Results: Portlet shows data. Example 700 rows. You must navigate to another page for the portlet to return to its original state.
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DE37517

Cannot set Attribute Partition code for Add Linked object on a process

Minor Problem

When we create a process and try to set Add Linked object, we cannot set and change Attribute Partition code.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create Partition Model.
2. Set partition model for cost plan object.
3. Add full view for the partition model.
4. Create a process. Define Primary object properties. Set the created partition for Partition field. Click Add Linked object and set.
Expected Results: We can set Attribute Partition code.
Actual Results: We cannot set Attribute Partition code. This is the problem. System is set for partition and we cannot change this on UI.
Workaround: The workaround is using XOG.

DE37541

Process is being triggered unexpectedly when start condition is not met

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Open a Project with tasks/milestones
2. Go to Tasks
3. Open in Scheduler - PPM Gantt
4. Click on Autoschedule with Publish
5. For example, create a process based on project object with starting condition ( Project Status != Project Status [Previous Value] )
6. Observe process gets triggered when condition was not met
Note: These steps are for 15.3. In 15.2 even without making any changes to the project when I click on Save, process is triggering (same process which was
built above in Step 5). It only seems to be happening on lookup type attributes when comparing to previous value in the process start condition.
Expected Results: Process should not trigger as start condition had not been met
Actual Results: Process is getting triggered when not expected by end user which could lead to wrong updates done to the project based on the processes
that are getting triggered.

DE37625
Cosmetic
Fixed in 15.4.0.0

Health Report showing invalid db object view COP_PROJECT_ROLLUP_V installed with PMO is no longer used
The Health Report is showing invalid objects in both the PPM Schema for the customer. Looks like database view was installed with PMO however the view is
no longer used - Health check is showing it as invalid and cannot be recompiled. Checked in previous version of PMO accelerator - COP_PROJECT_ROLLUP_V
is installed view, however does not look to be referenced anymore in queries.
Object was removed.

DE37656

CA PPM Jaspersoft Admin Command Throws Java Heap Space

Major Problem

Exporting a Jaspersoft content zip file larger than 1.0 GB results in a Java Heap Space error.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Have a tenant in Jaspersoft which is more than 1 GB, generate or upload large Excel, PDF, and other files if necessary to test.
2. Export the content using admin command. For example:
admin jaspersoft export -orgName cppm55X55_test -fromUserName superuser -fromPassword superuser -fileName C:\cppm55X55_test.zip -fromURL http:
//EXAMPLE:8787/reportservice -verbose
Expected Results: The export should be successful.
Actual Results: The export fails with Java Heap Space ERROR while writing the file to disk.

DE37663
Cosmetic
Fixed in 15.4.0.0

The amount of ETC is not automatically refreshed in the New UX after removing a resource from a task
In the PPM New UX, after removing a resource that was assigned to a task, the ETC for the task is not automatically refreshed. The page has to manually be
refreshed in order to have the ETC change reflected in the details pane. Clicking on other tabs of the pane does not trigger the update either. Only manually
refreshing the page displays the new ETC amount. This behavior does not appear to happen on PPM 15.2. The ETC amount reflected after updating the
assignment to a task appears to be inaccurate. The newly updated value should be displayed automatically.
STEPS TO REPRODUCE:
1. Log into the PPM New UX
2. Create a project and add two team members to it
3. Create a task in that project
4. Assign the two team members to that task
5. Update the ETC to 40 in the task
6. Remove 1 of the team members from the tasks, then navigate back to the task properties
Expected Results: The ETC should automatically be updated in the page to reflect the new amount after having removed that team member
Actual Results: The ETC amount displayed is not automatically updated and does not reflect the new amount. Additionally, the page has to be refreshed to
see the updated ETC.
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DE37708
Cosmetic

Power Filter Evaluated Expression shows incorrect String value
STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Log in to CA PPM.
2. Navigate to Administration --> Lookups.
3. Create a new static Lookup with below details and click Save and Continue.
Lookup Name : Test Lookup Lookup ID : test_lookup Content Source : Customer Source : Static List
4. In the next page, selelect below details & click "Save and Continue" Hidden Key : LOOKUP_ENUM Display Attribute : NAME
5. In the next page, create new list values making use of below details: i) First value: Lookup Value Name : Digital ID (LOOKUP_ENUM) : 1 ii) Second
value: Lookup Value Name : Credit ID (LOOKUP_ENUM) : 10 iii) Third value: Lookup Value Name : Business Energy ID (LOOKUP_ENUM) : 2 iv) Fourth
value: Lookup Value Name : aSolar ID (LOOKUP_ENUM) : 20
6. Create a new Dynamic Query Lookup with below details & click "Save and Continue" Lookup Name : Test Lookup Dynamic Query Lookup ID :
TestLookup_DynamicQuery Content Source : Customer Source : Dynamic Query (Do not select any Object)
7. Enter below query in Niku Query section & save and return SELECT @SELECT:probability.lookup_code:PROBABILITY_VALUE@
,@SELECT:Probability.
name:PROBABILITY_NAME@ FROM cmn_lookups_v probability WHERE probability.lookup_type = 'TEST_LOOKUP' AND probability.language_code =
@where:Param:language@ AND @FILTER@
8. Navigate to Administration --> Object --> Project
9. Navigate to Attributes tab and create a new attribute say "Test Power Filter" making use of the created Dynamic Lookup (Test Lookup Dynamic Query)
10. Naviaget to Home --> Projects
11. Expand the FILTER12. Click on [Build Power Filter]13. Select Object as "Project" & Field as the one what we have created i.e. "Test Power Filter"
14. Making use of the Browse icon , select "Digital" from the opened popup & click Add.
15. Click on Add and verify the "Evaluated Expression" & "Expression" values
Expected Results: "Expression" should show the right ID for the selected value & "Evaluated Expression" should show the ID corresponding value
for the Evaluated Expression = ( Project Test Power Filter = 'Digital' )Expression = ( project.test_power_filter == lookup("TESTLOOKUP_DYNAMICQUERY",
"1") )
Actual Results: "Expression" shows right ID, but the "Evaluated Expression" does not show the ID repective value.i.e. Evaluated Expression = ( Project Test
Power Filter = 'Credit' )Expression = ( project.test_power_filter == lookup("TESTLOOKUP_DYNAMICQUERY", "1") )Additional Details:Seems like the Evaluted
Expression is not honoring the IDs, instead it is displaying the value on alphabetic order.

DE37713
Cosmetic

Classic Portfolio Waterlines Weighted Ranking Rules Bug
Waterlines ranking is not working as expected when defined ranking rules use the default Yes|No lookup.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log in to Classic CA PPM.
2. Navigate to Administration --> Objects --> Project
3. Create a new lookup attribute say "Yes No" , making use of the OOTB Yes No lookup "PAC_RPT_YESNO"
4. Make this new attribute available in any section of the "Project Edit" view.
5. Create a new project say "Test 1" & save.
6. In Edit view of the Project , please select value "No" for newly added attribute and save the details.
7. Create another project say "Test 2" & save.
8. In Edit view of the Project , please select value "Yes" for newly added attribute and save the details.
9. Now, navigate to Administration --> Objects --> Portfolio Investment
10. Navigate to "Attribute Registry" tab and get the newly created attribute "Yes No" from Available Attributes to Selected attributes and save the details.
11. Navigate to Home --> Portfolios & create a new portfolio
12. Navigate to "Contents Editor" tab & add 2 projects (Test1 & Test2) under "Individual Investments" section.
13. Click on "Sync Now" and wait for that to get complete.
14. Navigate to "Waterlines" tab, we should see the 2 projects.
15. Click on "Define Ranking Rules" option
16. Let the "Primary Constraint" be "Planned Cost", but add the newly created attribute "Yes No" amking use of Add button.
17. Select "Ranking Method" as "Higher is Better".
18. Click on "Lookup Value Weighting" & have 0 weighting to "No" and 1 weighting to "Yes", and save the details.
19. Now, click on the "Run Ranking Rules"
Expected Results: We should see Test2 project first followed by Test1.
Actual Results: Ranking rules does not have any impact on the available projects. Whatever is the Ranking Method, the results do not get changed.

DE37718

In Chrome, when clicking on different attributes of URL type in same page, the new opened tab is overwritten

Minor Problem

When creating 2 new attributes of URL type in an object and adding these in the properties page, on clicking the first one a new tab is opened. On clicking the
second one, no new tab is opened, it overwrites the first opened tab. In IE 11, this is working correctly, each URL opens in a new tab.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. In Google Chrome browser, create 2 new attributes of URL type, with default value (any url address) and read-only.
2. Add these attr to the project properties view
3. Create a new project and go to properties.
4. Click on the first url attr, it opens a new tab in the browser and opens the url.
5. Click on the second url attribute.
Expected: A new tab to be opened for display of new URL.
Actual: It overwrites the tab opened in Step 4.

DE37731

Duplicate submission of Cost Plan (Budget Plan)

Minor Problem

When opening two separate windows in your browser with the cost plans open and click 'Submit Plan of Record for Approval' (in both windows) it causes for
two (2) cost plans to be in 'submitted' status.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a cost plan on a project.
2. Open the cost plan page into two separate windows/tabs.
3. Click the 'Submit Plan of Record for Approval' in both windows.
4. In both windows, rename the cost plans to Cost plan 1/Cost plan 2 and click submit in both windows
Expected Results: Only one cost plan should be in submitted status, the other should be denied as one has already been submitted (per documentation).
Actual Results: Both cost plans are put into the submitted status cause for 2 of the same cost plan to be in submitted status.
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DE37743
Cosmetic
Fixed in 15.4.0.0

Allocation field in Team Detail and Team Staff Should not be Editable
On the Team - Staff, and Team - Detail page, the "Allocation" field can be set to "Allow Editing", and the user can edit the field, but the change is not saved.
This is misleading, and has caused confusion to many users. The Allocation field should be made a READ-ONLY field in the GUI to prevent the users from
editing it, and to eventually learn that it cannot be changed.
STEPS TO REPRODUCE:
Method 1: Team - Staff page
In PPM, go to a project's Team tab which takes you to the Team Staff page.
Click on the Allocation field for a team member to attempt to edit their allocation
Expected Results: The Allocation field becomes editable and you are able to update the resource's allocation to a different a value
Actual Results: The field is read only, and you are unable to edit the allocation
Method 2: Team - Detail page
In PPM, go to a project's Team tab, and from the Team tab select Detail Click on the Allocation field for a team member to attempt to edit their allocation
Change the Allocation value and click Save.
Expected Results: The Allocation value is saved successfully
Actual Results: The Allocation value reverts back to the original value prior to edit

DE37749

Graphs missing from Investment Transaction Inquiry report after upgrade to 15.3

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Post to WIP
2. Run the Investment Transaction Inquiry report.
Expected Results: Graphs should appear.
Actual Results: Graphs do not appear after upgrade to 15.3

DE37750

Note Date value is missing from the prnotes after adjusting the posted timesheet

Minor Problem

When adjusting a timesheet the original Timesheet Note date field is removed from the note in the UI and the note field is nulled in the database. (CA
Support Note for Support Staff Only: See also CLRT-76972.)

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1.
2.
3.
4.
5.

Make sure you do not have New Timesheets Activated
Make sure you enable Note Date on Admin/Timesheet Options
Add a task and create a time entry level note and include the note date
Approve and Post timesheet
Adjust timesheet

Expected Results: Adjustment timesheet includes the Note Date with the existing Note
Actual Results: Adjustment timesheet shows the Note but the Note Date is blank. Also null in db.
Workarounds: Would have to write query to join the original timesheet note to the adjusted to pull data into a custom report.

DE37752

Jaspersoft Timesheet Detail Report Missing Sunday Hours - MS SQL Server

Major Problem

SQL Server version only of Timesheet Detail Report does not reflect hours posted on a Sunday.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
- Does not matter what the Project Management settings First Day of the Week or what day the time period start on
1. Make sure the resource you are using has a Department defined.
2. Post a timesheet with hours on at least a Sunday.
3. Run Load Data Warehouse job.
Expected Results: Sunday hours show on report.
Actual Results:

Sunday hours do not show on report. Same report works correctly in Oracle on 15.3.

Workarounds: None

DE37753

MSP New Driver, % Complete for summary task changes to 0% if child task has a resource assigned and % Complete is >0 but <100

Minor Problem

In MSP New Driver, % Complete for a summary task changes to 0% if the child task has a resource assigned and the % Complete is >0 and <100.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1) In MSP, create two tasks and make the first task a summary task to the second task
2) Assign a resource to the child task (task beneath the summary task)
3) Update the % Complete of the child task to 50%, which updates the % complete of the summary task to 50% (Issue does not happen if you change the %
Complete to 100%)
4) Save the project back to PPM (% Complete is correct in PPM at this step)
5) Export the project to MSP
Expected Results: Summary task % complete still shows as 50% which matches the child task
Actual Results: Summary task % Complete is 0% Note: If you save the project back to PPM, the % Complete of the summary task is then 0% there.
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DE37767

Jaspersoft OBS Resource Reports do not show Demand and Investments

Minor Problem

In 15.3 the Resource OBS reports do not retrieve demand when there are several layers of OBS.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
Only reproducible on customer dataset as I do not have system with many OBS units.
1. Run either report
-Capacity vs Demand by OBS
-Booking Status by OBS
2. Choose Resource OBS Type: Department OBS and Resource OBS Unit: MSU|IT
Expected Results: All Capacity and Demand show (and match the portlet)
Actual Results:

Demand is 0 for all months.

Workaround: Run at a lower level such as IT SERVICES ACADEMIC INFORMATION TECHNOLOGY and the Demand does show.

DE37785

Virtual Attributes are available to select in the Start Condition of a Process

Minor Problem

Virtual attributes are available to select in the Start Condition of a process. If a process on the task object is created using a virtual attribute on its start
condition, it then prevents them from using autoschedule. This also happens when an Aggregated Calculated Attribute is configured in a process condition.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
Using a Virtual Attribute on a SubObject: (create a virtual attribute on the task object (myVirtualattr referencing a field from the project object)
1. Create a new process.
2. Add the Task object as the Primary object
3. Select 'Auto- Start' as the Start Option
4. Select 'Update' for the Start Event and click Save
5. Click on the 'Set Condition' link
6. On the 'Start Condition Builder' page, select the Task object
7. Click on the Attribute Value drop down
Expected Results: Virtual Attributes should not be available to select in the process expression builder
Actual Results: Virtual Attribute are available to select.
Selecting such attributes and running the process causes issues in other areas of the project such as not being able to save Tasks or Task Assignments. Using
an Aggregated Calculated Attribute on a Master Object:
1. Create a new 'Aggregated' attribute on the Project Object (ACA1)
2. Create a new process definition
3. Add the Project object as the Primary Object
4. Select 'Auto-Start' as the Start Option
5. Select 'Update' for the Start Event and click 'Save'
6. Click on the 'Set Condition' link
7. On the 'Start Condition Builder' page, select the Project object
8. Click on the Attribute Value drop down
Expected Results: Aggregated Attributes should not be available to select in the process expression builder.
Actual Results Aggregated Attributes are available to select. Selecting such attributes causes issues in other areas of the project such as not being able to save
Team Member records.
Troubleshooting Notes: Using virtual attributes in start conditions is not supported and can cause issues in other areas, such as autoschedule. Update your
legacy Start Conditions to exclude virtual attributes; however, this change could lead to the process getting triggered to run more often. For example, you set
up processes to run when values on a task change, such as the task baseline finish date. After setting up this process, you may no longer be able to publish
their autoschedule tentative dates. If you attempt to do so, you might get a System Error. The UI and the logs indicate that the error message is due to the
process that you created. Even if you put the process on hold, you might still need to restart the services to get autoschedule working again, which requires
even more effort if you have to get this service restart scheduled with OnDemand.

DE37803
Cosmetic

PPMOP_15.3_DEFECT - GEL Script retains data from files that it read before
GEL script that uses "jelly:com.niku.union.gel.FileTagLibrary", retains data from files that it read before.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a text files called 1.txt with the following content: hello,world,1.1 hello,world,1.2 hello,world,1.3
2. Create a text files called 2.txt with the following content: hello,world,2.1 hello,world,2.2 hello,world,2.3
3. Create a text files called 3.txt with the following content: hello,world,3.1 hello,world,3.2 hello,world,3.3
4. Create a GEL script with the following content:
<gel:script xmlns:file="jelly:com.niku.union.gel.FileTagLibrary" xmlns:gel="jelly:com.niku.union.gel.GELTagLibrary" xmlns:core="jelly:core" > <core:
forEach items="1.txt, 2.txt, 3.txt" var="infile"> <file:readFile fileName="${infile}" delimiter="," var="infileParsed" embedded="false"/> <gel:out>Processing
file: ${infile}</gel:out> <core:forEach items="${infileParsed.rows}" var="row" indexVar="i" begin="1" step="1"> <gel:out>${row[0]}, ${row[1]}, ${row[2]}</gel:
out> </core:forEach> </core:forEach> </gel:script>
5. Run this GEL at the command prompt: gel -script
Expected Results: Each occurrence of "Processing file: " would show only the contents of that file following it.
Actual Results: Each occurrence of "Processing file: " would show contents of all previous files as well as itself.
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DE37806
Cosmetic

PPMSAAS_15.3_DEFECT - For any other locale other than English, the HRS bar does not get filled in New UI
STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Go to Account Settings.
2. Change Locale to German (Germany).
3. Navigate to the CA PPM New User Experience timesheets.
4. Go to Review and Approve tab.
5. Filter for Posted timesheets.
Expected Results: The HRS bar underneath the name of a resource is filled.
Actual Results: The HRS bar is not filled. The HRS bar gets filled when Locale is set to English. For all other Locales, it is not filled.

DE37841

Classic PPM - Unable to save Timesheet Note when Returning a Timesheet on a Popup

Major Problem

Unable to save Timesheet Note when Returning a Timesheet on a Popup. The 'Save and Return', and the 'Return' buttons are missing. This defect is found in
the 'Timesheet' portlet (Home > Timesheets). (Note: This is similar to DE35875 which affected the 'Timesheet Overview' portlet.)

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Go to Home -> Timesheets
2. Open the properties of an 'Open' timesheet
3. Add a task and enter hours on the timesheet
4. Submit the Timesheet for Approval
5. Log out of PPM
6. Log back in to PPM as a different user
7. Go to Home > Timesheets
8. Filter for Submitted Timesheets.
9. Click on the Timesheet icon next to the Submitted Timesheet from step 4
10. On the Timesheet portlet, click on the 'Return Timesheet' button.
Expected Results: The 'Add Timesheet Note' page is displayed, and you can enter a note and save.
Actual Results: The 'Add Timesheet Note' page is displayed, you can enter a note, but cannot save it. The 'Save and Return' or 'Return' buttons are missing.
Users are unable to enter a reason for returning a timesheet if the Timesheet properties open in a popup as configured. Without a note for returning the
timesheet, users would not know the reason why it was returned.
Workarounds: Use the Timesheet Overview portlet (fixed with DE35875) in 15.3.

DE37855
Cosmetic
Fixed in 15.4.0.0

Sending a reminder to all resources with Open Timesheets does not provide any confirmation
After sending a reminder to all resources with Open Timesheets when using the New UX, no notification confirmation is shown, but it is when a reminder is
sent to an individual resource.
STEPS TO REPRODUCE:
1* Open the New Timesheets UX
2* Go to "Review & Approve" section of Timesheets and show users with open timesheets
3. Click on the clock icon to remind one user -> a green notification confirmation message pops up at the top of the screen ("Reminder sent").
4. Click on the filter section's "Open", then on "Remind All"
Expected Results: Like with an individual notification, a green notification confirmation message pops up at the top of the screen ("Reminders sent").
Actual Results: No confirmation appears on the screen.

DE37879

Issue with fetching audited TSV attributes in Custom Object

Major Problem

Issue with fetching time sliced audited TSV attributes in Custom Object

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create an object
2. Create an attribute of the Data Type, "Time Varying"
3. Display the newly created attribute on the edit view of the object
4. Audit the attribute created in step 2 for Insertion and Update
5. Create a new instance of this object
6. Populate the attribute created in step 2 with data
7. Save
8. Change the data populated on step 6 and Save again
9. Make sure that the Audit of TSVs is being Time Sliced. (create 2 time slice definitions for OLD & NEW values as per TEC601945)
This query can be run on the DB to check this: select * from prj_blb_slicerequests where lower(request_name) like '%tsvaudit%' ;
10. Query the CMN_AUDITS_TSV and ODF_SL_AUD_OLD_VALUE tables for the attribute created in step 2
11. Make note of the result
12. Query the CMN_AUDITS_TSV and ODF_SL_AUD_NEW_VALUE tables for the attribute created in step 2
13. Make note of the result
Expected Results: Result sets from steps 11 and 13 do not match. Result set in step 11 should have a lag with respect to time against result set in step 13.
Actual Results: Result sets from steps 11 and 13 match. No differentiation is being made between the Old and the New TSV values.

June 6, 2018 | Downloaded from docops.ca.com

page 36

Fixed in 15.4.0.0 | Resolved Defects

DE37990

MAX_FETCH_LIMIT governor can be overridden in WSDL Query calls, producing incorrect slice totals and results

Major Problem

MAX_FETCH_LIMIT governor can be overridden in WSDL Query calls, producing incorrect slice totals and results. Bypassing this governor limit also permits a
single user action to create a java.lang.OutOfMemoryError condition to bring down the application service.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a Studio query called 'nolimit' with the following content on an Oracle PPM system. Oracle is required due to the vendor-specific query content, the
defect itself is generic. It dynamically generates a guaranteed > 50k rows from the database (actually about 73k) without needing the physical data created.
select @SELECT:DIM:USER_DEF:IMPLIED:cal:rowkey:rowkey@,@SELECT:DIM_PROP:USER_DEF:IMPLIED:cal:dt:dt@from (select rownum as rowkey,
trunc (sysdate,'YEAR') + level -1 as dtfrom dualconnect by level <= (trunc (sysdate,'YEAR')+interval '1' year - (trunc (sysdate,'YEAR') - (365*199) )))
dategenWHERE @FILTER@
2. Login to the XOG client and set an output file for the results.
3. Create a XOG input file with the following content:nolimit
4. Call the XOG input file and check the results.
Expected Results: The output file will correctly contain 50k results (per the governor limit) and state in the Slice section the true Total (e.g. 73000) but a Size
value matching the quantity fetched of 50000
Actual Results: The output will correctly contain 50k results, but the Total and Size fields of the slice section will both show 73000, making it appear that all
results are included
5. Create a XOG input file with the following content:
nolimit
0
55000
6. Call the XOG input file and check the results.
Expected Results: The output file should contain 50k results (per the governor limit) and state in the Slice section the true Total (e.g. 73000) but a Size value
matching the quantity fetched up to the governor limit of 50000
Actual Results: The output will contain 55k results instead of 50k, the Slice field Total will correctly show 73k, but the Size field will also show 55k results
instead of 50k (note: 55k is 'correct' for this response but since the response is wrong, both the number of records and this flag field are incorrect).

DE38034

No audit trail for attributes in the pac_mnt_projects table when project created via XOG using a template

Minor Problem

There is an issue with the Project XOG using Template and it seems to be a defect. We noticed that the "Financial Status" and "Department" were NOT
appearing on the Project Audit page if these fields were updated. The Project Object has the Audit turned on these fields and it is working fine for most of the
other projects in the system. We found that the audit trigger on PAC_MNT_PROJECTS was NOT inserting records into CMN_AUDITS table for this project
because the column ODF_OBJECT_CODE in PAC_MNT_PROJECTS was NULL while ideally this column should be 'project'. We confirmed that this project was
created through XOG using template (XOG xml had fromTemplate to point to a template). We verified other such projects and the result was same. The
ODF_OBJECT_CODE in PAC_MNT_PROJECTS remains NULL in a project if the project is created via XOG using a template reference in XML.

Fixed in 15.4.0.0

The issue doesn't happen when 1) Project is created via Front end without using template
2) Project is created via Front end using template
3) Project is created via XOG without using template The issue happens only when project is created via XOG using a template.

STEPS TO REPRODUCE:
1. Turn on audit trail for department and financial status attribute by going into Administration->Objects>Project.
NOTE: You may use any attributes that are stored in the PAC_MNT_PROJECTS table.
2. XOG in a prj_projects_from_template_write.xml file using XOG client.
3. Confirm project was created successfully by going into Home->Projects
4. Try to update values for Financial Status and Department attributes by going into project properties and choosing Settings
5. Click on Audit Trail tab and see that no activities are available to see for above mentioned attributes
6. Run the following query on the database: select * from pac_mnt_prjojects where odf_object_code is null order by created_date desc
Notice that this field is blank for the project you just created. This attribute should match the odf_object_code in the inv_investments table
Expected Results: able to see audit trail activities
Actual Results: not able to see audit trail activities
WORKAROUND: Run the following query to fix this problem. Then rerun the query whenever new projects are xogged in. Update pac_mnt_projects set
odf_object_code = 'project'

DE38046

Clarity dependency libraries Security Scanning Issues in 15.2 - New

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0

DE38058

XXE Vulnerability in XOG

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0

DE38059

SQL Injection

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0

DE38073

SSL Password is not encrypted

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0

DE38088

Jackson JSON Library vulnerabilities

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0
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DE38095

Changing the Charge Code ID Allowed

Minor Problem

In 15.3, the Charge Code ID can be changed even after it has been used in Cost Plan or WIP, causing issues with WIP showing on the cost plan. I believe this is
only for new charge code values and not for existing that were upgraded and already in use.

Fixed in 15.4.0.0

Steps to Reproduce:
1. Create a new Charge Code under Administration / Project Management => Charge Codes
2. Create or use a Financially Enabled Project with Financial Status = Open
3. Add the charge code you created to the Project Properties so you can create a cost plan from team.
- Or add the charge code to a task if you want to populate from assignments
4. Add Financially Enabled resource
5. Make sure they have some allocation amount
6. Create a cost plan by Populate from Team - Group by Resource and Charge Code
7. Verify the cost plan looks ok.8. Create a transaction for the project and resource - Use the same charge code
9. Post transaction to WIP
10. Verify the transaction shows on the cost plan as Actual Cost (may need to add field to cost plan details columns.)
11. Go to the Charge Code under Administration
12. Change the ID and click save
Expected Results: Error message: TMA-0200: Charge code ID cannot be changed because it is referenced by one or more records.
Actual Results: Allows you to save it. Once the ID is changed the actual amount is removed from the Cost Plan as now WIP has a different ID than the current
Charge Code in the cost plan.

DE38135

Redirection Failure due to Jsessionid in URL in 15.3 PPM

Major Problem

Unable to log in after upgrading to Clarity 15.3 due to HTTP 404 error in web browser. Redirection to PPM fails after SSO authentication when the browser is
opened for the first time. The issue is not seen when the browser is already opened before authentication of user.

Fixed in 15.4.0.0

After authenticating on Portal the user will be redirected to Portal with a HTTP 302 request from Portal. The JSESSION info is embedded in the URL when the
browser is opened for the first time. The issue is occurring only with PPM version 15.3.
STEPS TO REPRODUCE:
1. Make sure browser is not opened.
2. Authenticate to Clarity (running 15.3 version) via SSO with following Relaystate.
https://cppmxxxx.ondemand.ca.com/niku/app
3. Forbidden error message is displayed after successful SSO authentication.
4. The URL shows the presence of JSESSIONID https://cppmu221-dev.ondemand.ca.com/niku/app;jsessionid=D16EE4350C18985BA0490366F980A4D3
5. Manually remove the JESSIONID from URL and refresh the page. The result is the PPM page is displayed properly.
Expected Results: User is prompted login screen.
Actual Results: Browser is displaying error with a HTTP 404; insertion of the JSESSIONID in the URL

DE38136

'Click Here' link to task properties issue in notification doesn't work; 'System error. Contact system administrator'

Minor Problem

Link to task properties issue in notifications: CA PPM does not correctly generate a link to Task properties in Notification.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a process
2. Add Task object:
3. Start Options -> On Demand:
4. Setup Start step to send modifications:
5. Click on Process – Completed process step
6. Add link to Body of notification using binoculars:
7. You should see the link in the body like below:
8. Click save and return and validate the process:
9. Create an action item in Task Object:
10. Add Action to Task Properties Action menu list:
11. Launch Action from Task properties:
12. Email is received:
13. When we click on the link error appears:
14. We see that CA PPM generated link with wrong projectId parameter. Project Name is used instead of internal ID:
Expected Results: To click the Click Here link.
Actual Results: “! ERROR: System error. Contact system administrator.” (The project name, and not the project ID, is shown in the URL.)

DE38148

Performance of Load Data Warehouse Job is slow on large environments due to missing index on few tables

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Login to PPM and run the Load Data Warehouse job - either incremental or full load
2. Run the SQL Optimzer and you will see it will suggest few index
Expected Results: With the index in the system the job runs faster, the benchmark we have seen is on large system the job used to take 5 hour 45 minutes
without index and with the mentioned index it takes 5 hour 25 minutes
Actual Results: Slowness in the Load Data Warehouse job

DE38186

SQL Injection in the My Projects portlet

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0
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DE38190

Report and Jobs: Scheduling a report to return XLSX output reverts the saved scheduled report format to PDF (default)

Minor Problem

In Report and Jobs- When scheduling any report to return output type as XLSX the report format reverts back to PDF (default)- The scheduled reports format
should be the one which is selected by end-user- This happens for Schedule the report and Save the parameters to share the output with other resources.

Fixed in 15.4.0.0

Steps to Reproduce:
1) Login to Clarity
2) Navigate to Reports and Jobs
3) Schedule any report with Format as XLSX
4) Open that scheduled report5) Report format reverts back to PDF (default)
Expected results: In Reports and Jobs the saved scheduled report's format should be the one which is selected by end-user
Actual Results: When scheduling any report the format reverts back to PDF (default)

DE38191

Incident-Email notifications

Minor Problem

When updating incident status to Resolved notification is not getting generated.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Navigate to Home->Demand Management->Incidents
2. Click New to create new Incident and click on Save and Return
3. While in the List View change Status to Resolved and click Save
4. It should generate notification and email should be sent
5. Click on Organizer and observe that no notification has been generated and obviously email has not been sent.
(Note that when Status is changed form the Incident properties page, notification is getting generated properly.)
Expected Results: Notification should get generated when status is updated to Resolved and email should be sent.
Actual Results: Notification is not generated when status is updated to Resolved and email not sent.

DE38210

Orphan slice records remain in internal slice table PRJ_BLB_SLICES_M_ETC after removing team member from OWB

Minor Problem

Removing team members from OWB leaves orphan slices behind.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a project and note the project ID from the URL, eg: 5004000
2. Add a team member to the project so the Effort task is created and ETC populated.
3. Run this query against the DB select * from PRJ_BLB_SLICES_M_ETC where investment_id = 5004000
4. This returns row of data.
5. Remove the team member and re-run the query
6. The slice data has been removed as expected.
7. Add another team member and re-run the query in step 3
8. Slice data is populated
9. Open the project in OWB 10. Delete the resource from the project plan
11. Save back to PPM
12. The team member is not present on the project in PPM
13. Re-run the query
Expected Results: The slice data to be removed too
Actual Results: The slice data is still present, leaving orphan entries behind

DE38273

Start_Period and Finish_Period of Cost Plan list page show Time Periods of all Entities

Minor Problem

In ppm15.2, ppm15.3, Start_Period and Finish_Period of Cost Plan list page show Time Periods of all Entities. In ppm14.2, Start_Period and Finish_Period of
Cost Plan list page show only Time Periods of related Entity. Customer upgraded from ppm14.2 to ppm15.2 and encountered this problem. It is replicated in
ppm15.3.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Define two Entities. (ex, Entity01 and Entity02)
2. Define Time Periods. (ex Monthly time periods between 2017/04/01 - 2018/03/31 for each Entities.)
3. Create Cost Plan in project which is related Entity01.
4. In Cost Plan list page, click Start_Period, Time Periods of Entity01 and Entity02 are displayed.
5. Start_Period and Finish_Period in Cost Plan properties page shows correct Periods data which are related to Entity.
Expected Results: Time Periods of related Entity should be displayed.
Actual Results: Time Periods of all Entities are displayed.
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DE38304

Unable to save changes made in the Chargebacks section of a Project

Major Problem

After upgrade from PPM 14.3 to 15.3, non-admin users can no longer make changes and save them on the Chargebacks section of a Project. When trying to
do so, the below error message is shown to the user: "Error 401 - Unauthorized. You are not authorized to view the page. If you are sure you have access, try
logging in again or contact your system administrator."

Fixed in 15.4.0.0

For whatever reason, after assigning the access right "Financial Maintenance - Financial Organizational Structure" is needed to be able to successfully make
and save those changes. This was not needed in 14.3. The root cause of this appears to be the same one as mentioned in DE29606. Providing the access right
mentioned above resolves the problem, but it should not be needed as that access right is meant for financial management from the Administrative side, not
an end-user project manager perspective, where that right should not be needed for normal non-adminstrative functions.
STEPS TO REPRODUCE:
1. Create a project or navigate to an existing one with a normal project manager type user (meaning they do not have the right "Financial Maintenance Financial Organizational Structure")
2. In the project, click on the Chargebacks tab and select Options from the dropdown menu
3. Choose a value for the Chargeback Type and for the Bill Expense Type
4. Click on the Save button
Expected Results: The changes are saved without an error.
Actual Results: Saving the changes results in "Error 401 - Unauthorized. You are not authorized to view the page. If you are sure you have access, try logging
in again or contact your system administrator." No specific error message is recorded in the app-ca logs indicating what is causing the save error.
Workarounds: Granting the Financial Maintenance - Financial Organizational Structure access right to the user allowed them to save the change. This did not
give them access to the Administration menu.

DE38309

501 Error when removing a resource from an action item

Minor Problem

Error appears when removing a resource manager from an action item.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1: Navigate to Home -> Organizer -> Action Items.
2: Click on Action Item Name Link
3: Select the resource name and click on remove button under Assignees
4: Click on Return button
Expected Results: It should return to the action items page without an issue.
Actual Results: Error 501 - Not Implemented. The server does not support the requested feature. Contact your system administrator.

DE38372

Action Items generated from Task object process errors when user clicks on Task name in the Object links

Major Problem

When a Task object process with an action item is generated, the action item contains a link to a task. Clicking on the link after receiving the action item
results in an error:[en - Unable to process request - Server or Network error]

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a simple Task Object process a Start and Finish steps (Start Step => Finish Step)
2. Set the Start Option to be 'On Demand'.
3. Create an Action in the 'Start' step based on Action Type => 'Manual Action'
4. For the 'Actions' Select 'Approved' and 'Rejected' fields.
5. In the Subject field, select Task 'Name'
6. For 'Assignees', select the users you are currently logged in as from the 'Resource' tab.
7. Click on 'Save and Return' button to come out of the page then specify the 'Finish' to complete and Validate/Activate process
8. In the Task object, create a new 'Action' from the 'Actions' tab which is of Type => 'Process' and select the process created in the Steps above.
9. From the 'Views' tab, click on 'Actions Menu' for the 'Task List' then click on 'General' link and the Action created in step 8 above to the 'Selected Actions'
section. Click on 'Save And Return' button.
10. From CA PPM project list page, open a project => Task list page. Select a Task by clicking on a checkbox then from the 'Actions' dropdown menu click on
the Action created in step 8. Process is launched and executed
11. Navigate to CA PPM Home => Organizer page to view the Action Item. Click on Action Item to open then the 'Objects' link.
Expected Results: Task to open successfully
Actual Results: Error message is generated as follows: 'en - Unable to process request - Server or Network error'

DE38373

Annual Plans show incorrect amount in the Financial Forecast Review by Investment Report

Major Problem

Annual Plans show incorrect amount in the Financial Forecast Review by Investment Report. Similar to CLRT-80605 which addressed the Project Storyboard
Report. That report does appear to be correct. When you break the annual plan to monthly in the cost plan and then add up the individual months the total
matches the Financial Forecast Review by Investment Report.

Fixed in 15.4.0.0

Steps to Reproduce:
1. Make sure your DW Entity has annual plan periods defined and active
2. Use a project that is associated to that Entity
3. Create an Annual Type cost plan
a. Make the Annual Amount = $1,000,000
b. Change TSV to month and observe the monthly amounts
c. Change the TSV back to Annual
4. Make sure the Time Slicing job runs
5. Run Load DW Job in Full mode
Expected Results: Planned Amount on Financial Forecast Review by Investment Report shows 1,000,000
Actual Results: Planned Amount on Financial Forecast Review by Investment Report shows 1,000,000.02 (for 2017). For FY 2018 it shows 1,000,000.04.
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DE38383

Current timesheet displays timesheet for last week due to 17-hour difference

Minor Problem

Current timesheet displays the timesheet for last week due to 17-hour time difference.

Fixed in 15.4.0.0

A Japanese user has 17 hours difference between the server time (PST) and login user time (JST). When we try to log in to PPM on Monday (JST) and click
Current Timesheet icon, we see the timesheet for last week because the server time still shows Sunday time. This happens when the login user date is Monday
but the server date is Sunday. We should see the timesheet for this week because login user date is Monday.
STEPS TO REPRODUCE:
1. Configure a CA PPM environment to match the user scenario given in the description.
2. Log in PPM and click Current Timesheet icon. For example, log in on Monday, January 8, 2018.
Expected Results: I should see the timesheet for this week (1/1 - 1/7) because date is 2018/01/08 (Mon).
Actual Results: The timesheet for the last week (12/25 - 12/31) appears.
Workaround: Manually select the current timesheet.

DE38418

System Restricted Lookup value is editable and could be activated or deactivated from Administration

Minor Problem

Values of system restricted static lookup, could be activated/deactivated from the lookup definition, under studio; however, the deactivated values are still
observed, wherever these lookups are referenced. The expectation is that the system restricted lookup values should not be editable in terms of
activation/deactivation.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log in to PPM and navigate to Administration >> Data Administration >> Lookups.
2. Filter for a system restricted lookup, for example - Report Output Types
3. Navigate to the values tab, select any of the available value, for example, PDF, uncheck the Active check box and click on save and return
4. Navigate to the attribute where this lookup is in use and check for the lookup value list
Expected Results: The value which was deactivated in the static system restricted lookup, should not be visible. User should not be able to edit system
restricted lookup and activate/deactivate values. Although the system does not honor such changes, this could create confusion among end users, for whom
such options are available.
Actual Results: The deactivated value is visible in the lookup list; however, the above changes are not applied.

DE38482

XSS Issue in PPM on gridExcelExport action

Major Problem

This security issue has been resolved.

Fixed in 15.4.0.0

DE38499

SCR Finding - Medium - XML External Entity (Continuation of Bug DE38058)

Minor Problem

This security issue has been resolved.

Fixed in 15.4.0.0

DE38554

Unable to open field property in Filter Portlet if the default value has an "&" symbol

Major Problem

If the default value of a lookup type field has an "&" symbol - customer is unable to open it later and make changes. The "&" symbol in the lookup value
name is causing issues. We have had previous issues with special characters in the OBS field, but the "&" was not in the list of special characters that were not
allowed as documented below: https://support.ca.com/us/knowledge-base-articles.TEC602263.html

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a static lookup "Test Lookup MQ" Add Values to this lookup as follows: Value1 value1 Value 2 value2 Value 4 & 5 value45
2. Create a portlet of type "Filter Portlet" named say "Test Portlet" and Save it Content Souce : Customer Category: Project Instance Type: General
3. Click on Fields
4. Add a new Field "Test Field MQ" Data Type: Lookup In the Lookup box Select the lookup created in step1 "Test Lookup MQ"
5. Click on Save not Save and Return
6. On the same Field page select Filter Default as "Value 4 & 5" and click on save
7. The page refreshes and I get an error - (at this step customer who is on 14.4. does not get an error and is able to save the value.)
8. Close the error and go back to Clarity
9. Go back to "Test Portlet" and go to Fields and click on "Test Field MQ"
Expected Results: The Test Field MQ Field properties page should open up
Actual Results: You get an error "Unable to Process request". If you remove the "&" symbol from the Lookup value which is set as the default value on the
field and go back to open the field properties - it opens up just fine.
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DE38593

Numeric overflow in sequence CMN_SEC_USER_GROUPS_S1

Minor Problem

If the Sequence CMN_SEC_USER_GROUPS_S1 exceeds the maximum positive value for a 32-bit signed binary integer (2,147,483,647), it is not possible to
create new projects. The database error received is: java.sql.SQLException: [CA Clarity][Oracle JDBC Driver]Numeric overflow.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. In a design concept, think about a CA PPM system with 2000 projects, each one having a group for users (so there are 2000 groups).
2. With 2000 users who participate in multiple projects, in total, there are 2000 x 2000 x 2000 possibilities to assign - theoretically this would be 8,000,000,000.
3. This number seems to increase with every assignment to a group on at least the number of rights which are in this group. So if a group shares 20 rights to a
user, every user who is included to this group increases the sequence to at least another 20 numbers per assignment to a group.
4. Imagine this system exists for 10 - 15 years and assignments are updated regularly at least on a daily basis. This happened on a "normal" ppm application,
which exists for several years now.
Expected Results: The sequence to increment correctly
Actual Results: The sequence throws a numeric overflow error; this error seems to originate in META-INF/dms/pmd/dmsPMD.xml . The p_id is used for insert
of the id field of the CMN_SEC_USER_GROUPS table.
Workaround: This error was resolved manually by enlarging this sequence to long datatype, by changing in dmsPMD.xml:
direction="OUT" defaultValue="0"to param name="p_id" type="long" direction="OUT" defaultValue="0"

param name="p_id" type="int"

DE38600

Type “\-->” in Project Description field, click save, it changes to this ".....\\\\\\\\\\\\\\-->'

Minor Problem

If you create a project with special characters in the description these character gets transformed. After several savings the description text field is grown to a
critical size. See: https://support.ca.com/us/knowledge-base-articles.TEC1082026.html

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a new project. Home > Portfolio Management > projects and click New.
2. Create a new project with the description text which contains the following characters “\-->”
3. Click Save.
4. The project is saved and the description text is escaped.
5. Change the finish date to the next day and press save, or you don’t have to change the Finish date, you can just click on the ‘Save’ button again.
6. The description gets escaped a second time. The size of the text in in the text field grows.
7. Repeat step 5 till the value in description field is too large.
Expected Results: It should be possible to change a project and the description does not get escaped each time it is saved.
Actual Results: The description gets longer until the description field is too large to display. It ends up showing something like this:\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\
\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\-->

DE38627

Autostart Process autostart does not trigger on using xog

Minor Problem

In a system, we have a xog process for inserting and updating timesheets. After create or update, a process is to be auto started. The timesheets are created
and updated correctly but there is no process started although the conditions are met. On creating/updating the timesheet manually through the UI, the
process is started correctly.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Take the prj_timeperiod_read.xml to xog out an existing timesheet of a resource
2. Modify the output xml: add some hours for a new period in order to create a new timesheet. Follow the steps in TEC4386983.
3. Create in UI a process with auto start condition for create and update: ("Timesheet Status = 'Open')
4. Xog in the modified xml
Expected Results: The timesheet to be created and the autostart process to be triggered
Actual Results: The timesheet is created but the autostart process is not triggered

DE38763

PPMOP_15.3_Defect Forgot Password Functionality CASE Sensitive

Major Problem

The new UX "Forgot Password" functionality requires the exact case of the username in the field, to receive an email. If you don't you won't receive an email.
Classic PPM doesn't require you to match the case of the username. If I click on the "Forgot Password" link and put in the userid of abC, instead of abc, I won't
receive an email to reset the password. However, I can log into the solution successfully with abC.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a Username that has mixed case.
2. Log into the solution with username in all lower case >> will be successful.
3. Logout.
4. Click the link to log in again.
5. Click "Forgot Password"
6. In the username field, enter all lower case.
7. Will not get a reset password email.
Expected Results: Login and Forgot Password should work the same way (non-case-sensitive)
Actual Results: Forgot Login Functionality is case sensitive. If a user doesn't realize that their username is mixed case they won't get an email to change their
password.
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DE38767

Values not showing for multi-valued attribute lookups on list views

Minor Problem

In the event of a problem with a lookup definition in use by a multi-valued attribute, it may result in the values for that and/or other multi-valued lookups
based attributes to disappear from the display on the object's list view. Unless you know which logger to enable at the right level, instrumentation does not
help identify the issue (at which point you wouldn't need instrumentation anymore as you already know the problem).

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create two multi-value lookup based attributes on the Project object. You can use any static list lookup with a few simple values to select from.
2. Invalidate the lookup_type reference for just the first of these two attributes that was created.
Note: although it's not the way the problem occurs in the wild, for the purposes of this STR this will work to recreate the scenario that can occur. I would
suggest updating odf_custom_attributes and setting lookup_type value to something that does not actually exist, like 'bad_lookup_type' or similar.
3. Add the second attribute to the project list view and publish it.
4. Attempt to browse in the list view for any existing project some new values to store against the 2nd attribute and save the selection.
5. Refresh or revisit the project list view at any time.
Expected Results: The saved values for the 2nd attribute should be displayed as chosen and saved.
Actual Results: No values are shown (although they did save if the database is checked), and no errors are reported for this page/action.

DE38788

Performance issue with Advanced reporting after upgrading to Oracle 12c

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Log in to CA PPM.
2. Navigate to Advanced reporting and run below reports:
Project Status Report V1
Project Status Report V2
Project Summary Report
Project KPI Report
Gantt Summary Report
Expected Results: All the Reports should fetch the results in less than a minute
Actual Results: Critical reports generation is taking time. 1- Project Status Report V1 and Project Status Report V2: These two reports are having the Project
Name as a multi-select filter. The report is working fine only when we are selecting one project in this filter. In case when we select 2 or more projects, the
report is taking around 20 - 25 mins to come up. 2- This issue is common across all other Project related Reports(Project Status Report V1 & V2, Project
Summary Report, Prject KPI Report): Here the reports work fine if we select a project from Project Name filter but when we select other filters like OBS Name,
the reports again takes around 15 mins to come up. 3- Portfolio Summary Report: The performance of this report at the time of creating this CASUP seems to
be OK, but it is also having the performance issues frequently.

DE38839

Incorrect Format Dates in notifications

Minor Problem

Date Format for all Notifications does not honor Resource Local under account settings.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1) Navigate to Home > Account Settings and set Locale to English (United Kingdom)
2) Create a new Action Item Then go to Home > Organizer > Action Item tab a
3) Select a Due Date, check the attribute “Notify Assignees” and assign the Action Item to yourself
4) Go to Home -> Organizer -> Notifications
Expected Results: A notification is received with the 'Due Date' format displayed according to the User’s locale = English (United Kingdom)
Actual Results: Notification is received with an English locale (US date format).

DE38856

XOG object write may select the wrong lookup value or permit an invalid lookup value to be saved

Major Problem

STEPS TO REPRODUCE:
Steps are provided using a query that is Oracle specific but using an MSSQL variant of the query causes the same issue.

Fixed in 15.4.0.0

1. Create an NSQL based lookup called 'rtest' with the following contrived SQL to force the issues to occur consistently without organic data creation steps:
select@SELECT:cc.CODE:code@,@SELECT:cc.NAME || '(' || cc.code || ')':name@from(select 'abcdef' as code, '1st' as name from dualunion allselect 'abc' as code,
'2nd' as name from dualunion allselect 'fabcde' as code, '3rd' as name from dualunion allselect 'ab' as code, '4th' as name from dual)ccWHERE@FILTER@
Note: Column 2 is sorted alphabetically, Column 1 is deliberately out of the sort order (as might be the case if querying from a table of data rows).
2. Set the Hidden Key to 'code' and the Display Attribute to 'name'
3. On the Browse window tab set the Default Sorting Column to 'name' and Default Sort Order 'Ascending'
4. Create an attribute on the Resource object called 'rtest' that uses this lookup 'rtest'
5. Perform a basic XOG user write for 'admin' supplying the value 'abc' for the rtest attribute, for example,
resourceId="admin" resourceType="LABOR" username="admin">
abc
NIKU.ROOT
Expected Results: If using PPM 15.1 you expect that the attribute should be set to "abc" and show "2nd (abc)" in the PPM UI
Actual Results: If using PPM 15.1 the attribute is set to "abcdef" and shows "1st (abcdef)" in the PPM UI
6. Perform a basic XOG user write for 'admin' supplying the value 'z' for the test attribute, e.g.:
resourceId="admin" resourceType="LABOR" username="admin">
z
NIKU.ROOT
7. Observe that the XOG output file states that the lookup value is invalid and does not change the attribute value.
8. Perform a basic XOG user write for 'admin' supplying the value 'a' for the test attribute, e.g.:
resourceId="admin" resourceType="LABOR" username="admin">
a
NIKU.ROOT
Expected results: In 15.3 this should also reject the attribute value in the XOG output and state that it is invalid.
Actual results: In 15.3 it stores "a" to the custom attribute on the object, shows no problem in the XOG output, and appears blank in the PPM UI.
Queries/reports written expecting to join the value of this attribute (if not null) to another table will result in the resource record being excluded from the
results due to no matching join.
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DE38910

HTML portlets containing "-->" break page layout after login

Minor Problem

If an HTML portlet that contains "-->" in the source is displayed as a top portlet with other portlets, the page layout is broken and all the portlets are
displayed inside this one. A page refresh is necessary every time after logout to display the correct layout.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1* Create a new HTML Portlet with the following code:
<!DOCTYPE html><html>
<head>
<title>Basic Web Page</title>
</head>
<body>
Hello World! --> Goodbye :(
</body>
</html>

2* Add the portlet in the Overview page (Overview -> Manage my Tabs -> Content -> Add -> [html portlet])
3* Make sure that there are additional portlets as well.
4* Go to Layout tab, and use any multi-column layout (e.g.: Two Column 66-34), and in the first column, add the HTML portlet as the topmost portlet, and
some other portlets below. Right column should have content, too.
5* Log out. This is important.
6* Log in and open the Overview page.
Expected Results: Layout for the Overview page is as configured in the page Layout tab.
Actual Results: Layout for the Overview page is "broken", all the portlets appear inside the HTML portlet.
Workaround: Refreshing the page will temporarily correct the layout issue.

DE38947

Attribute Defaults not working with New UI is the attribute is not visible in New UI in the project

Minor Problem

We have defaulted the Status field to always be Approved. When we create a project in the New UI and then look at it in Classic PPM this field always shows
Unapproved. But if we were to create this project in Classic PPM then the Status field shows Approved (like we have it defaulted to do).

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Log in to CA PPM (Classic) and click Administration, Studio to open the following objects and attributes:
Object: Project. Attribute: Status Set Default: Approved
Add Attribute Status in the Layout:Create view
and in Layout:Edit In View: Project Properties - Property Field be sure you don't have Override Default
2. Create a Template. Verify Status=Approved
3. Create a new project from that template in Classic PPM. Status field shows Approved (like we have it defaulted to do). = In the new UI
4. Create a New Project from that Template. Notice that you don't see 'Status' in the new UI. That is one of the attributes that you can not add, it was not an
option to select it. Attribut Status has 'API Attribute ID' grayed out.
5. Open the Project created in new UI in classic PPM. Check 'Status'
Expected Results: The projects Status should be Approved
Actual Results: The projects shows Status Unapproved.
NOTE: Defaults works fine for attributes that you can add/see in the project in the new UI.

DE39007

Cannot Create New Task in NEW UI when Task ID is Auto-Extended

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.0.0

1. Administration > Objects > Search ‘Project’ > Click on ‘Attributes’ tab > Select ‘Investment ID’
2. Click on ‘Auto-Numbering’ tab > Tick ‘Auto-Numbered> Create a new scheme > Click on [Edit]
3. Click on ‘Numeric Counter’ > Set the counter length to ‘17’ >Tick ‘Auto–extended’ > Save and Return
4. Administration > Objects > search ‘Task’ > Click on Attribute tab > Select ‘ID’
5. Click on ‘Auto- numbering’ tab > Tick ‘Auto-Numbered’ > Create a new scheme > Click on [Edit]
6. Click New button Type of Segment: Parent Object Attribute Reference Referenced Object: Investment Referenced Attribute: Investment ID Segment Max
Length: 6
7. Save and Return
8. Click on ‘Numeric Counter’ > Set the counter length to ‘10’ > Ensure ‘Auto–extended’ > Save and Return
9. Home > Portfolio Management > Click Project > Create a New Project
10. Add a resource
11. Click on Task tab > Create a New Task > Save and Return
12. Navigate to NEW UI > Select on the project created in Classic view
13. Click on Task
14. Create a New Task
Expected Results: New Task is created.
Actual Results: Error ‘ID’ is too large. Maximum size is 16 is displayed It seems task ID is not auto extending when the limit is reached in the NEW UI.

DE39080

PARENT_SKILL_ID in RSM_SKILLS table remains unchanged when skills updated via XOG

Major Problem

The PARENT_SKILL_ID in RSM_SKILLS table remains unchanged on xogging of skills.

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Create a Skill Named "Parent Skill 1".
2. Create a Skill Named "Child Skill".
3. Make the Parent Skill of the "Child Skill" as "Parent Skill 1"
4. Create a Skill Named "Parent Skill 2"
5. XOG out the "Child Skill" and update the Parent as below,
6. In the UI, the Parent Skill of "Child Skill" becomes "Parent Skill 2"
7. In the RSM_SKILLS table the "SKILL_PATH" and "PARENT_SKILL_PATH" gets updated.
8. But, the "PARENT_SKILL_ID" is not updated and still contains the ID for Parent Skill 1.
Expected Results: PARENT_SKILL_ID in the rsm_skills table is updated to the Id for Parent Skill 2.
Actual Results: PARENT_SKILL_ID in the rsm_skills table is not updated and still contains the ID for Parent Skill 1PARENT_SKILL_ID in the rsm_skills table is
updated to the Id for Parent Skill 2 when Child Skill is updated via the CA PPM UI.
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DE39199
Cosmetic

Roles are Open for Time Entry
Roles are created with Open for Time Entry and Track Mode=PPM if these attributes have default values on the Resource Object.

Fixed in 15.4.0.0

Steps to Reproduce:
1. Resource Object Attributes set attributes as follows: - Open for Time Entry - check the default boolean - Track Mode = PPM
2. The create a new Labor Role
3. Add the Open for Time Entry and Track Mode attributes to the resource list page.
Expected Results: Role is not Open for Time Entry and Track Mode = None.
(Note: These fields cannot be edited for Roles.)
Actual Results: Open for Time Entry = Yes and Track Mode = PPM
Roles have timesheets available and time can be posted to Roles which is not a supported PPM function.

DE39245

Project issues are editable even if the user does not have editing rights and the issues have been created from a risk

Minor Problem

Access rights are not respected on all scenarios. Users with no editing rights can actually edit and save changes

Fixed in 15.4.0.0

STEPS TO REPRODUCE:
1. Go to Administration > Organization and Access > Groups
2. Create a new group called TestGroup
3. Add the following global rights:
Projects - Navigate | Resource - Navigate | Project - Risk, Issue, Change Request - View - All | Project - View Tasks - All
4. Create a new user UserTest1 and add him to the above group
5. Create a project called TestProject and add UserTest1 to the team
6. On the Risks/Issues/Changes tab, create a risk on the project in Classic PPM.
7. Click on Save and afterwards, create an issue from this risk by using the Create Issue button on the risk itself
8. You will notice the issue has been created
9. Log out and log in as UserTest1
10. Go to the project list and you will see the TestProject project
11. On the Risks/Issues/Changes tab > Risks, open the risk. This is read-only. That is fine
12. On the Risks/Issues/Changes tab > Risks list, the fields are read-only. That is fine
13. On the Risks/Issues/Changes tab > Issues, open the issue. This is read-only. That is fine
14. On the Risks/Issues/Changes tab > Issues list, click on any of the cells available.
Expected result: The issue to be read-only, as I only have view rights
Actual result: The cells are editable and I can actually do changes and save them
Workaround: Add the 'Originating issue/Risk' field to the list view

DE32401

CLRT-80863: Custom Timesheet User Value 1 lookup values are not carried to DWH and are blank in Ad Hoc Views

Major Problem

Steps to Reproduce:
1. Connect to PPM UI - Administration - Lookups
2. Click on New
3. Set the Name to Test Custom User Value 1
4. Select Dynamic Query
5. Enter the query below:

Fixed in 15.4.1 SP

SELECT
@SELECT:TE.PRID:PRTIMEENTRYID@,
@SELECT:SUBSTR(TSK.PRNAME,1,30):USERVALUE@
FROM PRTIMESHEET TS, PRTIMEENTRY TE,
PRASSIGNMENT ASSG, PRTASK TSK
WHERE TS.PRID = @WHERE:PARAM:USER_DEF:INTEGER:USERDEFTSID_PARAM@
AND TS.PRID = TE.PRTIMESHEETID
TE.PRASSIGNMENTID = ASSG.PRID
AND TSK.PRID = ASSG.PRTASKID
AND @FILTER@

AND

6. Hit Save and Continue
7. Save and Return
8. Now connect to Administration - Timesheet Options
9. In Default Layout add User Value 1 into the Selected Columns
10. Hit Save
11. Now change the User Value 1 Lookup
12. Browse to the Test lookup we created, select it and Save
13. Now navigate to Home - Timesheets
14. Select a timesheet for Resource, note the Resource Name and the Period/dates
15. Open the timesheet, enter some time against a task
16. Select a Value for User Value 1
17. Save and Submit
18. Now go to Home - Jobs
19. Run Load Data Warehouse job with Full Load
20. Once completed, go to Advanced Reporting
21. Select Ad Hoc Views - Create
22. Select Domains - Time management Domain - Choose Data
23. Select all the Fields to Selected Fields - OK
24. Set the Ad Hoc View to Table and No Data
25. Add the fields: Date Worked Investment Name Task Name User Value 1 Resource Name
26. Once done, set the Ad Hoc View to Full Data and look in the list to find out the timesheet/ User Values
Expected Result:

To see the new lookup values for the Time entries in the DWH/Ad Hoc view

Actual Result: The values are not updated for the User Value. If the OOTB lookup is used, they are updated. If we look in DWH_META_COLUMNS, the time
entry value for user_value1 lookup is still mapped to lookup_type PRTIMEENTRY_USER_LOV1. The other lookup never gets in this table. We also see that
PRTIMEENTRY_USER_LOV1 is hardcoded in the DWH_TIMEENTRY_V. DWH_LKP_USER_VALUE1_V also points to PRTIMEENTRY_USER_LOV1 and
cmn_lookups_v that only allows for static lookup values.
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DE32455

PPMOP_15.1_DEFECT - OWB Resource Filter Changes

Major Problem

Just upgraded to PPM 15.1 and noticed a change in OWB. When you filter on a resource, it shows the tasks for that specific resource. When you click on a
different program, or even press F3, and then click back to OWB, the tasks shown are still for the selected resource but the name shown in the filter drop
down box has changed. Have found one resource who it doesn't change for, he hasn't logged any actuals to the project so maybe that is something to
investigate.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Open a project plan with tasks, resources, and actuals from Clarity into OWB.
2. In the Tasks tab, use the Resource "Quickfilter" to select Resource A.
3. Now you should see all tasks for Resource A.
4a. Now press F3 on your keyboard, a box will open, close this box.
4b. Another test, instead of pressing F3, click your mouse on a different program, then click your mouse back onto OWB.
5. Now look at the name in the Resource ""Quickfilter"", it will have changed (lets say to Resource B) but the tasks actually shown in the window are still for
Resource A. Through some basic testing they have found that it always goes to the same resource. For example, Resource A always goes to Resource B.
Resource X always goes to Resource Y. As mentioned above it does not jump to a different resource if the original resource (eg Resource A) has not logged
any actuals to the project. This has changed since the 14.2 version of OWB they used to use. Only happens on master project.
Expected Results: When you filter on Resource A and press F3 to open the ‘View Definition – Gantt Chart’ and then close the chart you expect to see Resource
A in the filter
Actual Results: When you filter on Resource A and press F3 to open the ‘View Definition – Gantt Chart’ and then close the chart it changes to another
resource in the filter

DE32902

PPMOP_15.1_DEFECT - Unable to XOG in the project object

Minor Problem

See also CLRT-81652. Installing Earned Value Management addin (EVMS) on vanilla 15.1 with SQL DB causes issues with View "Baseline Revision Filter::
baselineRevisionList". It will insert 3 records in odf_views table with object_code = 'evbaseline' and data_service = 'baseline'. This problem isn't caused by the
upgrade to 15.1 it seems, but by something that went wrong with the installation of the Earned Value Management add-in (EVMS) after upgrade. Every time
Restore To Defaults of the Baseline object views is performed; even after correcting at the DB level the issue with (data_service <> object_code) == 'baseline',
it puts the fault back again. So 3 rows in odf_views keep returning to have a mismatch between data_service and object_code because those records are
having data_service set to evbaseline instead.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Take a vanilla 15.1 with SQL DB
2. Go to Admin side - Objects. Open baseline object. Go to Views Tab. For view ""Baseline Revision Filter"" check the Layout. Attributes Name, Code are in
Selected (Left Column) Add attributes Current Revision, Start, Finish. Save.
3. Go to Admin side - Views. Filter by Object Name=baseline and category=Filter There is 1 view with code ""Baseline Revision Filter::baselineRevisionList""
Views of baseline object are OK.
4. Install Earned Value Management addin (EVMS)
5. Review Admin Log. It shows:
12/15/16 9:54 AM (admin) Content Pack Installation Complete
12/15/16 9:55 AM (admin) CA Clarity Earned Value Manager installation was successful and is complete. 12/15/16 9:55 AM (admin)
Check the admin.log for errors that might not have been handled.
However, the log also shows errors:
12/15/16 9:50 AM (admin) ERROR 15-12 09:50:55,395 - Failure while evaluating
""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:50 AM (admin) java.lang.Exception: Invalid expression integer(data/object/@code): Error parsing
number evbaseline
12/15/16 9:50 AM (admin) Caused by: java.lang.NumberFormatException: Error parsing number evbaseline
12/15/16 9:51 AM (admin) ERROR 15-12 09:51:15,784 - Failure while
evaluating ""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:51 AM (admin) java.lang.Exception: Invalid expression integer(data/object/@code): Error
parsing number evcwbselement
12/15/16 9:51 AM (admin) Caused by: java.lang.NumberFormatException: Error parsing number evcwbselement
12/15/16 9:51 AM (admin) ERROR 15-12 09:51:33,287 Failure while evaluating ""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:51 AM (admin) java.lang.Exception: Invalid expression integer
(data/object/@code): Error parsing number evslpp
12/15/16 9:51 AM (admin) Caused by: java.lang.NumberFormatException: Error parsing number evslpp
12/15/16 9:51 AM (admin) ERROR 15-12
09:51:45,455 - Failure while evaluating ""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:51 AM (admin) java.lang.Exception: Invalid expression
integer(data/object/@code): Error parsing number evcontrolaccount
12/15/16 9:51 AM (admin) Caused by: java.lang.NumberFormatException: Error parsing number evcontrolaccount
12/15/16 9:52
AM (admin) ERROR 15-12 09:52:04,191 - Failure while evaluating ""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:52 AM (admin) java.lang.Exception:
Invalid expression integer(data/object/@code): Error parsing number evcontract
12/15/16 9:52 AM (admin) Caused by: java.lang.NumberFormatException: Error parsing number evcontract
12/15/16 9:52 AM (admin) ERROR 15-12 09:52:23,051 - Failure while evaluating ""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:52 AM (admin) java.
lang.Exception: Invalid expression integer(data/object/@code): Error parsing number evagency
12/15/16 9:52 AM (admin) Caused by: java.lang.NumberFormatException: Error parsing number
evagency
12/15/16 9:53 AM (admin) ERROR 15-12 09:53:24,047 - Failure while evaluating ""integer(data/object/@code)"" in expression ""{integer(data/object/@code)}"" 12/15/16 9:53 AM
(admin) java.lang.Exception: Invalid expression integer(data/object/@code): Error parsing number evworkpackage
12/15/16 9:53 AM (admin) Caused by: java.lang.NumberFormatException: Error
parsing number evworkpackage

6. Again Go to Admin side - Objects. Open baseline object. Go to Views Tab. For view "Baseline Revision Filter" check the Layout. View: Baseline Revision
Filter and I see the duplicates attributes in the Selected (Left Column). I see: Name Code Current Revision Start Finish Name Code Current Revision Start
Finish
7. Go to Admin side - Views. Filter by Object Name=baseline and category=Filter There are now 2 views with code "Baseline Revision Filter::
baselineRevisionList"
8. Connected to the DB and run query: select * from odf_views where data_service = 'baseline' and object_code = 'evbaseline' Query Output: 3 rows with
view type Filer and Codes: baselineRevisionList baselineRevisionList_default baselineRevisionList_master Expected Result: For object_code = 'evbaseline' the data_service should be 'evbaseline' Actual Result: 3 records in odf_views table have object_code = 'evbaseline' and data_service = 'baseline'
Expected Results: In odf_views table records for object_code = 'evbaseline' should have data_service 'evbaseline'
Actual Results: In odf_views table there are records for object_code = 'evbaseline' and data_service = 'baseline'
Workaround: As a workaround we tried to correct the 'data_service' (we ran: update odf_views set data_service = 'evbaseline' where data_service = 'baseline'
and object_code = 'evbaseline' ) then restarted services, and then restored the view to default, but that didn't resolve the issue. After restoring the view to
defaults, Baseline Revisions - List Filter Layout didn't show any attribute in Available, Selected columns . Every time Restore To Defaults of the Baseline object
views is performed; even after correcting at the DB level the issue with (data_service <> object_code) == 'baseline', it puts the fault back again. So 3 rows in
odf_views keep returning to have a mismatch between data_service and object_code because those records are having data_service set to evbaseline instead.
Either way, when those records are evbaseline or baseline, the filter layout shows empty. The fields link does show the fields still on the object as 'available',
but it is not appearing on the layout page due to the odf_views issue and something else that is affecting both the layout and the restore to defaults
operation at a higher level (caused seemingly by the EVMS addin failure).
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DE35535

PPMSAAS_15.1_DEFECT - Idea financial not removed from Portfolio

Major Problem

Portfolio Investments leaves the Idea simple budget page planned costs and budgeted costs if costs are removed after initial sync. After entering an Idea with
simple plan and budget in portfolio and then removing the costs from the Idea and doing an additional sync, the values were not removed from the portfolio.
It did not matter if the values were fully removed or if they were replaced by 0. What appears to be driving the costs on the portfolio is if the NPV on the Idea
does not update. The NPV does not update unless you initially leave the dates. When you remove the values along with the Start and Finish Dates the NPV on
the Idea does not update. If you remove the values from the costs, but leave the start and finish dates and click save, the NPV gets updated. After NPV
updates and you sync the portfolio again the costs will update. But the dates appear to stay in the portfolio on the latest row even if they are then removed
from the idea.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create an Idea - Enter simple budget Planned Costs and Budget Costs - Fill in Costs dates
2. Create a portfolio
3. Add the Individual Idea to the portfolio
4. Sync Portfolio
5. Add Costs fields and dates to the Portfolio Investments page if not already there
6. Verify data came in correctly.
7. Edit the Idea - Remove values from the costs (blank them out) - Remove values from the dates (blank them out)
8. Click Save
9. Notice that the NPV remains
10. Sync Portfolio again
Expected Result: Costs update to 0
Actual Result: Original costs and dates remain
Work Around: Leave the dates on the page, click save, make sure NPV updates then sync portfolio.Do not have explanation or work around for the dates.

DE35596

PPMSAAS_15.2_DEFECT - Rate Matrix Extraction Job Not Updating Some Rates - Incorrect ACWP

Major Problem

Rate Matrix Extraction Does not update changes to matrix when rate matrix is on entity not project. See DE32542. For my example project I did eventually put
the matrix on the project to verify that once it was placed there the new rows were added to the table. If the Rate Matrix is associated at the Entity level and
not on the project, once changes are made to the rate matrix, the changes are not pulled into the nbi_proj_res_rates_and_costs (nbi) table.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create or use an existing rate matrix.
a. Create one row with all asterisks to cover at least on year (1/1/2017-12/31/2017)
b. Give it a rate/cost of $1
2. Add the rate matrix association on to an entity
3. Create a project
a. Add financially enabled resource to team
b. Financially enable using the same department/location as the Entity from step 2, but do not put the matrix on the project itself.
4. Create task with dates 6/1/2017 - 9/30/2017 and assign the resource
5. Run Rate Matrix Extraction job with options 2 and 3, or 1,2,3.
6. Check nbi table. Note the rates are there
7. Go back to the rate matrix
a. On the line you created change the To Date to 7/31/2017
b. Create a new line with same options with dates 8/1/2017-12/31/201
7. Give this a rate/cost of $88 - This should in theory create new rows in the nbi table as the rate change is in the middle of the project and task.
8. Run Rate Matrix Extraction job again with options 2 and 3 or 1,2,3.
Expected Result: nbi table has new rows to reflect the change in rate
Actual Result: No new rows are inserted into the table
Workaround: Add the matrix information to the project itself run RME job again.
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DE36773

Parameterized lookup values do not show in the List View

Minor Problem

Parameterized lookup values do not show in the List View. The Parameterized lookup value does not show in Object List Views while displaying correctly on
Properties views. The issue doesn’t happen with all Parameterized lookup. The scenario where we see the issue is when the NSQL of the lookups read records
from Project's subobject (custom object) and sub-subobject (custom object) and those objects have fields type lookup with NSQL that also read data from
other custom objects.

Fixed in 15.4.1 SP

SET UP:
1. Create the 3 custom objects using the XOG with the following XML files: c_sol_del_method.xml, c_summary_role.xml, and c_summary_comptency.xml
2. Create the following dynamic lookups.
a. Lookup Name=c_fin_prj_num_count
Lookup id=c_fin_prj_num_count
NSQL:
SELECT @SELECT:id:code@,
@SELECT:Name:Name@,
@SELECT:Code||'('||name||')':solution_PL@,
@SELECT:decode(c_active,1,'Yes',0,'No'):c_active@,
@SELECT:c_approved_cur:c_approved_cur@,
@SELECT:c_approved_hours:c_approved_hours@,
@SELECT:(select name from cmn_lookups_v where language_code='en' and lookup_type='C_PN_CAP_STATUS' and lookup_code=c_cap_status):c_cap_status@,
@SELECT:(select name from odf_ca_c_sol_del_method where code=c_sol_del_method):c_sol_del_method@
FROM odf_ca_c_fin_project_number
WHERE @FILTER@
AND (odf_parent_id=@where:param:user_def:integer:id@ or @where:param:user_def:integer:id@ is null )
Hidden Key=code
Display Attribute=name
b. Lookup Name= Proj role Parameterzed
Lookup id=C_TEAM_PROJROLE_PARAM
NSQL:
SELECT @SELECT:odfr.id:id@,
@SELECT:odfr.Code:Code@,
@SELECT:odfr.Name:Name@,
@SELECT:odfr.c_proj_role_id||' - '||odfr.name:displayName@,
@SELECT:odfr.c_hours:c_hours@, @SELECT:(select name from odf_ca_c_summary_role where code=odfr.c_sum_prod_role):ps_role@, @SELECT:(select
full_name from srm_resources where id=odfr.c_primary_role):primary_role@, @SELECT:(select name from odf_ca_c_summary_comptency where code=odfr.
c_sum_competency):competency@ FROM odf_ca_c_proj_role odfr, odf_ca_c_fin_project_number odfpn WHERE odfr.odf_parent_id=odfpn.id AND (@WHERE:
PARAM:USER_DEF:STRING:fin_project@ is not null AND odfpn.id=@WHERE:PARAM:USER_DEF:STRING:fin_project@) AND @FILTER@Hidden Key=codeDisplay
Attribute=code
3. Use the c_fin_project_number.xml file and execute XOG which creates 2 custom objects:
a. Custom Object=Financial Project NumberObject ID=c_fin_project_numberMaster Object=Project
b. Custom Object=ProjRoleObject ID=c_proj_roleMaster Object=Financial Project Number
4. Go to admin side. Open Resource: PPM Administrator. Go to Global Access Rights. Click on Add. Add the access right for the created custom objects
5. Create instances in the custom subobjects:Custom Object=Solution Delivery MethodObject ID=c_sol_del_methodTwo Instances:abCustom
Object=Summary CompetenciesObject ID=c_summary_comptency
Two Instances:a (all fields)b (all fields)Custom Object=Summary RolesObject ID=c_summary_roleTwo Instances:a (all fields)b (all fields)
6. Create attributes in Object: Team.Go to admin side. Open Object: Team. Go to attributes and create 2 attributes type lookups:a. Attribute=Financial Project
NumberAttribute ID =c_fin_proj_numUsing Lookup =c_fin_prj_num_count b Attribute= Proj Role IDAttribute ID =c_proj_roleUsing Lookup =Proj role
Parameterzed Lookup Parameter Mappings:fin_project mapped to c_fin_proj_num
7.Object: Team. Go to Views Tab. View: Staff Member PropertiesAdd in the Edit Layout Attributes= Financial Project Number and Proj Role ID
8. Create the following lookups. Use the following xml files to create them via XOG:C_SUMMARY_COMP_lookup.xmlc_summary_role_lookup.xml
STEPS TO REPRODUCE:
1. Open any project.
2. Select Properties > Financial Project Number List
Create an Instance:
Name=a
Create another Instance: Name=b

ID=a
ID=b

3. Open Financial Project Number instance aProperties > ProjRole ListCreate an Instance:Competency=aProj Role ID=aPrimary Role= select any
roleHours=0Prod Role=aName=a1Create another Instance:Competency=aProj Role ID=aPrimary Role= select any roleHours=0Prod Role=aName=a2
4. Open Financial Project Number instance bProperties > ProjRole ListCreate an Instance:Competency=bProj Role ID=bPrimary Role= select any
roleHours=0Prod Role=bName=b1Create another Instance:Competency=bProj Role ID=bPrimary Role= select any roleHours=0Prod Role=bName=b2
5. Go to Team - StaffAdd a resourceClick on Staff Member PropertiesEnter:Financial Project Number=aProj Role ID=PR-00000002 (select the row for
name=a1)Save and Return
6. In Staff List, click on configure. Go to List Column Section Layout Add to Select Attributes= Financial Project Number and Proj Role ID
7. In Team - Staff List observe columns Financial Project Number and Proj Role ID
ACTUAL RESULT: Financial Project Number=a

Proj Role ID=

EXPECTED RESULT: Financial Project Number=a

Proj Role ID=PR-00000002

DE36932

External Dependencies get Deleted when using the MSP Legacy Driver

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Create two projects in PPM with two task each
2. In PPM, make Project2 Task1 be a Successor of Project1 Task1
3. Export Project1 to MSP and verify that the external Successor shows on Task1
4. Without making any changes to Project1, close out of MSP
5. Export Project2 to MSP and verify that the external Predecessor shows on Task1
6. Without making any changes to Proejct2, close out of MSP
7. In PPM, make Project2 Task2 be a Predecessor of Project1 Task1
8. Export Project1 to MSP
Expected Results: Both the newly added external Predecessor and the previously added external successor show on Project1 in MSP.
Actual Results: The newly added external Predecessor shows in MSP. However, the Successor that was added on Step 2 and previously showing on Step 3 is
no longer part of the project in MSP. If we were to not notice and we save the project back to PPM, it would remove the first external dependency from Task1
in PPM as well.
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DE36999

Jaspersoft Scheduled Reports "Start Date" is not dynamic

Minor Problem

The required field "Start Date" in the scheduled report is static, and does not get adjusted automatically when the report runs. For example: A report is
scheduled to run monthly, and the Start Date is entered as 09/1/2017. When the report runs, it produces data for September 2017 through August 2018.
When the report runs on 10/1/2017 or the next month, the Start Date remains the same which means that you get reporting data from September 2017
through August 2018 again, instead of from October 2017 through September 2018.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Navigate to Advanced Reporting > Reports > View List.
2. Right-click on a report, and select Schedule (to schedule a report).
3. Set the following field:
Start Date - On Specific Date: 9/1/2017
Recurrence Type: Calendar Month: Every month
Expected Results: Report to display data from the current month.
Actual Results: Report displayed data from the Start Date.

DE37155

Data is not displayed when filtering on the second and subsequent pages when displaying

Minor Problem

When we show 2nd page on grid portlet and make a filter with the data within 1 page on page filter then we can see no data. When we show 2nd page on
grid portlet and make a filter with the data within 1 page on page filter then we can see no data. If we use the portlet filter then we can see the data correctly.
We suspect that this is due to page filter.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a custom object.add 2 attributes.create instance data for 26 counts. The value for bu_id from 1st to 21st is A.
2. Create a query based on the custom object.
3. Create a portlet based on the query.
4. Create a filter portletcreate 2 fields.
5. Create a portlet page with the grid portlet and filter portlet.
6. Show the portlet page.We can see 26 data and go to 2nd page on the list. We can see one "A" data and 5 "B" data in the list. When we input "B" on filter
portlet for bu_id and click filter button then I can see the message "There are no items to display".
This is the problem. This should show 5 "B" data. When we input "B" on the portlet filter for bu_id and click filter button then I can see 5 "B" data.
Expected Results: This should show 5 "B" data.
Actual Results: I can see the message "There are no items to display".
Workaround: Use the portlet filter.

DE37169

Plan Start and Finish dates in Portfolios not honored

Minor Problem

Portfolio Waterlines page Role Demand does not honor plan dates if portfolio dates are changed. When you have a plan covering different dates than the
portfolio the Role Demand shows correctly until you change the portfolio dates and Sync. Then the Waterlines page shows Role Demand across the portfolio
instead of honoring the Plan dates. Even when changing to another plan and then back, the dates are not honored. The only way to get the Waterlines Role
Demand to honor the plan dates is to reset the dates on the plan (change them and change them back).

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Make sure you have project which has a Resource with a Role and allocation (so there will be Role Demand) The project dates 8/1/17-12/31/2017
2. Create a portfolio dates 1/1/2017-12/31/2017 - Add the project from step 1 into the contents editor page and sync
3. On Targets tab add the role for the resource from step 1.
4. On Waterlines page configure the view to add the Role from step 1.
5. Set the Aggregate to that Role as well - this way you can see their demand in TSV - Note the Demand for that role (my example = .39)
6. Create a plan with dates matching the project dates, 8/1/17-12/31/17
7. Set waterlines page to that plan - Note the Demand for that role (my example = .92)
8. Change the dates on the portfolio to make the end date = 5/31/2018
9. Sync
10. Go to Waterlines page (note it should already be set to the Plan1 and Aggregate for the Role)
Expected Results: Role demand still reflects the numbers associated with the plan dates
Actual Results: Role demand is spread over the portfolio dates. Even swapping plans on the waterlines page does not reset it.
Workaround: No easy work around. Only way is to reset the dates on the plans which is not feasible.

DE37207

A project can't be opened in OWB after creating a requisition on a role with 0% Default Allocation

Minor Problem

After creating a requisition for a role that has 0% default allocation, the project cannot be opened in OWB.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a new project
2. Go to Team tab and add a role. Make sure that the default allocation is set to 0% (as well as Average allocation, Allocation, ETC...)
3. Create a new task with ETC. Assign the role (so that the role ends with ETC for the assignment)
4. Go to Team tab and execute action "Allocate from Estimates" on the role
5. Execute action "Create Requisitions" on the role (Create and Open)
6. Go to Team > Requisitions and open the newly created Requisition.
7. On the Resources tab, add a resource
8. Book the requisition
9. Go to the Team tab and confirm that the resource has been added to the team.
10. Open the project in OWB
Expected Results: OWB opens the project
Actual Results: OWB shows the error "Unable to open project XXXX. Operation Disallowed: AllocCurve must be of type RATECURVE".
Workaround: Project can be opened in OWB after selecting all resources in the team tab, then choose the action "Set Allocation", then set "Default Allocation
%" to "0" and check "Clear existing allocation segments", then Save.
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DE37241
Major Problem
Fixed in 15.4.1 SP

'PRJ-07008: Finish date earlier than start date.' Error is thrown when Attempting to Modify Expense Assignment Properties (such as
Finish Date, Loading Pattern, Assignment Role) on the Assignment List
'PRJ-07008: Finish date earlier than start date.' Error is thrown when Attempting to Modify Expense Assignment Properties (such as ETC, Loading Pattern,
Assignment Role) on the Assignment List
STEPS TO REPRODUCE:
1. Create a new project with dates of 3/1/2017 -12/31/2017
2. Financially enable the project
3. Add an expense resource and a labor resource to the team
4. Create a new task (dates: 3/31/2017-12/31/2017) and assign both resources to the task
5. Add etc to the labor resource for the entire task duration
6. Add etc to the expense resource, but only for the months of March - September
7. Post monthly transactions for the monthly ETC amounts entered on the previous step for the Expense resource for every month between March and
September
8. Go to the task properties page, notice the Expense assignment has an Assignment Finish Date and an Actual Thru date is 9/30/2017 (0 ETC remaining)
9. Add a 100 ETC amount for the Expense resource on the time scale for the month of October 2017
10. Click Save at the bottom of the Assignment list
Expected Results: 100 ETCs get added in the month of October, and the assignment Finish Date gets extended to 10/1/2017
Actual Results: The ETCs are not saved and the following error is thrown: PRJ-07008: Finish date earlier than start date.
Workarounds:
1. Add ETC to the ETC column first and then redistribute it on the Time Scale.
2. Add an ETC segment on the assignment properties page for the month of October.

DE37316

The auto-suggest feature is too slow when searching for a department OBS node

Major Problem

Steps to Reproduce:

Fixed in 15.4.1 SP

Be sure you have many (~15,000) departments with levels/hierarchy. The time to increase as the hierarchy depth increase.
1. Go to Home -> Projects
2. New project
3. Go to Department OBS Browse.
4. Type any valid department name in order to get all the values using the auto population functionality.
5. This is taking approx. 2 min to display those values in Department OBS and making system slow.
Steps to Reproduce in 15.3 are different, however this should be enough to understand the issue.
1. Go to Home -> Projects -> Click on ""A Test Proj""
2. In Project Summary view in the Department OBS text entry type the characters, for example /BBT/INFORMATION
3. Just wait there and not select anything. Suddenly it shows "no results match"
4. Observe multiple webservice calls in the tomcat app-access log and look for entries for "/niku/odata/GetSuggestionsForOBSLookupByOBSType"
Expected Result: Auto population in department OBS should find the department faster
Actual Result: Auto population in department OBS is taking too much of time.
Workaround: use binoculars/pop-up window to select department OBS.
-------------------------------------------------------------------------See also previous issues where auto-suggest feature is slow when searching for a department OBS node. Separate bug logged for both SQL and Oracle. Bug
detail show status Closed and Fixed in PPM 13.3.
-CLRT-71677 - The auto-suggest feature is too slow (sometimes minutes) when searching for a department OBS node.-FOR SQL SERVER
-CLRT-69572 - The auto-suggest feature is too slow (sometimes minutes) when searching for a department OBS node.-FOR ORACLE
-https://support.ca.com/us/knowledge-base-articles.tec591362.html
-(Previous CASUP Defect Id DE35806 - PPMOP_14.3.0.6_CASUP - Auto Suggest Feature Not Working - changed configuration to add locations to the Location
OBS which they are using on the Team tab now for Staff OBS)

DE37467

Filter for German character 'ß' in the Resource List doesn't show the correct records

Minor Problem

German Character ‘ß’ does not filter in Resource list.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Navigate to Administration > Resources
2. Create new resources with the following names ""Groß"", ""Roß"" and ""Broß""
3. Navigate to Home > Resource Management > Resources
4. On the resource list, Filter for character ""*ß""
Expected Result: All Resources with 'ß' in their name are displayed.
Actual Result: All resources with 'ß' in their name are not displayed. When German language is set, the filter doesn't return the resources with 'ß' in their
names.
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DE37592

E2E Data Only - Program Hierarchy with subprojects in multiple currencies does not export data as observed in the portlet

Minor Problem

This is a new defect based on CLRT-75010 and DE30900. In a program with multiple subprojects in more than one currency (e.g.: Program's Currency is in USD
and it contains subprojects in USD, EUR...), the projects that are not in USD show its costs in converted USD amount (as per the currency conversion rates
configured in PPM). If the results are exported using the Export to Excel Data Only feature, the amounts that appear are different: they are shown in their
configured currency. Subprojects do not show which currency they are using so this generates additional confusion.

Fixed in 15.4.1 SP

Steps to Reproduce:
1. Use a multi-currency environment with at least two currencies (e.g., USD [system currency] and EUR) enabled and with a currency exchange rate between
them different than 1., e.g.: 1 EUR = 1.1 USD and vice-versa.
2. Create a project p1 in USD and set ""Planned Capital Cost"" to a non-zero amount (e.g: 1000)
3. Create a project p2 in EUR and set ""Planned Capital Cost"" to a non-zero amount (e.g: 2000)
4. Create a program in USD.
5. Add the projects as subprojects to the program
6. Go to program Hierarchy > Financial Rollup.
7. p1's Planned Cost will show up as 1000. p2's Planned Cost will show up as 2200. No units are referenced in the portlet for any subproject.
8. Use the Export To Excel Data Only
Expected Result: p1's Planned Cost will show up as 1000. p2's Planned Cost will show up as 2200.
Actual Result: p1's Planned Cost will show up as 1000. p2's Planned Cost will show up as 2000.

DE37611

Waterline views - manual change in Ranking

Minor Problem

In Portfolios -> Waterline views, if we manually edit the ranking of an investment, the new ranking entered is automatically increased by 1.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
In waterline view for a portfolio with 10+ investments, edit the ranking of item # 9 and change it to 4.
Expected Results: New ranking of the investment is 4
Actual Results: New Ranking of the investment is 5.
Workarounds: Customers do have a workaround of dragging and dropping. But could cause issues if user is not paying attention.

DE37649

Failed DWH Trending jobs lead to orphaned FK and Load Data Warehouse - Full failure

Major Problem

Failed DWH Trending jobs lead to orphans and Load Data Warehouse - Full failure.

Fixed in 15.4.1 SP

Steps to Reproduce:
1. Start the Create/Delete Trending job and fail it for any reason (interrupt it). For example start it, and hit Cancel mid way. Then delete the job instance. (Does
not always work. Has to be stopped in a certain moment.)
2. Run the Load Data Warehouse job - Full Load.
Expected Results: the Load Data Warehouse job to run properly
Actual Results: The Load Data Warehouse job fails with error ORA-02298: cannot validate (PPM_DWH.DWH_TRD_INV_INVESTMENT_FK1) - parent keys not
found or similar FK violation
Workaround:
#1 Delete the orphaned data with SQL query (has to update ALL the affected tablesor
#2 Refresh DWH with a new blank database (Important!!! will erase ALL existing trends!)
The issue happens because the Load Data Warehouse job is actually enabling ALL the constraints in the system. I would think it would be probably better to
run CMN_ENABLE_CONSTRAINTS_SP for non-trending tables only. Otherwise what will happen is that if the Trending job is failing for any reason the other job
will be dependent on it.

DE37736

Different conversions rates for Budgeted Cost

Minor Problem

Budgeted Cost currency conversion on Program Financial Hierarchy page is not correctly calculated.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
Customer has a Master program which uses Swedish Krona. Then a child Program 1 that is in Brazilian Currency and then another child project for program 1
which is also in brazilian currency.
A plan and budget cost have been created in the child project and these have the same value which is 5386 in Brazilian currency. When they roll up to Master
Program in the Hierarchy - Financial Rollup (Basic View), the 'Planned cost' gets converted to Swedish currency correctly but the 'Budgeted Cost' currency
conversion is wrong.
On the 'Detailed' view however the conversions are correct for both fields. If we remove the child project and add back, this still did not make any difference.
The 'Budgeted Cost' value is stored as a blob in the fin_financials so we are not able to determine how this gets generated and stored in the
'BUDGET_CST_TOTAL' column.
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DE37816

15.2 PPM DWH_CFG_AUDIT still has DWH_RES_SECURITY and DWH_INV_SECURITY

Major Problem

The following view in the DWH: DWH_CFG_AUDIT Still uses the following tables: DWH_RES_SECURITY and DWH_INV_SECURITY. Can this be cleaned up in a
future PPM release as the tables are no longer used.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
Check the DWH and the following view: DWH_CFG_AUDIT is still using the following tables: DWH_RES_SECURITY and DWH_INV_SECURITY
Can these tables/views be cleaned up as the tables are no longer populated via the DWH job?
Expected Results: Tables should no longer be there if they are no longer populated.
Actual Results: Tables are still available within the DWH.

DE37891

Calculated Attribute is not getting added to the Portfolio Investment object

Major Problem

Calculated Attribute is not getting added to the Portfolio Investment object with the following error:
“was not added to the Portfolio Investment object because the following contributing attributes were missing: {1}”

Fixed in 15.4.1 SP

Difficulty to implement our usual business indicators in the CA PPM solution.
STEPS TO REPRODUCE:
1. Log in as a Clarity Administrator user.
2. Administration, Studio: Objects, open the Project Object, Attributes tab
3. Create a new calculated attribute (MyCalculatedNumber01)
4. Click 'Save' button, then click ""[Build Calculated Attribute]"" to create a Formula. Select:
a. Function ""Divide""
b. Argument 1 - Attribute Name 'Planned NPV (planned_npv)'
c. Argument 2 - Attribute Name 'Planned Cost (planned_cst_total)'
5. Click 'Generate' button
6. Click 'Save and Return' button
7. Administration, Studio: Objects, open the Portfolio Investment Object, Attribute Registry tab
8. From the 'Available Attributes' box, look for 'MyCalculatedNumber01' and move it to 'Selected Attributes' box
9. Click Save
Expected Results: Gets added from the Available Attributes to Selected Attributes
Actual Results: Attribute does not get added to Selected Attribute with the following error:“ was not added to the Portfolio Investment object because the
following contributing attributes were missing: {1}”

DE37900

Action 'Synchronize Portfolio Contents' has disappeared

Minor Problem

The action ""Synchronize Portfolio Contents"" has disappeared. Customer would like to know if something has changed? There have been changes in the
code. Action ""Synchronize Portfolio Contents"" is missing for user without the 'Portfolio -Edit All' right. Once you grant that access right, everything is OK.
The following defect was addressed as part of: DE28435 The synching would fail without the access right: Portfolio - Edit All access right so I would assume
that the code changed due to that defect (DE28435) has possibly caused this?

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Go to Administration -> Resources -> go into a resource and remove the 'Portfolio – Edit All' right.
2. Log in as that resource
3. Go to Home -> Portfolios -> click on a portfolio
4. Go to the Portfolio Properties – General screen
5. Click on ‘Actions’ from the top right corner
Expected Results: To still see ‘Synchronize Portfolio Contents’ in the Actions drop down menu.
Actual Results: ‘Synchronize Portfolio Contents’ is missing from the Actions drop down menu.
Workarounds: They have create another process to synchronize portfolios, users can continue using this functionality, but is important because is better to use
the system functionality.

DE37985
Cosmetic
Fixed in 15.4.1 SP

Portfolio waterline calculation hangs when no constraint columns are selected for the view
In PPM 15.3, after creating a portfolio and adding investments to it, the waterline value can be calculated in the Waterline section tab. However, if each of the
constraint columns (Planned Cost, Planned Capital Cost, Planned Operating Cost, Role Demand), and then the waterline value is calculated, the portlet hangs
with the 'Loading...' animation and never completes. Additionally, the portlet list section remains blank (meaning no investments are listed).
STEPS TO REPRODUCE:
1. Navigate to Home > Portfolios and click New
2. For the creation options, just enter the required fields but make sure Dashboard View is set to PMO-Portfolio Investment Dashboard
3. Save and Return
4. Go to Contents Editor and click Add under Individual Investments
5. Add at least 20 projects to the Portfolio then run Sync Now
6. Wait until the sync finishes, then go to the Waterlines section tab
7. Click on the Configure for the portlet and move the fields Planned Cost, Planned Capital Cost, Planned Operating Cost, and Role Demand from the Selected
Columns list to Available Columns
8. Save and Return, the bottom section of the portlet should say 'There are no constraint columns configured on the view.'
9. On the portlet header, click the dropdown arrow and then use 'Run Ranking Rules'
10. Click on the rectangle next to the dropdown arrow to calculate the waterline value
Expected Results: The waterline value is calculated. If the waterline value can't be calculated because no constraint column is selected for the view, then a
message indicating that should be displayed.
Actual Results: The waterline value looks like it is being calculated, and the 'Loading...' animation is displayed but never completes. After refreshing the page,
the portlet results are blank.
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DE37995

Investment OBS Does not work on the Capacity vs Demand by Role report

Minor Problem

Investment OBS is not taken into account on the Capacity vs Demand by Role report. The report shows the same results regardless of the OBS Type and OBS
Unit selected in the filter.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a role
2. Create a resource and set their Primary Role to be the role from Step 1.
3. Create a new project with OBS unit 1 (dates: 12/1-1/31)
4. Staff the resource from Step 2 on the project from Step3 with 100% allocation
5. Create a second new project with OBS unit 2 (dates: 12/1-1/31)
6. Staff the resource from Step 2 on the project from Step4 with 100% allocation
7. Run the time slice job and wait for it to complete
8. Run the Load DWH job (Full Load) and wait for it to complete
9. Go to Advanced Reporting - Open the Capacity vs Demand by Role report
10. Run the report with all filters cleared and a Start Date of 12/1/2017
11. Take note of the results - The Demand amount includes the resource demand on both projects
12 Run the report again, but for the Investment Type and Investment OBS filters, select the OBS Unit 1 that Project 1 is using
Expected Results: The Demand value is half of what it was on Step 11, as only the demand on Project 1 should show on the report results
Actual Results: The Demand value is the same as it was on Step 11 - The Investment OBS filter parameter is ignored, and the results incorrectly include the
demand from both Project 1 and Project 2.

DE38062

ALERT An expired request has been detected. Request has been canceled

Minor Problem

The customer is getting this error when opening IE or Chrome in their LAN anywhere in the CA PPM GUI:

Fixed in 15.4.1 SP

ERROR: ALERT An expired request has been detected. Request has been canceled Expired Request An expired request has been detected while processing a
request. To recover you should use the browser back button or PPM History to return to the previous page. Refresh it and try the request again. If the problem
persists contact your system administrator and provide them with the following information: Request ID: Type of Error: Expired request
Please consult this knowledge Base article: TEC567263
STEPS TO REPRODUCE:
The customer can be working anywhere in CA PPM and he gets this message many times a day.
All the users and under working under any of the ca ppm options. q3wddrqdqwdqwdqqwxdqw3dqwdx
Expected Results:
Actual Results:
See also "A request has been denied as a potential CSRF attack" in KB Article: 000092928.

DE38192
Minor Problem
Fixed in 15.4.1 SP

UI drop-down for opening in Scheduler in the new UX does not do anything if there is no Scheduler Format configured for the
Project
The drop-down to open a Project in a scheduler (Workbench or Microsoft Project AND PPM Gantt) does not do anything in the new UX, not even displaying
the PPM Gantt option, unless a Scheduler Format has an assigned (non-null) value.
STEPS TO REPRODUCE:
1* For any project, in the Classic UX, go to Project properties > Settings > Scheduler and make sure that ""[--Select--]"" is the selected option.
2* Go to the new UX and open the same project.
3* In the tasks tab, click the three-dot menu.
Expected Results: PPM Gantt option is displayed.
Actual Results: Nothing happens (not even a warning/error message) after clicking. Note that the classic UX displays Workbench and PPM Gantt even if there
is no Scheduler Format assigned to the project.

DE38332

The auto-suggest feature is too slow when searching for a department OBS node FOR ORACLE

Major Problem

Steps to Reproduce:

Fixed in 15.4.1 SP

1. Login to classic PPM as a Project Manager
2. Home > Projects > Any Project General Properties page
3. In the Department OBS field, start typing any valid ID from Department List
Expected: For auto-suggest to provide quick results.
Actual: For this test it took 9m 43s autosuggest to provide results. I tried the following Dept ID - 7XX3 - It took 9 min to auto-suggest an OBS.
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DE38347
Cosmetic
Fixed in 15.4.1 SP

PPMOP_15.3_DEFECT - ETC units displayed in hours instead of days on the PPM Gantt for projects participants
ETC units displayed in hours instead of days on the Gantt Chart for projects participants. Project participants cannot see their ETC, Actuals and other data in
Days unit even if it is set as the System defaults. Even the user changes the setting to Days, the data still shows in Hours.
STEPS TO REPRODUCE:
Logged in as PPM Admin user in a CA PPM 15.3 instance.
Go to Administration --> Project Management --> Settings.
Checked that the ""Default Display Unit for Work Effort"" is set to Days. ""Allow Effort Task Creation"" was also checked. Now, I created a PPM user. I created a
project which starts and ends on January 3, 2018.
Added the new resource as team member.
Added the following global rights to the user:
a) Project - Benefit Plan - Edit All
b) Project - Budget Plan - View All
c) Project - Cost Plan - Edit All
d) Project - Create from Template
e) Project - Edit Assigned Tasks - All
f) Project - Edit Chargebacks Information All
g) Project - Financial Plan - Submit All for Approval
h) Project - View Tasks - All
i) Projects - Navigate Logged out from PPM admin user. Logged in as the new user.
Go to Home --> Portfolio Management --> Projects.
Open that newly created project. Go to Task tab, and click on Task tab drop down. Only Task list and Gantt is visible. Due to the access rights, Resource
Utilization and Assignments subpages are not visible. Open the project in PPM Gantt. Click on the ""configure"" cog wheel button.
From List Column Section, add ETC column in the Gantt view before the ""schedule"" column.
Go to the ""Options"" subpage, and see the ""Work Effort Unit of Measure"" is set to System Default (which is Days).
Click on Save and return to come back to the Gantt window.
Expected Results: In the ETC column, data should be showing in Days.
Actual Results: In the ETC column, data is displayed in Hours.

DE38429
Major Problem
Fixed in 15.4.1 SP

Unable to save changes on a project if a dynamic lookup exists pointing to a subobject and parent child object processes exist on the
system
Once the setup is done you cannot save changes to a project. (Note: Might be related to: CLRT-81535.)
STEPS TO REPRODUCE:
1. Go to Studio > Objects > Create a new subobject of the project object called mysubobject
2. Make it event enabled.
3. Go to Administration > Data Administration > Lookups
4. Create a dynamic query called Mylookup with query as follows:
SELECT @SELECT:ID:ODF_PK@,@SELECT:CODE:CODE@,@SELECT:NAME:NAME@ FROM odf_ca_mysubobject WHERE @FILTER@
Link the lookup to the mysubobject object
5. Go to Studio > Objects > Project object
6. Create a custom attribute called MyLkp pointing to the Mylookup lookup field l
7. On the project object views, add the custom field to the General view. (Layout-Edit --> Project summary)
8. Create a project (Myproject) and go to the Mysubobject list
9. Create a couple of instances.
10. On the project general page, you now see the MyLkp field.
11. You can choose a value as per the subobject instances created. Everything is fine.
12. Go to Administration > Data Administration > Processes
13. Create a process called My_proj_process with the project as primary object
14. Add a linked object and select the MyLkp attribute
15. Give any auto-start condition and validate the process. The condition is not important, just the fact of the process being active
16. Go to Administration > Data Administration > Processes
17. Create a process called My_sub_process with the mysubobject as primary object
18. Add a linked object and select parent project object
19. Give any auto-start condition and validate the process. The condition is not important, just the fact of the process being active
20. Go back to MyProject and click on save.
Expected Results: Saving action to be successful
Actual results: Error pops up: Unable to communicate to PPM server. Please try again.

DE38494

Portfolio Reports do not seem to utilize Portfolio Manager Filter

Minor Problem

Portfolio Reports included with the PMO Accelerator (Portfolio Plan Changes, Portfolio Plan Changes - Waterline and Rank, and Portfolio Plan Comparison) do
not seem to utilize the Portfolio Manager filters.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1- logged in to Clarity
2- click on home -> portfolio management -> portfolios and select a portfolio from the list with multiple managers.
3- next login to advance reporting
4- open portfolio reports i.e Portfolio Plan Changes
5- opened report without any filtering criteria
6- confirmed that the report opened successfully
7- next filter by specifying any portfolio manager listed in step 2 manager which we had confirmed existed in PPM

Expected Results: reports should run and filter the data based on selected portfolio manager
Actual Results: no data is returned; the report fails to populate with any data and gives message ""no data available for matching criteria""
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DE38542
Minor Problem
Fixed in 15.4.1 SP

'Set Allocation' functionality in Service => Team - Staff page does not work when Team object attribute - 'Default Allocation' =>
'Default Value' is set to 0%
End users are unable to set new allocations for all resource at one go, so can be time-consuming to manually enter these for each resource on Staff Member
Properties page.
STEPS TO REPRODUCE:
1. Open Team object from CA PPM Administration page and set the Default Allocation attribute - 'Default Value' to 0%
2. Create an instance of a Service (1 Jan 2018 - 31 Dec 2018) and and allocation 3 labor resources in the Team - Staff page
3. Change their Default Allocations to 100% in the Team - Staff Member Properties page and click 'Save And Return' button.
4. In the Service => Team - Staff page, select all three resources then from the 'Actions' drop down list, click on 'Set allocation'
5. On the 'Set Allocation' page, enter a New Allocation Segment. For example, 1 Jan 2018 - 31 May 2018 with 0% Allocation. Click on 'Save' button.
6. You get an alert message on the top of the page as follows: 'The selected resources have been updated'. Click 'Return' button to go back to Team - Staff
page
Expected Results: The entry made in the 'Allocation Segment' in step 5 should be reflected in the 'Allocation' and 'Average Allocation %' fields on the Team Staff page
Actual Results: There are no changes to the 'Allocation' and 'Average Allocation %' fields on the Team - Staff page.

DE38563
Cosmetic
Fixed in 15.4.1 SP

PPMOP_15.3_DEFECT - Value shifts during inline editing in a TSV if the Start date type is Other Date and set as START and Time
period offset is not zero
Users are unable to use the TSV and its features properly for a specific setting.
STEPS TO REPRODUCE:
Login to CA PPM 15.3 as an Admin user.
Create a new project with start date January 1, 2018 and End date as June 30, 2018.
Add a resource in TEAM tab for that project.
Go to the ""Team - Detail"" subpage from the Project's Team tab.
Click on the cog wheel button to configure the ""Time-Scaled Value"".
Select the radio button for ""Other Date"" for the Start Date and select START from the drop-down list.
IMPORTANT: Be sure to configure 'Other Date'Set the Number of Time Periods as 12. Time Period Offset will be 2.
IMPORTANT: Be sure it is NOT set to Zero(0)Click Save and Return.
In the Team - Detail page, the ""Allocation By period"" TSV will show from March 2018 (assuming the Time Scale for that Virtual field is set as ""Month"").
Click on the March 18 column to edit the Allocation for that month.
Once the Allocation box is editable, input 50 and hit ENTER.
Click Save.
Expected Results: Allocation for the March 2018 column will be saved as 50.
Actual Results: The value 50 gets shifted 2 columns forward, and May 2018 column gets updated with 50.
WORKAROUND: Change session Time-Scaled Value configuration to use other options that will not cause this issue.

DE38597

Adding and editing a TSV in the Resource list generates an HTTP 500 error

Minor Problem
Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1* Create a new Time Varying (number) attribute in the Resource object.
2* Go to Home > Resources and click on Options > Configure.
3* Go to List Column Section > Fields > New and select ""Time-Scaled Value""
4* Configure the TSV to include 1 period, ""Start of Next Year"", Save.
5* After saving, select option ""Allow editing"".
6* In the Resource list, for any row, enter a value and then Save.
Expected Results: The value is saved and displayed back.
Actual Results: Right after clicking on Save the value will disappear and after double clicking on the same row, an HTTP 500 internal server error will appear.
NOTE: Applying same STR but using the Project object will not reproduce this issue; looks like it may not affect all objects.

DE38603

Attempts to upload an attribute longer than the 20-character limit on the project object via XOG has corrupted the project object

Major Problem

After attempting to XOG in 22-character custom attribute and update the risk formula field the xog fails with:
XOG-3360: Custom attribute record has not been inserted. SQL Exception with error code : 12899- custom attribute xxx_rc_interdependency is 22 Characters

Fixed in 15.4.1 SP

- The risk formula field has restriction of 20 characters
- Update to the risk formula field fails due to 20 character limit
- The database partially gets updated and it causes corruption
- Tried to re-install LOD project object via pmo add-in not successful
STEPS TO REPRODUCE:
1) On PPM 15.3 vanilla system
2) XOG in customer input file project_rcf.xml
3) Go to Administration > Object > Project or Home > Projects
Expected Results: The custom attributes are available in the UI
Actual Results: XOG has corrupted the project object.
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DE38608

After adding calculated Aggregated attribute to the project list it is taking very long time for project list to populate

Minor Problem

Customer created calculated aggregated attribute on the project object and placed it on the project list. After that it is taking way to long and in many cases it
is timing out. This issue occurred in an environment with over 8000 status reports across 150 projects.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Navigate to Admininstration->Studio->Objects and select project object
2. Click on Attributes tab and click on New
3. Create Aggregated Attribute as below:
Attribute Name = Overall Status
Attribute ID = jfs_overall_status
Data Type = Aggregated
Current Expression = AGG_Max(cop_prj_statusrpt.cop_overall_status)
Filter ( ( Status Report Report Status = 'Final' ) and Status Report Report Date = Maximum of Status Report Report Date )
4. Click Save to create new attribute
5. Navigate to Home->Projects and click on Configure
6. Add newly created attribute to the list, notice how long it takes for project list to populate Please note it is not something i was able to reproduce on
Vanilla, because of the number of status report instances available in the environment.
Expected Results: project list to populate in the reasonable time.
Actual Results: it takes about 15 minutes for project list to come up.

DE38750

About setting change of plan cost when shifting the period backward in the portfolio plan

Minor Problem

When we delay the duration on portfolio plan then the role demand becomes back but the cost plan does not become back and it is uniform.

Fixed in 15.4.1 SP

When we delay the duration for a project on the waterline of portfolio then the role demand becomes back but the plan cost does not become back and it is
uniform.
STEPS TO REPRODUCE:
1. Create a project Start Date : Apr 1st 2017 Finish Date : Nov 30th 2017
2. Add a role on the project
3. Create a cost plan Start Period : 2017/11/01-2017/11/30 Finish Period : 2019/03/01-2019/03/31 Create Cost Plan Details.
4. Create a portfolio Add the project as investments. Planned Capital Cost is same as Project Capital value. Planned Operating Cost is same as Project
Operating value. Waterlines
5. Change the start date from Apr 1st 2017 to May 1st 2017. Aggregate : Role Demand 1 month changed and the value is same. Aggregate : Planned Cost
Aggregate : Planned Capital Cost Aggregate : Planned Operating Cost Start period is changed and the value is also changed.
Expected Results: For Planned Cost, Planned Capital Cost and Planned Operating Cost, the result is same as Role Demand when I change the start date from
Apr 1st 2017 to May 1st 2017.
Actual Results: For Planned Cost, Planned Capital Cost and Planned Operating Cost, Start period is changed and the value is also changed.

DE38816
Cosmetic
Fixed in 15.4.1 SP

Role names are getting truncated
When adding a new role, the Role Name allows up to 100 characters to be entered. But, the Role Name is always truncated to 32 characters on the following
pages: Select Role, Resource List (in the Primary Role attribute), Resource Properties (in the Primary Role attribute).
STEPS TO REPRODUCE:
1) From HOME -> Resources, add a New Role. In the Role Name, enter a name that is longer than 32 characters.
2) From HOME -> Resources, open any Resource.
3) In the Primary Role attribute, use the Browse to open the Select Role window. Note that the Role Name added in step 1 was truncated to 32 characters.
Select the Role you added in step 1 and press Add. Note that the Role Name is also truncated in the Primary Role attribute of Resource Properties page.
4) Press Return to go back to the Resource List. Note that the Primary Role attribute is truncated to 32 characters on this page as well.
Expected Results: Since you are able to enter up to 100 characters in the Role Name when adding a new role, the Primary Role should not be truncated to 32
characters on the Select Role, Resource List, or Resource Properties pages.
Actual Results: The Primary Role is truncated to 32 characters on the Select Role, Resource List, or Resource Properties pages.

DE38836

Health Report - Invalid Database Objects

Minor Problem

When the Datamart Extraction job is executed, the health check report shows up with 3 invalid objects which are Stored Procs related to DME job.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Login to CA PPM
2. Administration - Health check report - Summary tab
3. In Database Category, check if there are any invalids. If there are any, compile the objects to make it valid.
4. Once there are no invalids (or atleast no objects related to Datamart), run the Datamart Extraction job
5. Once DME completes, run Datamart Rollup
6. Navigate back to Health check report under administration
Expected Results: There are no invalids under DB category
Actual Results: The Health check report shows 3 invalids.
The below query returns the records showing 3 SP related to Datamart.
select * from user_objects where status != 'VALID'
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DE38843

Rate Matrix allows spaces after the resource/resource role/location/transaction class causing not to accept proper rate

Minor Problem

When creating a new row for the data matrix, a resource can be entered with additional spaces, and this makes the rate not to be found for the intended
resource (for example, "admin" != "admin "). It is also difficult to identify at a glance which rows have additional spaces as they are not visible - although they
can still be observed by selecting the whole cell text.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1* Go to Administration > Finance > Manage Matrix, click New
2* Fill in the details for the rate matrix except the resource
3* For the resource, try either a or b:
a* Using the binoculars, select a resource (e.g.: ""admin""), select ""Add"" and then add one or more blank spaces after the ID (""admin "")
b* Type "admin " (including one or more blank spaces after the ID)
4* Click Save and Return
Expected Results: The blank spaces are not saved or an error is displayed (REVMGR-20187:Resource code is not valid.), as ""admin "" is not valid resource ID.
Actual Results: Blank spaces are saved and row is inserted in the matrix. Rates for that row are not found as do not match resource ID (""admin"" != ""admin
""). Same can be reproduced with Resource Roles, Locations, and Transaction Classes.

DE38853

Data Warehouse Incremental job performance on large datasets (Oracle)

Major Problem

The Load Data Warehouse - Incremental is taking much longer than the Full Load.

Fixed in 15.4.1 SP

STR:
1. On a large database (500 GB), run Load Data Warehouse - Full - takes about 900 min
2. Now run Load Data Warehouse - Incremental - it will take about 1200 minutes
Expected Results: Incremental to take much less time than Full.
Actual Results: Incremental takes more time (about 1000-1200 minutes).

DE39047
Major Problem
Fixed in 15.4.1 SP

Create DWH Trend job fails with error ORA-01841: (full) year must be between -4713 and +9999, and not be 0 or ORA-01722: invalid
number due to View columns position
STR:
1. Issue might be related to a specific customer database or configuration details not available here. Contact CA Support for more details about this resolved
issue.
2. Run Create DWH Trend job
Expected Results: job to run fine
Actual Results: Error message: ORA-01841: (full) year must be between -4713 and +9999, and not be 0orORA-01722: invalid number.

DE39058
Cosmetic

Ideas visible to wrong sec obs
[CONVERTED FROM CASUP 00922795.]

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Resource 'Admin' belongs to Group 'GROUP-1'
2. Group 'GROUP-1':
- OBS Unit Access Rights:
Idea - Edit for OBS Unit 'Security OBS:Confidential'
Idea - View for OBS Unit 'Security OBS:Confidential'
Idea - Edit for OBS Unit 'Security OBS:IT'
Idea - View for OBS Unit 'Security OBS:IT2'
- Global Access Rights:
Idea - Create Idea - Navigate
3. Resource 'Admin' belongs to 'Security OBS:'=/NODE-1
4. Security OBS: Used for Access Rights Associated with Idea object
5. Open one of those Ideas. Check properties -> Full View: filter by user name = Admin, the user is found.
6. Click on the Key Icon. It shows: Idea - Create granted throrugh Group 'GROUP-1' Global Idea - Navigate granted throrugh Group 'GROUP-1' Global
7. Login to the PPM application with user 'admin'
8. Navigate to Idea List
9. Observe idea
Expected Results: User should not be able to see Ideas that have OBS 'Security OBS'=/NODE-1
Actual Results: User sees the ideas that have OBS 'Security OBS'=/NODE-1

DE39141

Allocations are Zeroed out in MSP for Equipment and Material Resources and Roles

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Install the MSP New Driver and create an equipment resource (also reproducible with equipment role, material role, or material resource).
2. Set the Availability to 1 on the Resource Properties in PPM
3. Create a project and allocate the Equipment Resource to the project
4. The Equipment resource has a non-zero allocation:
5. Export the project to MSP Note: by MSP design, non labor resource/roles have no Max Units and no availability in MSP
Expected Results: Since we made no changes in MSP, the resource allocations should remain the same as they were in Step 4
Actual Results: The allocations are now 0
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DE39151
Cosmetic
Fixed in 15.4.1 SP

Unable to add Template Task External ID into a process where the project primary object has a template associated due to an expired
request alert
Unable to add the "Template Task External ID" into a process where the project primary object has got a template associated due to an Expired request Alert
STEPS TO REPRODUCE:
1. Ensure your system is configured correctly to respond to CSRF attacks: tokenCacheStrategy=""session"" is on your applicationServer node in your
properties.xml fileMake sure there is not a testMode=true program parameter on your app server instance. Make sure you do not have a tokenCacheCapacity
element on your applicationServer node. Restart your system if any changes are necessary.
2. Go to Administration > Data Administration > Processes
3. Create a new process where primary object is project and associate any project template
4. Ignore auto-start options and go to the start step
5. Create an action > system action
6. Ensure the Action is ""Copy Task WBS from Template""
7. Click the binoculars icon for the ""Template Task External ID""
Expected: The browse option should show list of "Template Task External ID"
Actual: You get an error: Expired request Alert: An expired request has been detected. Request has been cancelled.

DE39197

PPMOD_15.3_DEFECT - Date range filter field not working properly in custom object based portlet

Minor Problem

Users unable to use the filters for custom portlets.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create 2 attributes of DATE type under that Object. Name the attributes as ""Go Live from"" and ""Go Live to"". (for example)
2. Add both of these attributes under the Edit Layout view of that Custom Object. Create a new grid portlet selecting the newly created custom object as data
source. So, this is an Object based portlet.
3. Now, go to the List column section and add the following attributes: Name, ID, Go Live from, Go Live to, Created by.
4. Save and go to the List Filter section.
5. Add the following attributes in the filter layout: Name, ID, Go Live from and Go Live to. Save the changes and go to the Fields subpage under the List filter
section. Change the Display type to Date Range for both Go Live from and Go Live to fields. Save the changes.
6. Open the ""Overview"" portlet page and add a new tab there.
7. Add the newly created portlet in that tab. Save the changes. Create a custom object which will be a sub-object of Project.
8. Go to Home > Projects and open any of the existing projects. Go to the Subobject list page and start creating 4 or 5 instances for that sub-object.
9. For every instance, fill up the ""Go Live from"" and ""Go Live to"" dates. Now, go to the PPM home page, and navigate to the new Tab. The portlet, we
created, should be there. Expand the filter section. ""Go Live from"" and ""Go Live to"" fields would be there as Date ranges.
10. Select the ""Go Live from"" range in the filter section in such a way that you can sure which instances will fall within that.
11. Click on Filter.

Expected Results: Those instances are returned which are having ""Go Live from"" dates withing that range mentioned in the filter.
Actual Results: Either no rows are returned or all the rows that are having ""Go Live from"" dates within the given range are not returned.

DE39282

In the MSP New Driver, Actual work entered on a Saturday or Sunday gets pushed out to the next day

Minor Problem

In the MSP New Driver, Actual work entered on a Saturday or Sunday gets pushed out to the next day. This also pushes out dates of tasks in MSP if the end
date was a Saturday or Sunday where last actuals were entered.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. In PPM create a new project, open for time, with track mode of PPM.
2. Add one resource to the team.
3. Create a task and assign the team member to the task.
4. Go to the resource’s timesheet, and submit 3 hours of time on a Saturday (Example 10/21/17).
5. Approve the timesheet.
6. Wait 5 minutes then run the Post Timesheets job in order for the actuals to be posted.
7. Export the project to MSP.
8. Add Actual Work to a Task Usage Timescale view and view the actual work for 10/21 and 10/22.
Expected Results: 3 hours show for 10/21.
Actual Results: 2 hours show for 10/21, and 10 hours show for 10/22 This also happens if you submit time on a Sunday, some of the actual work gets pushed
out until Monday.
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DE39375

Project Earned Value Report Query: The PRJ_EV_HISTORY table has multiple records for the same Period Interval

Cosmetic
Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Run the following query that is run by the ' Project Earned Value' Jaspersoft report in the PPM database for one project.
-- Environments might have many projects with this issue, this is just an example project:
SELECT i.id AS project_id,
i.code AS project_code,
evpd.period_type AS period_type,
ev.period_number AS period_number,
ev.period_start_date AS period_start_date,
ev.period_end_date - 1 AS period_end_date,
ev.bac AS bac,
ev.etc AS etc,
ev.itd_bcws AS itd_bcws,
ev.itd_acwp AS itd_acwp,
ev.itd_bcwp AS itd_bcwp
FROM inv_investments i
INNER JOIN inv_projects pv ON i.id = pv.prid
LEFT OUTER JOIN cmn_lookups_v l2 ON i.progress = l2.lookup_enum
AND l2.lookup_type = 'INVESTMENT_OBJ_PROGRESS'
AND l2.language_code = 'en'
LEFT OUTER JOIN cmn_lookups_v l3 ON i.status = l3.lookup_enum
AND l3.lookup_type = 'INVESTMENT_OBJ_STATUS'
AND l3.language_code = 'en'
LEFT OUTER JOIN srm_resources m ON i.manager_id = m.user_id
INNER JOIN evm_period_defs evpd ON pv.ev_period_id = evpd.id
LEFT OUTER JOIN (SELECT epd.id,
CASE WHEN epd.period_type = 1 THEN 'W'
WHEN epd.period_type = 2 THEN 'M'
WHEN epd.period_type = 3 THEN 'Q'
WHEN epd.period_type = 4 THEN 'A' END pd
FROM evm_period_defs epd) pdnm ON evpd.id = pdnm.id
LEFT OUTER JOIN prj_ev_history ev ON i.id = ev.project_id
AND ev.object_type = 'PROJECT'
WHERE i.id =5021196
OR simply run:
select * from prj_ev_history
where object_type = 'PROJECT'
and project_id = 5021196
order by period_start_date

Expected Results: Only one row per period is returned in the query.
Actual Results: Various periods have multiple rows returned. For example, the weekly periods of 11/12/2017 to 1/7/2018 each have 5 rows and the period of
1/14/2018 has 4 rows.

DE39391

Datamart Extraction Job is failing

Minor Problem

Converted CASUP to DEFECT
00961203-Datamart Extraction Job is failing in on-premise PPM 15.3 environments with Oracle databases.

Fixed in 15.4.1 SP

The datamart extraction has never completed on DEV environment and fails with error:
java.sql.SQLException: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-20000: Error in NBI_EXTRACT_SP - Executing NBI_EXTR_PCF_SP: ORA-20000: Error in
NBI_EXTR_PCF_SP - executing NBI_PROJECT_CURRENT_FACTS_SP: ORA-20000: Error in NBI_PROJECT_CURRENT_FACTS_SP - Calling
NBI_PROJECT_FORECAST_SP since there are projects with Forecast: ORA-00001: unique constraint (CLARITY.NBI_PROJECT_CURRENT_FACTS_PK) violated
===================================
1. Obtain the CA PPM 15.3 dataset TEST_APP_SERVER: XXNAT:70000 Server: clarityNNN.ca.com
Username/password HIDDEN/niku SID: clarity Port: 15X1 Browser: http://NN-NAT:60201
2. We are able to reproduce the error: the table NBI_PROJECT_CURRENT_FACTS does not populate even though it has data in the view. The job has never
completed as the Administration > Datamart Settings currency shows not as read-only.
3. Tried to run the stored procedure (NBI_PROJECT_CURRENT_FACTS_SP) directly on the database but same error
4. We tried to find duplicate plan of records but none exist.
Expected: NBI_PROJECT_CURRENT_FACTS table populates.
Actual: NBI_PROJECT_CURRENT_FACTS table does not populate.

DE39437

NEW UX: Heat Map tag is not displaying under the correct color

Minor Problem

When hovering over Heat Map, the tag is not displaying under the correct color.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Log into New UI
2. Click on Staffing icon
3. Click on Settings
4. On the Heat Map section > Hover Over the colors
Expected Result: When hovering over the Heat Map colors, the ‘Under/Over Allocated’ tag should display a specific color.
Actual Result: When hovering over the colors, the ‘Over/Under Allocated’ tag remains as is on the left.

DE39438

NEW UX: Resource initials on staffing page, the beginning of the name is cut off

Minor Problem

When hovering over the initials for a resource on the Staffing page, the beginning of the name is cut off.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Log into New UI
2. Click on staffing icon
3. Click on a resource with a long name
4. Hover over the resource initials
Expected Result: The full name should appear.
Actual Result: The beginning of the name is cut off.
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DE39522
Major Problem
Fixed in 15.4.1 SP

XOG Error in Benefit Plan: java.lang.ClassCastException: com.niku.xmlserver.blob.NkCurve cannot be cast to com.niku.xmlserver.
blob.FiscalCurve
XOG Error in Benefit Plan after modifying StartPeriod or FinishPeriod:
- java.lang.ClassCastException: com.niku.xmlserver.blob.NkCurve cannot be cast to com.niku.xmlserver.blob.FiscalCurve
STEPS TO REPRODUCE:
1. Navigate to Financial Plans-)Benefit Plans
2. Created new benefit plan called B1 with Period Type = Monthly, Start Period = Jan 1, 2017-Jan 31, 2017 and Finish Period = Dec 1, 2017-Dec 31, 2017
3. Click on Detail tab and click on Add, Description = Test, Benefit Class = Reduce Cost, Benefit Subclass = Headcount
4. Now click on Return to go back to Benefit Plan list
5. Check flag for B1 plan and click on Actions in the upper right hand corner and click on Copy Benefit Plan
6. While Copying Benefit Plan change Finish Period to Dec 1, 2018-Dec 31, 2018 and click on Save.
7. Now that you created a copy of the benefit plan from step 6 above, you need to xog out that plan using input file below:
(?xml version="1.0" encoding="UTF-8"?)
(NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_read.xsd")
(Header version="13.0" action="read" objectType="benefitPlan" externalSource="NIKU"/)
(Query)
(!-- (Filter name="name" criteria="EQUALS")Copy of DITL Benefit Plan(/Filter)
(Filter name="code" criteria="EQUALS")Copy of DITL Benefit Plan(/Filter) --)
(Filter name="investmentCode" criteria="EQUALS")Antonio(/Filter)
(Filter name="name" criteria="EQUALS")Copy of B1(/Filter)
(/Query)
(/NikuDataBus)

8. You should get an output like below:
(NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_benefitPlan.xsd")
(Header action="write" externalSource="NIKU" objectType="benefitPlan" version="15.3.0.200"/)
(BenefitPlans)
(BenefitPlan code="Copy of b1" finishPeriod="Dec 1, 2018-Dec 31, 2018" investmentCode="Antonio" investmentType="project" name="Copy of B1"
periodType="MONTHLY" revision="0" startPeriod="Jan 1, 2017-Jan 31, 2017")
(Description/)
(Details)
(Detail detailName="test")
(Benefit/)
(ActualBenefit/)
(CustomInformation)
(ColumnValue name="obj_benefit_class")class01(/ColumnValue)
(ColumnValue name="partition_code")NIKU.ROOT(/ColumnValue)
(ColumnValue name="obj_benefit_subclass")subclass02(/ColumnValue)
(/CustomInformation)
(/Detail)
(/Details)
(CustomInformation)
(ColumnValue name="partition_code")NIKU.ROOT(/ColumnValue)
(/CustomInformation)
(/BenefitPlan)
(/BenefitPlans)
(/NikuDataBus)

9. Now add segment to the detail section of your plan you just xogged out and it should look like this
(NikuDataBus xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/nikuxog_benefitPlan.xsd")
(Header action="write" externalSource="NIKU" objectType="benefitPlan" version="15.3.0.200"/)
(BenefitPlans)
(BenefitPlan code="Copy of b1" finishPeriod="Dec 1, 2018-Dec 31, 2018" investmentCode="Antonio" investmentType="project" name="Copy of B1"
periodType="MONTHLY" revision="0" startPeriod="Jan 1, 2017-Jan 31, 2017")
(Description/)
(Details)
(Detail detailName="test")
(Benefit)
(segment finish="2017-01-31T00:00:00" start="2017-01-01T00:00:00" value="0"/)
(/Benefit)
(ActualBenefit/)
(CustomInformation)
(ColumnValue name="obj_benefit_class")class01(/ColumnValue)
(ColumnValue name="partition_code")NIKU.ROOT(/ColumnValue)
(ColumnValue name="obj_benefit_subclass")subclass02(/ColumnValue)
(/CustomInformation)
(/Detail)
(/Details)
(CustomInformation)
(ColumnValue name="partition_code")NIKU.ROOT(/ColumnValue)
(/CustomInformation)
(/BenefitPlan)
(/BenefitPlans)
(XOGOutput)
(Object type="BenefitPlans"/)
(Status state="SUCCESS"/)
(Statistics insertedRecords="0" failureRecords="0" totalNumberOfRecords="1" updatedRecords="0"/)
(Records/)
(/XOGOutput)
(/NikuDataBus)

10. Attempt to XOG it back in and you get an error below:
(NikuDataBus)
(Header action="write" externalSource="NIKU" objectType="benefitPlan" version="15.3.0.200"/)
(XOGOutput xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="../xsd/status.xsd")
(Object type="benefitPlan"/)
(Status elapsedTime="0.266 seconds" state="FAILURE"/)
(Statistics failureRecords="1" insertedRecords="0" totalNumberOfRecords="1" updatedRecords="0"/)
(Records)
(Record)
(KeyInformation)
(column name="externalSource")NIKU(/column)
(/KeyInformation)
(ErrorInformation)
(Severity)FATAL(/Severity)
(Description)com.niku.xmlserver.blob.NkCurve cannot be cast to com.niku.xmlserver.blob.FiscalCurve
java.lang.ClassCastException: com.niku.xmlserver.blob.NkCurve cannot be cast to com.niku.xmlserver.blob.FiscalCurve

Expected Results: To successfully XOG benefit plan that has start period or finish period modified in XOG file.
Actual Results: Users cannot use a process that modifies a benefit plan.
FATAL(/Severity) (Description)com.niku.xmlserver.blob.NkCurve cannot be cast to com.niku.xmlserver.blob.FiscalCurve java.lang.ClassCastException: com.niku.
xmlserver.blob.NkCurve cannot be cast to com.niku.xmlserver.blob.FiscalCurve
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DE39539

Timesheet hours for Application Incidents not showing n Portlets and Reports

Major Problem

Incident Actual Hours are not available for reporting or in and of the TSV portlets. This is the same on any type of NPIO.

Fixed in 15.4.1 SP

Steps to Reproduce:
1. Associate an incident with an NPIO. I used Application.
2. Assign resource to team and make sure they have the rights to post time to the associated incident
2. Have resource enter time to the incident.
3. Approve and post timesheet
4. Check application
5. Go to Team Detail and configure the TSV to show Incident Actuals
Expected Result: Incident Actuals show in TSV
Actual Result: Incident Actuals do not show in TSV. Incident Actuals are not available for reporting anywhere especially in DWH.
Workaround: There is no work around available. CA Support can provide an NSQL query portlet to at least show the incident actuals, but this does not help
with any of the OOTB potlets for capacity or resource planning.

DE39589

Generate invoices job fails

Major Problem

Converted from CASUP 00968035-Generate invoices job fails into a DEFECT.
The Generate Invoices Job fails with the following error:

Fixed in 15.4.1 SP

ERROR 2018-02-20 10:24:21,921 [Dispatch Generate Invoices-PGT : bg@RTNNN29 (tenant=clarity)] niku.njs (clarity:P4GUNN:14629005__19AE8EDE-3898-4DE1-AC6D-29E00F7A95DE:Generate Invoices-PGT)
Error executing job: 5612173 java.lang.Exception: invalid transaction id found:Processing adj_transno : [5086337] details : [{}] chargeback_type - C : debit_id - transId[0] c_trans_id :
[5767695] at com.niku.revenue.chargeback.invoice.TransactionUtils.generateAdjustmentsImpl(TransactionUtils.java:339)

STEPS TO REPRODUCE:
1. DB Info: RESTORE-PPM (14.3.0.10.28 (Patch 10))
2. Run the Generate Invoices job in the above environment
Expected Results: Generate Invoices job runs.
Actual Results: Generate Invoices job fails. (Issue is only reproducible with the customer data. We changed the Investment Financial Type to 'Internal' for the
project that invoice isn't generating for, but that didn't make a difference.)

DE39599

New Project Button in New UX Appears Even if User Doesn't Have Project Create Permissions

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Create a new user in PPM with the Project Management - Navigate global access right.
(Important: The user does NOT have Project - Create or Project - Create from Template access rights.)
2. Log in to the PPM New UX as the user created above. This should take you directly to the New UX Projects page.
Expected Results: New Project button is not visible since the user does not have access to create new projects.
Actual Results: New Project button is visible.

DE39606
Cosmetic

New UI > Applications > Time Entry User Lookup Field 1 shows inactive values
The New UI Timesheets does not display the Lookup > Time Entry User Lookup field 1 correctly as it is set in the Classic UI.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Classic UI > Home > Application. Create an application. Assign a resource to the team
2. Classic UI > Administration > Lookups > Time Entry User Lookup field 1 (PRTIMEENTRY_USER_LOV1).
Click Values tab Enter 4 values, e.g. val1 val2 val3 val4 and make the values active and make 1 value inactive.
3. Log in to New UI > Timesheets as the resource assigned to the application. Enter time on the application.
4. Review the lookup values in the User Value 1 field.
Actual: New UI shows all lookup values, even if inactive.
Expected: New UI should only show active lookup values.

DE39624

Reports scheduled from Reports and Jobs fail after a period of time

Major Problem

Default system and custom reports scheduled on the Reports and Jobs page run and suddenly the reports start failing. Custom reports are running against
the transactional DB. The error message received when the reports fail:

Fixed in 15.4.1 SP

The log error is: ERROR 2018-01-30 13:20:14,541 [Thread-212004] niku.njs (clarity:me1:21099943__D909634C-4F32-40BE-A89B-F6ADXX66FE9:none) Error
during adding file to DMS. com.niku.union.exceptions.DMSException: Document already exists:Capacity_vs_Demand_by_Resource_recurrence_1335989
9.pdf
STEPS TO REPRODUCE:
1. Navigate to Home>Reports and Jobs
2. Select a report from the list.
3. Select Scheduled and uncheck Immediately under When.
4. Select today's date and time for the start date
5. Scroll down and select Set Recurrence
6. Set the report to run via crontab, customer used ""*/15 * * * *"" to run every 15 minutes.
7. Submit the scheduled report.
Expected Results: Scheduled reports run every 15 minutes until paused or canceled.
Actual Results: Reports run as expected for a period of time, then fail. Once the scheduled report fails, it continues to fail.

DE39644

PPM URL with reportservice endpoint is allowing cross-Site Scripting

Major Problem

This security issue has been resolved in this release.

Fixed in 15.4.1 SP
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DE39663

Load Data Warehouse job failed after changing maximum size on the string attribute

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Create custom master object and check Include in the Data Warehouse flag
2. Create Test string type attribute with maximum size 20 and check Include in the Data Warehouse flag
3. Create at least one instance of the custom object and populate Test attribute created in the step 2 with data
4. Run Load Data Warehouse job with Full sync mode
5. Once job completes successfuly go back and update maximum size for Test attribute created in step 2 to 80 and click on Save.
6. Now go to the custom object instance created in step 3 and now update String value to something 80 characters long.
7. Run Load Data Warehouse job in Full sync again and observe that it fails.
Expected Results: Load Data Warehouse job should succeed
Actual Results: Load Data Warehouse job fails

DE39748

Cannot filter in Staffing module in the New UI when using an Ampersand '&'

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Log into PPM and go to the New UI
2. Go to the Staffing page
3. In the Resource-to-Investments, Investments-to-Resources, or Requests grids, enter something containing an ampersand, but that does not begin with an
ampersand (Example: R & S, or M & A)
Expected Results: Results are returned if there are any that include 'R & S' in the name. If no results, No results found.
Actual Results: The following error is thrown and the list is not filtered: API-1006 : The value ''R' for Attribute 'queryString' is not in expected format or is
invalid.

DE39760

Upgrade fails while creating datasourse in HDP

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Ensure on 15.3 you have HDP set up
2. Start PPM upgrade from 15.3 to 15.4
Expected Results: Upgrade should be complete
Actual Results: Upgrade fails with below error. In 15.4 upgrades, the ODATA job refresh fails to finish within the stipulated time.
[exec] [echo] Running: /fs2/clar/clarity/bin/admin odataservice createDatasource -dataSourceName SC22975tDataSource -adminUser 14 -adminPassword xxxxxxxx [exec] [exec]
Creating Data Source in OData Service Server and registering it in CA PPM... [exec] [exec] OData model refresh could not be completed in stipulated time frame. Please contact
System Administrator. [exec] [exec] Error occurred: com.niku.union.reporting.odata.ODataServiceException: Error occurred while creating V2 Data Source [exec] [exec] Check
admin.log or use -verbose for more information. [exec] [exec] Result: 1

DE39765
Major Problem
Fixed in 15.4.1 SP

MSP New Driver error: We're sorry. There seems to be a problem with this file that keeps us from opening it. Please try using a
backup copy if available.
In the MSP New Driver, we receive an intermittent error message: ""We're sorry. There seems to be a problem with this file that keeps us from opening it.
Please try using a backup copy if available."" Reviewing the XML, it shows that the issue appears to be due to Notes being corrupted upon export from PPM,
where characters are incorrectly appended to the end of tags.
STEPS TO REPRODUCE:
1. In MSP create a new project
2. Create one new task with a Start and Finish Date
3. Double click on the task
4. Click on the 'Notes' tab
5. Paste a large quantity of text into the Notes field (I used about 3,000 characters) and click OK
6. From the CA PPM Integration tab, click the Save As button to save the project to PPM as a new project
7. Attempt to open the project from PPM to MSP (Note if you do not receive the ""We're sorry error at this step, repeats steps 2-7 above until the error is
generated, it took 3 attempts in one test, but can take more)
Expected Results: Project Opens successfully with task(s) displayed
Actual Results: Receive the following MSP error and the project does not open. ""We're sorry. There seems to be a problem with this file that keeps us from
opening it. Please try using a backup copy if available."" Additionally, if you look at the XML, unexpected characters are randomly added to the end of notes
tags.
Workarounds:
1. Sometimes, making a change to the Note in PPM, such as removing a '.' at the end of a line in a note that has corruption in the tag helps, but in some
instances it keeps coming back.
2. If that doesn't help, as a temporary workaround, reducing the number of notes in the project has helped to allow the project to open. The Notes
information can be stored locally in a document until the issue is resolved where the Notes can then be added back to the tasks.

DE39782

'Refresh OData Model' job does not behave correctly when the OData model refresh takes more than 5 mins

Minor Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Ensure on 15.3 you have HDP set up
2. Use a system where OData model refresh takes more than 5 mins or change the timeout to very low value to recreate the issue.
Note: 5 mins is the timeout time for “Refresh OData Model” job and currently it is not configurable.
It would be better if this can be configured at some place e.g. database or properties file.
3. Run “Refresh OData Model” job. The job would fail with an error which looks somewhat like this… “OData Refresh failed to complete within stipulated time.”
This is expected.
4. Run “Refresh OData Model” job again. The job fails immediately again with an error message… “Cannot start the OData Model Creation because it is
currently running.”
Expected Results: Job should wait the refresh completes or if timeout reaches error out indicating a timeout error.
Actual Results: Job fails immediately.
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DE39783

Jaspersoft error while importing content

Major Problem

When trying to import jaspersoft content to CA PPM 15.3, having Oracle as RAC Oracle setup, using the following command: admin content-jaspersoft csk userName superuser -password superuser. The following error is being received:

Fixed in 15.4.1 SP

Failed to import content for tenant java.lang.NullPointerException
STEPS TO REPRODUCE:
1) Setup a PPM 15.3 environment to be used with RAC Oracle instead of Oracle Standalone
2) Import jaspersoft content into the PPM 15.3 environment using the command -> admin content-jaspersoft csk -userName superuser -password superuser
3.) Set the JDBC connection in CSA like jdbc:clarity:oracle://:;serviceName (ensure servicename is small s)
Expected Results: Content should get imported
Actual Results: Content did not get imported, however failed with the following error: Failed to import content for tenant

DE39786

Jaspersoft report Project Storyboard has mismatched data

Major Problem

STR:
1. Fulfill all the report prerequisites
2. Run the Report Project Storyboard

Fixed in 15.4.1 SP

Expected Results: Data to be correct
Actual Results: Some data is incorrect (EV Values, CPI, SPI); we tried with the report from 15.4, same thing.

DE39815

Jaspersoft reports run from PPM Reports and Jobs fails intermittently due to job ID from Jaspersoft is missing

Major Problem

STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Run 5 recurring reports from PPM Reports and JOB giving a gap of 2 minutes
Expected Results: All Reports should be completed.
Actual Results: Few reports fail.

DE39860
Cosmetic

Finish Date on Fixed Duration Tasks Change After Posting Timesheets
STEPS TO REPRODUCE:

Fixed in 15.4.1 SP

1. Create a project
2. Staff a resource to the project team
3. Create two tasks
- Task T1 is a Fixed Duration task with dates between 3/12/2018 - 3/30/2018
- Task T2 is a Fixed Duration task with dates between 6/1/2018 - 6 /15/2018
4. Assign the resource to both tasks.
- Assign the resource to T1 with dates between 3/12 - 3/26
- Assign the resource to T2 with dates between 6/1 - 6/8
5. Post a timesheet for the resource for the week of 3/12 - 3/18
(To reproduce the issue, make sure you add time entry for only T1 in the timesheet. If you add for both T1 and T2, the issue won't be reproducible)
Expected Results: The finish date for Task T2 remains at 6/15
Actual Results: The finish date for Task T2 is now 6/8.
Workaround: The only workaround is to have the assignment have the same finish date as the task finish date. Using the above STR on versions 14.3-14.4, the
task finish date on T1 would also move, to 3/26. However, on 15.1 and later versions this no longer occurs as the following defect was fixed as of 15.1: CLRT
-80126: Task finish date is retracted after Posting actuals via Timesheet even though the ""Fixed Duration"" setting is checked. The issue in the STR is still
reproducible as this was not one of the scenarios addressed with CLRT-80126. The STR is also reproducible if T2 was on a different project entirely.

DE39870

Copy Timesheet dropping one Incident

Minor Problem

Converted from CASUP 00973026-Copy Timesheet dropping one Inciden

Fixed in 15.4.1 SP

Steps to Reproduce:
1. As an example we use: Resource Mary Demo 5047746 for time period 3/4/18
2. Go to an open timesheet for this resource.
3. Populate the timesheet
Expected Results: Number of incidents should remain the same
Actual Results: For each subsequent week, the number of incidents decrease by 1 and it is the 2nd one that always gets removed.
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DE39915

ETC in Task Assignments TSV section (ETC By Period) shifts depending on value specified in 'Time Period Offset'

Major Problem

ETC by Period field values on the Task Properties page under Assignments in the TSV section shift depending on the value specified in Time Period Offset
when Start Date option selected is Other Date.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a Task with with Start / Finish dates - 19th March 2018 - 6th April 2018
2. Assign a resource to the Task
3. From the Task Properties => Assignments page, click on the 'Options' button => Configure => Fields to open 'List Column Fields'
4. Click on the Properties icon of the field 'ETC BY Period'
5. In the 'Time Scale' section under Start Date, click to select option => 'Other Date' and specify value 'Start'.
For 'Time Scale' specify 'Week'.
For 'Number of Time Periods' specify
7. For 'Time Period Offset' specify value -1.
6. Click on 'Save And Return' button to return back to Task Assignment page.
7. From Task Properties => Assignments page enter the following data in the 'ETC By Period' section.
For week beginning 19 March enter 5 hours, week beginning 26 March enter 6 hours, week beginning 2 April enter 7 hours.
8. Click Save.
Expected Results: Data entered should remain in the week entered.
Actual Results: Weekly Data entered shifts back by one week. If the 'Time Period Offset' value specified is '-2' then backward shift will be two weeks.

DE40016

15.4 Issue with Risks, Issues, Change Requests

Major Problem

New UX Only if there are Financial Plans
Any OD Customer behind the portal cannot access Risk, Issues, Change tabs after clicking on the Financials Tab if there are financial plans. Projects without a
financial plan do not appear to have the issue.

Fixed in 15.4.1 SP

Steps to Reproduce:
1. Find a project with a financial plan
2. Log into New UX
3. Click on Risks, Issues, Change tab.
4. Note the screens render.
5. Click on Financials Tab
6. Click back on any tab in step 2.
Expected Result: Screen renders
Actual Result: Screen does not render and there is a black X at the top. Clicking on the black X brings you back to the /pm projects page
Workaround:
A) Click on Documents tab.
OR:
B.) Change to another cost plan if one is available.

DE40067

Copy cost plan bad user experience

Minor Problem

Whenever user copies a costplan that has large number of rows (~500 rows), the operation takes a long time. But the user is not aware of it as the COPY
module is still open and keeps on clicking the COPY button multiple times (as he is not aware of what is happening in the back end).

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a Cost Plan with more than 500 rows in the New UI
2. Click on ""Copy"" button of the New UI
Expected Results: The pop-up appears immediately, with the copied Cost Plan's details
Actual Results: The pop-up takes time to come up, and in the meanwhile, the user can click on Copy multiple times.

DE40084

About the phenomenon in which English display is mixed

Minor Problem

We can see both Japanese and English on the personal setting window of portlet. We can see the same on all filter portlet. We cannot see the same on nonfilter portlet.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a Grid portlet
2. Create a filter portlet.
3. Locate the Grid portlet and Filter portlet on a tab.
4. Go to tab and show the Grid and Filter portlet.
5. Set japanese to Language on account setting and select configure on filter setting. I can see that Portlet is in English on Layout tab. This is the problem. I
can see that Portlet is in English on field tab. This is the problem. I can see that General, Name, ID, Description and Restore Default are in English on General
tab. This is the problem. On the other hand, when I select configure on portlet setting then I can see thecorrect Japanese in List filter Section, List column
section and General tab.
Expected Results: When we select configure on filter setting then we can see Japanese on Layout, Field and General Tab.
Actual Results: When we select configure on filter setting then we can see English on Layout, Field and General Tab.
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DE40088

Unable to export portlet Japanese characters to csv file

Major Problem

Exporting a portlet in Japanese Characters (Project List page for example) to CSV does not export characters correctly. File shows junk. Export to Excel works
fine.

Fixed in 15.4.1 SP

Steps to Reproduce
1. On Admin/Resource for a resource choose Language as Japanese
2. Login as that resource/user.
3. Go to the Project List Page
4. Choose Export as CSV (It says CSV ... in the dropdown)
5. Look at the csv opened in Excel

(I left my Locale as English.)

Expected Result: Characters should show correctly.
Actual Result: They look something like this ã‚¹ãƒ†ãƒ¼ã‚¿ã‚¹ ãƒ¬ãƒ ãƒ¼ãƒˆ
Workaround: None.

DE40163

Task Board View not displaying in new UX (15.4)

Major Problem

Any OD Customer behind the portal cannot switch between Tasks List and Board views. If they are on the Board View even when clicking on List view, the
Board View remains. Same thing happens if user is already on List view.

Fixed in 15.4.1 SP

Steps to Reproduce:
1. OD Customer behind the portal
2. Log into New UX
3. Click on Tasks tab.
4. Note if defaulted to Task view or Board view.
5. Click on the other view.
Expected Result: Screen changes to other view
Actual Result: Screen remains on the current view.
Workaround: Double click on the view you want which brings you back to the main screen and then sometimes the view will switch.

DE40259

Portfolio Sync Job very slow

Major Problem

00977387-Portfolio Sync Job very slow

Fixed in 15.4.1 SP

In one environment with one portfolio with 4 investments, the job takes 8-10 minutes.
After restoring the database, the same portfolio job takes only 21 seconds.
STEPS TO REPRODUCE:
CA Support engineers cannot reproduce the defect.
Expected Results: Small Sync job should run a lot faster.
Actual Results: Small sync jobs taking 8-10 minutes.

DE40304

Getting error message in Project Earned Value Report

Major Problem

Steps to Reproduce:
1. Configure and run Load Data warehouse job.
2. Run Load Data warehouse Access Rights job.
3. Run ""Project Earned Value Report"" with no filters selected.

Fixed in 15.4.1 SP

Expected Result: Report data should be displayed without any errors
Actual Result: Getting error ""Error filing Report"".
Caused by: org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object '' with class 'java.lang.String' to class 'java.math.BigDecimal'

DE40362

When creating new adhocs getting duplicate project records

Major Problem

MS SQL Server DWH_INV_SECURITY_V creates two records for the user/investment when rights are provided through OBS as well as having Global Rights. This
causes duplicate projects to show on Report Parameters in Reports and Jobs as well as in ad-hoc views.

Fixed in 15.4.1 SP

Steps to Reproduce:
Only reproducible on MSSQL for PPM 15.3 and 15.4
1. Create an OBS and associate it to the Project object
2. Create a unit in the OBS
3. Mark the OBS to be used for Access Rights
4. Create a project and associate it to the unit from Step2
5. Create a Group from Administration - Groups
6. On the Group's Access Rights - select the OBS Unit Access Rights
7. Click on Add, and Add the 'Project - View Management' access right, for the OBS, select the OBS unit from Step2
8. Go to Administration - Resources and open the properties to an existing user
9. Under the Resource Properties, go to the Groups tab, and add the group created in the previous steps
10. Go to Resource's Access Rights - Global, and add the 'Project - View Management - All' global right to the user
11. Go to Home - Reports and Jobs, run the Load Datawarehouse job
12. Once the Load DWH job completes, run the 'Load Data Warehouse Access Rights' job
13. Once the access rights job completes, run the following query: select * from dwh_inv_security_v where user_uid = '' and investment_key =
Expected Results: The query returns one row where the Global_View_Right = 1
Actual Results: The query returns two rows, one where the Global_View_Right =1 and another where the Global_View_Right =0
Workaround: No feasible work around; fix for one user during investigation was to remove OBS rights.
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DE40368

Duplicated Hierarchy record in INV_HIERARCHIES

Major Problem

CONVERTED from CASUP 00990585-Duplicated Hierarchy record in INV_HIERARCHIES

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
Special case where data is not upgraded properly. There is supposed to be a row with parent_id = null if a child does not have a parent node. If a child has a
parent, it should have that record showing the parent_id = null in addition to a row that shows the parent_id and child_id populated showing the relationship.
The following query is used as an example:
SELECT
*
FROM INV_HIERARCHIES H
where child_id in (
8052242
)
8547055 5081205 8052242
8547044 null 8052242
if severing the relationship via hierarchy > parent page
it shows the correct row.
8547044 null 8052242

Expected: Upgrade script checks for missing rows and inserts them. For example, POSTUPGRADE_FIX_HIERARCHIES.xml.
Actual: Although the upgrade takes care of new parent-child node relationships, it does not account for the past relationships. The upgrade did not take care
of the records that were affected; there was no correction script to add records to the INV_HIERARCHY table that will add parent_id = null condition for any
child_id that does not have a parent.

DE40388

Error API-1030 after trying to change the password in the New UX with the 'Force Password Change' option

Minor Problem

The below error message is displayed after a resource signs into the New UX when the 'Force Password Change' option is set to on for that resource.

Fixed in 15.4.1 SP

""Error during login API-1030 : Password is expired or needs to be changed. Contact your system administrator for necessary action.""
This seems to be the same as a previous defect DE37066, which was supposed to be resolved in PPM 15.4, but the same behavior seems to be occurring. The
only difference is that in 15.4 the 'Forgot Password' feature COULD be used to reset and change the password to successfully login through the New UX. The
underlying problem is still there. Users signing on for the first time often have the 'Force Password Change' option set on for them and won't be able to sign
in and can cause a poor experience.
STEPS TO REPRODUCE:
1. Create a resource in Home > Administration > Resources, or use an existing one
2. Navigate to the Properties tab for that resource
3. Check on the 'Force Password Change' box
4. Have the resource sign in through the New UX
Expected Results: The user signs in and is shown the proper page to change their password as the defect causing this was reportedly fixed in 15.4
Actual Results: The user remains on the login page and is shown the error message ""Error during login API-1030 : Password is expired or needs to be
changed. Contact your system administrator for necessary action.""
WORKAROUND: Three workarounds listed below (Option 3 is NOT available in 15.3 for the customer I reported this for; telling them to upgrade to 15.4 would
be tantamount to telling them just use that workaround since the underlying problem has not been resolved)
1. Uncheck the 'Force Password Change' option on the accounts of the resources and set a password that they can provide to the user. The user can then
either continue to use that password or use the 'Forgot Password' feature to change the password to something else, if needed.
2. When the 'Force Password Change' option is set to true for the resources, they can have the user sign in through the Classic UX, where they can change
and set their password with no problem. The 'Force Password Change' option is turned off after those steps are taken.
3. Users can use the 'Forgot Password' feature because that does seem to function correctly in 15.4 since the 'Force Password Change' option is correctly
turned off after those steps are taken.

DE40396

CA PPM New UI Displays Hours instead of Days in Effort Metrics

Minor Problem

In CA PPM New UI when you select a Project and go into the 'STATUS' tab, in the 'Effort Metrics' section the 'Total Hours' and'Total Hours Spent' attributes are
not correctly converted to hours if in Classic PPM the Default Display Unit For Work Effort is Days (in Administration->Project Management->Settings) and
also set as Days at the instance level.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. In CA PPM - Administration -> Project Management -> Settings -> 'Default Display Unit for Work Effort' is set to Days
2. Create a Project and Task in CA PPM Classic with Start / Finish Dates [2 April 2018 - 31 May 2018].
3. Allocate a labor resource to project (100% Allocation with 8 hours availability) and assign the resoucre to the Task.
4. ETC is the task is 44 days
5. Post Actuals for one day on say 12 April 2018 so that remaining ETC reduces to 43 days
6. Open the Project in CA PPM New UI and click on the 'STATUS' tab.
Expected Results: 'Total Hours' and 'Total Hours Spent' attributes should display values in hour as per labels on attributes.
Actual Results: 'Total Hours' and 'Total Hours Spent' attributes display values which are really days and not hours.
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DE40407

Updating Subproject Dates does not update the Proxy Task Duration on the Master Project

Cosmetic
Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a project, Project A with a total duration of 2 days (4/12-4/13)
2. Create a second project, Project B
3. Add Project A as a subproject of Project B
4. On the master project, Project B, go to the Task list or PPM Gantt and verify that the proxy task created for the subproject has a duration of 2 days
5. Go to the properties of the subproject, Project A, and extend the finish date to 4/20 (the total duration is now 7 days)
6. Go to the task list page or the PPM gantt for the master project, Project B
Expected Results: The duration for the subproject proxy task should now be 7 days.
Actual Results: The duration for the subproject proxy task remains at the old duration of 2 days.
- The dates however have correctly updated to show 4/13-4/20.
Workaround: Remove the subproject from the master project and re- add it. This will force the duration to recalculate.

DE40475
Cosmetic

'service clone app' fails java.lang.IllegalArgumentException
Cannot run multiple app and bg service instances. Attempting to clone app service via CSA or command line fails with an exception being reported.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Log into CSA.
2. Click on the All Services in the left hand pane.
3. Check the CA PPM Application service type
4. Click the ""CLONE"" button.
Expected Results: There is a new application service instance added to the list of available services.
Actual Results. No service is added and the nsa-ca.log reports the following exception
ERROR 2018-04-13 05:47:37,183 [NSA Job (10.162.4.85:9091)] niku.nsa (none:none:none:none) Failed to clone service: app^M java.lang.
IllegalStateException: java.lang.IllegalArgumentException: 'null' is not a valid ApplicationServerInstanceTypeServiceTypeType at org.exolab.
castor.xml.handlers.EnumFieldHandler.setValue(Unknown Source) at com.niku.union.utility.ObjectUtil.clone(ObjectUtil.java:125) at com.niku.
union.utility.ObjectUtil.clone(ObjectUtil.java:58) at com.niku.nsa.service.ServiceUtil.cloneApplicationServerInstance(ServiceUtil.java:151) at
com.niku.nsa.service.ServiceUtil.cloneApplicationService(ServiceUtil.java:98) at com.niku.nsa.xbl.handlers.ServiceJob.clone(ServiceJob.
java:111) at com.niku.nsa.xbl.handlers.ServiceJob.runCmd(ServiceJob.java:79) at com.niku.nsa.xbl.handlers.AbstractJob.run(AbstractJob.java:67)
at java.lang.Thread.run(Thread.java:745)

DE40517

Resources from Agile Central fail to get synced into PPM, when the count of unique owners is greater than 20

Major Problem

PPM and Agile Central fail to hold the correct Resource related information.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Configure the Agile Central integration as AC to PPM
2. Create a project in PPM and select the integration previously configured
3. Run the Synchronize Agile Central job to create the initiative in AC
4. Create more than 20 features for the initiative in AC
5. Assign a different owner to each feature previously created
6. Run the Synchronize Agile Central job again
Expected Result: All features are created as tasks, and owners are either created as team members or display in the Missing Resources portlet.
Actual Result: Some resources are missing.

DE40535
Cosmetic
Fixed in 15.4.1 SP

New UX Auto-numbering is not preventing people from editing the Cost Plan ID
Cost Plans with Auto Number on Plan Code (ID) allows you to change the ID on the Plan Settings Page. Per our award-winning CA DocOps documentation,
the Plan ID should not even show on the Settings if there is auto-numbering on the field.
Steps to Reproduce:
1. Activate Auto Number on the Cost Plan Object => Plan Code
2. In New UX Create a new Cost Plan
3. Notice on the create there is no place to enter the ID/Code
4. Populate the plan and make it the plan of record, though you do not have to do these.
5. Go to Settings
Expected Result: Plan ID is not shown on the page and therefore would not be editable.
Actual Result: Plan ID shows on the page and you can change it. The update is then reflected in Classic UI as well.
Workaround: None.

DE40801

Oracle table analyze job gathers statistics by estimate percent

Minor Problem

Running this job by estimate percent is inefficient, as compared to running it by Auto Sampling

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Navigate to the Jobs page
2. Run Oracle table analyze job.
Expected Result: The job is expected to collect via Auto Sampling as well. Or the application provides an alternate way of running Oracle table analyze job.
Actual Result: The jobs runs through Estimate Percent.
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DE40820
Cosmetic
Fixed in 15.4.1 SP

Special Characters incorrectly displayed for the logged in user first and last name in upper right corner of Classic PPM
Resources with Special characters in their name are incorrectly displayed for logged in user's first name in upper right corner of page (where the about and
help action is located). The name appears correctly in other areas of Classic PPM and it appears correctly in the NEW UX logged in user's name field.
STEPS TO REPRODUCE:
1. Log into CA PPM
2. Navigate to Administration > Resources
3. Create a new resource with first and last name 'Frédéric'
4. Log out and log in as the new user - look at the upper right corner where the logged in user's first and last name is displayed
Expected Result: Name is correctly displayed
Actual Result: Name is incorrectly displayed as 'FrÃ©dÃ©ric FrÃ©dÃ©ric'

DE40968

Login name gets garbled after PPM was upgraded to 15.4

Minor Problem

On 15.4, if user name, such as Last Name and First Name, contains multiple byte characters, they get garbled.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a resource with multiple byte characters in First Name and Last Name.
2. Log into PPM and see a login name displayed at top of the screen.
Expected Results: The Login User name with double byte characters are displayed properly.
Actual Results: The Login User name with double byte characters get garbled.

DE41126

Chargeback errors after 14.2 upgrade

Major Problem

This is a result of case 01073248 where Generate Invoice job is failing with Missing or Invalid Debit Rule even though the rule is correct.

Fixed in 15.4.1 SP

CBK_GL_ALLOCTION.cost_type is being populated with NULL instead of (null)
It was found that 14.3 Upgrade script adds the new field CBK_GL_ALLOCATION.cost_type and updates it incorrectly as NULL instead of (null)
Steps to Reproduce:
1. Post transactions to WIP
2. Run Generate Invoice job
Expected Result: Most, if not all transactions process
Actual Result: All transactions as stuck under Messages with error Missing or Invalid Debit Rule

DE41199
Cosmetic
Fixed in 15.4.1 SP

Users - Action Tracing wrong default value in Spanish languages
'Action Tracing' default value is not set in Off when you try to create a resource in different languages. For example in English default value is 'Trace Off' and in
Spanish Language is set to 'Instrucciones de seguimiento'. It looks like is sorting alphabetically and since the name in different language does not have the
same order.
STEPS TO REPRODUCE:
-Configure the language for the user in Spanish
-Go to Administracion > Recursos -Click on 'Nuevo' Button.
Expected Results: 'Seguimiento de la acción'('Action Tracing' in English) should show 'Seguimiento Desactivado'('Trace Off' in English)
Actual Results: 'Seguimiento de la acción'('Action Tracing' in English) is showing 'Instrucciones de seguimiento'

DE41200

Oracle Privilege Access Violations

Major Problem

The following are possible deviations from Oracle standards
GRANT UNLIMITED TABLESPACE TO CLARITY: This should not be needed if the application schema account has unlimited quota on their own tablespace.
10.2, ‘connect’ and ‘resource’ roles had many privileges but these have all been removed.
GRANT CONNECT TO CLARITY: These are deprecated privileges.
GRANT RESOURCE TO CLARITY: These are deprecated privileges. Prior to Oracle 10.2, ‘connect’ and ‘resource’ roles had many privileges but these have all
been removed.
GRANT SELECT_CATALOG_ROLE TO CLARITY: Should provide a list of the exact data dictionary views that they require, rather than requesting this role.

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
To set up PPM Database you need below permission
• GRANT CONNECT TO CLARITY and GRANT RESOURCE TO CLARITY: These are deprecated privileges. Prior to Oracle 10.2, ‘connect’ and ‘resource’ roles had
many privileges but these have all been removed. ‘CREATE SESSION’ should be sufficient instead of the roles above. As of 10.2 the connect role only contains
create session. 12.1 included the set container. The RESOURCE privilege has these and is required for PPM to work. Otherwise we will have to give these
privileges individually. Giving them individually will enable us to remove RESOURCE if needed.
• GRANT UNLIMITED TABLESPACE TO CLARITY: This should not be needed if the application schema account has unlimited quota on their own tablespace.
We need to make sure the USER tablespaces are set to unlimited or created as BIG FILE tablespaces.
• GRANT SELECT_CATALOG_ROLE TO CLARITY: The vendor should provide a list of the exact data dictionary views that they require, rather than requesting this
role.
Expected Results: The roles should be revoked.
Actual Results: The roles are still documented.
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DE41217

Projects missing in DWH_INV_TEAM_PERIOD_FACTS table

Major Problem

Actuals posted out of allocation ranges are missing from DWH views. If a resource posts time after their allocation dates the actual hours (and periods) will not
be in DWH. Upon further investigation the views
• dwh_inv_team_ru_per_facts_f_v
• dwh_inv_team_ru_per_facts_m_v
• dwh_inv_team_ru_per_facts_w_v
are joining back to dwh_inv_period_facts and this table only brings in period_facts for the actual allocation slices (slice ID = 6)

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
1. Create a project starting on 3/1/18 and finishing on 5/31/18
2. Create a task starting on 4/16 and finishing on 4/17
3. Add a resource to the project team with allocation starting on 3/1/18 and finishing on 3/31/18 – Hard – 100% (does not need to be Hard booked)
4. Post 8 hours for the resource with the 4/16 period.
5. Run all necessary jobs in PPM and DWH
6. Query the dwh_inv_team_ru_per_facts_m_v filtering by the project.
Expected Results: The query will return actual hours for April
Actual Results: The query only returns data through March (to match the allocation dates)
Workaround: Change allocation dates to the end of the project. Not recommended.

DE41370

Run Reports (Auto) is classified as a Restricted Right

Major Problem

Access Right 'Run Reports (Auto)' is classified as a Restricted Right

Fixed in 15.4.1 SP

STEPS TO REPRODUCE:
Check Run Reports (Auto) access right. (Check the license counts by user portlet.)
Expected : Report Run (Auto) access right is View-Only.
Actual: In the license counts portlet, the users with this access right are included in the count of Restricted license types.
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