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Release Notes
Welcome to CA Workload Automation iXp.

This section contains information on the CA Workload Automation iXp release.

Release Notes 11.4.00
This section describes new features, changes to existing features, fixed issues, supported platform information, system
requirements, and known issues.

New Features 11.4.00
This section includes new features in CA Workload Automation iXp Release 11.4.00:

Monitoring AutoSys Workload Automation Version 12.0 jobstreams is now supported.

You can now create, modify, and delete the following job types:

• CMD
• BOX
• FTP
• FW
• FT

Changes and Enhancements to Existing Features 11.4.00
This article details the changes and enhancements to existing features in CA Workload Automation iXp Release 11.4.00.

• Removed old non-functioning perl upgrade scripts from /contrib folder.
• Signed Jars expiration date for this release is "Mon Oct 17 23:59:59 GMT 2022".
• The iXp clients (iXp Admin, GUI, and CLI tools) communicate with the iXp server through the Tomcat HTTP or HTTPS

connector. As part of the communication protocol some HTTP meta-headers are exchanged like "Content-Type". Since
product inception iXp has sent "application/ixp"; however after review, a more appropriate response would have been
"application/octet-stream". As such, iXp has been adjusted to respond accordingly.

• The list of supported AutoSys versions with iXp r11.4-GA is now restricted to r11.3 or later. For further information on
supported platforms see the Compatibility Matrix.

Fixed Issues 11.4.00
This article details the issues fixed in CA Workload Automation iXp Release 11.4.00.

• Problem Record: 99
When trying to utilize the Migration Wizard to move jobs between various AutoSys servers (such as PROD, QA, or
TEST) an invalid SendEvent permission check was performed on the target AutoSys instance and always failed.

• Problem Record: 105
The Signed Jars shipped with previous versions of iXp were signed with a date and time marked as CDT (U.S. Central
Daylight Time). However, in some locales the CDT format was not understood by the Java VM and Operating System
itself, resulting in the inability for the iXp server to detect when the Signed Jars would be expiring. An error message
displayed on log in, as well as being logged within the iXp logging system. This has been fixed by shifting the expire
time to use GMT format.

• Problem Record: 110
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When creating a custom report and selecting a non-default RowCount through a drop-down, the RowCount value was
saved to the server but ignored when the Report was reloaded from the server (after the GUI is closed or user log off
or log in).

• Problem Record: 111
When trying to override a job definition through the Job Editor, the resulting JIL would incorrectly try to redefine the
job_type: attribute, resulting in the AutoSys AppServer rejecting the override. Overriding the job through the iXp GUI
JIL interface was still possible as a workaround.

Known Issues 11.4.00
This article details the known issues in CA Workload Automation iXp Release 11.4.00.

• When using the iXp Migration Wizard, the UserID being used for security checks is the OS (Windows session) user.
This may cause confusion due to the fact that a non-OS user (such as iXpAdmin) might have logged into the iXp GUI
to perform migration activities.

• The max RowCount for a custom report is indicated as "No Limit"; however, for server performance and practical
reasons, the limit is actually 10,000 rows.

• Launching the iXp using the iXp Client GUI displays a version mismatch in an upgraded environment.
To resolve this issue, use the Java Webstart to launch the application or use the ixp.war file from the ixp-
distrib-11.4.0.134.tar file.
Use the respective command from the following list to start the iXp AdminTool or iXp GUI application from jnlp:

• javaws: http://<iXP_SERVER_NAME>:<port>/ixp/AdminTool.jnlp
• javaws: http://<iXP_SERVER_NAME>:<port>/ixp/iXp.jnlp

This issue is fixed in 11.4.00 Patch#2.

Changes in 11.4.00 Patch 2
This section describes the issues that are fixed in 11.4.00 Patch#2:

WARNING

• Before you apply 11.4.00 Patch#2 (patch number 99111179), you must install Release 11.4.00-GA as a
prerequisite.

• For more information about applying these patches, see the Readme files in the patches.

NOTE
This patch includes all fixes from previous patches.

Fixed Issues

iXp GUI STANDALONE INSTALL DOES NOT CONNECT TO UPGRADED iXp SERVER

Problem Record:14337

After applying iXp r11.4.0.135 (Patch#1), a standalone installation of iXp GUI reports an invalid version number and fails
to connect to the iXp server.

CONFIGURABLE iXp GUI STALE DATA ALERT

Problem Record:14336

When the iXp server has taken more than five minutes to process an AutoSys instance's job stream (inclusive of all jobs
and their definitions), it notifies every logged in iXp GUI user that the server's data is stale. This notification manifests on
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the iXp GUI as a popup window which the end user must manually click on, each time the iXp GUI makes a refresh call.
For much delayed processing or periodic refresh intervals, many alerts can be displayed to the user.

A new server configuration variable to be placed in <IXP_HOME>/etc/server.conf can be set to override the five minute
threshold, server-wide. After updating the configuration parameter, the iXp server must be restarted.

For example, the Stale data alert popup displayed to iXp GUI users will now be displayed only if processing of an AutoSys
instance has taken more than nine minutes.
IXP_SITE_STALE_DATA_ALERT_TIMEOUT=9

iXp SERVER OCCASSIONALLY PERFORMS UNNECESSARY FULL RELOAD

Problem Record:14335

Under certain conditions, the iXp server will determine that it needs to fully reload all of an AutoSys instance's jobs' data
(such as job definitions, job runs, global alarms) irrespective of the configured interval. Typically, the impact of this full
reload operation is small; however in case where the target AutoSys instance has a lot of parent/child relationships and
start conditions, this can impact iXp GUI job updates.

Changes in 11.4.00 Patch 1
This section describes the issues that are fixed in 11.4.00 Patch#1:

WARNING

• Before you apply 11.4.00 Patch#1, you must install Release 11.4.00-GA as a prerequisite.
• For more information about applying this patch, see the Readme file in the patch.

Fixed Issues

IXAUTOCAL_ASC MULTI-IMPORT OF CALENDARS DOES NOT CHECK SECURITY

Problem Record:12925

When a user used the CLI tool ixautocal_asc with the "-I" import option, or the iXp File->CLI->autocal_asc with the "-I"
Import option selected and if multiple calendar/ext.calendar/cycles were provided in the import, security was only checked
for the first calendar object. Audit record showed only the first calendar as imported.

IXAUTOCAL_ASC ALLOWS USER TO UPDATE CALENDAR WITHOUT PROPER CREDS

Problem Record:12924

When using iXp GUI File->CLI->ixautocal_asc panel to add or update a calendar and also deselecting the -I checkbox, the
security system skips proper security checks and allows any user to create or update a calendar. Also, the iXp audit trail
for this operation logs the user's action as a PRINT (aka read) operation instead of a create/update calendar operation.

IXAUTOCAL_ASC CYCLE IMPORT FAILURE

Problem Record:12923

When using iXp CLI tool "ixautocal_asc" to import a cycle, the import works only if a user's UpdateCalendar permission is
"*".

11.3.5 Incremental 8
This section includes new features and fixed issues in CA Workload Automation iXp Release 11.3.5 INCR8:
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WARNING

 If you are using CA Workload Automation iXp v7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply the following 11.3.5 INCR8 patches:

• CA Workload Automation iXp: SO10498
• CA Workload Automation iXp CA Third-Party Requirements: SO10496

For more information about applying these patches, see the Readme files in the patches.

 

New Features

Support for Newer Versions of Java

Support for Oracle Java 11 LTS and OpenJDK 11 has been added, for Client and Server side.

Note: For more information, see the Compatibility Matrix.

Added New iXp Client GUI and AdminTool installation Method (Loss of Java WebStart on Newer JRE versions)

With the release of Oracle Java 11 LTS, Oracle has removed the ability for desktop users to start Java Webstart
applications from their browser by simply clicking on a URL or hyperlink. Since iXp GUI and AdminTool both require
WebStart to function, we have enhanced iXp so that it can be installed locally on your desktop, and run like a normal
Windows application. If you are still using older versions of Java that still have WebStart support, iXp will continue to
operate as it always has (no change to functionality or interface).

Note: For installation instructions and usage, see the Install the iXp Graphic User Interface on a Windows Desktop.

Changes to Existing Features

Signed Jars Updated

With this release, the iXp client-side signed jars have been updated to use a Broadcom/Avago SSL certificate chain. Also,
the signed jars now expire on Oct 17, 2022.

User Interface Changes to the Conditions Page for a Job

When the number of conditions are lengthy for a job, iXp now displays only a limited number of conditions in the list. The
job details page displays all the conditions. 

Rebranding

Various Product Screens have Changed to Reflect Broadcom branding changes. Also some screenshots in the
documentation may still reflect older CA branding but the underlying content is still correct. 

11.3.5 Incremental 7
This section includes new features and fixed issues in CA Workload Automation iXp Release 11.3.5 INCR7:

WARNING

 If you are using CA Workload Automation iXp v7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply the following 11.3.5 INCR7 patches:
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• CA Workload Automation iXp: SO00503
• CA Workload Automation iXp CA Third-Party Requirements: SO00502

For more information about applying these patches, see the Readme files in the patches.

New Features

Support for Newer Versions of Perl

Problem Record: 44

In previous releases, iXp's Perl scripts supported only Perl 5.13 or lower versions. iXp now supports newer versions of
Perl.

This issue is fixed.

iXp Supports Larger Character-Lengths for Global Variable Names and Values

Problem Record: 47

iXp is updated to support larger character-lengths for Global Variable names and values. The maximum length of
the name and value depends on the CA Workload Automation AE version.

 For more information, see 'sendevent Command -- Set or Delete a Global Variable' in the CA Workload Automation AE
documentation.

New RunNum Column Added to Job Run Data Table

Problem Record: 67

A new RunNum column is added to the Job Information->Run Data->Job Run Data table. The RunNum column
indicates the run number that is associated with every run of a job. For more information, see View Job Information.

Support for IPv6

iXp has been certified in IPv6 network environments. Review known issues for caveats.

Filter Global Variables Based on CA Workload Automation AE Instance

Problem Record: 88

The iXp Global Variables panel (View->Global Variables) now supports additional filter functionality for global variables.
By default, global variables across all CA Workload Automation AE instances are listed. You can now filter global variables
by an instance name. For more information, see View Global Variables.

Changes to Existing Features

Default Setting of Database Connectivity Test Parameter is Modified

In the previous release, the default value of the following iXp parameter was
FALSE

 unless the user modifies it:

ixp.server.db.test.host.reachable

 9
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In the current release, the default value is set to TRUE.

Fixed Issues

Newly Created Cycle Not Shown in Calendar Name Drop-down 

Problem Record: 87

After you create a new cycle using the iXp Calendar Editor, the new cycle is not shown in the Calendar Name drop-down
even though it was created in CA Workload Automation AE.

This issue is fixed.

Job Flow View Does Not Display All Jobs that a Box Contains

Problem Record: 84

If a CA Workload Automation AE instance contains a huge number of jobs, the job flow view might not display all jobs and
its dependencies correctly. This issue occurs due to the Java VM default sort setting that was changed in JRE 1.7+.

This issue is fixed.

Migrate Now Button in Migration Wizard Not Working

Problem Record: 76

The Migrate Now button in the Migration Wizards is enabled but non-functional.

This issue is fixed.

iXp Migration Error on Windows

Problem Record: 75

When you migrate jobs on a Windows installation of iXp, sometimes the temp migration folder is not created under newer
JVMs.

This issue is fixed.

CLI Commands Executed with Incorrect User ID in iXp User Security Mode

Problem Record: 74

If a user executed CLI commands (File->CLI menu) in iXp User security mode, the commands were executed with the OS
user ID instead of iXp user ID with which the user is logged in.

This issue is fixed.

iXp Users Cannot View Report with Custom Date Range

Problem Record: 73 

When a user created a report with a custom date range (for example, From: 1/1/2017 and To: 1/10/2017), subsequently all
iXp users are unable to view their reports. The issue might occur after the upgrade to patch RO96944 when a report with
the same name or custom date range was already defined in iXp.

This issue is fixed.
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Some LDAP Servers Not Found in List

Problem Record: 71

When you add more than ten LDAP servers in the Admin Tool, the newly added servers are not visible, requiring users to
resize the panel.

This issue is fixed.

Duplicate LDAP Server Added in iXp Admin Tool

Problem Record: 70

When you modify the name of an LDAP server in the Authentication->LDAP->LDAP Servers tab in the Admin Tool, a
duplicate LDAP server with the modified name gets added in addition to the original LDAP server.

This issue is fixed.

Sendevent Errors Occur Intermittently

Problem Record: 69

The following errors occur intermittently during sendevents:

error loading job detail

 

jobname not found

These issues occur due to huge sendevent traffic in large CA Workload Automation AE environments where jobs can be
dynamically created. If a job is created immediately before a sendevent, sometimes the job name cannot be found in local
cache during security checks. Hence, security checks fail causing sendevent error.

This issue is fixed.

job_depends Functionality Not Working

Problem Record: 68

When you install CA Workload Automation AE CLI Release 11.3.6 SP5 or later on iXp server, the iXp job_depends
functionality does not work.

This issue is fixed.

Exception Error Occurs When Job Condition's Length Exceeds Internal Maximum Limit

Problem Record: 65

If the length of a job condition exceeds 4096 characters, an exception error is recorded in the iXp server log.

This issue is fixed. The maximum length is now set to 8192 characters.

CLI Menu option Not Shown in iXp User Security Mode

Problem Record: 64
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When iXp is configured with iXp User security mode, the File->CLI menu is not shown in the iXp GUI.

This issue is fixed. 

Help Links Broken

Problem Record: 60

The default iXp landing pages (/index.html and /index.jsp) contain links to non-existent documentation.

This issue is fixed.

Newly Created Filter Not Available for Editing

Problem Record: 54

When you create a new filter from the Edit->Edit Filter->Filter Editor dialog, the filter is sometimes not available for
editing in the Current Filter drop-down list. Also, when you modify an existing iXp Group filter, the modified filter details
are lost. 

This issue is fixed.

Known Issues

Validation Failed Message Shown When Saving LDAP Server Configuration

Suppose that you configure an LDAP server with a User Base (base distinguished name) at a high level with many
records below it in the schema. When you save or validate the LDAP server configuration, the configuration is saved with
the 'validation failed' message. If the LDAP server configuration details are valid, users can log in to iXp GUI using LDAP
authentication despite the 'validation failed' message.

As a workaround, reduce the User Base to a smaller schema segment and create multiple LDAP servers to cover all the
schema branches.

Remote iXp GUI Clients in IPv6 Environment Cannot Connect to iXp Server

The remote iXp GUI Clients running in an IPv6 environment may receive the following error when iXp is in SSO User
security mode:

Login error. Invalid IP address: 127.0.0.1

If your iXp GUI clients exist on IPv6 or hybrid IPv4/IPv6 networks and you want to limit iXp GUI logins to the
GUIAuthentication->SingleSignOn->IPAddress panel, only the remote client’s IPv4 addresses are valid and restricted.
If the remote iXp GUI exists only on the IPv6 domain and it does not have an IPv4 address, the remote client defaults to
127.0.0.1 . So, you must enter either * or 127.0.0.1  in the IPAddress restrictions panel. You may use the hostname
restrictions panel to further limit based on client hostname.

Unable to Use IPv6 Address to Connect to an IPv6-enabled CA Workload Automation AE Database

When iXp connects to an IPv6-enabled CA Workload Automation AE database (Oracle, SQLServer, Sybase), you can
use only the hostname of the remote database in the database connection string. You cannot use an IPv6 address, for
example, 
fe80::250:56ff:fe86:5de

.
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Changes in 11.3.5 Incremental 7 Patch 3
This section describes the changes to existing features and the issue that are fixed in 11.3.5 INCR7 Patch#3 (SO06381):

WARNING

 Before you apply 11.3.5 INCR7 Patch#3 (SO06381), you must apply these 11.3.5 INCR7 patches as a
prerequisite:

• CA Workload Automation iXp: SO00502
• CA Workload Automation iXp CA Third-Party Requirements: SO00503

If you are using CA Workload Automation iXp 7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply 11.3.5 INCR7 patches and INCR7 patch#3.

For more information about applying these patches, see the Readme files in the patches.

  

Fixed Issues

LDAP Server Priority Not Always Honored

 Problem Record: 97

If multiple LDAP servers are defined and users can be authenticated against any of the LDAP servers, iXp does not
start the user authentication from the LDAP server that is higher on the LDAP server priority list. Instead, iXp performs
authentication using the last LDAP server that successfully authenticated a user.

This issue is fixed.

Default Authentication Mode for New Users is Not Set to LDAP When LDAP Authentication is Enabled

 Problem Record: 96

The default authentication mode for a new user is not set to
LDAP

, even though the Enable LDAP Authentication check box is selected in the Authentication->GUI tab in the iXp Admin
Tool.

This issue is fixed.

Changes to Existing Features

Changes to the Multiple-LDAP Authentication Mechanism

 Problem Record: 98

When iXp is configured with multiple LDAP servers, iXp checks for the user in the target LDAP server and then performs
authentication with the user-provided password. If the authentication fails, iXp does not check for the user in the remaining
LDAP servers.

To enable the failover for user authentication with multiple LDAP servers, you must change the default iXp authentication
behavior. By setting the IXP_LDAP_AUTH_FAILURE_OPTION=NEXT  parameter for the Tomcat server, iXp checks all the
configured LDAP servers until server list is complete, looking for any LDAP server that can validate the user password.

This feature is useful for environments, where a userID may exist in multiple LDAP domains, but the user provides
password for a domain that is lower on the LDAP priority list.

For more information, see Enable Failover for User Authentication with Multiple LDAP Domains.
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Changes in 11.3.5 Incremental 7 Patch 2
This section describes the issue fixes that are delivered in 11.3.5 INCR7 Patch#2 (SO04669):

WARNING

 Before you apply 11.3.5 INCR7 Patch#2 (SO04669), you must apply these 11.3.5 INCR7 patches as a
prerequisite:

• CA Workload Automation iXp: SO00502
• CA Workload Automation iXp CA Third-Party Requirements: SO00503

If you are using CA Workload Automation iXp 7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply 11.3.5 INCR7 and INCR7 patch#2.

For more information about applying these patches, see the Readme files in the patches.

Invalid LDAP Authentication Using Blank Password

Problem Record: 94

iXp performs invalid LDAP authentication by accepting blank passwords for LDAP users.

This issue is fixed.

WARNING

If you are using LDAP authentication for iXp, you must apply this fix.

Box Jobs or Job Dependencies Displayed Incorrectly in Job Flow View

Problem Record: 95

Due to changes in default sorting algorithms in JRE 1.7 or higher, sometimes the iXp GUI would not display all jobs (or
jobs within a box) in the flow view, or some dependency links between jobs/boxes were broken or incorrect. Visually, it
could look like jobs/boxes were misaligned/stacked on top of each other. A Java exception can also be noticed in the
Desktop Java console output. A fix for this issue (Problem Record #84) was made in 11.3.5 Incremental 7, however in
some environments this fix alone did not correct the problem, therefore we have updated the iXp.jnlp configuration file to
tell the newer JRE to use the older sorting algorithms and maintain backward compatibility.

This issue is now fixed.

Changes in 11.3.5 Incremental 7 Patch 1
This section describes the changes that are delivered in 11.3.5 INCR7 Patch#1 (SO03931):

WARNING

 Before you apply 11.3.5 INCR7 Patch#1 (SO03931), you must apply these 11.3.5 INCR7 patches as a
prerequisite:

• CA Workload Automation iXp: SO00502
• CA Workload Automation iXp CA Third-Party Requirements: SO00503

If you are using CA Workload Automation iXp 7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply 11.3.5 INCR7 and INCR7 patch#1.

For more information about applying these patches, see the Readme files in the patches.
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Support for CA Workload Automation AE Release 11.3.6 SP7

CA Workload Automation iXp now supports CA Workload Automation AE Release 11.3.6 SP7.

Alarm on Terminate Check Box Added to the Job Editor Dialog

In the iXp GUI, a new Alarm on Terminate check box is added to the Alarm page in the Job Editor dialog. The Alarm
on Terminate check box specifies whether an AutoSys JOBTERMINATED alarm should be generated every time the job
ends in a TERMINATED status. By default, this check box is selected.

Note: The Alarm on Terminate feature works only with CA Workload Automation AE 11.3.6 SP7 or higher.

Edit Calendars Option in the Definition Menu is Renamed

In the iXp GUI, the Edit Calendars option in the Definition menu is renamed to View/Edit Calendars. Similarly, the
Calendar Editor dialog is renamed to Calendar Viewer/Editor.

Validity of the JAR File Signature

The CA Workload Automation iXp JAR files are signed with an SSL certificate, so that the JAR files are trusted by JRE.

In CA Workload Automation iXp 11.3.5 INCR7, the validity of the JAR file signature expires on March 8, 2019. With
INICR7 patch#1 (SO03931), the expiration date is extended until April 5, 2020.

WARNING

If you are using previous releases of CA Workload Automation iXp, we recommend that you either upgrade to
INCR7 patch#1 (SO03931) or add iXp to the exception list in the Security tab of the Java Control panel.

To launch the Java Control panel, change to the following directory at the command prompt and enter the
javaws -viewer

command:

java_install_dir\bin

java_install_dir

Specifies the Java installation directory.

11.3.5 Incremental 6
This section includes new features, fixed issues, and known issues in CA Workload Automation iXp Release 11.3.5
INCR6:

WARNING

If you are using CA Workload Automation iXp v7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply the following 11.3.5 INCR6 patches:

• CA Workload Automation iXp: RO95863
• CA Workload Automation iXp CA Third-Party Requirements: RO95865

For more information about applying these patches, see the Readme files in the patches.
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New Features

Support for CA Workload Automation AE Release 11.3.6 SP6

CA Workload Automation iXp now supports CA Workload Automation AE Release 11.3.6 SP6.

User Authentication Using LDAP

Administrators can now configure user authentication using one or more of the following LDAP servers: Microsoft Active
Directory (AD), Novell eDirectory, or Sun ONE Directory. Once configured, users can log in to iXp GUI or iXp Admin Tool
with their LDAP credentials.

For information about configuring user authentication using LDAP, see Set Up User Authentication and Manage Users and
User Groups.

Notification About Impending Signed JAR Expiration

Users are now notified about the impending expiration of the signed JAR files, when they log in to the iXp GUI or iXp
Admin Tool. The notification starts occurring 180 days before the expiration date. For more information, see Signed JAR
Expiration Notices and Errors and Warnings.

Fixed Issues

Job Editor does not show Date Conditions of Jobs

Problem Record: 62

The iXp JobEditor sometimes throws an Exception in the java console when loading a job with date conditions. This also
might cause other aspects or information regarding the job to fail to load completely or correctly.

This issue is fixed.

Missing Security Checks on sendevent / autorep -I and -B Options

Problem Record: 58

When you invoke the File->CLI->autorep or sendevent command, iXp allowed the Application (-I) and Group (-B)
operations but no Job Control privilege check was performed. This issue also occurred when you invoked the ixsendevent
or ixautorep commands from an iXp Client CLI.

This issue is fixed.

Unable to Update Extended or Cyclic Calendars

Problem Record: 57

When you modified an extended calendar or a cycle, the following error might occur:

Calendar name already exists

Beginning with CA Workload Automation AE Client r11.3.6 SP3 or higher, the autocal_asc command requires the force
overwrite option (-F) to overwrite or update an extended calendar or a cycle. This issue is fixed. iXp now verifies the
version of the Autosys Client installed on the iXp server and provides the -F option if needed by autocal_asc.
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Unable to Copy Calendars

Problem Record: 56

When you copy an existing calendar using the Copy button in Calendar Editor and save it with a new name, the following
error occurs:

Saving calendar failed. Calendar not found.

This issue is fixed.

Future Sendevents Not Listed in Unsendevent Panel

Problem Record: 55

The future sendevents are not listed in the Unsendevent panel of the File->Sendevent dialog when using SQL Server as
the Autosys database.

This issue is fixed.

Unable to Modify or Delete Calendars or Cycles that Contain Hash Symbols in their Names

Problem Record: 53

When you modify or delete a calendar or a cycle that contains a hash (#) symbol in its name, an error similar to the
following might occur:

Saving calendar failed

This issue occurs only on Unix-based iXp servers.

This issue is fixed.

Invalid Future Sendevent

Problem Record: 50

When you select random options in the Unsendevent panel of the File->Sendevent dialog, the sendevent command
might produce an invalid list of parameters. This might result in an error indicating that Autosys cannot perform
unsendevent as the event does not exist.

This issue is fixed.

Sendevent Submitted with an Invalid High Priority Value

Problem Record: 49

When you issue a sendevent with the High Priority checkbox selected in the File->Sendevent dialog, iXp submits the
sendevent with an invalid priority value 0 (-P 0). When iXp submits the sendevent with an invalid priority value, the CA
Workload Automation AE Application Server ignores that priority value and defaults to priority of 10 instead.

This issue is fixed. iXp now submits -P 1, which is the highest sendevent priority value allowed by CA Workload
Automation AE.
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Calendar Editor Cannot Deselect a Date

Problem Record: 48

If you click on a date that was already selected or click on a new date to select it in the Calendar Editor, you cannot
deselect it unless you close and reopen the Calendar Editor. 

This issue is fixed.

Java Exception Error Occurs Due to Missing ojdbc5.jar

Problem Record: 46

iXp is shipped with ojdbc6.jar file, however the server statistics feature that runs approximately every 30 minutes by
default was still depending on the previously shipped ojdbc5.jar file. Hence, the java exception error similar to the
following occurs in the iXp Daemon log:

stats_ACE:java.io.FileNotFoundException

java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver

This issue is fixed.

iXp Forecast Report is Empty

Problem Record: 43

The ixforecast utility either generates a blank forecast report or throws an error similar to one of the following due to an
improperly described Java class name:

The system cannot find the file specified

Error: Could not find or load main class com.ca...

This issue is fixed. As part of this fix, the same changes are also made to ixauditreport.pl, ixcheckdb.pl, ixgroupaudit.pl,
ixhostdetails.pl, ixjobstatus.pl, ixreport.pl, ixserverstats.pl, ixusers.pl, and ixversion.pl.

Invalid Time Listed for Future Sendevent

Problem Record: 42

The File->Sendevent dialog shows an invalid future sendevent time when the iXp server timezone is different than the
Autosys database time.

This issue is fixed.

Unable to Retrieve Large Job Log Files

Problem Record: 40

For huge job log retrieval, the iXp GUI might run out of memory.

This issue is fixed. The maximum memory value of the iXp.jnlp startup file for iXp GUI has been updated to allow
a maximum of 1024 MB (compared to 256 MB in previous versions). Similarly, the maximum memory value of the
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AdminTool.jnlp startup file for iXp Admin Tool has been updated to allow a maximum of 512 MB for larger customer
environments. 

Heap Memory Error Occurs When Refreshing Job Data

Problem Record: 39

In larger customer environments where iXp GUI users have many objects (Jobs, Calendars, and so on), the Java VM
might run out of memory and display an error similar to the following in the desktop clients' Java console dialog:

java.lang.OutOfMemoryError: Java heap space

This issue is fixed. The maximum memory value of the iXp.jnlp startup file for iXp GUI has been updated to allow
a maximum of 1024 MB (compared to 256 MB in previous versions). Similarly, the maximum memory value of the
AdminTool.jnlp startup file for iXp Admin Tool has been updated to allow a maximum of 512 MB for larger customer
environments.

IXP_USERCOMMAND_USER_NAME Environment Variable Does Not Appear in the CLI Output

Problem Record: 38

The IXP_USERCOMMAND_USER_NAME environment variable does not appear in the environment files that are created
by the ixsendevent or other iXp Client CLI commands.

This issue is fixed.

Edit Dialog Does Not Appear When Clicking the Command Edit Icon in Job Editor

Problem Record: 37

When you click the Edit icon next to the Command field in the Job Editor dialog, the Edit dialog does not appear.

This issue is fixed.

Known Issues

iXp Report and Forecast Utilities Do Not Support Perl Version 5.15 or Higher

The iXp report and forecast utilities use the Perl scripting language. These utilities do not support Perl version 5.15 or
higher.

If you must use a newer version of Perl and your OS/Perl release has compiled the perl4:corelibs module, you may add
and configure the newer version as a workaround until iXp supports it.

Validation Failed Message Shown When Saving LDAP Server Configuration 

Suppose that you configure an LDAP server with a User Base (base distinguished name) at a high level with many
records below it in the schema. When you save or validate the LDAP server configuration, the configuration is saved but
with the 'validation failed' message. If the LDAP server configuration details are valid, users can log in to iXp GUI using
LDAP authentication despite the 'validation failed' message.

As a workaround, reduce the User Base to a smaller schema segment and create multiple LDAP servers to cover all the
schema branches.
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Remote iXp GUI Clients in IPv6 Environment Cannot Connect to iXp Server

The remote iXp GUI Clients running in an IPv6 environment may receive the following error when iXp is in SSO User
security mode:

Login error. Invalid IP address: 127.0.0.1

If your iXp GUI clients exist on IPv6 networks (or in a hybrid IPv4/IPv6 network) and you want to limit iXp GUI logins
via the GUIAuthentication->SingleSignOn->IPAddress panel, please note that only the remote client’s IPv4 addresses
are valid and restricted. If the remote iXp GUI does not have an IPv4 address (ie it only exists on the IPv6 domain)
then the remote client will default to using “127.0.0.1” and therefore you must have either “*” or “127.0.0.1” entered in
the IPAddress restrictions panel. You may use the normal hostname restrictions panel to further limit based on client
hostname (per normal operation).

Unable to Use IPv6 Address to Connect to an IPv6-enabled AutoSys Database 

When iXp connects to an IPv6-enabled AutoSys database (Oracle, SQLServer, Sybase), you cannot use an IPv6 address
(For example, 
fe80::250:56ff:fe86:5de

) in the database connection string but only the hostname of the remote database.

File->CLI Menu Does Not Appear When Switching to iXp/LDAP Mode

When you switch to the iXp/LDAP user mode from the SSO mode, the File->CLI menu does not appear in the iXp GUI.

iXp GUI Becomes Unresponsive When Collapsing an Expanded Box in Tree View

In large environments, when you perform the File->View->Expand All operation and subsequently collapse a box in the
tree view, sometimes the iXp GUI becomes unresponsive. This issue occurs only for some boxes, not all. 

As a workaround, you can close the parent box first if it contains child boxes, disable the flow view, or close and reopen
the iXp GUI.

Newly Created Filter Not Available for Editing

When you create a new filter using the Edit->Edit Filters->Filter Editor dialog in iXp GUI, the newly created filter is not
available for editing in the Current Filter drop-down list.

Also, when you modify an existing iXp Group filter, the modified filter details are lost.

Job Flow View Does Not Display All Jobs that a Box Contains

The job flow view in the iXp GUI sometimes does not display all the jobs that a box contains. However, the jobs are still
visible in the tree view.

11.3.5 Incremental 5
This section includes new features and issues fixed in CA Workload Automation iXp Release 11.3.5 INCR5:

WARNING

If you are using CA Workload Automation iXp v7.2 or lower versions, upgrade CA Workload Automation iXp to
11.3.5 and then apply the following 11.3.5 INCR5 patches:
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• CA Workload Automation iXp: RO91051
• CA Workload Automation iXp CA Third-Party Requirements: RO91053

For more information about applying these patches, see the readme files in the patches.

New Features

Support for CA Workload Automation AE Release 11.3.6 SP5

CA Workload Automation iXp now supports CA Workload Automation AE Release 11.3.6 SP5.

Update the Group and Application Attributes of a Job in Job Editor

Users can specify or update the name of a group and an application in the Basic page of the Job Editor or the iXp JIL
console, so that the job is associated to the specified group and application.

Support for New Job Types

CA Workload Automation iXp now supports these job types: File Trigger and FTP

Find Job By Dialogs

The File Trigger and FTP options are added to the Job Type drop-down in the following dialogs under View > Find Job
By:

• Find Job By Type
• Find Job By Description
• Find Job By Owner
• Find Job By Machine

Instance-Level Job Type Filter

The following options are added to the Job Type section in the Instance tab of the iXp Admin tool:

• FT
• FTP

List All Future SendEvents

Users can now retrieve the list of all future sendevents using the Refresh future events button in the Sendevent dialog.
Only one event can be selected at a time from the list and unsent.

Job Name Update in Job Editor

In the previous release, when a user enters a job name that does not pass authorization validations, the Job Editor dialog
gets closed and the job must be inserted again from Definition -> Edit Jobs.

In this release, user can now change the job name in the Job Editor dialog.

Configurable Job Name Prefix Length

Users can now override the default setting of "3" for job name prefix length.

iXp has built in functionality to export user view as JIL. It uses autorep command to load job definitions. Due to the
limitation in autorep, a set of jobs using only one job name definition can be pulled. Calling autorep for each job separately
is time consuming. Hence, iXp groups the jobs by prefixes and then supplies these prefixes to autorep. For example, the
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output of the command "autorep -J job_name_prefix%" may contain jobs that are not part of the view. These jobs are then
filtered by iXp.

The default value "3" may be insufficient for some businesses as it may cause thousands of jobs being pulled from the CA
Workload Automation AE server. Hence, you can override the default value by configuring the following java VM variable:

ixp.job_name_prefix_length

Example: -Dixp.job_name_prefix_length=6

Changes to Existing Features

Validity of the JAR File Signature

The CA Workload Automation iXp JAR files are signed with an SSL certificate, so that the JAR files are trusted by JRE.

In CA Workload Automation iXp 11.3.5 Incremental 5, the validity of the JAR file signature is extended until March 8, 2019.

WARNING

If you are using previous releases of CA Workload Automation iXp, we recommend that you either upgrade to
Incremental 5 or add iXp to the exception list in the Security tab of the Java Control panel.

To launch the Java Control panel, change to the following directory at the command prompt and enter the
javaws -viewer

command:

java_install_dir\bin

java_install_dir

Specifies the Java installation directory.

Fixed Issues

iXp Login Window Shows Outdated Copyright Year

The login window of the iXp GUI and iXp Admin tool shows an outdated copyright year.

This issue is fixed.

Job Column in Find Job By Dialogs is Not Expandable

The Job column in the Find Job By dialogs under View > Find Job By is not expandable. Hence, the long job names are
not displayed properly.

This issue is fixed.

11.3.5 Incremental 4
This page describes the new features and known issues in CA Workload Automation iXp Release 11.3.5 INCR4:
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New Features

Job Detail View - New Information Fields

The Job detail view now has additional information fields:

• Group
• Application

Job Editor Window - New Fields

The Job Editor Window now has additional information fields:

• Group
• Application

Calendar Editor Window - Dependent Jobs List

The calendar editor window shows a list of dependent jobs. Select a calendar from the drop down menu to show jobs that
are using this calendar including information on whether the calendar is used as a run calendar or an exclude calendar.

Additional Job Type Information

Job logs, job error logs and spool files are now accessible for all Additional Job Type Information.

New Filter Editor Definitions

The ‘Group’ tab is renamed as ‘iXp Group’ tab to avoid confusion with WA AE Groups. You can filter the definitions now in
the Filter Editor.

Filter Editor - Calendar Tab

You can now create and filter jobs via the calendar:

• Show all jobs that are associated with a particular calendar schedule.
• Right click job to open context menu select to ‘show in console’.

Additional Filters

New ‘group’ support for filtering by CA Workload Automation AE groups and new ‘application’ support for filtering by
applications in the filter editor.

Hostname Command

New command ‘IXP_USERCOMMAND_USER_HOSTNAME’ used to return your hostname.

Additional Job Detail Filters

Filter by ‘group’ or ‘application’ to display jobs matching the selected group or application.

HTML Support for 'Message of the Day'

Message of the Day now supports html markup for message customization.

Graph Columns Group and Application

Additional columns in the console for organizing progress graphs by Group and Application.
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QuickFilters

You can create quick filters by clicking on one of these job attributes: Status, Run Machine, Group, Application, Box name,
in the job detail view. Filters are dynamically generated and are not saved. If you want to save, create a copy in the Filter
Editor with a new save name.

Server/Client Connection Information

Both iXp Gui and IXp AdminTool users can see the name of the iXp server they are connected to. Information is visible in
the top right corner next to the user name.

CLI - ixuserjobcmd

Provides the ability to run previously defined user job commands from the command line.

CLI - ixautocal_asc

ixautocal_asc is now able to relay command line arguments to underlying autocal_asc with iXp security and audit. When
using the Import or Export option, the specified files are transported to/from the iXp server. This is now the preferable
way of importing/updating calendars from CLI because this bypasses WA AE 11.3 -> 11.3.5 behavior inconsistency
(overwriting instead of updating calendars when using input
redirect “<”).

Known Issues

Validity of the JAR File Signature

The CA Workload Automation iXp JAR files are signed with an SSL certificate, so that the JAR files are trusted by JRE. In
CA Workload Automation iXp 11.3.5 Incremental 4, the JAR file signature is valid only until September 2016. Hence, you
might not be able to log in to CA Workload Automation iXp properly after September 2016.

To resolve this issue, we recommend that you either upgrade to Incremental 5 or add iXp to the exception list in the
Security tab of the Java Control panel. To launch the Java Control panel, change to the following directory from the
command prompt and run the javaws -viewer  command:

java_install_dir\bin

• java_install_dir
Specifies the Java installation directory.

11.3.5 Incremental 3
This page describes the new features, fixed issues, and known issues in CA Workload Automation iXp Release 11.3.5
INCR3:

New Features

Support for CA Workload Automation AE Release 11.3.6

Workload Automation iXp now provides support for CA Workload Automation AE Release 11.3.6.
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NOTE
The Workload Automation iXp Job Editor supports only Command, Box, and File Watcher job types. The
job types that are added to CA Workload Automation AE after Unicenter AutoSys JM 4.5 are not supported.
However, users can view or define the additional job types using the ixautorep or ixjil CLI commands.

Support for Log Filtration

The iXp Admin Tool supports the log filtration option that lets users filter the iXp server logs based on a search keyword.
To filter the logs, specify a keyword in the Find in log field and click the Previous or Next button.

Fixed Issues

11.3.6 Version Option Not Listed on the Instance tab of iXp Admin Tool

When you defined a new CA Workload Automation AE 11.3.6 instance, 11.3.6 version option was not listed in the Version
drop-down on the Instance tab. This issue has been fixed. You can now select 11.3.6 from the Version drop-down list
when you define a new CA Workload Automation AE 11.3.6 instance.

Calendar Editor Denies Calendar Access for Users with Read Privilege

Users with calendar read privileges on an instance were denied access to calendars by the calendar editor. This issue has
been fixed. Users can now view all calendars for which read privileges are assigned on an instance.

Calendar Editor Toolbar Icons Not Dynamically Displayed Based on the Calendar Type

When an instance defined with an extended calendar was selected from the AUTOSERV drop-down list, all icons were
displayed in the calendar editor toolbar. This issue has been fixed. The calendar editor toolbar icons are dynamically
displayed based on the standard calendar, extended calendar, or the cycle that an instance is defined with. For an
extended calendar, the toolbar displays specific icons and disables the remaining ones.

Date Condition Check Box Not Selected in iXp Job Editor

When you ran the ixpautorep command with the date condition attribute (t), the Date Condition check box was not
selected on the iXp Job Editor. iXp ignored the attribute. This issue has been fixed. iXp Job Editor now selects or clears
the Date Condition check box based on the date condition attribute that you define in the ixpautorep command.

iXp JIL Command Failed to Execute

If you specified an escaped double quote (\") at the end of a JIL command, the JIL command failed to execute. You can
now execute the JIL command that ends with an escaped or unescaped double quote.

iXp System Call Hung in UNIX_Linux Environments

Valid on UNIX and Linux 
When iXp server sent a system call to CA Workload Automation AE, the system call hung. This issue has been fixed. iXp
now terminates the hung system call after 30 minutes.

Job Detail View Displayed Incorrect Global Variable Value

When you set a global variable on an instance using a job in another instance, iXp assumed that the global variable is
set on the instance where the job is defined. So, the job detail view displayed the wrong instance name and an undefined
value. This issue has been fixed. The job detail view now displays the correct global variable value with appropriate
instance name.
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Job Flow View Not Displayed for a Three-Letter Site Name that Matches an Instance Name

If you specified a three-letter site name that matches an instance name, the job flow view for the site name was not
displayed. The minimum number of characters for a site name is now four.

Log File Retrieval Failed for CA Workload Automation AE Jobs

When you retrieved the log file for a CA Workload Automation AE Release 11.3.5 or higher job, the log file could not be
viewed. For example, if you retrieve the standard error log file for the job (TEST) of the instance (ORG), the following
message appears:

ORG-TEST: "STD_ERR_FILL": invalid identifier

This issue has been fixed. You can now retrieve log files for all CA Workload Automation AE jobs.

Sendevent Dialog Not Refreshed After a Sendevent Invocation

When you opened the Sendevent dialog from the File menu in iXp user interface, the Sendevent dialog displayed the job
from the previous Sendevent invocation. This issue has been fixed. The Sendevent dialog now displays the selected job.
Open the Sendevent dialog after you select a job in the tree view.

Sendevents JOB_ON_NOEXEC and JOB_OFF_NOEXEC Not Supported for CA Workload Automation AE Release
11.3.6 Jobs

The JOB_ON_NOEXEC and JOB_OFF_NOEXEC sendevents were not supported for CA Workload Automation
AE Release 11.3.6 jobs. This issue has been fixed. You can now issue the JOB_ON_NOEXEC and JOB_OFF_NOEXEC
sendevents for both CA Workload Automation AE Release 11.3.5 and Release 11.3.6 jobs.

Unknown Job Type Displayed for CA Workload Automation AE Release 11.3.5 or Release 11.3.6 Jobs

When a CA Workload Automation AE Release 11.3.5 or Release 11.3.6 job was viewed in the Job Editor dialog, the job
type was displayed as UNKNOWN. This issue has been fixed. The job type is now displayed correctly based on the type
you specify in the CA Workload Automation AE job definition.

Basic System Requirements
This section lists the system requirements for installing and running the iXp components. Some of the prerequisite
software is already present on the machines when the operating system is loaded.

Contents:

iXp Daemon

• Apache Tomcat v7 or v8 (64-bit implementation)
• JRE v1.8 (64-bit implementation). Also supported is Oracle Java 11 LTS and OpenJDK 11.
• PERL v5.8 or higher is recommended
• 2 GHz processor with two free cores
• 5 GB of disk space for full installation
• 4 GB of available RAM
• CA Workload Automation AE Full Client and configuration files for all instances of CA Workload Automation AE that

will be accessed.
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The following table lists additional requirements for the iXp Server that depend on the type of deployment:

Up to 50000 jobs,
10 concurrent users

Up to 100,000 jobs,
50 concurrent users

Up to 200,000 jobs, 100
concurrent users

Processor 2 GHz with two free cores 2 GHz with four free cores 2 GHz with four free cores
Available RAM 4 GB 8 GB 16 GB
Disk space for full installation 5 GB 10 GB 10 GB

iXp Client

• JRE v1.8 (32- or 64-bit implementation).  Also supported is Oracle Java 11 LTS and OpenJDK 11.
• 2 GHz processor
• 1 GB of available RAM

Additional requirements that depend on the type of deployment are the following.
– Up to 50,000 jobs: 500 MB free physical memory
– Up to 100,000 jobs: 750 MB free physical memory
– Up to 200,000 jobs: 1 GB free physical memory

• The iXp user interface is designed to support a minimum screen resolution of 1280 x 720, but higher resolutions are
suggested for optimal experience.

iXp CLI

• JRE v1.8 (32- or 64-bit implementation). Also supported is Oracle Java 11 LTS and OpenJDK 11.
• 5 MB of disk space

iXp Agent

• JRE v1.8 (Optionally, PERL v5.1 or higher for the deprecated agent program)
• The CA Workload Automation AE sendevent, zql, xql binaries are optional. They are needed if you want the iXp

Daemon to automatically install and start the PERL-based iXp Agent.

Compatibility Matrix
The following compatibility matrix specifies the components and vendor products that are compatible with the latest
version of CA Workload Automation iXp.

Support is limited only to the components and platforms, and Broadcom products combinations that are listed in this
document. Any platforms and Broadcom products combinations or versions that are not listed in this document are not
supported.

Broadcom Support Policy

Broadcom supports third-party product versions only when they are supported by the original vendor. If a vendor
discontinues support for a product, Broadcom no longer supports it.

You can contact Broadcom Support for CA Workload Automation products that:

• Have not reached an End of Support date or End of Life date. For more information, see CA Workload Automation
Release and Support Lifecycle Dates.

• Run on third party product versions that are currently supported by the original vendor.

More info:
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• For the platforms and components supported by AutoSys Workload Automation, see the AutoSys Compatibility Matrix.
• For CA Workload Automation Solutions Certification/Supported Platforms, see the CA Workload Automation Solutions

Certification/Supported Platform Information.
• For End of Service and Official Support for CA Workload Automation iXp, see CA Workload Automation iXp Release

and Support Lifecycle Dates.
• For End of Service and Official Support for all CA Workload Automation products, see CA Workload Automation

Release and Support Lifecycle Dates.

Component Vendor Product Notes
Java Components (Server) JRE v1.8u45 (64-bit implementation). Also

supported is Oracle Java 11 LTS and
OpenJDK 11.

Java Components (Client) JRE v1.8u45 (32/64-bit
implementation). Also supported is Oracle
Java 11 LTS and OpenJDK 11.
Note: Newer JREs may not support
WebStart feature and therefore must use
standalone iXp as documented on the iXp
Launcher help page.

Java Components (CLI) JRE v1.8u45 (32/64-bit
implementation). Also supported is Oracle
Java 11 LTS and OpenJDK 11.

Java Components (Agent) JRE v1.8u45. Optionally, PERL v5.1 or higher for the
deprecated agent program

Apache Tomcat (Server) Apache Tomcat v7, v8, and v8.5 and v9
(64-bit implementation)

• If you are using Tomcat v7 and
v8 along with Java 9, 10, and
11, remove the following Java
parameter from thecatalinafile
in the Tomcat bin directory:-
Djava.endorsed.dirs="$JAVA_ENDORSED_DIRS" -
classpath "$CLASSPATH" \For
information about Tomcat and
Java compatibility, see http://
tomcat.apache.org/whichversion.html.

• Java 6 is not supported with Tomcat 7
and above.

• Java 7 is not supported with Tomcat 9.

Server Platforms Oracle Linux 6 and 7 (64-bit)
AIX 7.2 and 7.1 POWER (64-bit)
Solaris 10 and 11, SPARC (64-bit)
Red Hat Enterprise Linux 5, 6, and 7
(x86_64-bit)
SuSE Linux Enterprise Server 11 and 12
(x86_64-bit)
HP-UX 11i v3, PA-RISC (64-bit)
Windows Server 2019 and 2016 (64-bit)

Server refers to the CA Workload
Automation iXp server.

Clients Platforms Oracle Linux 6 and 7 (x86_32/64-bit)
Red Hat Enterprise Linux 5, 6, and 7
(x86_32/64-bit)
SuSE Linux Enterprise Server 11 and 12
(x86_32/64-bit)
Windows 10
Windows Server 2019 and 2016 (64-bit)

Client refers to the Java-based clients
(Admin Tool and GUI).
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CLI Platforms Oracle Linux 6 and 7 (x86_32/64-bit)
SuSE Linux Enterprise Server 11 (zSeries
31/64-bit)
AIX 7.2 and 7.1 POWER (64-bit)
HP-UX 11i v3, PA/RISC
Red Hat Enterprise Linux 5 and 6 (zSeries
31/64-bit)
Solaris 10 (SPARC 32/64-bit) and 11
(SPARC 64-bit)
Solaris 10 and 11 (x86_32/64-bit)
Windows 10
Windows Server 2019 and 2016 (64-bit)
Red Hat Enterprise Linux 5, 6, and 7
(x86_32/64-bit)
SuSE Linux Enterprise Server 11 and 12
(x86_32/64-bit)

CLI refers to the iXp Command Line
Interface.

Scheduling Managers AutoSys Workload Automation r12.0.01
AutoSys Workload Automation Version 12.0
CA Workload Automation AE r11.3.6 (up to
SP8)
CA Workload Automation AE r11.3.5

Product Accessibility Features
Broadcom is committed to addressing user accessibility in the development of its products and documentation to help all
customers, regardless of ability, to accomplish vital business tasks.

Third-Party Software Acknowledgements
You can view acknowledgements from within the CA Workload Automation iXp GUI or Admin Tool.

Follow these steps:

1. Log in to iXp GUI or iXp Admin Tool.
2. Select About from the Help menu.
3. Click the Third Party Notices tab.

This CWAIXP 11.4.00 file contains copyright and license agreement information for the following third-party
components used in CA Workload Automation iXp Release 11.4.00:

• Apache 2.0, which includes:
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– Commons Codec 1.9
– Commons IO 2.4
– Commons Lang 2.6
– Log4j 1.2.13

• jTDS v.1.2

• Oracle JDBC Driver 12.2.0.1
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Getting Started
Workload Automation iXp lets you monitor, control, update, forecast, simulate, report on, and print CA Workload
Automation AE job streams across multiple instances.

The Workload Automation iXp is a Java-based graphical interface and can be opened from Java Web Start. Based on a
true web-based 3-tiered architecture developed in JavaTM, iXp is highly scalable, efficient, fast and minimal in terms of
impact on the network bandwidth and the CA Workload Automation AE repository. 

This product provides also following additional tools and features:

• The iXp Admin Tool lets you manage privileges for users by defining authorization roles.
• The iXp Command Line Interface (CLI) lets users view, report, control, create, update, and delete CA Workload

Automation AE jobs. The commands interface with the Workload Automation iXp security model, providing secure
access to the CA Workload Automation AE environment, and do not require a local installation of the CA Workload
Automation AE software. The iXp Client CLI enables users to execute CA Workload Automation AE commands from
any client machine without having to install the CA Workload Automation AE software. 

• The wizard-style migration assistant lets you migrate jobs and other related objects from a Unicenter AutoSys JM
4.5.1 instance to any CA Workload Automation AE r11.3 or higher instance. You can visualize, build, validate, and
upload packages containing the appropriate set of jobs and their related global variables and calendars.

To use Workload Automation iXp, you should meet the following requirements:

• You are familiar with CA Workload Automation AE.
• You have CA Workload Automation AE running.
• Workload Automation iXp is installed on your system.

Architecture and Processing
CA Workload Automation iXp architecture consists of the following elements:

• iXp Daemon
• iXp Cache
• iXp Client
• iXp Agent

All communications between iXp clients and server are secured with SSL when the Tomcat server is configured for
HTTPS.

iXp Daemon

This process runs on the iXp Server machine and is the only process that runs constantly. The iXp Daemon is a multi-
threaded Java process that performs the following functions:

• Collects all the relevant job data from the CA Workload Automation AE instances
• Maintains the iXp Cache
• Supplies the data to all the iXp clients

The iXp Daemon runs as a servlet within a Web Application Server (for example, Tomcat).

iXp Cache

These highly compressed data files in proprietary binary format include all the CA Workload Automation AE Remote
Agent data that the iXp Daemon and the iXp clients require.
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iXp Client

The iXp Client is the JavaTM-based GUI that can be opened on any Java-supported system, and the Command Line
Interface (CLI) that can be opened on supported systems.

• The GUI provides the capability to monitor, report, forecast, control, and update job processing across the CA
Workload Automation AE instances. Because the GUI is a Java application, there is no software installation required
on the machine that will open the client.

• The CLI provides the capability to run CA Workload Automation AE commands, such as sendevent, autorep, jil, and
job_depends, from any machine without installing thCA Workload Automation AE client software.

iXp Agent

The iXp Agent is a Java program that runs on a CA Workload Automation AE Remote Agent. The iXp Agent lets iXp
Clients retrieve the output files that CA Workload Automation AE jobs create.

iXp also provides a PERL-based agent that has been deprecated. The iXp Daemon can start this program automatically
when needed, or it can be started as a job from CA Workload Automation AE. The iXp Server can install this program
automatically, or the iXp administrator can install it manually.

Note: The iXp Agent is not required with CA Workload Automation AE r11.3 and higher .

Processing Examples

The following examples explain how the CA Workload Automation iXp components participate in processing.

Server Invocation

Server invocation represents a call from a client (web browser) to the server, which in turn makes a call to refresh or
request data from a CA Workload Automation AE instance.

Data Refresh Cycle

The processing done by each component of the architecture and the interaction between them during a normal data
refresh cycle for the iXp Daemon and the Client are described as follows:

1. The iXp Daemon reads data from the CA Workload Automation AE databases for each instance. A group of CA
Workload Automation instances is called a site.

2. It updates the iXp Cache with the newly fetched data.
3. The iXp Client contacts the web application server during its refresh cycle, and reads the iXp Cache for the data

refresh. Since the iXp application is a multi-threaded software, it can service multiple client requests simultaneously.

On-Demand Activity Example

The processing done by each component and the interaction between them when an iXp Client performs an on-demand
activity such as putting a job on hold are described as follows:

1. The iXp Client contacts the web application server.
2. The web application server associates the request with a thread and asks it to perform the action to put the job on

hold.
3. The thread uses the sendevent command to perform the action and reports the status back to the web application

server.
4. The web application server then reports the status back to the iXp Client and the thread exits.

 32



 CA Workload Automation iXp 11.4.00

Log File Retrieval

The processing of each component and the interaction between them when an iXp Client requests retrieval of a log file
(e.g. STDOUT) created by a job running in Unicenter AutoSys JM r11 or older are described as follows:

1. The iXp Client contacts the iXp Daemon via the web application server.
2. The iXp Daemon then requests the iXp Agent on the CA Workload Automation AE Agent machine (where the job ran)

to read the appropriate log file and send the contents back to the iXp Server. If the iXp Agent is not running, then the
iXp Daemon sends a message back to the Client indicating that the Agent is not running.

NOTE
Beginning with AutoSys r11.3, the iXp Daemon requests the AE Application Server to collect the log from
the Agent machine.

3. Once it receives the contents, the iXp Server sends the contents back to the requesting iXp Client. The iXp Client
displays the contents in a browser window.

Security
The following two security methods are available for controlling access to iXp:

• Native iXp security
• Single sign-on (SSO)

In either case, iXp security includes the following features:

• Data transmission between the server and client machines can be secured and encrypted through current secure
HTTP technology. Also, the sensitive data stored by iXp is encrypted.

• Roles can be assigned to the iXp user identities to provide read, update, and control privileges for the CA Workload
Automation AE objects.

• The security model is very dynamic and user policies can be changed on the fly. Changes immediately take effect and
a user logout is not necessary.

• The iXp administrator can easily manage the security role policies through the iXp Admin Tool.

Native iXp Security

iXp provides a native multi-layered security model that encompasses data encryption, user authorization, and optional
user authentication. The same security model is applied to both the iXp GUI and the iXp CLI.

In this model, user access to iXp requires validation of the user identity and password. By default, user identities and
passwords are managed in iXp and have no relation to system/domain IDs and passwords. However, user authentication
(username/password check) can be performed by a remote LDAP-based server (ActiveDirectory, SunOne, Novell
eDirectory) if configured.

Single Sign-On

Using the single sign-on, iXp leverages the user ID already authenticated to the Active Directory Domain or the local
machine. No password maintenance is required for users stored in iXp.
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Installing
This section contains steps to install the iXp Server components on UNIX, Windows, and Linux Web Servers.

To install CA Workload Automation iXp, perform the following tasks:

1. Review basic system requirements.
2.  Install the iXp Daemon on the iXp Server.

The Web Application Server starts this process as a servlet. The main tasks of installation are:
a. Satisfying software prerequisites.
b. Installing iXp files.
c. Configuring iXp so it can communicate with all the CA Workload Automation AE instances to be managed.
d. Configuring user security.

3. You can download the iXp GUI from the iXp Landing page (http://hostname/ixp/) to your machine, or if you have a
Java Web Start enabled desktop JRE you can run the GUI directly by clicking on the link within the iXp Landing page
itself (no client installation required). For more information on installing the GUI on a client machine, see Install the iXp
Graphic User Interface on a Windows Desktop.

4. Install the iXp Agent.
 
The iXp Agent is a Java program that runs on a Unicenter AutoSys JM 4.5.1 or r11 Remote Agent. The iXp Agent lets
iXp Clients retrieve the output files created by Unicenter AutoSys JM 4.5.1 jobs.
 
iXp also provides a PERL-based agent that has been deprecated. This program can be started automatically by the
iXp Daemon when needed, or can be started as a job from Unicenter AutoSys JM 4.5.1. This program can be installed
automatically by the iXp Server or manually by the iXp administrator.

5. (Optional) Install the iXp Client CLI on client stations.
Since the client is a Java application, no software installation is required on the machine where it is opened.
The iXp Client CLI can be installed on any supported system. We recommend that you install the Client CLI on those
machines from which users want to run certain CA Workload Automation AE commands (e.g. autorep, autocal_asc,
sendevent, jil). You do not need to install the CA Workload Automation AE Client software on machines where the iXp
Client CLI is installed.

6.  Review the post-installation checklist.

Install the iXp Server
After you met the system requirements, proceed with installing the iXp Server.

Follow these steps:

1. Review the iXp Server Pre-Installation Checklist.
2. Configure or install JRE.
3. Configure or install Tomcat.
4. Install the iXp Server.

Configure or Install JRE

The iXp Server needs a 64-bit Java Runtime Environment (JRE). If the Java environment is not present, install the
appropriate version.

NOTE
For a list of supported JRE versions, see the Compatibility Matrix.
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To check the version of Java on the server machine, run the following command from a command prompt.

 % java –version
 

The following response may appear based on the Java version you installed:

 java version "1.7.0_05"
 Java(TM) SE Runtime Environment (build 1.7.0_05-b064)
 Java HotSpot(TM) 64-Bit Server VM (build 23.1-b034, mixed mode)
 

The java executable that was run above is typically stored in the /usr/bin directory on UNIX/Linux systems and C:
\Windows\System32 on Windows systems. On UNIX/Linux, it is a soft link to the real java executable in the directory
where the Java environment resides. There is a possibility that the required version of Java is present on the server
machine, but it is not present in the PATH of the user. Before installing the new version of Java, it may be helpful to search
the server machine for any other versions of Java.

Once the JRE files have been located, put the directory in the PATH environment variable of the user that
will install and run iXp. For example:

 PATH=/opt/jre1.7/bin:$PATH; export $PATH (On UNIX/Linux)
 

To download and install the required JRE, go to the java.oracle.com website (or http://www.oracle.com/technetwork/
java/javase/downloads/index.html) and follow the provided download instructions. If your platform is not listed, contact
Broadcom Support for appropriate download directions.

Configure or Install Tomcat

The iXp server requires an Apache Tomcat server.

If Tomcat is not present on the machine, download it from the Apache Software Foundation (http://tomcat.apache.org).

NOTE

• For a list of supported Apache Tomcat versions, see the Compatibility Matrix.
• If the iXp server will be installed on a Windows machine, download the 32-bit/64-bit Windows Service

Installer.

Note: If the iXp server will be installed on a Windows machine, download the 32-bit/64-bit Windows Service Installer.

To install Tomcat on a UNIX/Linux machine, extract the contents of the Tomcat tar file to the appropriate location. You
can edit the "conf/server.xml" file under the base Tomcat directory to change the default parameters (port numbers, http
mode).

To install Tomcat on a Windows machine, run the Windows Service installer, and make modifications to the default
parameters as necessary (port numbers, login options).

Start the Tomcat process as a user with the following privileges:

• Full privileges for the iXp home directory and its sub-directories.
• Edit and Exec Superuser capability on all Unicenter AutoSys JM and CA Workload Automation AE instances (Only if

users will be performing job updates or sendevents through iXp).
• If the Unicenter AutoSys JM or CA Workload Automation AE instances are enabled with CA EEM, the Tomcat user

must be defined in CA EEM with full privileges to all resources within each resource class related to those instances.

On Windows, you can configure the "Login" property of the Tomcat service to start as a user with these privileges.

Comment the following line in the <tomcat>\conf\server.xml file:
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<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />

Install the iXp Server

Install the iXp Server using the following DVD image files:

• The ISO file for  Workload Automation iXp 11.4.00 Third-Party Requirements
• The ISO file for Workload Automation iXp Release 11.4.00

Follow these steps:

1. Create the iXp Root Directory where all the iXp files will be stored, as defined in the iXp Server Pre-Installation
Checklist. Make sure the directory can store up to 2 GB of data.

2. Log in to the Web Server machine as the user that runs the web application server (Tomcat).
3. Mount the ISO file for Workload Automation iXp 11.4.00 Third-Party Requirements.
4. From the ISO image mount point, run the following installation files:

– Windows: installer.bat
– UNIX: installer.sh
You must agree to the EULA (End-User License Agreement) to continue.

5. Extract the archive files to the "lib" directory under Tomcat as follows:
– On UNIX/Linux: Extract the tar file "ixp-thirdPartyLib-11.4.00.X.tar" from the ISO image.
– On Windows: Extract the zip file "ixp-thirdPartyLib-11.4.00.X.zip".
In the filenames, X is the latest build number.

6. Mount the ISO image for Workload Automation iXp Release 11.4.00
7. From the ISO image mount point, run the following installation files:

– Windows: installer.bat
– UNIX: installer.sh
You must agree to the EULA (End-User License Agreement) to continue.

8. Set the following environment variables:
– IXP_HOME

Specifies the root directory of the iXp files.
– JAVA_OPTS

Specifies Java options.
– JAVA_HOME

Specifies the root directory of Java.
– CATALINA_HOME

Specifies the root directory of Tomcat.
– PATH

Must include the bin directory of Java.
For example:
 % IXP_HOME=/export/home/ixphome; export IXP_HOME 
% JAVA_OPTS="-Dixp.home=$IXP_HOME –Xms1500m –Xmx1500m"
% JAVA_HOME=/opt/jre1.7
% CATALINA_HOME=/opt/tomcat7
% PATH=$JAVA_HOME/bin:$PATH
% export JAVA_OPTS JAVA_HOME CATALINA_HOME PATH
 

9. Configure the Tomcat server:
– On Windows, open the Configure Tomcat menu item from the Windows Start Menu and make the following

changes:
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• Under the "General" tab, change the "Startup type" to "Automatic" if appropriate.
• Under the "Log On" tab, if not performed earlier, change the service to run as a Windows user that has full

Edit and Exec super user privileges to all the CA Workload Automation AE instances. If the CA Workload
Automation AE environment is enabled with CA EEM, this user must be defined in CA EEM with full privileges to
all resources within each resource class that relates to CA Workload Automation AE.

• Under the "Java" tab, add the following three lines to the "Java Options" item:
 -Dixp.home=IXP_HOME 
 -Xms1500m
 -Xmx1500m
 

• IXP_HOME
Specifies the root directory for iXp software. This value has to be specified in the Windows 8.3 format.

– On UNIX/Linux, add the lines from step 8 to the login profile of the user that runs the web application server.
10. Extract the following archives to the IXP_HOME directory:

– On UNIX/Linux, extract the tar file "ixp-distrib-11.4.00.X.tar" from the ISO image.
– On Windows, extract the zip file "ixp-distrib-11.4.00.X.zip".

11. Go to the $IXP_HOME/webapps sub-directory and copy the iXp WAR file (ixp.war) to the appropriate directory of the
servlet engine. For the above example, copy the file to /opt/tomcat7/webapps directory. If this directory has a previous
iXp WAR file, then delete that file before copying this new file. Also, delete the /opt/tomcat7/webapps/ixp directory and
all of its contents.

12. Restart the Web Application Server:
– On Windows, start the Tomcat server.
– On UNIX/Linux, run the following command:

 $CATALINA HOME/bin/startup.sh
 

13. Monitor the following log files to make sure that iXp comes up without error:
– $IXP_HOME/log/ixpDaemon.log
– $CATALINA_HOME/logs/catalina.out

iXp Server Pre-Installation Checklist
The following information will be requested during the installation of the iXp Server. Fill in the values you will use during
the installation process:

• Hostname of the Web Server
Your value: ____________________________________________________
Example: venus

• IP Address of the Web Server
Your value: ____________________________________________________
Example: 192.168.200.19

• Port number of the Web Server process
Your value: ____________________________________________________
Example: 8080

• Secure or Standard Web Server process (http or https)
Your value: ____________________________________________________
Example: Standard (http)

• Total Number of CA Workload Automation AE Instances that will be monitored
Your value: ____________________________________________________
Example: 3 (PRD, DEV, TST)

• Web Server Type and Version
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Your value: ____________________________________________________
Example: Tomcat v7

• Location of Web Server webapps directory
Your value: ____________________________________________________
Example: /opt/tomcat7/webapps

• Directory for JRE binaries
Your value: ____________________________________________________
Example: /opt/jre1.7/bin

• CA Workload Automation AE RDBMS Vendor
Your value: ____________________________________________________
Example: Sybase

• Location and name of PERL v5.x executable
Your value: ____________________________________________________
Example: /opt/perl5/bin/perl

• CA Workload Automation AE Root Directory (AUTOSYS) on the Web Server
Your value: ____________________________________________________
Example: /opt/CA/WorkloadAutomationAE/autosys

• Directory for CA Workload Automation AE Configuration Files (AUTOUSER) on the Web Server
Your value: ____________________________________________________
Example: /opt/CA/WorkloadAutomationAE/autouser

• Value for Library Path environment variable (LD_LIBRARY_PATH or SHLIB_PATH or LIBPATH)
Your value: ____________________________________________________
Example: /opt/CA/WorkloadAutomationAE/autosys/lib:/opt/CA/CAlib

• Directory for Sybase interfaces file (SYBASE) on the Web Server
Your value: ____________________________________________________
Example: /opt/sybase

• Directory for Oracle tnsnames file (TNS_ADMIN) on the Web Server
Your value: ____________________________________________________
Example: N/A

• Oracle Home Directory on the Web Server (ORACLE_HOME)
Your value: ____________________________________________________
Example: N/A

• Root Directory where iXp files will be installed (IXP_HOME)
Your value: ____________________________________________________
Example: /opt/ca/ixp

• Root Directory for iXp files (IXP_HOME) on the iXp Clients and iXp Agents (for CLI)
Your value: ____________________________________________________
Example: C:\ca\ixp

Installing the iXp Agents
The iXp Agents run on the Remote Agent machines from which the iXp Clients retrieve job log files. The iXp Agent can be
installed at your convenience. The iXp distribution image includes the software to install the full client (which includes the
iXp CLI and Agent), or only the iXp Agent. The software is located in the "install" sub-directory under the iXp root directory.

NOTE

The iXp Agent is not required with CA Workload Automation AE r11.3 and higher.

Contents:
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Install Java Agent on UNIX/Linux

The following software files enable the full Client and Agent-only installation:

• ixp-client-RELEASE-PLATFORM.tar
• ixp-agent-RELEASE-PLATFORM.tar

Where RELEASE is the version of iXp and PLATFORM is the OS platform for which the Agent has been compiled.

Follow these steps:

1. Copy the file appropriate for the Agent platform to the Agent machine.
2. Create a directory that will contain the Agent software and extract the contents of the TAR file to this directory.
3. Modify the Environment profile file for the user running the Agent program to include the following environment

variables.
IXP_HOME=<Root Directory of Agent Software>; export IXP_HOME

PATH=JAVABIN:$PATH; export PATH

– JAVABIN - Specifies the directory that contains binaries for Java v1.7 or v1.8
4. If $IXP_HOME/etc/ixp.conf file does not exist, copy the sample file provided ($IXP_HOME/etc/ixp.conf.sample) to

ixp.conf using the following command:
cp $IXP_HOME/etc/ixp.conf.sample $IXP_HOME/etc/ixp.conf

5. Edit the ixp.conf file to specify the location of the iXp Server.
IXP_SERVER_URL=PROTOCOL://IXPSERVERNAME:PORT

– PROTOCOL - Specifies http or https, depending on the configuration.
– IXPSERVERNAME - Specifies the name or IP address of the iXp Server machine.
– PORT - Specifeis the Port number of the iXp Server process.
For example:
IXP_SERVER_URL=http://venus:8080

6. Normally, CA Workload Automation AE jobs refer to certain environment variables when specifying the STDOUT/
STDERR file names. Also, the default location of Remote Agent log files can be configured to be different than /tmp.
We recommend that you create a file for each CA Workload Automation AE instance that specifies the values for such
variables. That way, when users request log files that contain names of environment variables, the Agent will be able
to substitute the appropriate values.
For each instance, create $IXP_HOME/agent/conf/$AUTOSERV.conf files, where $AUTOSERV = the 3 letter name for
the CA Workload Automation AE instance.
For example:
 $IXP_HOME/agent/conf/DEV.conf for the DEV instance.
 $IXP_HOME/agent/conf/TST.conf for the TST instance. 
 

A sample of environment variables that you can specify in each file is as follows:
 AUTOSYS=/opt/CA/WorkloadAutomationAE/autosys
 AUTOUSER=/opt/CA/WorkloadAutomationAE/autouser
 AutoRemoteDir=/opt/CA/WorkloadAutomationAE/tmp
 LOGDIR=/opt/CA/WorkloadAutomationAE/logs
 

Start Java Agent on UNIX/Linux

After the iXp Agent has been configured as listed above, it has to be started so that the log files can be retrieved from this
machine. You need to start the Agent only once per iXp Server. You can start the Agent in various ways.
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• Create a CA Workload Automation AE job to start the Agent. You will need one job per Agent machine.
• Have the standard startup scripts for the machine start the Agent when the machine boots up.
• Start the Agent process by running the startup command in the background of an interactive UNIX command window.

The Agent can be run in one of the following two ways:

• A persistent process that will only stop if it encounters a fatal error, or if the iXp Server is not available for more than 30
minutes.

• A timed process that will gracefully finish when the specified duration is reached. It will also stop if it encounters a fatal
error, or if the iXp Server is not available for more than 30 minutes.

The syntax to run the iXp Agent is as follows:

$IXP_HOME/bin/ixagent SERVER_URL AGENT_MACHINE DURATION

• SERVER_URL = The URL connection string for the iXp Server
• AGENT_MACHINE = The name of the local Agent machine that matches the name specified in the Run machine field

of the CA Workload Automation AE job
• DURATION = The time, in minutes, for which the Agent will keep on running. If you want to run it persistently, specify 0

(zero)

For example,

$IXP_HOME/bin/ixagent http://venus:8080 neptune 0

This will run the agent as a persistent process, and it will connect to the iXp server running on venus over port 8080. The
agent will pick up all log file requests for jobs that ran on machine neptune.

$IXP_HOME/bin/ixagent http://venus:8080 neptune.ca.com 10080

This will run the agent for 7 days, and it will pick up all log file requests for jobs that ran on machine neptune.ca.com.

NOTE

You will need to run multiple executions of the Agent concurrently if you have jobs running on the same machine
but using different hostnames, DNS aliases, short and fully qualified names.

Install Java Agent on Windows

The following software files enable the full Client and Agent-only installation:

• ixp-client-RELEASE-win.zip
• ixp-agent-RELEASE-win.zip

where RELEASE is the version of iXp.

Follow these steps:

1. Copy the appropriate software image file to the Windows Agent machine.
2. Create a directory that will contain the Agent software and extract the contents of the ZIP file to this directory.
3. Modify the System Environment so that the following environment variables are present when the Agent process is

started.
Select the Control Panel > System > Advance > Environment Variables menu option and specify the following
values:
 IXP_HOME=<Root Directory of Agent software>
PATH=JAVABIN;%PATH%
 

If %IXP_HOME%\etc\ixp.conf file does not exist, copy the sample file provided (%IXP_HOME%\etc\ixp.conf.sample) to
ixp.conf using the following command:
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copy %IXP_HOME%\etc\ixp.conf.sample %IXP_HOME%\etc\ixp.conf

4. Edit the ixp.conf file to specify the location of the iXp Server as follows:
IXP_SERVER_URL=PROTOCOL://IXPSERVERNAME:PORT 

– PROTOCOL = http or https, depending on the configuration
– IXPSERVERNAME = Name or IP Address of the iXp Server machine
– PORT = Port number of the iXp Server process
For example,
IXP_SERVER_URL=http://venus:8080 

The IXP_SERVER_URL environment variable overrides the ixp.conf file. If this variable (optional:
IXP_SERVER_URL_2) is set, the value in the ixp.conf file is ignored. This simplifies the use of multiple iXp
environments.

5. Normally, CA Workload Automation AE jobs refer to certain environment variables when specifying the STDOUT/
STDERR file names. Also, the default value for the Remote Agent logging directory is stored within the CA Workload
Automation AE Remote Agent configuration only. We recommend that you create a file for each CA Workload
Automation AE instance that specifies the values for such variables. That way, when users request log files that
contain names of environment variables, the Agent will be able to substitute the appropriate values.
For each instance, create %IXP_HOME\agent\conf%AUTOSERV%.conf files, where %AUTOSERV% = the 3 letter
name for the CA Workload Automation AE instance.
For example,
%IXP_HOME%\agent\conf\DEV.conf for the DEV instance.

%IXP_HOME%\agent\conf\TST.conf for the TST instance.

A sample of environment variables that you could specify in each file is as follows:
 AUTOSYS=C:\Progra~1\CA\Unicen~1.DEV\autosys
 AUTOUSER=C:\Progra~1\CA\Unicen~1.DEV\autouser
 AutoRemoteDir=C:\Progra~1\CA\Unicen~1.DEV\tmp
 LOGDIR=C:\Progra~1\CA\Unicen~1.DEV\logs
 

NOTE

Specify at least the AutoRemoteDir environment variable, or else the iXp Agent will be unable to retrieve the
Remote Agent log files.

Start Java Agent on Windows

After the iXp Agent has been configured as listed above, it has to be started so that the log files can be retrieved from this
machine. You need to start the Agent only once per iXp Server.

To start the Agent, create a CA Workload Automation AE job to start the Agent. You will need one job per Agent machine.

Note: Since the Agent will run as a CA Workload Automation AE job, you have to restart the CA Workload Automation AE
Remote Agent service so that the new environment variables can be passed to the Remote Agent.

The Agent can be run in one of the following two ways:

• A persistent process that will only stop if it encounters a fatal error, or if the iXp Server is not available for more than 30
minutes.

• A timed process that will gracefully finish when the specified duration is reached. It will also stop if it encounters a fatal
error, or if the iXp server is not available for more than 30 minutes. If you choose this method, specify the date/time
conditions for the job such that the job runs every day and has start_mins of 5 minutes. That way, when the Agent
finishes, the job will restart the Agent within 5 minutes.

The syntax to run the iXp Agent is as follows:
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%IXP_HOME%\bin\ixagent.exe SERVER_URL AGENT_MACHINE DURATION

• SERVER_URL = The URL connection string for the iXp Server
• AGENT_MACHINE = The name of the local Agent machine that matches the name specified in the Run machine field

of the CA Workload Automation AE job
• DURATION = The time, in minutes, for which the Agent will keep on running. If you want to run it persistently, specify 0

(zero)

The following example will run the agent as a persistent process, and it will connect to the iXp server running on venus
over port 8080. The agent will pick up all log file requests for jobs that ran on machine neptune:

%IXP_HOME%\bin\ixagent.exe http://venus:8080 neptune 0

The following example will run the agent for 7 days, and it will pick up all log file requests for jobs that ran on machine
neptune.ca.com:

%IXP_HOME%\bin\ixagent.exe http://venus:8080 neptune.ca.com 10080

Note: You will need to run multiple executions of the Agent concurrently if you have jobs running on the same machine
but using different hostnames, DNS aliases, short and fully qualified names.

Install and Start PERL Agent

If any machine on which you want to run the iXp Agent does not have JRE v1.7 or v1.8, but has PERL v5.6.x or higher
installed, then you can run the deprecated iXp Agent. The PERL script for the iXp Agent can be installed manually on
every system or automatically by the iXp Daemon when needed.

To run the PERL iXP Agent, do any of the following:

• Copy the Agent Script file, $IXP_HOME/etc/runlog/ixpagent.pl, which is provided with the distribution, to each machine
and then run it to start the iXp Agent.

• Load the Agent Script as a database table on any relational database. The advantage of this mechanism is that the
script can be extracted to any machine by using a database command, rather than copying the file (as per the previous
section). By default, you can use the CA Workload Automation AE database on each instance.
Note: If you copied the PERL script on to the Remote Agent machines, you can skip this section.

Tips:

• We recommend that you create two jobs per Remote Agent machine in your environment. The first job performs
the SQL extract and the second job runs the extracted PERL script. You can set up the second job to run after the
SUCCESS of the first job and after its own completion. By doing this, you do not need to copy the Agent file to each
machine, as the first job for each machine will extract the code from the database.

• If you end up creating a job that performs the SQL extract, we recommend that you create a limited database user ID
that has permissions to read the IXP_AGENT table. That way, exposing the database user ID and password will not
compromise your current security model.

To install and start the PERL Agent as a database table, follow these steps:

1. cd $IXP_HOME/etc/runlog
2. Load the script using the appropriate command for the database type.

– For Oracle databases, use the following command:
zql -u <User> -p <Password> -s <TNS_ALIAS> -f ixpagent.zql 

– For Sybase databases, use the following command:
isql -U <User> -P <Password> -S <Dataserver> -i ixpagent.sql 

– For SQL Server databases, use the following command:
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osql -U <User> -P <Password> -S <Dataserver> -i ixpagent.sql

3. a. • <User> - The Database login user ID
• <Password>- The Database login password
• <TNS_ALIAS>- Oracle Database name
• <Dataserver>- Sybase Dataserver or SQL Server name
The commands create a table called "IXP_AGENT" on the database provided. The rows inside this table shall
contain the actual PERL script of the iXp Agent. If the iXp Server machine does not have a database client, then
copy the IXP_HOME/etc/runlog/ixpagent.sql file to any machine that has a database client and is configured to
reach the database, and run the above command from that machine. For example, you can copy the file to the
Unicenter AutoSys JM scheduler and run the above commands from there.

4. Extract the script from the database by running the following command on the machine from which the script was
loaded.
Note: If you copied the PERL script on to the Remote Agent machines, you can skip this step.
– For Oracle databases, use the following command:

zql -u <User> -p <Password> -s <TNS_ALIAS> -qh -c "select text from ixp_agent order by line" >

 ixpagent.pl

– For Sybase or SQL Server databases, use the following command:
xql -U <User> -P <Password> -S <Dataserver> -qh -c "select text from ixp_agent order by line" >

 ixpagent.pl

5. Copy the extracted script to a directory on every Remote Agent machine. In the above case, the file "ixpagent.pl" that
was created by extracting the information from the database needs to be copied to each Remote Agent machine.

6. Run the script as follows:
perl <FILE> http://<iXpServer>:<PORT> <Hostname> <Duratio

– <FILE>- The full path and name of ixpagent.pl
– <iXpServer>- The name of the iXp Server machine
– <PORT>- The Port number for Tomcat on iXp Server
– <Hostname>- The name of the iXp Agent machine
– <Duration> - The amount of time (in minutes) that the iXp Agent script will stay running.
The following command will have the iXp Agent running for 600 minutes before exiting. While the Agent is running, iXp
Clients can retrieve log files from the Agent machine:
perl C:\temp\ixpagent.plhttp://venus:8080 neptune 600

Install iXp Client CLI
The iXp Client CLI is a self-contained set of files that has to be copied to each machine from where the commands will be
executed. The total disk space required for these files is less than 3Mb.

You can set up the iXP Client CLI using environment variables or using the configuration file that is provided with the
installation. If the values are set as environment variables, then they take precedence over the lines in the file.

Contents:

Set Up iXp Client CLI using the Environment Variables

Follow these steps:

1. Copy the iXp Client CLI files to each machine from where commands will be executed.
2. Set the following environment variables:

– IXP_HOME=<Directory where software resides>
Specifies the base directory where the iXp Client CLI has been installed.

– AUTOSERV=<CA Workload Automation AE Instance name>
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Specifies the name of the CA Workload Automation AE instance for which the command is being executed. This
variable can be set before each execution, if the commands are being used for multiple instances.
Limits: 3 letters

For example:
 IXP_HOME=C:ixphome 
AUTOSERV=ACE 
 

3. (Optional) Set the iXp server address as variables. If these variables are defined, the configuration file is ignored.
 IXP_SERVER_URL=<http://IXP_SERVER:PORT>
IXP_SERVER_URL_2=<http://IXP_SERVER:PORT>
 

4. Execute the following command to create a configuration file:
  echo "IXP_SERVER_URL=http://IXP_SERVER:PORT" > $IXP_HOME/etc/ixp.conf (UNIX/Linux) 
 echo IXP_SERVER_URL=http://IXP_SERVER:PORT > %IXP_HOME%\etc\ixp.conf (Windows)
 

– IXP_SERVER
Defines the machine/IP address of the iXp Server

– PORT
Defines the HTTP port number of the iXp Server.

The configuration file is created under the IXP_HOME/etc directory and is named ixp.conf. This file contains a single
line that provides the URL of the iXp Server to the Client CLI. If the IXP_SERVER_URL variable is not defined in the
environment, configuration file is mandatory.
The following example shows a command to execute to create the ixp.conf file:
  echo IXP_SERVER_URL=[http://venus:8080/ > C:\ixphome\etc\ixp.conf 
http://venus:8080/
 

Now you can run the client CLI.

If there is an alternate iXp server running for high availability, add an additional line in the configuration file to provide its
connection information to the CLI.

  echo "IXP_SERVER_URL_2=http://IXP_SERVER_2:PORT" >> $IXP_HOME/etc/ixp.conf 
 

• IXP_SERVER_2
Defines the machine/IP address of the alternate iXp Server

• PORT
Defines the HTTP port of the alternate iXp Web Server

You can also define the alternate iXP server as an environment variable.

After you install the iXP Client CLI, set up authorizations for users to run the commands. This can be done from the iXp
Admin Tool.

Set Up iXp Client CLI Using Configuration File

You can also install the iXP Client CLI and set it up using the configuration file.

1. Log in to the Client machine and extract the installation files from the software image to the iXp Root Directory. Make
sure the directory can store up to 5 MB of data.
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The iXp Client CLI software is in a single file named ixp-client-RELEASEPLATFORM.tar (UNIX/Linux) or ixp-
clientRELEASE-win.zip (Windows). The software is located in the "install" subdirectory under the iXp root directory on
the iXp Server machine.

2. Edit the IXP_HOME\etc\ixp.conf file and add the following line that provides the connection information for the iXp
Server.
 IXP_SERVER_URL=http://IXP_SERVER:PORT
 

3. If there is an alternate iXp server running for high availability, add an additional line in the file to provide its connection
information to the CLI:
 IXP_SERVER_URL_2=http://IXP_SERVER_2:PORT
 

4. Have the user set the following two environment variables before executing the commands:
– IXP_HOME

Specifies the Root Directory on the Client machine where the iXp CLI is installed.
– AUTOSERV

Specifies the CA Workload Automation AE Instance name for which the command is being executed.
These variables can be set beforehand or at runtime.
The following example shows these environment variables set as per the sample check list:
 IXP_HOME=C:\ca\ixp
 AUTOSERV=DEV
 

To run the commands, users can go to IXP_HOME/bin directory.

Install the iXp Graphic User Interface on a Windows Desktop
Note: The iXp Graphic User Interface (GUI) and AdminTool may not launch directly from within the browser, for some users, when
using newer versions of Java Runtime Environments(JREs). In such scenarios, use the following procedure to install the iXp GUI or
AdminTool directly on your Windows desktop.

The Java WebStart feature was removed beginning with Oracle Java 11 LTS, due to architectural changes made to Java
by Oracle. The WebStart feature of desktop JREs allowed users to simply click on a URL link in the iXp webpage and start
the iXp GUI or AdminTool directly, without having to install any other component on their desktop. To facilitate maximum
compatibility for our customers, we have updated the iXp product so that it can be directly placed on a Windows desktop
and launched like a typical Windows application.

Follow these steps:

1. Ensure you have already installed a supported Java Runtime Environment on your Windows desktop. The list of
supported Client JREs is located at Compatibility Matrix.

Note: To test if you already have a supported JRE installed, you can open a cmd.exe or Powershell window and type "java –
version", and make sure version number is shown as an iXp Client supported version.

2. Open your desktop browser and enter the URL corresponding to an iXp installed server. For example, http://
prodGUI:8080/ixp

3. The iXp Product landing page is displayed indicating the iXp Version number and instructions for running iXp.

4. Click on the IXP_CLIENT.zip at the bottom section of the iXp landing page, and download it to your hard drive.
5. After the download has completed, open the ZIP archive and extract the contents to a folder on your hard drive. We

recommend you use a location like "C:/ixp" or "C:/applications/ixp" for clarity and future reference. 
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6. Open File Explorer and navigate to the folder where the ZIP archive was extracted.
Double click on the iXp.exe icon to start the iXp Launcher. It may take a few
moments before the new GUI is displayed, because it is loading the JRE in the
background.

Note: If you have problems starting the iXp Launcher., see the Troubleshooting section in this page.

Example:
The following is an example of the iXp Launcher. For more information, see the iXp Launcher.

Create a Desktop Shortcut

You can create a desktop icon or shortcut.

Follow these steps:

1. Browse to the  iXp.exe file on your hard disk.
2. Right-click the  iXp.exe file.
3. Select Create Shortcut from the menu. A shortcut to the iXp Launcher is created on your desktop.

Troubleshooting

When trying to start the iXp Launcher, if it does not start or an error is displayed, see the following troubleshooting steps.
There are 3 log files in the folder where the iXp.exe is located which will have trace information for startup and error
troubleshooting.

JRE missing/not found The iXp.exe application tries to launch a Java Runtime Environment(JRE) to display the iXp
Launcher GUI. If there is a problem in the your desktop environment, for example Java is not installed on your desktop, an
error will be displayed. Additional trace information can be found in the ixp.log file located in the users iXp install folder.

Workaround startup method If the event that you are unable to launch iXp.exe from your desktop, a workaround/
troubleshooting method is to use the failsafe.bat file located in the same folder as iXp.exe.

Follow these steps:

1. Open the failsafe.bat file using Notepad.exe.
2. Enter a valid iXp Server URL or port# to your iXp Server.
3. Double-click the failsafe.bat or run it from a cmd.exe window. Extra startup trace information is displayed to the

console window, which helps you troubleshoot further.

Missing Jars

If the iXp Launcher detects a missing Jar it will notify you. Reinstall the iXp Launcher using the install package from the
iXp main homepage.

Additional Logging

Additional trace logging can be found in launcher.log, admin.log and ixp.log located in the users iXp install folder.

Post-Installation Checklist
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After installation according to the above steps, the following items need to be done or verified to assure full functionality of
iXp clients.

A Web browser must be in the PATH variable on the client or the
location of the browser must be provided in the IXP_HOME/dat/
user/<username>/props file

√

Supported desktop JRE is needed on the client machine to run the
iXp UI.

√

The ID that the Web Application Server runs under needs to have
JIL update privilege in CA Workload Automation AE, if users are
going to be performing JIL updates through iXp. Typically, that ID
is the same as the CA Workload Automation AE Edit SuperUser
ID.

√

Installation Troubleshooting

Common Installation Problems

• IXP_HOME environment variable is not set correctly.
• Database URLs are incorrect.
• JAVA_OPTS environment variable is not set correctly.
• Database user password is incorrect.
• Database user permissions are incorrect.
• The Tomcat options for Java are not set correctly.

For problems with installing or using the desktop installation of iXp Launcher, see the following sections:

• Install the iXp Graphic User Interface on a Windows Desktop
• iXp Launcher

Symptoms and Solutions

SYMPTOM/PROBLEM CAUSE/SOLUTION
"Undefined User" error message. The system/AD user has not been defined to iXp yet. Log in as

"iXp Admin" and set up the user.
"Invalid Password" error message. Possible typo in login screen. Retype password.
Web Application Server does not start iXp Daemon JAVA_OPTS variable may be incorrect. Reset the JAVA_OPTS

variable, and restart the web server.
No jobs visible within iXp application and SQL exceptions in
ixpDaemon.log file.

Database URLs are incorrect. Correct the database URLs.

"permission denied" errors in ixpDaemon.log file. User permissions are incorrect. Solution: correct them.
"unauthorized access" errors in ixpDaemon.log file. Database user password is incorrect. Solution: correct it.
Java Web Start window does not show the icons for iXp or Admin
Tool

There is a problem with the URL specification or the web server is
not running.

English version of iXp appears on your French or Italian operating
system.

Cause may be the locale variable is not set on your system.
Solution: set the locale variable on your system.

Upgrade from 11.3.x to 11.4.x
You can upgrade iXp using one of the following procedures, based on your requirements.
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InPlace Upgrade

You can inplace-upgrade an existing iXp r11.3.x installation to r11.4.x.

NOTE
The Pre-requisites for Release 11.4 apply.

Follow these steps:

1. Verify the Compatibility Matrix of the existing iXp release for Java/OS/Tomcat versions Release 11.4 requirements.
2. Stop the Tomcat/iXp server.
3. Back up the <IXP_HOME> folder.
4. Back up the <TOMCAT_HOME> folder.
5. Delete the <TOMCAT_HOME>/webapps/ixp.war and <TOMCAT_HOME>/webapps/ixp folders.
6. Extract the r11.4-GA ISO and the 3rd party ISO to a temp folder. (C:\Temp or /tmp)
7. Execute the installer.bat/installer.sh and agree to the r11.4-GA EULA.
8. Extract the ixp-upgrade-11.4.0.134.tar from the ISO to a temp folder. (C:\Temp or /tmp)
9. Copy the ixp.war file from webapps/ixp.war to the <TOMCAT_HOME>/webapps folder.
10. Start the Tomcat/iXp server.
11. Download the new iXP GUI and confirm users can log in to the system.

NOTE
Some users may need to clear their Java cache to download the new iXp GUI.

The inplace-upgrade is now complete.

Fresh Installation

You can migrate a newly installed iXp release from one server to another.

NOTE
Copy the pre-existing IXP_HOME folder to new server.

Follow these steps:

1. Verify the Compatibility Matrix for the IXP release you plan to migrate and confirm the requirements are met on the
new server.

2. Back up the entire IXP_HOME folder on the existing server and copy to the new server.
3. Copy the ixp.war file to the <TOMCAT_HOME>/webapps folder.
4. Configure the environemt with proper <IXP_HOME>/<TOMCAT_HOME> folder on the new server.
5. Start the Tomcat/iXp server.
6. Download the iXP GUI/iXP Admin and confirm users can log in to the system.

NOTE
Some users may need to clear their Java cache to download the new iXp GUI.

The installation on the new server is now complete.
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Administrating
Workload Automation environments are rapidly transitioning to a self-service management mode. With Workload
Automation iXp, Broadcom delivers the next generation in web-based graphical workload automation, as a secure and
scalable solution. These guiding principles are central to the development of Workload Automation iXp:

1. The architecture should scale up and down. Users requiring minimal data should have minimal bandwidth
requirements. Users requiring access to large volumes of data should expect quick response with conventional
desktop hardware in a local area network.

2. The client should be easy to maintain. The only current requirement for the client to run iXp is to install the
JavaTM plug-in. With respect to CA Workload Automation AE monitoring, the client does not require a CA Workload
Automation AE client license. In addition, iXp administrators can configure user-defined commands that enable clients
to perform custom server-side executions.

3. Management by exception is facilitated throughout iXp.
– Alarms are selected to the top of the Console View.
– Failures within boxes are visible while boxes are still running.
– Sort by Status is available.
– Impact analysis including critical path filtration facilitates response to exceptions.

Access the iXp Admin Tool

The iXp Administration Tool ("Admin Tool") allows the iXp administrator to control and monitor security, user permissions,
user commands, and connections to CA Workload Automation AE. iXp Admin Tool functions manage authentication and
authorization policies for end users. The tabs at the top of the iXp Admin Tool allow the administrator to view, enter or
modify information pertaining to a particular area. The data within each tab has to be saved individually. For example,
clicking the Save button on the Configuration tab would save only the iXp Server information.

To access the iXp Admin Tool, you must be a designated iXp administrator. The Admin Tool can be launched from the iXp
landing page by clicking on the Admin Tool link, or by manually installing Java WebStart on your iXp Client machine.

Follow these steps to manually launch the iXp Admin Tool:

1. Pass the appropriate iXp URL as an argument to Java Web Start on your iXp Client machine. You can find the URL
value in your Pre-Installation Checklist.
Using the working example, run the following command on your Client machine:
javaws http://MACHINE:PORT/ixp/AdminTool.jnlp 

– MACHINE
Specifies the name of the iXp Server machine.

– PORT
Specifies the port number of the Web server (for example, 8080).

Example:
javaws http://venus:8080/ixp/AdminTool.jnlp

2. When prompted with a Security Warning, click Always and Run to continue opening the iXp Admin Tool.
The first time you open the application, Java Web Start has to download the application image, so you may experience
some delay if you have a busy network. This initial download only occurs the first time you open an application through
Java Web Start or when software upgrades occur. Once loaded you should see the login prompt.

3. At the iXp login prompt, enter the user "ixpAdmin" and the default password "ixpAdmin". You will be prompted to
change the password for this user. Select a new password that is at least 8 characters long, and has one special (non-
alphanumeric) character, one uppercase letter, and one numeric character.
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We recommend creating a shortcut for opening Java Web Start on your desktop. Java Web Start prompts you to do that
when used for the first time. After doing so, subsequent opening of iXp can be done by using the desktop shortcut or by
opening the Java Cache Viewer using the command "javaws -viewer".

Configure CA Workload Automation AE Instance
Select the Instance tab in the iXp Admin Tool to enter the CA Workload Automation AE Instance configuration area.
Each CA Workload Automation AE instance to be accessed from iXp has to be set up. The Copy Instance button can
be used to create an identical AUTOSERV instance connection with a new instance name. Once copied, just the unique
information should be changed.

Contents:

General Options

The following table explains the fields listed in the General section. This section enables you to specify how much Run
Data and Alarm data will be stored on the iXp Server, and other time-out related settings.

Field Description
AUTOSERV The CA Workload Automation AE instance name, as denoted by

the AUTOSERV environment variable.
Refresh Enabled Used to enable or disable the iXp Daemon data retrieval process

from the instance. If disabled, the iXp Daemon will not read any
data from the instance until it has been enabled.

Visible Select this check box to make this instance appear in the GUI.
If you clear this check box, this instance is only accessible from
iXp Admin Tool. It will not appear anywhere in the GUI. A report
that runs against multiple instances will not show information for
the invisible instance. A report that only references the invisible
instance will give an error.

Version The Version of CA Workload Automation AE for this Instance. The
default is Release 11.3.6.

Sleep Time The numbers of seconds that the iXp Daemon will be idle between
data refresh cycles. The default value for this setting is Server
Sleep Time – 1 second.

JIL Reload Timeout Number of seconds to wait before reload of JIL based on job time
stamp changes.

Minimum JIL Reload Interval Minimum number of seconds to wait for JIL reloads, irrespective of
the amount of changes being made.

Forecast Duration Specifies if the iXp Forecasting Engine should generate a real-
time forecast of upcoming events and runs, based on the current
state of the CA Workload Automation AE instance. If this value
is set to non-zero, then on every Instance refresh cycle, the iXp
Server will generate a forecast for the next X hours, where X is the
value specified here. The default is 0.

Run Past Hours The iXp Daemon will retrieve all the runs within the CA Workload
Automation AE instance that either started, or ended in the time
frame set by this field. If set to 0 (zero), the iXp Daemon will not
retrieve any run data for the instance, until the value is changed.
The lower value here, the faster the performance of the server.
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Alarm Past Hours If the value for this field is set to 0 (zero), the iXp Daemon will not
retrieve any alarms from the instance. If the value is set to any
value greater than 0 (zero), then the iXp Daemon will retrieve all
the alarms from the instance. This setting is "loosely enforced",
meaning that the current setting plus 24-hours worth of alarms are
retrieved.

Stats Refresh Dictates how often the iXp Daemon retrieves and calculates
the CA Workload Automation AE performance statistics for the
particular instance. Typically, it is 30 to 45 minutes.

Stats Timeout Number of seconds after which server statistics collector process
will timeout.

Refresh from Secondary Connection If the CA Workload Automation AE instance has Dual Servers,
the iXp Daemon would retrieve the data from the Primary Server.
If this option is selected, the iXp Daemon will retrieve data from
the Secondary database. This may be useful in case of network
problems or database issues.

Refresh On Demand If this option is selected, the iXp Daemon will try to retrieve CA
Workload Automation AE data at the most optimal point in its
refresh cycle. This ensures that the iXp Cache features more
recent job status information. If you have a busy iXp Server and
fast-performing database servers, we recommend that you turn
this option ON.

Command-Line Options

The following table explains the fields listed in the Command Line section. You can specify the Date Format that is used
for this CA Workload Automation AE instance, and alternate "jil" and/or "sendevent" commands.

Field Description
Sendevent Shell Command By default, iXp uses "/bin/sh" or "cmd /c" when executing the

sendevent command on the iXp server. You can specify an
alternate shell command here (e.g. ssh).

JIL Shell Command By default, iXp uses "/bin/sh" or "cmd /c" when executing the jil
command on the iXp server. You can specify an alternate shell
command here (e.g. ssh).

Sendevent Command iXp uses "sendevent" as the default command to use when
performing certain actions. You can specify a new command here,
and iXp will pass all the sendevent parameters to the command
specified here, instead of passing them to the "sendevent"
command.

JIL Command iXp uses "jil" as the default command to use when modifying,
creating job and override definitions. You can specify an alternate
command here, and iXp will pass the JIL file to this command
instead.

Date Format The Date Format, as specified within CA Workload Automation
AE, for this instance. This field is needed for proper functioning
of "sendevent". The value for this field must be identical to what
has been specified within the CA Workload Automation AE
configuration file/registry.
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Environment Options

The following table explains the fields listed in the Environment section. You can specify the values for all the CA
Workload Automation AE related environment variables here.

Field Description
AUTOSYS Path to AUTOSYS directory on the iXp Server. If the CA Workload

Automation AE Remote Agent has not been installed on the iXp
Server, leave this field blank.

AUTOUSER Path to AUTOUSER directory on the iXp Server, if the CA
Workload Automation AE Remote Agent has been installed on the
machine.

ORACLE_HOME Value of the ORACLE_HOME environment variable on the iXp
Server. This value is not needed with Unicenter AutoSys JM r11
and higher versions.

SYBASE Value of the SYBASE environment variable on the iXp Server.
This value is not needed with Unicenter AutoSys JM r11 and
higher.

TNS_ADMIN Value of the TNS_ADMIN environment variable on the iXp Server.
This is needed by the CA Workload Automation AE client to locate
the database connection information. This value is not needed
with Unicenter AutoSys JM r11 and higher.

LD_LIBRARY_PATH/ SHLIB_PATH/ LIBPATH Value of the applicable environment variable that is required to
locate the CA Workload Automation AE libraries.

Database Options

The information provided in the checklist for AUTOSYS, AUTOUSER, SYBASE, TNS_ADMIN, ORACLE_HOME,
LD_LIBRARY_PATH, SHLIB_PATH, LIBPATH, and TZ environment variables is applied to each instance of CA Workload
Automation AE that is configured.
The following table explains the fields listed in the Database section. The fields in this section specify the connection
information to the CA Workload Automation AE database.
The Primary Connection and Secondary Connection values mirror the CA Workload Automation AE convention for
Primary and Secondary Event Servers.

Field Description
Database Vendor Name of the supplier of the CA Workload Automation AE

database (Oracle, SQL Server, Sybase). Oracle is the default.
JDBC Driver JavaTM DataBase Connection driver. The drop-down lists the

options for Sybase, Oracle, and SQL Server drivers.
Schema Owner The owner of the DB schema being used by CA Workload

Automation AE— needed only for Oracle (typically "aedbadmin" or
"mdbadmin")

URL The database connection parameters used by the JDBC driver.
User The database user for the connection.
Password The password for the database user.
Re-enter Re-enter the password for verification.
DSQUERY The name of the Sybase Dataserver or the ORACLE TNS alias.
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Row Prefetch The number of rows that is fetched at a time by the Oracle JDBC
driver when performing any database query. The default value
is 10. If you notice that the iXp server is experiencing slow data
retrieval times, we recommend that you set it to 1000.

In addition to these values, the following information about each database is needed:
JDBC Driver
oracle.jdbc.driver.OracleDriver (Oracle)
net.sourceforge.jtds.jdbc.Driver (Sybase)
net.sourceforge.jtds.jdbc.Driver (MS SQL Server)
URL
jdbc:oracle:thin:@HOST:PORT:SID (Oracle)
jdbc:jtds:sybase://HOST:PORT/DATABASE (Sybase)
jdbc:jtds:sqlserver://HOST:PORT/DATABASE (MS SQL Server)
User/Password
DBUSER(All)
DBPASS (All)
where:

HOST = Hostname or IP Address of the machine where the autosys
RDBMS resides

PORT = Port number for the database
SID = The Oracle SID or Global Service Name for the Oracle instance

that the database is on
DATABASE = The name of the Sybase or MS SQL Server database where the

CA Workload Automation AE data for the instance is stored. This
parameter needs to be used only when the name of the database
is not the same as the default database for the DBUSER.

DBUSER = The database user that has read permissions on all CA Workload
Automation AE tables and update permissions on the alarm table.
Typically, this is the database user autosys.

DBPASS = The password of the database user DBUSER.

The Connection Enabled check box allows the administrator to disable a DB connection (clear the check box) when a
database is down for maintenance or a rollover has occurred. If all the DBs are disabled (Connection Enabled check box
is cleared), then the GUI Instance Status Monitor will show the instance as "Disabled".

GUI Options

The following table explains the fields listed in the GUI section. You can use this section to customize how the CA
Workload Automation AE job data for this instance is shown in the iXp GUIs.

Field Description
Console Background You can specify the color that will be used to highlight the jobs

of this CA Workload Automation AE Instance, in the iXp Console
View. The default is "No Highlight".

Timezone The timezone value for this instance. This value can be displayed
whenever start times or end times for jobs belonging to this
instance are shown.

Time Format The format that will be used to display the dates, times, and
timezone for the run data for jobs of this instance.
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Current Time Shows a sample display of date/time, for the chosen value in the
"Time Format" field.

Enable Server Statistics for All Users If this option is selected, all iXp Users will be able to view the iXp
Server Statistics Graph for their instances.

Enable Server Statistics for iXp Administrators Only If this option is selected, then only iXp administrators will be able
to view the iXp Server Statistics Graph for their instances.

Maximum Alarm Response Length The total number of characters allowed in the response field when
acknowledging or closing an alarm. The header data that iXp
automatically adds for each alarm response is included in this
value. This value should not exceed 127 characters.

NOTE: We recommend that you create all the needed CA Workload Automation AE instance information first, before
creating user definitions.
IMPORTANT! Restart the iXp Web Application Server (Tomcat) after all the CA Workload Automation AE instances have
been created.

NOTE: You also have to restart the iXp Tomcat server every time you add a new CA Workload Automation AE instance.

Job Type Options

The following table explains the fields listed on the Job Type tab:

Field Description
Only permit the defining of Autosys 4.5 job types When selected, users are only allowed to define Unicenter

AutoSys JM 4.5.1 job types through ixjil (from the command line)
and File > CLI > jil
Note:  iXp no longer supports AutoSys r4.5; see the Server
Support Matrix for supported AutoSys versions.

CMD, Box, FW, FT, FTP When selected, users can access these job types in the iXp Job
Editor. The admin user can limit the job types that are accessible
to the user.

Configuring for Oracle RAC

If your CA Workload Automation AE instance is set up with Oracle RAC, you can define the database connection
information in iXp to leverage this configuration.
To set up iXp with Oracle RAC, perform the following tasks:

1. Copy the database connection information from the Oracle "tnsnames.ora" file on the CA Workload Automation AE
server machine.

2. Paste the database connection information in the "URL" field under the "Database" subtab in the "Instance" tab of the
iXp Admin Tool.

For example, the database connection URL can be as follows:
jdbc:oracle:thin:@(DESCRIPTION =(LOAD_BALANCE=on)(FAILOVER=on)(ADDRESS_LIST =(ADDRESS =
(PROTOCOL = TCP)(HOST = orasvr1)(PORT = 1521))(ADDRESS =(PROTOCOL = TCP)(HOST = orasvr2)(PORT =
1521)))(CONNECT_DATA = (SERVICE_NAME = ORCL)(FAILOVER_MODE=(TYPE=SELECT)(METHOD=BASIC))))

Validate the Instance Configuration

Once the Instance has been defined and the Tomcat server has been restarted, you can verify its configuration by
performing the following steps:

1. Open the iXp client, and log in as "ixpAdmin".
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2. Click the Instance name in the Tree View, right-click and select "Expand" option to see the top-level jobs of this
instance.

3. Select any job that is shown for this instance, and select the Edit > Edit Jobs menu option to see its definition in the
Job Editor.

4. Verify that the Console View is showing the Start and End Time information in the appropriate time format and time
zone.

Configure the iXp Server and GUI
The following table explains the fields listed in the iXp section. This section enables you to specify some general
information, and server-level configuration parameters.

iXp Server Configuration Fields Description
Site Name Name of the site running iXp software. The site name will be

shown in the Tree view of the main GUI. The site name must be at
least 4 characters long.

Site Description Description of the iXp Server site.
Sleep Time The time, in seconds, that the iXp Daemon will sleep after each

series of data retrieval from the CA Workload Automation AE
instances. The recommended value is between 1 and 10 seconds,
depending on the processing power of the iXp Server machine.
The default value for this setting is five (5) seconds.

Thread Timeout A central thread monitors all the threads of the iXp Daemon. If any
of the threads has not finished its work within the value specified
here, iXp will start reporting timeout errors. Setting a low value
here may be too restrictive on the daemon, and a high value
would not have any use. On average, no thread should take more
than 5 minutes to finish its work.

Audit Expiration iXp will maintain an online audit for the number of days specified
here. After that, the audit files will be archived. The default value is
30 days.

Log File Deletion iXp Daemon logs will be kept for the number of days specified
here. After that they will be deleted. The default value is 30 days.

GC Threshold Available memory is constantly checked and if below the
Threshold, GC (Garbage Collection) is requested from the Java
VM immediately. This means a high Threshold causes GC to
occur more often, which could degrade performance. Suggested
setting for GC Threshold is about 33% or less of the Tomcat -Xmx
setting.

Hold DB Connections If this option has been selected, each of the daemon threads that
reads data from its CA Workload Automation AE instance will
keep the database connection open. This reduces the processing
overhead on the server and the database. By default, this option is
turned off.

Parallel Refresh If this option has been selected, the daemon will retrieve data from
multiple CA Workload Automation AE instances concurrently. This
speeds up the data refresh cycle on the server. By default, this
option is selected.

Sequence System Calls Enable this option to limit the iXp Server to perform user actions
sequentially. This setting can be useful for servers with limited
RAM.
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The GUI tab controls instance monitoring and GUI idle timeout.

iXp Server
GUI Attributes

Description

Enable instance monitor The instance monitor is an icon, at the bottom left corner of the
GUI, which signifies the status of CA Workload Automation AE
instances. The check boxes enable this feature for all users or for
administrators only.

Pause client refresh If a user does not perform any action in iXp, the refresh will
automatically pause after the specified number of minutes. A pop-
up window informs the user, and when the user clicks "OK" the
automatic refresh resumes.

Set Up User Authentication
Click the Authentication tab at the top of the iXp Admin Tool window to configure the authentication policy for iXp. You
have to specify the user authentication model for users logging in to the Client GUI.

By default, iXp is configured to authenticate users based on Single Sign-On mode. The other option is to use
internally stored username/password based authentication. When using the latter mode, you can also choose to
have iXp authenticate some or all users with one or more LDAP (Lightweight Directory Access Protocol) authentication
servers.

From this tab, you can also enable the iXp Client CLI and specify the authentication model for users executing the
commands.

The following diagram illustrates the security model used in iXp:

  

 Contents: 

  

Single Sign-On Authentication

The Single Sign On authentication is the default authentication mode. With this mode, users do not have to enter a
username and password when they open the GUI. The iXp Client GUI will recognize users based on their Domain or OS
authentication.
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Under this method, you can provide a list of valid IP Addresses, Host names, and Windows Domain names. Users
that are not authenticated to the valid Domain, or whose iXp Client machines are not within the list of valid IP
Addresses or host names, will be unable to open the GUI.

IP Address

You can provide a list of IP Address strings that will cover all valid iXp Client machines. By default, access is enabled from
any IP address ("*").

You can provide multiple lists of valid IP Addresses, and you can use wildcards or ranges for any of the values. For
example: 

192...*

19.68.5.10-200

10.1.86.*

*

If an iXp Client machine matches any one of the specified IP Address lists, then only it will pass the IP Address check.

Host Names

You can provide a list of host name strings that will cover all valid iXp Client machines. The list of host names is needed
along with the list of IP Addresses. A valid iXp Client machine has to pass both the checks. By default, access is enabled
from any host name ("*").

You can provide multiple lists of valid host names and you can use wildcards for any values. For example, 

ukp*

usp*

usfinm1

*

If the host name of an iXp Client machine matches any of the specified host name lists, it will pass the host name check.

Domain

This field is used to validate the Domain or OS authentication of a user. You can provide a list of Domains or host names
that will cover all valid user authentications. The domain names are case-sensitive. By default, access is enabled from any
domain ("*").

If a user is logging on to a Windows Active Directory, NT Domain, or local Windows machine, you can provide the names
of valid Domains and local machine names. If a user logs on to a Domain not listed, or logs on to the local machine not
listed, then the user will not be authorized to open the iXp GUI.

If a user is logging on to a UNIX/Linux machine, then you have to provide the names of valid machines. In this case, the
list of machines could match the list of Host names provided earlier. For example:

CA

us*

*

Once a user has logged on from a valid client, and has authenticated to a valid Domain or machine, the user will be able
to open the iXp GUI. The user will not be asked to provide a password, since the authentication has passed all checks.

 57



 CA Workload Automation iXp 11.4.00

iXp User/Password Based Authentication

The iXp User/Password based authentication is an alternate authentication mode for users logging in to the iXp GUI. With
this option, usernames must be defined within iXp. We recommend that you use names that already exist for users in your
domain. The password authentication of users is performed using one of the following two modes:

• iXp: Authenticates using the password stored in iXp
• LDAP: Authenticates using the password stored in a remote LDAP

Each user can be configured independently, so that some users have passwords defined in iXp and others have
authentication performed by a remote LDAP server.

NOTE

• If you define a users password locally in iXp, you can also specify the password policies and other account
settings as described in the following table.

• If you use a remote LDAP server to perform the user authentication, the username that you define in
iXp must match the username defined in the LDAP server. No password is stored for this user in iXp, and
the users will be prompted for their LDAP login credentials when they log in to iXp GUI or iXp Admin Tool.
For users that are authenticated using LDAP, not all password policies are applicable, as described in the
following table.

• For more information about setting up LDAP authentication, see LDAP Authentication.
• When iXp is configured with multiple LDAP servers, iXp first checks for the user in the target LDAP

server and then performs authentication with the user-provided password. If the user was found but the
authentication fails, by default iXp does not check for the user in the remaining LDAP servers. To enable this
feature, you must change the default iXp authentication behavior. For more information, see Enable Failover
for User Authentication with Multiple LDAP Domains.

When you choose this authentication model, users have to enter a user name and password every time they open the
GUI.

The following table provides details on the fields for which information has to be provided:

 Field  Value 
Maximum Incorrect Entries The maximum number of incorrect password entries allowed

before the account is automatically Suspended. The default value
is 1000 tries.
 Notes: 
• This field applies for both the iXp user/password based

authentication and LDAP authentication.
• For LDAP authentication, iXp verifies the password of the

LDAP user name that is defined in the LDAP server. If the
maximum number of incorrect entries is reached, only the user
name that is defined in iXp gets suspended. If your domain
controller has a separate invalid-login-attempts parameter, it
will still be enforced by your domain controller.

Maximum Days The number of days after which the password for any user has to
be reset.
 Note: This field does not apply to users who are configured for
LDAP authentication mode.

Minimum Days After setting a password, users cannot change that password for
the number of days specified here. Administrators can still change
the password from the iXp Admin Tool. The default value is 0
days.
 Note: This field does not apply to users who are configured for
LDAP authentication mode.
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Unique Entries A new password cannot match the last X number of passwords.
The default value is 3.
 Note: This field does not apply to users who are configured for
LDAP authentication mode.

Maximum Account Idle Days If an iXp User account does not have any user or administrator
activity for the number of days specified here, the account will be
automatically Suspended by the iXp Daemon. The default value is
365 days.
 Note: This field applies for both the iXp user/password based
authentication and LDAP authentication.

iXp CLI Authentication

By default, the iXp Client CLI is enabled. Users can install the CLI, and use the commands unless you disable it in iXp
Admin Tool. If the CLI is enabled, users will be able to execute commands directly from the iXp GUI (File > CLI).

By default, the CLI is enabled to follow the same authentication fields as the GUI. For the CLI, there is no option to choose
iXp User/Password based authentication.

If you chose the Single Sign-On authentication option for the GUI, you can elect to follow the values specified for the GUI
authentication. In that case, the CLI has to be opened from machines that are valid for the GUI and has to be opened by
users authenticated to the same Domains and hosts specified for the GUI.

If you do not want to follow the same settings as the GUI, clear the "Follow GUI" check box and specify the list of valid IP
Addresses, Host names, and Domains. The same options exist here as they do for the GUI. 

Once the user authentication has been set up, you now have to set up authorizations for each valid user.

 Note: Without valid authorization policies, users will not be able to open the GUI or CLI, even after successful
authentication.

LDAP Authentication

The LDAP authentication is also an alternate authentication mode for users logging in to the iXp GUI. It enables iXp to
authenticate users' login credentials through an external LDAP server. To enable the LDAP authentication for users, select
the Enable LDAP Authentication check box in the Authentication->GUI tab.

To use the LDAP authentication, iXp must be configured with at least one LDAP server in the Authentication-
>LDAP tab. If you configure multiple LDAP servers, all the LDAP servers must be of the same vendor type. If you want to
change the LDAP server type, you must first remove all the previously configured LDAP servers from the iXp Admin Tool.

iXp uses the LDAP server based on the server usage priority you specify, with the lowest value indicating the highest
priority level. For example, if an LDAP server goes down, iXp connects to another LDAP server automatically based on
the specified usage priority.

iXp supports the following LDAP servers:

• MS Active Directory
• Novell eDirectory
• Sun ONE Directory

To configure an LDAP server in the Authentication->LDAP tab, provide the appropriate information in the following sub-
tabs:

• Shared Parameters
• LDAP Servers
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Shared Parameters

The LDAP shared parameters apply to all LDAP servers you configure in iXp.

The following table lists the shared parameters for LDAP servers:

Parameter  Value 
Server Type The LDAP server type.

Select one of the following LDAP server types:
•  Microsoft: MS Active Directory
•  Novell: Novell eDirectory
•  Sun: Sun ONE Directory
 Default: Microsoft

Self Signed Certificate Select the Self Signed Certificate check box if you are
connecting to an LDAPS (SSL-based LDAP) server that uses a
self-signed SSL certificate. 
 Important! The "Issuer DN" of the SSL certificate must match the
host name of the LDAPS server.
Clear this check box if you use a valid VeriSign/Thawte certificate
or other SSL certificate that is recognized by the iXp server's Java
Virtual Machine (JVM). By default, iXp always checks the JVM's
cacerts file first when a remote LDAP server presents an SSL
certificate.

LDAP Servers

The following table lists the information fields shown in this LDAP Servers sub-tab for the selected LDAP server:

Field Value
Name The name of the LDAP server. Each server name must be unique.

 Limits: 1-255 characters
User Base The base distinguished name that you can use to limit user entries

to specified organizational units. This value is appended to the
users login ID when performing authentication with an LDAP
server.
 Examples: 
cn=admin,dc=ixp
ou=users,ou=North America,dc=ixp,dc=com

User Login Name Property The LDAP identity property that is configured in the LDAP server
schema for each unique user. iXp uses this property to search for
and authenticate users in LDAP. Active Directory typically uses
"sAMAccountName" whereas Novell LDAP servers use "cn" and
Sun ONE LDAP servers can use "uid". Please contact your LDAP
Administrator for the key used in your environment.
 Default: sAMAccountName

Server URL The URL of the LDAP server.
 Examples: 
ldap://myldapserver.com:389
ldaps://ukxyz01.com:636 (s denotes that the LDAP server is SSL
enabled)
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Bind Users Name The name of the user that has an account on the LDAP server. iXp
logs in (binds) to the LDAP server using this user. It must be the
fully qualified Distinguished Name (DN) of the user. Sometimes,
this user is an Administrator on the LDAP server.
Examples:
cn=Admin,ou=users,o=ixp
uid=bob,ou=people,dc=example,dc=com

cn=serviceacct,ou=users,ou=North America,dc=ixp,dc=com
Bind Users Password The password that is associated with the specified Bind Users

Name.
The password is required only for creating a new server
configuration, but not for editing an existing configuration.

Enabled Indicates whether iXp authenticates users through this particular
LDAP server. By default, the Enabled check box is selected.
Clear the Enabled check box if you do not want to use this server
for authentication.

Server usage priority The usage priority of the LDAP server when multiple LDAP
servers are configured with iXp. iXp uses the LDAP server based
on the usage priority you specify for the server; the lowest value
(1) indicates the highest priority value. 
 Default: 1
 Limits: 1-256
Based on the priorities of the existing LDAP server configurations,
the priority for the new server configuration is generated
automatically. For example, if the priority of an existing LDAP
server is 1, the priority of the next server will default to 2.

Configure an LDAP Server

1. Log in to the iXp Admin Tool.
2. Click the Authentication->LDAP tab.
3. Click the Shared Parameters sub-tab and do the following tasks:

a. Select the type of LDAP server you want to configure from the Server Type options.
b. (Optional) Select the Self Signed Certificate check box to accept self-signed certificates from LDAP servers using

SSL communications and self-signed certificates.
4. Click the LDAP Servers tab and do the following tasks:

a. Click the Add icon on the toolbar.
b. Enter the information for the following required fields as described in the above table:

• Name
• User Base
• Server URL
• Bind Users Name
• Bind Users Password

c. (Optional) Modify the default values in the following fields:
• User Login Name Property
• Server Usage Priority

d. (Optional) Clear the Enabled check box, if you do not want to use this server for authentication.
e. Click the Save icon.

The LDAP server configuration is saved and is validated by iXp.
f. (Optional) Click the Test icon to verify that the LDAP server connection and the bind user authentication are

successful.
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g. (Optional) Repeat Steps 4a-4f to configure more LDAP servers.

 

Secure LDAP

Secure LDAP (LDAPS) uses an SSL certificate exchanged between a client and the server to authenticate the identity
of the LDAP server. When iXp is configured to use an LDAPS server, it uses the JVM’s default SSL authentication
mechanism to authenticate connections. If the authentication fails, iXp verifies if the SSL certificate is self-signed
by the remote LDAPS server (that is, IssuerDN=hostname) and accepts the certificate only when the Self Signed
Certificate checkbox is selected in the iXp Admin Tool.

iXp performs the SSL validation as follows:

• Instructs the JVM to authenticate the SSL certificate provided by the remote LDAPS server. If the LDAP server uses a
top-level signed certificate issued by Thawte/VeriSign or other valid certificate, the JVM might already trust your LDAP
server certificate. If you use a custom Domain Controller with Certificate Services that has issued the LDAPS servers
SSL certificate, you must add the certificate to the list of JVM Trusted CA providers, using the Java keytool utility. For
more information, see the Oracle Java keytool documentation.

• If the LDAPS server does not have a top-level signed Certificate or local Domain Controller that can authenticate an
SSL certificate, you may manually add your LDAPS servers certificate to the default cacerts file using the Oracle Java
keytool utility. By default, the cacerts file is located in the following directory:
JAVA_HOME/lib/security/cacerts

  JAVA_HOME 
Specifies the root directory of Java.

• If the LDAPS server sends a self-signed certificate to the iXp server, select the Self Signed Certificate check box from
the Shared Parameters section. This ensures that iXp accepts the SSL certificate as long as the SSL certs “IssuerDN”
is equal to hostname value of the LDAPS server.

Enable Failover for User Authentication with Multiple LDAP Domains

When iXp is configured with multiple LDAP servers, iXp first checks for the user in the target LDAP server and then
performs authentication with the user-provided password. If the user was found but authentication fails, by default iXp
does not check for the user in the remaining LDAP servers.

To enable the failover for user authentication with multiple LDAP domains, you must configure the default iXp
authentication behavior. When this failover feature is enabled, iXp checks all the configured LDAP servers until server list
is complete, looking for any LDAP server that can validate the user password.

This feature is useful for environments, where a userID may exist in multiple LDAP domains, but the user provides
password for a domain that is lower on the LDAP priority list.

 Follow these steps: 

1. Stop the iXp server.
2. Open the server.conf  file from the following directory:

IXP_HOME/etc

–   IXP_HOME 
Specifies the root directory of the iXp files.

3. Add the following configuration parameter:
IXP_LDAP_AUTH_FAILURE_OPTION=NEXT

4. Start the iXp server.
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Manage Users and User Groups
This section contains information about managing users and user groups:

  

Groups

You can create Groups and assign privileges to each group.

Select the iXp Group tab in the iXp Admin Tool to maintain group definitions.

Click the New iXp Group icon on the toolbar to create a new group, or click the Copy iXp Group icon to copy an existing
group, including its memberships and privileges. By default, each Group gets created with "Site Filter" such that the
users assigned to this group cannot view, update, or control CA Workload Automation AE jobs.

Specify group properties and members in the respective tabs.

 Note: The group name cannot include any spaces.

Member

The Members tab enables you to assign membership to this group.

To add members, select the users from the "Members NOT Included" area and click the "Add" button.

To remove members, select the users from the "Members Included" area and click the "Remove" button.

Privilege

The Privilege tab lets you assign the privileges for this Group. All members of this group will then inherit these privileges.
When you change the privileges for any group, all the members will immediately get the new set of privileges.

Each Group can be assigned different levels of authorizations, depending on its function. 

Account History

This tab shows creation and modification information about the Group. 

Once you have created one or more Groups, you can now create users and assign group memberships to them.

Users

Select the User tab to create users and assign passwords, group memberships, and/or privileges. Once users pass the
authentication tests, they can open the iXp Client GUI or the CLI only if they are defined here.

The options available in the General tab are based on the authentication mode that you selected in the Authentication-
>GUI tab. For more information setting up authentication modes in iXp, see Set Up User Authentication.

iXp operates in one of the following authentication modes:

• Single Sign-On authentication mode:
If you selected the Single Sign-On authentication mode in the Authentication tab, you
can define the user type and assign group memberships and/or privileges.

NOTE

 The user name must match the Active Directory or OS user name. The user names are not case-sensitive
if the iXp Server is running on Windows. If the iXp server is running on UNIX or Linux, the user names are
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case-sensitive. We recommend that you use lowercase for all usernames in iXp, irrespective of the OS
platform. Do not include spaces in user names.

• iXp User/Password authentication mode:
If you selected the iXp User/Password authentication mode in the Authentication tab, you also have the option for
each user of choosing from locally-managed passwords or password management using a remote LDAP server.

General

This tab enables you to assign user type, authentication mode, and some general information. The following table
provides details about the fields in this tab:

 User Field  Description 
 Account Type An iXp user can be of the following types: Regular, Admin, or

Temporary. Click the Edit button to set the Account type. An
administrator will be able to access the iXp Admin Tool and
perform all the functions available here. A Temporary user is a
Regular user, except that the user ID will Expire after the account
expiration date has been reached.

 Account Status Indicates whether the account is Active or Suspended. If an
account is suspended, it cannot be used for opening the iXp Client
or the iXp Admin Tool. To suspend an account, click Edit and set
the status to Suspended. To re-activate a Suspended account,
click Edit and set the status to Active.

 Account Expiration The number of days after which the selected Temporary user
ID will Expire. Administrator can re-activate Expired accounts
by changing the Expiration Date. This field is available only for
Temporary accounts.

 Description A text description for the username.
 Email Address You can use this to store any characteristics of the user, for

example, the email address.
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 Authenticate Using The authentication mode that iXp uses to verify the users' login
credentials.Options are: iXp and LDAP. 

 Default: iXp

Warning!  If the Enable LDAP Authentication check box
is selected in the Authentication->GUI tab, the default
authentication mode is set to
LDAP

.

If iXp is selected, you must specify the password for the iXp
username. If LDAP is selected, iXp will verify the username
and password using one of the LDAP server(s) configured in
the Authentication->LDAP tab in iXp Admin Tool.

Note:

• If iXp uses the Single Sign On authentication mode,
the Authenticate Using drop-down is disabled.

• You cannot change the authentication mode of the default
ixpAdmin account

• If you want to authenticate the user using the password stored
in the LDAP server, you select LDAP in the Authenticate
Using drop-down and subsequently the Password field where
you define the password locally in iXp gets disabled.

• When you define a new user that will be authenticated by
an LDAP server, the user name that you create in iXp must
match the user name (excluding the domain symbol @ and
the domain name) defined in the LDAP server. iXp does not
support domain symbol @ and the domain name in user
names. For Microsoft Active Directory, we recommend that
you use the sAMAccountName value as the user name. For
example, if user bob@domain.com wants to log in to iXp
using the LDAP credentials, an iXp user named "bob" must be
created.

 Password / Re-enter The password for the iXp username. This is required only if the
GUI authentication is set to iXp User/Password. Passwords have
to be at least 8 characters long and need to contain at least
one numerical character and one special (non-alphanumeric)
character. A password supplied here is temporary, and users have
to change their password at the next login time. These fields are
disabled in the Single Sign On mode, or if LDAP is selected from
the Authenticate Using drop-down.

 Generate Use this button if you want iXp to create a temporary password.
The temporary password will be shown in a pop-up dialog. You
can highlight the text and copy it using standard copy-and-paste
operation.

 Low Band You can assign this setting to users that will connect to the iXp
Server over a slow network connection. When you enable this
setting, the iXp Client receives lesser amount of data on startup
and on every refresh.

Group Membership

This tab enables you to assign group memberships to the selected user.

To add this user to a Group, select the Group from the "Groups NOT Included" area and click the "Add" button.
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To remove this user from a Group, select the Group from the "Groups Included" area and click the "Remove" button.

You can click the "Save" icon at any time to save the current User definition.

When a user is a member of multiple groups, the user inherits the combined privileges of all those groups.

Privilege

This tab enables you to assign specific privileges to users. These privileges will be given to the user, in addition to the
privileges that the user inherits from its group membership. This is recommended if the user needs to be assigned some
privileges temporarily, or if the user is fulfilling some unique responsibilities not assigned to the rest of the group members.
The privileges are identical to those at the group level.

Account History

The following table lists the informational fields shown in this tab for the selected user. This tab shows limited data when in
SSO (Single Sign-On) mode.

 Informational Field  Description 
 Account Created The Date and time when an account was created.
 Account Modified The Date and time when an account was modified, either by an

administrator or by the iXp Daemon.
 Account Suspended The Date and time when an account was Suspended, either by an

administrator or by the iXp Daemon.
 Password Modified The Date and time when the password was last modified, either by

an administrator or by the user.
 Last Login The Date and time of the last login by the user.

Create a New User

1. Click the New User icon on the toolbar.
2. Type the new User Name in the input box, and click OK.
3. Select one of the following authentication modes from the Authenticate Using drop-down list in the General tab. If

iXp is in SSO security mode, this drop-down is disabled.
– iXp: iXp User/password based authentication

• If iXp is selected, enter the new user Password, and re-enter for verification. This password will be temporary
only. The user will be forced to change the password at the time of initial login. If you want iXp to create
a temporary password, click the Generate button next to the Password field. The temporary password
will be shown in a pop-up. You can select the text of the password and copy it using keyboard shortcut keys,
such as Ctrl+C on Windows.

– LDAP: LDAP authentication
• For the LDAP authentication to work, you must have LDAP server(s) configured in the Authentication-

>LDAP tab in iXp Admin Tool. For more information, see .Set Up User Authentication v11.3.5.
4. (Optional) Enter a Description for the user.
5. (Optional) Enter an Email Address for the user.
6. By default, the user type is set to "Regular". If you want to assign iXp administrator privileges to this user, click the

Edit button and select "Admin" as account type. If the user ID is a temporary ID, click the Edit button and select
"Temporary" as account type.

7. If the User is of the type "Temporary", then click the Edit button for Account Expiration and assign the number of
days for which the user will be valid.

8. Assign the Group memberships for this user. Optionally, assign specific privileges to the user.
9. Click the Save icon to save the new user definition. Now, the saved user can log in to the iXp GUI.
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You can also create a new user by copying an existing user with its group membership and the properties defined in the
ID box. Adjust the password and other identity and security properties as needed.

User Message

Click the Send Message icon to send a message to the currently selected user. The message will display in a pop-up box
and the user's refresh will be paused until the message is acknowledged. A User Message expires after 20 minutes.

ixp Admin User

The security settings for the ixpAdmin user cannot be changed. This user ID represents the iXp "Administrator". The
password for this user can be changed from this screen.

Reconfigure Users from iXp User/Password to LDAP Authentication Mode

By default, users that you create in iXp are authenticated using the “iXp User/password” authentication mode.
Administrators can use the Admin Tool to modify each user's authentication mode to LDAP, by selecting LDAP in
the Authenticate Using field so that the authentication is performed by one of the LDAP servers configured within iXp.

Rename Existing iXp Users to Match the LDAP Schema

If you want an iXp user to be authenticated using LDAP, the user name must match the LDAP user name (excluding the
domain symbol @ and the domain name) defined in the LDAP server. For example, if user bob@domain.com wants to log
in to iXp using the LDAP credentials, an iXp user named "bob" must be defined in the Users tab in the iXp Admin Tool.

Instead of creating a new iXp user name in Admin Tool to match your LDAP naming schema, you may rename the
existing users to match the required naming schema.

 Follow these steps: 

1. Rename the following file to  NEWusername.conf :
IXP_HOME/etc/user/username.conf

–   IXP_HOME 
Specifies the root directory of the iXp files.

–   Username 
Specifies the existing name of an iXp user.

–   NEWusername 
Specifies the new name that matches the LDAP naming schema.

2. Open the  NEWusername.conf  file in edit mode and do the following tasks;
a. Set the value of the following property to the new user name:

IXP_USER_NAME=NEWusername

b. Add the following property if it does not exist. If the property already exists, modify its value as follows:
IXP_USER_ACCOUNT_AUTH_MODE=auth.type.ldap

Automate Migration of Users from iXp to LDAP Authentication Mode

The LDAP authentication mode is supported beginning with iXp Release 11.3.5 INCR6. If the existing iXp user base is
large, you can programmatically batch migrate the existing iXp users from “iXp User/password” to "LDAP" authentication
mode by updating each user's  IXP_HOME/etc/user/username.conf  file. The user name must match the LDAP
naming schema as described in Set Up User Authentication.

You can write an automated script to modify each username.conf  file and either add
the property IXP_USER_ACCOUNT_AUTH_MODE=auth.type.ldap  if it does not exist, or modify its value
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if IXP_USER_ACCOUNT_AUTH_MODE=auth.type.ixp  already exists. In a pre-existing iXp environment, the key/value
pair will have to be added.

Set the Default Authentication Mode to LDAP

When you create a new user, the authentication mode is set to
iXp

by default. If the Enable LDAP Authentication check box is selected in the Authentication->GUI tab, the default
authentication mode is set to
LDAP

.

To set the default authentication mode to
LDAP

, regardless of whether the Enable LDAP Authentication check box is selected, you can configure the iXp server.

 Follow these steps: 

1. Stop the iXp server.
2. Open the gui.conf  file from the following directory:

IXP_HOME/etc

–   IXP_HOME 
Specifies the root directory of the iXp files.

3. Set the value of the following server parameter to true :
IXP_AUTHENTICATON_HARDCODE_NEWUSER_LDAP

4. Start the iXp server.

Assign Privileges to Users and Groups
After you defined the authentication policy, assign privileges to users. Users that do not have any privileges will not be
able to open the iXp GUI or the CLI.

You can assign privileges to users in two ways:

1. Assign privileges to Groups and assign Group memberships to each user. Users can be members of multiple
groups. The privileges for each user will be the combined privileges of all of their groups. 

2. Assign privileges directly to users, with or without Group memberships. These privileges would be in addition to any
other privileges the user inherits from its group membership.

By default, each Group gets created with "read-only" privileges for every CA Workload Automation AE job. 

Contents:

Privileges for Groups and Users

The Privilege tab in the Group or User dialog lets you assign the privileges for this group or user respectively. All members
of the group will inherit these privileges. When you change the privileges for any group, all the members will immediately
get the new set of privileges. Privileges that you assign to a user are added on to of the privileges that the user inherits
from its group membership. This is recommended if the user needs to be assigned some privileges temporarily, or if the
user is fulfilling some unique responsibilities not assigned to the rest of the group members. 

Each group can be assigned different levels of authorizations, depending on its function.

The privileges are classified in to multiple categories: Alarm, Calendar, Global Variables, JIL, Jobs, User Command, and
Migrate. You can expand each category and see the individual privileges.

 68



 CA Workload Automation iXp 11.4.00

The following table explains all of the categories and their individual privileges:

Category Privilege For the Jobs matching the filters, Users
can

Alarm Job Alarm Read • See the Alarm Dialog
• View the job-related CA Workload

Automation AE Alarms subject to Job
Detail privilege

 Instance Alarm Read • See the Alarm Dialog
• View the non-job related CA Workload

Automation AE Alarms for instances
covered by the Job Read privilege.

 Job Alarm Acknowledge • Acknowledge the CA Workload
Automation AE Alarms in the iXp Alarm
Dialog.

 Job Alarm Close • Close the CA Workload Automation AE
Alarms in the iXp Alarm Dialog.

 Instance Alarm Acknowledge • Acknowledge non-job related CA
Workload Automation AE Alarms.

 Instance Alarm Close • Close non-job related CA Workload
Automation AE Alarms.

Calendar Calendar Read • Create, or modify any of the Calendars
for the Instance(s) included that match
the given expressions.

• View all the Calendars for the
Instance(s) included that match the
given expressions.

 Calendar Update • Create, or modify any of the Calendars
for the Instance(s) included that match
the given expressions.

Global Variable Global Variable Read • View any Global Variables for the
Instance(s) included that match the
given expression(s).

 Global Variable Update • Change any Global Variables for the
Instance(s) included that match the
given expression(s).

 Global Variable Delete • Delete any Global Variables for the
Instance(s) included that match the
given expression(s).

JIL JIL Insert • Create new jobs from the iXp GUI using
Job Editor, or from the CLI using "ixjil".

 JIL Update • Update jobs using the iXp GUI or CLI.

 JIL Override • Issue one-time overrides using the iXp
GUI or the CLI.

• Delete one-time overrides using the iXp
GUI or CLI.

 JIL Delete • Delete jobs using the iXp CLI.
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 JIL Owner • Assign a Job Owner when creating or
updating jobs using the iXp GUI or CLI.

Job Job Detail • View and search job attributes such as
command, owner, description.

• Also control Log read and Alarm read
access.

 Job Read • View Jobs and their statuses, details,
run history, alarms

• View One-time Overrides
• Generate Historical and Forecast Run

Reports.

 Job Control • Issue any sendevent.

 Log File Read • View Job Log, Job Profile, and Remote
Agent log files subject to Job Detail
privileges.

 Script Read • View the Command Script file specified
in the selected job's command attribute.

Machine Machine Edit • Change or delete any Machine for the
included Instances that match the given
expressions.

• Issue the MACH_ONLINE and
MACH_OFFLINE sendevent
commands.

 Machine Use • Use any Machine for the included
Instances that match the given
expressions in a job's machine attribute.

User Command Job Command • Execute predefined Job User
Commands.

 Alarm Command • Execute predefined Alarm User
Commands.

 Context Free Command • Execute predefined Context-Free User
Commands.

Migrate Create Migration Package • Open the migration assistant, and
create and save workload packages.

 Perform Migration • Open the migration assistant, and
migrate workload packages.
Note: Administrators can migrate all
packages created by any user if given
this privilege. Other users can migrate
only packages they created themselves.

Warning!  If custom conversion scripts
are used in your environment, they run
with the same execution permissions as
the iXp server, typically Admin or root.
Before you execute conversion scripts,
ensure that you review and trust the
code or content of the scripts.
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NOTE
In the JIL Owner area, you can provide a list of owners that are allowed for each user. You can use wildcards
(*) in the owner names. If you specify just a wildcard, user can specify any owner, other than "root". To allow the
user to specify "root" as a job owner, click the "Superuser" tab and enable that privilege.

Using Filters for Security

Most of the privileges must be allocated a list of jobs. These lists are called "Filters" in iXp. The iXp administrator can
assign any out-of-the-box filters provided with iXp, or create new filters and assign them. Users will be able to leverage
their privileges only for those jobs that pass through the filters assigned for that privilege.

Filters are used to create authorizations. Only the filters created by users with "Admin" privileges and the filters provided
standard with iXp can be used for this purpose.

Each filter can include wildcards for any of the job attributes. The iXp Daemon dynamically generates a list of jobs based
on the values assigned to each field in the filter definition.

After saving a new filter, click the Reload Filters icon on the Group toolbar to import the newly saved filter in the list of
filters available for assignment to privileges.

Validating the Privileges

The following table shows the steps that users can perform to validate their privileges. The user must log in to the iXp
client before performing these steps.

Category Privilege Validation Steps
Alarm Job Alarm Read • Click the "Alarm" button to open the

Alarm dialog. If job alarms are not
displayed, select "Show Closed Alarms"
to fetch alarms that are in Closed State.

 Instance Alarm Read • Click the "Alarm" button to open the
Alarm dialog. If non-job alarms are not
displayed, select "Show Closed Alarms"
to fetch alarms that are in Closed state.

 Job Alarm Acknowledge • Open the Alarm Dialog, and select a job
alarm that is in Open or Acknowledged
state. Click the Acknowledge button,
enter a short response, and click
OK. The alarm state will now be
"Acknowledged", and your username
and response will be displayed in the
Response field.

 Job Alarm Close • Perform the same steps as above but,
instead of clicking the "Acknowledge"
button, click the "Close" button. The
alarm state will change to "Closed" and
it will disappear from the Alarm dialog if
the "Show Closed Alarms" check box is
cleared.

 Instance Alarm Acknowledge • Perform the same steps as those for
the "Job Alarm Acknowledge" privilege,
but select a non-job alarm instead of an
alarm related to a job.

 71



 CA Workload Automation iXp 11.4.00

 Instance Alarm Close • Perform the same steps as those for the
"Job Alarm Close", but select a non-job
alarm instead of an alarm related to a
job.

Calendar Calendar Read • Select the Edit > Edit Calendars menu
option, select the appropriate instance,
and choose a Date or Extended
calendar from the drop-down list.

 Calendar Update • Select the Edit > Edit Calendars menu
option, and create a Date calendar with
the current date. Click Save to create
the calendar.

Global Variable Global Variable Read • Select the View > Global Variables
menu option to see your authorized
global variables.

 Global Variable Update • Select the appropriate instance in the
Tree View, select the File > Sendevent
menu option, and click the Set Global
tab. Enter the name of the new variable
and value, and click Issue sendevent to
create the variable.

 Global Variable Delete • Delete the variable created in the
validation test for "Global Variable
Update" step by settings its value to
"DELETE".

JIL JIL Insert • Select the Edit >  Edit Jobs menu
option, select the appropriate Instance,
and create a new Command job. Define
the attributes as appropriate, and click
Save to create the job.

 JIL Update • Select the appropriate job in any of
the views, select the Edit > Edit Jobs
menu option to open the Job Editor,
modify the description field for the job,
and click Save to make the change.

 JIL Override • Select the appropriate job in any of the
views, select the Edit > Edit Jobs menu
option, click the icon to "Add One-time
Override", specify the override, and
click Save.

 JIL Delete • Select the File > CLI > JIL menu option,
select the appropriate instance, and
enter "delete_job: JOB", where JOB is
the name of the job you want to delete.
Click "Run" to process the delete jil sub-
command.

 JIL Owner • Select a job for which you have the Job
Update privilege, select the Edit > Edit
Jobs menu option, modify the "owner"
attribute to the appropriate value, and
click Save to update the job with this
new "owner" attribute.
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Job Job Detail • Select the appropriate job, and select
the Edit > Edit Jobs menu option. The
"owner" attribute of the job should be
visible with the appropriate value.

 Job Read • Select the View > Find Job By Name
menu option, and enter the name of the
appropriate job. You can use "*" as a
wildcard. Press "Enter" to find the job.

 Job Control • Select the appropriate job, select the
File > Sendevent menu option to
launch the sendevent dialog, click the
"Comment" tab, enter a comment, and
click "Issue Sendevent" to send the
event.

 Log File Read • Select a Command job, and select
the Job Information > Log Files >
Standard Out menu option to see the
output file.

 Script Read • Select a Unicenter AutoSys JM
4.5 command job, and select the
Job Information > Log Files >
Command Script menu option to see
the command script.

Machine Machine Edit • Select the File > CLI > JIL menu option,
select the appropriate instance, and
enter the JIL statements to create
the machine definition. Click "Run" to
process the JIL statements to create the
machine.

 Machine Use • Select a job for which you have the
Job Update privilege, select the Edit
> Edit Jobs menu option, modify the
"machine" attribute to the appropriate
value, click Save to update the job to
run on this machine.

User Command Job Command • Select the appropriate job, and select
the File > User Command > Job >
USERCOMMAND menu option, where
USERCOMMAND is the name of any
user command shown in this menu
option.

 Alarm Command • Open the Alarm dialog, select an alarm,
and select the Alarm Command >
ALARMCOMMAND menu option,
where ALARMCOMMAND is the name
of any user command shown in this
menu option.

 Context Free Command • With or without a job selected, select
the File > User Command > Context
Free > USERCOMMAND menu option,
where USERCOMMAND is the name of
any user command shown in this menu
option.
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 Create Migration package • Select the Migrate > Edit Migrations
menu option to create a migration
package.

Migrate Perform Migration • Select the Migrate > Edit Migrations
menu option, and create a new package
or open an existing package. Perform
all the steps until you reach the last
panel. Verify that the Migrate Now
button is enabled.

Configure the Migration Assistant
The Migration tab lets you configure settings related to the migration assistant. The following table provides details about
the fields in this tab:

Setting Description
Migration Enabled Enables users to open the graphical migration assistant from this

iXp server and create migration packages to copy their jobs and
related objects from a Unicenter AutoSys JM 4.5.1 instance to a
CA Workload Automation AE r11.3, Release 11.3.5, or Release
11.3.6 instance. By default, this is turned off.

JIL Command The default command that will be used to upload the jobs from
the migration package to the target CA Workload Automation AE
instance.

JIL Syntax Checker Command The default command that will be used to check the syntax of the
JIL file generated by the migration assistant.

Exclusion Rule Set The name of the rule set that will be applied, by default, to all
migration packages created on this iXp server. The rule set can be
created from the iXp user interface. Users creating the migration
packages can elect not to apply the rule set. Users can also
manually override the exclusion of one or more jobs.

JIL Conversion Script The script or program to which the JIL file generated by the
migration assistant will be passed as standard Input. The script
can parse the JIL file and make modifications to meet the syntax
requirements of the target instance and the internal corporate
standards. The migration assistant will capture the standard
output and use that as the new JIL file. A sample PERL script
(ixpParseJobs.pl) is provided in the "contrib" directory.

Warning!  This script is run with the same execution permissions
as the iXp server, typically Admin or root. Before you execute the
script, ensure that you review and trust the code or content of the
script.
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Global Conversion Script The script or program to which the sendevent script generated by
the migration assistant to create the related global variables will
be passed as standard input. The script can parse that sendevent
script and make modifications to meet the syntax requirements
of the target instance and the internal corporate standards.
The migration assistant will capture the standard output and
use that as the new sendevent script. A sample PERL script
(ixpParseGlobals.pl) is provided in the "contrib" directory.

Warning!  This script is run with the same execution permissions
as the iXp server, typically Admin or root. Before you execute the
script, ensure that you review and trust the code or content of the
script.

Calendar Conversion Script The script or program to which the file generated by the migration
assistant to create all related calendars in the target instance,
which is compatible with the "autocal_asc" command, will be
passed as standard input. The script can parse that file and
make modifications to meet the syntax requirements of the target
instance and the internal corporate standards. The migration
assistant will capture the standard output and use that as the new
calendar file. A sample PERL script (ixpParseCalendars.pl) is
provided in the "contrib" directory.

Warning!  This script is run with the same execution permissions
as the iXp server, typically Admin or root. Before you execute the
script, ensure that you review and trust the code or content of the
script.

Remove Migration Packages after X days Specifies that any package that has been successfully migrated to
the target instance will be removed from the iXp server after this
number of days.

Note: For more information about migration, see the section How to Manage Workload Migration.

View the iXp Daemon Log
The iXp Daemon log stores all the messages, warnings and errors generated by the daemon. This log is very useful in
tracking the status of the daemon and its threads, and also in troubleshooting the problems. The log is particularly useful
for the following tasks: 

• Changing or adding an Instance configuration. The effect of instance modifications on the daemon can be seen.
• Monitoring client access.

To access the iXp Daemon log, select the Log tab in the iXp Admin Tool.

To fetch the latest data, click the Refresh icon and select the number of lines, counted from the end of the log, that you
want to view.

 

iXp Daemon Log Technical Notes
The iXp Daemon Log Technical Notes PDF describes the keywords, variables, and error messages that you can see in an
iXpDaemon.log file.

Manage User Commands
User commands are a way for iXp to pass job data to an existing UNIX, Linux or Windows script, command, or program.
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When a user selects one job and executes a user command, the following processing occurs:

1. The command is authorized for the user.
2. The proper environment variables are set.
3. The command is executed.
4. The results are returned.

User commands can be executed for a single or multiple jobs or alarms. If the command fails, or is unauthorized, the
server captures the resulting text, and returns the results to the client.

WARNING

The User Command executes the custom shell script, command, or program with the same execution
permissions as the iXp server, typically Admin or root. Before you let users execute any scripts or programs,
ensure that you review and trust the code or content of the scripts or programs.

Contents:

User Command Types

The following types of user commands are available in iXP:

• Job
Set up to return Operator Instructions for any job selected by the user on the client.

• Alarm
Set up to page the on-call person with details about the alarm generated.

• Context-free command
Gets system details of the iXp Server.

The Job and Alarm commands are available only when the user has selected a job or an alarm in the iXp client.

Context-free commands can be executed without selecting any job or alarm.

Create or Edit User Commands

iXP administrators can create user commands using the iXP Admin Tools. The commands are available to the iXP client
users in the iXP menu.

Follow these steps:

1. Click the New User Command icon and assign a name.
2. Type or edit the command in the Command text box. Enter the full path to any command or executable that is not

included in the PATH set on the iXp Server for the user running the iXp Daemon.
3. Enter the Input Prompt text if applicable. The text appears in the input prompt in the iXP Client when user attempts to

execute this user command.
The following image shows an example of an input prompt dialog for an Email command, requesting to specify an
receiver email address:
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4. Select the Type: Job, Alarm, or Context Free.
5. Specify whether the command requires user confirmation by selecting the Confirmation Dialog check box.
6. If you are creating a Job or Alarm User Command, you can run the user command on multiple jobs. Use

the Maximum Selections field to specify the maximum number of jobs or alarms that a user can select when
executing this user command. The default value is 50. If the user command is returning a URL, then we recommend
that you set the value for this field to 1.

7. Click the Save icon to save the new user command to the iXp Daemon.
The user command is available to iXp users with the proper permissions. After defining a newuUser command, users
with active sessions will have to exit and log back in to the GUI to access the new commands.

Note: Click the Remove icon to remove the user command from the iXp Daemon.

Environment Variables for User Commands

For user commands of Type Job, the following environment variables are set on the iXp Server before the command is
executed:

• IXP_USERCOMMAND_JOB_NAME
Specifies the selected job's name.

• IXP_USERCOMMAND_JOB_LAST_START
The selected job's last start time.

• IXP_USERCOMMAND_JOB_LAST_END
The selected job's last end time.

• IXP_USERCOMMAND_JOB_LAST_RUN_MACHINE
The selected job's last run machine.

• IXP_USERCOMMAND_JOB_JOID
The selected job's joid value.

• IXP_USERCOMMAND_JOB_STATUS
The selected job's current status, e.g. "SUCCESS".IXP_USERCOMMAND_USER_NAME. The name of the iXp user
executing the command.

• IXP_USERCOMMAND_INPUT
The text input by a user during execution of an Interactive User Command.

• IXP_USERCOMMAND_INPUT_PROMPT
The text prompted to a user during execution of an Interactive User Command.

• IXP_USERCOMMAND_USER_HOSTNAME
Set value to the user's host name where the iXp client runs.

For User Commands of Type Alarm, the following variables are set on the iXp Server before the command is executed:
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• IXP_USERCOMMAND_ALARM_NAME, (e.g. JOB_FAILURE)
• IXP_USERCOMMAND_ALARM_TIME
• IXP_USERCOMMAND_ALARM_COMMENT
• IXP_USERCOMMAND_USER_NAME
• IXP_USERCOMMAND_ALARM_RESPONSE
• IXP_USERCOMMAND_ALARM_JOB_NAME
• IXP_USERCOMMAND_INPUT
• IXP_USERCOMMAND_INPUT_PROMPT

The following CA Workload Automation AE environment variables are set for both Job and Alarm User Commands: 

• AUTOSERV
• AUTOUSER
• AUTOSYS
• DSQUERY
• IXP_SERVER_URL
• PATH, prepended with the proper $autosys\bin directory.

For Context Free User Commands, no variables are set, except for IXP_USERCOMMAND_INPUT, IXP_SERVER_URL,
and the PATH variable of the Web Server.

Assign Groups to User Commands

Similar to filters, you can assign groups to user commands. When you do that, only the members of the included groups,
and iXp administrators, will be able to execute the user commands.

To assign groups to user commands, click the Group tab in the User Command dialog and select groups allowed to
execute the command.

Interactive User Commands

Interactive user commands prompt users for input when attempted for execution in the iXP GUI.

iXp shows any output generated by the user command in a web browser window. Since iXp sets the environment
variables before executing the script associated with the user command, the script can leverage the same variables and
perform the required action. 

Set Up Forecast Properties
Forecast properties delineate the output of the command line forecast utility, and the job run forecasts that will be
viewable in the Time View Chart. These parameters also affect the iXp application Interactive Forecasting tool. Forecast
parameters are stored in the IXP_HOME/etc/forecast.props file.

To set up forecast properties, select the Forecast tab. The Xp Forecast Properties dialog appears.

You can specify the following forecast parameters:

• Forecast Duration
This setting is deprecated. Only the iXp forecasting command line interface uses it. This field specifies a time window
for the forecasting engine, in hours. Example: setting this to "4" will generate a 4 hour forecast when processed via the
command line. 

• Set Status Time
The estimated time in milliseconds that the scheduler requires to update a status in the Event Server database. 

• Set STARTING Time
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The time in milliseconds the scheduler requires to update a status with the value of STARTING in the Event Server
database. Its value may differ from the default (Set Status Time). 

• Set RUNNING Time
The time in milliseconds the scheduler requires to update a status with the value of RUNNING in the Event Server
database. Its value may differ from the default (Set Status Time) because the value should also capture the contention
that may arise from a remote agent simultaneously performing a roughly identical task. 

• Set DONE Time
The time in milliseconds the scheduler requires to update a status with the value of SUCCESS, TERMINATED, or
FAILURE in the Event Server database. Its value may differ from the default (Set Status Time) because the value
should also capture the contention that may arise from a remote agent simultaneously performing a roughly identical
task. 

• Status Read Time
The time in milliseconds the scheduler requires to read a job's status (such as when evaluating a job's "condition:"
field) from the Event Server database. 

• Event Read Time
The time in milliseconds the scheduler requires to read an event from the event server database. This value may
reflect the presence of a backup server and the attendant event synchronization required. 

• Start Job Time
The time in milliseconds the scheduler requires to perform the calculations to determine if a job can be started. 

• VMStat Time 
The time in milliseconds the scheduler requires to perform vmstat on each machine in the "machine:" field of a
command job or file watcher. 

• Cross Instance Sendevent Time
The time in milliseconds the scheduler requires performing a sendevent to an external instance when processing the
job completion of a job that has an external successor.

Set Up Message of the Day (MOTD)
The Message of the Day (MOTD) appears in the iXp Login screen. If the MOTD is changed, all active iXp Clients will
display the new message. Users have to acknowledge the message before continuing with the client. 

To view or change an MOTD, select the MOTD tab in the iXP Admin Tools.

The MOTD format supports HTML 3 and pictures saved on your local Tomcat server.

View Clients
To view a list of active client connections, select the Clients tab in the iXP Admin Tools.

The number of active client sessions (users) is displayed on the top line. The Client Connections tab shows the following
information for each client connected:

• ID
User name. 

• Description
Description as entered in the Users tab. 

• Filter
Current active user filter. 

• On Since
Time elapsed since user logged on. 

• Email
Email address of user, as specified in the user definition. 

• Low Band
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If a logged on user has been assigned the "Low Band" setting, then this check box will be selected.

Manage Pick Lists for Sendevent Comments and Alarm Responses
As an administrator, you can set up predefined sendevent comments or alarm responses. These predefined texts are
listed in pick lists. iXp users can then select the required comment or response when executing a sendevent or when
responding to alarms. The Sendevent Comment pick lists appear in the Job Control Popup functionality sendevent
comment input boxes. The Alarm Response pick lists appear in the Alarm Manager functions Acknowledge and Close
alarm response input boxes.

To manage pick lists, select the Pick Lists tab in the iXp Admin Tools.

• To insert pick list items, click Insert, enter the pick list text, click OK, then click the Save icon.
• To delete pick list items, highlight them, click Delete to remove them from the list, then click the Save icon.

Audit iXp GUI and Admin Tool Activities
iXp keeps track of certain activities performed within the iXp GUI or the iXp Admin Tool.

To view the audit information of these activities, select the Audit Trail tab in the iXp Admin Tool. Use the CSV and HTML
toolbar icons to export the displayed audit trail into CSV or HTML files respectively.

To view the audit information for a specific user, select the View > View By User menu option.

Audit trail includes the following iXp Admin Tool activities if a user performs them:

• Logs on to the iXp Admin Tool.
• Creates, Updates, or Deletes an iXp user definition.
• Updates the iXp Server information.
• Creates, Updates, or Deletes an CA Workload Automation AE Instance information.
• Creates, Updates, or Deletes an iXp User Command.
• Creates, or Updates the Message of the Day.
• Creates, Updates, or Deletes any of the Pick list lines.
• Creates, Updates, or Deletes a Filter definition.

Audit trail includes the following iXp GUI activities if a user performs them:

• Logs on to the iXp GUI.
• Creates, Updates, or Deletes a Filter definition.
• Issues any sendevent successfully.
• Updates a job definition successfully.
• Creates, Updates, or Deletes a job override successfully.
• Updates the user preferences.
• Saves the Session settings.
• Executes a User command successfully.
• Acknowledges or Closes an Alarm successfully.
• Changes the Password.
• Creates, Updates, or Deletes a Report definition.

Audit trail includes the following iXp CLI activities if a user performs them:

• Views job summary, detail, or definition using ixautorep.
• Creates, Updates Job definitions using ixjil.
• Issues sendevents using ixsendevent.
• Creates one-time job overrides using ixjil.
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The audit trail table provides the following information:

• Time
The time of the activity. 

• User
The User that performed the activity. 

• Host
The name of the client machine from which the user performed the audited action. This field is used only in Single
Sign-On mode. 

• Type
The Type of activity performed. This is an internal iXp classification mechanism. 

• Action
The performed activity. 

• Instance
The name of the CA Workload Automation AE Instance on which the action was performed. 

• Detail
The details of the actual activity performed.

Click the appropriate column header to sort by any of the above columns.

Configure Log File Retrieval
The iXP Client users can  request access to the log files created by any job when it runs on its Remote Agent machine.
These files include the STDOUT, STDERR, STDIN, Remote Agent log file, and Job Profile file. Since these files reside
on the Remote Agent machine, the iXp Server communicates with the iXp Agent, which must be running on the Remote
Agent machine, to retrieve the files.

Contents:

Configure Log File Retrieval

You can configure the retrieval of these log files in the Run Log Files tab of the iXP Admin Tools.

Note: This tab is applicable only for environments running Unicenter AutoSys JM r11 or older.

Select the Run Log Retrieval Enabled option to allow users to view log files (std_in, std_out, std_err, profile,
auto_remote log, script) depending on security permissions. If this option is not selected, no access to logs is available
through iXp.

Resolving File Names

The file name for each of the log files is resolved by the iXp Daemon and the iXp Agent by extracting the name of the file
from the job definitions and then resolving Environment variables and Global Variables.

If the file name includes standard CA Workload Automation AE variables such as AUTO_JOB_NAME, AUTORUN,
AUTOROOT, AUTOUSER, AUTOSERV, AUTOSYS, the applicable substitution is made depending on the name of
the selected job, and the values for the variables in either the iXp Agent execution environment, or in the Instance
configuration file in the $IXP_HOME/agent/conf sub-directory on the Agent machine.

If the file name includes any Global variables, then the appropriate value is substituted in the file name.

If the file name includes any non-standard variable or a variable whose value is dynamic, then you can specify the
definition of such variables to iXp.
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The variable substitution is processed as follows:

1. The iXp Daemon substitutes values for Global variables and substitution parameters defined to iXp and then passes
the resulting file name to the iXp Agent.

2. The iXp Agent substitutes any remaining environment variables with the values found in the current environment.
3. The file name that results from these substitutions will be retrieved.

The following table lists available CA Workload Automation AE variables and their substitutions:

Variable Name Substituted Value
AUTO_JOB_NAME The name of the selected job.
AUTORUN RUN_NUM-NTRY where RUN_NUM and NTRY are the highest

run number and ntry values for the selected job.
AUTOSERV The 3-letter AUTOSERV value of the selected job.
Base_Time The UTC time of the last start time of the selected job.
__box_joid The JOID of the box job that contains the selected job.
__box_name The name of the box job that contains the selected job.
__job_name The name of the selected job.
__joid The JOID of the selected job.
__ntry The highest NTRY for the latest run number of the selected job.
__run_num The highest RUN_NUM of the selected job.
__run_machine The name of the Remote Agent machine.

For example, consider a job that has the following JIL definition:

insert_job: FTSEDaily_FTSE_upld

job_type: c

box_name: FTSEDaily

machine: venus

command: sleep 5

std_out_file: /tmp/$AUTO_JOB_NAME.$AUTORUN.txt

std_err_file: /tmp/$AUTO_JOB_NAME.$AUTORUN.txt

If the job last ran with the run number 114 and ntry 1, then the file name for STDOUT and STDERR will be:

 /tmp/FTSEDaily_FTSE_upld.114-1.txt 

If there is a global variable called LOGDIR defined to CA Workload Automation AE that has the value set to "/opt/CA/logs"
and is used as follows in the JIL definition of a job:

std_out_file: $$LOGDIR/$AUTO_JOB_NAME.$AUTORUN.txt
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std_err_file: $$LOGDIR/$AUTO_JOB_NAME.$AUTORUN.txt

then, the file name for STDOUT and STDERR will be resolved to the following:

 /opt/CA/logs/FTSEDaily_FTSE_Daily_upld.114-1.txt

Date and Time Substitutions

If the file name uses variables that cannot be determined from the current environment on the Remote Agent, or if it uses
variables that have their values set depending on the date and time of the execution of the job, then you can specify the
resolution format of those variables to iXp. During substitution, the iXp Daemon calculates the values of these variables as
specified and then substitutes in the file names.

If the variable value includes date or time substitutions, the iXp Daemon calculates the value of those variables using the
latest start time of the selected job. 
Assume the following two variables are defined to Workload Automation iXp:

• The 'date+%Y%m%d_%H%M' variable in JIL text to be resolved to "yyyyMMdd_HHmm".
• The $DATE variable needs date and time values to be substituted in a "yyyy-MM-dd" format. The iXp Daemon will use

the latest start time of the selected job to determine the value of this variable. 

The following file names are specified in the JIL definition:

std_out_file: /tmp/$AUTO_JOB_NAME.$DATE.txt

std_err_file: /tmp/$AUTO_JOB_NAME.$DATE.txt 

If the job last ran on 12th of January, 2006, the file name for STDOUT and STDERR will be resolved to:

/tmp/FTSEDaily_FTSE_Daily_upld.2006-01-12.txt 

The following table shows how to specify date and time format substitutions.

Letter Description Format Example
yy/yyyy Year Numeric 05 / 2005
M/MM Month Numeric 2 / 02
MMM/MMMM Month Text Jan / January
d / dd Day Numeric 8 / 08
EEE/EEEE Day Text Tue / Tuesday
H/HH Hour Numeric 1 / 01
m/mm Minute Numeric 9 / 09
s/ss Second Numeric 8 / 08

Tip: For substitution variables, remember to put single-quotes around any letters/words in the values that need to be
substituted "as-is".

Command Line Utilities for iXp Server
The following Command Line (CLI) Utilities are available on the iXp server to aid in administrating and monitoring the iXp
system. Click the utility name for more information how to use it.
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Command line utilities are stored in the IXP_HOME/contrib directory. These utilities can be run at a Windows command
line or UNIX shell prompt on the iXp Server machine.

ixserverstats.pl-Get Server Statistics
The ixserverstats utility lets you get the iXp generated statistics for any CA Workload Automation AE instance. For
information on how to run this utility, enter the following command:

%perl ixserverstats.pl

The following output is generated:

perl ixserverstats.pl -i instance -k [s|c|e|l] \

     -t [6|12|24|48|72|168] -f outputFile

• -i (instance)
Specifies the instance. Valid values are the AUTOSERV variable (e.g. "ACE").

• -k (kind)
Specifies the typo of statistics. Valid values are: s (starts), c (completions), e (events), or l (latency).

• -t (time in hours)
Specifies the statistic period. Valid values are: 6, 12, 24, 48, 72, 168.

• -f (file)
Specifies the file to contain report output.

The IXP_HOME variable must be set.

The serverstats script prints to the output file, in three columns. The first column contains sequential UNIX timestamps,
the second column has the standard date/time stamp, and the third column has the number of events.

Example: To view the number of start events over the last 6 hours in the PA1 CA Workload Automation AE instance,
execute the ixserverstats utility as follows:

%perl ixserverstats.pl -i PA1 –ks -t6 -f outputfile

The following output will be generated:

1207655707|4/8/08 5:55 AM|190

1207655857|4/8/08 5:57 AM|435

1207656007|4/8/08 6:00 AM|432

1207656157|4/8/08 6:02 AM|389

1207656307|4/8/08 6:05 AM|268

1207656457|4/8/08 6:07 AM|296

1207656607|4/8/08 6:10 AM|301

1207656757|4/8/08 6:12 AM|210
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ixforecast.pl-Forecast Job Runs and Events
The ixforecast utility lets you get the forecasting data for job runs and events. For information about how to run this utility,
enter the following command:

%perl ixforecast.pl

The following output is generated:

perl ixforecast.pl [-p propertyFile] [-r runReportFile] \

     [-e eventReportFile] [-f filter]

• Specify either -r or -e or both.
• The following variables must be defined:

– IXP_HOME
– IXP_SERVER_URL

• The default propertyFile is $IXP_HOME/etc/forecast.props.
• The default filter is "No Filter".

The job run forecast provides the following information:

• Instance
• Jobname
• Box name of parent job
• UNIX time stamp in seconds of start of run
• Normal time stamp of start of run
• UNIX time stamp in seconds of end of run of job
• Normal time stamp of end time
• Duration
• Machine
• Forecasted status of run
• Reason for the job run

The event forecast provides the following information:

• UNIX time stamp in milliseconds
• human readable time
• instance of the job,
• jobname,
• box name,
• type of event,
• event qualifier,
• reason for the event.

If a column entry is not available, it is blank as in ||.

Example: Forecasting Job Runs

To perform a job run forecast, execute the utility as follows:

%perl ixforecast.pl –r

The following output file is generated. Each row of output corresponds to one job run, similar to the Time View:
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JU2|job_0_0_0|EveryHour_15|963878909|7/17/00 6:08 PM|963879209000|7/17/00 6:13 PM|05m00s||SUCCESS|Run was

 Scheduled based on Job Definition.

Example: Forecasting Events

To perform an event forecast, execute the utility as follows:

%perl ixforecast.pl –e 

The following output file is generated. Each row of output corresponds to one event in the CA Workload Automation AE
database, as shown below: 

964114081955|7/20/00 11:28 AM|JU2|oftenMins||STARTJOB|<eventQualifier>|Event was
 Scheduled based on Job Definition.

964114084055|7/20/00 11:28 AM|JU2|oftenMins||CHANGE_STATUS|STARTING|<reason>

ixusers.pl-View Currently Active Users
The ixusers utility provides information about currently active users. This utility returns the user IDs, their current filters,
the size of the users' caches, and the time each user logged onto iXp.

To run this utility, enter the following command:

perl ixusers.pl

The following example shows the utility output:

total users=4

John.Doe, Level Zero Filter,6k,04/01/08 22:49

Jane.Doe,AsiaJobs,3k,03/25/08 19:18

Rob.Smith,EuropeJobs,3k,03/28/08 15:34

Mary.Jackson, Exception Filter,1k,04/03/08 22:01

ixauditreport.pl-Generate the Audit Report
The ixauditreport utility generates an Audit Report in HTML or CSV format. You can generate a report for either a specific
user or all the "Admin" users. For information about how to generate the Audit Report, run the following command:

%perl ixauditreport.pl

The following output is generated:

perl ixauditreport.pl -d auditDays -f outputFileName [-h || -c] [-u user || -i]

• -d
(Required) Specifies the number of days.

• -f
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(Required) Specifies the full path for the output filename.
• -h OR -c

(Required) Specifies the file extension html or csv.
• -u OR -i

(Required)
– -u

Specifies the valid user name.
– -i

Indicates all the users with ixpAdmin Privilege.

The following variables must be set:

• IXP_HOME
• CATALINA_HOME

Job Information and Restart Instructions
A Job Information and Restart Instructions browser pop-up function is available. Select a job name in iXp (the following
example uses "EuropeHourlyBox") then open a new browser to view the Job Information and Restart Instructions pop-up
as shown below:
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How to Manage Workload Migration
As an administrator, you are responsible for managing migration, including setting up security, enabling the migration
feature, and controlling what is available during migration. Workload Automation iXp migration assistant lets users migrate
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jobs and other related objects, such as calendars and global variables, from a Unicenter AutoSys JM 4.5.1 instance to any
CA Workload Automation AE r11.3 or higher instance.

NOTE

To migrate workload objects from an older Unicenter AutoSys JM release instance to a newer release instance,
you can also use CA Workload Automation AutoSys Upgrade Assistant (AUA).

You can also perform any of the following migration management tasks:

• Configure the parameters of the CA Workload Automation AE r11.3 or higher instance to which the Workload
Automation iXp server connects.

• Manage authorization policies for migration.
• Create exclusion rule sets that, when applied, filter the workload objects retained in the package during migration.
• Create conversion scripts that, when applied, eliminate syntax errors that can be potentially encountered during the

migration of workload objects.

You may also be tasked with creating migration packages and performing the actual migration of packages created by
users without the migration privileges. For more information about migrating workload, see the section How to Migrate
Workload.

As prerequisites, configure the parameters of the Workload Automation iXp server to let users create and perform
migrations from the Workload Automation iXp server. Also define authentication policies for users.

To manage workload migration in Workload Automation iXp, follow these steps:

Configure the Parameters of the CA Workload Automation AE Instances

You must configure the parameters, such as environment variables and database connection information, of the CA
Workload Automation AE instances to which you want to migrate workload. The configuration of the CA Workload
Automation AE instances lets the Workload Automation iXp server access the CA Workload Automation AE data.

Note: You can select a predefined CA Workload Automation AE instance to edit it or create a new CA Workload
Automation AE instance.

Configure Two Instances with Identical Names on a UNIX/Linux iXp Server

If the name of the new CA Workload Automation AE instance is the same as that of an existing Unicenter AutoSys JM
4.5.1 instance, and you want to connect Workload Automation iXp to both instances, we recommend that you install the
Workload Automation iXp server on a UNIX/Linux machine.

Follow these steps:

1. Log in to the iXp server.
2. Install and configure the Unicenter AutoSys JM 4.5.1 client and the CA Workload Automation AE r11.3 or higher client.

WARNING
Both clients can be installed with the same name, but the software files have to be located in two separate
directories.

3. Configure the relevant database client files with the proper connection information for the Unicenter AutoSys JM 4.5.1
instance.

4. Open the iXp Admin tool and then click the Instance tab.
Note: We recommend that you configure the Unicenter AutoSys JM 4.5.1 instance first.

5. Click New, and define a 3-letter designation that is different from the original instance name for the new Unicenter
AutoSys JM 4.5.1 instance.
For example, if the Unicenter AutoSys JM 4.5.1 instance is called "ACE", you can name it as "A45" in Workload
Automation iXp.
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6. Define proper values for the other instance parameters as per the location of the software files on the iXp server, the
Unicenter AutoSys JM 4.5.1 database connection properties, and other Workload Automation iXp related settings.
For more information about setting up an instance definition, see the section Configure CA Workload Automation AE
Instance.

7. Click Save to save the configuration of the first instance.
8. Click New, and define a 3-letter designation that is the original instance name for the new CA Workload Automation AE

r11.3 or higher instance, for example, "ACE".
9. Define proper values for the other instance parameters, and click Save.

The configuration of the second instance is saved.
10. Set the environment for the Unicenter AutoSys JM 4.5.1 instance and the iXp installation.
11. Open the $IXP_HOME/etc/instance directory, and run the following command:

env |sort > $AUTOSERV.env

A file with the original name of the Unicenter AutoSys JM 4.5.1 instance is created.
12. Rename the file with the name of the Unicenter AutoSys JM 4.5.1 instance as configured in Workload Automation iXp,

for example, "A45.env".
The "env" file is created. 
Two instances with identical names are successfully created on a UNIX/Linux iXp server. 

NOTE

• Every time the Unicenter AutoSys JM 4.5.1 command runs, Workload Automation iXp sets its
environment based on the "env" file that is created. Although the instance is identified with a different
name, the environment is set with the original name and the command work properly.

• When you configure the filters and user/group security policies in Workload Automation iXp, use the
name designated for the Unicenter AutoSys JM 4.5.1 instance and not its original name.
For example, the filters and security policies must refer to the Unicenter AutoSys JM 4.5.1 instance as
"A45" and not "ACE". The name "ACE" must be used for the new CA Workload Automation AE instance.

• You must let the users know the meaning of the names designated in Workload Automation iXp.

Configure Two Instances with Identical Names on a Windows iXp Server

You can configure two instances with identical names on a Windows platform only if the Unicenter AutoSys JM 4.5.1
instance is not eTrust-enabled. If the Unicenter AutoSys JM 4.5.1 instance is eTrust-enabled, you must install Workload
Automation iXp on a UNIX/Linux machine to connect it to two identically named instances.

Follow these steps:

1. Log in to the iXp server.
2. Install and configure the Unicenter AutoSys JM 4.5.1 client.
3. Define a 3-letter designation that is different from the original name of the instance.

For example, if the Unicenter AutoSys JM 4.5.1 instance is named "ACE", you can name it "A45" during the client
installation.

4. Define proper values for the other instance parameters.
Note: The parameter values must match their values in the original instance.

5. Configure the relevant database client files with the proper connection information for the Unicenter AutoSys JM 4.5.1
instance.

6. Install the CA Workload Automation AE r11.3 or higher instance with its original name and settings.
7. Open the iXp Admin tool and then click the Instance tab.

Note: We recommend that you configure the Unicenter AutoSys JM 4.5.1 instance first.
8. Click New, and define a 3-letter designation that is used during the installation of the Unicenter AutoSys JM 4.5.1

client, for example, "A45".
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9. Define the values for the other instance parameters based on the location of the software files on the iXp server, the
Unicenter AutoSys JM 4.5.1 database connection properties, and other iXp related settings. For more information
about setting up an instance definition, see the section Configure CA Workload Automation AE Instance.

10. Click Save to save the configuration of first instance.
11. Click New, and define a 3-letter designation that is the original instance name for the new CA Workload Automation AE

r11.3, Release 11.3.5, or Release 11.3.6 instance, for example, "ACE".
12. Define the proper values for the other instance parameters, and click Save to save the configuration of second

instance.

Two instances with identical names are successfully created on a Windows iXp server.

NOTE

• When you configure the filters and user/group security policies in Workload Automation iXp, you must use
the name designated for the Unicenter AutoSys JM 4.5.1 instance and not its original name. For example,
the filters and security policies must refer to the Unicenter AutoSys JM 4.5.1 instance as "A45" and not
"ACE". The name "ACE" must be used for the new CA Workload Automation AE instance.

• You must let the users know the meaning of the names designated in iXp.

Assign Security Privileges for Migration

You can assign migration-related privileges to the existing users and groups. The Migrate privilege determines whether a
user or a group can open the migration assistant to create a migration package or perform migration.

You must have the following iXp privileges to create migration packages:

• Users can create migration packages with only the jobs that are included in their individual- or group-inherited Job
Read and Job Detail privileges.

• Additionally, users will need the read privilege for global variables (Global Variables Read) and calendars (Calendars
Read) that are related to the jobs included in the migration package.

Note: See the section Assign Privileges to Users and Groups for further details about the security privileges. 

Follow these steps:

1. Log in to the iXp Admin tool.
2. Do one of the following:

– Assign the migration privilege to a group, as follows:
a. Click the Group tab.

The Group dialog is displayed.
b. Select a group from the Group drop-down list.

– Assign the migration privilege to a user, as follows:
a. Click the User tab.

The User dialog is displayed.
b. Select a user from the User drop-down list.

3. Click the Privilege tab to view the list of security privileges.
4. Double-click Migrate.

The migration privileges are displayed under the Migrate category.
5. Select the Create Migration Package privilege, and set the User can create migration packages for job streams

check box as appropriate.
6. Select the Perform Migration privilege, and set the User can perform migrations of job stream check box as

appropriate.
Note: You can migrate the packages created by other users if you have been set up as an "Admin" user and the
"Perform Migration" privilege has been assigned to you.
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7. Click the Save icon to save the settings for migration privileges.

Important! When you are assigned the "Perform Migration" privilege, you also need the following privileges to
successfully migrate the objects to the target instance:

• Job Read, Job Detail, JIL Insert, JIL Update, and Job Control privileges on all the jobs included in the package.
• Machine Use privilege should include all the names shown in the "Machines" tab of the Migration Assistant.
• JIL Owner privilege should include all the names shown in the "Owners" tab of the Migration Assistant.
• Global Variable Read, Global Variable Update, and Global Variable Delete privileges should include all the names

shown in the "Globals" tab of the Migration Assistant.
• Calendar Read and Calendar Update privileges should include all the names shown in the "Calendars" tab of the

Migration Assistant.

Create an Exclusion Rule Set

You can create an exclusion rule set, so users can apply the rule set to their migration packages. An exclusion rule set
is a set of rules that specifies the criteria to exclude jobs from the migration package before the package is migrated.
The criteria can be based on the status of the jobs (for example, jobs with statuses that have not changed in over 500
days, jobs that are in ON_ICE for more than 365 days, and so on) and other attributes. Once you assign the rule set in
the migration configuration, the migration assistant automatically applies the rule set every time a package is created or
opened.

Notes:

• Users creating migration packages can choose not to apply the rule set.
• Users can also manually override the exclusion of one or more jobs.

Follow these steps:

1. Log in to the iXp user interface client.
2. Click the View tab, and select Hide Selected Jobs to create an exclusion rule set.

The Hide Selected Jobs window is displayed.
3. Click the Create New Rule Set icon at the top left.

The Input dialog is displayed.
4. Enter the name of the exclusion rule set, and click OK.

Note: Do not include spaces in the name of the exclusion rule set.
5. (Optional) Select the newly-created rule set from the Rule Set drop-down list to apply the job exclusion rules based on

the job status, machine, and owner.
6. Click the Status tab to add exclusion rules based on job status.
7. Select the corresponding Apply check box, and specify the options as appropriate.
8. Click the Machine tab to exclude jobs based on machine, and specify the following as appropriate:

– Insert
Lets you add the name of the machine in the exclusion list. 

– Delete
Lets you remove the name of the machine from the exclusion list.

9. Click the Owner tab to exclude jobs based on owner, and specify the following as appropriate:
– Insert

Lets you add the name of the owner in the exclusion list. 
– Delete

Lets you remove the name of the owner from the exclusion list.
10. Click the Miscellaneous tab to view the remaining exclusion settings, and specify the following as appropriate:

– Exclude empty boxes
Lets you exclude the empty box jobs. 

– Exclude sleep, dir, env, and ls jobs
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Lets you exclude jobs whose command attributes begin with "sleep", "dir", "env", and "ls".
11. Click the Save icon to save all the specified rules.
12. Click OK to apply the rule set to the current view and close the dialog.

All the specified rules are applied to the rule set.

Create Conversion Scripts

CA Workload Automation AE r11.3, Release 11.3.5, or Release 11.3.6 has stringent syntax requirements, compared
to Unicenter AutoSys JM 4.5.1. Therefore, some existing object definitions or attribute values may not meet the new
requirements. You can create scripts or programs to parse job, calendar, and global variable files and modify their
definitions and attribute values to meet the new syntax requirements. The scripts can also be used to make changes to
meet internal standards.

Once applied, the migration assistant automatically runs the scripts specified for each object type on the respective files
generated from the Unicenter AutoSys JM 4.5.1 data.

WARNING

The conversion scripts are run with the same execution permissions as the iXp server, typically Admin or root.
Before you execute migration scripts, ensure that you review and trust the code or content of the scripts.

JIL Conversion Script

The JIL conversion script receives the JIL file generated by the migration assistant as standard input. The script then
parses the JIL file and modifies the file to meet the syntax requirements of the target CA Workload Automation AE
instance and the internal corporate standards. The migration assistant captures the standard output and uses the modified
JIL file as the new JIL file.

Note: A sample PERL script (ixpParseJobs.pl) is provided in the "contrib" sub-directory under the iXp home directory.

Run the Syntax Checker on the Generated JIL File

You can run the syntax checker on the generated JIL file to identify the syntax-related errors and verify that the JIL file
meets the syntax requirements of the target instance.

Follow these steps:

1. Extract your current Unicenter AutoSys JM 4.5.1 job definitions to a JIL file by running the command:
autorep –J ALL –q

2. Run the following command to verify any missing dependencies in the Unicenter AutoSys JM 4.5.1 instance. The
output from this command shows the names of the jobs and any of their predecessor jobs that do not exist. Missing
dependencies generate warnings during migration and prevent the jobs from running properly in the new CA Workload
Automation AE environment:
echo exit 0 |jil –V batch >OUTPUT_FILE

2>&1 

OUTPUT_FILE   = Defines the name of the JIL file where the output must be stored.
3. Copy the JIL file to a machine in which the new CA Workload Automation AE r11.3 (or higher) client is installed.
4. Run the following command to perform a syntax check on the entire JIL file. The output from this command shows the

potential errors and warnings that are encountered during migration if no changes are made to the job definitions or
the JIL file:
jil –V syntax <INPUT_FILE>OUTPUT_FILE 2>&1 

INPUT_FILE  = Defines the name of the JIL file that contains the Unicenter AutoSys JM 4.5.1 job definitions. 
OUTPUT_FILE   = Defines the name of the JIL file where the output from the syntax check command must be stored.
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Note: If you want to create a conversion script for calendars, you must identify the names of the calendars that generate
error messages about invalid characters or symbols when you run the syntax checker on the JIL file.
The two output files let users identify possible syntax-related issues that are encountered when the jobs are migrated
to the new CA Workload Automation AE r11.3 or higher instance. You can view the error messages that begin with
"CAUAJM_E", from the output file generated by the syntax checker

Global Variables Script

The global variables script receives the sendevent script generated by the migration assistant as standard input. The
sendevent script is used to create the related global variables. The global variables script parses and modifies the
sendevent script to meet the syntax requirements of the target instance and the internal corporate standards. The
migration assistant captures the standard output and uses that as the new sendevent script.

Note: A sample PERL script (ixpParseGlobals.pl) is provided in the "contrib" sub-directory under the iXp home directory.

Extract Global Variable Names and Values to a JIL File

You can extract the existing global variable names and values to a file and parse the contents to verify that the names of
the global variables match the syntax requirements as listed in the CA Workload Automation AE Reference Guide.

Follow these steps:

1. Extract your current Unicenter AutoSys JM 4.5.1 global variable names and values to a file by running the following
command:
autorep –G ALL > OUTPUT_FILE 2>&1 

OUTPUT_FILE  = Defines the name of the file where the output must be stored.
2. Identify the global variables whose names or values do not match the syntax requirements as listed in the CA

Workload Automation AE Reference Guide.
For example, the following global variable does not pass the syntax requirements of CA Workload Automation AE
r11.3, Release 11.3.5, or Release 11.3.6: 
VAR%1 FAIL 10/31/2012 00:00:01 

The conversion script must find such variable names and replace "%" with a valid character.

Calendars Script

The migration assistant creates a file to create all related calendars in the target instance. This file is compatible with the
"autocal_asc" command. The calendars script parses and modifies this file to meet the syntax requirements of the target
instance and the internal corporate standards. The migration assistant captures the standard output and uses that as the
new calendar file.

Note: A sample PERL script (ixpParseCalendars.pl) is provided in the "contrib" sub-directory under the iXp home
directory.

Configure Migration Options

You must enable migration at your site if you want users to be able to open the migration assistant from the iXp user
interface.

Follow these steps:

1. Log in to the iXp Admin tool.
2. Click the Migration tab.

The General migration settings are displayed by default.
3. Select the Migration enabled check box to enable the migration feature in the iXp user interface.

Note: By default, this option is turned off.
4. Specify the following instructions on the General tab:
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– JIL Command
Defines the default command that is executed to upload the jobs from the migration package to the target CA
Workload Automation AE instance. 

– JIL Syntax Checker Command
Defines the default command that is executed to check the syntax of the JIL file generated by the migration
assistant. 

– Exclusion Rule Set
Specifies the exclusion rule set that you want to apply to each migration to skip certain jobs when migration
packages are being created. 
Note: You can use the iXp user interface to create a new exclusion rule set. For more information about the
exclusion rule set, see Create an Exclusion Rule Set. 

– JIL Conversion Script
(Optional) Defines the conversion script that runs against the JIL file. 

– Global Conversion Script
(Optional) Defines the conversion script that runs against the global variables definition file. 

– Calendar Conversion Script
(Optional) Defines the conversion script that runs against the calendar definition file. 

– Remove Migration Packages after X days
Specifies the number of days after which any packages that are successfully migrated to the target instance are
removed from the Workload Automation iXp server.

5. Click Save to save the migration options.

You configured complete settings for the migration of workload object using Workload Automation iXp. Users with the
necessary privileges can now open the migration assistant, create migration packages, and migrate workload objects from
Unicenter AutoSys JM 4.5.1 instance to a newer release of CA Workload Automation AE.

Signed JAR Expiration Notices
The CA Workload Automation iXp JAR files are signed with an SSL certificate, so that the JAR files are verified and
trusted by the JRE on a user's desktop when logging in to the iXp GUI or iXp Admin Tool. To ensure complete and
consistent cryptographic protection, these signed JARs will expire occasionally. When the iXp signed JARs expire, your
desktop client's JRE can no longer trust that the iXp GUI and iXp Admin Tool are secure. Hence, it alerts you either
through a popup alert, or based on your JRE/browser settings you may not get any notice at all. To get the newly signed
JARs, you must apply the appropriate iXp maintenance.

To help you plan for iXp maintenance, the iXp GUI and iXp Admin Tool has a feature that alerts you of an
impending signed-JAR expiration date. This alert starts when there are less than 180 days till JAR expiration, and a
popup notification will be displayed to every user who logs in to the iXp GUI or iXp Admin Tool.

For non-Admin iXp users, the iXp GUI shows the signed JAR expiration alert and recommends that users contact the
iXp Administrator. For iXp users who are configured as Administrators, a different popup window opens, allowing them to
disable the alert system wide.

WARNING

When an Administrator disables the system-wide certificate-expiration alert for all users, no other alerts
will be displayed to any users. Hence, the iXp Administrators must upgrade or apply the appropriate
maintenance for iXp, after disabling the expiration alert.

The following screenshot shows a sample popup notification for users in the iXp GUI:
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The following screenshot shows a sample popup notification for Administrators in the iXp GUI or iXp Admin Tool:

Determine the Expiration Date of Signed JAR Files

You can determine the expiration date of signed JAR files in the following ways:

• When a user logs in to the iXp GUI or iXp Admin Tool, the user's Java Console displays the number of days that are
left until expiration.

NOTE

Some users do not have access to the Java Console and would need to use the Java configuration tool to
make the necessary adjustments to see the log.

• When you start the iXp Server, it checks the signed JAR expiration date and outputs the expiration details (expiration
date and number of days left until expiration) in the iXp server logs. The iXp server logs are located in the IXP_HOME/
log directory:
– IXP_HOME

Specifies the root directory of the iXp files.
• Wait till the iXp GUI or iXp Admin Tool detects that there are less than 180 days till expiration and displays a popup to

your users.

Re-enable Signed JAR Alerts

If an Administrator has disabled the signed JAR alert mechanism inadvertently, you can re-
enable it by setting the following property value in the IXP_HOME/etc/server.conf file and restarting the iXp server:
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IXP_IGNORE_EXPIRED_CERTS_NOTICE=false

Auditing

When an Administrator disables the signed JAR expiration alert, the user's ID and the date/time of disabling are logged in
the iXp Server log file. The iXp server log files are located in the IXP_HOME
/log

 directory:

• IXP_HOME
Specifies the root directory of the iXp files.

Workarounds for Expired JAR Files

We recommend that you plan and upgrade iXp to the latest maintenance to prevent the expiration of the signed JAR files.
However, if the JAR files have already expired and you want to immediately resolve this issue, you may add iXp to the
exception list in the Security tab of the Java Control panel. This step must be performed on each user's desktop computer.
To launch the Java Control panel, change to the following directory from the command prompt and run the
javaws -viewer

command:

java_install_dir\bin

• java_install_dir
Specifies the Java installation directory.
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Using
Contact your iXp administrator for the URL of the iXp server and login information. On the main GUI, drag the window size
adjusters with your mouse to view all four iXp windows. To move the panel all the way to the edge of the GUI window, left-
click the arrow indentation on any size adjuster. Any views in that direction will collapse. For example, a left-click on the
down arrow indentation on the size adjuster between the Console View and the Job Flow View will completely hide the
Job Flow View and enlarge the Console View.

The main GUI provides multiple graphical views to display job data.

To verify your version of iXp, select the Help > About menu option.

Contents:

Access the iXp Client 

When accessing the iXp client for the first time, open the iXp Application using Java Web Start. Since this is the first time
you are opening the application, on the iXp Client machine run a following command:

javaws http://venus:8080/ixp/iXp.jnlp

Set Up and Manage the iXp Client Session

You can customize some parameters and user preferences of the iXp Client session. After you set up your user
preferences, click the File > Save Session Settings menu option. This option saves the following settings of your
session:

• User preferences, as listed in the preference dialog.
• The start-up filter setting, as dictated by the Current Filter.
• The current iXp windows layout, the size, position and sort order of columns in the Console View and the Alarm

Manager.

The next time you open iXp, the saved settings will determine the display format and the data shown.

Set Time Zone

By default, the job run information displayed throughout the iXp Application is shown based on the time zone of the iXp
Client machine. For example, users opening the iXp client in Malaysia for CA Workload Automation AE jobs running in
Chicago will see all the job run times in the corresponding Malaysian time zone.

The File > Set Time Zone menu option lets you set your time zone preference, and the job run data will be displayed
based on the selected time zone.

Note: iXp administrators can use the iXp Admin Tool to assign a timezone for each CA Workload Automation AE instance.
In that case, iXp will always show the information in that timezone, irrespective of the value here.

Change Password

Select the File > Change Password menu option to bring up the Password dialog box to change the iXp password for the
current user.

View Global Variables

Global Variables are set using the CA Workload Automation AE sendeventSET_GLOBAL command. Select
the View > Global Variables menu option to bring up the Global Variables information window. 
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By default, all Global Variables that you are allowed to view across all CA Workload Automation AE instances are
displayed, along with their current values. To search for a specific variable, type a search string in the Global Name field
(* wildcard is supported) and click the search icon. The search is not case-sensitive. You can also filter global variables list
based on an instance.

Select a Global Variable in the top section of the window to view Related Jobs in the lower section of the window. 

Related Jobs are jobs that depend on the Global Variable, or jobs that set the Global Variable (using a sendevent in the
job definition command line).
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iXp Launcher
The

iXp Launcher is a new interface for starting the iXp GUI and AdminTool components, directly from your Windows desktop.
This feature was added in iXp r11.3.5 INCR8 due to changes in the Oracle Java Architecture and removal of the Java
Web Start feature.

Note: For more information on installing the iXp Launcher on your Windows desktop, see Install the iXp Graphic User Interface on a
Windows Desktop.

To start the desktop iXp Launcher, double-click on the ixp.exe icon (example
below):

iXp LauncherHere is an example of the iXp Launcher
GUI:

This new interface allows you to enter the target URL for an iXp Server instance, and start the iXp GUI or AdminTool.

BUTTON DESCRIPTION

iXp Server URL Enter the proper URL for an iXp server. Ensure that you include
the port number, if relevant in your installation.
For example, http://ixphost:8080/ixp

Connect Click Connect to connect to the iXp Server URL you entered,
to see if a valid iXp server instance is running. If the iXp server
instance is up and running, the iXp GUI and iXp AdminTool
buttons will be enabled after validating the connection. If there is
a problem connecting to the server URL you provided, an error
message/status will be displayed.

iXp GUI Click on this button to launch the iXp GUI. If the button is disabled
(grayed out), then you must first enter a valid iXp Server URL and
click Connect.

AdminTool Click on this button to launch the iXp AdminTool. If the button is
disabled (grayed out) then you must first enter a valid iXp Server
URL and click Connect.

Keep Window Open.. By default the iXp Launcher will close or exit when you click either
the iXp GUI or iXp AdminTool buttons. To keep the window from
closing, select this checkbox.

Add an iXp Server URL

By default, when the iXp Launcher is initially started, there are no known iXp Server URLs listed in the dropdown.
However, once a valid connection is made, the new iXp Server is added to the dropdown for future use when the
Launcher is started again. 

Delete an iXp Server URLYou can edit the iXp Server List and remove an iXp Server URL from the drop-down list of
URLs. 

Follow these steps:

1. Select File, Edit Server List. A list of servers displays.
2. Select the server/s you want to remove from the list and click Delete.
3. Click OK. The server/s are now removed from the Server list.

Troubleshooting

Start the iXp Launcher
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If you experience problems starting the iXp Launcher, see the Troubleshooting section at Install the iXp Graphic User
Interface on a Windows Desktop.

Unable to Connect to an iXp Server URL

Error dialogs are very descriptive, make sure you follow the example server URL. If problems persist, collect the
admin.log, launcher.log and ixp.log from the desktop Users iXp install folder for review by Broadcom Support.

View Jobs
A job is the basic building block on which an operations cycle is built. A CA Workload Automation AE job is any single
command or executable, UNIX shell script, or Windows batch file. Each CA Workload Automation AE job definition
contains qualifying attributes, including conditions for when and where a job should be run.

• Command jobs execute commands.
• Box jobs are containers that hold other jobs.
• File watcher jobs watch for the arrival of a specified file.

Contents:

Select Multiple Jobs in Views

You can select a job in any view by left-clicking the job name. 

• <Ctrl>left-click adds jobs to those selected—two or more jobs at the same time—this applies in the Tree View, the
Console View, and the Job Flow View. 

• <Shift>left-click selects all jobs between the two mouse click locations—this applies in the Tree View and the Console
View. 

Once jobs are selected, right-click to bring up the Job Tools pop-up for all of the selected jobs.

Note: In multi-selected mode, right-click does not bring up the Expand and Collapse selections of the menu.

Customize Job View

To get better visual overview of the jobs, you can use various options from the View menu to hide unwanted data or to
display additional data.

Hide Selected Jobs

Select the View > Hide Selected Jobs menu option to create or select rule sets that define criteria to hide jobs from the
current view or to apply when performing migrations. When the rule set is applied to the current view, jobs matching the
rule will be hidden, until the user changes the filter or restarts the UI. 

For more information about these rule sets, see the section How to Manage Workload Migration.

To hide individual jobs and their progeny or instances in the view, select the object in the view, right-click the selected
object, and from the drop-down menu select the Hide option.

Note: Activating this item removes the selected job or instance and also all of the jobs within them, from all of the
views. You cannot hide a Site.

Expand Box Jobs

Select the View > Expand menu option to expand all the box jobs in the current view by one more level. This is an easy
way to drill down in all the displayed box jobs one level at a time.
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Select the View > Expand All menu option to expand all the box jobs in the view to show all the jobs contained in the box.
This is an easy way to drill all the way down in all the displayed box jobs.

To expand or collapse only one box job or instance, select the object in the view, right-click the selected object, and from
the drop-down menu select the required option:

• Select Expand to include the children of the box job in the views.
• Select Expand All to include all progeny of the box job (its children, their children, and so forth) in the views.
• Select Collapse to remove all progeny of the box job (its children, their children, and so forth) from the views.

Undo View Functions

To undo the most recent iXp view function performed, such as Expand or Include, select the Edit > Undo menu
option. Then, sequentially, the previous functions become available for Undo. 

Save View as JIL

To generate a text file with JIL definition of all the jobs that are currently in view, select the File > Save View as JIL menu
option. This feature will generate the file as long as every job in view passes the user's JOB_DETAIL privilege. By default,
the file will be shown in a web-browser.

Job Overrides

Select the View > Job Overrides menu option to bring up the Job Overrides view window, populated with job names of
jobs that have current Overrides. Select a job name and then select View Override to see the Overrides for that job.

To delete an override, click the Delete button. You will be required to confirm that you want to delete the override. 

The Close button lets you close the dialog without affecting any of the jobs and overrides listed.

Tree View

The Tree View depicts the hierarchical box structure of the jobs. Box Job icons look like a box and open when the Tree
View displays the jobs contained in the Box Job. Left-click the knob next to a Box Job or double-click the box to expand
one level and show the contents of the Box Job in the Tree View.

Use the right mouse button to select Expand to expand the view one level, or Expand All to view the entire Tree View.
The Expand or Expand All option can be applied to a Box Job, an Instance or the whole Site. Expanding a Box job shows
all the jobs at the next level within the selected Box job.

Expanding an instance shows all Level Zero jobs (i.e. all jobs that are NOT within a Box job), including top-level Box jobs.
When an Expand All is performed, all jobs within the selected Instance or Box or Site are shown. This could result in quite
a large number of jobs. 

Each job has an icon that displays the status of the job. Icon meanings are listed on the Graphics Help page under the
Help menu.

Note: Clicking on the Status, Box name, Run machine, Application, or Group attributes automatically creates a temporary
job filter that shows all jobs with the same attributes.

Editing Job View Preferences
To customize how job information is displayed, select the Edit > Edit Preferences menu option. The Preference Editor
dialog opens where you can set job status colors and adjust other iXp job view parameters.

After setting new preferences, click the Save icon to save the new preferences. Once preferences are saved, you can
change them by saving new ones.
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Customize Job View Colors

You can assign different color for a job icon based on the job status to quickly differentiate between jobs. You can also
assign a color for the iXP application background to visually differentiate between multiple iXp windows.

Follow these steps:

1. Left-click the mouse on the value for a status color, such as "FAILURE Color". The Color Editor appears. 
Use the Swatches, HSB or RGB tabs to choose the color for the chosen status:
– In the Swatches tab, select on a color swatch.
– In the HSB tab, drag the marker around in the color selection square.
– In the RGB tab use the scroll bars to select the color.

2. Select OK in the Color Editor to show the color in the Preferences Editor window.
3. Select OK again in the Preferences Editor to apply the new status color to the iXp views.

Customize Other Job View Preferences

The following table lists other preferences that you can specify for job view.

Preference Name Description
Filter The Filter specifies to the iXp Daemon about the kind of data the

user wants to view. See JOB FILTERS for more information.
Job Name Font Sets the font type for the job names in the Job Flow View. Click

Job Name Font to bring up the font chooser window.
Table Font Sets the font type for iXp table views.
Tree Font Sets the font type for iXp tree views.
Future Hours Sets the number of hours of forecast data visible in the Time View

chart window.
Horizontal Spacing Sets the horizontal spacing between jobs in the Job Flow View

window.
Past Hours Sets the number of hours of historical data visible in the Time View

chart window.
Refresh Interval Sets the number of seconds between iXp client refreshes.
Vertical Spacing Sets the vertical spacing between jobs in the Job Flow View

window.

Searching Jobs

Quick Find

To find a particular job, enter the search string (job name or its part) in the box to the right of Help on the iXp Menu
Bar. Any job name containing the string entered will be matched (wildcards are not supported because all matching strings
will be found).

The order in which jobs are found is controlled by the Tree View order, that is: jobs near the top of the Tree will be found
first. 

Click the Next  and Previous icons to move the selection to the next job that matches the string in the box. If no jobs have
a matching string, the icons are grayed out.

Job Search

Use the View menu to search for particular jobs. 
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Find Job By Name

The View > Find Job By Name menu option brings up the Find By Name window. Enter a job name or a wildcard string
and press Enter to see the list of jobs whose name matches the string.

Select one or more jobs and choose OK to highlight the jobs in the job view windows. If the selected jobs are not in the job
views, the job views will expand to include the selected job. Also, double-clicking a job selects that job in the Views. Click
the Refresh button on the Find By Name window to refresh the list of job names. Click Cancel to exit the Find By Name
window without selecting any jobs.

Narrow the names on the Find By Name list by typing a wildcard name string in the Job Name field and then pressing
Enter. iXp assumes that you are searching for job names rather than instances. A ^ denotes the instance name following
each job name. The job name matching is not case-sensitive. 
Typing one or more characters after a * finds the job names ending in that character, not the instance name (E*2 finds job
names ending in 2, regardless of whether on instance JU2 or JU3). That is, *xyz expands to *xyz^{*}.

Find Job By…

The View > Find Job By…menu option provides the following additional options for locating a particular job:

• Job Type (Command, Box, File Watcher, File Trigger, FTP)
• Description
• Command
• Watch File (name)
• Owner
• Machine

Instance is an option for each search as is Job Name.

After you enter the search conditions (for example, Job Type is "command" and Job Name is "test*") click the
search icon to find matching jobs, then select one and click OK. The specified job will become the highlighted/selected job
in all iXp views.

Job Detail View
The Job Detail View shows details of the selected job.

 Note: Clicking on the Status, Box name, Run machine, Application, or Group attributes automatically creates a temporary
job filter that shows all jobs with the same attributes.

The following table lists items on the job detail view:

Detail View Item Description
Selected Jobs Lists the jobs that have been selected in the Console View, the

Job Flow View, or the Tree View. If more than one job is selected,
only the selected job names will appear; the remaining fields in the
Detail View will be blank.

Instance/icons The name of the CA Workload Automation AE Instance where this
job is defined, and icons that provide detail about the job. In the
example above, the icons show that this is a Command (rather
than Box or File Watcher) job, that it has date/time conditions, that
it has a dependency, and that it uses a Global Variable.

Box Name The name of the Box Job that contains the selected job. Jobs that
are not in boxes will show N/A.

Description The contents of the CA Workload Automation AE JIL description
attribute.
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Command / Watch File The contents of the CA Workload Automation AE JIL command
attribute to be executed for command jobs, and may be the name
of any command, executable, UNIX shell script or batch file, and
its arguments. If the job is a Box Job, this field is not shown. If
the job is a File Watcher, then the contents of the CA Workload
Automation AE JIL watch_file attribute is shown.

Condition The contents of the CA Workload Automation AE JIL condition
attribute specifies when the job can or cannot run relative to other
jobs. If this attribute is blank, then this field is not shown.

Group Displays the group that the job is associated to.
Application Displays the application that the job is associated to.
Status, Machine, Start Time, End Time, and Next Start The same attributes as described for the Console View.
Exit Code The exit code returned by the operating system for the most

recent run of the job.
Job Load The CA Workload Automation AE JIL job_load attribute data;

default value is 0 if not defined. This field is not shown for Box
jobs.

Priority The CA Workload Automation AE JIL priority attribute data; default
value is 0 if not defined. This field is not shown for Box jobs.

Days of Week/Run Calendar The CA Workload Automation AE JIL days_of_week or
run_calendar attribute of the selected job. If this attribute is not
defined, then this field is not shown.

Exclude Calendar The CA Workload Automation AE JIL exclude_calendar attribute
of the selected job.

Start Times / Start Mins The CA Workload Automation AE JIL start_times or start_mins
attribute of the selected job. If this attribute is not defined, then this
field is not shown.

Time zone Displays the CA Workload Automation AE JIL time zone attribute
of the selected job. If this attribute is not defined, then this field is
not shown.

Run Window The CA Workload Automation AE JIL run_window attribute of the
selected job. If this attribute is not defined, then this field is not
shown.

Predecessor Jobs The predecessors to the selected jobs, as shown in the Job Flow
View. A check box in front of the predecessor job name indicates
whether the condition between that job and the selected job has
been met or not.
Selecting a job in the Predecessor Jobs list will highlight that job
in all the views, including the Job Detail View. This is one way to
easily trace through job dependency relationships.

Successor Jobs The successors to the selected job, as shown in the Job Flow
View. Each successor job is listed with an icon that shows its
current status.
Selecting a job in the Successor Jobs list will highlight that job
in all the views, including the Job Detail View. This is one way to
easily trace through job dependency relationships.

Global Variables If the selected job is dependent on Global Variables , or is setting
the value for any, then the current value of the global variables will
be displayed here.
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If any of the following attributes are displayed, you can click the values shown to perform the associated actions:

Attribute Associated Action
Run Calendar View the calendar dates in the graphical Calendar dialog.
Exclude Calendar View the calendar dates in the graphical Calendar dialog.
Predecessor Job Change the selection to the job that was clicked.
Successor Job Change the selection to the job that was clicked.
Global Variable Open the Global Variable dialog to view the list of jobs associated

with the clicked Global variable, set the value or delete the Global
variable.

Console View
The Console View provides an ordered list of jobs and their vital details.

COLUMN NAME DESCRIPTION
Job Type The job type: CMD, BOX, FW, or new job type
Icon The type of job or its state represented pictorially.
Instance The 3 letter CA Workload Automation AE instance that contains

the displayed job.
Job Name The job name, a CA Workload Automation AE attribute.
Status The most current job status with its defined color.
Time View A Gantt chart that shows past and future job runs based on the

Past Hours and Future Hours settings for the user. The future job
runs are based on the real-time forecast performed by the iXp
Server.

Run Machine The name of the physical machine that the job last ran on or is
currently running on.

Start Time The time the job last started.
End Time The time the job last ended.
Duration End Time minus Start Time, accurate to the second. For currently

running jobs, this column shows Current Time minus Start Time.
Next Start The next start date/time for jobs that are defined with date

conditions.
Estimated End Time For currently running jobs, this column shows the forecasted end

time as calculated by the iXp Server.

To adjust the column widths in the Console View, dragg the edges of the column heading labels (e.g. "Start Time") with
the left mouse button. You can lock the first three columns (job type, icon, instance, and job name) in size by selecting
the View > Lock Job Name Column menu option.

To modify the order of the columns, dragg them individually to the appropriate positions. The order of the first four columns
that show the job type, job icon, instance and job name respectively, cannot be changed.

Each job row has an icon that indicates the status of the job.

Sort Order in Console View

To rearrange the listing order in the Console View, right-click a column heading and select the sort.
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If no sort order is selected, and if there are no open ALARMS for any of the jobs in the Console View, the jobs will be
displayed in the Default Order, which is a hierarchical sort order, very similar to the Tree View. 

Jobs that have even one Open Alarm are listed at the top of the view. If multiple jobs have Open Alarms, those jobs are
sorted by the time the Alarm was generated, with the job with the most recent Alarm at the top. As soon as all the Open
Alarms for such a job have been Acknowledged or Closed, the job would move to its default position. 

The Console View lets you specify primary and secondary sort criteria. For example, jobs could be sorted first by Job
names and then by Start Times. 

Sorting by Status gives the following order:

• FAILURE/TERMINATED
• RESTART
• QUE_WAIT
• PEND_MACH
• RESWAIT
• WAIT_REPLY
• STARTING
• RUNNING
• ACTIVATED
• ON_HOLD
• ON_ICE
• ON_NOEXEC
• SUCCESS
• INACTIVE

Time View
The Time View displays the past and forecasted job runs for all jobs listed in the Console View. 

The job runs are displayed as colored rectangular bars, where the boundaries of the bars are based on start and end
times of that run. The color of the bar indicates the completion status of the run. For forecasted runs, this would always
match the color for a successful run. The colors can be edited by accessing the Preference Editor dialog. A smaller solid
bar within the boundaries of the job run shows the progress of currently running jobs. The color of that bar matches the
color of the RUNNING status. If the job has been running much longer than average, the color of that bar turns red. If
the job has not run beyond its average duration, the distance between the end of the solid bar and the end of the job run
boundary shows the estimated time left for the completion of the job. 

The Time View has vertical line markings by the hour and the current time is displayed in red with a vertical red line going
down the view. All job runs shown to the right of the red line of the current time are the forecasted runs. 
The iXp Server generates a real-time forecast for all the configured CA Workload Automation AE instances. To generate
an accurate forecast, the iXp Server takes into account the current statuses of all jobs, job dependencies, date/time
conditions, and average job durations as stored in the CA Workload Automation AE database. The iXp Server performs a
forecast of each CA Workload Automation AE instance as per their forecasting properties listed in the iXp Admin Tool. The
iXp Server also accounts for all the major CA Workload Automation AE latencies and hence the duration for forecasted
runs may be greater than the average job duration, which does not account for any latencies. If a past job run lasted much
longer than the average duration for that job, the job run is marked with a red 'X' in the Time View. This provides a visual
alert on all job runs that lasted longer than average.

NOTE

Jobs that run much longer than scheduled, or are predicted to run much longer than scheduled, are also marked
with a red X.
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Setting Chart Duration

Use the "Past Hours" and "Future Hours" settings in the Preference Editor to set the duration of the Time View chart. For
example, by setting the Past Hours and Future Hours to two Hours, the Time View would depict any runs within the last
two hours for the jobs in the Console View and also show all forecasted runs for the next two hours for the same jobs.

Use the "Time Window" tab on the Filter Editor window to select jobs to be displayed according to their past and future
run times. For example, adjusting "Past Hours" to two and "Future Hours" to 10, in the Filter Editor, and then applying
the resulting filter, will contain jobs that have run in the past 2 hours, are currently running, or are forecasted to run in
the next 10 hours. Adjusting the Time Window in the Filter Editor does not affect the Time View Chart duration set in the
Preference Editor.

Retrieve Run Data

The File > Retrieve Run Data menu option specifies whether the client retrieves the historical and forecasted job runs. If
this option is not selected, no job run data are displayed and hence the Time View does not show any runs. In order for
the client to display past and forecasted job runs, select the Retrieve Run Data option.

Turning off Retrieve Run Data can improve the application speed especially for dial-up use.

Job Flow View
The Job Flow View shows the predecessor and successor job relationships for each job and the box hierarchy.

Left-click a job in the Job Flow View to show the selected job with a red border, and highlight its predecessor and
successor relationship arrows. All other jobs and arrows will be grayed out. Once a job is selected, any right-click actions
will affect that job.

In the Job Flow View, the jobs are arranged in the following ways:

1. Largest job streams (set of related jobs—jobs in boxes and jobs that depend on each other) at top left.
2. Smaller job streams are spaced across the top (or side if streaming top to bottom). Additional job streams are centered

under each job stream in the top row.
3. All jobs with no dependencies are grouped together
4. All other things being equal (size, number and position of predecessors, number and position of successors, how

many joids occur between the two compared joids), jobs with a higher JOID (i.e. jobs that were defined later) will be
below or to the right of jobs with lower JOIDs.

Jobs that are contained in the same box or Level-0 jobs, once they have been grouped, are positioned using the following
criteria:

• size of job or box
• number and position of predecessors
• number and position of successors
• the presence of out-of-box predecessors or successors
• the presence of circular dependency logic

If all the listed criteria are equivalent for two jobs in the same box, a job with a higher JOID (i.e. jobs that were defined
later) will be below or to the right of a job with a lower JOID. 
The Stream Jobs option on the View menu can be used to toggle between a left to right job flow and a top to bottom
(default) job flow.

Note: Viewing large number of jobs in the Job Flow View increases the consumption of system resources on your client
machine. You can hide the Job Flow View by deselecting the View > FlowView > Display Flow View menu option.

Contents:
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Zoom

Use the Zoom buttons on the iXp toolbar to adjust the size of the Job Flow View. The Fit icon sizes the Job Flow View to
show the entire structure. You can select the zoom value from the drop-down list or by clicking the Zoom icon. The zoom
value of 100% gives a font size for the Job Flow View about equal to the other view fonts. 

The default sizing layout in the Job Flow View (Zoom 100%) is derived from the job name font, horizontal spacing, and
vertical spacing as set in the preferences.

Other sizing options are the Zoom in and Zoom out icons on the Flow View Toolbar, and the "rubber-band" function—
use the mouse to select an area that you want to view in more detail (this works best when refresh is paused). Finally, it is
possible to simply type numbers in the zoom drop-down list.

Names in Job Flow View

In the Job Flow View, job names can be abbreviated in several ways. This preserves View space in the event of
commonly used naming practices. The abbreviation functions are as follows:

• Truncate Job Names, based on shared prefixes of sibling jobs existing on the iXp Client. Example: jobs named
abc101 and abc102 are abbreviated to *1 and *2. The three special characters (., _ and –) are special delimiter
characters, and are kept in the abbreviated job names.
Example: abc.101 and abc.102 are abbreviated as *.101 and *.102.

• Keep First 8 Letters, which is a simple numerical cut of everything from character 9 on.
• Hide Job Names, which reduces each job to an icon.
• Show Job Names displays the entire job name for each job.

To adjust the job name, select the View > Job Flow View menu option.

Note: You can reduce the size of the job representations in the Job Flow View using the Hide Icons menu option.

Global Variable Symbol

Jobs that have dependency relationship on a Global Variable show a white "map pin" in the upper-right corner. This
indication is shown for two kinds of jobs.

• Jobs that have an explicit dependency on one or more global variables, as defined in their starting conditions.
• Jobs that set the value of one or more global variables. The appropriate sendevent syntax for setting global variables

must be defined in the command field.

Print Job Flow View

To print the Job Flow view, select the File > Print menu option. The standard operating system Print window
appears. Adjust Properties for your printer if necessary, and click OK to print the Job Flow View.

Multi-page prints are tiled, with tile row and column numbers printed in the lower left of the pages.

The Print Grid controls paging and lets you customize the print by zooming in or out. Select the View > FlowView >
Show Print Grid check box to see the Print Grid in the Job Flow View window.

NOTE
 The entire Job Flow View will be printed, not only what you see in the Job Flow View's scrolling area. Currently,
the print size and print orientation is not configurable. Hence, the print size is always 8.5 x 11 inches, and in
portrait orientation. If the print layout exceeds one page, iXp will print out the job flow across multiple pages.

View Job Relationships

The following options under the View > Job Flow View menu option let you control the display of job relationships:
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• Show Arrows–Controls the drawing of arrows in the Job Flow View. If it is selected, the view displays all job
relationship arrows. This is the default option.

• Hide Out of Box Arrows–Controls the drawing of arrows for out-of-box dependencies. If this option is selected, then
the Flow View will not display arrows for such dependencies.

• Hide All Arrows–Controls the drawing of all arrows in the Flow View. If this option is selected, then the Flow View
will not display any arrows between jobs. If you select a job, then the arrows to the immediate predecessors and
successors of that job will be shown.

• Enable Arrow Routing–Routs arrows around the jobs rather than over or behind them. This option is only valid when
jobs are being streamed from top to bottom.

View Job Information
To view detail information about jobs, right-click a job in a view, select the Job Information option, and then select the
required information:

• Job definition
• Detailed report on the last job run
• Run data displaying all the historical and forecasted runs of the selected job
• Log files the job and CA Workload Automation AE created when the job ran on the Remote Agent machine (if the iXp

Agent is installed on that machine)
• Calendars associated with the job

Select Job Definition, Detailed Report, View Run Data to view the Job Information for the selected job. Select the Log
Files sub-menu item to see a list of files that you can retrieve for the last job run. Select the Calendars sub-menu to see
the Run or Exclude Calendar for a job.

Note: To see Log Files of Jobs, you need the iXp Agent only if you are running CA AE Release 11.0. iXP Agent is not
needed if you are running CA AE Release 11.3 and higher.

Job Definition

Select Job Definition to return the JIL definition of the job. This is by means of a call to the CA Workload Automation AE
command:

autorep –J jobname –L 0 –q

To view job definitions, you require a CA Workload Automation AE Client that is configured for all instances monitored
through iXp.

Detailed Report

Select Detailed Report to return the event history of the most recent run of the job. This is by means of a call to the CA
Workload Automation AE command:

autorep –J jobname –r 0 –d

To run a Detailed Report, you require a CA Workload Automation AE Client that is configured for all instances that are
monitored through iXp.

These reports are returned in a Web browser.

Run Data

The Run Data option provides a listing of all the historical and forecasted runs for the selected job. The runs are listed in
descending order with the most recent run at the top. The most recent run (or the current run if the job is running) has the
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run-number 0. Hence, the oldest run has the highest run-number. All forecasted runs are marked with "FUTURE", rather
than numbers. This provides a clear indication about which runs are forecasted and which are actual.

Note: Forecast runs are displayed here only if Forecast Duration Hours are set to a value greater than 0 in the CA AE
instance configuration tab of the Admin Tool.

Selecting Run Data returns a report as shown in the following screen:

To see the detailed report (autorep -d) on any run, select that run on this dialog and click the View Detail button.

The following table provides description of columns in the Job Run Data report:

RUN DATA COLUMN DESCRIPTION
First column Job run identifier number, as used in the CA Workload Automation

AE command autorep –j job_name –r run_number.

Status Status of the job for the specific run of the job.
Start Time Time the run of the job started.
End Time Time the run ended.
Duration End Time – Start Time.
Exit Code Exit Code returned for the execution of the job run.
Run Machine Name of the machine where the job is run.
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RunNum Run number that is associated with every run of a job.

Create Run Data Report

Once the appropriate runs have been imported in the Run Data dialog, you can create an HTML report that lists those
runs by clicking the Create Report button. The report opens in a web browser. You can save the run report, print it or send
it by email.

The following image shows a sample job run report:

Calendars

Select the Calendars option to view the name and the dates of calendars attached to the selected job. The calendar
shown is "Read only" and no changes are permitted.

Note: This option is available only for jobs that use a "run_calendar" or "exclude_calendar". 

You can view one calendar year at a time by selecting the year from the drop-down list. For each year, the dates set inside
the calendar definition are shown in "green" color. The name of the calendar is shown in the title bar of the window. 
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Job Log Files
You can retrieve the following log files for the last job run of the selected job:
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• STDOUT
• STDERR
• STDIN
• Job Profile
• Remote Agent

To retrieve the files, right click the job, select Job Information, Log Files, and then select the requested file. The log file
opens in a web browser. You can search for text, email, or print the contents of the file.

If any of these files are not present on the Remote Agent machine, the iXp Client will notify you. Since all of these files
reside on the Remote Agent machine, the iXp Agent has to be up and running on that machine in order for the iXp Client
to show the files for jobs running in Unicenter AutoSys JM r11 or older versions. If the iXp Agent is not running, then the
iXp Client will display an error indicating this condition. If the iXp Client displays a Process Timeout error, you can try to
retrieve the log again.

Note: The Log Files option is available only if the privilege to view Job Log files or Job Script files has been assigned to
you. 

STDOUT, STDERR, STDIN

Select the Standard Out, Standard Error, or Standard In option to view these files. The iXp Daemon will extract the
file name as defined to the job and resolve any Substitution, Global, or Environment variables in the file name before
retrieving the file. If the file name is based on variables that can have dynamic values (e.g. the RUN_NUM, NTRY of a job,
the date when the job ran, and so on), then the iXp Daemon will use information from the last run of the job to determine
the value of such variables.

The following image shows the output of an STDOUT file. The job is defined to create the STDOUT file based on
a Global Variable called "LOGDIR" and the standard CA Workload Automation AE Environment variables called
"AUTO_JOB_NAME" and "AUTORUN". The output from iXp Client shows the resolved name of the file after the
appropriate values were plugged in for the variables used.
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Job Profile

Select the Profile menu option to view the file that has been assigned to the job profile field in the job definition. 

Note: This functionality is available only for UNIX jobs.

The following image shows a job profile file:
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Remote Agent Log

Select the Autoremote Log option to view the Remote Agent Log file. In most cases, CA Workload Automation AE is
set up to purge the Remote Agent Log when the job ends in a SUCCESS. This functionality may work only with jobs in a
FAILURE or TERMINATED status. 
For Unicenter AutoSys JM r11 or older, if the iXp Agent cannot find a file, the web browser window will show that
message. The window will also show the fully qualified name of the file that the iXp Agent attempted to retrieve.
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Note: To view log files of a job, you need the IXp Agent if you are running CA Workload Automation AE Release 11.0. The
IXp Agent is not needed if you are running the CA Workload Automation AE Release 11.3 or highier.

Create Custom Sendevents
Sendevent is a CA Workload Automation AE command to activate the scheduler. The File > Sendevent menu option
opens the sendevent dialog for creating custom sendevents for selected jobs. You can select one or multiple jobs for
creating sendevents. If more than ten jobs are selected, they are denoted in the Current Sendevent window as J* rather
than a complete listing. 

This menu option is visible only if you are allowed to control jobs. 

 Select the tabs in the Sendevent Dialog to create a custom sendevent. Click the Issue Sendevent button to issue the
event to CA Workload Automation AE. Click the Close button to close the Sendevent Dialog. 

Future Sendevent: The option Time (-T) provides a mechanism to issue events for a later date and time in advance,
rather than doing it in person at that time. For example, a job may have been put ON_HOLD a few minutes ago and you
want the job to be taken OFF_HOLD later that night. It would be easier to issue a future OFF_HOLD event on that job for
that night, rather than to open iXp to issue the command exactly at the appropriate time. 
Clear the Now check box to enter a time when the sendevent will occur.

Opening the Sendevent dialog pulls all instance/job related future events from AE server and fills the tables in tabs
according the event type. After each send event all tables are refreshed. Sometimes however the new future event may
not appear in the table immediately. In this case consider refreshing future events by clicking Refresh future events
button.
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To unsend the event select future event from the table, check Unsendevent checkbox and click Issue sendevent button.

Standard Tab

The Standard tab creates default sendevents as does the Job Control option, with the option to alter the Sendevent time.

Standard Tab Item Description
Example: Sendevent Pick from the standard Sendevent listing: FORCE_STARTJOB,

JOB_ON_HOLD, JOB_OFF_HOLD, JOB_ON_ICE,
JOB_OFF_ICE, JOB_ON_NOEXEC, JOB_OFF_NOEXEC,
KILLJOB, STARTJOB. These are as in Job Control > STARTJOB.

Comment (-C) Type a comment to be associated with the Sendevent.
Time (-T) Select a time for the Sendevent, or select Now (the default time).
Current Sendevent Lists the Sendevents that have been selected. Select Issue

Sendevent to issue to CA Workload Automation AE, or select
Close to close the window without issuing any events.

CHANGE_STATUS Tab

CHANGE_STATUS Tab Item Description
Example: sendevent Pick from the CHANGE_STATUS types: FAILURE, INACTIVE,

RUNNING, SUCCESS, TERMINATED, as are in the Job Control
Pop-up.

ALARM Tab

ALARM Tab Item Description
Example: sendevent Pick from the ALARM type that is listed as per the selected

version of CA Workload Automation AE.

COMMENT Tab

COMMENT Tab Item Description
Comment (-C) Type a comment – for standalone COMMENT if no job is selected,

or to go with selected jobs.

SET_GLOBAL Tab

Set_Global Tab Item Description
Global Variables Select Global Variables that must be created or updated. All

existing variables are provided in the drop-down list.
Values Select Values for the Global Variables. All the values for the

existing global variables are provided in the drop-down list.

CHANGE_PRIORITY Tab

CHANGE_PRIORITY Tab Item Description
Priority Select the priority value to be assigned to the chosen job. You can

pick a value from the drop-down menu or type it in.
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SEND_SIGNAL Tab

SEND_SIGNAL Tab Item Description
Kill Signal Select the kill signal to be sent to the chosen job. You can pick a

value from the drop-down menu or type it in.

MACHINE Tab

MACHINE Tab Items Description
Event Name Select the event that you want to send to the machine.
Machine Name Select the name of the machine that you want to send the event

to.

Manage Calendars
Contents:

Create and Edit Calendars

To create and edit CA Workload Automation AE calendars, select the View/Edit Calendars option from the Definition
menu. The View/Edit Calendars selection provides a GUI-based editor for CA Workload Automation AE calendars.

NOTE

If you use Unicenter AutoSys JM r11 or higher, you can use this editor to manage extended calendars and
cycles.

To manage an existing calendar, select the calendar name and the CA Workload Automation AE instance from the
respective drop-down list.

The panel below the calendar name displays the job and box jobs that the selected calendar is applied to.

The default view shows all 12 months of the current calendar year. You can change the view by selecting the year from
the drop-down list.

The forward and reverse buttons move by 3 months at a time, the fast forward/fast reverse move by 1 year at a time.

When you are managing a standard calendar, clicking a date toggles the inclusion of that date in the calendar. When the
date is included, it is displayed in green by default. If the date is excluded, there is no background color.

Manage Standard Calendars

Click the calculator icon to bring up the Date Generator dialog where you can create standard calendars with dates that
follow a pattern. For example, you can create a calendar that includes the 10th, 20th, and 30th of every month with the
following settings:

 119



 CA Workload Automation iXp 11.4.00

Manage Cycles

If you use Unicenter AutoSys JM r11 or higher, you can create cycles that extended calendars can leverage. To create
a cycle, set the appropriate Instance and select the New > Cycle menu option. Enter the name of the cycle. The date
generator dialog shows the parameters to manage a cycle.
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You can specify the date ranges for the cycle by entering the Start and End dates for each period. You can type in the
dates manually, or you can select them visually by clicking the date icon next to the date field.

To set the cycle to repeat every year, omit the year or select the year "1972" when entering the dates.

You can move the periods up and down. You can also delete them by using the up/down arrows and the delete icon.

You can view the cycle definition in the format the "autocalasc" command supports by clicking the

 icon.

To save the cycle, click the "Save" icon. You can also copy the cycle to another instance by clicking the "Save As" icon.
You can copy the cycle to a new name within the same instance by clicking the "Copy" icon.
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Once the Cycle has been saved and the date generator dialog has been dismissed, the Calendar Viewer/Editor shows
the days that the cycle covers.

Managing Extended Calendars

If you use Unicenter AutoSys JM r11 or higher, you can create extended calendars that one or more jobs can use. To
create a new extended calendar, set the appropriate Instance and select the New > Extended calendar menu option.
Enter the name of the calendar. The date generator dialog shows the parameters to manage an extended calendar.

Once you have the appropriate values for the calendar, you can click the Preview icon

 to
see the dates that are set when the calendar is saved. The dates are shown for the next 12 months from the current day.

Once the calendar has been saved, you can click the Generate icon

 to
regenerate the dates for the next 12 months from the current day.

To save the extended calendar, click the "Save" icon. You can also copy the calendar to another instance by clicking the
"Save As" icon. You can copy the calendar to a new name within the same instance by clicking the "Copy" icon.

Once the calendar has been saved and the date generator dialog has been dismissed, the Calendar Viewer/Editor
shows the days the calendar covers.

Edit Jobs
To maintain and administer jobs, select the Edit Jobs option from the Definition menu.

The bottom area of the job editor shows the Job Information Language (JIL) that will be used to define the job to CA
Workload Automation AE.

NOTE

For more information about each field in the Job Editor, click the help icon next to each field in the iXp GUI.

The following pages of job editor provide information about jobs and let you edit jobs:

Basic page

Basic information for a job includes the following items:

• Job Name
The job name is used to identify the job to CA Workload Automation AE, and must be unique within CA Workload
Automation AE. It can be from 1- to 30 alphanumeric characters long, and is terminated with white space. Embedded
blanks and tabs are illegal.

• The Box the job is in (if any); box job is a CA Workload Automation AE job that spawns other jobs that are "contained"
in the box job. 

• Job Owner (ID to be used when running the job)
• Job Type (cannot be changed)
• Description
• Condition (starting conditions of the job)
• Machine
• Group
• Application
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Date/Time page

The Date/Time page includes the following details:

• Date Conditions check box—must be selected to schedule by date & time
• Date sub-page

– Run Calendar
– Run Days
– Exclude Calendar

• Time sub-page
– Times of Day
– Minutes After Each Hour
– Run Window
– Time Zone

Alarm page

The Alarm page includes: Maximum and Minimum Run Time alarms, and the Alarm on Failure and Alarm on Terminate
check boxes.

WARNING

 The Alarm on Terminate feature works only with CA Workload Automation AE 11.3.6 SP7 or higher.

 

Execution page

The Execution page includes the following options:

• Box terminator (for jobs in boxes)
• Job terminator (for jobs in boxes)
• Terminate job minutes
• Delete job hours
• Restart number of times parameter
• Average run time minutes
• AutoHold for jobs in boxes check box

Runtime page

On the Runtime page, the standard output file, standard error file, standard input file, and profile to be used when running
a job are defined.

Resource page

Resources include the Maximum Exit Code parameter, the Heartbeat Interval, the Job Load and Job Priority settings (for
use with queuing), and the Disk Space parameters.

Permission page

On this page the permissions for access to the job are defined. Edit and Execute permissions for Group, World, and All
Hosts are available.

Box page

This page contains parameters that are unique to Box jobs: Box Success and Box Failure conditions.

File Watcher page

This page provides parameters that are unique to File Watcher jobs. Minimum File Size and Steady State Interval are the
parameters supported here.
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Issue User Commands
Select the File > User Command menu option to bring up the User Command pick list. This menu option is visible only if
you are allowed to execute User Commands. You will only see those User Commands that are either shared globally, or
shared with your groups.

User Commands are created by the iXp administrator. User Commands are a way for iXp to pass job data to existing
UNIX or Windows scripts, commands, or program interfaces on the iXp Server. Once User Commands are created, they
appear on the pick list. When a User Command is run, iXp sets appropriate environment variables on the iXp Server, for
the type of command, and then opens the specified command.

By default, the user has to confirm the execution of the User Command (this requirement may be disabled by the
administrator—in which case the command will execute immediately).

User Commands may require input from the user (again, as defined by the administrator). If that is the case, the prompt
will appear.

For more information about user commands, see Manage User Commands under Administrating.

Job Type Commands

User Commands of type Job may be run when a job is selected in the iXp views. Select "Job" to run a User Command
of type Job after selecting a chosen job in the iXp views. Job User Commands can ONLY be run when a job has been
selected. If no job is selected, the Job User Command menu item will be grayed out. User commands can be set up such
that you can select multiple jobs and then execute the same command on each of the selected jobs. If a User Command
is executed on multiple jobs, iXp will run the user command on each job consecutively, and then show the concatenated
output.

When a user command is executed, some relevant information about the selected job is set in the environment. The
following example lists some of the environment variables that are set and their values:

IXP_HOME=opt/CA/ixp

IXP_USERCOMMAND_INPUT_PROMPT=

IXP_USERCOMMAND_INPUT=

IXP_USERCOMMAND_JOB_JOID=757

IXP_USERCOMMAND_JOB_LAST_END=5/7/15 11:31 AM

IXP_USERCOMMAND_JOB_LAST_RUN_MACHINE=aragorn

IXP_USERCOMMAND_JOB_LAST_START=5/7/15 11:11 AM

IXP_USERCOMMAND_JOB_NAME=FTSEDaily_FTSE_process

IXP_USERCOMMAND_JOB_STATUS=INACTIVE

IXP_USERCOMMAND_USER_NAME=ixpAdmin

ixp.home=opt/CA/ixp
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The results of any user command are shown in a web browser. This enables the user to leverage the functionality of the
browser to save, print, email, or search the output.

For a quick access to all user commands of a job type, you can also right-click a job in a view and select the User
Command option. This option shows all the job user commands that are available for execution.

Alarm Type Commands

User Commands of type Alarm are available when an Alarm Job is selected in the section Alarm Manager. The procedure
to execute Alarm User commands is the same as that for Job User commands.

If a Job Alarm is selected in the Alarm manager, right-clicking it will bring up the Alarm Pop-up menu, which includes
Alarm User Commands. The Pop-up is not supported for other types of alarms (Rollover, and so on).

Context Free Commands

For User Commands of type Context Free, the iXp Request Server executes the command without setting any job or
alarm specific information. To run context free commands, it is not required to click and select a job or an alarm. The
default context free user command supplied with iXp is Forecast-Report.

The Forecast-Report command provides a text report of all the forecasted runs.

Manage Reports
Reports list selected job runs of special interest. You can filter job runs based on relative or absolute times, job names,
box names, machine names, and job run statuses. The resulting data can be sorted by job name, job start time, or job
hierarchy. All the reports are generated in HTML format and are returned to the user in a web browser.

Create Reports

Select the Report > Edit Report Definition menu option to bring up the Reports editor. Use the Reports Editor File menu
to create and delete report types:

• Select the File > Create New Report menu option, and enter a name in the Input box to begin a report creation.
Specify report parameters in the tabs on the Report editor.

• Select the File > Save menu option to save the report creation. 
• Select the File > Delete menu option to delete the report name shown in the Report window. 
• Select the File > Copy menu option to create a copy of the report name populated in the Report window. 
• Select the File > Process menu option to process the report name populated in the Report window. The resulting

report will appear in a new browser window.

The Reports editor provides report information in multiple tabs. The following table lists the Reports editor tabs and their
usage:

Reports Tab Usage
Instance Select CA Workload Automation AE instance of jobs to be

reported.
Time Identify the times of jobs to be reported. Select Absolute to

specify an absolute start time to end time window. Select Relative
to choose a time window in the past from the present time.

Status Select the run status(es) of jobs to be reported: SUCCESS,
FAILURE, TERMINATED, ON_NOEXEC, RUNNING.

Row Count Select number of rows to be reported, to limit the report length, or
select "No Limit".
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Machines Insert and delete expressions for machine names of job runs to be
reported.

Jobs Insert and delete expressions for job names to be reported.
Boxes Insert and delete expressions for box names of job runs to

be reported. If a box name is specified here, the report will be
generated on the box job and all of the jobs within that box job.
This is an easier and intuitive way to generate reports for sets of
box jobs.

Order Select order of jobs in the report: autorep (the default order),
alphabetical, by start time, or "Last Run Only" for only the most
recent.

Group Select Groups to be included in the Report.

The following image shows an example of a job run report:

Process Reports

Select the Report > Process Report menu option to select a report for processing from a list. The list contains the
following reports:

• "Out of the box" reports delivered with iXp:

 126



 CA Workload Automation iXp 11.4.00

– The DailyErrors report shows all job runs that resulted in FAILURE and TERMINATED in the last 24 hours. 
– The DailyReport report shows all job runs that occurred over the last 24 hours. 
– The WeeklyErrors report shows all job runs that resulted in FAILURE and TERMINATED in the last 7 days. 
These reports cannot be edited, and ixp Admin-created reports cannot be edited by any user other than ixp
administrator. 

• Reports that have been created by you.
• Reports that have been globally shared by the administrators.
• Reports that have been assigned to one or more of your groups.

Alarm Manager
Alarms are special events that notify operations personnel of situations requiring attention. 

CA Workload Automation AE alarms are in one of three states:

• Open (red font)
• Acknowledged
• Closed

The Alarms button at the bottom of the iXp window brings up the Alarm Manager dialog. From the Alarm Manager, Open
alarms may be Acknowledged or Closed. Acknowledged alarms may be Closed or Acknowledged again. Closed Alarms
may be Closed again, if needed. When closing multiple alarms at the same time, a confirmation dialog appears before the
alarms are closed.

The Alarm Manager Buttons at the bottom of the Alarm Manager change the state of selected alarms, and prompt for a
Response. 

The iXp administrator can restrict the total length of each response (including the date/time and user name information
in the response header). If you enter a response that exceeds this value, an error dialog shows the maximum allowed
characters and the total length of the current response.

The File > Retrieve Alarm Data specifies whether the user receives the alarm data for all the jobs allowed. Clearing this
check box can speed-up the client, especially over slower networks.

Note: The Alarms button is visible only if the user has been assigned the privilege to view CA Workload Automation AE
Alarms and if the option Display Alarm Button is selected in the View menu.

The following table provides details for the fields and options in the Alarm Manager:

BUTTON DESCRIPTION
Acknowledge Acknowledge the selected Open alarms. If multiple alarms are

selected, the Acknowledge button will acknowledge those alarms
that are in the Open state. The Enter Alarm Response input box
will appear. Enter the appropriate response text for the alarms,
and select OK.

Acknowledge All Acknowledge all the Open alarms. The Enter Alarm Response
input box will appear. Enter the appropriate response text for the
alarms, and select OK.

Close Close the selected Open or Acknowledged alarms. If multiple
alarms are selected, the Close button will Close those alarms
that are in the Open or Acknowledged state. The Enter Alarm
Response input box will appear. Enter the appropriate response
text for the alarms, and select OK.

Close All Close all the Open and Acknowledged alarms. The Enter Alarm
Response input box will appear. Enter the appropriate response
text for the alarms, and select OK.
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Refresh Enabled By default, the Alarm Manager refreshes the alarm data with every
client refresh. To prevent the Alarm Manager from automatically
refreshing while you are working with it, clear this check box.

Show Closed Alarms Includes Closed alarms on the Alarm Manager list.
Hide Closed Alarms Removes Closed alarms from the Alarm Manager list.
Close Window Closes the Alarm Manager dialog.

The information boxes in the Alarm Manager window display the following alarm management information:

INFORMATION BOX DESCRIPTION
User The user who Acknowledged or Closed the alarm.
Comment An attribute of alarm, provided by the CA Workload Automation

AE scheduler.
State Time The time of the most recent state transition of the alarm (to state

Open, Acknowledged or Closed).
Response The response input when the alarm was transitioned from Open to

Acknowledged, or to Closed. If the alarm has been Acknowledged
or Closed multiple times, all the responses entered will be shown.

Job Control in Alarm Manager

Right-click an alarm to bring up the Job Control menu for the job that generated the alarm. Choose "Select in Console" to
highlight the job in all the iXp views. If the selected Alarm Manager job is not in the current iXp job set, a refresh will be
executed to bring in the job.

If the Alarm selected is not related to a job, a more limited pop-up menu is displayed.

Sort Order in Alarm Manager

To rearrange the listing order in the Alarm Manager, select a column heading with the right mouse button and select
the sort type. The columns in this dialog may be moved and resized by clicking and dragging the column headers. The
column positioning, sizing and the sort order can be saved by selecting the Save Session Settings option under the File
menu item on the main screen.

Alarm Manager on Top

If you are viewing the Alarm Manager and you click the main GUI screen, then the Alarm Manager will be sent to the
background. You will have to click the icon for iXp on the taskbar to bring it to the foreground. If you enable this menu
option, then the Alarm Manager will never be sent to background, even if you are working in the main GUI.

Instance Monitor
The Instance Monitor icon

 at
the bottom-left corner of the iXp window brings up a dialog box that shows the current state of all the CA Workload
Automation AE Instances.

If one or more CA Workload Automation AE Instances are experiencing a database issue, then the icon will change to

 .

 128



 CA Workload Automation iXp 11.4.00

If one or more CA Workload Automation AE Instances have been disabled in iXp, then the icon will change to

 .

Job Filters
When the iXp Daemon receives a request for a read operation, such as refresh, job filters are applied to the iXp Data
before returning jobs data to the Client, as follows. 

• The iXp Daemon first applies the appropriate security read filter to the site data, returning a security-filtered site. (The
request from the iXp Client always comes identified with the specific user, for individualized response from the iXp
Daemon.)

• Then the user-specified filter is applied to the security-filtered site data, and the data are sent to the client.

Current filter is the filter that currently applies to job view. Current filter is displayed in the Filter box at the bottom of the
iXP window. Use this box to change the current filter.  iXp will refresh the job views on the client, from the iXp Daemon,
using the selected filter. 

Filter Logic Sequence

The filter saved to the iXp Daemon, for the specific iXp Client, is applied to the security-filtered site, according to the
following filter logic: 

• The Job Attribute Filter or Job Dependency Filter reduces the view according to the specified attributes. Then any
Exclusion Post-Process attributes result in special eliminations.

• User-modifications to the views are applied, including Expand, Collapse, Expand All, Hide, Update Filter, Find Job by
Name, Predecessor and Successor (as chosen from the Job Detail View).

• Inclusion of the complete Box Ancestry for all jobs returning to the iXp Client is always the final filtration step on the iXp
Daemon.

• New jobs, arriving to the Client after graphics customization, are positioned logically by iXp, post-process.

Example Filtration Sequence

For an example of the filtration sequence of events, follow these steps:

1. Apply the level Zero Filter
Only the first level Box Jobs appear in the view.

2. Apply a Critical Path Filter on one of those jobs through the Update Filter function on the. 
This will create a new filter that belongs to you, and will return all the dependency-related jobs for that selected job,
also leaving the other first level box jobs.

3. Use the Find Job By Name function on a third level Box Job.
This returns that job and its parent, in addition to the other jobs.

4. The iXp Client will expand the box graphics in the Job Flow View and insert the newly returned jobs.

Filter Editor
The Filter Editor can be opened by selecting the Edit > Edit Filter menu option, or by clicking Filter Value in the
Preference Editor. Use the filter editor to adjust the configurations of the job attributes for any filter.

The iXp Daemon sends to the iXp client only jobs that pass the current filter.

Contents:
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Create a Filter

Click the New Filter icon to create a new filter. When you type in the name for the filter, remember that the
name cannot include any spaces.

You can create a filter that includes jobs based on values for one or more attributes listed in this dialog. By default, each
attribute is ignored unless you explicitly provide a list of values. For example, if the Job Name field is blank, all job names
will pass through the filter.

Define a new filter using the attributes listed in the Filter Editor Tabs.

Edit a Filter

To edit a Job Attribute Filter, follow these steps:

1. Select the filter from the Current Filter menu. The list of filters is ASCII sorted (alphabetically with capitals first).
2. Select the filter attribute that you want to edit from among the twelve tabs: Description, Current Status, Job Name, Box

Name, Owner, Instance, Box Level, Defined Machine, Exclusion, Run Machine, Run Status, and Time Window.
3. Edit the properties of that tab on the dialog. For Instance, Run Machine, Defined Machine, Exclusion, Job Name, Box

Name and Owner, use the Insert and Delete buttons to edit the Expressions. In Box Level and Time Window, slide
the level pointer. In Current Status and Run Status, check or uncheck Statuses to filter. In the Description, directly type
your description information.

NOTE

For example, a wildcard expression for all jobs having Job Name that starts with Pay or pay can be used in
the follow way:

• You can use asterisk (*) as a wildcard for your search terms. For example, entering Pay*, pay* or PAY*
returns all jobs having Job Name with Pay or pay.

• For JOB NAMES, ^ is a special character that defines a CA Workload Automation AE Instance, as
inJob_A*^ACE...

4. Select OK to save your edits and close the Filter Editor window.
5. Click the Save icon on the Filter Editor, or on the Preference Editor, to save your filter edits.

The filter edits are saved. 

Note: iXp creates temporary filters when a user action related to the view is performed (e.g. Critical Path analysis).
These temporary filters are named username_number, where username is the name of the logged-on user and number
is an incremental number, starting with 0. To save any of these temporary filters, just select the filter and click the Save
icon. Remember to save such filters or else they will not be available to the user after logging out or closing the browser.
These temporary filters are very useful as users can save the results of any Impact Analysis actions, job selections, and
so on. 

Filter Editor Tabs

The following table lists tabs in the Filter Editor:

Filter Attribute Description
Instance CA Workload Automation AE Instance names, such as "ACE", or

wildcard expressions, such as "A*". The absence of any entries
means no jobs will be excluded based on instance.

Box Level Box Level is the maximum number of box levels that will satisfy
the filter. All jobs of a higher box level will be excluded.
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Run Machine Run Machine entries pass only jobs having one or more run
records in the specified list of statuses. Entries may be a string,
such as "pluto", or a wildcard expression, such as "pl*".The
absence of any entries means no jobs will be excluded based on
run machine. Only jobs having one or more historical run records
on a run machine (or virtual machine) will pass the filter. If a job
satisfies a filter, its box ancestry will also be included.

Run Status Works in conjunction with the Time Window tab. Only those
jobs that have historical or forecasted runs with a status selected
here AND within the time frame selected in the Time Window
tab will pass through the filter. By default, all run statuses are
selected.
 The filter includes all ancestors of jobs satisfying this filter,
regardless of the ancestors' Run Statuses. The absence of any
Run Status selections means no jobs will satisfy the filter. If no
Run Status filtration is needed, select all statuses.

Time Window "Future Hours" and "Past Hours" set bounds on the Run Status
and Run Machine filter tabs. Choosing "Ignore" for Past Hours
means no recent run history is required to pass the filter. Choosing
"Ignore" for Future Hours means no future execution is required to
pass the filter.

Defined Machine Each list entry can be a string, such as "pluto", or a wildcard
expression, such as "jup*". The absence of any entries implies
that no jobs will be excluded based on the JIL "machine:"
specification. A job satisfies the filter if it has at least one machine
in its JIL "machine:" definition that matches any of the filter's
wildcard expressions. Note that if a job satisfies a filter, its box
ancestry will also be included.

Exclusion Exclusion expressions are performed after all other filter
expressions. If a job_name satisfies an exclusion expression
that job, and if a box all of its descendants, will be discarded.
Expressions may be a string, such as "job_ABC", or a wildcard
expression, such as "job_A*".The absence of any entries means
that no jobs will be filtered based on Exclusion expressions.

Description Use the Description field to document the filter.
Current Status Only jobs with Statuses that are selected by a check mark

will satisfy the filter. If no statuses are selected, no jobs will pass
the filter. If all Statuses are selected, no jobs will be excluded
based on status. By default, all current statuses are selected.

Job Name Each list entry can be a job_name, such as "Job_A" or a wildcard
expression, such as "Job_A*". The absence of any entries implies
that no jobs will be excluded based on job_name. Note that "ˆ" is a
special character for delimiting instances. "Job_A" is equivalent to
"Job_Aˆ*".

Box Name Each list entry can be the name of a Box Job. The name supports
wildcard expressions. The filter will return all Box Jobs that match
the name expressions and all the jobs within them including other
box jobs.

Owner Only jobs with an owner that match these expressions passes the
filter. Entries can be a string, such as "root@pluto", or a wildcard
expression, such as "root@*". The absence of any entries means
that no jobs are excluded based on the owner.
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Group Filters jobs by group. To enforce empty value, type
<empty>

.
Calendar Filters jobs by calendar.
iXp Group Filters jobs by iXp group. A filter can be assigned to one or more

groups. When a filter gets assigned to groups, only the members
of that group (and administrators) will be able to see the filter in
their Shared Filter list. If a group has no members and the filter
gets assigned to that group, only the administrators will be able to
see that filter. Group members can use the filter, but not edit it. If a
user is removed, all of that user's filters will be deleted, including
group filters.

Application Filter jobs by application. To enforce empty value, type
<empty>

.

Filter Editor Check Boxes

The following table lists check boxes available in the Filter Editor:

Check Box Description
Read Only Indicates this filter is not owned by the current user and cannot be

modified.
Dynamic Indicates this filter is modified by job run data.
Graphics Configuration Indicates additional drill-down or drag-n-drop actions are

associated with this filter. This is a deprecated setting that may be
enabled again in a future release.

Needs Save Indicates that filter configuration changes have not yet been saved
to the iXp Daemon.

Filters Defined
There are two kinds of filters in iXp.

• Attribute Filters limit the job data that is sent back, according to specified job attributes.
• Job Dependency Filters limit the iXp views according to specified job dependencies.

Users have access to two types of filters: 

• "Out of the box" filters provided by iXp. These include several Job Attribute Filters.
• "User-defined" filters are owned by the user who defined them, and are configurable by him/her. These include

temporary filters created when jobs are added to the view.

All filters are applied after the user security filters have been applied.

NOTE

Applying the "No Filter" as a current filter will show all jobs that the user is allowed to see. 

Contents:
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Attribute Filters

Job Attribute Filter configurations may be edited, or created, with the Filter Editor. Attribute Filters can use CA Workload
Automation AE job attributes to further define or limit the views in iXp.
The following table shows the "Out of the box" Attribute Filters:

iXp Job Attribute Filter Name Description
Level Zero Filter Includes all instances in the site and jobs that are not in boxes and

box jobs at level zero i.e. jobs within a box are not shown.
Running Filter Includes jobs that have a current status of STARTING, RUNNING

or ACTIVATED.
Exception Filter Includes jobs that have a current status of FAILURE or

TERMINATED.
Instance Filter Only the Site and Instance icon are shown. No jobs are shown.
Site Filter Only the Site icon is shown. No instance icons or jobs are shown.
No Filter Shows all instances and all jobs within all instances.

Job Dependency Filters

You can apply the following job dependency filters on job views:

• Job Focus Filter
Filters the iXp views to show a job and its immediate predecessors and successors.

• Critical Path
Focuses on a job and then follows predecessor and successor relationships (dependency relationships) from that job,
as far as the dependency relationships can be traced in the job stream.

• Recursive Critical Path
Performs a critical path filter on the job, and on all its ancestors and all its progeny. This yields all the extended
ancestor and progeny relationships (Box relationships) to the selected job, and all the extended predecessor and
successor relationships (dependency relationships) to each of those jobs.

• Transitive Closure
Follows all Box and dependency relationships in both directions, throughout the CA Workload Automation AE Job
structure. First a Recursive Critical Path filter is applied to the selected job, then a Recursive Critical Path filter is
applied to the resulting jobs, and so forth through the job stream. Transitive Closure on any job in the set of jobs
returned by the Transitive Closure filter has the useful property that the filter applied to any one selected job returns the
same set of jobs as for any other job in the set. The Transitive Closure filter can be useful for understanding where the
partitions are in your job stream, hence for designing more modular job streams, for rapid failure recovery.
To show the transitive closure of all the jobs in the view, select the View > Transitive Closure menu option. This could
result in jobs being imported in to the view to display the complete closed set of jobs for all the jobs in the view. 

To create and apply job dependency filters, right-click a job and select New Filter or Update Filter:

• New Filter always creates a new temporary filter with the selected Job Dependency criteria. New Filter clears
the existing view, creates a temporary filter based on the username, and show the jobs that match the selected
filter. Select New Filter to create a new filter that will appear on the Set Filter list.

• Update Filter always updates the existing filter with the selected Job Dependency criteria. Update Filter applies the
selected filter to the existing view and may result in an addition of new jobs to match the filter but will not result in a
removal of any jobs from the existing view. Select Update Filter to return the union set of jobs for a job dependency
filter on the selected job, together with the existing filter. The Update Filter item has the same choices as the New Filter
option. 
For example, choosing an Update Filter of Job Focus will add the child and parent dependency relations of the
selected job to the view and will not remove the other jobs.
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Once the filter is set the preferred way, you can save it with a new name from the Filter Editor.

View Filters

Use the following options of the View menu to search for available filters:

• Find Admin Filter
You will see only those filters that have been either shared globally, or have been assigned to one or more of your
groups.
Some filters may not provide any data for some users, as their security settings may not allow them to view the jobs
specified in the filters. To import newly created shared filters, reopen the iXp clients.
Displays a dialog where you can find all or any of the Shared Filters that have been created and shared by the
administrators. Only administrators can modify these filters. You can search for a filter by providing a name with wild
cards.

• Find Personal Filter
Shows a dialog with all the filters created by the user, and the standard filters provided by iXp. If the user is an
administrator, then this dialog will show those filters that have been created by the user and not shared with other
users. This dialog is similar to the Shared Filters dialog.

• Find Group Filter
Shows a dialog with all the filters for the group, and the standard filters provided by iXp.

Job Control
To create job definition overrides, update job definitions, change job status, and send events to CA Workload Automation
AE for the selected jobs, right click a job, select the Job Control option, and then select the requested option.

Note: The Job Control menu provides only those options for which you are authorized.

Update Job

The Update Job menu item opens a dialog from which you can update the job definition.The Job Editor Dialog and the
JIL Editor allow users to update any attribute of the job, including the  owner  field. 

The Job Editor Dialog allows you to edit an job in a form-based dialog. The dialog accepts job definition attributes in JIL
format. That dialog also shows the current job definition in JIL format, for reference.

The JIL Editor shows a text-based editor where you can edit by typing in JIL statements. I think you are allowed to update
the owner field in both.

Note: The Job Editor Dialog performs a syntax check on the JIL submitted, and warns on erroneous, invalid and
incomplete data. 

Override Job

The Override Job menu item provides a dialog from which you can submit a one-time job override to CA Workload
Automation AE. For one-time overrides, CA Workload Automation AE only allows a selected job attributes to be modified.
Hence, the iXp dialog may generate error messages if the one-time override is issued for invalid job attributes.

The following image shows an example of a job override dialog:
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Change Status

The Change Status menu option lets you assign required status to a job.

Send Events

The Job Control menu option provides a list of events that you can send to CA Workload Automation AE for the selected
jobs. When an event is selected, you can also provide a comment that could be used for audit purposes. The comment
is not mandatory and the text area for the comment can be left blank. Every time iXp issues an event to the CA Workload
Automation AE database, the iXp username is inserted as a part of the comment, even if the comment is left blank. This
provides an audit trail of all events performed via iXp. 

When you select a particular sendevent, the confirmation dialog appears where you can type the comment to be
associated with that job and event.

 135



 CA Workload Automation iXp 11.4.00

View Server Statistics for CA Workload Automation AE Instance
Server statistics provide a comprehensive report on the capacity, usage and performance of a CA Workload Automation
AE instance. These statistics provide guidance to the CA Workload Automation AE administrator for capacity planning and
fulfilling service level agreements. Ideally, the scheduling latency should not be more than a few seconds and the number
of jobs submitted should be as high as possible without affecting the latency. The gray area is set to show the average
figures for every chart. 

Non-admin users can see this option only if the privilege has been granted by the administrator.

To view the statistics, right-click a CA Workload Automation AE Instance icon on the Tree View, and select the View
Statistics option. The Server Statistics chart appears.

From top to bottom, the charts show the number of jobs started per minute, the number of jobs completed per minute, the
events processed per minute, and the average scheduling latency time in seconds, each plotted as a function of time. The
gray area of each chart is set to contain eighty percent or more of the charted data.

The following image shows a sample server statistics chart:
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Select the chart duration in the list at the top of the chart. Move the mouse over a chart to view the exact data value, and
time, in the mouse flyover banner. 

iXp Client Command Line Interface
iXp provides a set of command line tools that enable users to execute the CA Workload Automation AE commands
sendevent, autorep, and jil from their client machine without installing the CA Workload Automation AE software. These
commands interface with the iXp Server and the actual execution of CA Workload Automation AE commands occurs on
the iXp Server. The results of execution are passed back to the client. All the parameters supported by the actual CA
Workload Automation AE commands can be passed to the iXp commands, including input files.

The following commands are supported: autorep, autostatus, job_depends, sendevent, jil.

All except one are counterparts to CA Workload Automation AE commands. Each command has the same syntax as its
CA Workload Automation AE counterpart, and accepts the same input and parameters. 

Issuing iXP Client CLI Commands

When you execute any command, the parameters and input file, along with your authentication information, are passed
to the iXp Server defined in your configuration file. If you have been assigned the authorization to execute the command
for all the parameters and input provided, the iXp Server will run the original CA Workload Automation AE counterpart,
capture the results, and send them back to you. The user's security privilege setting will control what jobs and what
actions are allowed. 

To run an iXP Client CLI command, select the File > CLI menu option and then select the command to run. For example,
to run an autorep command, select the File > CLI > autorep menu option. The command dialog appears. Click Run to run
the command. For specifics regarding the command line options, click the Usage button.
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For the jil command, you can additionally specify the "quiet" (-Q) and verification (-V) options or you can import file with
JIL from an external source.

iXP Client CLI Command Reference

The following iXP Client CLI commands are provided in the $IXP_HOME/bin directory. Click the command name for
details:

ixautorep
The ixautorep command is the iXp counterpart of the CA Workload Automation AE " autorep " command. It accepts the
same list of parameters that you can pass to the "autorep" command. 

 The following shows the syntax for the ixautorep command. Notice how it is actually the syntax of the CA Workload
Automation AE "autorep" command. 

C:\ixphome\bin>ixautorep

 

Usage:  [-J Jobname] <-d | -s | -q | -t | -o [Override #] | -w>
        [-B GroupName] [-I ApplicationName]
        [-R run_num] [-L Print Level] [-N Retry] [-x]
        [-G GlobalName] [-M MachineName] [-D TNS_alias_name]

        IF OverRide# = 0, it will display OverRide Currently in Effect. 

 

Error in command line for autorep.

JobName OR GlobalName OR MachineName is required. 

When you run the ixautorep command with the "-J", "-B", or "-I" option, it will provide the Summary, Detail, or Definition
output, depending on the parameters. Only those jobs for which you are authorized will be displayed. 
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When you run the ixautorep command with the "-M" or "-G" parameters, to view information about Virtual Machines or
Global Variables respectively, all the machines and global variables will be displayed.
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ixsendevent
The ixsendevent command is the iXp counterpart of the CA Workload Automation AE " sendevent " command. 

The syntax of the ixsendevent command is as follows: 

C:\ixphome\bin>ixsendevent 
Usage: sendevent -E EVENT [-S AUTOSERV] [-A Alarm] [-J JobName]
                [-B GroupName] [-I ApplicationName]
                [-s Status] [-P Event Priority] [-M Max Send Trys ]
                [-q Job Que Priority] [-G Global=Value] [-C Comment]
                [-U (Un-SENDEVENT)] [-T Time of Event] [-K Signal(s)] 

 

Error in command line for sendevent.
Event [-E] is required. 

When you run the ixsendevent command with the "-J", "-B", or "-I" option, it will issue the sendevent to the job only if you
are authorized to do so. Otherwise, the iXp Server will return a security exception. 
You can pass any valid parameter supported by the CA Workload Automation AE " sendevent " command.

NOTE

ixsendevent does not allow "-E STOP_DEMON" events. These events have to be issued from your normal
commands or interfaces.

ixjil
The ixjil command is the iXp counterpart for the CA Workload Automation AE " jil " command. This command enables
you to create, update, or delete CA Workload Automation AE job and machine definitions using valid JIL statements. 

 You can run the ixjil command only in the batch mode. You have to either pass a filename or valid JIL statements as
standard input. 

In the screen below, you can see how the ixjil command is executed with JIL statements and filename as standard input. 
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When you create, update, or delete job definitions, the name of the job has to match your authorizations. If the
authorizations have been implemented with naming standards in place, the job name has to meet your naming standards
also. 

In the example below, the user is authorized to create jobs with job names matching any of the following expressions: 

fin_*_*

pay_*_* 
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As shown above, the JIL insert statement for job pay2_app1_joba failed as it did not meet the authorization. 

Note: If the standard input to ixjil is a filename, the entire file should contain JIL statements that meet your authorizations.
If it contains even one JIL statement that does not meet your authorization, the entire file will be rejected.

ixautostatus
The ixautostatus command is the iXp counterpart for the CA Workload Automation AE "autostatus" command. This
command enables you to view the current status or value of a single CA Workload Automation AE job or global variable
respectively.

The syntax of the ixautostatus command is as follows:

C:\ixphome\bin>ixautostatus

Usage: <-J JobName> OR <-G GlobalName> [-S AUTOSERV]

Error in command line for autostatus.

For example,

C:\ixphome\bin>ixautostatus -J EuropeDailyBox

SUCCESS
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ixjob_depends
The ixjob_depends command is the iXp counterpart for the CA Workload Automation AE "job_depends" command. This
command enables you to view the list of job dependencies, the current status of predecessor and successor jobs of a
single job, or a forecast report of all jobs scheduled to run within a specific time frame and their successors. 

The syntax of the ixjob_depends command is as follows:

C:\ixphome\bin>ixjob_depends

 

JobName is required.

 

Must specify Mode:

c Current Condition Status

d Dependencies Only (from Job Definition)

t Time Dependencies (Forecasts) 
 
 Usage: job_depends< -c | -d | -t | -t -s | -t -e | -t -e -s ><-J JobName>| -w
 [-F From Date/Time (MM/DD/YYYY HH:MM)]
 [-T To Date/Time]
 [-L Print Level] [-D TNS_alias_name]

 

*** Error in command line for job_depends.***

 

The sample output of ixjob_depends command is as follows:
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ixautocal_asc
The ixautocal_asc command enables you to view, create, modify, and delete standard CA Workload Automation AE
calendars. The functionality is similar to the CA Workload Automation AE autocal_asc command.

The following example shows the command being executed with a filename that contains lines to add dates to a calendar:

#>cat infile

TESTCAL

A

08/05/2011

09/05/2011

10/05/2011 
 #>ixautocal_asc<infile

Utility to Add/Delete or Print entries in Calendar. 
 Calendar Name: Add (A) or Delete (D) or Print (P) ? 
 Date (MM/DD/YYYY [HH:MM]): ...Successful.

Date (MM/DD/YYYY [HH:MM]): ...Successful.

Date (MM/DD/YYYY [HH:MM]): ...Successful.

Date (MM/DD/YYYY [HH:MM]): 
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 The following example shows the command being executed with standard input that prints
 out the dates in a calendar: 
 #>echo "TESTCAL\nP" |ixautocal_asc

Utility to Add/Delete or Print entries in Calendar. 
 Calendar Name: Add (A) or Delete (D) or Print (P) ? 
 Days in the Calendar: TESTCAL

--------------------------------

08/05/2011 00:00

09/05/2011 00:00

10/05/2011 00:00

ixflags
The ixflags command is a command to view the current version of iXp Client. 

$ ixflags 

 iXp-11.3.5.X

NOTE

This command is not a counterpart to the CA Workload Automation AE " autoflags " command. The "X"
character in the preceding response shows the build number.

ixuserjobcmd
The ixuserjobcmd command allows you run a user command previously defined in AdminTool.

Specify the command and job names that this command will operate upon. The command return results in a standard
output.

NOTE

You must have rights to run user job commands.

usage: ixuserjobcmd v11.3.5.5097

 

-c,--command <arg> - REQUIRED. User job-command name.

 

-j,--job <arg> - REQUIRED. Job name or comma separated list of job names 
that are passed to a user job-command. If fullname is notused, current 
instance is added to job name. Job name will be set to env. variable 
IXP_USERCOMMAND_JOB_NAME and IXP_USERCOMMAND_JOB_FULL_NAME.
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-i,--input <arg> - Custom user input. Input will be set into env. variable
 IXP_USERCOMMAND_INPUT

 

-s,--autoserv <arg> - CA WAAE (Autosys) instance to be used. If not specified 
the one from env. variable AUTOSERV is used.

 

-x,--version - Shows client version.

 

-h,–help - Shows this help.

 

Interactive Forecasting
A key function of iXp is the ability to perform interactive forecasting and simulations. Forecast reports can be generated
and simulations played back. All job run simulations are done by iXp and not actually run on CA Workload Automation AE.
Simulation is based on historical averages and resolution of job dependencies as defined within CA Workload Automation
AE. The results of a simulation can be viewed as steps-through-time and also can be saved in a report. Simulation also
provides the ability to perform "what-if" scenarios that could help during decision-making.

To perform interactive forecasting, follow these steps:

Go Offline

Interactive forecasting can be performed only during the Offline mode. The Offline mode provides a means to perform
filter and view customization without the cost of roundtrip server invocations. After customizing the iXp setup, you can
save your preferences and filters, and then go back Online with those preferences and filters. 

In the Offline mode, all filtration and navigation actions derive results from the in-memory snapshot, not from the
server. When Offline mode is started, all job dependencies and relevant attributes are loaded on the client, and job runs
and current statuses are not loaded or shown. As a result, all jobs are initially marked as INACTIVE. Job Control actions
such as job definition updates or sendevents are not possible.

Note: Although the job data is highly compressed during Offline mode, it could impact the client machine performance
because all that data is stored in memory on the client machine when a user decides to enter Offline mode. Therefore, iXp
allows users to enter Offline mode with data for a single CA Workload Automation AE instance only.

Follow these steps:

1. Select the File > Go Offline menu option to enter iXp Offline mode and enable Interactive Forecasting.
2. If iXp is monitoring more than one CA Workload Automation AE instance, select the instance on which the forecasting

is to be performed.
The offline mode copies all the data of the selected instance to the local machine. All forecasting and simulation
activities will be performed on that local snapshot.
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iXp presents jobs that match the current filter and also four new buttons that control interactive forecasting. 

Configure the Forecast Simulation

Before you start a simulation, set all parameters for the forecasting. After you set all the parameters, you can also create
or select the appropriate iXp filter. During the simulation, only jobs that match the filter will be shown in the views.

For example, to view all jobs that would run on a particular set of machines during a specific date and time, specify the
requested date and time in the forecast configuration. Then create or select a filter that has the "Run Machine" attribute
defined with the appropriate set of machines. As a result, only the jobs that would run on those machines are shown
during the simulation. However, iXp still performs a complete and comprehensive simulation of the selected CA Workload
Automation AE instance, but only show jobs that match the selected filter.

To customize a forecast simulation, click the Customize button and set required parameters in the Forecast Customization
window. Click OK to apply the changes and close the Forecast Configuration window.

You can customize the following parameters:

• Time Settings
Define the forecast time window. The following parameters can be set:
– Forecast Start Time

Specifies the year, month, day, hours and second for the forecast start time.
Default: current date and time

– Forecast Duration
Specifies the number of hours of forecast time.
Default: 4 hours

– Seconds Per Refresh
Specifies the number of simulated seconds per forecast window refresh (the "speed" of the forecast). 
Default: 60 seconds

• EP Latencies
Specify the forecast scheduling latencies, in milliseconds. The following table shows how EP latencies fields are
mapped to the EP latencies variables defined by iXP administrator:

EP Latencies Field Forecast Property Variable

Job Completion setDoneStatusTimeMillis

VM Stat vmstatTimeMillis

Remote Agent Connect StartJobTimeMillis

Set DB Status setStatusTimeMillis

X-Instance sendevent xinstanceSendeventTimeMillis

Set DB Starting Status setStartingTimeMillis

Read DB Event readEventTimeMillis

Set DB Running Status setRunningTimeMillis

For more information about EP latencies variables, see the section Set Up Forecast Properties.
• Log Files

Define log files where textual reports of the job forecast are stored. These files are stored on the local machine where
the simulation was performed. The following log files are created:
– Event Log

Specifies where to place the event log file (path and file name).
– Run Log
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Specifies where to place the run log file (path and file name).
– Log Filter

Specifies filter for data content of the log files. For more information about log filters, see the section Job Filters.
• Run Times

Specify parameters for specific job runs. Assigning new run times for a job overrides the average run time values for
the next forecasted run of the job. Set the following parameters:
– Job Name

Specifies the name of job to which new run time is to be assigned.
– Current Average Run Time

Specifies the average run time currently used by the forecaster.
– Assigned Run Time

Specifies the hours, minutes and seconds for a new run time. The resulting run time is combined with the Job Name
in the Run Time field.

– Run Time
This field combines the Assigned Run Time with the Job Name fields. This may also be edited directly. Select Add
to add the newly assigned time to the update list.

– Simulated Run Times
Displays a running list of all the run times to be added to the simulation. You still can delete run times from this list.
Click OK, to assign the job names and times listed in this field.

• End Statuses
Assigning a new End Status for a job overrides the current End Status, in the job forecast processing logic, for the
next forecasted runs of the job. If a job runs multiple times within your forecast window, each run will end in the status
specified.
– Job Name

Specifies the job name to which a new End Status is to be assigned in the simulation.
– Assigned End Status

Lists available End Statuses. Seletc the status currently to be assigned by the forecaster.
– End Status

This field combines the Job Name and Assigned End Status fields, select Add to add the newly assigned value to
the list.

– Simulated End Statuses
Displays a running list of all the End Statuses to be added to the simulation. You still can delete end statuses from
this list.
Click OK, to assign the job names and End Statuses listed in this field.

• Sendevents
Add new Future Sendevents for the next iXp forecast run. Specify the following parameters for sendevents:
– Time

Specifies the execution time of a simulated sendevent. To simulate a future Sendevent, set the time fields to
appropriate future execution date and time.

– Job Name
Specifies a Job Name to which a new Sendevent is to be assigned.

– Events
The event portion of the Sendevent JIL.

– Future Sendevent
This field combines the Time, Job Name, and Events fields to define a Future Sendevent. Select Add to add
this one to the Future Sendevents list. The JIL populated here is essentially the same as used in CA Workload
Automation AE (except for the use of ^InstanceName in the iXp syntax).

– Future Sendevents
Displays a running list of all the Future Sendevents to be added to the simulation. You still can delete future send
events from this list.
Click OK to assign the Sendevents listed in this field.
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Run the Forecast Simulation

Click the Play button to starts the forecast simulation sequences. To change job filters to view different jobs, click
the Pause button and set required filter criteria.
To restart a simulation with the same parameters, click the Rewind button.

Return to Online Mode

After you complete the forecasting simulation, you can return to Online mode. When you return to online mode, Interactive
Forecasting is disabled and job runs and current statuses from the CA Workload Automation AE instances are again
loaded and shown in iXp. To prevent the lost of the information gained from a simulation in Offline Mode, keep the log
files in saved file names.

The next time you switch to Offline mode, the Interactive Forecasting properties will be reset to the current job properties
and defaults, all job dependencies and relevant attributes will be loaded on the client, and job runs and current statuses
will not be loaded or shown.

To return to Online mode, Select the File > Go Online menu option.

View Forecast Run Data

Forecast jobs (jobs generated by the iXp Daemon rather than by CA Workload Automation AE) appear in the Run
Data table with a job index number listed as SIMULATED. The following image shows a list of forecast jobs: 

Errors and Warnings
The iXp client provides various indications to the user about problems that iXp may be experiencing. These indications are
provided via the means of messages, warnings or certain behavior.

Contents:

iXp Client Shows “Expired Signed JAR” Alert

iXp uses encrypted JAR files for the iXp GUI and iXp Admin Tool. These JAR files have an expiration date. When the
number of days before the expiration date is less than 180, an alert is displayed in a popup window to all users who logs
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in to the iXp GUI or iXp Admin Tool. The alert is also logged in the iXp server log file. For more information, see Signed
JAR Expiration Notices.

Examples:

“WARNING - Signed jars will expire in 90 days! Please contact your iXp Admin.”

“Alert – iXp signed jars are expiring in 90 days.
Do you want to disable the system-side certificate-expiration alert for all users? “

Warning for Old Data

The iXp Daemon continuously reads data from the CA Workload Automation AE databases. The daemon also
incorporates the acquired data in the iXp cache that is read by the iXp clients. If the iXp Daemon is unable to read data
from a CA Workload Automation AE instance, then it will not update the cache. To alert the user of such a condition, the
iXp client will update the Instance monitor to indicate that the Instance is not refreshing. The Instance monitor is shown
in the lower left corner of the client. Also, if the cache has not been updated in five minutes, the iXp client will get an error
dialog message indicating the condition.

No Activity Warning

The iXp administrator has the ability to set a time out for inactive GUIs. If there is no activity in the GUI for the given
number of minutes, a notification dialog will appear:
Clicking the OK button will return the iXp Client to normal refresh behavior.

iXp Client is "Out Of Memory"

The Java environment for the iXp client is configured with Java Runtime Parameters. These parameters define how much
memory can be used by the Java Environment on the client. If the iXp client's Java environment requires slightly more
memory than that defined by the parameters, the Java environment will issue an "Out Of Memory" message and exit. This
message is shown in the Java Console or the Java application viewer command console if the iXp client was started from
a web browser or the application viewer respectively. If the iXp client was started through Java Web Start, the message
will be shown in the Java console. There may be no visual indication on the iXp client indicating that it is "Out Of Memory".
Users may notice the iXp client going through data refreshes without updating the view or the data timestamp on the
lower-left corner or may notice that the iXp client is not responding.

To recover from this condition, reopen the iXp client and adjust the memory settings for the Java environment.

 

09-02 16.49.31:width=1200

09-02 16.49.31:height=700

09-02 16.49.31:http://titan:8082/ixp/

09-02 16.49.31:iXp-7.2.0.4

09-02 16.49.31:java.specification.version:1.5
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09-02 16.49.31:java.version:1.5.0_11

09-02 16.49.31:Temp Directory:C:\DOCUME~1\parag\LOCALS~1\Temp

09-02 16.49.31:MainApplet.start():0ms

09-02 16.49.31:init(1):31ms

#### Java Web Start Errror:

#### java.lang.OutOfMemoryError: Java heap space

iXp Client gets "EOF" Exceptions

Users may notice "EOF" exception errors when performing certain operations that require the iXp client to contact the iXp
server. Actions such as processing iXp reports, getting job definitions, issuing sendevents, responding to CA Workload
Automation AE Alarms, and so on. may result in this exception. Typically, this occurs due to a timeout parameter setting
between the iXp client and the server. The default value for this parameter is 60 (sixty) seconds. If the iXp client has
not received the results of its request within this time, it will throw this exception message to the user. The iXp client will
not stop functioning due to this exception. Also, this exception does not indicate the result of the action requested. For
example, the user clicks a few alarms and tries to Acknowledge them. After the timeout interval, the iXp client throws
the exception and continues with its refresh cycle. Meanwhile, the iXp Requestor finally updates the alarms in the CA
Workload Automation AE database, but it cannot tell the user that requested the update about the completion of its work.
However, the iXp client would receive the new data as a part of its refresh.

If the iXp Daemon has crashed, the iXp client will timeout for every refresh and throw the EOF exception message in the
Java Console or the application viewer command window. For users that open iXp from a web browser, the Java Console
is an extremely important window, as the majority of error messages would go in there. We recommend that you configure
the Java environment, so that this console is opened every time.

How to Migrate Workload
As a CA Workload Automation AE scheduler, you want to migrate workload objects from an older Unicenter AutoSys JM
release instance to a newer release instance. For example, you set up an instance of CA Workload Automation AE r11.3
or higher and you want to move your workload objects from the existing Unicenter AutoSys JM 4.5.1 instance over to it.
While traditional Unicenter AutoSys JM 4.5.1 migration utilities such as datamover let you migrate workload objects, the
migration assistant offers you the following capabilities that other utilities do not:

• If authorized, you can migrate the workload objects yourself instead of relying on an administrator to do it for you.
• You can define, visualize, and migrate subsets of workload objects easily to ensure that you migrate only the data you

want.
• You can create a migration package for future migration.

Note: To migrate workload objects from an older Unicenter AutoSys JM release instance to a newer release instance, you
can also use CA Workload Automation AutoSys Upgrade Assistant (AUA).

This scenario shows the full process of workload object migration by stepping you through creating and migrating a
package. Skip any steps of the process that do not apply to you.

To migrate workload objects from a Unicenter AutoSys JM 4.5.1 instance to a CA Workload Automation AE r11.3 or higher
instance, follow these steps:
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Review the Prerequisites

Verify that the following prerequisites are met before you migrate a set of workload objects in Workload Automation iXp:

• You are authorized to access the iXp user interface client and logged in.
• You have the security privileges to create migration packages, migrate the package, or both.

Note: The Migrate tab is displayed on the iXp menu bar only when you have security privileges to create or migrate
packages.

• You are familiar with transitive closures, exclusions, and conversion scripts.
Note: For more information about transitive closure, see the section Job Dependency Filters Definitions.

• You are familiar with iXp filters, and you know how to create a filter to view the desired set of jobs.

Preparing the Migration Package

A migration package contains the set of workload objects that include jobs and their related global variables and
calendars.

If you are authorized, you can prepare a package for migration using either of the following methods.

Create a Migration Package

To migrate a package with a set of workload objects, create a migration package based on filters. The filter can only
include jobs from a single Unicenter AutoSys JM 4.5.1 instance.

Note: You must be authorized to view the details of the jobs that are shown in the filter and any dependent jobs included
by transitive closure. You must have authorization to read the calendars and global variables that are associated with the
jobs included in the migration package.

Follow these steps:

1. Log in to the iXp user interface client.
2. Select an existing filter from the Filter drop-down list.

Notes:
– You can also select an existing filter by clicking View, Personal filter, or Group filter. The Personal filter option shows

only the filters that you have created. The Group filter option shows only the filters that are created and shared only
by your group.

– If the existing filters do not include the jobs that you want to migrate, create a new filter to show only the jobs that
you want.

A list of filtered jobs is displayed.
3. Click Migrate, Edit Migrations.
4. Click Create.

The Create Job Stream Migration dialog opens with the selected job filter in the Job Stream Name field.
Note: The job stream name, or package name, must not match any previously created package names. If you select
an existing name, an error message is displayed.

5. Select the CA Workload Automation AE instance to which you plan to migrate the package from the Target
AUTOSERV drop-down list.

6. (Optional) Enter a description for the package.
7. (Optional) Clear one or more of the following check boxes if you do not want to apply them to this migration package:

– Apply Transitive Closure
Applies the transitive closure to the package. The transitive closure lets the migration assistant build a closed set of
jobs that run together without breaking job flows.
Note: The transitive closure lets migration assistant amend your jobs in the package and include the dependent
jobs that are not included in the active filter. Thus, a closed set of jobs is built.

– Apply Exclusions
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Applies the exclusion rule set to the package. The exclusion rule set excludes jobs from the migration package
based on job status, machines, and other attributes that your administrator has specified.
Note: By default, the migration assistant automatically applies the rule set every time a package is created or
opened.

– Apply Conversion Scripts
Applies predefined conversion scripts to the package. The conversion scripts parse and modify the workload object
files to meet the syntax requirements of the target instance and the internal corporate standards.
Note: For more information about exclusions and conversion scripts, see the section How to Manage Workload
Migration.

8. Click OK to retrieve and include the filtered set of workload objects in the package.
9. Click Next.

The Migrate Job Stream dialog displays the list of jobs that are included in the package. Jobs that meet the exclusion
rule set are marked as excluded.

The package is loaded with workload objects and the internal list of workload objects is built. Next, you should verify that
all of the workload objects you want to migrate are included in the package.

Select an Existing Package

An existing package can be migrated if you want to do either of the following:

• Migrate workload objects you packaged previously.
• Rebuild an existing package with JIL definitions that have been modified since you created the package.

You can edit the package before migration.

Follow these steps:

1. Log in to the iXp user interface client.
2. Click Migrate, Edit Migrations.

The Migrate Job Stream dialog is displayed.
3. Click Edit.

The Select Migration dialog displays with a list of migration packages.
Note: A checkmark in the list indicates that the migration package has been loaded into the target instance.

4. Select the migration package, and click OK.
The migration assistant automatically checks the added, deleted, or modified jobs or job dependencies that affect the
closed set of jobs. The package is loaded with workload objects and the internal list of workload objects is built.
The Migrate Job Stream dialog displays the set of workload objects included in the package.
Note: If the list of jobs or their dependencies have changed, the migration assistant suggests that you rebuild the
package by clicking Rebuild. When you rebuild the package, the migration assistant deletes and creates a set of files.
This process rebuilds the references to related global variables, calendars, machines, and owners and updates the
dependent object files with current definitions.

The package is loaded with workload objects and the internal list of workload objects is built. Next, you should verify that
all of the workload objects you want to migrate are included in the package.

Verify that the Appropriate Workload Objects are Included in the Package

The migration assistant applies the default exclusion rule to exclude particular jobs from the package that you have
created or selected. The migration assistant also applies transitive closure, if enabled, to find all the dependent jobs.

You can manually include or exclude jobs from the list of jobs that are shown in the Migrate Job Stream dialog. Before the
migration starts, verify that all the workload objects you want to migrate have been included in the package.

Note: If you have selected a predefined package to migrate, you cannot change the list of excluded jobs. If you add new
jobs to the predefined package, you can manually exclude only those additional jobs.
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Follow these steps:

1. Click the Search icon on the Migrate Job Stream dialog.
The Hide Selected Jobs dialog is displayed with the default exclusion rule set. You can view the rules to exclude jobs
based on status, machine, and so on, by clicking the Status, Machines, Owner, and Miscellaneous tabs respectively.

2. (Optional) Do one of the following actions after you close the Hide Selected Jobs dialog:
– Clear the Included check box against the Level-Zero job that you want to exclude from the package.
– Select the Included checkbox against the Level-Zero job that you want to include in the package.

3. Click Next.
The migration assistant processes the included jobs, and prepares the list of workload objects to be included in the
package.
Note: The transitive closure, if enabled, lets migration assistant amend your jobs in the package and include the
dependent jobs that are not included in the active filter. Thus, a closed set of jobs is built.

4. Verify the list of workload objects by performing the following actions in the Migrate Job Stream dialog:
a. Click the Jobs tab to verify the set of jobs to be loaded in the package.
b. Click the Calendars tab to verify the set of calendars to be loaded in the package.
c. Click the Globals tab to verify the global variables to be loaded in the package.
d. (Optional) Click the relevant Edit File icon next to the object count in the Pre-conversion Summary section to view

the JIL file, the calendar definition file, and the global variable script.
Note: The JIL file, calendar definition file, and the global variable script are used to create jobs, calendars, and
global variables. The migration assistant parses the JIL file and builds a list of calendars and global variables that
are referenced by the job attributes in that file.

e. Click the Machines tab to verify the list of machines that are referenced by jobs defined in the JIL file.
f. Click the Owners tab to see the list of job owners for the jobs included in the migration package.
g. Click the Profiles tab to see the list of profile names that are referenced by any Windows-based jobs included in the

migration package.
NOTES:
– If the jobs use credentials that are stored in the Unicenter AutoSys JM 4.5.1 database, they are displayed in the

Owners tab.
– The machine, owner, and profile lists are only for a reference. The migration assistant does not create them in the

target instance.

You are now ready to run the conversion scripts against the object files to validate their syntax and finalize them for the
migration.

Validate the Integrity of the Workload Objects in the Package

You can automatically run the predefined conversion scripts and syntax checker on the workload objects after you verify
the contents of the package to migrate. This validation ensures that the workload objects are migrated more easily and
with fewer errors.

The conversion scripts can be set up to change the definitions of the workload objects before migration. The syntax
checker verifies that the object files meet the syntax requirements of the target instance. You can view the list of objects
after the conversion scripts have processed their respective definition files.

Follow these steps:

1. Click Next from the workload object verification page of the Migrate Job Stream dialog after you verify that the package
contents are correct.
The migration assistant loads the workload objects in the package, runs the conversion scripts against the object files,
and prepares them for the migration. The Migrate Job Stream dialog displays the converted files.

2. Re-verify the converted files of workload objects that are loaded in the package after the scripts ran, as changes to
these objects may have taken place. To do so, use the following available methods:
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– The Pre-conversion Summary section displays the number of jobs, calendars, global variables, machines, owners,
and profiles by parsing the definition files. The definition files are created after the conversion scripts ran.

– The Jobs, Calendars, and Global variables tabs show the objects that exist on the target instance and the objects
that are ready for migration.

– The Machines and Owners tabs list the required objects and the objects that have not yet been defined on the
target instance.

WARNING
If any machines have not been defined on the target instance, you cannot proceed with migration. Contact
the CA Workload Automation AE administrator to resolve these errors.

3. Click Next.
The migration assistant performs a syntax check on the JIL file and displays the job stream migration panel.

4. (Optional) Perform the following actions as appropriate if your syntax check fails:
a. Click View Details to view the errors.
b. Click Previous to go back to the previous panel and click the Edit File icon next to the job count.
c. Verify the JIL files again and modify them, if required.

Notes:
• You can run the syntax checker multiple times to make the required modifications until you have no syntax

errors remaining.
• You can close the migration assistant at any time. Before you close the migration assistant, ensure that you

have saved all the modifications.
d. Click Next to go to the panel to migrate the package.
Note: Alternatively, click the Edit File icon next to the job count in the conversion summary section to run the syntax
check manually, as follows:
a. Click the Check Syntax toolbar icon to run the syntax checker. The JIL file includes the results of the syntax check

and the messages that are generated by the syntax checker as comments.
b. Click View Results of syntax check to view the entire output in a separate dialog.
c. Type a string in the Find option to find the syntax errors and warnings. You can type the search strings

CAUAJM_W for warnings and CAUAJM_E for errors.

You are now ready to migrate the package.

Migrate the Package

You can migrate a package after the migration assistant validates that the workload object files meet the syntax
requirements of the target instance.

To complete the package migration, click Migrate Now.

If the migration is successful, the migration assistant prompts you to bring the migrated jobs into the tree view in the main
iXp client window.

Notes:

• If you decide to migrate the package at a future time, click Exit and your package is saved.
• If the migration panel displays only Exit, you do not have authorization to migrate the package. Click Exit, and your

package is saved. Contact your CA Workload Automation AE administrator to migrate the package for you.

If an error is encountered during the migration, the migration assistant deletes the workload objects that were created prior
to the step where the error is encountered. The migration is then stopped and rolled back automatically to let you resolve
errors and missing objects before proceeding.

WARNING

Important! If an error is encountered during the migration and the migration is not automatically rolled back due
to network and system issues, the migration assistant indicates that the rollback is not working. Contact your
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CA Workload Automation AE administrator to perform the rollback manually by using the relevant files in the
following directory on the iXp server:

$IXP_HOME/dat/migrate/<package_name>/rollback

You have successfully migrated the workload objects that you want from the source Unicenter AutoSys JM instance to the
target CA Workload Automation AE instance.
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Additional Resources
Additional resources for Workload Automation iXp include:

• Product page
• Product Support
• Education
• CA Workload Automation Community
• Twitter
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Documentation Legal Notice
This Documentation, which includes embedded help systems and electronically distributed materials, (hereinafter referred
to as the “Documentation”) is for your informational purposes only and is subject to change or withdrawal by Broadcom
at any time. This Documentation is proprietary information of Broadcom and may not be copied, transferred, reproduced,
disclosed, modified or duplicated, in whole or in part, without the prior written consent of Broadcom.

If you are a licensed user of the software product(s) addressed in the Documentation, you may print or otherwise make
available a reasonable number of copies of the Documentation for internal use by you and your employees in connection
with that software, provided that all Broadcom copyright notices and legends are affixed to each reproduced copy.

The right to print or otherwise make available copies of the Documentation is limited to the period during which the
applicable license for such software remains in full force and effect. Should the license terminate for any reason, it is your
responsibility to certify in writing to Broadcom that all copies and partial copies of the Documentation have been returned
to Broadcom or destroyed.

TO THE EXTENT PERMITTED BY APPLICABLE LAW, CA PROVIDES THIS DOCUMENTATION “AS IS”
WITHOUT WARRANTY OF ANY KIND, INCLUDING WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. IN NO EVENT WILL
CA BE LIABLE TO YOU OR ANY THIRD PARTY FOR ANY LOSS OR DAMAGE, DIRECT OR INDIRECT, FROM
THE USE OF THIS DOCUMENTATION, INCLUDING WITHOUT LIMITATION, LOST PROFITS, LOST INVESTMENT,
BUSINESS INTERRUPTION, GOODWILL, OR LOST DATA, EVEN IF CA IS EXPRESSLY ADVISED IN ADVANCE OF
THE POSSIBILITY OF SUCH LOSS OR DAMAGE.

The use of any software product referenced in the Documentation is governed by the applicable license agreement and
such license agreement is not modified in any way by the terms of this notice.

The manufacturer of this Documentation is Broadcom Inc.

Provided with “Restricted Rights.” Use, duplication or disclosure by the United States Government is subject to the
restrictions set forth in FAR Sections 12.212, 52.227-14, and 52.227-19(c)(1) - (2) and DFARS Section 252.227-7014(b)
(3), as applicable, or their successors.

Copyright © Broadcom. All Rights Reserved. The term “Broadcom” refers to Broadcom Inc. and/or its subsidiaries. All
trademarks, trade names, service marks, and logos referenced herein belong to their respective companies.
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