Änderungsauswirkungen und Aktualisierungen

ccppmop1581
HID_HID_release_info_change_impact_od
Auf dieser Seite
Änderungsauswirkungen und Aktualisierungen
werden wichtige Änderungen, erforderliche Aktionen, bekannte Probleme und empfohlene Optionen für Kunden beschrieben, die ein Upgrade der früheren Version auf
Clarity
15.8.1 durchführen. Planen Sie das
Clarity
-Upgrade, und legen Sie die Optionen fest, die den Anforderungen Ihres Unternehmens entsprechen. Teams können diese Informationen auch verwenden, um die Einführung Ihrer neuen Funktion, das Onboarding und den Aufwand für Schulungen zu planen.
Sie führen z. B. ein Upgrade von
Clarity
Version 15.3 auf 15.8 durch. Überprüfen Sie vor und nach dem Upgrade die Änderungen in den Versionen 15.4, 15.4.1, 15.5, 15.5.1, 15.6, 15.6.1, 15.7 und 15.7.1. Um auf die Seite
Änderungsauswirkungen und Aktualisierungen
der einzelnen Versionen zu wechseln, klicken Sie oben auf dieser Seite auf das Menü
Versionen
. Überprüfen Sie häufiger, ob aktualisierte Inhalte vorhanden sind, besonders dann, wenn Sie eine PDF-Datei heruntergeladen haben. Die englische Version dieser Dokumentation wird regelmäßig mit neuen Informationen aktualisiert, wie z. B. neue Beispiele, Erläuterungen, Korrekturen und Patch-Informationen.
Um ein Upgrade auf
Clarity
15.8.1 vorzubereiten, überprüfen Sie die unterstützten Upgrade-Pfade, Funktionen, Verbesserungen und die erforderlichen Upgrade-Aktionen. Die folgenden Informationen fassen zusammen, wie die neuen Änderungen, die in dieser Version eingeführt wurden, das Upgrade beeinflussen.
Clarity
SaaS unterstützt jetzt Jaspersoft 7.1.3 auf der Google Cloud Platform
Für
Clarity
SaaS-Kunden auf der GCP wird in Kürze ein Upgrade auf Jaspersoft 7.1.3 durchgeführt. Kunden können Jaspersoft Studio 7.1 und die vorhandenen Adapter für Studio- und Arbeitsanweisungslösungen weiterhin verwenden. Weitere Informationen finden Sie unter Install Jaspersoft Studio Professional 7.1 and CA JDBC Adapter.
Nur
Clarity
GCP SaaS-Kunden
Die in PostgreSQL migrierten Domänen zeigen Fehlermeldungen an, wenn sie im Domänen-Designer angezeigt oder bearbeitet werden. Lesen Sie sich diesen KB-Artikel durch, um dieses Problem zu lösen.
Sie können sich auch diesen KB-Artikel zu Verbindungsfehlern zwischen Jaspersoft Studio und dem Jaspersoft-Server durchlesen.
Clarity
wird in Kürze den Support für Jaspersoft 7.1.3 für On-Premise-Kunden bekanntgeben.
Ab
Clarity
15.7 – OracleJDK wird durch AdoptOpenJDK ersetzt
Java-Image
Clarity
wird Produktaktualisierungen im Zusammenhang mit Oracle Java ab dem
19. August 2019
einstellen. Dadurch kann sich unser Entwicklungsteam auf die Wertschöpfung künftiger Produktveröffentlichungen konzentrieren. CA Technologies, ein Broadcom-Unternehmen (CA), unterstützt weiterhin seine Produkte und hält sich an die in den Lizenzvereinbarungen zwischen CA Technologies und seinen Kunden festgelegten Nutzungsbedingungen.
Vorhandene Kunden können weiterhin Versionen ausführen und verwenden, die Oracle-Java-Komponenten in Produktions- und Nicht-Produktionsumgebungen enthalten
. Um jedoch zukünftige Java-Sicherheits- und Schwachstellenprobleme zu lösen, müssen Kunden möglicherweise ein Service Pack installieren oder ein Upgrade auf eine neuere Version von
Clarity
durchführen, die AdoptOpenJDK unterstützt. Diese Änderung hat keine Auswirkungen auf die Jaspersoft-Version, die weiterhin Java 8 unterstützt.
2
Clarity
PPM ist jetzt
Clarity
Clarity
PPM wurde in
Clarity
umbenannt. Sie können das neue
Clarity
-Logo im Anmeldefenster und in "Neue Benutzererfahrung" sehen. Die Dokumentation wurde aktualisiert, um die neue Marke widerzuspiegeln.
Clarity
bezieht sich auf "Neue Benutzererfahrung", und
Classic PPM
bezieht sich auf
Classic PPM
Studio.
Clarity
Upgrade-Aktion
: Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, wird das neue
Clarity
-Logo angezeigt.
Im folgenden Video werden die Verbesserungen beschrieben, die in dieser Version am Clarity-Logo vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Benutzerdefinierte Hauptobjekte, Unterobjekte und benutzerdefinierte virtuelle Attribute sind in
Clarity
verfügbar
Sie können API jetzt für benutzerdefinierte Haupt- und Unterobjekte in
Classic PPM
aktivieren, damit sie in
Clarity
verfügbar sind. Stellen wir uns ein Szenario vor, in dem Sie den gesamten Lebenszyklus eines Produkts mit
Clarity
verwalten. Jetzt möchten Sie den Net Promoter Score (NPS) für alle Ihre Produkte erfassen und diese Daten in
Clarity
speichern. Außerdem möchten Sie Kunden bestimmte Fragen zu den Support- und Dienstprozessen stellen. Sie möchten diese Daten jedoch getrennt von den NPS-Bewertungen speichern. Sie können ein benutzerdefiniertes Hauptobjekt namens "NPS" in
Classic PPM
erstellen und API für das Objekt aktivieren, damit es in
Clarity
verfügbar ist. Sie können dann zwei Unterobjekte namens "Dienste" und "Support" erstellen und API für diese Unterobjekte aktivieren. Anschließend können Sie
Clarity
verwenden, um Ihre NPS-Daten und die zugehörigen Umfragedetails zu Diensten und Support zu speichern.
Aktivieren von API für benutzerdefinierte Haupt- und Unterobjekte in Clarity
Sie können auch XOG verwenden, um API für standardmäßige und benutzerdefinierte virtuelle Attribute in
Classic PPM
zu aktivieren. Benutzerdefinierte virtuelle Attribute werden nur für Unterobjekte definiert. Ein virtuelles Attribut ist ein schreibgeschütztes Attribut des Unterobjekts, das mit einem bestimmten Attribut des Hauptobjekts verknüpft ist.
Sie können
Classic PPM
nicht verwenden, um API für standardmäßige und benutzerdefinierte virtuelle Attribute zu aktivieren.
Upgrade-Aktion
: Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie API für vorhandene benutzerdefinierte Haupt- und Unterobjekte aktivieren. Sie können diese dann in
Clarity
verwenden. Sie können auch XOG verwenden, um API für standardmäßige und benutzerdefinierte virtuelle Attribute zu aktivieren.
Im folgenden Video werden die Verbesserungen beschrieben, die in dieser Version an benutzerdefinierten Haupt- und Unterobjekten vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Verbesserungen für das Finanzmanagement
Sie können Leistungspläne in Projekten, benutzerdefinierten Investitionen und Ideen erstellen, indem Sie das Modul "Finanzen" verwenden. Anschließend können Sie Ihre Kostenpläne mit Leistungsplänen verbinden, um die Leistung Ihrer Investitionen oder des Kapitalwerts für eine Investition zu schätzen.
Erstellen von Leistungsplänen in Investitionsobjekten mithilfe des Moduls "Finanzen" in Clarity
Während ein Leistungsplan mit einer unbegrenzten Zahl von Kostenplänen verbunden werden kann, kann ein Kostenplan nur mit einem Leistungsplan verbunden werden. Sie können das Modul "Finanzen" verwenden, um neue Leistungspläne zu erstellen oder vorhandene Pläne zu aktualisieren. Beachten Sie, dass Sie keine Leistungspläne löschen können, die mit einem Kostenplan verbunden sind.
Beachten Sie außerdem, dass gespeicherte Ansichten über die Finanzmodule verschiedener Investitionstypen hinweg gemeinsam genutzt werden. Wenn Sie beispielsweise im Raster "Leistungsplan" eine Ansicht für eine benutzerdefinierte Investition speichern, ist die gleiche Ansicht im Raster "Leistungsplan" für Ideen und Projekte verfügbar.
Upgrade-Aktion
: Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie vorhandene Leistungspläne, die in
Classic PPM
verfügbar waren, in
Clarity
verknüpfen. Sie können neue Leistungspläne auch direkt in
Clarity
erstellen.
In den folgenden Videos werden die Verbesserungen beschrieben, die am Modul "Finanzen" in Projekten, benutzerdefinierten Investitionen und Ideen vorgenommen wurden.


Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier und hier, um sich die Videos auf YouTube anzusehen.
Allgemeine Suchkomponente
Sie können die Suchleiste verwenden, die in den Pinnwand-, Raster- und Zeitskala-Layouts verfügbar ist, um Werte anhand des Namens oder der ID zu filtern. Beispiel: Sie möchten eine bestimmte Aufgabe in einer Investition suchen. Sie können in der Suchleiste einfach die ersten Buchstaben des Namens eingeben, um die Aufgabe zu finden und zu bearbeiten.
Allgemeine Suchkomponente in Clarity
Die Suchwerte werden nicht beibehalten, wenn Sie eine Ansicht speichern. Wenn Sie den Arbeitsbereich verlassen und später zurückkehren, werden die Eingaben aus der Suchleiste gelöscht.
Sie können die Suchleiste neben dem herkömmlichen Filter verwenden, der in
Clarity
verfügbar ist. Beispiel: Sie verwenden den Filter, um alle Aufgaben zu identifizieren, die noch nicht gestartet wurden. Anschließend verwenden Sie die Suchleiste, um nach einer bestimmten Aufgabe zu suchen.
Clarity
zeigt nur Ergebnisse an, die den Kriterien des Filters und der Suchleiste entsprechen.
In Roadmaps, dem Modul "Mitarbeiter" und dem Modul "Zuweisungen" steht die Suchleiste nicht zur Verfügung.
Weitere Informationen finden Sie unter Standardkomponenten.
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, wird die neue Suchleiste über den Pinnwand-, Raster- und Zeitskala-Layouts angezeigt.
Verbesserung der benutzerdefinierten Dropdown-Liste
Ab
Clarity
15.8.1 enthält die Dropdown-Suchoptionsliste "Statischer Wert" eine Suchoption, mit der Sie schnell nach dem Attribut suchen können, anstatt durch die gesamte Liste zu scrollen. Wenn der Name des Attributs zu lang ist, wird der Name in
Clarity
mit Ellipsen angezeigt. Die Suchfunktion funktioniert überall dort, wo die Suchoptionsliste "Statischer Wert" angewendet wird.
Durchsuchbare Dropdown-Liste
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, wird die Suchleiste in Suchoptionslisten für statische Werte angezeigt.
Längere Hyperlinks beim Export in Excel (
Classic PPM
)
Die Funktion "In Excel exportieren" wurde in
Classic PPM
verbessert, um Verknüpfungen mit bis zu 2085 Zeichen zu unterstützen. In früheren Versionen wurde ein Hyperlink aus der Microsoft Excel-Datei entfernt, wenn Sie die Funktion "In Excel exportieren" verwendet haben und die URL länger als 255 Zeichen war. Ab
Clarity
15.8.1 wurde das Limit für die URL-Länge von 255 auf 2085 Zeichen erhöht.
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen und die Funktion "In Excel exportieren" verwenden, werden die entsprechenden Verknüpfungen in der Microsoft Excel-Datei angezeigt.
Im folgenden Video werden die verschiedenen Verbesserungen beschrieben, die in dieser Version an der Benutzeroberfläche vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Sicherheit auf Feldebene wird für benutzerdefinierte Investitionen unterstützt
Die Sicherheit auf Feldebene ist jetzt für benutzerdefinierte Investitionen verfügbar. Beispiel: Sid ist ein Portfoliomanager und für die Erstellung, Bearbeitung und Verwaltung von benutzerdefinierten Investitionselementen für seine Organisation verantwortlich. Sid erstellt eine benutzerdefinierte Investition, um die Strategie seiner Organisation zu definieren. Er sichert das Attribut "Geschätzter Budgetplan" und gewährt den relevanten Stakeholdern Bearbeitungsrechte. Die Stakeholder können den geschätzten Budgetplan für relevante Strategien jetzt überprüfen und aktualisieren.
Sicherheit auf Feldebene
Nachdem die Strategie fertiggestellt wurde, teilt Sid die Strategie mit den Teams. Alle Ressourcen im Team können das Attribut "Geschätzter Budgetplan" anzeigen.
Weitere Informationen finden Sie unter Sichern des Zugriffs auf Feldebene.
Upgrade-Aktion
: Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie die Sicherheit auf Feldebene verwenden, um Attribute zu sichern, die mit benutzerdefinierten Investitionen verbunden sind.
Im folgenden Video werden die verschiedenen Verbesserungen beschrieben, die in dieser Version an der Sicherheit auf Feldebene vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Anpassen des Logos für die Kopfzeile und des Anmeldelogos
Sie können jetzt das Logo für die Kopfzeile und das Anmeldelogo anpassen, damit
Clarity
das Branding Ihrer Organisation widerspiegelt. Sie können es auch verwenden, um zwischen verschiedenen Umgebungen wie Entwicklung, Qualitätssicherung und Produktion zu unterscheiden. Weitere Informationen finden Sie unter Clarity: Systemeinstellungen.
Sie benötigen Administratorberechtigungen, um die Logos zu aktualisieren.
Clarity
Upgrade-Aktion
: Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie den Abschnitt "Systemeinstellungen" in
Clarity
verwenden, um die Anwendung anzupassen, damit sie das Branding Ihrer Organisation widerspiegelt.
Im folgenden Video werden die verschiedenen Verbesserungen beschrieben, die in dieser Version an der Benutzeroberfläche vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Konfigurieren von
Clarity
zur Unterstützung von SAML 2.0 (nur On-Premise)
Mit
Clarity
15.8.1 und höheren Versionen können On-Premise-Kunden Anmeldeinformationen verwenden, die von einem IDP bereitgestellt wurden, der SAML 2.0 unterstützt, und sich bei
Clarity
anmelden. Eine SAML-basierte Einzelanmeldung bietet folgende Vorteile:
  • Nahtlose Integration von Netzwerken und Umgebungen: Alle Benutzer können problemlos zwischen dem Intranet Ihrer Organisation und
    Clarity
    wechseln.
  • Vereinfachte Kennwortverwaltung: Benutzerkennwörter müssen nicht getrennt von
    Clarity
    verwaltet werden, da sie über Ihr vorhandenes Benutzerverwaltungssystem verwaltet werden.
Weitere Informationen finden Sie unter Konfigurieren von Clarity zur Unterstützung von SAML 2.0.
Hinzufügen von Mitarbeitern zu Investitionen mithilfe des Rasters für Mehrfachauswahl
Sie können die neue Schaltfläche "Mitarbeiter hinzufügen" verwenden, um Ressourcen, Rollen und Teams zu einer Investition in
Clarity
hinzuzufügen. Nachdem Sie auf die Schaltfläche "Mitarbeiter hinzufügen" geklickt haben, können Sie auswählen, ob Sie Ressourcen, Rollen oder Teams hinzufügen möchten. Wenn Sie "Ressourcen" auswählen, lädt
Clarity
eine Liste aller verfügbaren Ressourcen in einem allgemeinen Raster für Mehrfachauswahl. Sie können mit der Such- und Filteroption die relevanten Ressourcen schnell identifizieren und zur Investition hinzufügen.
Hinzufügen von Mitarbeitern zu Investitionen mithilfe des Rasters für Mehrfachauswahl in Clarity
Weitere Informationen finden Sie unter Clarity: Zusammenstellen eines Projektteams.
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie die neue Schaltfläche "Mitarbeiter hinzufügen" verwenden, um Ressourcen, Rollen und Teams zu Ihren Investitionen hinzuzufügen.
Im folgenden Video werden die verschiedenen Verbesserungen beschrieben, die in dieser Version am Personaleinsatz vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Anzeigen des Arbeitsaufwands in Tagen
Sie können
Clarity
jetzt so konfigurieren, dass der Arbeitsaufwand in Tagen angezeigt wird. In früheren Versionen
Clarity
von konnten Sie den Arbeitsaufwand nur in VZÄ oder Stunden anzeigen. Sie können jetzt die allgemeinen Einstellungen verwenden, um den Arbeitsaufwand so zu konfigurieren, dass er in Tagen angezeigt wird. Dies ist im Modul "Mitarbeiter" oder im Modul "Zuweisung" bei Projekten und benutzerdefinierten Investitionen in
Clarity
äußerst hilfreich. Diese Einstellung wirkt sich nicht auf die folgenden Bereiche aus:
  • Arbeitsbereich "Personaleinsatz"
  • Zeitformulare
  • Finanzen
  • Roadmaps
Anzeigen des Arbeitsaufwands in Clarity in Tagen
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie
Clarity
so konfigurieren, dass der Arbeitsaufwand in Tagen angezeigt wird.
Warnmeldung aus dem Arbeitsbereich "Personaleinsatz" entfernt (bei aktivierten gemischten Buchungen)
Ab
Clarity
15.8.1 wird im Arbeitsbereich "Personaleinsatz" keine Warnmeldung mehr angezeigt, dass die Seite im schreibgeschützten Modus verfügbar ist, da gemischte Buchungen aktiviert ist. Der Arbeitsbereich "Personaleinsatz" ist weiterhin im schreibgeschützten Modus, wenn Sie gemischte Buchungen aktiviert haben.
Clarity
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, wird keine Warnmeldung angezeigt, wenn Sie auf den Arbeitsbereich "Mitarbeiter" zugreifen. Dies gilt, wenn Sie gemischte Buchungen in
Classic PPM
aktiviert haben.
Arbeitsbereich "Personaleinsatz" unterstützt jetzt benutzerdefinierte Investitionen
Sie können den Arbeitsbereich "Personaleinsatz" verwenden, um Rollenzuordnungen und Personaleinsatz für benutzerdefinierte Investitionen zu planen und Ressourcen anzufordern. In früheren Versionen von
Clarity
konnten Sie den Arbeitsbereich "Personaleinsatz" nur für Projekte und Ideen verwenden.
Arbeitsbereich "Personaleinsatz" unterstützt jetzt benutzerdefinierte Investitionen in Clarity
Upgrade-Aktion
: Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie den Arbeitsbereich "Personaleinsatz" verwenden, um benutzerdefinierten Investitionen Mitarbeiter zuzuweisen. Dies wurde in früheren Versionen von
Clarity
nicht unterstützt.
Im folgenden Video werden die verschiedenen Verbesserungen beschrieben, die in dieser Version am Personaleinsatz vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Verbesserte Importfunktion in Roadmaps
Die Option "Importieren aus
Clarity
" zeigt jetzt das entsprechende Raster mit Auswahl-Kontrollkästchen an. Bis Version
Clarity
15.8 konnten Sie mit der Importoption nach bestimmten Investitionsobjekten suchen. Ab
Clarity
15.8.1 können Sie Projekte, Ideen oder benutzerdefinierte Investitionselemente aus dem jeweiligen Raster auswählen. Im Auswahlraster können Sie einzelne Zeilenelemente auswählen. Sie können auch alle Zeilen auswählen oder die Auswahl aufheben.
Arbeitsbereich "Personaleinsatz" unterstützt jetzt benutzerdefinierte Investitionen in Clarity
Weitere Informationen finden Sie unter Clarity: Top-Down-Planung mit Roadmaps.
Upgrade-Aktion
: Keine Auswirkungen. Wenn Sie ein Upgrade auf
Clarity
15.8.1 durchführen, können Sie die verbesserte Importfunktion verwenden, um Investitionen in Roadmaps zu importieren.
Im folgenden Video werden die verschiedenen Verbesserungen beschrieben, die in dieser Version an Roadmaps vorgenommen wurden.

Dieses Video ist nicht verfügbar, wenn Sie die Dokumentation im PDF-Format herunterladen. Klicken Sie hier, um sich das Video auf YouTube anzusehen.
Internet Explorer 11 wird für
Clarity
-Funktionen nicht unterstützt
Classic PPM
unterstützt IE 11 weiterhin.
Clarity
kann die Abwärtskompatibilität mit alten Browsertechnologien (einschließlich IE 11) jedoch nicht verlängern.
Dies ist kein bekanntes Problem mit
Clarity
. Stattdessen ist es ein bekanntes Problem mit IE 11. Microsoft hat in den neuen Browser "Microsoft Edge" investiert.
Wenn Benutzer die Supportanforderungen ignorieren und versuchen, IE 11 mit
Clarity
zu verwenden, können folgende Probleme auftreten:
  • Fehlerhafte Funktionen oder Speicherverluste (ohne geplante Fixes von Microsoft)
  • Fehlender Browser-Framework-Support für neue REST-API-Funktionen
  • Schlechtes Erscheinungsbild oder langsame Leistung mit HTML 5 und neuen Angular-Komponenten
  • Verknüpfungen zu anderen Websites funktionieren nicht, oder es werden Meldungen angezeigt, in denen angegeben wird, dass Sie Ihren Browser aktualisieren müssen
Beispiel: Wenn Sie IE11 verwenden, kann dies dazu führen, dass Ihre Roadmap-Zeitskala nicht mehr funktioniert. Die Personaleinsatzseiten laden möglicherweise nicht alle Ressourcen, und es können andere Probleme auftreten, die
zufällig
erscheinen, bis Benutzer feststellen, dass sie eine alte, nicht unterstützte Browser-Technologie verwenden, um auf eine völlig neue Webanwendungsschnittstelle mit großem Drag-and-drop-Funktionsumfang zuzugreifen. Wechseln Sie zu einem neuen Browser wie Edge, Firefox oder Chrome, um optimale Ergebnisse beim Anzeigen der Seiten in der neuen Benutzererfahrung in
Clarity
zu erzielen.
Es kann kein Upgrade für Oracle durchgeführt werden, bis die Sicherheitslizenz und das MD5-Paket aktiviert sind
  1. Wenden Sie sich an Ihren Datenbankadministrator oder Oracle, um die erweiterte Sicherheitslizenz (OAS) zu erhalten, die nur bei Verwendung von DBMS_CRYPTO erforderlich ist.
  2. Aktivieren und erteilen Sie explizite Berechtigungen für dbms_obfuscation_toolkit.md5 (auch mit Ihrer Oracle-Installation bereitgestellt).
  3. Starten Sie das Upgrade.
Bekanntes Problem aufgrund weggefallener Unterstützung für Sprachen
In dieser Version werden folgende Sprachen nicht mehr unterstützt:
Katalanisch
Tschechisch
Dänisch
Ende
Ungarisch
Holländisch
Norwegisch
Polnisch
Russisch
Schwedisch
Türkisch
Chinesisch (vereinfacht)
Chinesisch (traditionell)
Koreanisch
Infolgedessen wird einem Benutzer anstelle des übersetzten Textes eine Rohtext-Bezeichnung oder englischer Text in der Benutzeroberfläche angezeigt.
Umgehungslösung
: Ändern Sie die
Clarity
-Kontoeinstellungen in eine der unterstützten Sprachen, die in den Versionshinweisen aufgeführt sind.
Exportieren in eine CSV-Datei enthält keine Daten für "Kennzahlen pro Zeitraum", es sei denn, die Spalte "Insgesamt" ist vorhanden.
In den Rastern "Mitarbeiter" und "Zuweisungen" werden die Spalten "Insgesamt" und "Kennzahlen pro Zeitraum" für "Restaufwand", "Restaufwand-Kosten", "Ist-Aufwand" und "Ist-Kosten" verwendet.
  • Wenn die Spalten "Insgesamt" und "Kennzahlen pro Zeitraum" im Raster konfiguriert sind, funktioniert die Funktion "In CSV exportieren" erwartungsgemäß.
  • Wenn die Spalte "Insgesamt" im Raster nicht konfiguriert ist, funktioniert der Exportvorgang nicht erwartungsgemäß (alle "Kennzahlen pro Zeitraum"-Spalten sind leer).
Umgehungslösung
: Klicken Sie im Raster auf "Spaltenbereich", und fügen Sie die Spalte "Insgesamt" zum Raster-Layout hinzu, bevor Sie die Option "In CSV exportieren" verwenden.
Bekanntes Problem bei Neuinstallationen von Jaspersoft 7.1
In On-Premise-Umgebungen wird bei der Neuinstallation von Jaspersoft 7.1.0 auf Oracle 11g R2 oder 12c möglicherweise der Eintrag
Failed to execute: create index
in den Installationsprotokollen angezeigt:
[exec] [exec] init-js-db-pro:
[exec] [exec] [echo] For JDBC driver the artifactId and version properties are set:
[exec] [exec] [echo] maven.jdbc.artifactId=ojdbc8
[exec] [exec] [echo] maven.jdbc.version=12.2.0.1.0
[exec] [exec] [echo] Specified JDBC driver jar exists
[exec] [exec] [advanced-sql] Executing resource: /fs0/clarity1/install_cd/ca_ppm_jaspersoft_7.1.0/buildomatic/install_resources/sql/oracle/js-pro-create.ddl
[exec] [exec] [advanced-sql] 0 rows affected
[exec] [exec] [advanced-sql]
Failed to execute: create index
idx46_jiresfldr_hidden_idx on JIResourceFolder(hidden)
[exec] [exec] [advanced-sql] java.sql.SQLException: ORA-01408: such column list already indexed
[exec] [exec] [advanced-sql] 0 rows affected
[exec] [exec] [advanced-sql] Executing resource: /fs0/clarity1/install_cd/ca_ppm_jaspersoft_7.1.0/buildomatic/install_resources/sql/oracle/quartz.ddl
Sie können diesen Eintrag ignorieren. Die Warnung wird angezeigt, um Sie über die Erstellung eines doppelten Indexes zu informieren. Dies ist jedoch keine gültige Warnung.
  • Diese Warnung hat keine Auswirkungen auf Ihre Installation und wirkt sich auf keine Funktionen von Jaspersoft 7.1 aus.
  • Die Engineering-Teams von CA haben bestätigt, dass alle DDL-Befehle nach der gemeldeten Warnung erfolgreich ausgeführt werden konnten.
  • Die Warnung wird nur bei neuen Oracle-Installationen angezeigt und tritt nicht bei unterstützten Versionen von Microsoft SQL Server auf.
Überprüfen von abgebrochenen Jobs nach dem Upgrade
Überprüfen Sie alle
Clarity
-Jobs, die sich im Status "Abgebrochen" befinden, nachdem Ihr Upgrade abgeschlossen wurde. Achten Sie besonders auf abgebrochene Aufträge, die zuvor sich wiederholende Aufträge waren. Manchmal ändern sich nach einem Upgrade die Auftragsparameter, und die Aufträge gehen in den Status "Abgebrochen" über. Wenn Sie abgebrochene Aufträge nicht proaktiv überprüfen, werden Sie diese nur bemerken, nachdem Sie Eskalationen vom Unternehmen erhalten haben.
Installations- und Upgrade-Abhängigkeiten
Die Installations- und Upgrade-Skripte in dieser Version führen die folgenden Abhängigkeiten in der aufgelisteten chronologischen Reihenfolge ein:
Diese Komponente installieren/aktualisieren:
Erfordert diese Komponente:
Upgrade von
Classic PPM
  • Data Warehouse konfiguriert
  • Auftrag "Data Warehouse laden" abgeschlossen
Clarity
  • PMO Accelerator-Add-In installiert
Installieren von PMO- oder APM-Add-Ins
  • Data Warehouse konfiguriert
Unterstützte Upgrade-Pfade für Version
15.8.1
In der Tabelle finden Sie Informationen zur unterstützten Mindestversion, von der Sie ein Upgrade auf die neueste Version von
Clarity
durchführen können.
Clarity-Version
Unterstützte Mindestversion für direktes Upgrade
15.8.1
15.6.1
15.8.0
15.3
15.7.1
15.3
15.7.0
15.2
15.6.1
15.0
15.6.0
15.0
15.5.1
14.3
15.5.0
14.3
15.4.1
14.1
15.4.0
13.2
15.3
13.2
15.2
13.2
15.1
13.2
  • Wenn Sie Version 14.3 oder älter haben, wird Ihre Version nicht mehr unterstützt. Führen Sie zuerst ein Upgrade auf 15.4 und dann ein Upgrade auf Version
    15.8.1
    durch.
  • Von Version 14.2 mit Jaspersoft 5.6.1 oder von Version 14.3 mit Jaspersoft 6.1.0 können Sie das Upgrade nicht
    direkt
    auf die Version
    15.8.1
    durchführen. Das Upgrade von Jaspersoft 6.4.2 oder 7.1 unterstützt diese Konfigurationen nicht. Das
    indirekte
    Upgrade wird jedoch unterstützt. Führen Sie zum Beispiel zuerst ein Upgrade auf 14.3 mit Jaspersoft 6.4.2 durch. Führen Sie dann ein Upgrade auf 15.8 und ein Upgrade auf Jaspersoft 7.1 durch.
  • Sie können ein Upgrade von einer früheren Version durchführen, auch wenn Sie keine Jaspersoft-Berichtsumgebung konfiguriert haben. Das Data Warehouse ist erforderlich; Berichterstellung allerdings nicht. Sie können sich dazu entscheiden, ein Upgrade von 14.x durchzuführen und anschließend eine Neuinstallation der Berichtsumgebung vorzunehmen.
  • Um ein Upgrade von früheren 13.x-Versionen durchzuführen, hilft es oft, wenn Sie zuerst ein Upgrade auf 14.3 oder 14.4 durchführen und die Komponente "Erweiterte Berichterstellung" überspringen. Diese Vorgehensweise vereinfacht die Fehlerbehebung und den Neustart des Prozesses, falls ein Upgrade fehlschlägt. Danach können Sie ein Upgrade von 14.x auf 15.6 durchführen und Jaspersoft 7.1 für erweiterte Berichterstellung installieren.
Das Installationsprogramm erkennt, wie viele inkrementelle Upgrade-Schritte erforderlich sind, um Ihre Installation auf die letzte Version zu aktualisieren. Wenn es zwei oder mehr sind, werden Sie aufgefordert zu entscheiden, ob das Installationsprogramm die automatischen Sicherungen bei jedem Schritt speichern soll, zum Beispiel von 15.4 auf 15.5, von 15.5 auf 15.5.1, von 15.5.1 auf 15.6, von 15.6 auf 15.6.1, von 15.6.1 auf 15.7, von 15.7 auf 15.7.1,von 15.7.1 auf 15.8 und von 15.8 auf 15.8.1.
Wenn Sie Patches auf der Basisversion installiert haben, stellen Sie sicher, dass Sie den neuesten unterstützten kumulativen Patch angewendet haben, bevor und nachdem Sie ein Upgrade durchführen. Die Wartung der Patches vor und nach Aktualisierungen ist wichtig für die Behebung von Fehlern und Sicherheitsproblemen und den allgemeinen Systemzustand.
Gehen Sie wie folgt vor
:
  1. Weitere Informationen finden Sie auf der Seite
    Clarity
    und kumulative Jaspersoft-Patches
    .
  2. Wählen Sie Ihre aktuelle Version aus dem Menü
    Versionen
    oben rechts auf dieser Hilfeseite aus.
    Wählen Sie zum Beispiel 15.1 aus, und stellen Sie sicher, dass Sie den 15.1.0.9-Patch installiert haben, oder wählen Sie 15.3 aus, und stellen Sie sicher, dass Sie den 15.3.0.5-Patch installiert haben, bevor Sie mit dem Upgrade auf 15.8 beginnen. Installieren Sie nach dem Upgrade den neuesten 15.8-Patch.
Es können Probleme auftreten, wenn Sie versuchen, ein Upgrade direkt von einer nicht unterstützten Patch-Ebene durchzuführen. Um optimale Ergebnisse zu erzielen, folgen Sie einem unterstützten Upgrade-Pfad. Weitere Informationen erhalten Sie beim CA Support. In der
Clarity
-Community
können Sie mit anderen Community-Mitgliedern zusammenarbeiten, um Ihre spezifischen Fragen zu klären.
Vor dem Upgrade: Ausführen des Installation Checker (nur On-Permise)
Das Dienstprogramm "Installation Checker" (checkinstall) bewertet eine Installation oder ein Upgrade. Das Dienstprogramm wird beim Start einer Installation oder eines Upgrades und am Ende eines Upgrade-Versuchs automatisch ausgeführt. Sie können es auch manuell ausführen. Das Dienstprogramm erstellt eine Berichtsergebnisdatei (precheck-results.html) im Verzeichnis <Installationsstamm>/checkinstall/check-logs.
Upgrade-Aktion
: Um optimale Ergebnisse zu erzielen, führen Sie Installation Checker aus, bevor Sie die vollständige Installation und den Upgrade-Vorgang durchführen. Warnungen müssen sorgfältig ausgewertet und behoben werden, bevor Sie fortfahren.
Gehen Sie wie folgt vor:
  1. Extrahieren Sie das
    Clarity
    -Installationsprogramm auf den
    Clarity
    -Anwendungsserver.
  2. Öffnen Sie eine Eingabeaufforderung, und navigieren Sie in das checkinstall-Verzeichnis, das sich in dem Verzeichnis befindet, in dem Sie das Installationsprogramm extrahiert haben.
  3. Rufen Sie den checkinstall-Befehl auf:
    UNIX
    :
    sh checkinstall.sh
    Windows
    :
    checkinstall.bat
    Sie werden nach dem Operator-Benutzernamen und der Operator-E-Mail gefragt. Diese Informationen beziehen sich auf den Benutzer, der das Upgrade oder die Installation durchführt, und auf die E-Mail des Benutzers. Diese Informationen werden als Datensatz im Installationsprotokoll gespeichert.
  4. Überprüfen Sie die Ergebnisse.
    Die Ergebnisse enthalten Warnungen und Fehler sowie Anpassungen, die Sie vorgenommen haben. Überprüfen Sie die Anpassungen, und nehmen Sie bei Bedarf Anpassungen für das Upgrade vor.
Drittanbieter-JAR-Dateien für das Installationsprogramm zugreifbar machen (nur On-Premise)
Aufgrund von Lizenzierungsbeschränkungen für bestimmte JAR-Dateien aus Drittanbieterbibliotheken (derzeit die Dateien "jgroups-all.jar" und "xinclude.jar") wurden Änderungen an der Bereitstellung dieser Dateien vorgenommen. Die JAR-Dateien werden gesondert vom
Clarity
-Image auf dem Installationsdatenträger ausgeliefert. Die genannten JAR-Dateien sind nicht im install.jar-Image enthalten. Installationspakete für eine frühere Version, die in "install.jar" enthalten ist, schließen die JAR-Dateien ebenfalls aus. Bei jeder Version von
Clarity
sind die JAR-Dateien in einem Ordner auf dem Installationsmedium zusammengefasst, der eine JAR-Datei mit Drittanbieterbibliotheken enthält. Für Version 15.x heißt die Datei
thirdparty.libs.15.x.0.jar
.
Upgrade-Aktion
: Entnehmen Sie die Datei
thirdparty.libs.15.x.0.jar
dem Installationsdatenträger. Platzieren Sie die Datei an einem Speicherort im Dateisystem, sodass sie für das Installationsprogramm zugänglich ist.
Tipp
: Um zu verhindern, dass Sie vom Installationsprogramm nach dem Speicherort der Datei gefragt werden, legen Sie die JAR-Datei im Stammverzeichnis der Installation ab. Wenn Sie die Datei in ein anderes Verzeichnis eingefügt haben, fragt das Installationsprogramm nach dem Dateispeicherort.
Upgrade von großen Datensätzen (nur On-Premise)
Wenn das
Clarity
-Upgrade ein großes Datenvolumen verarbeitet, ist es empfehlenswert, dass Sie die vom Upgrade verwendeten Standardspeichereinstellungen überschreiben.
Sie können die Standardspeichereinstellungen für diese Version überschreiben. Erstellen Sie eine Datei
memory.properties
, und platzieren Sie sie im Verzeichnis "$cappm/Config". Legen Sie die gewünschten Speicherwerte in dieser Datei fest.
Hier sind die Standardwerte, die das Upgrade verwendet:
defaultScriptMaxMem=1024m defaultScriptPermGenMem=128m
Hier sind einige Beispieleinstellungen in der
memory.properties
-Datei:
defaultScriptMaxMem=2560m defaultScriptPermGenMem=512m
Kompatibilitätsgrad der MS SQL Server-Datenbank
Setzen Sie den Kompatibilitätsgrad bei Verwendung von SQL Server 2016 für diese Version auf 130. Verwenden Sie hierfür SQL Server Management Studio oder den folgenden Befehl:
EXEC SP_DBCMPTLEVEL <database>, 130
Benutzerdefinierte Prozesse, Skripte und andere Anpassungen
Clarity
kann keine benutzerdefinierten Inhalte aktualisieren, die nicht unterstützt werden. Anpassungen müssen deaktiviert und möglicherweise neu entworfen sowie neu implementiert werden, damit sie mit den geänderten Produktfunktionen funktionieren.
Nach einem Upgrade führen Ihre Anpassungen, wenn Sie sie nicht deaktivieren, möglicherweise zu Fehlern oder funktionieren nicht erwartungsgemäß.
Gehen Sie wie folgt vor
:
  1. Identifizieren Sie den benutzerdefinierten Inhalt. Sie verfügen zum Beispiel über einen oder mehrere benutzerdefinierte Prozesse mit benutzerdefinierten GEL-Skripten, die Zeitformular-Statusattribute in einer früheren Version änderten.
  2. Bestätigen Sie die Anpassungen, und seien Sie sich bewusst, dass die Upgrade-Skripte den benutzerdefinierten Inhalt möglicherweise nicht unterstützen. Auch wenn der benutzerdefinierte Inhalt aktualisiert wird, funktioniert er möglicherweise nicht mehr wie erwartet. Ihre benutzerdefinierten Prozesse beziehen sich zum Beispiel auf ein Objekt oder Attribut, das in der neuen Version geändert wurde.
  3. Als On-Premise-Administrator bietet Ihnen das checkinstall-Skript eine Warnmeldung bei Anpassungen, die es vor der Aktualisierung erkennt. Sie können diese Warnungen oder die entsprechenden Protokolle anzeigen lassen, um einen Einblick in die Typen von Anpassungen bereitzustellen, die den Aktualisierungsvorgang beeinträchtigen können. Beispiel:
    WARNING: Possible schema customizations have been found. Any customizations to the system are the responsibility of the customer to maintain and are not supported. To upgrade, all customizations must be reviewed, changed, or removed as needed before the upgrade. After a successful upgrade, the customizations may be added back to the system. The possible customizations found are listed in the following log files:
    check‐logs/database_customization_triggers.txt check‐logs/database_customization_indexes.txt check‐logs/database_customization_tables.txt checklogs/database_customization_constraints.txt
  4. Als SaaS-Administrator sehen Sie diese Warnungen oder die entsprechenden Protokolle nicht. Diese Beispielmeldungen bieten einen Einblick in die Arten von Anpassungen, die den Aktualisierungsvorgang beeinträchtigen können.
  5. Deaktivieren Sie Ihre Anpassungen in On-Premise- oder SaaS-Umgebungen vor dem Upgrade. Wenden Sie die Anpassungen nach dem Upgrade erneut an, und testen Sie diese in der
    Classic PPM
    -Benutzeroberfläche. Überprüfen Sie optional die Auswirkungen des Anpassungsverhaltens auf
    Clarity
    .
  6. Überprüfen Sie zusätzlich zu den Datenbankobjekten außerdem die Attributwerte. Überprüfen Sie die Datenbank- und Data Warehouse-Änderungen für Oracle und Microsoft SQL (siehe Abschnitt Reference in der englischen Dokumentation). Überprüfen Sie, ob eine Ihrer Anpassungen von gelöschten, geänderten oder neuen Attributen abhängt.
Einige Kunden haben Fehler mit älterem benutzerdefiniertem Inhalt festgestellt. Nach der Deaktivierung des benutzerdefinierten Prozesses, Skripts oder anderen älteren Inhalten hat
Clarity
Funktionen ohne Nettoverluste für Endbenutzer bereitgestellt. Wir empfehlen, dass Sie eine Analyse durchführen, bei der Sie den Wert der
Clarity
-Funktionen in einer vollständigen COTS/SaaS-Lösung mit dem Wert der Entwicklung eigener, nicht unterstützter Anpassungen vergleichen.
Vor und nach dem Upgrade: Anpassungen im Dateiverzeichnis beibehalten (nur On-Premise)
Während des Upgrades werden Sie zur Angabe des Zielinstallationsverzeichnisses aufgefordert. Die neuen Schritte vor und nach dem Upgrade ermöglichen Ihnen, Dateien mithilfe von Ant-basierten Skripts in und aus dem
Clarity
-Verzeichnis zu kopieren. Verwenden Sie Ant-Skripts, um das Beibehalten und Wiederherstellen der Anpassung in den
Clarity
-Verzeichnissen zu automatisieren.
Vorlagen werden in versionsspezifischen Upgrade-Ordnern geliefert, die sich im Stammverzeichnis des Installationsprogramms befinden (auf derselben Ebene wie die install.bat-Datei). Die Vorlagen sind:
preprocess-upgrade.xml
und
postprocess-upgrade.xml
.
Beispiel für das preprocess-upgrade.xml-Skript
<project name="content" default="upgrade" basedir="."> <target name="upgrade"> <echo>Preserving customer specified files prior to upgrade from install.dir = ${install.dir}</echo> <if fileexists="${install.dir}" not="true"> <fail>Install dir not specified = ${install.dir}</fail> </if> <delete dir="upgrade_temp"/> <mkdir dir="upgrade_temp" /> <!-- Uncomment the copy below and list the files to be included for preservation --> <!--<copy todir="upgrade_temp"> <fileset dir="${install.dir}" > <include name="myfiles/my*.*"/> <include name="abb/*01.jar"/> <include name="a*01.jar"/> </fileset> </copy>--> </target> </project>
Beispiel für postprocess-upgrade.xml-Skript
<project name="content" default="upgrade" basedir="."> <target name="upgrade"> <echo>Restoring customer specified files after upgrade to install.dir = ${install.target.dir}</echo> <if fileexists="${install.target.dir}" not="true"> <fail>Install dir not specified = ${install.target.dir}</fail> </if> <!-- Uncomment the copy task below and list the files to be restored that were preserved in the preprocess-upgrade.xml script.--> <!--<copy todir="${install.target.dir}"> <fileset dir="upgrade_temp" > <include name="myfiles/my*.*"/> <include name="abb/*01.jar"/> <include name="a*01.jar"/> </fileset> </copy>--> </target> </project>
Nach dem Upgrade oder der Installation: Oracle 12c-Leistung optimieren (nur On-Premise)
Bei lokale Installationen von Oracle 12c R1 oder R2 haben, kann es ein Regressionsproblem mit Oracle 12c geben, wenn der Hinweis ORDERED in strukturierten Abfragen verwendet wird. Ein Fehler seitens Oracle in 12c R2 kann die Leistung beeinträchtigen, wenn der Optimierer auf 12.2.0.1 eingestellt ist.
  • Für Systeme, die Oracle 12c R1 (12.1.0.2) verwenden, ist keine weitere Aktion erforderlich.
  • Bei Systemen mit Oracle 12c R2 (12.2.0.1) können Sie die Leistung optimieren, indem sie den Optimierer auf 12.1.0.2 einstellen. Wir empfehlen Ihnen, diesen optionalen lokalen Fix anzuwenden.
Gehen Sie wie folgt vor
:
  1. Geben Sie in einem Eingabeaufforderungsfenster in Oracle folgende Zeilen ein:
    sqlplus / as sysdba ALTER SYSTEM SET "_fix_control" = '17800514:0'; Exit;
  2. Führen Sie den folgenden Befehl aus:
    ALTER SYSTEM SET OPTIMIZER_FEATURES_ENABLE= '12.1.0.2' SCOPE=BOTH;
  3. Stellen Sie sicher, dass die Parameter Ihrer Oracle 12c R2-Initialisierungsdatei dem folgenden Beispiel nahekommen:
    *._fix_control='17800514:0' *._optimizer_multi_table_outerjoin=FALSE *.audit_file_dest='/fs0/oracle/12201/12c/admin/niku/adump' *.audit_trail='DB' *.cluster_database=FALSE *.compatible='12.2.0.1' *.control_files='/fs0/oracle/12201/12c/oradata/niku/CONTROL01.CTL','/fs0/oracle/12201/12c/oradata/niku/CONTROL02.CTL' *.cursor_sharing='FORCE' *.db_block_size=8192 *.db_name='niku' *.diagnostic_dest='/fs0/oracle/12201/12c/admin/niku/udump' *.dispatchers='(PROTOCOL=TCP) (SERVICE=nikuXDB)' *.local_listener='LISTENER_NIKU' *.nls_comp='BINARY' *.nls_date_format='YYYY-MM-DD HH24:MI:SS' *.nls_language='AMERICAN' *.nls_sort='BINARY' *.nls_territory='AMERICA' *.open_cursors=1000 *.optimizer_adaptive_plans=false *.optimizer_adaptive_reporting_only=TRUE *.optimizer_adaptive_statistics=FALSE *.optimizer_features_enable='12.2.0.1' *.optimizer_inmemory_aware=FALSE *.pga_aggregate_target=4G *.processes=1000 *.remote_login_passwordfile='EXCLUSIVE' *.session_cached_cursors=1000 *.sessions=1536 *.sga_target=80G *.streams_pool_size=536870912 *.trace_enabled=TRUE *.undo_tablespace='UNDOTBS1'