Clarity PPM のパーソナライズ: パスワードの変更、アカウント設定、通知、Excel へのエクスポート

ccppmop157
HID_getting_started_personalize
アカウント設定のカスタマイズ、パスワードの変更、Excel または CSV へのエクスポート、アプリケーション ページの外観の設定を行うことができます。 変更はそれを行ったユーザにのみ表示されます。 ユーザ インターフェースをパーソナライズするには、管理者に問い合わせて、必要なアクセス権を取得します。 十分な権限があれば、必要なメニューとアイコンがページおよびポートレットに表示されます。
 
2
ドキュメントが製品のユーザ インターフェースに表示される内容と一致しない場合があります。 この違いは、機能、メニュー、ページ、ボタン、およびオブジェクトへのアクセスがすべて、ユーザのアクセス権によって判断されるために発生します。 組織は、アプリケーションのページ、オブジェクト、ルックアップ、パーティション、プロセス、およびユーザ インターフェースをカスタマイズすることもできます。 ドキュメント内の手順のいずれかを完了できない場合は、管理者に連絡してください。
 
アカウント設定のパーソナライズ
 
個人アカウントの設定には、アクション アイテム代理、連絡先情報、およびパスワードが含まれます。 通知受信の優先方法を設定したり、クライアント ソフトウェア ツールを
Clarity PPM
で使用するためにダウンロードしたりすることもできます。
場所と言語設定の管理
タイム ゾーン、ロケール、および言語を定義できます。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [アカウント設定]
    をクリックします。
  2. 以下のフィールドに入力します。
    •  
      タイム ゾーン:
      プライマリ ワークスペースのタイム ゾーンを定義します。
    •  
      ロケール:
      勤務先ロケールを定義します。 ロケールにより製品の数値および日付の言語形式を制御します。
      既定値:
      英語(米国)
    •  
      言語:
      ユーザ インターフェースで使用する言語を定義します。
      既定値:
      英語
  3. 変更を保存します。
パスワードの変更
管理者が設定されたセキュリティ ポリシーによって、ログイン パスワードを変更できる場合があります。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [アカウント設定]
    をクリックします。
  2. [パスワードの変更]
    セクションで、要求された情報を入力します。
  3. 変更を保存します。 
[パスワードの変更]セクションは、以下の理由で表示されません。
  • 管理者によって「
    アカウントの設定 - ナビゲート
    」アクセス権が付与されていません。 この権限は、[アカウント設定]ページに移動するために必要です。
  • 管理者が LDAP や SSO などの外部認証を有効にしました。 これらの設定で、外部ログイン認証情報を変更する方法については、管理者にお問い合わせください。
代理の指名
アクション アイテムに対する代理として別のリソースを一時的に指名できます。 割り当てられたリソースは、定期的にスケジュールされたアクション アイテムと緊急アクション アイテムを代理期間中に受信します。 指名された代理に対しては、
[概要]
ページの
[アクション アイテム]
ポートレットにアクション アイテムが表示されます。
 プロキシ リソースに、実行する必要のあるアクションに対する適切なアクセス権が付与されていることを確認してください。 たとえば、プロジェクトのアクティビティを完了するためのアクション アイテムを代理で受信した場合、プロジェクトを表示する適切な権限が必要です。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [アカウント設定]
    をクリックします。
  2. [代理]
    をクリックします。
  3. 必要な情報を
    [セットアップ]
    セクションに入力します。
  4. (オプション)そのアクション アイテムに対する代理としてその他のリソースを指名できます。 代理の名前は
    [リソース]
    フィールドに表示されます。
  5. 変更を保存します。
通知の設定
ソフトウェアのほかの部分での特定のイベントの発生が、自動通知をトリガできます。 さまざまな種類の通知の受信を管理できます。 たとえば、誰かがアクション アイテムに応答したときに電子メールで通知を受け取るように設定できます。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [アカウント設定]
    をクリックします。
  2. [通知]
    をクリックします。
  3. 通知を受信する機能エリアおよびメソッドを選択します。 既定では、各機能エリアの方法のチェック ボックスがすべてオンになっています。
  4. (オプション)
    [既定値の復元]
    をクリックして、管理者が最後に発行または保存した設定に一致するように、通知の設定を行います。
  5. 変更を保存します。
以下のリストは、各機能エリアの通知をトリガする状況を説明しています。
  •  
    アクション アイテム
    通知は、新規のアクション アイテムが割り当てられ、期限が来ると送信されます。
  •  
    変更依頼
    通知は、変更依頼を割り当てられると送信されます。
  •  
    エスカレーション
    通知は、プロセスが失敗するか滞っており、エスカレーションの通知担当者として指定されている場合に、送信されます。
  •  
    問題
    通知は、問題を割り当てられると送信されます。
  •  
    プロセス
    通知は、リソースにより、プロセス内の特定のステップの連絡担当者として指定された場合に、送信されます。
  •  
    プロジェクト
    リソースがプロジェクトに追加されたり、プロジェクトから削除された場合に、通知が送信されます。
  •  
    レポートとジョブ
    自分が開始またはスケジュールしたレポートやジョブ、または自分に割り当てられたレポートやジョブが完了または失敗した場合に、通知が送信されます。
  •  
    リスク
    通知は、リスクに割り当てられると送信されます。
  •  
    タイムシート
    通知は、提出されたタイムシートの通知を受信すると送信されます。 タイムシートが期限切れであるか返却された場合に通知を受信することができます。
クライアント ソフトウェアのダウンロード
管理者は
Clarity PPM
サーバでインストール ファイルをセットアップします。 独自のクライアント コンピュータで以下のソフトウェアをダウンロードできます。
  •  
    Open Workbench
    : デスクトップ プロジェクト管理とスケジューリングのスタンドアロン ソフトウェア アプリケーションとして Open Workbench を使用するか、または Open Workbench と
    Clarity PPM
    と統合します。
  •  
    Microsoft Project インターフェース:
    Microsoft Project インターフェースを使用して、Microsoft Project のスケジューリング機能を統合します。
ソフトウェアをダウンロードするには、以下が必要です。
  • ソフトウェアをダウンロードするアクセス権。
  • ソフトウェアをインストールする管理者権限。
 適切なアクセス権があっても、ソフトウェアを利用できない場合があります。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [アカウント設定]
    をクリックします。
  2. [ソフトウェア ダウンロード]
    をクリックします。
  3. [ダウンロード]
    リンクをクリックします。
  4. ダウンロードおよびインストールの手順に従います。 ソフトウェアをインストールしたフォルダの場所をメモしておきます。
必要なクライアント ソフトウェアをダウンロード、インストール、または実行できない場合は、管理者にお問い合わせください。
既定のパーティションの設定
ユーザは、
[既定のパーティション]
タブを使用できる場合、既定値を選択できます。
  1. [ホーム]
    -
    [アカウント設定]
    をクリックします。
  2. [既定のパーティション]
    タブをクリックします。 このタブは、ユーザが管理者によって少なくとも 1 つのパーティション ユニットのメンバとして追加されている場合にのみ表示されます。 通常、ユーザは 1 つのパーティションにのみ割り当てられますが、複数のパーティションに割り当てることも可能です。 管理者としてパーティションを設定するには、Studio ドキュメントの「
    リファレンス
    」を参照してください。
  3. パーティションを選択し、
    [保存]
    をクリックします。 パーティション モデルにオプションの Studio UI テーマを含めることができるため、選択したパーティションを保存した後、ユーザ インターフェース テーマ カラーを変更できます。
所属しているパーティションが 1 つか複数かにかかわらず、既定のパーティションを設定する必要があります。 デフォルト設定がない場合、アプリケーションの一部の領域で 1 つ以上のパーティションの関連データがすべて表示されない場合があります。
ホーム ページの設定
既定のホーム ページは、[概要: 概要]ページです。 どのようなページもホーム ページにできます。
 
以下の手順に従います。
 
  1. 新しいホーム ページにするページにナビゲートします。
  2. メイン メニューで、
    [ホーム]
    をクリックします。
  3. メニューの下部にある
    [ホームとして設定]
    をクリックします。
  4. ホーム ページとして設定したページに移動する方法
    1. テストとして別のページに移動します。
    2. メイン メニュー バーの ホーム アイコンをクリックします。
  5. (オプション)ホーム ページをデフォルトの[概要]ページにリセットできます。
    [ホーム]
    メニューをクリックし、
    [ホームをリセット]
    を選択します。
重要な情報のパーソナライズ
ユーザの情報を表示するには、以下のいずれかのページを開きます。
  • [ホーム]
    -
    [パーソナル]
    -
    [概要]
    をクリックします。
    [概要]
    は既定のホーム ページです。 このページには、ユーザのアクション アイテムと通知をリスト表示するポートレットが含まれます。 このページには、以下を追加できるポートレットも含まれます。
    • プロジェクトへのアクセスを容易にするプロジェクト リンク
    • 他のアプリケーション ページまたは外部インターネット アドレスへのお気に入りのリンク。 管理者は、複数のユーザによって使用されるサイト リンク ポートレットにリンクを追加できます。
    • お気に入りフォト
  • [ホーム]
    -
    [パーソナル]
    -
    [オーガナイザ]
    を選択します。
アクション アイテムの作成
 
アクション アイテム
は自分自身に割り当てるか、他のユーザから割り当てられる非タスクです。 アクション アイテムを使用してプロジェクトの進行状況を追跡し、プロジェクトが完全で予定どおりであることを確認します。
個人アクション アイテムと、プロジェクト関連アクション アイテムの両方を作成できます。 個人アクション アイテムは
[オーガナイザ]
ページから作成し、プロジェクト関連アクション アイテムはプロジェクト内から作成します。
[オーガナイザ]
ページの
[アクション アイテム]
タブには、作成する個人およびプロジェクト関連のすべてのアクション アイテムが一覧表示されます。
[アクション アイテム]
タブには、他のユーザにより作成され、割り当てられたアクション アイテムも一覧表示されます。
ユーザは自身が作成するアクション アイテムのオーナーです。 オーナーとして、アクション アイテムを変更または削除できます。 [アクション アイテムのプロパティ]ページで作成した個人アクション アイテムのプロパティを変更できます。 別のユーザによってユーザに割り当てられたアクション アイテムについては、ステータスのみを更新できます。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [オーガナイザ]
    をクリックします。
  2. [新規]
    をクリックします。
  3. 以下の
    [概要]
    セクションに入力します。
    •  
      繰り返し
      アクション アイテムを定期的に繰り返すかどうかを指定します。
    •  
      頻度
      アクション アイテムを繰り返す回数を指定します。
      : 毎週ステータス レポートを作成するには、このフィールドに「1」を入力します。
    • 終了日
      アクション アイテムが繰り返す最終日を示します。
  4. [通知]
    セクションに入力します。
    •  
      担当者に通知
      通知を送信する必要があるかどうかを示します。
    •  
      リマインダの送信
      アクション アイテムの期限になったら、リマインダの電子メール通知を割り当て済みリソースに送信するかどうかを示します。
    •  
      リマインダまでの時間
      あるアイテムのリマインダが発生する前の時間を定義します。 たとえば、このフィールドに「15」と入力した後、
      [ユニット]フィールドで[分]を選択します。
    •  
      ユニット
      [リマインダの送信]チェック ボックスがオンの場合は、リマインダの時間の単位を指定します。
  5. [担当者]
    セクションにアクション アイテムを割り当てるリソースの名前を入力して、変更を保存します。
[通知]からアクション アイテムを開く
通知には、アラート、電子メール、SMS メッセージなどがあります。 通知は、任意のページ上のデータの変更や新しいアクティビティを認識するのに役立ちます。 アラート通知は、[概要]ページ([通知]ポートレット)および[オーガナイザ]ページ([通知]タブ)に表示されます。 ユーザに割り当てられたアクション アイテムまたは期限超過のタイムシートについてのアラートが表示されます。
通知リストからアクション アイテムを開くことができます。
 
以下の手順に従います。
 
  1. [ホーム]
    を開いて、
    [パーソナル]
    から
    [オーガナイザ]
    をクリックします。
  2. [通知]
    をクリックします。
  3. [メッセージ]
    列内のリンクまたはアラート通知の隣に表示される
    [プロパティ]
    アイコンをクリックします。
プロセスの管理
プロセスとは、ビジネス目標の達成のために実行される、一連の関連するアクションまたは手順です。 
オーガナイザ
から以下のプロセスを表示できます。
  •  
    開始済み
    ユーザが開始した、または表示アクセス権を持つプロセス インスタンスを含みます。 ステータスを表示するか、プロセス リンクをクリックしてステップの詳細を表示できます。
  •  
    利用可能
    開始し、編集できるプロセスを含みます。 新規のプロセスを作成することもできます。
     プロセスは明示的に完了とはマークされません。 プロセス インスタンスの完了は、構成するステップのステータスによって異なります。 終了ステップの完了時に、プロセス インスタンスは終了します。 利用可能なすべてのグローバル プロセスのリストを表示するには、プロセス管理者アクセス権が必要です。
プロセスを開始、変更、またはキャンセルすることができます。 手動アクションまたは自動トリガによってプロセスが開始されるたびに、プロセス インスタンスが作成されます。 変更できるプロセスは、
[モード]
「ドラフト」
または
「保留」
に設定されているプロセスだけです。 プロセスを変更するために適切なアクセス権が必要です。 アクティブで未完了のプロセスのみをキャンセルできます。 キャンセルされたプロセス インスタンスは自動的には削除されず、参照用に残ったままです。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [オーガナイザ]
    をクリックします。
  2. [プロセス]
    をクリックします。
  3. [プロセス]
    メニューを開き、以下のいずれかのアクションを実行します。
  4. プロセスを開始します。
    1. [利用可能]
      をクリックします。
    2. 開始するプロセスの隣にあるチェック ボックスをオンにして、
      [開始]
      をクリックします。
  5. プロセスを変更します。
    1. [利用可能]
      をクリックします。
    2. 変更するプロセス名をクリックします。
    3. 以下の手順を実行します。
      • このプロセスの一般的な属性を変更します。
      • アクションの追加、名前変更、削除、条件追加、変更などを必要に応じて行い、プロセス ステップを更新します。
      • グループの追加、削除、整理、名前変更などを行い、グループを更新します。
      • エスカレーション タイプ、レベル、猶予期間、通知などを変更して、エスカレーションのプロパティを更新します。
      • [検証]リンクをクリックして、プロセスの変更を検証します。 エラーが見つかった場合、エラーを修正し、プロセスを再検証します。 エラーがない場合、[終了]をクリックします。
  6. プロセスのキャンセル
    1. [開始済み]
      をクリックします。
    2. プロセス インスタンスを選択し、
      [プロセスのキャンセル]
      をクリックします。
    3. [はい]
      をクリックして確定します。
タスクの更新
個人用タスクは、作業アイテムです。 作業をタイムシートに記録し、タスクの進捗状況を追跡できます。 自分で作成したパーソナル タスクと他のユーザにより割り当てられたパーソナル タスクを表示できます。 割り当てられた各タスクのエントリがリストに表示されます。 タスクで以下のアクションを実行できます。
  • タスクを開いて表示します
  • 表示されたタスク プロパティの編集
  • タスクに完了または未完了のマークをつける
タスクに関する情報を最新の状態に維持するために、パーソナル タスクまたは割り当てられたタスクを更新できます。
 
以下の手順に従います。
 
  1. [ホーム]
    -
    [パーソナル]
    -
    [オーガナイザ]
    をクリックします。
  2. [タスク]
    をクリックします。
  3. タスクを開き、そのプロパティを更新します。
    •  
      タスク
      タスクの名前を定義します。 フィールドの値は[タスクのプロパティ]ページ上の[名前]フィールドから取得されます。 リスト ページまたはポートレットでは、タスク名を表示します。
      制限
      : 64 文字
    •  
      投資
      投資名が表示されます。 このフィールドの値は、[プロジェクトのプロパティ]ページの[プロジェクト名]フィールドに基づいています。
    •  
      開始
      リソースに対するタスク割り当てを開始する日付を定義します。 リスト ページまたはポートレットは開始日を表示します。
      既定値
      : タスク開始日
      割り当ては、タスク開始日以降に開始されるように定義します。 割り当てに実績値が存在する場合、このフィールドは読み取り専用になります。
    •  
      終了
      リソースに対するタスク割り当てを完了する日付を定義します。 割り当ては、タスク完了日またはそれ以前に終了するように定義します。リスト ページおよびポートレットには、この完了日が表示されます。
      既定値
      : タスク完了日
    •  
      実績値
      リソースが動作しタスク割り当てにポストされた作業ユニットの合計が表示されます。
    •  
      未確定の実績値
      リソースがタイムシートに入力する時間数が表示されます。 未確定の実績値は、「オープン」、「保存済み(リソース別)」、「サブミット済み」、または「承認済み」のステータスでタイムシートに表示されます。
    •  
      ETC
      タスクを完了するための残存作業時間が表示されます。 値を編集するにはセルをクリックします。
    •  
      担当のステータス
      タスクのステータスを示します。 このフィールドの値は、[タスクのプロパティ]ページの[ステータス]フィールドから取得されます。
      値:
      • 開始前。 タスクに対してポストされた時間がありません。
      • 開始済み。 時間がタスクに対してポストされると、そのステータスは
        「開始済み」
        へと自動的に変更されます。
      • 完了。
         
        タスク ETC (残存作業時間)の時間数がゼロで、そのタスクのステータスが「
        完了
        」になると、そのステータスは「
        完了
        」に自動的に変更されます。
  4. 変更を保存します。
アバター イメージのパーソナライズ
他のユーザから識別してもらうため、
新ユーザ エクスペリエンス
で自分の写真をアイコンとして表示できます。 クラシック アプリケーション ページの右上隅に、ユーザを識別するための円形のイメージも表示されます。 既定では、リソースの姓と名の頭文字がアバター イメージに表示されます。 独自のイメージまたは写真をアップロードして、ユーザ アカウントを識別することができます。
ユーザのセッション間で識別するため、契約社員には頭文字、パーソナライズされたスタッフ アカウントには写真、特別チームや部門アカウントにはカラーの画像や図を使用するなどの方法があります。 管理者は、複数の個人ユーザ アカウントを保有する場合があります。 たとえば、個人用アカウントに写真アバターを使用します。 複数の色分けされたアバターをテスト アカウントに使用できます。
  1. スマート フォン、PC または Web カメラ、スキャナ、デジタル カメラを使用して、ユーザの写真をキャプチャします。
  2. 写真を電子メールで送信するか、ご使用のコンピュータまたはアクセスできるファイル サーバにコピーします。
  3. リソースを表すイメージ ファイルを外部のグラフィック アプリケーションで編集して、保存します。 たとえば、組織で色スキームまたはロゴを設定して、さまざまなチームのユーザを識別できます。 テキスト識別子をアバターに追加することもできます(たとえば DEV、PMO、RM、BLUE TEAM など)。 以下の設計要件に従います。
    1. イメージ ファイルのサイズは 250 KB 以下にします。 最大サイズは 2 MB ですが、パフォーマンス向上のため、より小さなイメージの使用をお勧めします。
    2. 40 x 40 ピクセル程度の正方形のサイズにイメージをトリミングします。 円形のイメージは直径 40 ピクセルにします。 大きなイメージは縮小され、適切に切り取られます。 著しく大きな(500 x 500 ピクセル)イメージを縮小すると、予期しない結果が生成されることがあります。 他のユーザがページを拡大したり、そのイメージをブログ、Web ページ、またはレポートにコピーしたりする可能性もあります。 最良の結果のため、アバターの元のアートは、72 dpi の 80 x 80 ピクセル程度に設定します。
    3. サポートされているイメージ ファイルの形式は、.png、.jpg、.gif、.ico です。 .tif などの他の形式はサポートされていません。
  4. 個人アバターで識別するリソースとして
    Clarity PPM
    にログインします。
  5. ページ上部の現在のアバター イメージまたは頭文字をクリックします。
  6. [Choose File (ファイルの選択)]
    をクリックします。
  7. イメージ ファイルを選択します。
    イメージのプレビューが表示されます。
  8. [戻る]
    をクリックします。
  9. (オプション)既定のアバターに戻すには、アバターをクリックして、
    [イメージの削除]
    を選択し、
    [戻る]
    をクリックします。
 リリース 15.3 以降のリリースでは、
新ユーザ エクスペリエンス
でアバター イメージを変更することができます。 「新ユーザ エクスペリエンスの開始」を参照してください。 標準の解像度である 72 dpi の場合、クラシック ヘッダ内のアバターは 32 x 32 ピクセルになります。
新ユーザ エクスペリエンス
では、アバターはタスク リストで 30 x 30 ピクセル、[チーム]タブで 40 x 40 ピクセルになります。
管理者はアバター イメージ ファイルとして許可されるファイル タイプを指定できます。
[管理]
メニューをクリックして、
[システム オプション]
を選択します。 たとえば、「
doc,docx,pdf,xls,jpg,gif
」と入力すると、リストされていない他のファイル タイプが除外されます。 この場合、.png および .ico の画像形式はブロックされます。 リストされたファイル拡張子は、ドキュメント管理システムに適用されます。 アバターや添付ファイルを含む他の機能もドキュメント管理システムに依存しています。 アバター機能は、このセクションの手順でリストされたファイル タイプのみに対応します。 ただし、リストされていない拡張子をオプションの許可リストでブロックします。
ページのパーソナライズ
ユーザは、必要な情報を表示するように、ページをパーソナライズできます。 ページをパーソナライズすると、タスクに関連するコンテンツのみが表示されます。 ユーザに最も適した方法でページにコンテンツを表示できます。
  • 十分なアクセス権を持っている必要があります。 パーソナライズする権限がある場合、必要なメニューまたはアイコンがページまたはポートレット ツールバーに表示されます。
  • 変更はそれを行ったユーザにのみ表示されます。
  • 各ページはポートレットから構成され、ページ コンテンツはタブで構成されます。
  • オーナーが元の項目を変更して発行すると、ユーザ個人が変更した内容は失われます。
  • ページの編集が許可されている必要があります。 管理者は、Studio 内のページに対して
    [エンド ユーザによるタブの追加を許可]
    または
    [パーソナライズ可能]
    チェック ボックスを有効にする必要があります。
ポートレットの追加や削除、または既定ポートレットの復元によりページ コンテンツをパーソナライズできます。
 
以下の手順に従います。
 
  1. ページの右上隅にある
    [パーソナライズ]
    アイコンをクリックします。
    [コンテンツ]ページが開き、ページ上にすでに表示されているポートレットのリストが表示されます。
  2. [追加]
    をクリックし、[コンテンツの選択]ダイアログ ボックスで、ページに追加するポートレットを選択します。
  3. 以下のいずれかのステップを完了します。
    • [追加]
      または
      [追加してさらに選択]
      をクリックします。
    • [戻る]
      をクリックし、変更を保存してページに戻ります。
    • [続行]
      をクリックして、さらに設定を続けます。
  4. ページからポートレットを削除するまたは既定コンテンツを復元するには、
    [削除]
    または
    [既定値の復元]
    ボタンを使用します。
ページ フィルタを追加する
ページ コンテンツをフィルタするためにフィルタ ポートレットをページに追加できます。
 
以下の手順に従います。
 
  1. ページの右上隅にある
    [パーソナライズ]
    アイコンをクリックします。
  2. [ページ フィルタ]
    タブを選択します。
  3. [追加]
    をクリックし、リストからフィルタを選択します。
  4. [追加]
    をクリックします。
  5. (オプション)
    [保持]
    および
    [既定値]
    オプションを設定します。
    •  
      保持
      別のページに移動した場合に、フィルタ内の値が保持されるようにします。 フィルタ値が保持されるのは、同じフィルタ ポートレットを使用しているページのみです。
    •  
      デフォルト
       
      ページ フィルタの既定値を設定します。 他のフィルタを選択しない限り、ページに発行される最初のフィルタがページ フィルタの既定値となります。
  6. 変更を保存します。
ページ レイアウトのパーソナライズ
ページ コンテンツを再整理し、ページのレイアウトを変更します。
 
以下の手順に従います。
 
  1. ページの右上隅にある
    [パーソナライズ]
    アイコンをクリックします。
  2. [レイアウト]
    タブを選択します。
  3. [レイアウト]
    フィールドでポートレットのレイアウト テンプレートを選択します。
    各オプションで、列の数と各列に割り当てるページの割合を指定します。
    [行レイアウト]
    オプションでは、1 つの行内に配置するポートレットの数によって、1 つのポートレットに与えられるスペースの割合が決まります。
  4. 矢印キーを使用し、ページで表示する順序にポートレットを移動します。
  5. 変更を保存します。
ページへの新しいタブの追加
独自のパーソナライズされたワークスペースを作成します。 タブをページに追加してから、選択したポートレットを追加します。 追加した新しいタブは、ページの左から右への順序の最後のタブとして表示されます。
 
以下の手順に従います。
 
  1. 現在のページで、
    [個人用タブの管理]
    アイコンをクリックします。
  2. [新規]
    をクリックします。
  3. [タブ名]
    および
    [説明]
    フィールドに入力し、
    [保存して続行]
    をクリックします。
  4. 新しいタブに表示するページのコンテンツを追加して管理し、
    [続行]
    をクリックします。
  5. ページ フィルタを追加し、
    [続行]
    をクリックします。
  6. レイアウトを設定し、
    [保存して戻る]
    をクリックします。
タブの編集
既存のタブのプロパティとコンテンツを編集します。 ページに表示されるタブ、および各タブに表示されるポートレットを設定できます。
すべてのタブのプロパティを編集することはできません。 編集可能なタブでは、リストの上にマウス カーソルを置くとリンクが表示されます。 ユーザが作成したカスタム タブのプロパティを編集することができます。
 
以下の手順に従います。
 
  1. 現在のページで
    [プロジェクト タブの管理]
    アイコンをクリックします。
  2. [タブの管理]
    ページで、編集するタブの名前をクリックします。
  3. ページ プロパティ、コンテンツ、レイアウト、およびフィルタを編集することができます。 この記事の後半のトピックを参照してください。
  4. 変更を保存します。
[タブの管理]
ページでは、タブを削除したり、順番を並べ替えたりすることもできます。 ユーザがページ上に作成したタブを削除できます。 システムの既定タブまたは PMO アクセラレータ アドインでインストールされたタブは削除できません。
ポップアップとしてページを示します。
いくつかのリストには、[オプション]ツールバー内に[設定]アイコンが表示されます。 これらのリストについては、ワークスペース上に浮かぶ個別のポップアップで表示するリストから選択された項目を設定できます。 ポップアップはユーザがアプリケーション内のどこにいるかを視覚的にリマインダを行う 1 つの方法です。 ポップアップにはワークスペースに表示されるページと同じ機能があります。
 
以下の手順に従います。
 
  1. 設定するリスト ページを開きます。
    たとえば、
    [ホーム]
    を開いて、
    [ポートフォリオ管理]
    から
    [プロジェクト]
    をクリックします。
  2. [オプション]アイコンをクリックしてメニューを開き、[設定]をクリックします。
  3. [リスト列セクション]
    メニューを開き、
    [フィールド]
    をクリックします。
  4. [属性]列で「名前」属性を見つけ、関連付けられている[プロパティ]アイコンをクリックします。
  5. [ポップアップとして開く]チェック ボックスをオンにし、
    [保存して戻る]
    をクリックします。
    ポップアップで表示する項目をリスト ページに設定すると、リスト項目はすべてポップアップ内に表示されます。
  6. [戻る]
    をクリックします。
リストのパーソナライズ
プロジェクト データのリストを操作することで、以下の内容を実行することができます。
  • リストをフィルタして、必要な情報のみを表示する
  • リストを並べ替えて、特定の順序で項目を参照する
  • リストを編集して正しい情報で更新する
  • リストをエクスポートして、Excel で表示して操作する
リストの[オプション]ツールバー
リストの最上部の[オプション]ツールバーでは、情報を管理することができます。
  •  
    フィルタ
     
    選択した条件付きのリストをフィルタできます。 ツールバーをダブルクリックするか、アイコン([+]または[-])をクリックして、フィルタを展開するか折りたたみます。 使用中のフィルタはフィルタ フィールドでリスト表示されます。 保存したフィルタのリストを表示するには、下矢印をクリックします。
  •  
    オプション メニュー
    表示されているポートレットに適用されるオプションにアクセスできます。 表示されるオプションはポートレットに応じて変わる場合があります。 以下のリストは、[オプション]メニューに表示されるメニュー オプションの一部を示したものです。
    •  
      設定
       
      次の方法でリストを設定できます。
      • リストおよびフィルタ フィールドの変更
      • リストおよびフィルタ レイアウトの変更
      • 列の情報の集計
      • リストの表示方法に関するオプションの設定
      • ガント図の表示設定の定義
      • 期間単位値の期間設定の定義
    •  
      複数列でソート
       
      複数の列を使用して、リスト内の情報をソートできます。
    •  
      Excel にエクスポート(データのみ)
       
      Microsoft Excel にリストをエクスポートします。 このエクスポートには図は含まれません。 
 いくつかのリストには、[オプション]ツールバー内に[設定]アイコンが表示されます。 これらのリストについては、ワークスペース上に浮かぶ個別のポップアップで表示するリストから選択された項目を設定できます。 このポップアップには、ワークスペースに表示されるページと同じ機能があります。
リストのフィルタ
多くのアイテムがあるリストは複数のページにまたがることがあります。 表示するアイテムのみにリストをフィルタするには、フィルタ フィールドを使用します。 [オプション]ツールバーの
[フィルタの展開/フィルタの折りたたみ]
アイコンを使用して、フィルタを非表示にするか、または表示します。 リストがフィルタされたときに、既定の結果リストに戻ったり、リスト ページの項目をすべて表示したりすることができます。
[すべて表示]
をクリックするか、[フィルタ]ドロップダウン リストから
[システム既定値]
を選択します。
フィルタに名前を付けたり、後で使用するために条件を保存したりすることができます。 保存したフィルタには[フィルタ]ドロップダウンからアクセスできます。
 
以下の手順に従います。
 
  1. リスト ページを開きます。
  2. フィルタが開いていない場合は、
    [フィルタの展開]
    アイコンをクリックします。
  3. フィルタ条件を入力し、
    [フィルタの保存]
    をクリックします。 フィルタ フィールドでは、大文字と小文字は区別されません。
  4. フィルタ名を入力します。
  5. このフィルタをこのリスト ページの既定フィルタにするには[既定]を選択します。
  6. 変更を保存します。
注:
階層リストにフィルタを適用すると、展開された項目は折りたたまれます。 フィルタされた項目の結果には、その親およびより上位の項目が含まれます。 すべての行の表示が折りたたまれています。
パワー フィルタの作成
パワー フィルタは、定義した条件によってリスト ページを検索するカスタム フィルタです。 リスト ページ上でパワー フィルタを単独でまたは他のフィルタ フィールドと一緒に使用します。 各リスト ページに対して作成できるパワー フィルタは 1 つのみです。
式を使用してパワー フィルタを設計し、構築します。 式は 2 つの部分(左辺および右辺)に分割され、「=」などの演算子で区切られます。 たとえば、以下の式は、プロジェクト リスト ページですべてのアクティブ プロジェクトを検索します。
project.is_active == 1
 
以下の手順に従います。
 
  1. リスト ページを開いたまま、フィルタを展開します。
  2. フィルタ セクション内の
    [パワー フィルタの作成]
    リンクをクリックします。
  3. フィールドに値を入力して、式の左辺を完成させます。 利用可能なフィールドはページによって異なります。
  4. [演算子]を選択します。 選択可能な演算子は、式の左辺で使用したオブジェクトとフィールドの値によって決まります。
  5. フィールドに値を入力して、式の右辺を完成させます。 利用可能なフィールドはページによって異なります。
  6. [追加]
    をクリックします。
    [式]フィールドに式が表示されます。
  7. 複数の節を含む式を作成する場合は、以下のフィールドから値を選択します。 たとえば、特定の部門に割り当てられているすべてのアクティブ プロジェクトを表示するには、複数の節で構成されるパワー フィルタを作成します。 このフィールドから値を選択した場合は、式用の新しい節を作成し、[追加]をクリックします。このアクションにより、[式]フィールドの値に節が追加されます。
    •  
      And/Or
       
      式の後半部分の計算式の種類を指定します。
    •  
      And
       
      複数の節で構成される式を定義します。
    •  
      Or
       
      論理和の式を定義します。
  8. 以下のいずれかのステップを完了します。
    • [評価]
      をクリックし、式の構文を評価します。 構文が有効ではない場合、
      [式]
      テキスト ボックスの上に[無効]が表示されます。
    • [かっこの追加]
      をクリックして、式をかっこで囲みます。
    • [否定]
      をクリックして、式をかっこで囲み、その前に感嘆符を追加することで式を否定します。
    • [クリア]
      をクリックし、
      [式]
      テキスト ボックスをクリアします。
  9. 変更を保存します。
    パワー フィルタが保存されます。 名前がページ フィルタの[パワー フィルタ]フィールド内に表示されます。
リストの並べ替え
希望する順序で項目を表示するために、行または列でリストをソートできます。 リストがソートされている場合、既定のソート順序にリセットできます。 リスト内の親項目をソートできます。 リストがソートされる場合、子項目は親のソート条件を継承します。
列をソートするには、列見出しをクリックします。 リストをソートすると、その列見出しに矢印が表示されます。 ソート順を逆にするには、列のヘッダをもう一度クリックします。 他の列見出しでソートする場合は、同じ操作を行います。
ページ レイアウトを変更するために列のソート順序を変更したり、複数の列でソートしたりするには、[複数列でソート]オプションを使用します。
 
以下の手順に従います。
 
  1. リスト ページを開きます。
  2. [オプション]アイコンをクリックし、[複数列でソート]をクリックします。
  3. 以下のフィールドに入力します。
    •  
      1 番目のフィールド
       
      ソートの最初の順序を定義する列を指定します。
    •  
      タイプ: テキスト
       
      情報をアルファベット順に表示します。
    •  
      タイプ: 番号
       
      情報を数字順に表示します。
  4. 2 番目、3 番目、4 番目のフィールドに情報を入力します。
  5. [列]フィールドで行う選択の方向を示します(昇順または降順)。
  6. [保存]をクリックします。
リストの編集
フィールド内をクリックすると、全リストが編集モードになります。 リスト内のフィールドを更新および修正するには、編集機能を使用します。 リストが編集モードの場合、ほかのフィールド内のリンクおよびアイコンをクリックできます。
リストを編集する際には、以下のルールが適用されます。
  • 保存されていない更新を示すフラグがフィールド内に表示されます。 Esc キーを押して表示モードに戻り、未保存の変更を破棄します。
  • フィールドを編集できる場合、フィールドは編集モードに変わります。 アクションが発生しない場合、フィールドは編集できません。
  • リストを編集するときに、項目を挿入することもできます。
  • リストに期間単位値の列が含まれており、期間単位の情報を編集する場合は、最初に変更を保存します。
 
以下の手順に従います。
 
  1. リスト ページを開きます。
  2. チェック ボックスを選択するか、項目行をクリックすると、新しい行がその下に挿入されます。
  3. [新規]
    をクリックします。
  4. フィールドを編集し、変更を保存します。 表示されるフィールドは必須フィールドです。
    新しい行が、更新されたフィールドと共に挿入されます。
リストを Excel または CSV へエクスポート
[オプション]ツールバーに[Excel にエクスポート]アイコンが表示されているリスト ポートレットから情報をエクスポートできます。 Excel へのエクスポートは、リストが複数のページにまたがっている場合に特に便利です。 SUM や AVERAGE などの統計演算を使用するには、Excel 形式でリストをエクスポートして表示します。
 
以下の手順に従います。
 
  1. 返された結果をエクスポートしていて、ページ処理を一切行っていないことを確認してください。
  2. エクスポートする情報が含まれるリスト ページを開き、
    [Excel にエクスポート]
    アイコンをクリックします。
  3. リストを Excel スプレッドシートとして開くか、ローカル デスクトップに保存します。
Excel でエクスポートされたデータの外観は多くの場合に変更されている可能性があります。
データを Microsoft Excel にエクスポートすると、各列のフォーマット設定もエクスポートされます。 列値の集計または比較に使用されている式もエクスポートされます。 それらは別個のアプリケーションおよびファイル形式であるため、
Clarity PPM
から Excel または CSV にエクスポートされたデータの外観が変わることが予測されます。 説明のため、以下の例の画像および説明を使用します。
 
この図は、Microsoft Excel で見られるように、CA PPM から CSV にエクスポートされたデータの例を示しています。
 
Excel に表示される各種のデータ タイプは、以下のとおりです。
  • 文字列
     
    文字列
  •  
    URL
     
    ハイパーリンク文字列
  •  
    リンク付きグリッド列
    リンクがイメージの場合は、Excel の列情報はイメージの説明(代替テキスト)になります。
  •  
    ブール イメージまたは値
    はい/いいえ
  •  
    数、式、または仮想アイコン列(イメージ、信号、値、または範囲の説明など)
    最大 3 列: 1 つが値(数字)、1 つが範囲の説明、そしてもう 1 つが信号が表示された場合に背景色のある狭い列。 式自身ではなく実際の値がエクスポートされます。
  •  
    日付
     
    Excel へのエクスポートでは、日付は MM-DD-YYYY 形式で表示されます。 ロケール設定は適用されません。 CSV へのエクスポートでは、日付の書式設定が保持されます。 エクスポートされた日付は、現在選択されたロケールの形式で表示されます。
  •  
    金額
     
    2 列: 数値と通貨コード。 小数点以下の桁数の正しい値が保存されます。
  •  
    仮想ガント主バー データ
    3 列: 項目名、開始日、終了日、さらに、すべてが 1 つのグループであることを示す[ガント]図列見出し接頭辞
  •  
    仮想ガント二次バー データ
    3 列: 項目名、開始日、終了日、さらに、列が 1 つのグループであることを示す[ガント]列見出し接頭辞 また見出し接頭辞は、列が主バーとは異なることを示します。
  •  
    仮想進捗状況バー
    3 列: 現在のステージ名、現在のステージ番号、ステージ数、さらに、列が 1 つのグループであることを示す[進捗ステータス]または[ステージ]列見出し接頭辞
  •  
    列見出し
     
    アプリケーションでは、この値が表示されます。
  •  
    二次値
     
    独立した列に表示されます。列見出しのタイトルは属性名です。
  •  
    期間単位値
     
    各タイム スライス(年数、月数、四半期、週数または日数)につき 1 列。 さらに、[ガント]列見出し接頭辞は、タイム スライスが 1 つのグループであることを示します。
  •  
    集計、比較、および差異行
     
    値または結果が行に表示されます。 値は灰色で表示され、対応する行見出しは表示されません。 集計値または比較値を選択すると、値の計算に使用された式が Excel の式バーに表示されます。
  •  
    属性で行をハイライト
     
    CA Clarity PPM でハイライトされた 2 行は、Excel ではハイライトされません。
Excel ファイルのエクスポート ルール
  • [Excel にエクスポート]アイコンが表示されない場合は、そのリストに制限が設定されています。
  • アクティブなエクスポートは、一度に 1 つしか実行できません。
  • フィルタ条件を適用した場合は、フィルタされた結果のみがエクスポートされます。
  • 第 1 レベル項目のみがエクスポートされます。
  • リストに表示されているフィールドのみがエクスポートされます。
  • ページに一覧表示されている項目のみがエクスポートされます。 複数のページが存在する場合は、これらのページを個別にエクスポートします。
  • グラフ(ガント図を含む)が存在する項目の場合、エクスポートできるのは最大 300 項目です。
  • エクスポートされた情報は、
    Clarity PPM
    で表示される形式で Excel または PowerPoint に表示されます。
  • [概要]ページなど、ポートレットを含む一部のページをエクスポートできます。 ポートレットのページをエクスポートできる場合は、エクスポート オプションが表示されます。
Excel (データのみ)および CSV ファイルのエクスポート ルール
  • アクティブなエクスポートは、一度に 1 つしか実行できません。
  • フィルタ条件を適用した場合は、フィルタされた結果のみがエクスポートされます。
  • 第 1 レベル項目のみがエクスポートされます。
  • リストに表示されているフィールドのみがエクスポートされます。
  • 最大 25,000 行のグラフなしのデータをエクスポートできます。 [Excel にエクスポートできる最大行数]フィールドを空のままにします。
  • ハイパーリンク付きのフィールドは、Excel の =HYPERLINK() 式を使用して書式設定します。 以下の例は、ハイパーリンク付きのプロジェクト フィールドがエクスポートされた CSV ファイルでどう表示されるかを示しています。
"=HYPERLINK("http://localhost/niku/nu#action:projmgr.projectProperties&id=5001023","Project_Name")
Excel および CSV へのエクスポートに関する問題のトラブルシューティング
エクスポート オプションをサポートするポートレットでは、最大 25,000 行のデータをエクスポートすることができます。 ただし、システム パフォーマンスの低下を回避するために、合理的な時間でエクスポートが完了できることがアプリケーションで確認されます。 配置された時間しきい値を超える時間がエクスポートで必要な場合は、エクスポートされた Excel ファイルに、タイムアウト メッセージが表示されます。 リストのボリュームと複雑さを抑えてみてください。 たとえば、フィルタを適用し、エクスポートを再度実行します。 長いリストの場合は、代わりにカスタム レポートを使用します。
Excel へのエクスポートの時間制限の仕組み
」を参照してください。
Clarity PPM
からエクスポートされた XLS ファイルを開くときに、Excel のユーザから以下のような Microsoft からのメッセージを見たという報告があるかもしれません。
 
 'my_file.xls' のファイルのフォーマットおよび拡張子が一致しません。 ファイルは、破損しているか、または安全ではありません。 ソース元を信頼する場合を除き、そのファイルを開かないでください。 それでもファイルを開きますか?
 
ファイルの送信元は
Clarity PPM
なので、ユーザは[
はい
]をクリックできます。
XLS ファイルをアップロードした後に Excel オンライン ユーザがそれを開こうとしたときに、以下のような Microsoft からのメッセージを見たという報告があるかもしれません。
 
  
 
ユーザのワークブックに認識できないデータがあります。 新しいバージョンの Excel のワークブックで開くまたは保存を試してください。
 
XLS ファイルに関するこれらのレガシーのセキュリティ問題については以下の解決策をとってください。
  • Excel クライアント アプリケーションでファイルを開き、XLS または XLSX としてそれを保存します。 (Excel Online でファイルを開くには、まず OneDrive または SharePoint にアップロードします。 ファイルをアップロードすると、Excel Online はファイルを検出して開きます。)
  • [Excel にエクスポート(データのみ)]
    ではなく
    [Excel にエクスポート]
    を使用します。 
  • ブラウザ ページから直接データをコピーし、別のアプリケーションに貼り付けてください。
  • XML Open Gateway (XOG) でデータをエクスポートしてください。
  • レポートを設計し、Excel、CSV または XLSX としてそれを保存してください。
  • 新しい[
    CSV へエクスポート
    ]オプションを使用します。 このオプションをサポートするグリッド ポートレットでは、最大 25,000 行のデータをカンマ区切り値 (CSV) 形式でエクスポートできます。 CSV形式は、Microsoft Excelと、その他幅広い、データベース、分析、レポート、および生産性ソフトウェアで認識されます。
Excel へのエクスポートの時間制限の仕組み
過剰な表示条件を含む可能性がある、最大 25,000 行のデータをエクスポートすると、要求の実行時間が長くなる場合があります。 たとえば、1 秒あたりの 3 つの行を処理する場合でも、20,000 を超える行のエクスポートには 2 時間以上かかる場合があります。 パフォーマンスの低下を緩和するために、システムは低速のエクスポート操作を中止しようとします。
以下の手順では、Excel へのエクスポートの仕組みについて説明します。
  1. governors.properties
    ファイル(オンプレミス)または PPM 環境設定(SaaS)で、既定の E2E_TIMER 設定は 600 秒(10 分)になっています。
  2. ユーザは
    [Excel にエクスポート(データのみ)]
    をクリックして Excel への PPM データのエクスポートを開始します。
  3. 約 1 分の行のクエリ処理の後に、システムによって行のサンプルが評価され、決定が行われます。
    1. システムが時間制限内(600 秒、10% の柔軟性マージンを持つ)でエクスポートを完了できると、処理が続行されます。 
      Clarity PPM
      が、有効な Excel スプレッドシート ファイルを生成します。
    2. エクスポートの予想時間が時間制限を超えた場合、
      Clarity PPM
      は、パフォーマンスの低下を回避するために操作を停止します。
      •  
        Clarity PPM
        は、エクスポート操作をフラッシュし、ワークシートの上部に以下のタイムアウト メッセージを含む、空のスプレッドシートを生成します。
        システムによって、Excel へのこのエクスポートの完了に 90 分かかると判断されました。これは許可されている時間数を超えています。 システムによって操作が停止されました。
      • ユーザ インターフェースには、エラー メッセージは表示されません。
      •  
        Clarity PPM
        は、
        app-ca.log
        ファイルで警告メッセージを出します。
        e2e 操作は中止されました E2E 最大時間制限値の規定内でこの操作を完了できません
         
[お気に入り]メニューを使用すると、毎日使用するリンクを保存できます。 この製品のどのページでもお気に入りとして保存できます。 これらのお気に入りは
Clarity PPM
ページに固有であり、ブラウザのお気に入りとは異なります。 ページ リンク、アクション リンク、およびメニュー セクションを追加して、お気に入りを整理することもできます。
お気に入りとしてページを保存するには、そのページを開き、
[お気に入り]
メニューを選択して
[現在を追加]
をクリックします。
[お気に入り]メニューにカスタム ページ リンクを追加できます。
 
以下の手順に従います。
 
  1. お気に入り
    ]を開き、[
    設定
    ]をクリックします。
  2. [追加]
    をクリックします。
  3. [ページ リンク]を選択し[次へ]をクリックします。
  4. 要求された情報を入力します。
    •  
      リンク名
       
      ページ リンクを指定するために使用するラベルを定義します。 この名前は、
      MyFavoritePage
      MyProjectList
      など、[お気に入り]メニューに表示されます。
    •  
      説明 
       
      セクションまたはページ リンクの目的を定義します。
    •  
      ページ名 
       
      [お気に入り]メニューでこのリンクをクリックすると表示されるページを指定します。
    •  
      親メニュー項目 
       
      このリンクが表示される[お気に入り]メニューの下にあるサブメニューを指定します。
  5. 変更を保存します。
[お気に入り]メニューにアクション リンクを追加できます。 アクション リンクをクリックすると、指定したアクションが発生します。
 
以下の手順に従います。
 
  1. お気に入り
    ]を開き、[
    設定
    ]をクリックします。
  2. [追加]
    をクリックします。
  3. アクション リンク
    ]を選択し、[
    次へ
    ]をクリックします。
  4. 要求された情報を指定します。 以下のフィールドには説明が必要です。
    •  
      リンク名
       
      アクションのリンクの名前を定義します。 このリンク名は、メニューで表示されるラベルです。
    •  
      アクション名
       
      リンクをメニューでクリックしたときに実行されるアクションを指定します。
    •  
      親メニュー項目
       
      リンクが表示されるセクションを指定します。
  5. 変更を保存します。
お気に入りメニュー セクションの追加。
保存したお気に入りページを編成できるように、[お気に入り]メニューにセクションを追加することができます。
 
以下の手順に従います。
 
  1. お気に入り
    ]を開き、[
    設定
    ]をクリックします。
  2. [追加]
    をクリックします。
  3. セクション
    ]を選択し、[
    次へ
    ]をクリックします。
  4. 要求された情報を指定します。
  5. 変更を保存します。
メニューの並べ替えセクション
お気に入り
]メニュー内のセクションおよびリンクを並び替えることができます。
 
以下の手順に従います。
 
  1. お気に入り
    ]を開き、[
    設定
    ]をクリックします。
  2. 並べ替え
    ]をクリックします。
  3. [メニュー項目]リスト内のセクションを選択し、矢印をクリックして、そのセクションを新しい位置に移動させます。
  4. 変更を保存します。
変更がメニューに反映されない場合は、
[更新]
ボタンをクリックしてください。
メニュー セクション、ページ リンク、またはアクション リンクを削除できます。 自分で作成したセクションまたはリンクのみ削除できます。
Clarity PPM
の既定のセクションまたはリンクを削除することはできません。
セクションまたはリンクを削除するには、[お気に入り]を開き、[設定]をクリックし、セクションまたはリンクを選択して削除します。