Upgrade From v5.4.* to 5.4.9 or later

Most changes are to the various masking and subset programs. Therefore for an upgrade it is typically valid to update only the following two libraries:
tdm49
This article applies to all service packs of v5.4 of the Mainframe installers on support.broadcom.com. Most changes are to the various masking and subset programs. Therefore for an upgrade it is typically valid to update only the following two libraries:
  • HLQ.LIB.DBRM
  • HLQ.LOADLIB
HLQ is the High Level Qualifier where you have installed your CA TDM mainframe product.
These two libraries HLQ.LIB.DBRM and HLQ.LOADLIB have changed from PDS to PDSE, as part of the CA Endevor process. The remaining libraries are still PDS for the time being.
To perform the update:
  1. Back up the existing libraries, for example, by renaming them.
    • HLQ.LIB.DBRM
    • HLQ.LOADLIB
  2. Allocate the XMI file (HLQ.XMI) with DCB properties:
    (RECFM=FB, LRECL=80, BLKSIZE=3120, SPACE>10 CYL)
  3. Allocate the HLQ.LOADLIB PDSE with DCB properties:
    (DSNTYPE=LIBRARY RECFM=U, LRECL=0, BLKSIZE=27998, SPACE>250 BLOCKS)
  4. Allocate the HLQ.LIB.DBRM PDSE with DCB properties:
    (DSNTYPE=LIBRARY RECFM=FB, LRECL=80, BLKSIZE=32720, SPACE>7 BLOCKS)
  5. Binary FTP the libload.xmi file into the HLQ.XMI file.
  6. Receive the loadlib file by:
    TSO Option 6:
    RECEIVE INDSN('HLQ.XMI')
    DA ('HLQ.LOADLIB')
  7. Binary FTP the libdbrm.xmi file into the HLQ.XMI file:
  8. Receive the dbrm file by:
    TSO Option 6:
    RECEIVE INDSN('HLQ.XMI')
    DA ('HLQ.LIB.DBRM')
  9. Bind the new versions of the programs by executing JCL HLQ.LIB.RUNJCL(BIND).
  10. Re-load the messages VSAM file by executing HLQ.LIB.RUNJCL(MSGLOAD).
  11. Test the programs.