Enhancements

This release includes all cumulative maintenance up to 6.0.1 plus the following enhancements:
This release includes all features and cumulative maintenance up to 6.0.0 plus the following new features and enhancements
  • Added support for a TLS1.2 encrypted connection between AAI and a Microsoft SQL Server database.
  • Improved prediction engine performance.
  • Improved batching of deletes during the automated database maintenance processing.
  • Added an
    examples
    folder in the root of the AAI installation with examples of Rest API calls for Subscription Services.
  • The next generation web user interface (i.e.
    http://localhost:8080/termawebui
    ) is available by default. System parameter changes no longer required to enable!
AutoSys
  • Added support for user-specified initial state for a new AutoSys job
IWS
  • Improved support for custom start time conditions for IWS
  • Improved handling of latencies for IWS schedulers
IWSz
  • Improved prediction for IWSz jobstreams
  • Added additional support for run cycle groups
  • Added support for
    Maximum Jobstream Run Duration
    . This option limits job runs in a jobstream run to those runs within the given time duration preceding the end of a target job run
  • Added a system parameter (
    customConditionGenConnTimeout
    (default=60)) to allow the timeout value for Custom Condition Generator Rest API calls to be configured
Additional Security Vulnerabilities Resolved
Resolved by upgrading jackson-databind to 2.9.10.3
CVE-2018-14718
CVE-2019-14379
CVE-2019-17267
CVE-2019-16335
CVE-2018-14719
CVE-2019-14540
CVE-2019-20330
CVE-2019-16942
CVE-2018-14720
CVE-2019-14892
CVE-2020-8840
CVE-2019-16943
CVE-2018-14721
CVE-2019-14893
CVE-2019-14379
CVE-2019-17267
CVE-2018-19360
CVE-2019-16335
CVE-2019-14540
CVE-2019-20330
CVE-2018-19361
CVE-2019-16942
CVE-2019-14892
CVE-2020-8840
CVE-2018-19362
CVE-2019-16943
CVE-2019-14893
Resolved by upgrading spring-webmvc to 4.3.15
CVE-2018-1270
CVE-2018-1275
Resolved by upgrading xstream to 1.4.12
CVE-2013-7285
CVE-2019-10173
Resolved by upgrading netty to 4.0.56.Final
CVE-2016-4970
Resolved by upgrading jython to 2.7.2
CVE-2016-4000
Resolved by removing xmllib
CVE-2020-8492