Upgrade Requirements and Considerations

Before you upgrade, review the following information to ensure that you have met all the requirements.
Before you upgrade, review the following information to ensure that you have met all the requirements:
For cloud environments, see Rehydrating Data in a Cloud Environment.
Operating System Requirements
To ensure that you successfully upgrade
DX NetOps Performance Management
, verify that your environment meets the operating system requirements. To verify the sizing requirements, use the
DX NetOps Performance Management
Sizing Tool
.
DX NetOps Performance Management
supports the following operating systems and versions unless otherwise specified:
Operating System
Tested
Should work
Notes
Red Hat Enterprise Linux (RHEL)
RHEL 6.6
RHEL 6.7
RHEL 6.8
RHEL 6.9
RHEL 6.10
RHEL 7.3
RHEL 7.4
RHEL 7.5
RHEL 6.6 and above/7.3 and above
  • RHEL installations offer packages and add-ons.
    DX NetOps Performance Management
    supports a minimal install environment for RHEL.
  • If you have installed
    DX NetOps Performance Management
    components on unsupported RHEL versions, you must upgrade the operating system
    before
    upgrading the
    DX NetOps Performance Management
    components. You might also need to move the
    DX NetOps Performance Management
    components, including configurations, customizations, and data, from one system to another system.
    For more information, see Plan the Upgrade or Migration.
Oracle Linux (OL)
OL 7.3 (Red Hat-compatible kernel version only)
OL 7.3 (kernel version 3.10.0-514)
OL 7.x
SUSE Linux Enterprise Server (SLES)
SLES 12 SP2 (SLES 12.2) kernel version 4.4.103
SLES 12 SP2/3/4/5
Package Requirements
For more information about the packages that the installer for each component requires, see Installation Requirements and Considerations
Sudo User Installations
For systems without root access, you can install and run the software using a sudo user account. Add the
sudo
prefix to commands to upgrade the components. Verify that your sudo accounts contain the correct permissions for each component.
For more information, see the sudo user configuration details for each component:
Back Up
DX NetOps Performance Management
Before you begin the upgrade process, back up all aspects of the product:
Low-Scale Systems
For a low-scale system where the data collector shares a host with the data aggregator, complete the configuration to enable the components to run on the same host.
For more information, see Install a Low-Scale System.
CA Business Intelligence
Integrations
If you have an existing
CA Business Intelligence
(CABI) integration,
DX NetOps Performance Management
20.2 supports CABI 6.4.2 and higher.
After you upgrade to a supported CABI version, you must re-install your CABI content.
For more information, see Install CA Business Intelligence Reports and Dashboards.
ActiveMQ Versions
To minimize data loss when you upgrade your data collectors, ActiveMQ continues to run unless you upgrade its version with the release.
The following
DX NetOps Performance Management
releases correspond with the following ActiveMQ versions:
DX NetOps Performance Management
ActiveMQ
3.2
5.13.1
3.5, 3.6
5.15.2
3.7, 20.2
5.15.8
NetOps Upgrade Considerations
Retired and replacement devices coming from
DX NetOps Network Flow Analysis
can exist in
NetOps Portal
. If your system is integrated with
DX NetOps Network Flow Analysis
, upgrade
DX NetOps Virtual Network Assurance
along with
DX NetOps Performance Management
to ensure that items monitored by both the data aggregator and
DX NetOps Virtual Network Assurance
are properly reconciled when Lifecycle changes occur.
Review the Known Limitations
To ensure that your system runs successfully after the upgrade, review the
DX NetOps Performance Management
limitations.
For more information, see Known Limitations.