System Requirements for Installing CA Spectrum

Contents
casp941
Contents
Windows System Requirements
Windows Support
The following table summarizes 
 support for Microsoft Windows operating systems:
Operating System
SpectroSERVER
OneClick Server
OneClick Client
CABI Version*
Windows Server 2008 SP2
(32-bit and 64-bit)
Yes
Yes
Yes
(32-bit or 64-bit JRE)
r3.3 and r3.3 SP1
Windows Server 2008 R2 SP1
(64-bit)
Yes
Yes
Yes
(32-bit or 64-bit JRE)
r3.3 and r3.3 SP1
Windows Server 2012
Yes
Yes
Yes
(32-bit or 64-bit JRE)
No
Windows Vista
(32-bit and 64-bit)
No
No
Yes
(32-bit or 64-bit JRE)
No
Windows 7
(32-bit and 64-bit)
No
No
Yes
(32-bit or 64-bit JRE)
No
Windows 8
(32-bit and 64-bit)
No
No
Yes
(32-bit or 64-bit JRE)
No
Report Manager uses CABI r3.3 as the report delivery engine. 
For information on the platforms that CABI r3.3 supports, see the Supported Platforms document that is delivered with the CABI r3.3 installation media.
SpectroSERVER
 and OneClick Server Requirements for Windows
The following table lists the system requirements for 
SpectroSERVER
 and OneClick server on Windows platforms:
Component
Requirement
Operating System
Windows Server 2008 SP2 (32-bit and 64-bit)
Windows Server 2008 R2 SP1 (64-bit)
Windows Server 2012 (64-bit)
Windows Server 2012 R2 (64-bit)
Memory (RAM)
Dependent on the configuration and number of managed devices
Processor
Dependent on the configuration and number of managed devices
Disk Space
Dependent on the configuration and number of managed devices
Video System
Video card that supports 32-bit color at 1024x768 pixel resolution
20" monitor or larger
PDF Document Viewer
Acrobat Reader X or later.
Do not set your foreground font color to white. If this font color is set to white, you cannot read the text on your screen during the installation.
OneClick Client Requirements for Windows
The following table lists the OneClick client requirements for Windows platforms:
Component
Requirement
Operating System
Windows Server 2008 SP2
Windows Server 2008 R2 SP1
Windows Server 2012
Windows Server 2012 R2
Windows Vista
Windows 7
Windows 8
Memory (RAM)
Dependent on the configuration and number of managed devices
Processor
Dependent on the configuration and number of managed devices
Disk Space
Dependent on the configuration and number of managed devices
Java Components
For CA Spectrum 9.4.1, 9.4.2, 9.4.2.1 and 9.4.2.2:
 Java 2 Runtime Environment (JRE) version 1.7.0_67 (32-bit or 64-bit) or later, and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
JCEUnlimited Strength Files available with CA Spectrum 9.4.1, 9.4.2, 9.4.2.1, and 9.4.2.2 are compatible with JRE 7 only. If you are already on JRE 7, place the JCEUnlimited Strength Files in the JRE version 7. If you are not on JRE 7, install JRE 7 first and then place JCEUnlimited Strength Files in JRE 7. For more information, see Install JRE and JCEUnlimited Strength Files.
For CA Spectrum 9.4.3:
Java 2 Runtime Environment (JRE) version 1.8.0_31 (32-bit or 64-bit), and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
JCEUnlimited Strength Files available with CA Spectrum 9.4.3 are compatible with JRE 8 only. If you are already on JRE 8, place the JCEUnlimited Strength Files in the JRE version 8. If you are not on JRE 8, install JRE 8 first and then place JCEUnlimited Strength Files in JRE 8. For more information, see Install JRE and JCEUnlimited Strength Files.
For CA Spectrum 9.4.3.1:
 Java 2 Runtime Environment (JRE) version 1.8.0_31 (32-bit or 64-bit), and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
For CA Spectrum 9.4.4:
 Java 2 Runtime Environment (JRE) version 1.8.0_92 (32-bit or 64-bit), and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
Web Browser
Firefox 10.0 or later (the latest version verified is Firefox 39.0)
Internet Explorer 8.0 or later (the latest version verified is IE 11.0)
Note
: Internet Explorer 10 and later versions entail some special requirements. For more information, see OneClickConsiderations.
Linux System Requirements
Linux Support
The following table summarizes 
 support for Linux operating systems:
Operating System
SpectroSERVER
OneClick Server
OneClick Client
CABI Version*
Red Hat® Enterprise Linux® 5.x
(32-bit and 64-bit)
Yes
Yes
Yes
(32-bit or 64-bit JRE)
r3.3 and r3.3 SP1
Red Hat Enterprise Linux 6.x
(32-bit and 64-bit)
Yes
Yes
Yes
(32-bit or 64-bit JRE)
r3.3 and r3.3 SP1
Report Manager uses CABI r3.3 SP1 as the report delivery engine. 
For information on the platforms that CABI r3.3 supports, see the Supported Platforms document that is delivered with the CABI r3.3 installation media.
SpectroSERVER
 and OneClick Server Requirements for Linux
The following table lists the system requirements for 
SpectroSERVER
 and OneClick server on Linux platforms:
Component
Requirement
Operating System
Red Hat Enterprise Linux 5.x (32-bit and 64-bit)
Red Hat Enterprise Linux 6.x (32-bit and 64-bit)
X-based desktop environment (such as KDE or GNOME)
Memory (RAM)
Dependent on the configuration and number of managed devices
Processor
Dependent on the configuration and number of managed devices
Disk Space
Dependent on the configuration and number of managed devices
Graphical User Interface
Motif (32-bit).
Note:
Motif is not required for a distributed installation.
Video System
Video card that supports 32-bit color at 1024x768 pixel resolution
20" monitor or larger
PDF Document Viewer
Acrobat Reader X or later
Packages
See "Required Packages," below.
Do not set your foreground font color to white. If this font color is set to white, you cannot read the text on your screen during the installation.
Required Packages
For purposes of identification, 32-bit RPMs for Red Hat Enterprise Linux contain "i386" or "i686". The 64-bit RPMs contain "x86_64".
 
For Red Hat Enterprise Linux 5.x and 6.x servers (32-bit or 64-bit), install the following RPMs and any dependencies:
openmotif
elfutils-libelf
libaio (required for MySQL v5.5, the MySQL version for the database)
 
For Red Hat Enterprise Linux 5.x or 6.x (32-bit or 64-bit), other dependent RPM packages may be required:
glibc
nss-softokn-freebl
libICE
libSM
libX11
libXext
libXft
libXmu
libXp
libXrender
libXt
fontconfig
freetype
libjpeg
libpng
libuuid
libxcb
libXau
expat
zlib
libstdc++
libgcc
libXi
libXtst
ncurses
elfutils-libelf
xorg-x11-fonts-misc
 
For Red Hat Enterprise Linux 6.x (32-bit or 64-bit), the following RPM package may be required:
 
ncurses-lib
OneClick Client Requirements for Linux
The following table lists the OneClick client requirements for Linux platforms:
Component
Requirement
Operating System
Red Hat Enterprise Linux 5.x (32-bit and 64-bit)
Red Hat Enterprise Linux 6.x (32-bit and 64-bit)
X-based desktop environment (such as KDE or GNOME)
Memory (RAM)
Dependent on the configuration and number of managed devices
Processor
Dependent on the configuration and number of managed devices
Disk Space
Dependent on the configuration and number of managed devices
Graphical User Interface
X11 system that the JRE supports
Java Components
For CA Spectrum 9.4.1, 9.4.2, 9.4.2.1 and 9.4.2.2:
Java 2 Runtime Environment (JRE) version 1.7.0_67 (32-bit or 64-bit) or later, and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
JCEUnlimited Strength Files available with CA Spectrum 9.4.1, 9.4.2, 9.4.2.1 and 9.4.2.2 are compatible with JRE 7 only. If you are already on JRE 7, place the JCEUnlimited Strength Files in the JRE version 7. If you are not on JRE 7, install JRE 7 first and then place JCEUnlimited Strength Files in JRE 7. For more information, see Install JRE and JCEUnlimited Strength Files.
For CA Spectrum 9.4.3:
Java 2 Runtime Environment (JRE) version 1.8.0_31 (32-bit or 64-bit), and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
JCEUnlimited Strength Files available with CA Spectrum 9.4.3 are compatible with JRE 8 only. If you are already on JRE 8, place the JCEUnlimited Strength Files in the JRE version 8. If you are not on JRE 8, install JRE 8 first and then place JCEUnlimited Strength Files in JRE 8. For more information, see Install JRE and JCEUnlimited Strength Files.
For CA Spectrum 9.4.3.1:
Java 2 Runtime Environment (JRE) version 1.8.0_31 (32-bit or 64-bit), and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
For CA Spectrum 9.4.4:
Java 2 Runtime Environment (JRE) version 1.8.0_92 (32-bit or 64-bit), and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
Web Browser
Firefox 10.0 or later (the latest version verified is Firefox 39.0).
Solaris System Requirements
Solaris Support
The following table summarizes 
 support for Oracle Solaris operating systems:
Operating System
SpectroSERVER
OneClick Server
OneClick Client
CABI Version*
Solaris 10
Yes
Yes
For CA Spectrum 9.4.1, 9.4.2 and 9.4.2.1 - Yes For CA Spectrum 9.4.3 - Not supported
r3.3 and r3.3 SP1
Solaris 11
Yes
Yes
For CA Spectrum 9.4.1, 9.4.2 and 9.4.2.1 - Yes
For CA Spectrum 9.4.3 - Not supported
Not supported
Report Manager uses CABI r3.3 as the report delivery engine. 
For information on the platforms that CABI r3.3 supports, see the Supported Platforms document that is delivered with the CABI r3.3 installation media.
SpectroSERVER
 and OneClick Server Requirements for Solaris
The following table lists the system requirements for 
SpectroSERVER
 and OneClick server on Solaris platforms:
Component
Requirement
Operating System
Solaris 10 with CDE
Solaris 11
X-based desktop environment (such as GNOME)
Memory (RAM)
Dependent on the configuration and number of managed devices
Processor
Dependent on the configuration and number of managed devices
Disk Space
Dependent on the configuration and number of managed devices
Graphical User Interface
Motif (32-bit).
Note:
Motif is not required for a distributed installation.
Video System
24-bit color graphics system that supports 65000 colors at 1024x768 pixel resolution
20" monitor or larger
PDF Document Viewer
Adobe Reader X or later
Packages
See "Required Packages" and "Required Packages for
," below.
Patches (minimum version specified)
Solaris 10:
119963-04 SunOS 5.10: Shared library patch for C++
118833-36 SunOS 5.10: Kernel patch
119578-30 SunOS 5.10: FMA patch (required by 118833-36)
119042-09 SunOS 5.10: usr/sbin/svccfg patch (required by 118833-36)
Do not set your foreground font color to white. If this font color is set to white, you cannot read the text on your screen during the installation.
Required Packages
  • Solaris 10
  1. Install the following packages on the 
    SpectroSERVER
     and OneClick servers:
    SUNWdtwm
    SUNWdtbas
    SUNWzlib
  2. Update a Solaris 10 Sparc server with the latest patchset. Use the following links for downloading the patchsets and viewing their Readmes:
    • Log in to MOS to download the patchsets:
    • A login is not required to download the Readme files.
  • Solaris 11
  1. Install the following packages on the 
    SpectroSERVER
     and OneClick servers:
    SUNWxorg-client-programs
    SUNWarc
    SUNWhea
    SUNWsprot
    SUNWmfrun
  2. Run the following packages on your Solaris 11 console or terminal:
    pkg install SUNWxorg-clientlibs
    pkg install SUNWmfrun
Required Packages for 
  • Solaris 10
  1. Install the following packages on the Report Manager server:
    SUNWgzip
    SUNWscpu
    SUNWbash
    SUNWbcp
    SUNWxcu4
    SUNWxwfnt
    SUNWxwplt
    SUNWlibC
    SUNWeu8os
    SUNWeuluf
    SUNWuiu8
    SUNWulcf
    SUNWmfrun
    SUNWxwice
  • Solaris 11
  1. Install the following packages on the Report Manager server:
    SUNWgzip
    SUNWbash
    SUNWxwplt
    SUNWlibC
    SUNWuiu8
    SUNWmfrun
    SUNWxwice
OneClick Client Requirements for Solaris
The following table lists the OneClick client requirements for Solaris platforms:
Component
Requirement
Operating System
Solaris 10 with CDE
Solaris 11
X-based desktop environment (such as GNOME)
Memory (RAM)
Dependent on the configuration and number of managed devices
Processor
Dependent on the configuration and number of managed devices
Disk Space
Dependent on the configuration and number of managed devices
Graphical User Interface
X11 system that the JRE supports
Java Components
For CA Spectrum 9.4.1, 9.4.2, 9.4.2.1 and 9.4.2.2:
Java 2 Runtime Environment (JRE) version 1.7.0_67 (32-bit or 64-bit) or later, and JCEUnlimited Strength Files. These components are available for download from OneClick home page.
JCEUnlimited Strength Files available with CA Spectrum 9.4.1, 9.4.2, 9.4.2.1 and 9.4.2.2 are compatible with JRE 7 only. If you are already on JRE 7, place the JCEUnlimited Strength Files in the JRE version 7. If you are not on JRE 7, install JRE 7 first and then place JCEUnlimited Strength Files in JRE 7. For more information, see Install JRE and JCEUnlimited Strength Files.
For CA Spectrum 9.4.3, 9.4.3.1 and 9.4.4:
CA Spectrum 9.4.3 does not support Solaris to launch OneClick client. OneClick is a JNLP based application and JavaWS is required to launch it. Oracle does not ship JavaWS with Java 8 for Solaris.
Web Browser
Firefox 10.0 or later (the latest version verified is Firefox 39.0).
System Configurations
The configuration tables in this section provide guidelines for running
at peak efficiency. You can achieve optimal system performance when all system resources are robust enough that a single resource does not limit the others. System resources include memory, processor speeds, and disk space.
Consult your support or sales representative for more help in determining the best configuration for your network.
You cannot define all configurations and system requirements for all users because of the following complexities and variables:
  • Polling frequency
  • Device types
  • Number of devices in a network
Installing OneClick on a single-CPU
SpectroSERVER
host system can degrade the performance of both
SpectroSERVER
and OneClick. To maximize the performance of both, we recommend that you install OneClick on a separate, dedicated computer. If you upgrade
SpectroSERVER
components, you might also need to upgrade OneClick.
SpectroSERVER
and OneClick
The following table lists the system configurations necessary for
SpectroSERVER
and OneClick.
The following table assumes that each
SpectroSERVER
manages fewer than 1000 devices with an average of 24 ports on each device.
Component
Platform
SpectroSERVER
Only
OneClick Only
SpectroSERVER
and OneClick
Memory (RAM)
Windows, Solaris, and Linux
4 GB Minimum
8 GB Recommended
2 GB Minimum
4 GB Recommended
4 GB Minimum
8 GB Recommended
Processor
Windows and Linux
2+ Ghz dual processor
2+ Ghz dual processor
2.5+ Ghz dual processor
 
Solaris
Non Intel-based processor
Non Intel-based processor
Non Intel-based processor
Disk^°
Windows, Solaris, and Linux
2 separate drives; SCSI 10,000 RPM
2 separate drives; SCSI 10,000 RPM
2 separate drives; SCSI 10,000 RPM
^ Disk Drives: For optimum performance, run
on systems with at least two ultra-wide, 10,000 RPM, SCSI disk drives. Disk1 = OS + swap space/virtual memory. Disk2 = all
SpectroSERVER
/OneClick components.
° Swap/Virtual Memory: Set the amount of swap space/virtual memory to either twice the amount of physical memory, or 4 GB, whichever value is lower.
OneClick with Report Manager
The following table lists the system configuration for OneClick with Report Manager running in the environment.
Component
Platform
OneClick with Report Manager
Memory (RAM)
Windows, Solaris, and Linux
4 GB Minimum
8 GB Recommended
Processor
Windows and Linux
2.5+ Ghz dual processor
 
Solaris
Non Intel-based processor
Disk°†
Windows, Solaris, and Linux
2 separate drives; SCSI 10,000 RPM
We highly recommend a separate, dedicated system for Report Manager. However, coinstallation with OneClick is also supported.
ª Assumes that Report Manager is monitoring the
SpectroSERVER
(polling for event data and asset change data). Otherwise, 1536 MB is acceptable.
^ Or any comparable Intel x86 1.5 GHz or better processor.
° Disk Drives: For optimum performance, run
on systems with at least two ultra-wide, 10K RPM, SCSI disk drives. Disk1 = OS + swap space/virtual memory. Disk2 = all OneClick/Report Manager components.
† Swap/Virtual Memory: Set the amount of swap space/virtual memory to either twice the amount of physical memory, or 4 GB, whichever value is lower.
System Support and Setup Considerations
  • Virtualization Environments
supports the following virtualization environments:
    • Solaris Zones
    • VMware for Windows and Linux
      For information about CA VMware guidelines, see Virtualization.
  • Rule of Localization Homogeneity
The
Rule of Localization Homogeneity
states that all components in a distributed
installation must run on servers that use the same operating system Locale. Think of
as one application running with one language, rather than as a set of distributed services potentially running different languages.
By following the
Rule of Localization Homogeneity
, you ensure that all access and modification of data through different communication paths use one consistent language. Otherwise, myriad languages can be stored in the
database. The multiple languages cause problems with such data issues as display, fonts, searching, and sorting.
We recommend that you set the Locale on the servers that run
processes before you install
. Such servers include the Location server, Processd,
SpectroSERVER
s, OneClick servers, clients, and the Secure Domain Manager.
  • Disk Striping and RAID
For optimum performance, you can run
on systems with multiple, ultrawide, 10k rpm, SCSI disk drives that use disk striping or RAID (redundant array of independent disks) technologies.
Disk striping is a technique of spreading data over multiple disk drives. RAID is a disk drive system that uses two or more drives in combination for fault tolerance and performance improvement.
  • Symantec pcAnywhere
    Symantec pcAnywhere™ can cause Java to lock and prevent Java applications from launching. Java applications include OneClick Console,
    Control Panel, Model Type Editor, and Performance View. The processes start, but the GUIs do not launch. If you stop pcAnywhere, the Java-based applications launch and the GUIs display correctly.
    To resolve this issue, install or upgrade to DirectX version 9.0 B, which is available at http://support.microsoft.com.
    Alternatively, you can stop the pcAnywhere Host Service before installation. After you install
    and OneClick, you can enable the pcAnywhere Host Service again.
  • Antivirus Software and Data Backup
does not include antivirus software. We recommend installing your preferred antivirus software to protect your networking environment.
To avoid database corruption, exclude
installation areas and
files from scans by any local or remote instances of antivirus software.
installation areas include OneClick and Report Manager installation areas.
Exclude all
installation areas, including OneClick and Report Manager installation areas, from scans by data backup programs.
OneClick Considerations
OneClick consists of a web server-based component and a client-based component, each of which requires different software. The OneClick web server includes the following items:
  • Apache Tomcat servlet engine
  • MySQL database management system
  • Java 2 Software Development Kit (SDK)
    supports only the version of the JDK that ships with OneClick.
The OneClick client includes the following items:
  • Java Runtime Environment (JRE) with Java Web Start and JCEUnlimited Strength Files
If Microsoft Internet Explorer version 10 is installed on the OneClick clients, set the browser security level to medium-low to avoid security-related issues. Or, if the Internet Explorer 10 security level is high, be sure to add the OneClick website to the list of Trusted Sites.
By default, the OneClick website is automatically run in Compatibility Mode if the OneClick web server is installed within an intranet. In Internet Explorer 10, intranet sites run in Compatibility Mode by default. Run Internet Explorer 10 in Compatibility Mode to support the
- CA Service Desk Manager integration and
. For more information, consult the Microsoft website.
OneClick and Report Manager Considerations
If you are installing OneClick with Report Manager, see the Install Report Manager
 
for installation information.
OneClick and Service Manager Considerations
If you are installing OneClick with Service Manager, the following considerations apply:
  • Service Manager must be installed on the computer where the
    SpectroSERVER
    is installed
    and
    on the computer where OneClick is installed. The modeling catalog and all modeling intelligence exist within the
    SpectroSERVER
    database. The historical database and event handling code exist on the OneClick web server, which is installed with OneClick.
  • We recommend that you also install Service Manager when you install Report Manager with OneClick. Installing these components together ensures that the Service and SLA Reporting tables are populated.
For more information about Service Manager, see .