CA UIM Compatibility Matrix

uim203
HID_UIM_Matrix
Compatibility Matrix
This section highlights the compatibility for the UIM components.
Component
OC 20.3.3
OC 20.3.2
OC 20.3.1
OC 20.3
UMP 20.1
UMP 9.0.2
UIM 20.3.3
yes
x
x
x
x
x
UIM 20.3.1
x
yes
yes
x
x
x
UIM 20.3
x
x
x
yes
x
x
UIM 20.1
x
x
x
x
yes
x
UIM 9.0.2
x
x
x
x
x
yes
  • UIM 20.3.1 is a patch release over UIM 20.3.0. The UIM 20.3.1 patch does not include any upgrade installer for the UIM Server. The patch includes the OC upgrade installer along with the separate standalone artifacts that you can use to upgrade the respective components to 20.3.1. For more information about the artifacts that are available as a part of the UIM 20.3.1 patch release, see the UIM 20.3.1 article.
  • OC 20.3.2 is a patch release. For more information about OC 20.3.2, see the OC 20.3.2 Patch article.
  • For more information about the UIM 20.3.3 release, see the UIM 20.3.3 article.
Component Support Matrix
Operating Systems
Browsers
2
Databases
Java JRE
Windows (64-bit)
Linux (64-bit)
Edge
Firefox
Chrome
Oracle
MySQL
MSSQL
UIM/OC 20.3.3
2012, 2012 R2, 2016, 2019
SLES 11, SLES 12.x, SLES 15, OpenSuse 12, OpenSuse 13, Red Hat 6, Red Hat 7.x, Red Hat 8, CentOS 6, CentOS 7, CentOS 8.x
79
2
Version 80 or higher
Version 85 or higher
12
19
5.6 (Enterprise Edition)
5.7 (Enterprise Edition)
2012
4
2014
4
2016
4
2017
2019
Java 8
UIM/OC 20.3.1 (and OC 20.3.2)(Patch)
5
2012, 2012 R2, 2016, 2019
SLES 11, SLES 12.x, SLES 15, OpenSuse 12, OpenSuse 13, Red Hat 6, Red Hat 7.x, Red Hat 8, CentOS 6, CentOS 7, CentOS 8.x
79
2
Version 80 or higher
Version 85 or higher
12
19
5.6 (Enterprise Edition)
5.7 (Enterprise Edition)
2012
4
2014
4
2016
4
2017
Java 8
UIM/OC 20.3
2012, 2012 R2, 2016, 2019
SLES 11, SLES 12.x, SLES 15, OpenSuse 12, OpenSuse 13, Red Hat 6, Red Hat 7.x, Red Hat 8, CentOS 6, CentOS 7, CentOS 8.x
79
2
Version 80 or higher
Version 85 or higher
12
19
5.6 (Enterprise Edition)
5.7 (Enterprise Edition)
2012
4
2014
4
2016
4
2017
Java 8
UIM/UMP 20.1
2012, 2012 R2, 2016, 2019
SLES 11, SLES 12.x, SLES 15, OpenSuse 12, OpenSuse 13, Red Hat 6, Red Hat 7.x, Red Hat 8, CentOS 6, CentOS 7
79
2
Version 60 or higher
Version 65 or higher
12
19
5.6 (Enterprise Edition)
5.7 (Enterprise Edition)
2012
4
2014
4
2016
4
2017
Java 8
UIM/UMP 9.2.0
2012, 2012 R2, 2016
SLES 11, SLES 12.x, OpenSuse 12, OpenSuse 13, Red Hat 6, Red Hat 7.x, CentOS 6, CentOS 7
79
2
Version 35 or higher
Version 45 or higher
11.2
12
5.6 (Enterprise Edition)
5.7 (Enterprise Edition)
2012
4
2014
4
2016
4
2017
Java 8
UIM/UMP 9.0.2
2012, 2012 R2, 2016
SLES 11, SLES 12.x, OpenSuse 12, OpenSuse 13, Red Hat 6, Red Hat 7.x, CentOS 6, CentOS 7
79
2
Version 35 or higher
Version 45 or higher
11.2
12
5.6 (Enterprise Edition)
5.7 (Enterprise Edition)
2012
4
2014
4
2016
4
2017
Java 8
  1. UIM supports the minor version for a supported major version.
  2. The Operator Console is certified on Chromium based Microsoft Edge.
  3. The CABI TLS v1.2 feature available with cabi probe 4.10 bundled supports TLS v1.2 when communicating with the CA UIM database: Microsoft SQL Server - 2012, 2014, 2016
    7
    , and Oracle - 11.2 and 12.1. Note that UIM 20.1 (and later) do not support Oracle 11.2.
  4. The CABI TLS v1.2 feature is not supported for Microsoft SQL Server 2012, 2014, and 2016 when installed on Windows Server 2016.
  5. UIM 20.3.1 is a patch release over UIM 20.3.0. The UIM 20.3.1 patch does not include any upgrade installer for the UIM Server. The patch includes the OC upgrade installer along with the separate standalone artifacts that you can use to upgrade the respective components to 20.3.1. For more information about the artifacts that are available as a part of the UIM 20.3.1 patch release, see the UIM 20.3.1 article.
  6. OC 20.3.2 is a patch release. For more information about OC 20.3.2, see the OC 20.3.2 Patch article.
  7. For more information about the UIM 20.3.3 release, see the UIM 20.3.3 article.
Robot Support Matrix
Supported Operating Systems
Robot 7.96
Robot 7.97
Robot 9.20
Robot 9.20S
Robot 9.30
Robot 9.30S
Robot 9.31
Robot 9.31S
Robot 9.32
Robot 9.32S
Robot 9.33
Robot 9.33S
UIM 9.0.2
UIM 9.0.2
UIM 9.2.0
UIM 9.2.0
UIM 20.1.0
UIM 20.1.0
UIM 20.3.0
UIM 20.3.0
UIM 20.3.1
UIM 20.3.1
UIM 20.3.3
UIM 20.3.3
AIX
PowerPC 64 6.1
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
PowerPC 64 6.2
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
PowerPC 64 7.0
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
PowerPC 64 7.1
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
PowerPC 64 7.2
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
HPUX
11.3 (IA64)
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
Linux
Amazon Linux 2
x
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
CentOS 6 x86_32
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
CentOS 6 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
CentOS 7 x86_32
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
CentOS 7 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
CentOS 8 x86_32
x
x
x
x
yes
x
yes
x
yes
x
yes
x
CentOS 8 x86_64
x
x
x
x
yes
yes
yes
yes
yes
yes
yes
yes
Debian 8 x86_32
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Debian 8 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Debian 9 x86_32
x
x
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Debian 9 x86_64
x
x
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
OpenSuse12 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
OpenSuse13 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
OpenSuse15 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
RHEL 6 x86_32
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
RHEL 6 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
RHEL 7.x x86_32
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
RHEL 7.x x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
RHEL 8 x86_64
x
x
x
x
yes
yes
yes
yes
yes
yes
yes
yes
SLES 11 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
SLES 12.x x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
SLES 15 x86_64
x
x
x
x
yes
yes
yes
yes
yes
yes
yes
yes
SUSE 11 x86_32
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
SUSE 11 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
SUSE 12 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
SUSE 12.x x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Ubuntu 14 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Ubuntu 16 x86_64
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Ubuntu 18.04 x86_64 LTS
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
Ubuntu 20.04 LTS (Intel 64-bit)
x
x
x
x
x
x
x
x
x
x
yes
yes
PowerPC 64 Little-endian (ppc64le)
RHEL 7.x
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
SUSE 12.x
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
Solaris
SPARC64 10
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
SPARC64 11
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
x86 10
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
x86 11
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
x86_64 10
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
x86_64 11
yes
yes
yes
x
yes
x
yes
x
yes
x
yes
x
Windows
10 64-bit
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
2012 64-bit
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
2012 R2 64-bit
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
2016 64-bit (Essentials, Standard, Datacenter)
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
2019 64-bit (Essentials, Standard, Datacenter)
x
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
zLinux
RHEL 6
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
RHEL 7.x
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
RHEL 8
x
x
x
x
yes
yes
yes
yes
yes
yes
yes
yes
SLES 11
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
SLES 12.x
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
SLES 15
x
x
x
x
yes
yes
yes
yes
yes
yes
yes
yes
  1. Secure robot is supported only on Linux x64-bit and Windows x64-bit environments.
  2. UIM supports the minor version for a supported major version.
  3. In CA UIM 20.3.0, robot installation on ppc64le through ADE is not supported.
Supported Operating System
Robot 5.50
Robot 5.71
Robot 5.73
Robot 5.77*
IBM i (Previously known as OS/400, AS/400, and i
5/OS
)
7.1
yes
yes
yes
yes
7.2
yes
yes
yes
yes
7.3
yes
yes
yes
yes
  1. IBM iRobot 5.77 contains only the robot_update. It does not contain the robot.
Automated Deployment Engine
Robot deployment using the Automated Deployment Engine (ADE) probe.
Deploy from ADE
Deploy to
Target System
Linux
Solaris
Windows
POSIX (AIX, HPUX, Linux, Solaris, zLinux)
Yes
Yes
Yes
Windows
Yes*
Yes*
Yes
*A Linux primary NMS hub can deploy Windows robots if the hub is a Windows hub. This enables the ADE to run Windows to Windows commands.