Additional Upgrade Deployments

Perform the following additional upgrade deployment tasks to ensure that you can use the latest functionality released after the CA UIM 9.0.2 release:
uim902-9-0-2
Perform the following additional upgrade deployment tasks to ensure that you can use the latest functionality released after the CA UIM 9.0.2 release:
 
 
Upgrade Robot and Hub to 7.97
We recommend that you upgrade to robot 7.97 and hub 7.97 so that you can take advantage of the following enhancements:
  • robot_update 7.97 and hub 7.97 have been updated to support the Microsoft Visual C++ Redistributable for Visual Studio 2017 package version 1.01 (vs2017_vcredist_x86 1.01 and vs2017_vcredist_x64 1.01). This support helps ensure that the minimum version of the VS 2017 package is equal to or greater than 1.01. With this dependency on version 1.01, the computer is no longer getting restarted automatically when installing the VS 2017 package. That is, with v1.01, no auto-restart of the computer happens.
    For more information about removing the dependency on the end-of-life (EOL) Microsoft Visual C++ Redistributable, see the related article.
  • robot_update 7.97 has been enhanced to manage the controller plug-in in a more efficient manner.
    For example, when controller 7.96 (compiled with vs2017_vcredist_x86 1.0 or vs2017_vcredist_x64 1.0) tries to load attr_publisher (compiled with Microsoft Visual C++ Redistributable for Visual Studio 2008), the controller stops responding. This happens because of the compiler incompatibility. Now, with this release of 7.97, which is dependent on vs2017_vcredist_x86 1.01 or vs2017_vcredist_x64 1.01, controller no longer loads the plugin (attr_publisher) if it is not compatible.
  • robot_update 7.97 has been updated to provide support for Amazon Linux 2.
  • hub_7.97 has been enhanced to manage the spooler plug-in in a more efficient manner.
    For example, when hub 7.96 (compiled with vs2017_vcredist_x86 1.0 and vs2017_vcredist_x64 1.0) tries to load plugin_metric (compiled with Microsoft Visual C++ Redistributable for Visual Studio 2008), the hub stops responding. This happens because of the compiler incompatibility. Now, with this release of 7.97, which is dependent on vs2017_vcredist_x86 1.01 and vs2017_vcredist_x64 1.01, hub no longer loads the plugin (plugin_metric) if it is not compatible.
Download the vs2017_vcredist_x86 1.01 and vs2017_vcredist_x64 1.01 packages from the Nimsoft web archive. These packages are required by robot_update and hub 7.97. After downloading the two packages, upgrade the primary hub robot, primary hub, secondary hub robot, secondary hub, and other robots in the domain to 7.97 by downloading the robot_update 7.97 and hub 7.97 from the Nimsoft web archive.
Upgrade UMP to UMP 9.0.2 HF2
We recommend that you upgrade to UMP 9.0.2 HF2 so that you can take advantage of the following enhancements:
  • Enable CA Business Intelligence (CABI) support for Transport Layer Security (TLS) v1.2 for Microsoft SQL Server 2012 and 2014. 
  • Provide fixes to various vulnerabilities.
  • Provide fixes to multiple defects.
Download UMP 9.0.2 HF2 from the Nimsoft web archive and follow the information in the related article.