Compatibility Matrix

Review the following topics:
apip502
Review the following topics:
Supported Browsers
Developers and API publishers need one of the following browsers to use the
API Portal
:
  • Mozilla Firefox 70 or later
  • Google Chrome 76 or later
Supported Environments
  • Docker Swarm
  • Helm v3.5
  • Kubernetes 1.20 running on:
    • GKE: Tested with best effort support
    • Other Kubernetes flavors: Theoretically supported, as yet untested
Support depends on the compatibility between Kubernetes and Helm versions.
Support for Layer7 API Management Products
This table compares the compatibility in all active releases for
API Portal
5.0.2:
Release 5.0
Notes
More Information
Layer7 API Gateway
  • 10.1
  • 10 CR1, CR2, CR3
  • 9.4
To manage API Gateway, API Gateway administrators need that same version of the Layer7 Policy Manager application.
Layer7 API Management OAuth Toolkit (OTK)
  • 4.4.1
  • 4.3.1
  • 4.2
For hybrid deployments, ensure that the Layer7 API Gateway has OAuth Toolkit (OTK) 4.2 or higher installed on it.
API Portal integration with a Cassandra database requires OTK 4.3 or higher.
Supported Identity Providers
Administrators can now configure, and authenticate Portal users using the following Identity Providers:
  • Lightweight Directory Access Protocol (LDAP)
  • SAML Single Sign On (SAML SSO)
  • CA Single Sign-On
The configured authentication types are available concurrently from the Layer7 API Portal. For information about how to configure the Identity Providers, see Configure Authentication Schemes.
Supported Platform for On-Premise Deployments
For more information about software and hardware requirements for on-premise deployments, see Hardware and Software Requirements.
Supported Databases
You can use the following external databases with API Portal:
Database
Version
MySQL
5.7, 8.0.22 (Portal 5.0 CR 1 or newer is required)
Supported Integration Bundle Software
The following version of the Portal Integration bundle should be installed to leverage and optimize the latest automatic deployments for APIs and Application API Keys:
  • UTC.20210430.1200.00
How To Tell If You Have the Latest Integration Bundle Installed
You can determine the version of the installed bundle by accessing the Gateway Policy Manager and looking up the 'portal.bundle.version' cluster property. The property should have a value of 'UTC.20210430.1200.00' or higher.