Compatibility Matrix

Review the following topics:
apip50
Review the following topics:
Supported Browsers
Developers and API publishers need one of the following browsers to use the
API Portal
:
  • Mozilla Firefox 70 or later
  • Google Chrome 76 or later
Supported Environments
  • Docker Swarm
  • Helm v3.1+
  • Kubernetes 1.17+ running on:
    • OpenShift: Full support
    • GKE: Tested with best effort support
    • Other Kubernetes flavors: Theoretically supported, as yet untested
Support for Layer7 API Management Products
This table compares the compatibility in all active releases for
API Portal
5.0:
Release 5.0
Notes
More Information
Layer7 API Gateway
  • 10.1
  • 10 CR1, CR2
  • 9.4
  • 9.3
  • 9.2 (limited compatibility - some features may not work as expected)
To manage API Gateway, API Gateway administrators need that same version of the Layer7 Policy Manager application.
Layer7 API Management OAuth Toolkit (OTK)
  • 4.4.1
  • 4.3.1
  • 4.2
  • 4.1
For hybrid deployments, ensure that the Layer7 API Gateway has OAuth Toolkit (OTK) 4.1 or higher installed on it.
API Portal integration with a Cassandra database requires OTK 4.3 or higher.
Supported Identity Providers
Administrators can now configure, and authenticate Portal users using the following Identity Providers:
  • Lightweight Directory Access Protocol (LDAP)
  • SAML Single Sign On (SAML SSO)
  • CA Single Sign-On
The configured authentication types are available concurrently from the Layer7 API Portal. For information about how to configure the Identity Providers, see Configure Authentication Schemes.
Supported Platform for On-Premise Deployments
For more information about software and hardware requirements for on-premise deployments, see Hardware and Software Requirements.
Supported Databases
You can use the following external databases with API Portal:
Database
Version
MySQL
5.7, 8.0.22 (Portal 5.0 CR 1 is required)