Compatibility Matrix

Review the following topics:
Review the following topics:
Supported Browsers
Developers and API publishers need one of the following browsers to use the
API Portal
:
  • Mozilla Firefox 70 or later
  • Google Chrome 76 or later
Support for Layer7 API Management Products
This table compares the compatibility of the SaaS deployment of Layer7 API Developer Portal with Layer7 API Management products.
APIM Product
Supported Versions
Notes
Layer7 API Gateway
  • 10.1
  • 10.0
  • 9.4
API Portal
requires Layer7 API Gateway version 9.4 or higher.
To manage API Gateway, API Gateway administrators need that same version of the Layer7 Policy Manager application.
Current Layer7 API Gateway SaaS deployments using Gateway version 9.2 will continue to be supported with a limited feature set until its scheduled end-of-service (October 2, 2021).
Layer7 API Management OAuth Toolkit (OTK)
  • 4.4.1
  • 4.3.1
  • 4.2
For hybrid deployments, ensure that the Layer7 API Gateway has OAuth Toolkit (OTK) 4.2 or higher installed on it.
API Portal integration with a Cassandra database requires OTK 4.3 or higher.
Supported Identity Providers
Administrators can now configure, and authenticate Portal users using the following Identity Providers:
  • Lightweight Directory Access Protocol (LDAP)
  • SAML Single Sign On (SAML SSO)
  • CA Single Sign-On
The configured authentication types are available concurrently from the Layer7 API Portal. For information about how to configure the Identity Providers, see Configure Authentication Schemes.
Supported Integration Bundle Software
The following version of the Portal Integration bundle should be installed to leverage and optimize the latest automatic deployments for APIs and Application API Keys:
  • UTC.20210430.1200.00
How To Tell If You Have the Latest Integration Bundle Installed
You can determine the version of the installed bundle by accessing the Gateway Policy Manager and looking up the 'portal.bundle.version' cluster property. The property should have a value of 'UTC.20210430.1200.00' or higher.