Upgrade the Gateway

Upgrades to the gateway are made available in accordance to your service agreement.
gateway10
Upgrades to the
Layer7 API Gateway
are made available in accordance to your service agreement.
This section describes how to upgrade a standalone Gateway or a cluster of Gateways. It is strongly recommended that you perform the upgrades across a secure network.
Upgrading Virtual or Hardware Appliance Form Factors to API Gateway Version 10.0
For the virtual or hardware appliance form factors of the API Gateway, version 10.0 of the Gateway must run on CentOS 7.x.
You cannot use the standard upgrade procedure (platform patches) to upgrade virtual or hardware appliance form factors from Gateway version 9.4 to Gateway 10.x. Only software Gateway customers can upgrade to version 10.0 via the standard patching process.
To get to Gateway version 10.0, use the Manual Expedited Upgrade Procedure or the Automated Expedited Upgrade Procedure.
The Automated Expedited Upgrade procedure is designed to make upgrading multiple Gateway clusters easier. It is only supported for upgrading Gateway 9.4 to Gateway 10.0 and requires Ansible, an open-source tool.
If your
Layer7 API Gateway
includes any custom assertions, please verify with Support prior to upgrading that you are running the most recent version and that your particular custom assertion will not cause issues during the upgrade.
Choose the type of Gateway being upgraded: