Upgrade the Gateway

Upgrades to the gateway are made available in accordance to your service agreement.
gateway10
Upgrades to the
Layer7 API Gateway
are made available in accordance to your service agreement.
This section describes how to upgrade a standalone Gateway or a cluster of Gateways. It is strongly recommended that you perform the upgrades across a secure network.
Upgrading Virtual or Hardware Appliance Form Factors to API Gateway Version 10.x
For the virtual or hardware appliance form factors of the
Layer7 API Gateway
, version 10.x of the Gateway must run on CentOS 7.x.
You cannot use the Standard Upgrade Procedure (platform patches) to upgrade virtual or hardware appliance form factors from Gateway version 9.x to Gateway 10.x. Only software Gateway customers or Appliance Gateway customers already running on 10.0 or higher can can upgrade to 10.x via the standard patching process.
If you are running version 9.x of the Gateway (platform is RHEL/CentOS 6.x): To get to Gateway version 10.x, use the Manual Expedited Upgrade Procedure or the Automated Expedited Upgrade Procedure.
The Automated Expedited Upgrade procedure is designed to make upgrading multiple Gateway clusters easier. It is only supported for upgrading Gateway 9.4 to Gateway 10.x and requires Ansible, an open-source tool.
Current GW Release and Platform (Starting Point)
Upgrade Method
Appliance Gateway version 10.0; CentOS 7.x
Software Gateway version 9.x or 10.0; RHEL/CentOS 5.10, 6.x, or 7.x
Appliance Gateway version 9.x; RHEL/CentOS 6.x
Appliance Gateway version 9.4; RHEL/CentOS 6.x
If your
Layer7 API Gateway
includes any custom assertions, please verify with Support prior to upgrading that you are running the most recent version and that your particular custom assertion will not cause issues during the upgrade.
Choose the type of Gateway being upgraded:
Upgrading Your Gateway with Solution Toolkits and Add-Ons
If you have any solution toolkits or add-ons installed on your current Gateway solution, ensure that the latest acceptable version is installed prior to upgrading to the latest version of the Gateway as indicated in the Compatibility Matrix. For example, if you have PAPIM running, and are currently using Gateway version 9.4, ensure that PAPIM version 3.4.41 is installed.
After upgrading the Gateway to the target (newer) version, follow the Compatibility Matrix to ensure that the correct versions of those toolkits or add-ons are installed for the target version of the Gateway. Using the PAPIM example again, if you have upgraded to Gateway version 10.1, install PAPIM version 3.4.64 OR 3.4.93, which are compatible with Gateway version 10.1.
For more upgrade information on individual Gateway solution kits and add-ons, see the following resources: