Software Gateway Specifications

Minimum requirements for a host machine running the Software form factor of the gateway:
gateway10
Minimum requirements for a host machine running the Software form factor of the
Layer7 API Gateway
:
Requirement
Minimum
Networking
one IPv4 or IPv6 interface
Processor
Dual core processor, 2 GHz or faster
Memory
4 GB (8 GB or above recommended)
Operating System
Dedicated server running one of:
  • Red Hat Enterprise Linux (RHEL) 7.x, 8
  • CentOS 7.x
Support for Cloud Environments:
Broadcom Layer7 has not formally tested Software Gateway deployment in cloud environments. Broadcom is fully committed to ensuring that the Software form factor runs on all supported operating systems, regardless of where those operating systems are located. Issues that arise between that operating system and the cloud environment should be directed to the operating system vendor or cloud environment owners.
Java
  • AdoptOpenJDK 11.0.11+b9
Database
MySQL 8.0, with root user and password
  • minimum 500 MB for tablespace (1 - 10 GB recommended)
  • INNODB table handler required
Support for non-English characters:
If non-English characters will be used in the Policy Manager (connected to a Software Gateway), configure the MySQL server to use "character-set-server=utf8" in the MySQL server configuration file.
Layer7 API Management OAuth Toolkit (OTK)
OTK 4.4
Optional Software
The following software is recommended:
  • SNMP installed and configured
  • NTP daemon installed and configured, for time synchronization
The
Layer7 API Gateway
offers the option to run with an embedded database that offers slightly reduced functionality, but with advantage of not requiring MySQL to be present.
nCipher nShield Connect
This optional HSM add-on is available for the Software Gateway. To learn how you may integrate your Software Gateway with the Connect HSM, including prerequisites, see Configure nShield Connect for the Software Gateway.
For the release of Gateway version 10.1, nShield Connect users MUST have nShield version 12.70.4 installed. To learn how, see Upgrading the nShield Client for the Software Gateway.
The Software Gateway was tested against the nShield Connect HSM device with the following specifications:
  • HSM Firmware Version 12.50.11
  • nFast Client Software Version 12.70.4