List of Update Files

This section lists the files that are required to upgrade your gateway to Release 9.2. These instructions apply to both Software and Appliance Gateway form factors (Hardware and Virtual). 
gateway92
This section lists the files that are required to upgrade your
Layer7 API Gateway
to Release 9.2. These instructions apply to both Software and Appliance Gateway form factors (Hardware and Virtual). 
For detailed instructions on upgrading your
Layer7 API Gateway
, see Upgrade a Software Gateway.
 
There is an accelerated upgrade process for the Virtual Appliance form factor of the
Layer7 API Gateway
. For more information, see Expedited Appliance Upgrade. Note that this process cannot be used on Hardware Appliance or Software Gateways
The update files are contained in image files from the distribution archives. For more information, see "Distribution Archive Files" in Release Notes 9.3.
Contents:
Background
The
Layer7 API Gateway
is designed around two major components: Platform and Application.
  • The
    Platform
    consists of the server that runs the API Gateway appliance and the dependency applications and tools that are located on it. This includes (but not limited to) the Linux kernel, OpenSSL, and MySQL.
  • The
    Application
    is the Java component of the API Gateway. The Application comprises the Oracle Java JDK and the Java programs that comprise the API Management suite.
These two components are designed to be updated separately, allowing systems administrators to upgrade the Platform without upgrading the Application. This ensures that the
Layer7 API Gateway
remains compliant with security protocols and is protected against common threats. A
Layer7 API Gateway
upgrade involves upgrading both the Platform and Application.
Platform Updates
Platform updates are required for Hardware Appliances and Virtual Appliances. They are not required for Software Gateways. (The expectation is that the host computer on which the Gateway is installed is updated according to best practices.)
: Prior to upgrading Gateway, you will need to install the kernel patch, CA_API_PlatformUpdate_64bit_vKernel-2018-10-05.L7P. The patch installation is a one-time requirement for each Gateway upgrade attempt. An upgrade attempt consists of the installation of one or more platform upgrade patches and ends with the installation of a single Gateway upgrade patch.
Install all updates in the order listed. Omitting an update may result in unexpected errors in the Gateway.
For Hardware Appliance Gateways, always install the "RHEL" patches. For Virtual Appliance Gateways, use the patch appropriate for the operating system (as listed in the Gateway Main Menu (Appliance)).
If upgrading from...
Install these updates...
From this image...
9.1.0
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-CentOS.L7
GEN12153748E.zip
GEN12153402E.zip
9.0.0
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
GEN06140236E.zip
GEN12153748E.zip
8.4.02
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
GEN06140236E.zip
GEN12153748E.zip
8.4.01
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
GEN06140236E.zip
GEN12153748E.zip
8.4.00
Layer7_PlatformUpdate_64bit_v9.0.00.L7P
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
DVD11144421E.zip
GEN06140236E.zip
GEN12153748E.zip
8.3.01
Layer7_PlatformUpdate_64bit_v8.4.01.L7P
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
DVD02111831E.ISO
GEN06140236E.zip
GEN12153748E.zip
8.3.00
Layer7_PlatformUpdate_64bit_v8.4.00.L7P
Layer7_PlatformUpdate_64bit_v9.0.00.L7P
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
DVD06165653E.ISO
DVD11144421E.zip
GEN06140236E.zip
GEN12153748E.zip
8.2.00
Layer7_PlatformUpdate_64bit_v8.3.00.L7P
Layer7_PlatformUpdate_64bit_v8.4.00.L7P
Layer7_PlatformUpdate_64bit_v9.0.00.L7P
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
DVD02121541E.ISO
DVD06165653E.ISO
DVD11144421E.zip
GEN06140236E.zip
GEN12153748E.zip
8.1.0
Layer7_PlatformUpdate_64bit_v8.2.00.L7P
Layer7_PlatformUpdate_64bit_v8.3.00.L7P
Layer7_PlatformUpdate_64bit_v8.4.00.L7P
Layer7_PlatformUpdate_64bit_v9.0.00.L7P
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
DVD09131550E.ISO
DVD02121541E.ISO
DVD06165653E.ISO
DVD11144421E.zip
GEN06140236E.zip
GEN12153748E.zip
8.0.0
Layer7_UpdateTrustStore.L7P
Layer7_PlatformUpdate_64bit_v8.1.0.L7P
Layer7_PlatformUpdate_64bit_v8.2.00.L7P
Layer7_PlatformUpdate_64bit_v8.3.00.L7P
Layer7_PlatformUpdate_64bit_v8.4.00.L7P
Layer7_PlatformUpdate_64bit_v9.0.00.L7P
Layer7_PlatformUpdate_64bit_v9.1.00.L7P
CA_API_PlatformUpdate_64bit_v9.2.00-RHEL.L7P
DVD01155803E.iso
DVD01155803E.iso
DVD09131550E.ISO
DVD02121541E.ISO
DVD06165653E.ISO
DVD11144421E.zip
GEN06140236E.zip
GEN12153748E.zip
Application Updates for Appliance
If you have an Appliance Gateway (either hardware or virtual), use the following update files:
CA_API_Gateway_v9.2.00.L7PCA_SSO_SDK_v12.52.L7P
These files are located in the
GEN12153748E.zip
 archive and must be installed after the platform upgrades.
The "CA_SSO_SDK" patch is required only if your Gateway communicates with the CA Single Sign-On product. This patch must be installed after the main "CA_API_Gateway" patch.
Application Update for Software
If you have a Software Gateway, use the appropriate update files based on your host operating system:
  • For RHEL/CentOS/SUSE Linux:
    • CA_API_Gateway_v9.2.00.L7P
    • CA_SSO_SDK_v12.52.L7P
      (required only if your Gateway communicates with the CA Single Sign-On product; install after 
      CA_API_Gateway_v9.2.00.L7P
      )
  • For Solaris:
    L7TECHssg-9.2.00-6904.pkg
These files are located in the
GEN12152555E.zip
archive.
CA Single Sign-On Users, note the following:
  • If the CA Single Sign-On SDK v12.51 already exists on the Gateway, applying the "CA_SSO_SDK" patch updates the SDK to v12.52 (for both Software and Appliance Gateways).
  • If the CA Single Sign-On SDK v12.51
    does not already exist
    on the Gateway, applying the "CA_SSO_SDK" patch does
    not
    install the v12.52 SDK. If you need this SDK, see Install the CA Single Sign-On SDK for Software Gateways to install it manually.