Requirements and Compatibility

This topic describes the supported versions of various technologies by the gateway.
gateway92
This topic describes the supported versions of various technologies by the
Layer7 API Gateway
.
2
Platforms
Layer7 API Gateway
Platform
Supported Versions
Hardware Appliance Gateway
RHEL 6.x
Virtual Appliance Gateway
RHEL 6.x
CentOS 6.x
Software Gateway
Policy Manager and XML VPN Client
To minimize security risks, install the Policy Manager software on a dedicated workstation.
Platform
Supported Versions
Windows
Supported: Windows XP, 7, 8, 10, Windows Server 2003 2008
Tested: Windows XP, 7, 10, Windows Server 2003, 2008
Linux
Fedora Core 10 through 15
Red Hat Enterprise Linux 5, 6
Ubuntu 11
SuSE 10
Virtualization
Virtual Platform
Supported Versions
VMware Workstation
8, 9, 10
VMware ESXi/VSphere
5.x, 6.0
Hardware Security Modules (HSM)
Supported hardware security modules:
  • Thales nShield Solo+ (nCipher)
  • Thales nShield Connect 
  • SafeNet Luna SA Network HSM v5.4.1
Policy Manager
  • A machine running one of the supported platforms for the Policy Manager listed above
    • Dedicated workstation recommended, to minimize security risks
    • When running the Policy Manager on Linux or Solaris, a Java 8 JDK must be properly installed and the JAVA_HOME environment set to the JDK installation directory path
    • When running the Policy Manager on Linux, a modern file system such as ext2/ext3 that supports full Linux file semantics instead of a FAT32/NTFS partition. The FAT32/NTFS partition does not allow uid, gid, and symlinks
  • Java version 1.8
  • Network access to one or more Gateways with a valid HTTP URI, through port 8443.
  • If running browser client version: ensure Java 8 Update 102 or higher is installed, with a supported Web browser
A known issue exists when running Policy Manager on high-resolution displays with Windows 10. See Start the Policy Manager.
Web Browsers
Browser
Supported Versions
Internet Explorer
Tested against latest versions
Firefox
Tested against latest versions
Firefox is usable only in Java Web Start mode. This browser no longer supports the older browser client technology involving the Java applet. For more information, see Start the Policy Manager.
Chrome
Not supported
Other browsers may work, but CA Technologies cannot not ensure performance, security, and compatibility if used.
Other CA API Management Products
The following product versions work together. Be sure your product versions are matched to a specific set.
Product
Supported Version Set #1
Supported Version Set #2
CA API Management OAuth Toolkit
3.6
4.0, 4.1*
CA Mobile API Gateway
3.3
4.0
Mobile SDK for CA Mobile API Gateway
1.7, 1.6, 1.3
1.7, 1.6, 1.5, 1.4
Mobile Developer Console
<not compatible>
1.0
CA Mobile API Gateway: Samsung SDS Nexsign Integration
<not compatible>
1.0
* OTK 4.1 requires a compatibility patch to work with MAG 4.0
(1) All minor versions (CRs) are supported as part of the major releases. (2) Cassandra 3x is not supported in
API Gateway
v9.1.x.
Identity Providers
Identity Provider
Supported Versions
CA Single Sign-On (formerly "CA SiteMinder")
12sp3, 12.51, 12.52
Sun JSAM (replaced by OpenSSO)
7.1
IBM Tivoli Access Manager (TAM)
6
Microsoft Active Directory (MSAD)
2008 R2
OpenLDAP
2.3, 2.4
Oracle Access Manager (OAM)
10g, 11g
Message Queuing Products
MQ Product
Supported Versions
IBM MQ Series
Supported: 7.0, 7.1, 7.1.01, 8.0
Tested: 7.0, 7.1, 8.0.0.5*
*
Note:
Version 8.0.0.5 is tested and supported for MQ Native Queue only.
TIBCO EMS
4.4.1, 6.1.0
WebLogic JMS
11g, 12c
Apache ActiveMQ
Supported: 5.3.2, 5.15.0
Tested: 5.15.0
FTP/SFTP
Product
Supported Versions
vsftpd
2.0.5
Squid
3.0.15
Antivirus (ICAP) Products
Product
Supported Versions
Sophos Antivirus
7.5.3
Symantec Antivirus Scan Engine
5.2
McAfee Web Security
7
UDDI Registry Products
Product
Supported Versions
Centrasite Active SOA
8.0, 8.1, 8.2
Centrasite UDDI
7.1 (Governance)
3.1.5 (Enterprise)
Systinet UDDI
6.5
Databases (JDBC Connector Only)
While the Data Direct driver claims support for a list of databases, the 
Layer7 API Gateway
is actively tested on a small subset of that list.  Support for issues may involve additional support from Data Direct.
Product
Supported Versions
MS SQL Server
Supported: 2000 and higher
Tested: 2008
IBM DB2
Supported: 8.x, 9.1, 9.5, 9.7
Tested: 9.7
MySQL
Supported: Community or Standard Edition 5.0 and higher
Tested: Standard Edition 5.5
Oracle
Supported: 
  • 8i R3 and higher
  • 9i R1 and higher
  • 10g R1 and higher
  • 11g R1 and higher
  • 12c R1 and higher
Tested: 11.2, 12c
Datastores (non-SQL Based)
Product
Supported Versions
Cassandra
Supported: 2.1.2, 3.0.0, 3.9.0
Tested: 3.9.0 
Miscellaneous/Other Products
Product
Supported Versions
Actional Server
8.0, 8.1
Apache Webserver
2.0.52
CA WSDM
3.5
EJBCA
4
1.4
JSON Schema
MS Exchange Server
2010
Open SSO
8
Radius
2.1.7, 2.1.12
Syslog
2.05, 7.4.7
Swagger
2.0