Expedited Appliance Upgrade

This topic describes how to perform an expedited upgrade of a gateway Virtual Appliance, from versions as old as v7.1 to the current version. This expedited upgrade reduces the number steps that are required when upgrading an old Gateway.
gateway92
This topic describes how to perform an expedited upgrade of a
CA API Gateway
 Virtual Appliance, from versions as old as v7.1 to the current version. This expedited upgrade reduces the number steps that are required when upgrading an old Gateway.
This expedited upgrade procedure should be performed only by system administrators or advanced technical users.
For normal upgrades to the next release, follow the standard upgrade process. Gateways not in the virtual appliance form factor can
only
be upgraded using the standard process.
Choose the upgrade scenario that matches your environment:
Frequently Asked Questions
Question
Answer
Why use this upgrade instead of the standard process?
The standard upgrade requires installing platform upgrade patches for each release. When jumping several releases, this can be time consuming. This "expedited" process basically involves creating a new Gateway and then moving your database. It bypasses all the platform upgrades and preserves your database.
Can I use the expedited upgrade all the time?
You can theoretically use it all the time, even to jump a single version. However in this case, installing a couple of patch files may be more expedient than creating a new instance of the Gateway.
Also note the expedited upgrade works only with virtual appliances. Gateways in
any
other form factor (hardware appliances, software Gateways, etc.) must be updated using the standard upgrade process.
What happens to my audit data during the upgrade?
The expedited process discards audit data older than 7 days. If you want to retain all your audit data, either export them first or use the standard upgrade procedure instead.
Can the Gateway keep running while the upgrade occurs?
No. The Gateway must be stopped while the upgrade occurs.
I am getting a "No upgrade path" error.
Refer to this article in CA Support:
"Gateway database upgrade from version 7.1.2 to 8.0.0 or later fails: No Upgrade Path"
, at: https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec0000001297.html
After completing the steps in the Support article, try the upgrade again:
  1. Select option
    2
    (Display CA API Gateway configuration menu).
  2. Select option
    1
    (Upgrade the CA API Gateway database).
Some of my listen ports do not start
This could be caused by one of the ports having DH_ciphers enabled. Run this MySQL command (all on one line; line breaks are added here for readability):
mysql ssg -e "update connector_property set value='TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA, TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA, TLS_DHE_RSA_WITH_AES_256_CBC_SHA, TLS_RSA_WITH_AES_128_CBC_SHA' where name='cipherList'"