Enforce WS-Security Policy Compliance Assertion

 
gateway91
 
The
Enforce WS-Security Policy Compliance
assertion helps you construct a policy that is compliant with the WS-Security Policy specifications. When this assertion is present, the policy validation window warns you of any WS Security Policy errors when any of the following assertions are present in the policy:
When you download a WSDL of a policy containing the Enforce WS-Security Policy Compliance assertion, the WS-Security Policy is attached. If the original WSDL contains an attached policy, that policy is replaced by the Gateway's WS-Security Policy for the service. For more information about downloading a WSDL, see Download WSDL and Policy Documents.
The Enforce WS-Security Policy Compliance assertion supports WS-Security Policy version 1.1. For more information, refer to http://specs.xmlsoap.org/ws/2005/07/securitypolicy/ws-securitypolicy.pdf.
Using the Assertion
  • Add the assertion to the policy development window. For more information, see Add an Assertion.
The assertion is added to the policy window; no further configuration is required.