Deprecated Components and Features

This topic lists the components and features that are deprecated in this release.
cad141
This topic lists the components and features that are deprecated in this release.
DXagent:
This component is no longer shipped with the Linux and Windows installer. The component is now embedded with the CA DIrectory installers.
Minimum-Authentication (min-auth):
The 'min-auth' parameter available in the dsa settings is deprecated.  "Authentication Level" parameter must be used instead. The "Authentication Level" parameter is available in the Ext. Knowledge section of a dsa. In Authentication levels, minimum setting is considered as min-auth.
Perform either of the following steps to set the "Authentication levels" of a DSA correctly:
Authentication Levels
Minimum- Authentication Levels
Upgrade Scenario
Resolution
Anonymous
None
No errors are displayed during upgrade.
No changes are needed.
Anonymous
Clear Password, SSL
Example:
When you upgrade from any previous version of CA Directory to 14.1, the
DXserver stops and displays an error message.
The security level of "Minimum- Authentication" is greater than "Authentication Levels", so set the "Minimum-Authentication" to none and set the respective "Authentication Levels".
Clear Password
SSL
Example:
When you upgrade from any previous version of CA Directory to 14.1, the
DXserver stops and displays an error message.
The security level of "Minimum- Authentication" is greater than "Authentication Levels", so set the "Minimum-Authentication" to none and set the respective "Authentication Levels".
Clear Password, SSL
None
Example:
When you upgrade from any previous version of CA Directory to 14.1, the
upgrade continues without any errors.
No changes are needed.
Once the "Minimum-Authentication" change is submitted in the Management UI, this field gets invisible. This change may impact existing access controls.