Connectors and Endpoint Types

This article covers the connector matrix for endpoints that are supported by CA Identity Manager and CA Identity Governance.
cim143
This article covers the connector matrix for endpoints that are supported by CA Identity Manager and CA Identity Governance.
2
Supported Connector Servers
The software prerequisites for installing Java Connector Server (CA IAM CS) and C++ Connector Server (CCS) are as follows:
Operating System
Release
CA IAM CS
CCS
Version / Level
Microsoft Windows
2012, 2012 R2, 2016, 2019
Yes
Yes
  • 64-bit support for CA IAM CS
  • 32-bit support on 64-bit machines for CCS
  • Support for Standard Edition and Enterprise Edition
  • Latest SP assumed
Red Hat Linux
6.x, 7.x
Yes
No
64-bit support only
Supported Connector Xpress Platforms
The software prerequisites for installing Connector XPress are as follows:
Operating System
Release
Version / Level
Microsoft Windows
8, 10
  • 64-bit (Latest SP assumed)
  • Enterprise Edition
Microsoft Windows Server
2012, 2012 R2, 2016, 2019
  • 64-bit (Latest SP assumed
  • Support for Standard Edition and Essentials Edition
Certified Connector Xpress Endpoint Types
Connector Xpress allows creation of dynamic connectors using Connector Xpress for RDBMS (JDBC) wizard or LDAP (JNDI) wizard to manage rows in arbitrary database tables or LDAP repositories.
Connector Xpress also allows creation of custom SCIM connector endpoint type using the Layer7 Plugin.
The endpoints that are certified with Connector Xpress are tabulated below.
Notes:
  • To understand what
    Shallow
    and
    Deep
    means, see Shallow and Deep Use Cases.
  • The .x in the release numbers denote the actively supported releases.
Endpoint
Endpoint Release
Supported by IM
Supported by IG
IG Mapping (Shallow/Deep)
Connector Server Platform
Agent Less Communication between IM and Endpoint
Comments
CA Directory
14.0, 14.1
Yes
Yes
Shallow
CA IAM CS
Yes
LDAP
Directory Server Enterprise Edition (DSEE)
6.3, 7.x
Yes
Yes
Shallow
CA IAM CS
Yes
LDAP
IBM DB2
11.1
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
IBM DB2 for z/OS
12.1.0
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
IBM DB2 for iSeries/400
7.x
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
Informix
11.x
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
Microsoft Active Directory Lightweight Directory Services
2012, 2012R2, 2016, 2019
Yes
Yes
Shallow
CA IAM CS
Yes
LDAP
Microsoft SQL Server
2012, 2014, 2016, 2017
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
MySQL Enterprise Server
5.x
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
Novell eDirectory
8.8.x
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
LDAP
Open LDAP
2.4
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
LDAP
Oracle Internet Directory
10g, 11g
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
LDAP
Oracle Server
12c, 12c R2, 18c, 19c
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
12c, 18c and 19c include Container DB
Oracle Unified Directory
12.x
Yes
No   
No
CA IAM CS
Yes
LDAP
Postgres
9.3 Onwards
Yes
Yes
Shallow
CA IAM CS
Yes
RDBMS
Red Hat Directory Server
10.x
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
LDAP
System for Cross-Domain Identity Manager Outbound Connector (SCIM)
1.1
2.0 -From IM 14.3 CP2 onwards
Yes
No
NA
CA IAM CS
Yes
SCIM
Sun One Directory
6.3, 7.x
Yes
Yes
Shallow
CA IAM CS
Yes
LDAP
Sybase Adaptive Enterprise Server
v15.01
Yes
Yes
Shallow and Deep
CA IAM CS
Yes
RDBMS
Supported Connector Endpoint Types
The following matrix lists the connectors for endpoints that are supported by CA Identity Manager and CA Identity Governance.
Notes:
  • To understand what
    Shallow
    and
    Deep
    means, see Shallow and Deep Use Cases.
  • The .x in the release numbers denote the actively supported releases.
Endpoint
Endpoint Release
Supported by IM
Supported by IG using IM Integration
Supported by IG using Standalone CA IAM CS
Comments
IG Mapping (Shallow /Deep)
Connector Server Platform
Agent Less Communication between IM and Endpoint
Amazon Web Services
NA
Yes
Yes
Yes
Integration using the "AWS Identity and Access Management Query API" Version 2010-05-08
Shallow
CA IAM CS
Yes
Azure
(REST Based)
NA
Yes
Yes
Yes
-
Shallow
CA IAM CS
Yes
Azure (CA API Gateway Based)
SSG 8.x
Yes
Yes
No
-
Shallow
CA IAM CS
Yes
Box
(REST Based)
NA
Yes
Yes
No
-
Shallow
CA IAM CS
Yes
Box
(CA API Gateway Based)
SSG 8.x
Yes
No
No
-
NA
CA IAM CS
Yes
CA Privileged Access Manager
2.8, 2.8.1, 3.0.x, 3.1.x, 3.2.x, 3.3
Yes
Yes
Yes
-
Shallow
CA IAM CS
Yes
CA Privileged Access Manager Server Control
14.1
Yes
Yes
No
-
Shallow
CCS
Yes
CA Privileged Identity Manager
12.6 SPx, 12.8 SPx
Yes
Yes
No
CA PIM r12.7 and r12.9 support r12.6 SPx and r12.8 SPx endpoints respectively.
Shallow
CCS
Yes
CA Strong Authentication
6.2.x, 7.1.x, 8.x
Yes
Yes
Yes
* Arcot Platform 1.0.8.3 (or higher) is required.
* Minimum of 6.2.2 version is required.
* RegFort 5.8.1 is also supported if UDS is shared with Webfort.
Shallow
CA IAM CS
Yes
CA-ACF2
15, 15.1
Yes
Yes
No
Requires CA LDAP Server for z/OS r15 or r15.1.
Shallow
IMPS
No
CA ACF2 (v2)
15.1, 16
Yes
No
No
Requires CA LDAP Server for z/OS r15 or r15.1 or 16
NA
CA IAM CS
No
CA ACF2 ACFESAGE
15, 16
No
No
Yes
* Requires ACFESAGE utility (contact CA mainframe support) to extract data from mainframe system.
* Version PTF - R034346 of the ACFESAGE utility has been certified.
Shallow and Deep
NA
-
CA-Top Secret
15, 15.1
Yes
Yes
No
Requires CA LDAP Server for z/OS r15 or r15.1.
Shallow
IMPS
No
CA-Top Secret (v2)
15.1, 16
Yes
Yes
Yes
Requires CA LDAP Server for z/OS r15 or r15.1.
Shallow
CA IAM CS
No
CA-Top Secret TSSCFILE
15
No
No
Yes
* Requires TSSCFILE utility (contact CA mainframe support) to extract data from the mainframe system.
* r15 version of the TSSCFILE utility has been certified.
Shallow and Deep
NA
-
Flat file (CSV)
NA
Yes
Yes
No
Supports Pentaho Data Integration (Kettle) API version 4.4.0.
Shallow
CA IAM CS
Yes
G Suite
(REST Based)
NA
Yes
Yes
No
-
Shallow
CA IAM CS
Yes
Google Apps
(CA API Gateway Based)
SSG 8.x
Yes
Yes
No
Integration using the 'Google Apps Admin SDK Directory API".
Shallow
CA IAM CS
Yes
HP-UX (v2)
11i v3
Yes
Yes
Yes
It is also available as a remote component utilizing ssh.
Shallow
CA IAM CS
Yes
IBM AIX (v2)
7.1, 7.2
Yes
Yes
Yes
It is also available as a remote component utilizing ssh.
Shallow
CA IAM CS
Yes
IBM DB2 UDB
11.1
Yes
No
No
See note 1 and 2
NA
CCS
Yes
IBM DB2 z/OS
12.1.0
Yes
Yes
Yes
See note 1 and 2
Shallow
CCS
Yes
IBM i5/OS (AKA OS/400)
7.x
Yes
Yes
Yes
-
Shallow
CA IAM CS
Yes
IBM Lotus Notes Domino Server
8.x.x, 9.x
Yes
Yes
Yes
* Domino Server supported on Windows, AIX and Linux.
* Supports Lotus Domino server 8.5 and later with ID VAULT feature enabled.
Shallow
CA IAM CS
Yes
IBM RACF - Security Server for z/OS
2.1, 2.2
Yes
Yes
No
Requires CA LDAP Server for z/OS r14.1 or r15 or r15.1.
Shallow
IMPS
No
IBM RACF - Security Server for z/OS (v2)
2.1, 2.2
Yes
Yes
Yes
Requires CA LDAP Server for z/OS r14.1 or r15 or r15.1.
Shallow
CA IAM CS
No
IBM RACF IRRDBU00
2.1, 2.2
No
No
Yes
* Requires IRDBU00 utility (contact CA mainframe support) to extract data from the mainframe system.
* Version 1.9, 1.10 of the IRRDBU00 utility has been certified.
Shallow and Deep
NA
-
Kerberos
5.0
Yes
No
Yes
Sun Implementation on Solaris 10 only
See note 2
NA
CA IAM CS
Yes
Microsoft Active Directory
2012, 2012R2, 2016, 2019
Yes
Yes
Yes
-
Shallow
CCS
Yes
Microsoft Skype for Business Server
2015, 2019
Yes
Yes
Yes
Earlier known as Lync Server. Skype for Business Server 2015 supports Lync 2013, Skype for Business 2015 and 2016 clients.
Shallow
CCS
Yes
Microsoft Exchange
2010, 2013, 2016, 2019
Yes
Yes
Yes
* Remote agent supports 2010.
* Exchange 2010/2013/2016 agent is 64-bit only.
* Exchange Cluster (DAG) 2010 supported as Endpoint.
* Exchange connector can run in either agent or agentless mode.
Shallow
CCS
Yes
Microsoft SQL Server
2012, 2014, 2016, 2017
Yes
Yes
Yes
See note 1
Shallow
CA IAM CS
Yes
Microsoft Office 365
All Business and Enterprise plans
Yes
Yes
Yes
For the Business plans which do not have Exchange, the flag "Business Class Email Enabled" of Endpoint Screen need to be deselected.
Shallow
CA IAM CS
Yes
Microsoft Windows
8 -Enterprise Edition
Yes
No
No
Support for 64-bit Enterprise Editions
NA
CCS
No
Microsoft Windows Server
2012, 2012R2, 2016, 2019
Yes
Yes
No
-
Shallow
CCS
No
Novell SuSE Linux Enterprise Server (v2)
10.1, 11.x, 12.x
Yes
Yes
Yes
It is also available as a remote component utilizing ssh.
Shallow
CA IAM CS
Yes
Oracle E-Business Suite
12.x
Yes
Yes
No
-
Shallow
CCS
Yes
Oracle Server
12c, 12cR2, 18c, 19c
Yes
Yes
Yes
* RAC not supported.
* Oracle Server also supported dynamically via Connector Xpress.
*12c, 18c and 19c include Container DB
Shallow
CA IAM CS
Yes
Oracle Solaris (v2)
10, 11.x
Yes
Yes
Yes
Solaris 10 Zones (Whole Root and Sparse) are supported
It is also available as a remote component utilizing ssh.
Shallow
CA IAM CS
Yes
PeopleSoft HRMS
8.9, 9.1, 9.2
Yes
Yes
Yes
*PeopleTools v8.48, v8.49, v8.50
*PeopleTools v8.5x for PeopleSoft HRMS 9.1 and 9.2
Shallow and Deep
CA IAM CS
Yes
PeopleSoft Financials
9.1, 9.2
Yes
No
No
PeopleSoft Financials 9.1 and 9.2 support PeopleTools v8.55 only.
NA
CA IAM CS
Yes
Red Hat Enterprise Linux (AS, ES) (v2)
6.x, 7.x
Yes
Yes
Yes
* The equivalent versions of CentOS are supported.
* It is also available as a remote component utilizing ssh.
Shallow
CA IAM CS
Yes
RSA SecurID
7.1 SP4, 8.x
Yes
Yes (for 7.1 SP4 only)
No
* Windows 2003 SP2 and Solaris 10 support
* Red Hat Linux 5.x supported for 7.1 only
* RSA SecurID 7.1 releases prior to SP3 are no longer supported.
* Agentless and CA IAM CS for RSA SecurID 7.1
Shallow and Deep
-
-
Salesforce
40
Yes
Yes
Yes
Integration using the "Force.com Web Services API" Version 40.0
Shallow
CA IAM CS
Yes
SAP ERP (R/3)
4.6C (SP50+), 4.7 (EXT 110 - SP51+), 4.7 (EXT 200 - SP51+)
Yes
Yes
Yes
* SAP 4.6C, minimum Basis Support Package level 50
* SAP 4.7 EXT 110 & 200, minimum Basis Support Package level 51
* Supports JCO Library V3.0
Shallow
CA IAM CS
Yes
SAP NetWeaver (R/3)
2004 (Kernel 6.40), 7.0 (Kernel 7.0), 7.3 (Kernel 7.20), 7.4, 7.5
Yes
Yes
Yes
* Covers AS ABAP type servers
* ECC 5.0 (6.40) & ECC
* 6.0 (7.0) supported
Shallow
CA IAM CS
Yes
SAP NetWeaver S/4HANA
Kernel 7.5
Yes
Yes
Yes
* Covers AS ABAP type servers
* In the Identity Manager User Console, the SAP NetWeaver (R/3) endpoint type represents SAP S/4HANA endpoint.
Shallow
CA IAM CS
Yes
SAP UME
SAP NetWeaver 2004 (SPS 14+) SAP NetWeaver 7.0 (SPS 05+)
Yes
Yes
Yes
Covers AS JAVA type servers
Shallow
CA IAM CS
Yes
Siebel CRM
7.8, 8.x
Yes
No
No
Not supported on CCS running on Windows 2008/2012 due the Siebel Client support limitation
NA
CCS
Yes
System for Cross-Domain Identity Management (SCIM)
1.1
2.0 -From IM 14.3 CP2 onwards
Yes
No
No
-
NA
CA IAM CS
Yes
ServiceNow (CA API Gateway Based)
SSG 8.x
Yes
Yes
No
-
Shallow
CA IAM CS
Yes
ServiceNow (REST Based)
NA
Yes
No
No
-
NA
CA IAM CS
Yes
Zendesk (REST Based)
NA
Yes
Yes
No
-
Shallow
CA IAM CS
Yes
Zendesk (CA API Gateway Based)
SSG 8.x
Yes
No
No
-
NA
CA IAM CS
Yes
Note
Comments
1
Also available as a dynamic Connector via Connector Xpress.
2
In an Integrated deployment, this Connector supports Provisioning but not Compliance. To request Compliance support for this Connector, please raise an enhancement request via support.
Note:
For more information about connectors, see Identity Governance and Administration Connectors.